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Getting Started

The instructions are written for OpenOffice.org but should also work for LibreOffice.

Installation

In order to install odt2braille, OpenOffice.org version 3.0 or later is required. You
can find the latest version of OpenOffice.org at http://download.openoffice.org/

other.html. If you don’t have Java installed on your system (verify your Java version at
http://www.java.com/en/download/installed.jsp), make sure you include the Java
Runtime Environment (JRE) to the download. Java 6 is required. If you choose not to
download OpenOffice.org with Java you can easily install Java afterwards. You can get
the latest version from http://java.com/en/.

To add the odt2braille extension, launch OpenOffice.org and open [Tools > Extension
Manager...]. First remove any older versions of odt2braille. Then choose Add..., select the
odt2braille installation package and follow the steps. You can download the latest version
from http://odt2braille.sourceforge.net/downloads.html.

Note: Make sure the installation package is an .oxt file. It might happen that
Internet Explorer saves it as a .zip file. In this case, just rename the file back
to .oxt.

It is strongly recommended that you also download and install the Sim-
Braille font from Duxbury Systems at http://www.duxburysystems.com/

product2.asp?product=The%20Braille%20TrueType%20Fonts&level=free&action=pur".
As of version 0.0.3, odtbraille will use his own odt2braille fonts instead:
http://odt2braille.svn.sourceforge.net/viewvc/odt2braille/Odt2BrailleAddOn/

fonts/odt2braille6.ttf for 6-dot Braille and http://odt2braille.svn.sourceforge.net/
viewvc/odt2braille/Odt2BrailleAddOn/fonts/odt2braille8.ttf for 8-dot Braille.

Note: Make sure you install the fonts after the plugin has been installed. Doing
it the other way around may cause the Braille preview window to show a bunch
of meaningless squares or periods instead of Braille symbols.

Finally, when everything is installed, restart OpenOffice.org and you’re ready to go.

OpenOffice.org and LibreOffice Accessibility

OpenOffice.org and LibreOffice are poorly accessible with traditional screen readers on
Windows. Accessing these office suites with the newer screen reader NVDA (NonVi-
sual Desktop Access http://www.nvda-project.org/) appears to work better. Mac OS
users can access OpenOffice.org with VoiceOver (http://www.apple.com/accessibility/
voiceover/); Linux users can access it with Orca (http://live.gnome.org/Orca). (Some
screen readers may provide good access to the user interface but not to document content,
for example, the text alternative for an image.) However, access to OpenOffice.org or Li-
breOffice does not necessarily imply that the user interface of an extension is accessible in
the same way. The odt2braille project would greatly appreciate any feedback about the ac-
cessibility of the extension (with information on which OpenOffice.org/LibreOffice version,
which screen reader version, which operating system, etcetera you use the extension).

http://download.openoffice.org/other.html
http://download.openoffice.org/other.html
http://www.java.com/en/download/installed.jsp
http://java.com/en/
http://odt2braille.sourceforge.net/downloads.html
http://www.duxburysystems.com/product2.asp?product=The%20Braille%20TrueType%20Fonts&level=free&action=pur"
http://www.duxburysystems.com/product2.asp?product=The%20Braille%20TrueType%20Fonts&level=free&action=pur"
http://odt2braille.svn.sourceforge.net/viewvc/odt2braille/Odt2BrailleAddOn/fonts/odt2braille6.ttf
http://odt2braille.svn.sourceforge.net/viewvc/odt2braille/Odt2BrailleAddOn/fonts/odt2braille6.ttf
http://odt2braille.svn.sourceforge.net/viewvc/odt2braille/Odt2BrailleAddOn/fonts/odt2braille8.ttf
http://odt2braille.svn.sourceforge.net/viewvc/odt2braille/Odt2BrailleAddOn/fonts/odt2braille8.ttf
http://www.nvda-project.org/
http://www.apple.com/accessibility/voiceover/
http://www.apple.com/accessibility/voiceover/
http://live.gnome.org/Orca
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Introduction

This guide explains how to create a document in OpenOffice.org Writer and prepare it for
Braille production. Chapter 1 explains all you have to know to get started real quickly.
In chapter 2 you will find a more comprehensive reference. You can find more help on
working with Writer at http://wiki.services.openoffice.org/wiki/Documentation/

OOo3_User_Guides/Writer_Guide.

After installing odt2braille, a whole new range of user preferences will become available.
Because of the broad range of Braille formatting conventions in use worldwide, odt2braille
provides a lot of flexibility. Users are able to adjust the Braille layout in detail, just like
they can fully customize the print layout.

To make sure that non-technical users will not be overwhelmed with possibilities, they
have the option to choose from a series of formal Braille rules, e.g. the BANA principles
of print to Braille transcription (see http://www.brl.org/formats/). This will consid-
erably limit their freedom, but it will also greatly simplify the production of valid and
well-formatted Braille.

What follows next is a detailed overview of all possibilities odt2braille offers.

http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide
http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/Writer_Guide
http://www.brl.org/formats/
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1 Quick Guide

Quick guide
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2 Advanced Guide

2.1 Languages

OpenOffice.org

• OpenOffice.org allows you to write documents in various languages or mix multiple
languages within the same document. You can set the language for the whole document,
individual paragraphs, or even individual words and characters. The language tools
can be found in [Tools > Languages].

• Languages can be associated with Braille translation tables in [File > Braille
Settings. . . ]. The translation table for the whole document can be set with the main
language option on the General tab. A contraction level can also be chosen. If the
document contains multiple languages, each additional language can be linked to a
translation table and contraction level in the Languages tab.

• Translation tables are available for all Western European languages, Modern Hebrew,
some Asian languages and even some minority languages like Gaelic and Esperanto.

2.2 Paragraphs

OpenOffice.org

• In OpenOffice.org, all regular text between pilcrow markers is considered a paragraph
(pilcrow markers can be made visible by selecting [View > Nonprinting Characters]).

• Each paragraph has got a formatting style. Paragraph styles can be assigned and
modified in [Format > Styles and Formatting (F11)].

• All paragraphs will be transcribed as Braille paragraphs, except

− headings (Section 2.3 [Headings], page 5) ,

− captions (Section 2.8 [Captions], page 10) ,

− paragraphs inside a list (Section 2.4 [Lists], page 6) ,

− inside a table (Section 2.5 [Tables], page 7) ,

− inside a note (Section 2.9 [Notes], page 11) ,

− or on the title page (Section 2.14 [Title Page], page 15) .

Braille

• By default, paragraphs are rendered in indented paragraph style (first line cell 3,
runovers cell 1 and not separated by blank lines.

• Paragraph settings can be altered in [File > Braille Settings > Paragraphs]. You can
link each used paragraph style with a different Braille formatting style.

• Braille formatting settings for paragraphs include spacing, alignment and margins. You
can control how many lines of a paragraph must be printed at least at the bottom of a
page (Orphan control). Moreover, you can protect a paragraph from being split across
multiple pages (Don’t split), and you can keep a paragraph together with the first line
of the next (Keep with next).
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• By default, empty paragraphs are dropped in the Braille edition. By checking the
option Keep empty paragraphs, an empty paragraph is brailled as an empty line.

2.3 Headings

OpenOffice.org

• In order for a paragraph to be interpreted by odt2braille as a heading, following condi-
tions must be true:

− An outline level has to be assigned to the text. This can be achieved in two ways:

− Outline levels can be permanently linked to paragraph styles in [Tools > Out-
line Numbering ].

− If no outline level is linked to the current paragraph style, a level can still
be assigned to the text by setting Outline Level in [Format > Paragraph >

Outline & Numbering ].

By default, the paragraph styles Heading 1, Heading 2, etc. have outline levels 1,
2, etc. The navigator [View > Navigator (F5)] provides an overview of all headings
in a document and the outline levels.

− In addition, a heading should not be placed on the title page (Section 2.14 [Title
Page], page 15) or inside a list (Section 2.4 [Lists], page 6) , table (Section 2.5
[Tables], page 7) or note (Section 2.9 [Notes], page 11) .

• To enable automatic numbering or bulleting of headings, set Numbering Style [Format
> Paragraph > Outline & Numbering ] to Outline Numbering.

• The exact formatting of bullets and numbers can be determined in [Tools - Outline
Numbering ]. Alternatively, choose [Format > Bullets & Numbering ] when a heading
has the cursor.

Braille

• In Braille, headings are rendered as follows:

− Level 1 headings are centered and preceded and followed by a blank line.

− Level 2 headings are centered as well but are only preceded by a blank line.

− Level 3 headings begin in cell 5 (runovers too) and are preceded by a blank line.

− Headings with an outline level greater than 3 begin in cell 1 (runovers too) and
are preceded by a blank line.

All these settings can be altered in [File > Braille Settings > Headings].

• As with paragraphs, you can set spacing, alignment and margins, you can protect a
heading from being split across multiple pages, and you can keep a heading together
with the first line of the following heading or paragraph.

• In addition, you can make a heading start on a new page.

• Numbers of headings are completely adopted in Braille.

• Bullets inside headings are automatically removed.

• Empty headings are automatically removed.

• All special typeface (Section 2.10 [Special Typeface], page 11) in a heading is ignored.
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• Only headings inside the body of the document (not in the preliminary section) are
included in the table of contents (Section 2.17 [Table of Contents], page 17) .

• Footnotes in headings: see Section 2.9 [Notes], page 11.

• When a regular volume (Section 2.13 [Volume Management], page 14) (not a pre-
liminary or supplementary volume) doesn’t start with a heading, odt2braille inserts a
continuation heading : the closest preceding heading is repeated and suffixed with the
string "(Cont.)". This continuation heading is included in the table of contents as
well.

Tip: Always start a volume with a heading.

2.4 Lists

OpenOffice.org

• Each paragraph with a Numbering Style [Format > Paragraph > Outline & Numbering ]
that is not Outline Numbering or None, will be interpreted by odt2braille as an item
of a list.

• To produce a numbered or bulleted list in OpenOffice.org, either use the numbering
and bullets icons, or use list styles.

− The numbering and bullets icons can be found on the Formatting toolbar [View >

Toolbars > Formatting ] or the Bullets and Numbering toolbar [View > Toolbars >

Bullets and Numbering ].

− List styles can be selected in [Format > Styles and Formatting > List Styles]. When
creating a new list style, make sure the name is not of the form L1 / L2 / . . .

• The level of a list item can be modified with keyboard shortcuts (tab to move down a
level, shift + tab to move up a level) or with the Bullets and Numbering toolbar.

• The exact formatting of lists can be determined in [Format > Bullets and Numbering ].
Alternatively, if the list was created using list styles [Format > Styles and Formatting
> List Styles], right click on the list style and choose Modify.

Braille

• All Braille formatting settings for lists can be altered in [File > Braille Settings > Lists].

• By default, lists are brailled as follows:

− Level 1 list items begin in cell 1, runovers begin in cell 5.

− Level 2 list items begin in cell 3, runovers in cell 7.

− Level 3 list items begin in cell 5, runovers in cell 9.

− List items with an outline level greater than 3 begin in cell 7, runovers in cell 11.

The entire list is preceded and following by a blank line.

• Numbers of list items are completely adopted in Braille.

• The user can determine how bullets are brailled.

• List items or entire lists can be protected from being split across pages.

• Textboxes (Section 2.6 [Textboxes], page 8) and images (Section 2.7 [Images], page 9)
that are anchored to a list item are rendered only after completion of the entire list.



Chapter 2: Advanced Guide 7

2.5 Tables

OpenOffice.org

• In OpenOffice.org, tables are created with [Table > Insert > Table] or [Insert > Table]
or with the Table toolbar [View > Toolbars > Table].

• The first row(s) of a table can be defined as column headings by checking the Headings
box. Set multiple heading rows by checking Repeat headings.

• To add a caption (Section 2.8 [Captions], page 10) to the table, place the cursor inside
the table and choose [Insert > Caption]. In order for a table caption to be correctly
linked to the table, it must be placed directly beneath the table and no other frame
(i.e. textbox (Section 2.6 [Textboxes], page 8) or image (Section 2.7 [Images], page 9)
) can be anchored to it.

Braille

• In Braille, tables are by default rendered in stairstep format :

− Column 1 table cells begin in cell 1, runovers too.

− Column 2 table cells begin in cell 3, runovers too.

− . . .

− Table cells in column 10 and beyond begin in cell 19.

• However, is it also possible to render tables in linear format. In this case, all cells in a
table row are joined together. The user can choose the column delimiter symbol which
separates the cells.

• Table rows can be protected from being split across Braille pages.

• All table settings can be accessed in [File > Braille Settings > Tables].

• Only regular text is retained in a table cell, all other elements are dropped or trans-
posed. If a table cell contains multiple paragraphs, these are first serialized.

• Table lines are only shown in Braille if they are present in print. A table line is
represented by a series of unspaced Braille dots 2356 (top table line) or 1245 (bottom
table line), extended across the full width of the Braille page. A table inside a larger
textbox is enclosed by full table lines (Braille dots 123456). If no table lines are shown
in print, the table is preceded and/or followed by a blank line.

• If column headings are present, these table rows are separated from the table body by
a series of unspaced Braille dots 25, extended across the full width of the Braille page.

• If a caption (Section 2.8 [Captions], page 10) is correctly linked to the table, it is
centered and placed directly below the top table line (or top blank line if the table line
is absent). A blank line is inserted between the caption and the actual table content.

• All footnotes (Section 2.9 [Notes], page 11) are collected beneath the table body, but
above the bottom table line (or bottom blank line if the table line is absent). Footnotes
in the table caption are placed directly below the caption.

• Empty table cells are indicated with an ellipsis (Braille dots 5-5-5). This usage is
explained on the transcriber’s notes page (Section 2.16 [Transcriber’s Notes], page 17)
.
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• When a table contains other tables, lists (Section 2.4 [Lists], page 6) , textboxes (Sec-
tion 2.6 [Textboxes], page 8) or images (Section 2.7 [Images], page 9) , these elements
are moved outside the table. Every transposition is indicated by a double dash (Braille
dots 36-36-36-36) at the element’s original location. An explaining transcriber’s note
(Section 2.16 [Transcriber’s Notes], page 17) is inserted before the table. Only af-
ter completion of the entire table, all previously omitted material is rendered. Each
element is preceded by another transcriber’s note explaining it was moved from it’s
original location.

Tip: Do not place other tables, lists, textboxes or images inside a table.

• A merged table cell is processed as if its whole content were in the left- and uppermost
’sub’-cell. The other (empty) ’sub’-cells are not shown in Braille. This currently also
applies to right-to-left writing systems such as Hebrew.

Tip: Try to avoid merged cells.

2.6 Textboxes

OpenOffice.org

• In OpenOffice.org, textboxes can be produced by choosing [Insert > Frame]. Options
can be modified later in [Format > Frame/Object ]. On the Type tab, the anchor type
can be selected. The anchor is the basis of the position and behavior of the textbox
within a document. It makes the textbox move with the object it is anchored to. You
can anchor frames as a character or to a page, paragraph, or character. In addition,
if a textbox has been placed inside another textbox, it can be anchored to this outer
frame. The anchor is symbolized by a gray marker, which is only visible if the textbox
is selected.

• To add a caption (Section 2.8 [Captions], page 10) to the textbox, place the cursor
inside the textbox and choose [Insert > Caption]. In order for a caption to be correctly
linked to the textbox by odt2braille, one of the following must be true:

• The textbox is anchored to a caption.

• The paragraph immediately following the object the textbox is anchored to is a
caption, and no other frame (i.e. textbox or image (Section 2.7 [Images], page 9)
) is anchored to it.

• The last paragraph of the textbox is a caption and no other frame is anchored to
it.

A caption that has been inserted through [Insert > Caption] is automatically linked to
the textbox.

Braille

• If textboxes are anchored as a character or to a paragraph or character, they are
rendered in Braille after completion of the paragraph or heading that contains the
anchor.

• If textboxes are anchored to another textbox, they are rendered inside this outer
textbox, before any other material it contains.

• Textboxes are omitted in Braille if they are anchored to a page.
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• Textboxes that are anchored to a list item (Section 2.4 [Lists], page 6) are rendered
only after completion of the entire list.

• Textboxes that are anchored to a table cell (Section 2.5 [Tables], page 7) are rendered
only after completion of the entire table.

• Textboxes that are anchored to a note (Section 2.9 [Notes], page 11) are replaced by
a double dash (Braille dots 36-36-36-36), indicating the omission.

• Box lines are only shown in Braille if they are present in print. A box line is represented
by a series of unspaced Braille dots 2356 (top table line) or 1245 (bottom table line),
extended across the full width of the Braille page. If no box lines are shown in print,
the textbox is preceded and/or followed by a blank line.

• If a caption (Section 2.8 [Captions], page 10) is correctly linked to the textbox, it is
centered and placed directly below the top box line (or top blank line if the box line
is absent). A blank line is inserted between the caption and the actual content of the
box.

• All material inside a textbox is retained in Braille. Headings (Section 2.3 [Headings],
page 5) are included in the table of contents (Section 2.17 [Table of Contents], page 17)
.

2.7 Images

OpenOffice.org

• In OpenOffice.org, images can be inserted by choosing [Insert > Picture > From File].
Options can be modified later in [Format > Picture]. Like textboxes (Section 2.6
[Textboxes], page 8) , an image can be anchored as a character or to a page, paragraph,
character, or frame.

• To add a caption (Section 2.8 [Captions], page 10) to the image, select the image and
choose [Insert > Caption]. In order for a caption to be correctly linked to the image by
odt2braille, one of the following must be true:

• The image is anchored to a caption (Anchored to paragraph, to character or as
character).

• The paragraph immediately following the object the image is anchored to is a
caption, and no other frame (i.e. textbox (Section 2.6 [Textboxes], page 8) or
image) is anchored to it.

A caption that has been inserted through [Insert > Caption] is automatically linked to
the image.

• For each image, a title and/or description can be provided in [Format > Object >

Description]. Alternatively, the title can be set with the Alternative (Text only) field
in [Format > Picture > Options].

Tip: The image description should be as brief and concise as possible.

Note: OpenOffice 3.2 and older versions have a bug that deletes an images
text alternatives (Title and Description) if the anchor is modified or when
a caption is added. To avoid this, the text alternatives should be added
after modifying the anchor or after adding a caption.
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Braille

• In Braille, images are replaced by a transcriber’s note (Section 2.16 [Transcriber’s
Notes], page 17) , which includes

1. The image caption (Section 2.8 [Captions], page 10) (if one is correctly linked to
the image).

2. A note saying that the image is not reproduced in Braille.

3. The image title (if one is defined).

4. An alternative desciption (if one is defined).

• If images are anchored as a character or to a paragraph or character, they are rendered
in Braille after completion of the paragraph or heading that contains the anchor.

• If images are anchored to a textbox (Section 2.6 [Textboxes], page 8) , they are rendered
inside this textbox, before any other material it contains.

• Images are omitted in Braille if they are anchored to a page.

• Images that are anchored to a list item (Section 2.4 [Lists], page 6) are rendered only
after completion of the entire list.

• Images that are anchored to a table cell (Section 2.5 [Tables], page 7) are rendered
only after completion of the entire table.

• Images that are anchored to a note (Section 2.9 [Notes], page 11) are replaced by a
double dash (Braille dots 36-36-36-36), indicating the omission.

2.8 Captions

OpenOffice.org

• To add a caption to an object in OpenOffice.org, select this object and choose [Insert
> Caption]. odt2braille treats all text elements (with the exception of headings (Sec-
tion 2.3 [Headings], page 5) ), with a paragraph style [Format > Styles and Formatting
> Paragraph Styles] that is

− Caption,

− Table,

− Drawing,

− Illustration or

− Text,

as captions. You can also add your own caption style by right-clicking on one of the
above styles and choosing New.

Braille

• A caption is only rendered in Braille if odt2braille links the caption to an object.
Captions can be linked to tables (Section 2.5 [Tables], page 7) , textboxes (Section 2.6
[Textboxes], page 8) or images (Section 2.7 [Images], page 9) . For more details on the
linking of captions to objects, see the appropriate sections.

• Table captions and textbox sections are centered and placed directly below the top
table/textbox line (or top blank line if the table/textbox line is absent). A blank line



Chapter 2: Advanced Guide 11

is inserted between the caption and the actual table/textbox content. Image captions
are contained in the transcriber’s note that represents the image.

• Footnotes in captions: see Section 2.9 [Notes], page 11.

2.9 Notes

OpenOffice.org

• To insert a note in an OpenOffice.org document, put the cursor where you want the
note reference marker to appear, then select [Insert > Footnote/Endnote]. Footnotes
are displayed at the bottom of the page containing their corresponding reference. By
default, endnotes are collected at the end of the entire document. To collect endnotes at
the end of the OpenOffice.org section that contains the note reference, choose [Format >
Sections], select a section, choose [Options > Footnotes/Endnotes] and check the option
Collect at end of section. Sections can be inserted by choosing [Insert > Section].

Braille

• In Braille, note references are preceded by the unspaced reference indicator (Braille
dots 35-35) and a number indicator (in case of a number) or a letter indicator (in case
of a letter). References are separated from surrounding text by at least one blank cell.

• Footnotes and endnotes are always preceded by their corresponding reference. No blank
lines are left before, after or between notes.

• Only regular text is retained inside a note, all other elements are dropped. If the note
contains multiple paragraphs, these are first serialized. Every omission of an element is
indicated by a double dash (Braille dots 36-36-36-36) at the element’s original location.

• Footnotes begin in cell 7, runovers begin in cell 5. Footnotes in paragraphs (Sec-
tion 2.2 [Paragraphs], page 4) , headings (Section 2.3 [Headings], page 5) , captions
(Section 2.8 [Captions], page 10) and list items (Section 2.4 [Lists], page 6) are ren-
dered immediately below the paragraph, heading, caption or list item. Footnotes in
tables (Section 2.5 [Tables], page 7) are are collected beneath the table body, but
above the bottom table line (or bottom blank line if the table line is absent).

• Endnotes are collected in note sections. Each note section begins on a new page. The
fully capitalized heading ("NOTES") is centered at the top of the page and followed by
a blank line. This heading is not included in the table of contents (Section 2.17 [Table
of Contents], page 17) . Then the endnotes are listed, ordered by their appearance in
print. Each endnote begins in cell 1, runovers begin in cell 3. When the note section
is complete, subsequent text is resumed on a new page. Note sections can appear at
various places in the Braille document:

− If an endnote reference is contained in an OpenOffice.org section that has the
Collect at end of section option checked, the note is brailled accordingly at the
end of that section.

− Else, if an endnote reference is placed on the preliminary pages (Section 2.12
[Preliminary Pages], page 13) , the corresponding note is rendered at the end of
the preliminary section.

− All remaining endnotes of a volume (Section 2.13 [Volume Management], page 14)
are collected at the very end of that volume.
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2.10 Special Typeface

OpenOffice.org

• In OpenOffice.org, you can apply many formats to characters using the [Format >

Character...] window and the buttons on the Formatting toolbar ([View > Toolbars
> Formatting ]). Text can also be formatted by applying a character style ([Format >
Styles and Formatting > Character Styles]).

• The relevant options for odt2braille are Bold, Italic, Underline and (Small) Capitals.

Braille

• Braille formatting settings for characters can be altered in [File > Braille Settings >

Special Typeface]. The user can link each used character style with a different Braille
formatting style. Bold, Italic, Underline and Capitals can be turned on or off in Braille,
irrespective of how the text is actually formatted in print. By default, the print version
in followed.

• In English Braille, a single italic word is prefixed by the unspaced italic sign (Braille
dots 46). If more than three consecutive words are italicized, the first word is preceded
by the double italic sign (Braille dots 46-46), and the last word by the single italic sign.

• A single bold word is prefixed by the unspaced bold sign (Braille dots 456). If more
than three consecutive words are boldfaced, the first word is preceded by the double
bold sign (Braille dots 456-456), and the last word by the single bold sign.

• Other special typefaces like underline, small caps, etc. are not indicated in English
Braille.

• All special typeface in headings (Section 2.3 [Headings], page 5) is ignored in the
Braille edition.

• In other languages (Section 2.1 [Languages], page 4) , other rules for indicating special
typeface might apply.

2.11 Page Numbering

OpenOffice.org

• To add a page number, put the cursor where you want the number to appear, then select
[Insert > Fields > Page Number ]. If you want to number all your pages automatically,
insert a page number in the page header [Insert > Header > Default ] or page footer
[Insert > Footer > Default ].

• odt2braille will only proces the first page number in a header or footer (in that order).

Braille

• All pages of text in the Braille edition carry consecutive Braille page numbers start-
ing with arabic 1 in the first volume (or a higher value specified by the option Start
numbering at). In subsequent volumes (Section 2.13 [Volume Management], page 14)
, pages of text are numbered consecutively from volume to volume. Preliminary page
numbers are either prefixed by the unspaced letter p, or rendered in Roman numerals,
the choice is up to the user. Each preliminary section is numbered individually, start-
ing with p1 or i. By default, the Braille page number is displayed in the bottom right
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corner of the page, with no fewer than three blank cells left between the text and the
number. The user can also decide to place page numbers at the top, or not display
them at all.

• If the source document contains page numbers, they can be included in the Braille
version as well. By default, print page numbers are displayed in the top right corner
of each Braille page (except on preliminary pages (Section 2.12 [Preliminary Pages],
page 13) ), again with no fewer than three blank cells left between the text and the
number. The number can also be placed at the bottom. When print page numbers and
Braille page numbers are both placed at the top or bottom, they are rendered next to
each other, print number first, with a space in between.

• If material on a print page cannot be contained on a single Braille page and must be
continued on one or more pages, the same print page number is placed in the top right
corner of each of these pages. The number is prefixed by the unspaced letter a (brailled
without the letter indicator) for the first continued page, the letter b for the second,
etc.

• Optionally, the user can decide to display the range of print pages contained in a Braille
page (instead of only the page number of the first print page). If the first page in this
range is a continued print page, it is prefixed with a letter as usual.

• When a new print page begins within a Braille page, a page change indicator, a line of
unspaced Braille dots 36, can be produced, with or without the new print page number
placed on the same line at the right margin. No space is left between this indicator
and the first symbol of the page number.

• By default, empty pages are completely ignored. If this setting is disabled, a combined
print page number will be displayed whenever empty pages are encountered: the num-
ber of the first empty page is combined with that of the page on which text reappears,
e.g. 5-7. If lettered continuation pages are required, they carry only the number of the
page on which text reappears.

• Another option is to treat unnumbered print pages as if they were a part of the preceding
page (as if their was no page break).

• All page number settings can be found in [File > Braille Settings > Page Numbers].

2.12 Preliminary Pages

Preliminary pages are those pages that precede the actual text of the document. These
can include for example a title page, a special symbols page, a transcriber’s note page,
cover material, about the author, a dedication, acknowledgements, an abstract, a table of
contents, author’s notes, a preface, a foreword, an introduction or a prologue, etc.

OpenOffice.org

• Which content is included in the preliminary section and the order of items is totally up
to the transcriber. All preliminary content must be placed inside a level 1 section (not
nested in another section) named PreliminaryPages. In OpenOffice.org, sections can
be inserted by choosing [Insert > Section]. An overview of all sections the document
contains and there level is provided by the navigator [View > Navigator (F5)].

• If a preliminary section has been defined, the transcriber has the option to include a
list of special symbols, a transcriber’s note page and a table of contents. These options
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can be found on the General, Table of Contents and Special Symbols tabs in [File >

Braille Settings. . . ].

• Another possibility is to create a preliminary volume. This option should be checked if
more than 80-90 Braille pages are required for the preliminary pages in the first volume
to include all items (see Section 2.13 [Volume Management], page 14).

• All content before the PreliminaryPages section will be ignored.

Braille

• If a preliminary section has been defined in OpenOffice.org, every Braille volume (Sec-
tion 2.13 [Volume Management], page 14) or supplement will be preceded by a number
of preliminary pages.

• Some pages (i.e. the title page (Section 2.14 [Title Page], page 15) , the special symbols
page (Section 2.15 [List of Special Symbols], page 16) , the transcriber’s notes page
(Section 2.16 [Transcriber’s Notes], page 17) and the table of contents (Section 2.17
[Table of Contents], page 17) ) are repeated in every Braille volume. However, their
content is different for each volume. All other pages only appear in the extended pre-
liminary section. This section is either included in the preliminary volume (if present)
or in volume 1.

• The print order of items is completely adapted in Braille. The special symbols page,
transcriber’s notes page and table of contents are placed (in that order) at the very
end of the preliminary pages, before any possible note sections (Section 2.9 [Notes],
page 11) .

• Preliminary pages are distinguished from normal pages by a different page numbering
(Section 2.11 [Page Numbering], page 12) .

• The actual volume body that follows the preliminary section always starts on a new
right-hand Braille page.

2.13 Volume Management

Often, because documents are too long to be bound in one single Braille book, they are
arranged in volumes.

Tip: Typically a volume should have around 80-90 one-sided pages (the page
count includes all pages, including the preliminary pages). Ideally, the next
volume starts at a logical place, such as the beginning of a new chapter. As a
guideline, there should not be a difference of more than 15 pages between two
volumes.

Also, appendixes, glossaries, indexes, bibliographies (Section 2.18 [Bibliographies],
page 18) etc. are often more useful when bound in separate supplementary volumes
(supplements). Finally, the extended preliminary pages (Section 2.12 [Preliminary Pages],
page 13) (i.e. with all preliminary content included) are sometimes bound in a separate
preliminary volume, when the first volume would otherwise become to long.

OpenOffice.org

• OpenOffice.org, by default, puts the entire document in one single volume.
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• To create a volume manually, insert a level 1 section [Insert > Section] and name it
Volume1, Volume2, etc. It is important to arrange volumes in this order, otherwise
they will not be accepted.

• A supplementary volume can be created by inserting a section named Supplement1,
Supplement2, etc. Make sure you put supplementy volumes after the last regular
volume and in the right order, otherwise they will not be accepted.

• If no regular volumes have been defined manually, everything between the preliminary
pages (Section 2.12 [Preliminary Pages], page 13) (or beginning of the document) and
supplement 1 (or end of the document) is equal to volume 1.

• If a preliminary section is present, a preliminary volume can be created by checking
the Create preliminary volume option in [File > Braille Settings > General ].

Braille

• In Braille, every volume or supplement has its own preliminary section (if enabled by
the user). Both the preliminary section and the volume body start on a new right-hand
Braille page. If a preliminary volume is created, it contains the extended preliminary
pages (Section 2.12 [Preliminary Pages], page 13) , but no actual volume body.

• When a regular volume doesn’t start with a heading, odt2braille automatically inserts
a continuation heading (Section 2.3 [Headings], page 5) : the closest preceding heading
is repeated and suffixed with the string "(Cont.)".

2.14 Title Page

OpenOffice.org

• To create a title page, insert a section named TitlePage [Insert > Section] (this does
not have to be a level 1 section). The title page can be placed anywhere, but it is
recommended to put it at the beginning of the document. If a preliminary section
(Section 2.12 [Preliminary Pages], page 13) is present, place the title page inside of it,
so that it is repeated in each volume.

Tip: The title page should be the very first page.

• If a title page has been defined, the transcriber has the option to include a transcription
information block. Furthermore, if the title page is a preliminary page, a volume
information block can be included as well. These options can be found in [File >

Braille Settings > General ]. The Braille formatting of the blocks can be specified by
the Paragraph style fields. The name of the transcriber can be set with the Transcriber
field.

Braille

• The print order of items on the title page is adopted in Braille. The volume information
block and transcription information blocks are placed (in that order) at the very end
of the title page.

• The volume information block contains the volume identification, the total number of
volumes, the page range, etc.
Examples:
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In 9 volumes and 2 supplements

Volume 2

Braille pages p1-p16 and 1-72

Print pages 46-79

In 1 preliminary and 5 volumes

Preliminary volume

Braille pages p1-p81

• The transcription information block contains the transcriber’s name, the year of Braille
transcription, etc.
Example:

Transcribed 2010 by Bert Frees with odt2braille

2.15 List of Special Symbols

OpenOffice.org

• If a preliminary section has been defined, the transcriber has the option to include a
list of special symbols in [File > Braille Settings > Special Symbols]. He or she can also
decide which symbols will be shown, in which order, under which conditions (always,
only in the first volume, or only when actually used in the current volume), and how
they are described. The list heading can be modified as well. By default, it is set to
"SPECIAL SYMBOLS USED IN THIS VOLUME".

Braille

• A special symbols list is included in the preliminary pages (Section 2.12 [Preliminary
Pages], page 13) of each volume (Section 2.13 [Volume Management], page 14) . The
actual content varies between volumes. The special symbols list begins on a new Braille
page. The heading is centered at the top of the page. It is not included in the table of
contents (Section 2.17 [Table of Contents], page 17) .

• After a blank line, the list follows. Each Braille symbol begins in cell 1 and is followed,
after one blank cell, by its identifying dot numbers, enclosed in parentheses, and its
description. Runovers begin in cell 3. These are the symbols that are listed by default:

− (56) Letter indicator ,

− (3456) Number indicator ,

− (35, 35) Note reference indicator ,

− (6, 3) Transcriber’s note indicator ,

− (46) Italic indicator ,

− (456) Boldface indicator ,

− (36, 36, 36, 36) Double dash indicating an omission , and

− (5, 5, 5) Ellipsis indicating empty table cell .

The exact Braille dots of some symbols can differ between languages (Section 2.1 [Lan-
guages], page 4) .

• If no symbols are listed, the special symbols list is not displayed.
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2.16 Transcriber’s Notes

A transcriber’s note is a note that is added in the Braille edition by the transcriber but not
shown in the print text. Some notes are inserted between other items in the document body,
some notes are displayed on a separate transcriber’s note page in the preliminary section.

OpenOffice.org

• Transcriber’s notes are automatically inserted by odt2braille. A user can only control
whether or not a transcriber’s note page is included in the preliminary pages, through
the option Include transcriber’s note page in [File > Braille Settings > General ]. The
transcriber’s note page heading can be modified in the field below. By default, it is set
to "TRANSCRIBER’S NOTES".

Braille

• Transcriber’s notes that appear throughout the document are brailled in paragraph
form. A note consists of one or more note paragraphs. Each note paragraph begins in
cell 7, runovers begin in cell 5. No blank lines are left before, after or between note
paragraphs. The complete note is preceded and followed by the unspaced transcriber’s
note indicator (Braille dots 6-3).

• The transcriber’s note page begins on a new Braille page. The heading is centered at
the top of the page. It is not included in the table of contents (Section 2.17 [Table
of Contents], page 17) . After a blank line the notes are listed. Notes are brailled
as indented paragraphs (Section 2.2 [Paragraphs], page 4) (first line cell 3, runovers
cell 1, no blank lines between notes). No transcriber’s note indicators are used. If the
transcriber’s note page doesn’t contain any notes, it is not displayed.

2.17 Table of Contents

OpenOffice.org

• In OpenOffice, a table of contents can be added to the document by selecting [Insert
> Indexes and Tables > Indexes and Tables] and choosing Table of Contents for Type.
However, these tables are not adopted in the Braille version. Instead, odt2braille
generates its own table of contents, and the user is given the option to include this
table of contents in the preliminary pages of each volume. This option is found in [File
> Braille Settings > Table of Contents]. The table heading can be modified in the field
below. By default, it is set to "CONTENTS".

Tip: If a table of contents is present in print, include it in the Braille
version also.

Braille

• The table of contents is rendered at the very end of the preliminary section (Section 2.12
[Preliminary Pages], page 13) , before any possible note sections (Section 2.9 [Notes],
page 11) . The table of contents begins on a new Braille page. The heading is centered
at the top of the page and followed by a blank line.

• The actual content varies between volumes. On the extended preliminary pages (either
included in the preliminary volume (Section 2.13 [Volume Management], page 14) , if
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present, or in volume 1), the table of contents lists all headings in the entire document.
Only headings in the body of the document are included. In all other regular volumes,
the table of contents is limited to headings in that particular volume. No table of
contents is included in supplementary volumes.

• Each table entry is composed of

− the heading,

− [the print page number (Section 2.11 [Page Numbering], page 12) , prefixed with
the appropriate letter if the heading begins on a continued page], and

− [the Braille page number]

Print and Braille page numbers in the table of contents can be enabled or disabled.

• By default, level 1 headings begin in cell 1, runovers in cell 5. Level 2 headings begin in
cell 3, runovers in cell 7. Level 3 headings begin in cell 5, runovers in cell 9. Headings
with an outline level greater than 3 begin in cell 7, runovers in cell 11. All these settings
can be altered in [File > Braille Settings > Table of Contents].

• The print and Braille page numbers are placed to end at the right margin of the Braille
line on which the heading ends. If space allows it, a sequence of unspaced guide dots,
preceded and followed by a blank cell, is inserted between the heading and the page
numbers. The Braille symbol for these guide dots can be specified by the user, the
default value is Braille dots 5.

2.18 Bibliographies

OpenOffice.org

• In OpenOffice.org, references to source material can be added through [Insert > Indexes
and Tables > Bibliography Entry ]. Although you can define sources within the document
itself, creating and keeping a bibliographic database allows reuse in other documents
and saves a lot of time. Select [Tools > Bibliography Database] to show this database.

• To generate a bibliography that lists all referenced sources, put the cursor where you
want this bibliography to appear, then select [Insert > Indexes and Tables > Indexes and
Tables] and choose Bibliography for Type. The bibliography heading can be modified
in the Title field.

Tip: Bibliographies are often more useful when bound in a supplementary
volume.

Braille

• In Braille, references to bibliography entries are rendered exactly as in print (the short
name or a number enclosed by square brackets).

• The bibliography begins on a new Braille page. On the first line, the heading is centered
and followed by a blank line. It is not included in the table of contents (Section 2.17
[Table of Contents], page 17) . The actual bibliography entries are brailled like any
other list (Section 2.4 [Lists], page 6) . Each item begins in cell 1, runovers in cell
3. The entries are translated literally, including special typeface (Section 2.10 [Special
Typeface], page 11) . After completion of the bibliography, subsequent text is resumed
on a new page.
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2.19 Mathematics

OpenOffice.org

• To insert a mathematical expression in OpenOffice.org, go to [Insert > Object
> Formula]. The equation editor will open at the bottom of the screen, and
the floating Selection window appears. The equation editor uses a markup
language to represent formulas. For more information on inserting math, read the
math guide at http://wiki.services.openoffice.org/wiki/Documentation/

OOo3_User_Guides/Math_Guide.

Braille

• Mathematical equations are conveyed to Braille through the use of specialized math
Braille codes. Supported math codes are Nemeth (generally accepted in the United
States), Marburg (Germany), UK Maths (United Kingdom) and Woluwe (Flanders,
Belgium). You can select which code you want to use in [File > Braille Settings >

Mathematics].

2.20 Inserting Literal Braille

• To insert Braille characters in the document that will be rendered identically in the
Braille edition and the print edition, the transcriber has two possibilities.

− In the dot pattern entry mode, Braille strings are specified by their dot patterns,
e.g. 12-1235-1-24-123-123-15 ("braille" in uncontracted English Braille).

− In the six-key entry mode, users can insert characters with the keys S (dot 3),
D (dot 2), F (dot 1), J (dot 4), K (dot 5) and L (dot 6), as if they were using
a mechanical embosser such as the Perkins Brailler. So to insert "braille", type
D+F, S+D+F+K, F, D+J, S+D+F, S+D+F, F+K. Spaces are entered with the spacebar
as usual and the enter / return key generates a hard return without starting a
new paragraph.

Note: Not all keyboards support this feature!

These modes can be activated in the menu [Insert > Braille Characters].

2.21 Braille-only Material

• Text can be formatted such that it will only be rendered in the Braille edition of the
document, but not in the print edition.

− To insert non-printing text, go to [Insert > Fields > Other. . . > Functions > Hidden
text ].

− To insert a non-printing paragraph, go to [Insert > Fields > Other. . . > Functions
> Hidden Paragraph]. In the Condition field, enter TRUE.

You can highlight these fields by checking [View > Field Shadings].

2.22 Hyphenation

• The user can choose to split words at the end of Braille lines if they are too long. This
will improve the layout of paragraphs. To enable hyphenation, check the corresponding
box in [File > Braille Settings. . . > General ].

http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/Math_Guide
http://wiki.services.openoffice.org/wiki/Documentation/OOo3_User_Guides/Math_Guide
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• For most languages, odt2braille has a hyphenation dictionary for automatic breaking of
words. In addition, a word at the end of a Braille line is always split when it contains a
hard hyphen, i.e. a plain minus sign ( - ). This allows for manual hyphenation. A more
elegant solution is to use soft hyphens, which are not brailled when the word appears
in the middle of a Braille line. To insert a soft hyphen, go to [Insert > Formatting
Mark > Optional Hyphen]. They are only visible in OpenOffice.org when [View > Field
Shadings] is checked.

Note: Soft hyphens can only be used in Windows.

2.23 Templates

• When you use the same Braille settings and layout frequently, it may be a good idea
to store these settings and layout in a template. Simply save your document as ODF
Text Document Template (.ott).

• odt2braille also includes some predefined, real handy Braille templates. One for a
simple Braille document and one for a more advanced, multi-volume Braille document.
Both templates contain a preliminary section with a titlepage. You can find them under
[File > New > Templates and Documents > Templates > Braille Documents].
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