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Mapinfo Help Guide
From issues raised on the internet based Mapinfo List by MapInfo users
last updated 17 Oct 1997

A
Adobe

converting maps with symbols to Acrobat .pdf files

I want to give people at various offices the ability to read the maps I
create with integrity intact using Adobe Acrobat.

We have been using Acrobat as a very successful method of
'packaging' various documents into a format that's readable by Macs, PCs
and UNIX machines. We often have to include some text and graphs/charts
with our maps and Acrobat makes it easy to distribute one document
containing all the necessary attachments without having to worry about what
the user needs on their end.

While Acrobat works well with many Programs (Excel, Word, Filemaker,
Netscape to name a few), Mapinfo's symbol fonts poses some problems. If
you use Mapinfo's symbol fonts, the symbols WON'T get translated properly
at the other end. The reasons is the way Acrobat uses its own ATM font
mechanism to re-build the fonts in the users document, it can't build
Mapinfo's symbols. So use a standard true type font to build symbols, if
needed.

Sgt. G. Patterson

ascii files
mapping imported ascii files with start / finish points for lines

I have a table that has been imported from an ascii file and contains
the start and end coordinates of a line in each row. How do I get MapInfo to
draw the line ?

A couple of quick steps and you're done.  First, make the table
mappable.
Choose Table>Maintenance>Table Structure
and check the box which says "Table is Mappable" and click OK.  Next,
choose Options>Show MapBasic Window
Then, in the MapBasic Window, type the following...

Update your_table_name Set Obj = CreateLine
(begin_X_column,begin_Y_column,end_X_column, end_Y_column)
...and then hit enter.

Don't forget to save your changes.

MapInfo Technical Support



If you have a table named lines with columns x1, y1, x2, and y2 then
this statement in the MapBasic Window will create the lines. (Be sure that the
table is mapable first. Check it in Table>Maintenance>Table Structure...)

update lines set obj = createline(x1,y1, x2, y2)

Andrew Dressel

B
Bearings

determining the compass bearing between two given points

Can anyone provide, or point me towards a resource that would give
me the formula to calculate the bearing between two sets of lat/long
coordinates

Look in the DIST_OBJ module from the KGM utilities. You will find
what you need and much more. These tools are available on the MapInfo-L
ftp archive at http://www.csn.net/~bthoen/mapinfo/ftpsite.html.

Pierre Lemieux.

Yes.  I wrote an MBX that does exactly that, and uploaded it to the
MapInfo-L ftp archives.  It's called, oddly enough, Bearing.mbx.  It calculates
the distance and bearing between two points, giving the bearing in degrees
with zero being true north. I've also included the MB source code.

Sean Reese

Buffering

buffering regions

I have a table with county boundaries of the UK...I want to create new
county boundaries which are 0.5km bigger all the way round, a catchment
area in effect.

You can make the cosmetic layer editable Map>Layer Control.  Then,
select all the counties in your county boundary table.  Choose Objects>Buffer
and type in the value to create the radius buffers for (i.e. .5).  Choose the
units you want and choose one buffer for each object.  This will create an
object that is .5 km bigger all the way around the boundary.

Cindy M.
MapInfo Technical Support

(i) open the county layer,



(ii) make the cosmetic layer editable,
(iii) use menu item 'query / select all' to select  all of the counties,
(iv) use menu item 'objects / buffer' to create a buffer around your 
counties - you can specify if you want a single buffer or a buffer for 
each county.

Steve Culshaw

All you need to do is buffer each county in question (see the Objects
>Buffer menu choice).  Keep in mind, however, that this does not  produce an
exact representation of the object in question as MI tries to draw a circle
around each node in the target object. The steps are as follows:

1) Make the layer that the new polygons will go into editable (Cosmetic will
work).
2) Select the counties that you want to buffer.
3) Select Objects> Buffer
4) Set Value to 0.5, Units to Kilometers and make sure "One buffer for each
object" is selected.  You will need to tinker with the Smoothness setting a bit
to get the best combination of speed and resolution.  I would start with
something like 3 to 5 first.
5) Click OK and then wait for the buffers to be drawn.  Note that this can be
time consuming if your source boundary is complex.

If you want to add in the information in your source County table then you will
have create a field in the target table to contain the information and then do a
Table>Update column to get the information.  You would use the following
settings, assuming that both the Source and Target tables have a character
field called CountyName.  Use the following commands - the sequence  is
important.

1) Table>Update Column
2) Set Table To Update to your target table
3) Set Get Value From Table to your source table
3) Click "Join" and select the second option - where object from table...You
will want this to look something like "Where object from table
Source_Contains_ (pick from list) object from table Target.
4) Click OK in the Join dialog
5) Set the Column To Update to CountyName
6) Set the Calculate field to Value
7) Set the Of field to CountyName
8) Click OK and your target table's field will be filled in with the county names.

Don't worry about your expanded counties overlapping each other - the
Update Column procedure is based on the centroid of your target county
falling within the boundary of the source county - which will always happen in
this case.

James L Marlow



creating polygons at the intersections of lines

I have a file containing a number of often intersecting lines (trails) for
which I'd like to build buffers, for each trail individually (I know how to do this
part) and to find all possible intersections of these buffers retaining
information on the "history" of creating these intersections (any given
intersection polygon should have an attribute indicating which buffers were
used in creating it). The whole thing should work something like "regions"
program in ArcInfo.

First make the cosmetic layer editable.  Also make sure that the layer
containing your streets is the first selectable layer underneath the cosmetic
layer. select all intersecting streets of the intersection in question. Objects >
Buffers. Set the buffer units and value (i.e.: 500 meters) and click OK.  A
buffer of 500 metres should be generated around that intersection. To get a
browser of all streets within the buffer, click inside the buffer region with your
boundary select tool and do a Window > New browser window on the selection.

Jennifer Clark

C
Colour

changing level of colour displayed on monitor

I am displaying aerial photos in my map windows with varying results.
8 bit rasters display and print okay but they are only 8 bit.

You can increase the quality of images as below although you loose
the ability to set one colour transparent. There are three parameters kept in
the registry which can be used to change how MapInfo handles images.

For 16-bit MapInfo add <key>=<value> pairs to MAPINFO.INI in the [MapInfo
Common] section:

For 32-bit MapInfo running on Win95, WinNT add the named values to the
following Registry key:
HKEY_LOCAL_MACHINE
         Software
            MapInfo
                MapInfo
                   Common
      UseTrueColor

Allows the user to stop the engine from dithering 24 bit images down to 8 bit.
This lets people with true color displays to have better quality color matching.
Unfortunately, there are side effects: transparency on these images is
disabled, but the UI for the
transparency is not.



0 - is default (off), dithers 24 bit color images into an 8 color space
1 - allows Windows to render 24 bit images with as many colors as possible
The value in the registry has to be a DWORD, and either Hex or Decimal.

Bob Young

How to select lines by colour
see Query, select lines by colour

How to select polygons  by colour
see Query, select polygons  by colour

Co-ordinates

updating Coordinates in a table
See Query : record coordinates from points

Custom Symbols

creating and using custom symbols

Most MapInfo symbol sets are TrueType fonts, and can't be custom-
colored (only solid-filled with a single color). Custom symbols, on the other
hand, are icon-like bitmaps that can depict anything you can draw within the
size limitations (32x32 pixels??? or something like that).

Here is a summary of info about MI custom symbols,

1 - custom symbols (bmp files) must be all stored in the directory custsymb. If
you want to use your own symbols, the way to access them with MI is to
locate them in this directory. MI will "read" it at loading time and make them
available

2 - all symbols in custsymb directory are displayed in a frame called Custom
Symbols. This set is listed above the "MI3 compatible" set in the list box of
the Symbol Style requester. ( menu Options>Symbol Style) Any one of these
"bitmap" symbols can be selected and used.

3 - there is no absolute limit to the number of custom symbols that can be put
in this list. It is more a question of memory available to store them than of
length of list

4 - a bitmap symbol can be accessed in MapBasic only by its file name.Code
number such as in the true type fonts do not exist. There does not exist a real
set ("custom") like there is a "Wingdings" with >220 symbols.

Jacques Paris



D
Date

how to set current date in a workspace
see workspace: current date

DDE

DDE definition

DDE (Dynamic Data Exchange) is a form of InterProcess
Communication (IPC) in Microsoft Windows and OS/2. When two or more
programs that support DDE are running simultaneously, they can exchange
information, data and commands. In Windows 3.xx this capability is
enhanced with Object Linking and Embedding (OLE).

Definitions

accuracy and scale

When using paper maps, we can relate map scale to absolute
accuracy through a convention such as that contained in the US National
Map Accuracy Standards--at a publication scale greater than 1:20,000, 90%
of the points have an error less than 1/30 inch, and at a scale less than or
equal to 1:20,000, 1/50 inch. For example, a USGS
1:24,000 topo map has 90% of the points plotted with a circular error less
than 1/50 inch = .508 mm. If I measure points from such a map and convert
them to ground scale, I expect that 90% of these measurements will have an
error less than .508 mm * 24,000 = 12.2 meters. Therefore the accuracy of
my measurements is implied by the map scale. But when looking at a map
display on the screen of a GIS, I am often zoomed in at a scale that is
inconsistent with such map accuracy standards, or I
may not be paying attention to the current display scale. So instead I need to
know the accuracy of my data in ground units, such as meters.

However, when I plot the data out to a paper map that other people may
view, I should at least be aware of the acceptable map scales that are
consistent with the quality of my data and the map accuracy standards.

Milan

Digitising

creating a new mapinfo table from an existing map

I  to learn how to do heads-up digitizing. Can someone give me some
basic instructions to get started? How do you create a table to go along with
your digitizing?

There are three basic steps to creating the table you have described.
All of the references refer to the User's Guide which came with your copy of
MapInfo Professional.



1.  Registration of the raster image that you will be tracing.  See Chapter 15,
especially pages 204-208, and note that the closer you zoom in (both map
window and image registration window), the more accurately the raster will
be registered.  Please, always use at least 5 well dispersed registration
points!

2.  Choose file>new table>open new mapper to create the table (here, columns
in your MapInfo browser) which you will enter your data into. See page 242
for instructions.

3.  With your raster image open, add your new table to the map.  Go to your
layer control and make your new table editable.  You are now ready to
digitize (trace) the items on your raster image.  Note:  Hitting the <S> key on
your keyboard will place you in SNAP mode (page 396); you will probably
only use the Polyline and/or Polygon tool (Chapter 13) for both of these tools,
hit the <escape> key to stop drawing your line.

Jo Jordon

E
Export

exporting maps to other software packages
see 'Powerpoint, inserting maps into slide shows'

F
File

File formats for MapInfo

I recently purchased some MapInfo format files for use with an OCX.
there seems to be 5 files associated with this:
mymap.DAT
mymap.TAB
mymap.IN
mymap.INDX
mymap.MAP
can someone clarify exactly what each of these do?

If you look in your MapInfo User's Guide (v. 4.0, pg. 322), you will see
the following in Appendix B:

filename.dat Tabular data for a table in MI native format
filename.dbf Tabular data for a table in dBASE format
filename.id ndex to MI graphical objects (MAP) file
filename.ind Index to MI tabular (DAT) file
filename.map Contains geographic info describing map objs.



filename.mid MI import/export format for tabular data
filename.mif MI import/export format for graphic objs.
filename.tab Main file for a MI table, associated with the appropriate

.DAT (or .DBF, .XLS, .WKS, or .TXT file), .MAP, .ID and 

.IND files.
filename.txt Tabular data in ASCII format
filename.wks Tabular data in Lotus 1-2-3 format
filename.wor MI workspace file (MapBasic program saves info about 

which tables and windows were in use in a MI session.

Jo Jordon

G
Graphs

labeling Pie Graphs

I am doing pie charts for a bunch of counties, I would like to indicate
the Percentages around each pie. Is there a way I can do that.

Tedious if you have many variables or many counties, but I would use
the autolabel function for each variable.

1. Set your label offset to 6 or more,
2. Use label lines,
3. Autolabel with your first variable,
4. Maneuver your labels if necessary,
5. Save your labels to a table with Labeler.mbx,

Rotate the position of your labels around the anchor point (the county
centroid is where your pie will show up, and also acts as the anchor) for each
succeeding variable.  Repeat items 4 and 5.

Jo Jordon

H
I
Info Tool window

resetting the location of the Info Tool Window

From time to time I lose the Info-tool window and cannot get it back.
My current solution is to save what I'm doing, shutting MapInfo down, and
then starting up again.  Is there a more convenient way to solve this
problem?

Try this: Choose Options>Show MapBasic Window.  This will put the
MapBasic window at the bottom of your window.  Then, type in the following



command: Set Window Legend position(1,1) Then, press the <enter> key.
This should bring your info window back on the screen.

Cindy
MapInfo Technical Support

J
K
L
Labels

adding additional text to labels

Has anybody got any suggestions as to the best way to automatically
label map objects using meaningful text based on what is held in columns in
a browser table?  e.g. Where a polygon is given the value "limestone" in the
browser table, label it "First lithology is limestone"'

For the purpose of this exercise, we will assume the field you keep the
first lithology in the named "First_Lith" Open your map(s) in a mapper window
and go to the layer control dialogue.  Click on the layer you wish to generate
labels from and chose the label button. Choose to "Label with: Expression"
Type the following line into the Expression box (including the double quotes
which tell MI to treat the string as text)(note the space after 'is'):  "First
lithology is " + First_Lith  This will set the string - 'First lithology is ' into the
label and add the lithology field to it. Use the verify button to check for correct
syntax and then 'OK' your way back out - your new label should now show up
on your mapper - you can modify the font, placement etc. as with any other
label. You can use this to make some pretty complex labels, the most useful
addition I have found is to add 'CHR$(13)' into long labels at judicious points,
this is a non-printing character that forces a carriage return, dropping any
following part of the label down a line and means you dont get huge long
labels.- try:"First lithology " + chr$(13) + "is " + First_Lith

Russ Mincher

avoiding auto labeling objects where the value=0

I have a table that contains traffic counts from two different sources.
Some road have values from source A and others from source B.  In order to
properly label these points, however, I need to put the layer in the map
window twice; once to label using source A's info and the other layer to point
to Source B's field.  Is there a way to "not label" if the value is 0, for example?
I have to manually delete the label I don't want.

Make a SQL query where you select object with attributes <> 0 and
then map the query (and label it) instead of the original table

Ole Gregor



Placing labels to Graphs
see Graphs; labeling Pie Graphs

Layout Window

changing text in title bar of  layout window
see mapper window, rename title bar

creating grid for alignment purposes in Layouts

 Does anyone know of  a way of getting a grid in the Layout window to
make it easier to align different objects correctly?  Having a ruler around the
edge isn't really enough when you have lots of objects in one layout and
they've all got to be aligned correctly.

Create a Paper Projection grid in a Mapper window which would be of
the size and dimensions you would want to use. When you send your map(s),
including the opened grid map (the paper one you created), that grid will be
in the new layout.  Expand the grid to the size you would want to see and
send it to the background.  Then drag and expand your other windows to
align with your grid.
Do a couple test prints and adjustments then close or delete that grid from
the layout before you print your final output. In theory that should work out for
you, but because you will stretch it for various sized prints, it might require
you make multiple paper grids with fixed dimensions.

Tom in Seattle

creating a template using layout window

Is there anyway to create 'templates' for standard layouts in MapInfo?

Yes, open MI with no mappers open and open new layout. Create the
borders, title block, logos, scale bar etc. and save the layout as a workspace
(i.e. A2_temp.wor) for an A2 end product. Later you can open them with any
mapper open, position your map and print. Works well in conjunction with
Named Views when you want to create a map series over a large area.

Greg Sonter

Legend Window

changing the colour of the window background.

How do I change the legend background colour on a layout.

 If you are in the layout you need only to change the attributes of the
legend frame.  To do this, select your legend, then either press the 'region
style' button (the polygon with the question mark on it) from the draw toolbar
or press <ctrl>-F8.  This will bring up the region style editor.  Here you can



set the fill pattern to N (none).  The legend will now be transparent and your
ocean layer will show through.

embedding the legend window into mapper window

On the point about the legend not being included when you save your
window, you need to embed the legend in the map window.  This can be
done using Legends.mbx  in your tools directory.  Once installed it will create
a Tools menu item. Select Tool>Legend Manager>Create Embedded Legend and
you will have a embedded legend that you can move around in your mapper
window. If you alter your thematic layer, add or delete one, it will be updated
in the embedded legend.

Tim

Lines

change the flow direction of lines

How do you change line direction - I saw that MI tracks this by the
"Show Line Direction" check box in the Display dialog box - so how do I
change the direction?  The reason I want to do this is I suspect the
"handedness" of the line controls the side the tics on asymmetrical line types
(for example the cliff line type)

Try MapInfo's free utility, Line Director at
http://www.mapinfo.com/free/mb4.html. It works on both Windows and Mac.

Bill Thoen

coordinates of a line

I need to get the x and y coordinates of all nodes in a line. I can see
the nodes  when they are turned on in the map layer, but how can I list
(browse) their coordinates and save this list to a file?

To return the coordinates of the nodes of a line, you could do the
following select:

Select objectgeography(obj,1) "BeginX",objectgeography(obj,2)
"BeginY",objectgeography(obj,3) "EndX",objectgeography(obj,4) "EndY" from
Tabname into Selection

This select will return four columns that represent the beginning X and Y and
ending X and Y coordinates for every line in the table.  If the objects in your
table are polylines, this same select will return the coordinates for the
Minimum Bounding Rectangle(MBR) of the polyline.  If you wish to get a
listing of all the coordinates that make up a polyline, one way you could
accomplish this would be to export the table to a MapInfo Interchange Format
(MIF) file and browse the file in a text editor.  In addition, there are MapBasic



commands that would enable you to return the coordinates for each node in
a polyline or polygon.

MapInfo Technical Support

drawing a line from coordinates
see 'ascii,mapping imported ascii files with start / finish points for lines'

editing line styles

Check out the standalone line style editor available for free from
MapInfo's Test Drive Center. visit  http://testdrive.mapinfo.com/
and follow the link at the bottom of the page to the line style editor. You can
read the readme online before downloading. Here's a snippet from the
readme:

What Is MapInfo Line Style Editor?
MapInfo Line Style Editor (MILISTED) is a stand-alone tool that allows you to
create custom line styles for use with MapInfo Professional. You can use the
editor to replace existing line styles, or to add new line styles to the
standard set MapInfo line styles.

steve.lombardi@mapinfo.com

measuring polylines
see query calculating the length of several polylines

How to select lines by colour
Query, select lines by colour

select object by line style

I've seen numerous questions on this list, regarding how to select
lines, points, etc., accoding to their color, fill  pattern, etc.  So I wrote a little
MapBasic utility, which I'm tentatively calling Stylist.mbx, which helps you
select objects based on their display styles.
How it works: First, you manually select one object which has the display
style you're interested in -- a thick red line, for example. Then you click the
"Select By Style" button (which Stylist.mbx adds to the Tools toolbar), and
STYLIST displays a dialog that lets you select by style.  STYLIST can select
just those objects with an identical display style (e.g. thick red lines), or you
can un-check various options to select all the red lines, or all thick lines, etc.

Dave Smith

M
Map Basic

Map Basic Guides
 High Mountain Press (Onward Press) MapBasic Developer's Guide

Angela Whitener and Breck Ryker



MapBasic Developer's Guide is a handbook for customizing MapInfo
Professional. The book begins with a tutorial on MapBasic elements, the
MapBasic development environment, and program building basics.
Subsequent chapters focus on customizing and editing of all program
components. Written to Version 4.x. Bonus disk included.$49.95 US    350
pages

Table of Contents
Customizing MapInfo
Elements of MapBasic
Building a Program
Menus
Managing Tables and Files
Trapping Errors and Debugging
Dialog Boxes
Coding With MapInfo Windows
The Select Statement
Programming With Workspaces
Editing Graphic Objects
Advanced Features
Example Application
Command Language Reference
ASCII Code Reference

MapBasic Window

accessing menu commands in the mapbasic window

I do not have mapbasic but would like to use a text editor to write
some script to use in the mapbasic window. How can I access the
menucommands such as edit..copy and edit..paste.

You can execute several lines at once by selecting them all and
pressing the "Enter" key. What you cannot do with the MapBasic window are
things like looping, branching, subroutine and function calls, and dialog and
menu creation. The only commands you can use are those that can be
executed on one line at a time, but you can execute several one-liners in
sequence. For example, to use the edit cut and edit paste, put all three of
these commands into the MapBasic window, select something in the map
window, then select all three of these lines and press enter:

set window FrontWindow() front
run menu command 202
run menu command 204
202 is the edit/cut command, and 204 is the edit paste. This script won't do
much as it cuts from a layer and pasted right back into that layer, but that's all
Joel asked for. You would probably want to add a "set map layer..."
command in there to change the editable layer before you paste the object.



Jacques Paris has written an excellent miniguide to the MapBasic window in
which he reveals a great deal about what you really can do with the
MapBasic window. It's about 100 pages long, but costs only $10 ($12
Canadian), I have posted a little blurb about it on the Rocky Mountain
MapInfo Users Group web pages at http://www.ctmap.com/mapinfo/other.htm
where you can get Jacques's email and snailmail address.

Bill Thoen

Mapper Window

embedding the legend window into mapper window
see Legend Window,embedding legend window

rename title bar of mapper window

Is there a way without using MB to rename Mapper and Layout
windows when more than a few mappers and several layouts are open in a
Workspace avoiding the LAYOUT:1, LAYOUT:2 naming method.

You need to use a MapBasic command, but you can do that in the
MapBasic window or in a workspace. The command you need it this.
<fontfamily><param>MS Sans Serif</param><bigger>
Set Window WindowID(0) Title "Chris"
</bigger></fontfamily>
The zero indicates the window most recently opened so this works fine if you
do it immediately after you open a layout window or the layout statement in a
workspace. (It works on mappers and browsers too.)

Andrew Dressel

The change is not saved with the workspace. You'd need to add some
code into your workspace manually to keep re-applying the name change.

Steve Wallace

Is there anyway through editing a workspace or in MB of changing the
title of a layout? For example, From 'Layout: 1' to 'Layout: Harlesden' or more
simply 'Harlesden'.

Make the window you want to change your front window Type in the
MB window set window frontwindow() title "Layout: Harlesden"

update edited point locations from browser in mapper window

I have a table with fields for latitude and longitude. If I change any of
these values in browser, how to refresh the map ? Currently I go and delete
.tab, .map and .id files. Recreate the points from the .dbf file.



1. Select in the browser the records whose coords you have changed.
2. In the map window set the points layer editable.
3. From the Edit menu, select Clear Map Objects Only - and the points that you
have selected will be removed from the map, but not the browser. Do not hit
the delete key.
4. Go to Table > Create points, and new points will be created only for those
records with no map object.

Martin Higham

Message Window

adding text to message window

Can anyone let me know what is the purpose of, and how to use, the
"messages" option that appears as an option in the pull down menu in the
Window>New Layout Window dialogue box. Can't seem to find any reference to
this in the help or manual.....

This option lets you place the message window in a frame on you
layout window. The message window is available to MapBasic programs as a
place to display
non-modal message. It floats on top of document windows. For example:
1. Open the MapBasic window (Options>Show MapBasic Window).
2. Type: print "hello world" and then press the enter key.
3. MapInfo displays the message window with the text you requested.
4. Use the option you asked about to add this text to your layout window.

Andrew Dressel

MetaData

MetaData.mbx tool tips
I have been struggling for over two years trying to find some workable

way to attach metadata to our MI tables.  Since downloading the
"metadata.mbx" yesterday morning, I have created a new "metadata" folder
in my "c:\mapinfo\mb_apps\" directory, used a text editor to create a
"default.met" file, saved that as a template in my word processor, filled in the
pertinent info (the hard part) for two of our base layers, used "save as/text" to
save these "layer_name.met"s into the new "metadata" folder, and then used
your "metadata.mbx" to import the data into the corresponding TAB file.
Now, in addition to having the metadata attached to the data, if you open a
table, use your .mbx to view metadata, open the layout window with those
two windows open, and print the layout, you can have a nice paper copy of a
small printout of the layer along with it's metadata.  Your librarians should
now be very proud of you!  Thanks again.
Fred Eaton

Microsoft



Access

How do I handle MS Access files in MI 4.1?

If you choose File>Save Copy As, you can save an open MapInfo table
as a new *.MDB file.  But, this file can not be opened in Microsoft Access
version 2.0 but in version 7.0 of Access.  If you are using Access version 2.0,
then that is why you would be unable to open the *.MDB file in Access.

MapInfo Technical Support

Excel Data Map

Can Microsoft Map, or data map, or whatever, use existing sets of
maps? I have hundreds of proprietary company maps but don't seem to be
able to use any of them in Excel 95/97.

MSMap can display any MapInfo map (except raster) as long as they
are in MapInfo format.  You will need to run the datainstaller to register the
.tab file.

Mapinfo Technical Support

I just spent the last couple of days working with DataMap and have
learned the following from that experience and from the Microsoft technet.
Hope it is helpful to you and others.

1. There are only 2 ranging methods available: equal count and equal range.
2. DATAMAP will not create a number of equal range categories that would
result in one of the categories being blank. For instance, I may specify 4
categories with the expected results and then respecify the number of
categories to 5. If this new range were to result in the creation of an empty
category, the map would stay displayed with 4 categories.
3. DataMap objects do not automatically update when associated data is
changed, as do chart objects. This by design due to the potentially prohibitive
amount of time required to update DataMap objects associated with large
amounts of data.
        Solution1: manually update the object by activating it and then clicking
the update button.
        Solution 2: use a visual basic for applications macro that updates the
object on the worksheet:
                Sub Update_DataMap_Object()
                'Assign DataMap Object Name to a Variable
                Mapname = "Picture 1"
                'Update DataMap Object
                ActiveSheet.OLEObjects(MapName).Object.Refreshmap
                End Sub
4. You cannot overlay two thematic maps, but you can overlap a thematic
map and say a graduated dot or symbol map, or pie or bar chart map.



5.  The symbols for the graduated symbol map are really letters not
symbols!?!
6.  Sometimes I had to copy the map to the clipboard and then paste it in a
new worksheet to get it to print correctly, even though it displayed correctly
on the screen. I think this was related to problems with the refresh option
being grayed out.
7. The choice of blue for the color ranges results in purple ranges being
printed on the HP1200C.
8. DataMap map files use Mapinfo 3.0 format.
 9. For Excel to have access to a map, the map must be registered in the
geodictionary. Copying map files to the subdirectory containing the
geodictionary does not register the files in the geodictionary. Our network
administrator must use the Data Installer to create an entry or to edit the
geodictionary.
10. When the DataMap object is created in the spreadsheet, Excel checks to
see if you have highlighted a source data range. If Excel doesn't find a
source data range, it creates a blank DataMap object. If Excel finds a source
data range, the data are passed to DataMap and it attempts to match a
sample of the data in each highlighted column with installed map templates.
Before the user's data can be displayed on a map, DataMap must be able to
match geographic data in the user's selection to labels stored in the .dat file
of a template.
11. DataMap attempts to match over 80% of the geographic data against an
installed map. If this criteria is met, DataMap opens the matched map and
begins to plot the data. If DataMap can match more than one map, users are
promted to choose which of the matched maps they wish to use. If no maps
are matched, DataMap disregards the data and prompts  the user to choose
a map to display.If the matching process takes more than 5 seconds,
DataMap aborts auto-matching and prompts the user for a map to use.
12. Once a map is matched, DataMap displays the map and binds the user's
data to it.
13. Geographic data which is not recognized (e.g., misspelled) will be
displayed one-by-one to help users an acceptable alternative.  The file
Mapstats.xls, sorted in the \Program\Files\Common\Files\Microsoft
Shared\Datamap\Data folder contains lists of the proper labels for all
installed maps.
14. By default, DataMap plots values in the first column to the right of the
geographic data as a Value Shaded format on the map. If DataMap finds
multiple records that pertain to the same region/boundary, the values are
aggregated with the sum function. It is possible to use a count or average
function in the aggregation.

Carolyn White

Excel, opening datamaps in MapInfo

Does anyone know how to open a excell spreadsheet in MapInfo and
have the projection set to other than long/lat.  I need it to be in NAD83
stateplane.  I wanted to avoid creating a seperate table, for my users want to
edit the data in Microsoft excel.



When you bring in the excel spreadsheet you can to geocode it or
create points to make the table mappable, at which time you can then specify
in the respective dialog box which projection the points are in to be geocoded
or created. If you just want to make the table mappable, go to
Table..Maintenance..Table Structure and select Table is Mappable. At that
point you will be given a Projection button where you can select the desired
coordinate system. If the excel spreadsheet has been opened and mapped
before and is in an undesired projection, go to Table Structure and deselect
Table is Mappable and you will be prompted that all map objects will be
permanently deleted. You can then go about remapping the excel
spreadsheet.

Joel Zimmerman

Powerpoint, inserting maps into slide shows

I am attempting to create a PowerPoint slideshow using MapInfo
layout windows. I am presently using MapInfo V4.02 on Windows 3.1 and
need to move the layout window into the Office 95 version of PowerPoint.

Yes, get your layout window up and selected Under FILE, select
Save Window As (accept whatever size it defaults to) select Windows
Metafile format select a directory and write a name in before the .wmf Select
Save.When you open PowerPoint: under Insert, select Picture select the
metafile you created...

Craig Parada

Monitors

setting screen colour  levels
see Colour, changing level of colour displayed on monitor

setting map view panning

 How do you set and unset the automatic panning of a map window?

There are two ways that I know of:

     1. Use the MapWin.MBX sample application

     2. Type this command in the MapBasic Window:
Set Window
WindowID(FrontWindow()) Autoscroll Off

Andrew Dressell

N
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OLE

definition of OLE
OLE (Object Linking and Embedding) means tying one piece of

information in one form into a document in another form, such that a change
in one piece of information will be automatically reflected in the other
document. Here's an explanation from the New York Times: Business reports
may contain information in a variety of formats, including text and numbers,
charts, tables, images, graphics, sound and video. Typically, these are
created in separate applications programs (e.g. spreadsheet, word
processing, charting, database, etc.) and are merged into a single document
(i.e. the report). But when the numbers used to create a chart are changed
the chart must be updated as well. The executive then has to track down all
the various components of the report, call up their respective applications,
make the changes and stitch everything back together. OLE promises to
keep track of those links and update the various components as they change.
Here's an explanation from PC Magazine: OLE is a complex specification that
describes the interfaces used for such tasks as embedding objects created
by one application within documents created by another, performing drag-
and-drop data transfers within or between applications, creating automation
servers that expose their inner functionality to other programs, extending the
Windows 95 shell with custom

P
Points

Adding to the data for a point it's location within a region.

I have following a point table for thousands of village locations
...Villages.tab  I also have ...Districts.tab which is polygon data How can I
associate district_ID, identifying to which district each village belongs, from
districts.tab to each the village record by Mapinfo/programming/SQL e.t.c.

Try joining the two tables on the object instead.  For example,
Select * from districts, villages where districts.obj contains villages.obj into
selection
This selection will join the two tables where the polygon object in thedistricts
table contains the point object from the villages table.

Cindy
MapInfo Technical Support

You will have to use the Table>Update Column command. The mapbasic
command is: Add Column "Villages" (district_ID) From Districts Set To
district_ID Where contains You can type this command in the MapBasic
window or enter it from the dialog box.

Pierre Lemieux



How about a simple Table>Update Column? Make sure Villages.tab has
a column for the District_ID.
Table to Update:  Villages.tab
Update Column:   District_ID
Get Value From Table: Districts.tab

Join: Where object from table Villages.tab
is within object from table Districts.tab

Calculate: value of district_ID

Erica Wieland

how to combine points and polygons
see 'Tables:Combining related points and polygons from seperate

tables into a single table'

how to create points using the MapBasic Window

I would like to be able to use mapbasic commands in the mapbasic
window in mapinfo to simplify some of the grunt processing I have to do with
my files.  Specifically, I need the command that will have the same effect as
selecting Table>Create Points on a DBASE DBF type table which has already
been opened.

Literally, the command is: RUN MENU COMMAND 408 but I know
that's not what you meant! Do:
CREATE MAP FOR mytable
UPDATE mytable SET
OBJ=CREATEPOINT(mytable.x_coord,mytable.y_coord)
where mytable is the name of your table and x_coord & y_coord are the
names of the column that hold that info. the symbol will be what every you
had set as default.

Bruce Taylor

Make sure that your Fields that hold the X and Y values for the points
are in  Lat-Lon, or issue a Set Coordsys command in the MapBasic window
first to change  the default coordinate system to match your file.  If you don't
know the exact  syntax for the coordinate system that you want, with the
MapBasic window open,  change the projection of a map window (any file will
do) to the coordinate system you want and look at the recorded line in the
MapBasic window.

Kelly Close

how to create a polygon around a selection of points

I have geocoded addresses and mapped them.  Now I want to create
a polygon that contains 85% of those address - those closest to a particular



park and ride location.  Is this possible - without getting into a protracted MB
creat ion?

Create a new field in your point database and using the "distance"
function, update the field with the distance between your park and ride
location and the addressed sites.  Sort the database by the distance field
using SQL Select and then select the top 85% of the sites.  There is a
MapBasic program called hull.exe (find it at
http://www.gisnet.com/gis/mapinfo/recent.htm) that may be able to create a
minimum bounding circle around your points...but I have not used it myself.
Otherwise you could draw the polygon by hand.

Bill Landis
Polygons

See Regions,
Polylines

See Lines,
Printing

printing in black and white

A while back I asked about an easier way of printing maps on a laser
printer (HP Laserjet).  Here is a summary of responses:

1.  Make sure that the Color Styles button is off in the Thematic
Dialog.  This only makes a difference when the color default is set to Black &
White in the System Settings category of Options>Preferences.  I  found that
with the black and white settings - the thematic on the screen is closer to
what is actually printed.  You have to make sure that the preferences are set
before you create the thematic.

2.  Playing with the fill patterns in the Styles Dialog.  There is a good selection
of patterns but I found that my blobs were too small to make a difference - all
the fill patterns looked the same when printed.

3.  Purchase Superprint (approx. $50US).  See www.zeno.com.  Looks
interesting but I'm at the bottom of the totem pole in my office with no power.

4.  MapBasic Utility - hexcell.mbx at http://www.sni.net/gis/mapinfo/files1.htm.
Creates a color chart using shades of red, green and blue.  The chart can be
printed out to compare  shades and colors.

What I ended up doing was creating a grid (using gridmaker) and then
creating a thematic map using individual ranges to get a range of colors. I
have now picked out the ones that work best on our printer.  Now I have 2
copies of every map - one for the color printer and one for the laserjet. This is
a pain when I have to make changes.

Paula



Q
Queries

query calculate area of polygons

I have drawn a few hundred polygons representing geological
outcrops I would like to calculate the total area and perimeter for all the
polygons on my mapsheet pertaining to a certain rock type.
In my table I have given the individual outcrop polygons attributes for the
geological rock units they contain but short of double clicking on each
individual polygon and totalling the total area manually I can't seem to find in
the reference manuals how to do this for a selection of polygons.

To return the Area and Perimeter for the polygons in your table, you
would do the following Query>SQL Select(we will use the States table in this
example):
Select Columns:  State, Area(obj, "sq mi"), Perimeter(obj, "mi") From Tables:
States Into Table: Selection
You can leave all the other dialog boxes blank.  When you click OK, MapInfo
will produce a query table with the name of the State and the Area and
Perimeter for each polygon object in the table.  You can also use
Table>Update Column to update a blank column in the table with a particular
function.  Under the SQL Select dialog, pull down the functions list box to
view the other functions that are available.  In addition, Appendix E in the
MapInfo Professional Reference Manual lists a description of all
functions.

MapInfo Technical Support

query count points in polygon 

How do I update a column in a polygon  tab file using SQL QUERY.  I
have a point and a polygon tab file.  I want to count the number of points from
the tab file that fall within each polygon in the polygon file and put that count
for each polygon in the polygon file.

One way to accomplish this is though Table>Update Column.  You can
add an integer column to your polygon table that will store the count
information(i.e. pointcnt).  You would then choose Table>Update Column and fill
in the dialog as follows:

Table to Update: Polygon
Column to Update: Pointcnt
Get Value from Table: Point
Calculate:  Count

Be sure to click on the Join button and select the second option where the
object from your point table IS WITHIN the object from your polygon table
Once you click OK to perform the update, MapInfo will update the column in
your polygon table with the count of points that fall within each polygon.



query calculating the length of several polylines

How can you quickly, presumably using an SQL statement, work out
the total combined length of several polyline objects?

Select the objects you want to query. In the SQL dialog, put the
following:

Select Columns:     Sum(ObjectLen(obj, "mi"))
from Tables:        Selection
Click OK

Change the "mi" to the units you prefer (i.e. "km", "m", "ft").  You can also use
the pulldown menus to get the above aggregate and function.

Jason Bryngelson

Query, record coordinates of nodes in a polygon/region
I have a region with one polygon and 26 nodes.  How can I return the

X, Y coordinates of all the nodes into a table.

You can put the following code in a MapBasic program to print the
coordinates of every node in the selected polygon:

dim i,numpoly,numnodes as integer
dim xcoord,ycoord as float
dim regobj as object

regobj=selection.obj
numpoly=objectinfo(regobj,21)
numnodes=objectinfo(regobj,21+numpoly)

for i=1 to numnodes
     xcoord=objectnodex(regobj,1,i)
     ycoord=objectnodey(regobj,1,i)
     print xcoord+","+ycoord
next

If you don't have MapBasic, one way to do this would be to export the region
object to a *. MIF file, Table>Export, and open the *.MIF file in a text editor.
The coordinates for each node are listed in the text of the *.MIF file.

Cindy
MapInfo Technical Support

Query record coordinates of points

A colleague of mine has a point table which was brought into MapInfo
via DXF. She needs to extract the x and y co-ordinates from each point and



place them in 2 columns in the browser table (these are only held internally at
present).

From Table>Maintenance>Table Structure, select the table to edit.  Add 2
fields, east and north and make them Float type.  Click OK.  For Table>Update
Column, select the table to edit, the select the east field, and in the value box,
type
CentroidX(obj)
click OK.  Do the same for the north field and
type
CentroidY(obj).
Save your table

Jason Bryngelson

You can use Table>Update column and update the columns in your
table as follows:

Table to Update:    Tabname
Column to Update:   Longitude
Get Value from Table:    Tabname
Value:              Centroidx(obj)

You can repeat the process again for the latitude column using your Latitude
column as the column to update and centroidy(obj) as the value. Remember,
if your coordinates are not in a Longitude\Latitude coordinate system, you
need to change the coordinate system of the MapInfo application.  To do so,
open up the States map that come with MapInfo. Choose Map>Options and
click on the Projection button.  Choose from the list the projection that you
map is in.  Click OK to get back out to your map.  Then, when you issue your
Update Table statement, the coordinate will be returned in the correct
coordinate system.

Cindy M.
MapInfo Technical Support

Type the following into the MapInfo MapBasic Window , you should
get the coordinates of the points in NGR. You need the Set  Coordsys,
otherwise MapInfo returns the coordinates in Lat & Long.

Set CoordSys Earth Projection 8, 79, "m", -2, 49, 0.9996012717, 400000,
-100000 Bounds (-7845061.1011, -15524202.1641)
(8645061.1011,4470074.53373)
Select CentroidX(obj),CentroidY(obj) from Amenity into Selection
Browse * From Selection

Steve Culshaw

Query How to save a query



see 'Workspace, Saving a selection query using a workspace'

Query save sql query

How to save sql queries

A hidden but much unappreciated tool is BUILDSQL.MBX in your
mapinfo\tools directory. This tool will allow you to easily build, save and
execute ODBC queries.

Douglas Cubin

The tools that were developed by Kevin Mahoney (kgm tools found in
mapinfo freestuff), You will find a program call SQL Select Enhanced. This
will save your SQL to a text file and recall them as needed.

Tyrone Cobb

Query select and remove duplicate records

I have a table with a number of duplicate records and am using SQL
Select (Group by) to get rid of the duplicates.  What I don't  understand is
why I lose the objects with my new table.  I've specified obj in the
selectcolumns.  When I open my new table and specify new mapper the file
will go to browser.  Does anyone know why this is?  When I make other
selections with SQL Select >(but not Group by) the objects are still
associated with the browser.

When doing a group by, it does get rid of the graphic objects that are
associated with the records in the table.  This is because you may have
duplicate records that have the same data value but don't have the same
object associated with them.  If you want to reassociate the object back with
the record after you have done your group by, you can do the following:

1.  Before doing your query, add an integer column to the table.
2.  Update the added integer column with ROWID.  For example,

Table to Update:  Tabname
Column to Update:  Addint
Get Value from Table:  Tabname
Value:  Rowid

3.  Perform your query making sure to include the added integer column in
your query.
4.  Save a copy of the resulting query table through File>Save Copy As under a
new name, i.e. NewTab.
5.  Open the saved query table.
6.  Perform another SQL Select to rejoin the objects back with the table.
For example,



Select Columns: *
From Tables: Tabname,NewTab
Where: Tabname.addint=NewTab.addint

The resulting query will have the objects associated with the table again and
will not have duplicates in the table.

MapInfo Technical Support

Query, select lines by colour

I have a file with a single layer. The lines have been assigned two
different colours to designate separate classes of objects. I wish to separate
these two object classes by querying by colour and writing out to separate
files.

Yes. In the SQL select window, the 'where' clause should read:
StyleAttr (ObjectInfo (obj, 2), 4) = 255
That is, if your line colors are 255 (bright blue). The ObjectInfo function
extracts the pen from the object, and the StyleAttr extracts the color from
that. If you need to know what the various colors in your objects are, put this
in the 'columns' field in the SQL select:
StyleAttr (ObjectInfo (obj, 2), 4)
And it will list all the colors of all the pen (or symbol or text) objects in your
map.

These numbers that represent colors are made up of three primary colors:
red, green and blue. Each has a range of 0 to 255, and a full color number is
calculated like so: R*65536 + G*256 + B. So, for example, a very light yellow
would be 192*65536 + 192*256 + 0 = 12,632,064.

Bill Thoen

Query select objects within a region

How would I select all the objects such as rivers which flow through a
region such as a county?

Select * from rivers where obj intersects  (select obj from district where
name like "Reading%") and get all the sections of river in the Reading district
area.

Steve Culshaw

To select objects (eg. rivers) within polygons (eg. districts) of a given
code, wouldn't it be easier to say:

Select * From Rivers, Districts Where Rivers.Obj Intersects Districts.Obj And
Districts.Code = "My District"



You could substitute the * with columns from the rivers table if you like.

Stephen Winter

Query Select Objects within a set area
I want to select numerous objects with a fixed area of "x", the

onlycolumn I have in the table is ID.  I use QUERY, SELECT,
OBJ=AREA(x)and Mapinfo reports back that there is a syntax error.  What is
my folly??

The syntax for Area is a follows:
Area(obj_expr, unit_name)

Obj_expr is an object expression
unit_name is  a string representing the name of an area unit(e.g. "sq km")

Here is an example of a select statement:

Select Area(obj, "sq mi") from Us_cnty into Selection

Cindy
MapInfo Technical Support

If I understand your problem correctly, try
Area(obj,"sq mi")=x
in the Where clause.  Substitute the correct units if needed.

Jason Bryngelson

Query select polygons  by colour

I'm trying to select all the polygons having the same color in a layer.

Select * from tab_name where
styleattr(objectinfo(obj,OBJ_INFO_BRUSH),BRUSH_FORECOLOR)=
couleur and
str$(obj)="region"

MapInfo Technical Support

Query select  objects by character.

I need to select all the objects that have records that begin with an "A"
in a browser. The field is of Character 10. For example - I have got records
ABC and ADG that I want to select. So how do you select wildcards - for
beginning, middle and end's of character strings.

If your table is called "Stuff" and your field is called "Name" then to
select any records where Name begins with "A", use the SQL select option
and enter:



select * from Stuff where Name like "A%"
or select * from Stuff where Left$(Name,1) = "A"
You can use the "like" clause with the wildcard '%' when you don't know the
exact position of the search string. In other words, for anything with "ABC"
somewhere in the middle, use
select * from Stuff where Name like "%ABC%"
or select * from Stuff where Name  like "%A"
gives all records ending in 'A' If you know the exact position, then you can
use the Left$(), Mid$() and Right$() functions in the "Where" clause in either
the MapInfo SQL Select dialog or in MapBasic.

Bill Thoen

In SQL your wildcards are % (percent) for many characters and _
(underline) for a single character. SQL is case-sensitive in strings. You can
select your records by using a SQL select with a 'like' clause.  When using
wildcards in SQL you need to use a 'like' clause in your where statement.
Single Char:select * from myTable where myField like "A_B" finds anything
starting with capA, followed by any single char, and ending with cap B

Roy Stewart

Not exactly. It is "capital" sensitive. If you put in...Where MyColumn like
"abc%"...it will find "abcde" or "ABCDE" (it is not case sensitive to the high
bit). But if you put in...Where MyColumn like "ABC%"... you have forced the
high bit to be on, thus it will only return "ABCde" or "ABCDE".

Steve Wallace

Query wildcard queries

Within a database we created a character column which is basically
made up of the format eg 222/0158 where the 222 identifies a particular
parish in Scotland and the 0158 identifies a  particular farm unit.  I have tried
selecting a particular parish by using the SQL select for "222/*" and while the
syntax was accepted as correct no records were selected.

Actually, they are using the typical SQL syntax commands for strings.
You need to do two things:

1) Replace your "=" to "Like"
2) Replace your "*" with "%" and "?" with "_"

Your syntax should look like this:
Select * From MyTable Where MyCol Like "222/%"

Steve Wallace



     The * doesn't work in this case.  Use the left function.  Assuming the field
is named PARISH, this is the syntax
select * from TABLENAME where left$(PARISH,4)="222/"

David F Forsythe

R
Raster Images

see also Video

attaching raster images to objects in Mapinfo tables
Also see; using MapInfo's Pixshow.mbx to add images to tables

In Mapinfo, under the table structure there is only character, decimal,
small integer, float, date and logical. Is there any way I can attach a image
say gif/jpg file to a line/polygon/node ?

You can write a MapBasic program to accomplish this.  There is a
sample MapBasic program on the MapInfo web site,
http://www.mapinfo.com/free/mb4.html.  The program is called PixShow and
gives an example of displaying bitmaps on the screen when you click on a
point on the map.

Cindy
MapInfo Technical Support

avoiding misaligned adjacent registered raster images

I have a set of planimetric images for New York. When I try to view the
images together (side by side, each image is a section of the whole) the
newly registered (on opening) image seems to push the other image out of
alignment. Any ideas would be appreciated.

If the rasters images are not registered in true vertical/horizontal it will
happen. Mapinfo will skew the rest of the map / images in accordence with
the newly registered map. Take enough care while you are registering the
maps. Ensure
1.   you have as many registrations points as possible,
2.   there is no error (pixel error),
3.   the image registration is in true vertical / horizontal.
You may consider to make all the rasters transparent so that there is no
patches on the edges if they overlap. But you cannot have more than one
color as transparent.

Bali,

using MapInfo's pixshow.mbx to add images to map tables.

I downloaded pixshow.mbx but it does n't seemed to work. It appeared
on the menu but where should I specified the image directory ? if I click on
the object does it show the pix?



To use this program, you would first run pixshow.mbx.  You need to
have the table open that you want to click on the map and display the raster
image. This table needs to have a column in it that specifies the directory and
name of the bitmap you're trying to display for each object.  Once you run this
program, it will ask you for the name of the table and the column that
specifies the path and name of the bitmap.  Then, when you click on an
object on the map, it will display the bitmap picture.

Cindy
MapInfo Technical Support

using the transparency control with raster images

MapInfo will read GIF 89a format. Will it recognize the transparency
and allow objects to be place behind the raster image? When I attempt this
my screen won't display anything under the image layer.

If you check "Transparent" from the Table>Raster>Adjust image Styles, it
will recognize the transparent color set in your GIF89 image. However, image
transparency is disabled if you have UseTrueColor=1 set in your Win95
registry (but instead you get up to 256 true colors per mapper, and not that
ugly dithered palette.)

Bill Thoen

MI allows for one color to be transparent in a raster image, regardless
of having saved it as a gif or not.  Go into Table>Raster>Adjust Image Styles,
then click on transparent, then choose the transparent color. This works for
displaying, but for large scale printing MI (using HP PostScript drivers, at
least) generates HUGE files, e.g. 300MB vs 20MB when not using
transparency.

Marc C Bate

Regions

How to find the coordinates of nodes in a region
See Query; Query to record coordinates of nodes in a polygon/region.

How to combine points and polygons
see 'Tables:Combining related points and polygons from separate

tables into a single table'

How to create a polygon at the intersection of lines
see Buffer; Creating polygons at the intersections of lines.

How to create a ring buffer around a region?



  I have a Region (Region1) which has been buffered to create
another Region (Region2).  The new Region (Region2) has been saved as a
separate table.

I now wish to create a region which represents, and only represents,
the new buffered area rather than Region1 and the buffer area together i.e. to
create a ring around Region1. Ideally I would like to also create concentric
rings of a user specified distance leading away from  Region1.

Assumption - The map is already been converted to regions.
    STEP 1.  Select the larger region object and CONVERT TO POLYLINES.
    STEP 2.  Select the island region object and CONVERT TO POLYLINES.
    STEP 3.  Select the larger polygon and SET TARGET.
    STEP 4.  Select the island polygon and do COMBINE.
The DATA AGGREGATION box came up.  If your table is strictly graphical
(no tabular fields), the click on NO DATA, then choose OK.
     STEP 5. CLEAR TARGET
     STEP 6. Select the larger outside polygon and CONVERT TO REGION.  The
result should be donut region EXCLUDING the island.
     STEP 7. Select the island and CONVERT TO REGION.
After the island has been converted to a REGION, the larger region should
still be EXCLUDING the island which is what we want.
    STEP 8. SAVE TABLE

Jennifer Clark

How to select regions by fill style
see 'Lines, select objects by line styles'

How to calculate areas of polygons
see 'Query, calculate areas of polygons'

How to select objects within a region
see 'Query, select objects within a region'

How to select polygons by colour
See select polygons  by colour

S
Scalebars

using standard scalebars in  projections other than long / lat

Is there a way to get scalebar.mbx (included with MI4) to draw proper
scale bars for maps that don't use the default lat/long projection?  I am using
an equal area projection of a map of Canada, and the scalebar is distorted.  I
would be grateful for any suggestions about how to fix this problem.

I have two suggestions.  One way is to duplicate your map window.  In
the duplicate, change the map projection to lat/long.  Run the scalebar
program.  Turn off all layers except for the cosmetic layer where the scalebar



is located.  In your layout window you place the duplicate window on top of
your original map window.  You need to set the line style and fill pattern for
the top window to be NONE (use the region style button to do this).

An alternate approach is to acquire a package that can create nice scalebars,
titleblocks, put in grids of any map projection.  We have two products, one
called Discover and the other EarthMap that have these capabilities plus
many other functions.  These run inside of MapInfo, extending its capabilities.
If you are curious, please go to our website at http://www.tms.bc.ca and
check out our software section.

Karl

Symbols
also see points

how to select objects by symbol style
see 'select objects by line styles

editing and creating custom symbols
see 'Custom Symbols, Creating and using custom symbols'

how to edit and create a symbol font

Can a MapInfo Symbol font be edited or created.

There are several symbols that can't be edited, picking one of them
gets a grey diamond, circle or square and I could not do anything with it.
Using the symbol.mbx then selecting the tools pull down menu once I
selected a symbol that was editable, it appeared in the mapper window and I
was able to use the tools to fill in colors and customize the borders, etc...then
I had to make sure to use the tool pull down menu and select save symbol
and not to try to save it as a bitmap through the file menu (that did not work).
The symbol saved automatically and was ready to use. The method I used of
editing a pre-existing symbol and saving it, saved over the original symbol.  If
you try this, keep that in mind. I could not find a way of making and saving a
new symbol.  I did try to create a new symbol, but I wasn't able to get the
shape right, but in editing a symbol I could keep the shape and get multiple
colors etc...

Melisa Snoeberger

Make a selection of all the vectors of the symbol and copy them when
you are in editing mode and cancel the edit mode. Go in new symbol creation
mode and paste what you have copied.  You will be able now to modify it to
create a new one.

Arnold McRae

T



Tables

combining points and polygons in separate tables into a single table

Table One contains point information with associated data such as
reference no. and location. There are approx 750 records in this table. Table
two only has an i.d. no. and displays a series of polygons in the map window.
There are approx 500 records in this table.

When displayed in a map window the two tables overlay on top of
each other with every one of the polygons in table two having within it a point
from table one. There are however 200 points from table one that do not fall
within a polygon from table two.

What I would like to be able to do is to combine these tables so that
the point data is linked to the polygon data. I would also like the resulting
table to contain all of the point data that does not fall within a polygon from
table two.

First, choose Query>SQL Select and fill in the dialog box as follows:
Select Columns:     * From Tables:   Table1,Table2
Where Condition:    Table1.obj within Table2.obj
into Table:    Table3

This will produce a temporary table called Table3 that joins all the points with
the regions where the points fall within the region objects.  Then, choose
File>Save Copy As and save a copy of Table3.  Close Table3 through
File>Close Table and open up the copy you saved.  We will call this copy
Table3a.
Then, do another SQL Select to select all the points that fall outside the
region objects.
Select Columns:     * From Tables:        Table1
Where Condition:    not obj partly within any(select obj from Table2)
into Table:    Table4
This will produce a table called Table4 that selected all the point objects that
fall outside the region objects.
Choose Table>Append Rows to Table and fill in the dialog box as follows:
Append Table:  Table4 To Table: Table3a

Table3a will now have all records from both of your selections.

Cindy
MapInfo Technical Support

multiple Column Update

I have a table that stores boundary information. This table has approx.
230,000 records and I need to update multiple columns in each record.



Through MI I can only update one column at a time, does anyone know of a
way to update multiple columns simultaneously.

The KGM utilities include a multiple column update tool

number objects in table by order

I want to number a bunch of points, starting at 1 to what ever in a
column, how do I do that? I can't seem to find it in the help. Currently I start it
in a spread sheet doing data fill, but figure there is a way in Mapinfo.

You can do it a couple of different ways
1) Do a "Table>Update Column and then filling in "RowID" in the Value text
box.
2) Download my free NumberIt.mbx Program that gives you a bit more
control over the process and a nice button on the toolbar.  See the Software
section of my web site (http://rampages.onramp.net/~vaxcrshr) for
NumberIt.zip - a small file that includes instructions.

James Marlow

There is an ID inherent in the database already.  You can access it
with the identifier ROWID.  If you sort the table, you will lose this identifier
(they get re-asigned to the new order).  Also important:  If you join the table
to another table, and want the resultant table to contain the originating table
ROWID, you will also lose it.

Try this:  Create a new column called ID, or whatever you like.  Then update
that field to equal ROWID.  Then save the table.  You will now have a
permanent unique ID for each record which can be forwarded to other tables,
etc..

Rob McGrath

update column with row number

I want to retrieve the row number of the current record in a table.  The
table with which I am working does not have a unique ID -  I would like to use
Update column along with a function  that returns current row number to
create one.

You can update a column in your table with the row number as
follows(this example assumes you have an empty integer column in your
table):

Update tabname set row_num=rowid

Row_num is the empty integer column and rowid will update that column and
number each record sequentially.



MapInfo Technical Support

Templates

Creating a template
see 'Workspaces,Creating templates using a workspace'

Toolbars

Displaying the toolbar options dialog box

Can the toolbar locations be reset and saved

 Try the menu Options >Toolbar...     selection

At the bottom of the "Toolbar Options" dialog box is a check box, "Save as
Default"

If you check this box (click), and exit MapInfo (whenever you are done), the
toolbars will be 'defaulted' into the positions specified in the “Toolbar Options”
dialog.

This won't stop buttonpads from detaching from the menu bar, but it
makes fixing them easier. Open your MapBasic window and put this in it:

alter menu "Help" add  "Arrg!!! \tAlt a/W@a"  calling 605

This adds a menu option (called "Arrg!!!") below the Help menu that calls the
function that display the Toolbar Options dialog box which controls
toolbuttons (normally found in two clicks under Options/Toolbars). The "\tAlt
a/W@a" just adds an accelerator key to this option (alt-a) so that you can
activate it in a single keystroke.

Add this menu command to your mapinfo.mnu file and it will come up as a
standard menu item every time. (WARNING! If you don't know what you're
doing with the mapinfo.mnu file, you'd better not touch it. Screw this up, and
MapInfo doesn’t run.)

Bill Thoen

U
V
Video

attaching a video clip to an object in a table

I believe there is a mapbasic program within the KGM utilities called
multimed.mbx which can attached picture/movie to an MI record



I've recently been working on a small MapBasic generic utility called
"MediaLink" which enables most windows based programmes (that accept
filenames as parameters to autoload) to be automatically loaded when a
single item in any prepared table is selected. It is much more flexible than
KGM / pixshow, multimedia and works a treat with things like (Mediaplayer -
AVI's, MIDI files etc.) Paintbrush/Paint/Paint Shop Pro pictures, Sound
Recorder, Word for Windows, Excel etc.). It can even automatically load
HTML pages in Windows Explorer - either intra or internet with no hassle.
Also when enabled, it works with any number of open tables and just a single
selection of points/lines/polys/text - no matter how you got there (pointer
select, boundary select, SQL etc.).We're not marketing this / sorted out a
price so make me (mike@dataview-solutions.co.uk) a smallish offer (to cover
costs) directly if you're interested - Its nothing fancy but just does the flexible
job required? It's currently 32-bit and tested on 4.1.x on Windows '95 and
more than measures up to ARCVIEW's in-built Hotlink function.

Mike Eden

Granted column creation and inserting of .mov or .avi filenames won't be
automatic... all you have to do in your code is "Run program
"c:\windows\mplayer.exe sample.mov" where sample.mov is a sample video
clip. You also would want to figure out the autoplay switch. I think it's "/p"...but
I’m not sure. Mplayer is a Microsoft movie player that ships with the Microsoft
OS.

Serge Dumoulin

W
Web Publishing

displaying  maps on intra/internets

Due to working in a paper less office, what is the best way to display
maps on the Internet/Intranet? Craig Parada seems to have done an
excellent job of this. http://www.ipac.net/csj/planning/pages/datzone.htm

Well, it is a bit tedious, but it can be done!   Yes, these were created in
MapInfo, and we did use  Adobe Acrobat 3.0.  The page was put together in
Front Page. It really was a trail and error process.  We set up workspaces
with the City broken into a grid of "quads", and set a frame up for a
"standard" view.  Each quad was set up, then printed to a file.  An overall
map was also set up (with most of the detail removed), and printed to a file.
These print files were brought into Acrobat, and processed.  The overall map
was set up with reference links in Front Page.  I didn't get very involved in this
part. With a smaller geographic area, this would a little less time consuming!
Anyway, it can be done.  Since we print maps anyway, and have workspaces
already set up. These can be brought up and sent to a file instead of a
printer.  It still takes a lot of time!



Craig Parada

Take a look at some of my maps:

www.bellsouthdcs.com/coverage.html
www.bellsouthdcs.com/gsmcovmap.html
www.bellsouthdcs.com/gsmcovmapa_f.html

The key to showing your maps (non-interactively) on a webpage is as follows:

1.  Clarity, Brevity and Color.  Make your maps clear, simple and bright.  You
want them to tell exactly the story that you define.  No more, no less.

2.  Keep all text (on the map itself) to a minimum.  The map can be described
in the text alongside of it.  Remember that you may very well be looking at
your map on a high quality monitor that many people who visit your site may
not have.

3.  After you have created the map to your liking, use file>save window as.
Rather than using the "Same as Window" default, alter your image size so
that the largest side is about 10 inches (the shorter side will change
proportionately).  This will give you a large, clear image which can always be
reduced in size when setting it on your Internet/Intranet site.

4.  Save the file as a .JPG or .TIF - these have given us the clearest images
while utilizing the smallest amount of file space.

Jo Jordon

Workspace

change name in workspace titlebar

Can someone please tell me how to name a layout window in
Mapinfo. I want more than calling a window Layout 1, 2, 3, etc. I know how to
change the  name of a window.

In the MapBasic window type in the following command:
Set Window FrontWindow() Title "Fill In Title Here"
Works with layout windows as well as mapper windows and the changes
should be saved in your workspace.

James Marlow

correcting workspace to avoid opening errors if a table is moved.

Our problem has been if I move a particular table from its stored
location on one drive that is used in several workspaces to another. When I



go to open a workspace which contained that table and I wasn't aware of it, it
won't open.

The only answer I am aware of is to manually use a text editor to put
the word "interactive" after the table name(s) in question in a workspace .wor
file. eg.
Open Table "S:\WASHINGT\DATA\Wa_dec" As Wa_dec
Open Table "O:\WASHINGT\BOUNDARY\Wa_cnty" As Wa_cnty Interactive
 MapInfo will then (after searching forever for the table on your hard drive)
offer an open table dialog box and allow you to select an alternative table in
place of the missing one. This can cause a workspace to take a
looooonnnnnggg time to open if your search path contains a lot of tables. Be
patient. You can also just edit the Open Table tablename line in the
workspace to point to an existing table.

Erica Wieland

The way that I get around the problem of people having directories
mapped differently, is to use the network name in the workspace rather than
the mapped name. ie //stdc/gis/layers/map.tab vs m:/layers/map.tab.This
hasn't caused a problem for me yet.

Mike Taylor

correcting workspace failure to open table

What happens to your workspace when you alter(change column
name), delete, or rename a table (within that workspace)and how to avoid or
fix such problems.

First, start with What is a workspace?

A workspace is a list of MapBasic commands that are used by MapInfo to
reproduce a particular user session.  A session includes open tables and
settings at a given time while MapInfo is running.

With this in mind, I suggest checking on Using the MapBasic Window in the
Reference books.  This will give you an idea of what the commands are and
how they are used.

Then, follow the advice on p. 284.  To solve workspace problems, open the
workspace in any text editor and make the necessary changes.  In the
MapInfo classes I teach we use Notepad or Wordpad for ease of access.

By using the MapBasic Window and the text editor, you can copy the
appropriate commands and paste them into the workspace as needed.

Andrew Greis



creating paper templates using a workspace

Is there anyway to create 'templates' for standard layouts in MapInfo?
I'm thinking of something similar to Word's templates for a memo, fax, etc.

Not quite as neatly as a Word template, but if you set up frames on a
layout, labels and other marginalia, and save the view as a workspace, then
you can open that workspace at a later time, and assign whatever map views
you want into the open frames. If you have a series of maps to do and really
don't want that hand-crafted, one-of-a-kind look to them, this is the way to do
it.

But there is a trick to getting map scale right. You'll find that getting the frame
contents to be at a scale of your choosing can be frustrating (change the
scale, and the frame changes size, ruining your layout, etc.) However, when
scale matters to me, what I do is first size the layout frame to some known
size (just click on it to bring up the Frame Object dialog, and look at and/or
set the window width and height). Then I'll size the map window that contains
the view I want in that frame to either the same dimensions or some even
multiple of that. Then I set the scale and position the image in the MAP
window to be what I want. This way you can affect the layout scale without
having the size of the layout frame changing all the time.

For example, suppose I have a frame that I want in landscape orientation that
is 40" x 30", and suppose I also want whatever is in this frame to be at a
scale of 1" to 5 miles. So I draw a frame in the layout window approximately
the size I need, and then click on it and manually set the frame to *exactly*
what I want. Then I set the contents of the frame to be the map window I
want (this is the Window: prompt in the Frame Object
dialog). Now I go to the map window and select it. Then enter in the
MapBasic window:

set window FrontWindow() width 4 height 3

This command resizes the map window to a known size, in this case 1/10th
of my layout map frame's size. Now go back to the now resized map window.
Click on the Change View tool (or Map/Change View menu) and set the scale
to 1" = 50 (since the map window is 10 times smaller than the one in the
layout frame, the scale must be 10 times smaller too - remember scale is a
ratio or a fraction, so 1:50 is SMALLER than 1:5). The view in the layout will
now be a perfect 1" = 5 mi.

Bill Thoen

deleting old workspaces

Is there a way to Delete  old or unusable workspaces from within
MapInfo.



There already is a way--thanks to Microsoft . If you open the Open
Workspace dialog box, highlight the file you want to delete and press the
Delete button. Note that this does NOT work for MapInfo tables; if you use
this procedure you will only delete the .TAB file, not the other associated files.
I use Open Table, then drop table in the MapBasic window to delete tables.
In windows 95 in any open or save dialog, just click on one or more files and
hit the delete key . You can also rename files the same way.

Erica Wieland

failure to open workspace errors

I've achieved the required output and saved the workspace, restoring
it brings up a wonderfully informative message :-
(c:\mapinfo\data\sector.wor:7) Found [where] while searching for [(].
Clicking OK informs me that Sector.wor was not completely opened

We've experienced the workspace error problem so much that I came
up with a document to assist co-workers.  I did however solicit help from this
list to achieve the following document.  The only thing I did not copy over
from the document was the "example workspace" but you will see this when
you open in a text editor.

What to do if a workspace will not open

What is a workspace?
The workspace is a list of all the tables and windows you are using, stored in
a file with the extension *.wor.  The workspace keeps track of what windows
you have open, the size of the windows and their position on the screen,
thematic maps, cosmetic objects labels, and styles for fonts, symbols, lines
and fill patterns used to display objects.

Reasons that a workspace may not open:
The structure of a table (column has changed)
The table is renamed
Location of table moved

When you change the name of a MapInfo table that is listed in a workspace,
you invalidate that workspace.  Table names are stored in the workspace file.
If you change the name of the table, the workspace does not know how to
find it.  For example, you might create a workspace called customer.wor
which contains the states table.  If you later rename the states table to
America, MapInfo will not be able to open the customer.wor workspace.  It
will try to open states table and not be able to locate it. When you change the
name of a column that is listed in a table, you again invalidate the workspace.
When you rename a column in a table, the workspace(s) that may contain
this table will need to be corrected in order for the workspace to open.
To correct workspace problems:



1. Make a note of the information window when opening up your
workspace: write down the column reference and the wor:# that is displayed
as this refers to the line in the workspace where the error is.
2. Close your workspace in MapInfo (DO NOT SAVE).
3. Open the workspace file in any text editor where you will manually
change the table or column names.  You can use MapBasic, Word,
Notepad,WordPad, BBEdit or any text editor with a "search and replace".
MapBasic and Word are preferred as they will allow you to find the line
(wor:#).
4. Change Paths if necessary.
5. Change table names if necessary.
6. change column names if necessary.
7. eliminate references to unneeded tables if necessary.
8. eliminate references to unneeded columns if necessary.

When changes are done save the workspace in your text editor close it, and
then reopen your workspace in MapInfo.  Don't be alarmed if other errors
occur, just start from #1 and proceed though until your workspace fully
opens.  If the next error wor# is higher then the last you are on the right track.

Note: After you have exhausted the list above and the same error
continues (the same wor:#) , last resort is to place a single quote (') at the
beginning of the line in question.  This will "comment out" that line and should
make the workspace "skip" and move on to read the remaining file. This
alternative could become a little tedious because you may have to "comment
out" more then just the error line (IE: the reference to the layer itself).

Cathy Galgano

place the current  date in a workspace

How could a workspace set as a template be set to display the current
date

Set up a layout as a template - place on a piece of text representing
the date. and save it as a workspace. Then in a file editor open the
workspace file and at the place where you see the Create text statement for
the text you placed on the layout - The Create text should look like this in the
workspace file : -

Create Text
str$(Curdate())
(1.9535,8.0396) (3.009,8.3229)
Font ("Arial",0,18,0)

the Str$() converts the date to a string. You could also do the following :

Create Text
 "Date : " +  str$(Curdate())
 (1.9535,8.0396) (3.009,8.3229)



 Font ("Arial",0,18,0)

This will put the word date in front of the word date !

When you next open this as a workspace today's date automatically will be
placed  on the layout !

Martin Hodder

saving a selection query using a workspace

To save the query itself, but not the result of the query. The actual
sorting would have to be done at each application but the procedure does not
have to be rewritten each time. I call it saving a script (instead of a macro)

Open the MapBasic Window before stating your selection. Make your
selection and all you need. Save the contents of the MBWindow as a text file.

Then 2 possibilities:

a/ reuse this text file by importing it into the MBW (you need to open the file in
a text editor, copy and paste) and run it after making the necessary
adjustments

b/ transform it into a .WOR file (just add the header) and RUN APPLICATION
"\....\xxx.WOR" from the MBWindow.

All this and more is explained in my MiniGuide to the MapBasic Window

Jacques Paris
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