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2 Basic Skills

Now that you’re familiar with Photoshop, you’re probably 

eager to get right into it! This chapter covers some of the 

basic tasks that Photoshop users should master, such as 

resizing and rotating documents and layers, working with 

masks, creating curves and custom shapes, working with 

transparent images, and more!

This chapter covers fundamental solutions that we’ll call 

upon throughout the remainder of this book. And as an 

added bonus, I’ll show you how to create a coupon box with 

dotted borders—no doubt you’ve always wanted to make 

your very own one of these!
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Placing a Graphic in your File
Often you’ll want to import existing graphics and artwork into your Photoshop 

document. A problem for Photoshop? Not at all—in fact, there are several ways you 

can do this!

External graphics can be placed in Photoshop as raster layers or Smart Objects. 

First, I’ll show you how to place these graphics, then we’ll talk about the difference 

between raster layers and Smart Objects.

Solution
	 placing artwork from a web page

	 Copy the artwork from the web page, then select Edit > Paste or press Ctrl-V 

(Command-V on a Mac) to paste it into your Photoshop document. Photoshop will 

create a new layer containing the artwork, or place it into a selected empty layer. 

The artwork will be on a raster layer.

	 placing artwork from flattened image files

	 A flattened image file—such as a GIF, JPEG or PNG—contains artwork on a single 

layer. Open the file in Photoshop and use Select > All or press Ctrl-A (Command-A) 

to create a selection of the entire document. Click on your Photoshop document 

then select Edit > Paste or press Ctrl-V (Command-V) to paste it. Photoshop will 

paste the document into a new or selected empty layer as it does when pasting 

artwork from a web page. The artwork will be on a raster layer.

	 placing layers from a different Photoshop document

	 Position the document windows so that both are visible. Select the window of 

the document you wish to import from, to bring up its Layers palette. Select and 

drag the necessary layers over to the new window and release the mouse button 

when you see a thick, black outline around the window. This will copy the layers 

across as shown in the example at the top of the next page. The copied layers 

will retain their original properties.
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Copying a layer from one Photoshop document to another

	 placing artwork from Illustrator

Paste dialog box

	 Open Illustrator and select the artwork you wish to export 

to Photoshop. Copy the artwork using Ctrl-C (Command-C 

on a Mac). Switch to Photoshop while Illustrator is still 

open and paste your copied artwork using Ctrl-V  

(Command-V)�. 

A dialog box will appear, asking you whether you wish to 

paste the artwork as a Smart Object, Pixels, Path or a 

Shape Layer.

	 placing artwork as a Smart Object

	 Select File > Place and choose the file you wish to import. Click Place to import 

the file into your Photoshop document as a Smart Object. For PDF and Illustrator 

files, Photoshop will display a dialog box that asks you to select the pages you 

wish to place. Choose the pages you want and click OK.

The bounding box for an image 
pasted as a Smart Object

	 The Smart Object will initially be placed with a 

bounding box surrounding it, as shown here. You can 

use this bounding box to move, rotate, scale, or make 

other transformations to the object. When you’re done, 

double-click inside the bounding box to commit the 

Smart Object to its layer.
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Discussion
Smart Objects
A Smart Object is an embedded file that appears in its own layer in Photoshop. 

A Smart Object layer is distinguished by an icon that overlays the thumbnail image 

displayed in the Layers palette, as shown in the example below.

Smart Objects are different from other layers because they are linked to a source file 

(e.g., an Illustrator file, JPEG, GIF or other Photoshop file). If you make changes to the 

source file, the Smart Object layer will also be updated with those changes.

Smart.Object.layer

Raster.Layer

Raster layer vs Smart Object layer

In contrast, raster layers (or regular layers) are fully editable, so you can draw and 

paint on them, fill them with colors, or erase pixels. Unlike Smart Objects, where you 

retain image quality, if you resize a raster layer smaller, you will lose information.

This is demonstrated in the example on the next page, which shows the result of 

a Smart Object that has been decreased in size, then resized back to its original 

dimensions. The same steps, when applied to a raster layer, produce an image that is 

blurred and of lower quality.
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Smart Object resized to 50% raster layer resized to 50%

Smart Object resized to 25% raster layer resized to 25%

Smart Object resized back to 100% raster layer resized back to 100%

The difference in image quality when resizing a Smart Object compared to a raster layer

Because Smart Objects are linked to an outside document, you can resize them 

without losing the original image data. While you can apply layer effects and some 

transformations to Smart Object layers, you cannot actually manipulate (paint, draw, 

erase) their pixels because they are not editable from external documents. You can 

open the original source file for editing by double-clicking on the Smart Object icon.

Rasterizing
You can rasterize Smart Objects by right-clicking on the name of the Smart Object 

layer and choosing Rasterize Layer. This will break the link to the original source file 

and treat the layer as an ordinary raster layer.
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Resizing a Document
Solution

Image Size dialog box

Bring up the Image Size dialog box by 

selecting Image > Image Size or pressing 

Ctrl-Alt-I (Command-Option-I on a mac). 

You can resize the document by altering 

either the Pixel Dimensions or the Document 

Size. Use the former when resizing images 

that will be used on screen (such as images 

that will be used on a web page), and the 

latter when resizing images that will be 

printed. You can maintain the original 

document proportions as you resize the image 

by checking the Constrain Proportions checkbox. To scale layer styles (drop shadows, 

strokes, etc.), check the Scale Styles checkbox.

Resizing a Layer or Selection
Photoshop also lets you resize layers or particular 

portions of a document without affecting the 

overall size of the document.

Resizing an element using corner handles

Solution
From the Layers palette, select the layer that 

contains the element you wish to resize. 

If the layer contains other elements that you 

don’t wish to resize, select your element using 

one of the selection tools.

After making your selection, use 

Edit > Free Transform or press Ctrl-T 

(Command-T on a Mac). A bounding box with 

handles will appear around your selection. 

Click and drag these handles to resize the 

element, as shown in this example. To keep the transformation in proportion so that 

the image does not appear squashed or stretched, hold down the Shift key and resize 

it using the corner handles.
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You can also resize the element to a specific width or height using the options 

bar. In the example below, I clicked the Maintain Aspect Ratio button (signified by 

chain links), then specified the width—this changed the height of my element 

automatically. If I had not maintained the aspect ratio, only the width of my rose 

would have changed.

Press Enter or double-click inside the bounding box to apply the transformation.

Using the Free Transform options

Discussion
When you resize different layer types, you get different results.

	 Vector shape layers, such as text or shape layers, can be resized larger or smaller 

without loss of quality.

	 Smart Objects can also be resized larger or smaller without loss of quality, 

depending on the original file. If the original file is a vector graphic, the Smart 

Object can be resized without ever losing quality. If the original file is a GIF or 

similar, the Smart Object can be resized up to the size of the image dimensions, 

above which it will start to lose quality.

	 Raster layers or selections can only be resized smaller. Resizing them larger will 

usually result in loss of quality.

Rotating a Layer or Selection
Earlier, you may have used the Free Transform command to resize layers and 

selections, and thought it was pretty swell. What you probably weren’t aware of 

at the time is that the very same command can also be used to rotate layers and 

selections!
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Solution

Rotating a selection

Make a selection or choose the layer you’d like to rotate. 

Select Edit > Free Transform or press Ctrl-T (Command T), 

and move your cursor outside the bounding box. 

You’ll see that it turns into a curved, two-headed arrow 

as shown in this example. You can click and drag this 

cursor to rotate the elements within the bounding box.

Hold down the Shift key to constrain the angle 

movement to 15-degree increments. You can also set 

a specific angle of rotation (between −180° and 180°) 

in the Angle text box in the options bar.

Setting the angle of rotation in the options bar

TIP  �Rotation 
Alternatives

For 90- or 180-degree rotations, 
you can select Edit > Transform 
and choose from Rotate 180°, 
Rotate 90° CW, or Rotate 90° 
CCW.

Press Enter or double-click inside the bounding box to complete the transformation.

Using Drawing Tools to Create Lines
Solution
Vertical and Horizontal Lines
Using the Brush or Pencil Tool (B), move the cursor to the position from which you’d 

like the line to start on your document. Click and hold down the mouse button. 

Hold down the Shift key to constrain mouse movement to straight lines, then drag the 

cursor to draw your line. Release the mouse button to complete the line.
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Diagonal Lines
Using the Brush or Pencil Tool (B), position the cursor at the point from which you’d 

like the line to start and click once (release the mouse button this time). Hold down 

Shift and click on the spot where you’d like your line to end. Photoshop will connect 

the dots with a straight line.

Perfect Squares and Circles
Solution
If you’ve been a bit adventurous and tried your hand at drawing a few shapes in 

Photoshop, you’ve probably found that it can be difficult to draw a perfect square or 

circle “freehand.”

The solution is simple—if you hold down the Shift key while creating a rectangle or 

ellipse, Photoshop will ensure that the shape is a perfect square or circle. This works 

for both the selection and the shape tools.

Straightening the Edges of a Rounded Rectangle
It’s pretty straightforward to create rectangles and rounded rectangles using their 

respective shape tools. But what if you want a rectangle on which only some corners 

are rounded?

Solution

Creating a rounded rectangle

1	 Create a rounded rectangle using the 

Rounded Rectangle Tool (U) highlighted 

in this example. Be sure to use the 

Shape layers option in the option bar, 

not the Fill pixels option.
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Click

Clicking on the anchor points with the Convert Point Tool

2	 Choose the Convert Point Tool (P), 

which you’ll find in the Pen Tool 

flyout menu. Click on the path to 

show the anchor points of the 

vector shape. These are represented 

by small white squares, as shown at  

right.

3	 Click on each of the anchor points 

that make up the rounded corner 

you want to “straighten.”

This will change the curve into a “cut” corner, as shown in the example below.

The result of using the Convert Point Tool

Moving the corner point

4	 Select the Direct Selection Tool (A) and 

click on the top angled point (zoom in if 

necessary). Holding the Shift key to 

constrain the movement to a horizontal 

path, drag the point laterally until it  

aligns vertically with the bottom point, 

as shown in this example. You can move 

the point using the arrow keys for more 

precision if you prefer.

Deleting the anchor point

5	 To tidy it up, select the Delete Anchor 

Point Tool (found in the Pen Tool flyout 

menu), and click on the bottom point 

to delete it (as shown in this example) 

as it’s now become redundant. Voila! 

You’ve got a straight edge on a rounded 

rectangle!
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Curved Design Elements

Curved design elements

There may come a time when you find yourself 

wanting to create curved design elements such 

as those shown here. You’ve probably noticed 

that Photoshop doesn’t have a “curve” tool. 

Where does the curvy goodness come from?

Solution
The answer, in a nutshell, is the Pen Tool (P).

Creating curves involves learning how to draw your own vector shapes—it’s exciting 

stuff! If you’ve never used vector drawing tools before, you’re in for a treat!

Think back to your adventures with the pencil and brush drawing tools, where you 

clicked and dragged the mouse to create a shape. The Pen Tool is distinctly different, 

because instead of creating a shape, you are clicking and dragging to set anchor 

points and curve directions. It takes some practice, but mastering the Pen Tool is 

your key to creating delightful curves.

Let’s start with the basics. Before I explain how to make curved shapes, I’ll quickly 

go over how to draw polygon shapes with the Pen Tool—it’s quite easy, and sets a 

good foundation for drawing trickier curves.

Let’s draw a triangle. Each click with the Pen Tool will create a corner point. Click 

once to create the first point, then again to create the second point. A line segment 

will automatically connect these points to form a path. Click again to create the 

third point—a line segment will connect this to the second point, extending the 

path. Any subsequent points created hereafter will be connected with line segments, 

but since we’re creating a triangle, we only need three points. To make the triangle 

shape, simply close the path by clicking on the first point we created. You’ll notice 

that the cursor changes into a pen with a little circle when you move it over the 

original point—this means that you can close the path by clicking on that point. 

Alternatively, you could close the path simply by pressing Enter. The example below 

shows the four clicks described to create a triangle.

Using the Pen Tool to create a polygon
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Curved paths

Let’s have a go at creating some curves. 

This time, when you click to place a point, 

drag the mouse. You’ll see two lines 

extending from the point you’ve made. 

These are known as Bezier control handles, 

or “handlebars.” The length and direction 

of these handlebars will determine the 

curvature of the path that we are about to 

make. Release the mouse button and move your cursor to another position. Click and 

hold down the mouse button again. You’ll see that a path has been created between 

your first and second points, and that one of your handlebars has disappeared. If you 

drag your mouse, new handlebars will extend from the second point.

Adjusting the curve with handlebars

Choose the Direct Selection Tool (A) and adjust the 

curve by dragging the end points of the handlebars, 

as shown in this example.

Let’s try making the curved shapes I showed you on 

the previous page using these techniques.

Curved Shape 1

Step by step for Curved Shape 1

Follow along with the diagram opposite.

1	 Using the Pen Tool (P), click once to 

create a point.

2	 Hold down the Shift key and click above 

the first point to create a straight, vertical 

line.

3	 Keeping the Shift key down, click to the 

right of the top point to create a straight, 

horizontal line.

4	 Still holding the Shift key, click below the 

point on the right-hand side to create a 

vertical line segment a bit shorter than the 

first one we created.

5	 Position your cursor as shown. Press 

Shift and click and drag to create a point 

with horizontal handlebars.
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6	 Position the cursor as shown in step 6 in the diagram. Hold down Shift, click and 

then drag to create another point with horizontal handlebars.

7	 Click once on the original point to close the shape.

Curved Shape 2

Creating Curved Shape 2

1	 Using the Pen Tool (P), click once to create 

a point.

2	 Hold down the Shift key and click above 

the first point to create a straight, vertical 

line as shown.

3	 Keeping the Shift key down, click to the right 

of the top point to create a straight, 

horizontal line.

4	 Position the cursor as shown. Click and 

drag to create a point with handlebars, then 

hold down Shift and drag to the left to create 

the curved section.

5	 Click once on the original point to close the shape.

Curved Shape 3

Creating Curved Shape 3

1	 Using the Pen Tool (P), click once to create 

a point.

2	 Hold down the Shift key and click to the right 

of the first point to create a straight, horizontal 

line.

3	 Keeping the Shift key down, click above the 

point on the right-hand side to create a straight, 

vertical line.

4	 Hold down the Alt key (Option on a Mac). 

Click on the point you just created and drag 

the mouse up and to the left to create 

a handlebar.

5	 Click on the original point to complete the 

shape, but do not release the mouse button. Drag the mouse downwards and to 

the left, as shown in step 5 in the diagram, to create a handlebar. Use the Direct 

Selection Tool (A) to adjust your curve with the handlebars.
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Reusing Vector Shapes
As you work more with shapes, you may find that you’re often recreating the same 

vector shape. If it’s a simple shape—one that doesn’t involve outlines or layers—you 

can save it as a custom shape and access it later using the Custom Shape Tool (U).

WARNING  Save your Shapes!

After you create and add your custom 
shape, I recommend that you click on 
the small arrow in the custom shape 
flyout box and select Save Shapes… . 
This will save all of the custom shapes 
that are currently visible into a .csh file. 
This way, if you ever need to reinstall 
Photoshop or reset the preferences, 
you’ll be able to reload your shapes.

You’ll find that most customizable 
elements, such as layer styles, patterns, 
and brushes, provide menu options 
that allow you to save the custom 
settings you’ve created for them. Saving custom shapes

Solution

Defining a custom shape

1	 Select your vector shape 

by clicking on it with the 

Path Selection Tool 

(the black arrow).

2	 Select Edit > Define Custom 

Shape… .

3	 Type a name in the Shape 

Name dialog box and 

click OK.

New custom shape

4	 To use your shape, select the Custom Shape 

Tool (U) and scroll down the list of available 

shapes—you’ll see that your shape’s been 

added!
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Sampling Colors from Image Files
Solution
Open the image file in Photoshop. If you’re not able to open it in Photoshop (the 

image might be embedded in a document, for example), open it in an appropriate 

program that lets you view the file on your computer (such as a web browser, or 

Microsoft Word if the image is in a Word document).

	 If the image is open in Photoshop, select the Eyedropper Tool (I) and click on 

the image to grab the color. Your foreground color will be set to the color you 

selected.

	 If you’ve opened the 

image in another program, 

resize and move the 

Photoshop window so 

that you can see both the 

Photoshop window and 

the image simultaneously 

(this example shows the 

SitePoint web site next to the 

Photoshop window). Select 

the Eyedropper Tool (I). Click 

anywhere in the Photoshop 

window, and then drag the 

eyedropper out to the image 

you’re sampling color from. 

In the example shown here, 

I sampled the orange color 

from the SitePoint logo. You 

can see that this color has 

been set to the foreground 

color in the Color Picker.

Sampling a color from outside the Photoshop interface
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Finding the 
Hexadecimal	
Code for a Color
Solution
When you’re working on the 

HTML and CSS for a web site 

design, you’ll need the six-digit 

hexadecimal codes for the colors 

that you use. Photoshop makes 

these available to you in two ways.

TIP  Time-saving Tip

Some icons in the 
Info palette have 
a little arrow icon 
next to them. You 
can change the Info 
palette display options 
by clicking on these 
icons—this way, you 
won’t need to go 
through the Palette 
Options dialog, which 
saves you two clicks! Choosing the color display option

Using the Info Palette
As you move the cursor around a document, the Info palette will show you the value 

for the color over which the cursor is positioned. By default, the palette is set to 

display the RGB and CMYK values for colors. You can configure the information 

displayed in the palette by clicking on the small arrow on the top right-hand side of 

the palette

Selecting Palette Options… for the Info palette

and selecting Palette Options…. A dialog box 

will appear, displaying the options you can 

change. Among other things, you’ll see two 

drop-down menus to change the Color Readout 

—change one of these to Web Color.

The Info palette displays the hexadecimal color codes

This will display the hexadecimal 

codes for the color’s red, green, and 

blue values. String these together to get 

your six-digital hexadecimal code. In 

this example, the hexadecimal code is 

c9ad1c.
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Using the Color Picker

The hexadecimal color code displays in the Color Picker

The hexadecimal codes for colors 

are also displayed in a text field at 

the bottom of the Color Picker 

dialog box, as shown here. You can 

highlight the color code, copy it 

using Ctrl-C (Command-C on a Mac), 

and paste it into a style sheet or 

HTML file. Note that the hash 

sign (#) isn’t copied, so don’t 

forget to add that when you’re 

pasting the code!

Adjusting Layer Transparency
Solution
We talked about this task briefly in “Layer Shortcuts and Tasks” in Chapter 1. To 

adjust the transparency of a layer, change its opacity using the Opacity field in the 

Layers palette.

Changing the opacity of a layer

If you have the selection, 

move, or crop tools selected, 

you can change the 

transparency simply by typing 

a number—the opacity level 

will magically change to 

reflect that percentage!

Fading an Image into the Background
An effect that’s commonly used in web design is to fade a whole image, or part of an 

image—its edges, for example—into the background on which it sits. You can easily 

produce this funky effect using gradients and layer masks in Photoshop.
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Solution

Initial document

1	 Arrange your Photoshop document 

so that the image you wish to fade 

is on one layer, and the background 

color is on another layer.

Creating a layer mask

2	 Select the image layer and click on 

the Add Layer Mask icon (signified 

by a white circle on a dark gray 

background) at the bottom of the 

Layers palette, as shown in this 

example. A blank rectangular  

thumbnail will appear next to the  

layer thumbnail, representing the  

layer mask. Make sure this  

thumbnail is selected.

Selecting the Foreground to Transparent gradient

3	 Set your foreground color to black. Select the 

Gradient Tool (G) and choose the Foreground 

to Transparent gradient.

Adding the fade effect

4	 Apply the gradient by clicking at 

the bottom edge of the image and 

dragging the mouse upwards. 

Hold down Shift to constrain the 

gradient path to a straight line. 

Release the mouse button, and the 

gradient will be applied. Your 

fade effect is complete!
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Discussion
Layer masks are grayscale images that show or hide areas of the layers to which 

they have been applied. The gray tones on the mask reflect the transparency of 

corresponding areas on the layer: black areas are completely transparent and, 

therefore, invisible; white areas are not transparent at all, so they’re completely 

visible; and shades of gray have varying degrees of transparency, depending on how 

dark the gray is (the closer it is to black, the more transparent the corresponding 

section on the image layer will be).

You can edit a layer mask using any of the drawing or painting tools, including 

the pencil and brush tools (B), the Gradient Tool (G), and the Paint Bucket Tool (G). 

Drawing on a mask affects the mask only, and does not touch the pixels that make up 

the image. Draw or paint on the mask in black, white, or gray.

In this solution, I used a black-to-transparent gradient to create a gradient on the 

layer mask. This allowed the upper part of the image to remain visible, but let the 

lower part fade away so that the background color could show through.

Creating a layer mask using the Brush Tool

We could also have created a fade effect  

with the Brush Tool (B). In the example 

shown, I’ve selected a soft-edged brush, 

set my foreground color to black, and 

painted along the bottom of the image 

on the layer mask to paint out the areas 

I want to fade.

You’re probably wondering why you 

wouldn’t just paint a green gradient on 

the bottom of the picture layer, or on its 

own layer, to achieve the same effect. 

Why use a layer mask?

The beauty of layer masks is that they are non-destructive. They don’t actually 

modify any of the pixels on the image layer itself—a benefit that, ultimately, gives 

you greater flexibility. If you decided that you didn’t want the effects you’d created 

using your layer mask, you could get rid of the mask and the original image would 

remain intact. Or, if you decided you didn’t like the green color, you could change 

the background color and the fade effect would still work.
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Blending Two Images Together
Solution
Blending two images together is very similar to fading an image into its background: 

you’ll apply a layer mask to at least one of your images. If you haven’t created layer 

masks before, read the solution titled “Fading an Image into the Background, in 

Chapter 2.”

Arrange your Photoshop document so that one of the images overlaps the other, 

as shown in the example below. I’ve usually found that the effect works best if the 

image backgrounds have similar colors or textures, although this is not mandatory by 

any means!

Initial document with two image layers

Create a layer mask for the top layer and use the Gradient Tool (G) or the Brush Tool 

(B) to create a fade effect as I described in “Fading an Image into the Background.” If 

you’ve hidden too much of the layer with the layer mask, you can make these areas 

visible again by painting them back with white on the layer mask.

Creating a layer mask

Beautiful flowers

Personally, I’m pretty happy with that effect 

so I’ll leave it there. You can see the final 

result here.
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Rounding the Corners of a Photo
Solution
1	 Select the Rounded Rectangle Tool (U) and choose the Paths option, as shown here.

Choosing the Paths option

2	 Use this to create a rounded rectangle path over the image. You can view the path 

in the Paths palette.

Creating a rounded rectangle

Creating the vector mask

3	 Select Layer > Vector Mask > Current Path. 

Photoshop will create a vector mask using the 

rounded rectangle path you just created. 

The example here shows the new vector mask 

in the Layers palette. You can use the Direct 

Selection Tool (A) to modify the path and 

change its shape.

Masking Multiple Layers with the Same Shape
Let’s say that you have multiple layers and you want them to be masked with the 

same shape. You could create a layer mask for one and then duplicate the mask 

for each layer, but what if you want to change the shape layer later? If you were 

motivated enough, you could go through each layer and modify the shape mask … 

but why would you bother when you could easily halve the time that job would take 

using the clipping mask?

	 Basic Skills	 47

Order the print version of this book to get all 286 pages!

http://www.sitepoint.com/launch/650367/


48	 The Photoshop Anthology 	 The Basics	 49

Solution

Web site design

In this solution, I’ll start with an 

interface design for a simple web 

site. It has a header bar, a menu 

bar, and a content area as shown 

in the example here.

I’ll paste in the flower images that 

I blended together earlier in this 

chapter. As you can see in the example below, the images are bigger than the header 

area. I want them to be contained within the header region, but I still want to be able 

to move them around. The solution may seem simple at first—a layer mask on each 

layer will do the trick. But what if I decide to change the header height later? I’ll 

have to modify all the masks.

Images for header area

Enter the clipping mask. First, your document must have a shape layer that contains 

the shape of the “masking” area. Put the layers you need to mask directly on top of 

this shape layer.

Holding the Alt (Option) key changes the cursor

In the Layers palette, move the cursor to the 

boundary between the shape layer and the layer 

above it. Hold down the Alt key (Option on a Mac). 

The cursor will change into two overlapping 

circles, as shown in this example.

Click once. The top layer will be clipped by the 

bottom layer. If you examine the Layers palette, 

you’ll notice that the thumbnail for the top layer 

now has a black arrow next to it, and our shape layer’s name is underlined.
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Clipping one of the layers with another

Clipping another layer

Now let’s do the same with our second image. Move your 

mouse up to the edge of the next layer in the Layers palette, 

hold down Alt and click.

Both layers have now been clipped by the base layer, 

as shown in the example below.

Creating a clipping mask for multiple layers

You can move the individual layers around, and they will remain clipped by the 

shape of the base layer. The image below illustrates this point.

Moving a layer with a clipping mask
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As a final flourish, I’m going to use the solution from “Fading an Image into the 

Background” to fade the right edge of the second flower into the background. 

Our final result is shown below.

Adding a layer mask

Discussion
A clipping mask allows you to mask multiple layers using a single, editable mask 

that sits on its own layer. This mask will clip all the layers that sit above it, which 

saves you from needing to create multiple layer masks based on the same shape.

The clipped layers inherit the base layer’s properties. So, for example, if the base 

layer has a 50% opacity, the clipped layers will also have 50% opacity.

To unclip layers, hold the Alt (Option) key and click below the layer you wish to 

unclip. All the layers above it will be unclipped.
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Making a Dotted Coupon Box

Loading square brushes

You’ve probably seen dotted coupon 

boxes before, and saved a good dollar 

or two by using them! This solution 

shows you how to create a coupon- 

style box with dotted borders using 

customized brush strokes.

Solution
1	 Select the Brush Tool (B).

2	 Open the Brushes palette. Click 

on the small arrow in the top 

right-hand corner and select 

Square Brushes. A dialog box will 

appear, asking you whether you want 

to replace or append to the list of brushes you currently  

have displayed. You can always restore your original brush settings by selecting 

Reset Brushes… (click Append if you’d rather add the default brushes to your 

current list, otherwise click OK.)

Modifying brush tip shape options

3	 Choose Brush Tip Shape and select a square 

brush whose diameter matches the length 

you want each dotted stroke to have. If the 

size is not quite right, you can adjust it with 

the Diameter slider as shown in the image 

on the right.

4	 Increase the Spacing slider until the 

spacing between brush strokes 

works for you.

Changing the height of the stroke

5	 You might want to squash your brush 

so that it’s more of a rectangle. Click on 

the top or bottom point of the circle in 

the dialog box and drag it towards the 

horizontal axis until the stroke looks 

similar to that in the image at left.
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6	 Check the Scattering checkbox and change the scattering amount to 0%.

Changing the scattering amount

7	 Right. Now you’re ready to draw your box! Choose a foreground color for your 

dotted line. Create a new layer, hold down the Shift key, and drag across your 

document to draw a horizontal line.

Drawing a dotted line

Rotating the brush

8	 Next, return to the Brushes palette 

and drag on the horizontal axis 

arrow to rotate the brush by 90 degrees 

(or type 90 in the Angle textbox). 

This will allow you to draw vertical 

strokes.

9	 Hold down Shift and drag the mouse 

down to draw a vertical line.

10	 Rotate your brush back to zero, and 

draw your second horizontal line.

11	 Complete your box by rotating the 

brush to 90 degrees once more and 

drawing the last vertical line.

Finished coupon box
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Applying a Drop Shadow
Solution
Choose the layer to which you wish to apply the drop shadow, and select Layer > 

Layer Style > Drop Shadow. Play with the opacity, angle, distance, and other settings in 

the Layer Style dialog box until you’re happy with the effect.

Note that the value for Angle will affect all drop shadows in your document, so that 

the light source is consistent across your entire image.

TIP  Dragging your Shadow

You can also click directly in the document window and drag the drop shadow around, as 
shown here. Make sure Drop Shadow is highlighted in the Layer Style dialog box, otherwise 
this won’t work!

Moving the drop shadow

Images with Transparent Backgrounds
Solution

Document with background layer turned off

Open a Photoshop document that 

contains transparent areas. 

You’ll see that Photoshop marks the 

transparent areas with a gray, 

checkered pattern.
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Select File > Save For Web…, or 

press Shift-Alt-Ctrl-S (Shift-Option-

Command-S on a Mac). In the dialog 

box that appears, choose GIF and 

check the Transparency option, as 

shown in the image to the right. 

While both GIFs and PNGs support 

transparency, some browsers 

(including Internet Explorer 6) do 

not support PNG transparency. 

For this reason, I’d recommend 

that you use GIFs to meet your 

transparent image needs. Saving as a transparent GIF

Click Save and name your file.

Discussion

Close-up of anti-aliased shape

Images with curved, smooth edges, like the one in 

this example, maintain the illusion of crisp edges 

as a result of anti-aliasing—partially transparent 

pixels are added onto the edges of the image to 

smooth them, as shown here. However, when you  

save an image as a GIF, these partially transparent  

pixels are saved as non-transparent pixels where  

white is the default “background” color.

Choosing alternate matte color

If you’re not placing this 

image on a white background, 

it might be wise to define a 

custom matte color by 

clicking on the Matte arrow, 

as shown here. Otherwise, 

you’ll end up with a white 

“color halo” around 

the image.
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Let’s say that we’re going to place this graphic against a bright red background. Click 

on the Matte arrow, choose Other…, and select a bright red.

Setting a bright red matte color

Close-up of color halo

Now you’ll be able to see a red color halo around 

the graphic. If you zoom in, you’ll see that those 

anti-aliased pixels behave as though they’re 

sitting on a red background.

Click the Save button to save your image.

No matte vs red matte

Summary
In this chapter, we looked at solutions to some of the basic functions that Photoshop 

users should master. We learned how to import graphics into a Photoshop document, 

how to resize and rotate images and selections, how to use the Shift key to constrain 

movements, and how to use masks and basic layer styles to create effects. We also 

looked at the basics of creating vector shapes and saving transparent GIFs. These 

skills form a great foundation for using Photoshop, and we’ll definitely turn to them 

in the coming chapters!
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What’s Next? 

If you’ve enjoyed this chapter from The Photoshop Anthology, why not order 

yourself a copy?

SitePoint’s first full color book, The Photoshop Anthology: 101 Web Design Tips, 

Tricks & Techniques provides you with over 100 tried and tested real-world 

Photoshop solutions for you to use on your projects. If you’ve ever been stuck for 

inspiration, or have puzzled over just how to create that shiny “Aqua” style button or 

that seamlessly tiling background image you saw on a web site recently, you need a 

copy of this book. 

Author Corrie Haffly has drawn on her extensive Photoshop experience to show you 

how to create a multitude of web graphics, ranging from buttons to backgrounds 

to other user interface elements. Corrie also covers ways to greatly improve your 

workflow and make working with Photoshop more efficient through batch processing 

and the automation of repetitive tasks. 

Following the same step-by-step, problem-and-solution format used in other 

SitePoint Anthology books, this book is packed with best-practice, innovative and 

visually stunning techniques to produce amazing graphics for your web sites. 

The book’s full color layout and larger than normal size (8” x 10”) were especially 

designed to help show off the techniques demonstrated in the book.

The Photoshop Anthology: 101 Web Design Tips, Tricks & Techniques also includes 

download access to all of the Photoshop (PSD) files used in the book—that’s over 

50MB of files—so you can use them right away in your projects. 

In the rest of the book, you’ll learn how to:

• Master the basics: image sizing, layers, vector shapes, transparency, and more. 

• Create a multitude of different buttons: aqua-style, metallic, glassy, and more. 

• Create seamless tiling backgrounds: rice paper, brushed metal, granite, and more. 

• Work with text: style it, create special effects, wrap it around 3D objects, and more. 

• Touch up photographs, match colors, and combine different images. 

• Use eye-catching special effects. 

• Isolate objects from images. 
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• Make graphics for CSS rollover buttons. 

• Design an entire web site and easily switch between different versions. 

• Optimize graphics for web use. 

• Work smarter: automate your workflow with batch commands and actions. 

• Create animated GIFs. 

• And lots more …

On top of that, order direct from sitepoint.com and you’ll receive a free Hexadecimal 

Color Reference Chart (while stocks last!).

Order now and get it delivered to your doorstep!
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