
Using 

ADOBE® CONTRIBUTE® CS4



Copyright© 2008 Adobe Systems Incorporated. All rights reserved.

Using and administering Adobe® Contribute® CS4 for Windows® and Mac OS

If this guide is distributed with software that includes an end-user agreement, this guide, as well as the software described in it, is furnished under license and 

may be used or copied only in accordance with the terms of such license. Except as permitted by any such license, no part of this guide may be reproduced, stored 

in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, recording, or otherwise, without the prior written permission of Adobe 

Systems Incorporated. Please note that the content in this guide is protected under copyright law even if it is not distributed with software that includes an end-

user license agreement.

The content of this guide is furnished for informational use only, is subject to change without notice, and should not be construed as a commitment by Adobe 

Systems Incorporated. Adobe Systems Incorporated assumes no responsibility or liability for any errors or inaccuracies that may appear in the informational 

content contained in this guide.

Please remember that existing artwork or images that you may want to include in your project may be protected under copyright law. The unauthorized 

incorporation of such material into your new work could be a violation of the rights of the copyright owner. Please be sure to obtain any permission required 

from the copyright owner.

Any references to company names in sample templates are for demonstration purposes only and are not intended to refer to any actual organization.

Adobe, the Adobe logo, Adobe Audition, Adobe Premiere, Acrobat, After Effects, Contribute, Creative Suite, Dreamweaver, Encore, Fireworks, Flash, 

Illustrator, InCopy, InDesign, Photoshop, and Version Cue are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States 

and/or other countries.

Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. Mac, Macintosh, 

and Mac OS are trademarks of Apple Inc., registered in the United States and other countries. All other trademarks are the property of their respective owners.

Updated Information/Additional Third Party Code Information available at http://www.adobe.com/go/thirdparty.

Portions include software under the following terms:

This product contains either BISAFE and/or TIPEM software by RSA Data Security, Inc.

Portions Copyright © 1998 Gilles Vollant

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

Flash 9 video is powered by On2 TrueMotion video technology. © 1992-2005 On2 Technologies, Inc. All Rights Reserved. http://www.on2.com.

This product includes software developed by the OpenSymphony Group (http://www.opensymphony.com/).

Portions of this code are licensed from Nellymoser (www.nellymoser.com).

Sorenson Spark™ video compression and decompression technology licensed from Sorenson Media, Inc.

MPEG Layer-3 audio compression technology licensed by Fraunhofer IIS and THOMSON multimedia (http://www.iis.fhg.de/amm/).

Certain Spelling portions of this product is based on Proximity Linguistic Technology. ©Copyright 1990 Merriam-Webster Inc. ©Copyright 1990 All rights 

reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA.  ©Copyright 2003 Franklin Electronic 

Publishers Inc.©Copyright 2003 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. Legal 

Supplement ©Copyright 1990/1994 Merriam-Webster Inc./Franklin Electronic Publishers Inc. ©Copyright 1994 All rights reserved. Proximity Technology A 

Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1990/1994 Merriam-Webster Inc./Franklin Electronic Publishers Inc. 

©Copyright 1997All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA ©Copyright 1990 

Merriam-Webster Inc. ©Copyright 1993 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey 

USA. ©Copyright 2004 Franklin Electronic Publishers Inc. ©Copyright 2004 All rights reserved. Proximity Technology A Division of Franklin Electronic 

Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1991 Dr. Lluis de Yzaguirre I Maura ©Copyright 1991 All rights reserved. Proximity Technology A 

Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1990 Munksgaard International Publishers Ltd. ©Copyright 1990 All 

rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1990 Van Dale Lexicografie 

bv ©Copyright 1990 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1995 

Van Dale Lexicografie bv ©Copyright 1996 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey 

USA. ©Copyright 1990 IDE a.s. ©Copyright 1990 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New 

Jersey USA. ©Copyright 1992 Hachette/Franklin Electronic Publishers Inc. ©Copyright 2004 All rights reserved. Proximity Technology A Division of Franklin 

Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1991 Text & Satz Datentechnik ©Copyright 1991 All rights reserved. Proximity Technology 

A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA.  ©Copyright 2004 Bertelsmann Lexikon Verlag ©Copyright 2004 All rights 

reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 2004 MorphoLogic Inc. 

©Copyright 2004 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1990 

William Collins Sons & Co. Ltd. ©Copyright 1990 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New 

Jersey USA. ©Copyright 1993-95 Russicon Company Ltd. ©Copyright 1995 All rights reserved. Proximity Technology A Division of Franklin Electronic 

Publishers, Inc. Burlington, New Jersey USA. ©Copyright 2004 IDE a.s. ©Copyright 2004 All rights reserved. Proximity Technology A Division of Franklin 

Electronic Publishers, Inc. Burlington, New Jersey USA. The Hyphenation portion of this product is based on Proximity Linguistic Technology. ©Copyright 

2003 Franklin Electronic Publishers Inc.©Copyright 2003 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. 

Burlington, New Jersey USA. ©Copyright 1984 William Collins Sons & Co. Ltd. ©Copyright 1988 All rights reserved. Proximity Technology A Division of 

Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1990 Munksgaard International Publishers Ltd. ©Copyright 1990 All rights 

reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1997 Van Dale Lexicografie bv 

©Copyright 1997 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1984 

Editions Fernand Nathan ©Copyright 1989 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey 

USA. ©Copyright 1983 S Fischer Verlag ©Copyright 1997 All rights reserved. Proximity Technology A Division of Franklin Electronic Publishers, Inc. 

Burlington, New Jersey USA. ©Copyright 1989 Zanichelli ©Copyright 1989 All rights reserved. Proximity Technology A Division of Franklin Electronic 

http://www.apache.org/
http://www.on2.com
http://www.opensymphony.com/
http://www.nellymoser.com
http://www.iis.fhg.de/amm/


Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1989 IDE a.s. ©Copyright 1989 All rights reserved. Proximity Technology A Division of Franklin 

Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1990 Espasa-Calpe ©Copyright 1990 All rights reserved. Proximity Technology A Division 

of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA. ©Copyright 1989 C.A. Stromberg AB. ©Copyright 1989 All rights reserved. Proximity 

Technology A Division of Franklin Electronic Publishers, Inc. Burlington, New Jersey USA.

Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110, USA

Notice to U.S. government end users. The software and documentation are “Commercial Items,” as that term is defined at 48 C.F.R. §2.101, consisting of 

“Commercial Computer Software” and “Commercial Computer Software Documentation,” as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, 

as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and 

Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial items and (b) with only those rights 

as are granted to all other end users pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States. 

Adobe Systems Incorporated, 345 Park Avenue, San Jose, CA 95110-2704, USA. For U.S. Government End Users, Adobe agrees to comply with all applicable 

equal opportunity laws including, if appropriate, the provisions of Executive Order 11246, as amended, Section 402 of the Vietnam Era Veterans Readjustment 

Assistance Act of 1974 (38 USC 4212), and Section 503 of the Rehabilitation Act of 1973, as amended, and the regulations at 41 CFR Parts 60-1 through 60-60, 

60-250,and 60-741. The affirmative action clause and regulations contained in the preceding sentence shall be incorporated by reference.



iv

Contents

Chapter 1: Resources 

Activation and registration  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

Help and support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

Services, downloads, and extras . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

What’s new?  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

Chapter 2: Setting up Contribute

The Contribute workflow  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

Connect to a blog  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

Connect to a website . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

Open Contribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

Create your blog/browse to your website  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

Edit your blog/website  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Publish your blog/website . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Integrate Contribute with Adobe Creative Suite applications  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Integrate Adobe Bridge with Adobe Contribute  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Chapter 3: Workspace

OWL  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

The Contribute workspace . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

Switch between browsing and editing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

Browse to web pages and blog entries  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

Open web pages and blog entries without browsing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

Set up access to commonly used pages  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

Set Contribute preferences  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Change or disable startup password  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Set browser encoding  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Contribute accessibility features  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

Chapter 4: Working with existing web pages and blog entries

Overview of working with blogs and web pages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46

Edit existing web pages and blog entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

Undo mistakes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55

Save drafts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55

Send web page drafts and files for review  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Access new review drafts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

Edit web page drafts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

Review web page drafts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61

Work with template-based web pages  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

Work offline . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65

Edit web pages in an external application  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67



v

Edit web page source in an external application . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

Configure blog server settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

Discard a draft, new page, or new blog entry  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70

Delete a web page or blog entry  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70

Export a web page or blog entry (Windows only)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

Print a web page or blog entry . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

Add Google search  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Chapter 5: Adding pages, blog entries, and documents

Create or copy a page on your website . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

Create a stand-alone web page  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Create a blog entry for your blog . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Set page properties for a web page  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Add keywords and a description for a web page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87

Set preferences for blog entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87

Enter metadata for a blog entry . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88

About converting documents to PDFs (Windows only) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 92

Add Microsoft Word and Excel documents to a website . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94

Open documents in Contribute from Microsoft Office applications (Windows only) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

Insert PDFs in Contribute pages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103

Insert HTML code snippets   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105

Chapter 6: Working with text

About HTML and CSS styles in the Contribute Style menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113

Add text to a web page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113

Format text  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

Position text on the page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 120

Create lists  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121

Check spelling . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126

Find and replace text  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127

Chapter 7: Working with images and graphic elements

About inserting images and buttons  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 131

Add an image to a page  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132

Insert shared assets into a web page  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135

Change image properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136

Change an image’s position or orientation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Edit an image in Contribute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 138

Edit an image in an external application . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 141

Insert SWF content into your web page  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

Insert a video in your web page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 143

Change a video’s position or orientation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 144

Add audio and video files to your blog  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 145

Add or delete a horizontal rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148



vi

Insert PayPal e-commerce buttons   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 149

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 151

Chapter 8: Working with tables

About conflicts in table formatting   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158

Insert tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158

Select table elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 160

Resize tables, rows, and columns . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 161

Align tables  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 162

Cut, copy, and paste cells . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 163

Add, delete, or merge table rows and columns  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 165

Modify table appearance  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 168

Sort tabular data  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 171

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 172

Chapter 9: Working with links

Create text and image links . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 177

Set the advanced linking options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184

Edit links  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 189

Test links . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 190

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 191

Chapter 10: Working with pages with frames

About frames  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 198

Edit frame content  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 199

Save and publish a page with frames . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 200

Target frame content . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 201

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 202

Chapter 11: Publishing web pages and blog entries

Publishing a page to your website  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 203

Preview a page in your default browser  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207

Publish a file from your computer to your website . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 208

Replace a file on your website  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 209

Roll back to a previous version of a page  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 211

Publish a document from Microsoft Office (Windows only) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 212

Post content to a blog . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 214

Post content to a blog from RSS aggregators . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 217

Publish a blog entry to your blog  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 219

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 222

Chapter 12: Creating and managing website and blog server connections

About creating and sending website connections  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 228

Enable or disable CPS for a website  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 236

Become an administrator of an existing Contribute website . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 239

Configure Contribute administration settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 241

Send connection keys for websites . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 251

Send connections for CPS managed sites . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 253



vii

Add users to websites that CPS manages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 254

Remove users from sites that CPS manages  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 255

Configure dependent files for blogs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 255

Manage website and blog server connections . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 256

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 262

Chapter 13: Managing users and roles

About roles  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 280

Create Contribute roles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 281

Edit a role’s settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 283

Manage drafts sent for review  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 296

Reference  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 297

Chapter 14: Windows keyboard shortcuts

File menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 307

Edit menu   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 307

View menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 308

Insert menu   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 308

Format menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 308

Table menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 309

Working with blog entries  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 309

Working in templates   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 309

Editing text  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 309

Working in tables   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 310

Working with images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 310

Getting help  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 311

Chapter 15: Macintosh keyboard shortcuts

File menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 312

Edit menu   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 312

View menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 313

Insert menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 313

Format menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 313

Table menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 314

Help menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 314

Working in templates   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 314

Editing text  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 314

Working in tables   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 315

Working with images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 315

Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 316



1

Chapter 1: Resources 

Before you begin working with your software, take a few moments to read an overview of activation and the many 

resources available to you. You have access to instructional videos, plug-ins, templates, user communities, seminars, 

tutorials, RSS feeds, and much more.

Activation and registration

Help with installation

For help with installation issues, see the Installation Support Center at www.adobe.com/go/cs4install.

License activation

During the installation process, your Adobe software contacts Adobe to complete the license activation process. No 

personal data is transmitted. For more information on product activation, visit the Adobe website at 

www.adobe.com/go/activation.

A single-user retail license activation supports two computers. For example, you can install the product on a desktop 

computer at work and on a laptop computer at home. If you want to install the software on a third computer, first 

deactivate it on one of the other two computers. Choose Help > Deactivate.

Register

Register your product to receive complimentary installation support, notifications of updates, and other services.

❖ To register, follow the on-screen instructions in the Registration dialog box, which appears after you install the 

software. 

If you postpone registration, you can register at any time by choosing Help > Registration. 

Adobe Product Improvement Program

After you use your Adobe software a certain number of times, a dialog box may appear asking whether you want to 

participate in the Adobe Product Improvement Program.

If you choose to participate, data about your use of Adobe software is sent to Adobe. No personal information is 

recorded or sent. The Adobe Product Improvement Program only collects information about which features and tools 

you use and how often you use them.

You can opt in to or out of the program at any time:

• To participate, choose Help > Adobe Product Improvement Program and click Yes, Participate.

• To stop participating, choose Help > Adobe Product Improvement Program and click No, Thank You.

http://www.adobe.com/go/cs4install
http://www.adobe.com/go/activation
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ReadMe

A ReadMe file for your software is available online and on the installation disc. Open the file to read important 

information about topics such as the following:

• System requirements

• Installation (including uninstalling the software)

• Activation and registration

• Font installation

• Troubleshooting

• Customer support

• Legal notices

Help and support

Community Help

Community Help is an integrated environment on adobe.com that gives you access to community-generated content 

moderated by Adobe and industry experts. Comments from users help guide you to an answer. Search Community 

Help to find the best content on the web about Adobe products and technologies, including these resources:

• Videos, tutorials, tips and techniques, blogs, articles, and examples for designers and developers.

• Complete online Help, which is updated regularly and is more complete than the Help delivered with your product. 

If you are connected to the Internet when you access Help, you automatically see the complete online Help rather 

than the subset delivered with your product.

• All other content on Adobe.com, including knowledgebase articles, downloads and updates, Developer 

Connection, and more.

Use the help search field in your product’s user interface to access Community Help. For a video of Community Help, 

see www.adobe.com/go/lrvid4117_xp.

Other resources

Printed versions of the complete online Help are available for the cost of shipping and handling at 

www.adobe.com/go/store. Online Help also includes a link to the complete, updated PDF version of Help.

Visit the Adobe Support website at www.adobe.com/support to learn about free and paid technical support options.

Services, downloads, and extras

You can enhance your product by integrating a variety of services, plug-ins, and extensions in your product. You can 

also download samples and other assets to help you get your work done.

http://www.adobe.com/go/lrvid4117_xp
http://www.adobe.com/go/store
http://www.adobe.com/support
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Adobe creative online services

Adobe® Creative Suite® 4 includes new online features that bring the power of the web to your desktop. Use these 

features to connect with the community, collaborate, and get more from your Adobe tools. Powerful creative online 

services let you complete tasks ranging from color matching to data conferencing. The services seamlessly integrate 

with desktop applications so you can quickly enhance existing workflows. Some services offer full or partial 

functionality when you’re offline too.

Visit Adobe.com to learn more about available services. Some Creative Suite 4 applications include these initial 

offerings:

Kuler™ panel Quickly create, share, and explore color themes online. 

Adobe® ConnectNow Collaborate with dispersed working teams over the web, sharing voice, data, and multimedia.

Resource Central Instantly access tutorials, sample files, and extensions for Adobe digital video applications.

For information on managing your services, see the Adobe website at www.adobe.com/go/learn_creativeservices_en.

Adobe Exchange

Visit the Adobe Exchange at www.adobe.com/go/exchange to download samples as well as thousands of plug-ins and 

extensions from Adobe and third-party developers. The plug-ins and extensions can help you automate tasks, 

customize workflows, create specialized professional effects, and more.

Adobe downloads

Visit www.adobe.com/go/downloads to find free updates, tryouts, and other useful software. 

Adobe Labs

Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging 

technologies and products from Adobe. At Adobe Labs, you have access to resources such as these:

• Prerelease software and technologies

• Code samples and best practices to accelerate your learning

• Early versions of product and technical documentation

• Forums, wiki-based content, and other collaborative resources to help you interact with like-minded users.

Adobe Labs fosters a collaborative software development process. In this environment, customers quickly become 

productive with new products and technologies. Adobe Labs is also a forum for early feedback. The Adobe 

development teams use this feedback to create software that meets the needs and expectations of the community.

Adobe TV

Visit Adobe TV at http://tv.adobe.com to view instructional and inspirational videos.

Extras

The installation disc contains a variety of extras to help you make the most of your Adobe software. Some extras are 

installed on your computer during the setup process; others are located on the disc.

To view the extras installed during the setup process, navigate to the application folder on your computer.

• Windows®: [startup drive]\Program Files\Adobe\[Adobe application]

http://www.adobe.com/go/learn_creativeservices_en
http://www.adobe.com/go/exchange
http://www.adobe.com/go/downloads
http://www.adobe.com/go/labs
http://tv.adobe.com
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• Mac OS®: [startup drive]/Applications/[Adobe application]

To view the extras on the disc, navigate to the Goodies folder in your language folder on the disc. Example:

•  /English/Goodies/

What’s new?

Workflow enhancements Assign predefined workflows to templates in Adobe® Contribute® CS4 to enforce a 

disciplined author-centric publishing process. Web pages created using a template follow the workflow assigned to the 

template. In all other cases, a default workflow, Author > Publish, is assigned to web pages. The following four 

workflows can be assigned to templates:

• Author > Publish

• Author > Review > Publish

• Author > Approve > Publish

• Author > Review > Approve > Publish

The toolbar changes dynamically to display buttons for only those actions that are available to the user at the given 

stage of the publishing cycle. 

Edit web pages in your favorite web browser Edit a web page or blog in your favorite browser directly without 

opening Contribute. The in-browser editor honors the site connection settings, permissions, and workflow settings in 

Contribute. The in-browser editor supports Firefox® 2, Internet Explorer® 6, and their later versions.

Support for dynamic websites that use blog protocols Use Contribute to edit content in dynamic sites that use the 

MetaWeblog, and Atom blog protocols. In dynamic sites, the contents of an entire page, or parts of it, are stored in a 

database. Changes to the content in the database are reflected in the corresponding portions of the page.

Dreamweaver CS4 and Flash CS4 support Insert Flash® CS4 files into web pages or blog entries created in Contribute. 

Contribute CS4 works with Dreamweaver® templates, which offer editable regions within an over-all protected design. 

Contribute users can easily edit advanced layout components like Spry widgets, or access in-context editing areas 

introduced in Dreamweaver CS4

Review web pages using commenting options Reviewers can use the commenting features in Contribute CS4 to 

review a web page. The author can view comments posted by reviewers and sort them using the available options. 

Expire and delete outdated pages Keep website content fresh with the new expiry notification feature in Contribute 

CS4. Set the expiry meta tag value for a single Contribute page or a set of pages to a future date, and send notifications 

to designated content contributors when pages are close to getting expired.

Specify site-root-relative paths for links Choose to set the path for links relative to the site root or to the web page. 

Setting the links to the site-root-relative path helps administrators shuffle documents within the website without 

worrying about the links being affected.

Auto save documents Prevent data loss resulting from unforeseen circumstances using the option to save documents 

automatically at specified time intervals. Define the AutoSave frequency once and Contribute automatically stores the 

updated drafts when specified. Content remains in draft format until the review and publish process is initiated. 

Inline spell checker Minimize spelling errors when typing using the inline spell checker in Contribute. Any spelling 

errors are flagged, and the correct options are displayed in the right-click pop-up menu.
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Chapter 2: Setting up Contribute

After you have completed installing Adobe® Contribute®, you can set it up to work with an existing website or blog. 

Administrators can use the workflow in Contribute to enforce processes that help efficiently manage a website.

The Contribute workflow

Contribute works with your existing website, whether it’s an intranet or a public website. It often takes a team of people 

to get a website up and running and to keep the content current. 

The team may include the following people: 

Web developers Create the website. The web developers (or design team) uses a website-creation application, such as 

Adobe Dreamweaver®, to build the website. This team is responsible for planning, designing, developing, testing, and 

publishing the website. They are also responsible for creating templates for websites that require a consistent look and 

feel. 

Web developers using Dreamweaver should see Dreamweaver Help for more information.

Contribute users Maintain the website. Contribute users are the marketers, managers, educators, students, small-

business owners, administrative assistants, project managers, and so on, who use Contribute to keep their websites up-

to-date. The user needs no experience in HTML or web design. Because Contribute works like a word processor, the 

user experience is intuitive and familiar. Users can add or update text, images, tables, links, and Microsoft® Word and 

Excel® documents.

Contribute administrators Set up Contribute users and help them use Contribute to maintain the website. 

Administrators enforce document workflows to web pages by assigning predefined workflows in Contribute to 

Dreamweaver templates. When you create a page using a Dreamweaver template, the page is assigned the workflow 

associated with that template. The Contribute administrator is also responsible for setting folder and user permissions, 

which determine who can edit website content and what contents they can edit. Only one Contribute administrator 

can be designated for each website in Contribute. However, more than one person can administer the website if the 

Contribute administrator shares the administration password for the website.

Note: You must connect to a website before you can edit and publish pages on that website, and you must connect to a 

blog server before you can edit and publish entries in that blog. 

The Contribute workflow involves the following steps:

1 Connect to a website or blog.

2 Open Contribute.

3 Create/browse to web a page or blog entry.

Use the Contribute browser to find the web page or blog entry you want to edit. The browser is familiar to users of 

Microsoft Internet Explorer and other popular browsers. The browser toolbar has the normal navigation buttons plus 

a Choose button to help you navigate to files that aren’t linked on your website. You can create bookmarks in 

Contribute and view your Internet Explorer bookmarks. You can also use shortcuts to view current drafts quickly.

1 Open your web page or blog for editing.

2 Edit your content.
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After you browse to the desired page or blog entry, click the Edit Page or Edit Entry button in the toolbar to open 

the web page or blog entry in the Contribute editor. Contribute copies the file from your web or blog server and 

locks it on the server so that no one else can edit the page or blog entry while you’re working on it.

The Contribute editor works much like a word processor. You can edit text, images, tables, and links on the page 

or blog entry, and you can even add Microsoft Word or Excel documents to your website or blog entry. The toolbar 

contains familiar editing buttons as well as buttons for saving, discarding, or publishing your edits.

3 Send your content for review or approval.

Depending on the workflow, get your document reviewed or approved before it is published.

4 Publish the changes.

When a web page completes its workflow or you are done with editing your blog, you can publish the page or blog 

entry to your website or blog server. Click the Publish button, and Contribute replaces the existing page or blog 

entry on your web server or blog with the edited version. Contribute also unlocks the file on the server so other 

users can edit the page or blog entry.

Connect to a blog 

Install Contribute® if it is not already installed on your computer. Before installation, ensure that your computer meets 

the minimum setup requirements.

Before you can use Adobe® Contribute to edit and update your website and blog content, you must create a connection 

to the web server that stores your website or blog. By creating a connection, you enable Contribute to access the web 

pages on your website and blog entries on your blog, and you can then edit pages and blog entries and publish any 

changes you make.

In most cases, your Contribute administrator sets up Contribute for you or provides the information you need to 

connect to your website or blog server.

You can connect to a blog account that is hosted on one of the following: 

• A blog publishing service, such as Blogger™, Typepad®, or WordPress®.

• An internal server using a service such as Movable Type® or WordPress.

To connect to a blog, you need the necessary connection information for the blog so you can enter the information in 

the Connection Wizard. You can use the MetaWeblog API to connect to a blog account that is hosted on a blog 

publishing service, such as Blogger, WordPress, Roller, or TypePad or an internal server. If you use a Macintosh® 

computer and have a .Mac account, Contribute detects the .Mac account and asks if you want to create a connection 

to it.

Note: Connection keys are not used for blog connections; they are available only for website connections.

For more information about connecting to a blog, see “Create a blog server connection” on page 233.

Connect to a website

There are two ways you can connect: by using a connection key that was sent to you, or by entering the connection 

information manually.
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Your Contribute administrator does one of the following to help set up a connection to your website for you:

• Send you an e-mail message with a website connection key file, which you can use to establish a connection to your 

website. The connection key contains all the network information that Contribute needs for connecting to your 

website.

• Provide the network location from where you can download the connection key.

Note: Connection keys are used only with website connections; they are not used for blog connections.

• Give you the necessary connection information for the website so you can enter the information in the Connection 

Wizard (see “Create a website connection” on page 231).

If you use a Macintosh computer and have a .Mac account, Contribute detects the .Mac account and asks if you 

want to create a connection to it. 

If your website is managed by Contribute Publishing Server, your administrator sends you a connection key or 

gives you connection information to enter in the Contribute browser address bar. 

Connect using a connection key

1 Open the e-mail containing the connection key. 

2 Double-click the attachment.

The Import Connection Key dialog box appears or the Log In To Publishing Services dialog box appears.

3 Do one of the following:

• If the Import Connection Key dialog box appears, enter your name, your e-mail address, and the connection key 

password, and then click OK.

• If the Log In To Publishing Services dialog box appears, enter your user name and password, and then click OK.

Note: If you don’t have the password, contact your system administrator. 

4 If you are prompted for other connection information, such as FTP login, type that information, and then click OK.

When the connection is complete, the website’s home page appears in the Contribute browser.

Connect by entering the connection information manually

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS), and then click Create.

The Connection Wizard or Connection Assistant appears.

2 Follow the on-screen instructions to enter your connection information.

Your web hosting service or your IT administrator can provide you with the required information. For more 

information, click the Help button located at the bottom of the dialog box.

Note: During startup, Contribute will not connect to any website or blog server. To change this behavior, in the My 

Connections dialog box, select the desired website or blog server, and clear the selection of the Don’t Connect To 

<site/blog> at Startup. 

Open Contribute

If the Require Contribute startup password option is selected in the Security category of Preferences, Contribute 

prompts you for your startup password when you start the program. 
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A startup password protects unauthorized users from editing or publishing pages and blog entries to your website or 

blog. If you do not enter the password when you start Contribute, all web pages and blogs are disabled and cannot be 

enabled. You can only browse to web pages or blog entries and create web pages or blog entries. After you enter the 

correct password, you can make updates and publish changes or new entries to the connected websites and blogs until 

you close Contribute.

In addition to providing secure access, when the Require Contribute Startup password option is selected, Contribute 

uses a stronger encryption method when saving your connection information on your computer.

Note: If you receive a connection key that requires a Contribute startup password, you must create a startup password 

before you can import that connection.

Enter a Contribute startup password

1 In the Enter Password dialog box, type the Contribute startup password.

You can enter the password incorrectly only three times before Contribute locks you out. If you are locked out, you 

can restart Contribute and reenter the startup password. 

If you forget your password, you have to delete all of your website connections and add them again.

2 Click OK.

Note: If you click Skip, you bypass the password prompt and Contribute starts. When you skip the password, you can 

only edit or cancel existing drafts for the website. You won’t be able to edit pages other than drafts, or publish changes 

to drafts until you restart Contribute and enter the correct startup password.

See also 

“Change or disable startup password” on page 32

Start Contribute without a network connection 

When you start Contribute, it checks your network connection so that it can connect to your website or blog. 

Contribute alerts you if it does not detect a connection. You can do one of the following in such circumstances.

1 Start Contribute.

The Connection Failure dialog box appears.

2 Select Work Offline if you know that you’re not connected to the network. For more information, see “Work 

offline” on page 65. 

3 Select Try To Connect Anyway to force Contribute to continue checking for a network connection.

4 If Contribute still fails to connect, Contribute displays an error message with two options:

• Click Yes to continue trying to connect to other websites and blog servers.

• Click No to disable the rest of your websites and blog servers. You can later enable them after you resolve your 

network connection problem. 

5 Click OK.

Note: You can disable a website or blog at any time—not just at startup—when there’s a problem. If you have multiple 

websites and blogs, you can disable the ones you aren’t currently working on, so Contribute does not maintain the 

connection for an extended period of time. For more information, see “Disable individual website and blog 

connections” on page 260.



9USING CONTRIBUTE CS4

Setting up Contribute

Enable a disabled website or blog

1 Browse to any page on the website or to any blog entry in the blog, and click Connect in the toolbar.

2 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

3 Do one of the following:

• To enable a website, select the website you want to enable from the list, and click Enable.

• To enable a blog, select the blog server under which the blog is listed, and click Enable. All the blogs listed under 

this blog server are enabled. You cannot enable individual blogs.

4 Click Close.

Create your blog/browse to your website

Contribute enables you to create and edit blog entries in its visual editor. You can also open and edit content from your 

browser or a Microsoft® Office application.

For websites, the Contribute browser works like a standard web browser, letting you do the following:

• Navigate to websites and locate pages by clicking links. 

• Refresh pages to see updates. 

• Reload pages you’ve visited using Back and Forward buttons. 

• Enter website addresses in the Address text box.

You can also create new web pages and link them to other web pages, files on your computer, pages on other websites, 

and e-mail addresses.For more information, see “Adding pages, blog entries, and documents” on page 76.

Create your blog

You can create a new blog entry from scratch. After you create the entry, you can add content such as text, images, and 

multimedia.

1 On your blog homepage in the Contribute browser, click the New button in the toolbar or select File > New.

2 In the New Web Page Or Blog Entry dialog box, enter a title for your new blog entry.

3 Click OK. The new entry opens as a draft in Contribute.

Note: Use the My Connections dialog box to select websites and blog servers that Contribute must not connect to 

during the startup process. 

You can browse to any website with Contribute, but you can edit only the pages of websites that you’ve created 

connections to. 

Browse to a website

• Enter a web address (URL) in the Address text box in the toolbar. 

• Click links to navigate to a web page.

• Click the Back or Forward button in the toolbar.
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Create new pages

1 In the Contribute browser, click New in the toolbar.

2 In the New Web Page Or Blog Entry dialog box, choose one of the following options: 

• Use The Blank Web Page.

• Select A Template Available On The Server.

• Copy One Of The Contribute Starter Web Pages.

3 Click OK. The new page opens as a draft in Contribute.

Note: While Starter web pages are available in Contribute, templates are available on the server. Some templates may 

not be updated from the server. Use the Refresh Templates button to download the desired template.

Edit your blog/website

You can edit an existing blog entry on any blog/website you’ve connected to. When you browse to such a website, the 

Edit Page button is enabled.

You can also create new web pages and insert contents from Microsoft documents directly into web pages.

You can edit a document from a Microsoft Office application, or open a web page for editing in your favorite web 

browsers.

For information on opening and editing existing web pages and blogs, see “Working with existing web pages and blog 

entries” on page 46.

For information on opening and editing new web pages and blogs, see “Adding pages, blog entries, and documents” 

on page 76.

Publish your blog/website

After a web page completes its workflow or you have completed editing a blog, you can publish it to your website or 

blog from Contribute. You can also publish content from Microsoft Office applications or your web browser. 

Note: You will not be able to publish a web page if you do not have publish permissions.

For more information on publishing blogs and websites, see “Publishing web pages and blog entries” on page 203. 

Integrate Contribute with Adobe Creative Suite 
applications

You can run custom startup scripts during the installation of other Adobe Creative Suite® applications to enable access 

from the relevant suite product to Adobe Contribute. When these scripts are run, Adobe Contribute-related menus, 

options, and toolbar icons are created in the Creative Suite applications. Also, relevant Creative Suite product-related 

menus, options, and toolbar icons are created in Adobe Contribute.
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Perform Adobe Contribute-related operations in Creative Suite applications

The Cross DOM is a small API that provides a set of functions that are common across Adobe Creative Suite 

applications. These include functions to open files, execute scripts, and print files. You can use the Cross DOM API 

for startup scripts to perform any of the following operations across the Adobe Creative Suite applications:

• Open a new web page or blog entry in Adobe Contribute from another Creative Suite application using the Open 

function in the Cross-DOM API. Also, you can open files in Adobe Contribute from another Creative Suite 

application using the Cross-DOM API in a startup script.

• Open files from the following Creative Suite applications in  Adobe Contribute by using the Open function in the 

Cross-DOM API: Adobe Bridge®, Adobe Photoshop®, Adobe Illustrato®r, Adobe InDesign®, Adobe Acrobat®, 

Adobe Flash®, Adobe Dreamweaver®, and Adobe Fireworks®.

• Open video and audio files from the following Creative Suite applications using the Open function in the Cross-

DOM API: Adobe After Effects®,  Adobe Premiere® Pro, Adobe Audition®, and Adobe Encore®. If the file can be 

viewed in the embedded browser, it is opened in the embedded browser.

• Edit files in one of the following Creative Suite applications, and call the Reveal function to switch to Adobe 

Contribute: Adobe Bridge,  Adobe Photoshop, Adobe Illustrator, Adobe InDesign, Adobe Acrobat, Adobe Flash, 

Adobe Dreamweaver, Adobe Fireworks, Adobe After Effects, Adobe Premiere Pro, Adobe Audition, and Adobe 

Encore. 

• Print files from the following Creative Suite applications in  Adobe Contribute using the PDF printer and the Print 

function in the Cross-DOM API: Adobe Bridge, Adobe Photoshop, Adobe Illustrator,  Adobe InDesign, Adobe 

Acrobat, Adobe Flash, Adobe Dreamweaver, and Adobe Fireworks.

• Print files from the following Creative Suite applications using the Print function in the Cross-DOM API: Adobe 

After Effects, Adobe Premiere Pro, Adobe Audition, and Adobe Encore. (Although video files are rarely printed, 

printing these files lets you verify whether the corresponding applications respond to BridgeTalk messages.)

• Close Adobe Contribute from other Creative Suite applications using the Close function in the Cross-DOM API.

• Quit Adobe Contribute from the following Creative Suite applications using the Quit function in Cross DOM API: 

Adobe Bridge, Adobe Photoshop,  Adobe Illustrator, Adobe InDesign, Adobe Acrobat, Adobe Flash, Adobe 

Dreamweaver, Adobe Fireworks, Adobe After Effects, Adobe Premiere Pro, Adobe Audition, and Adobe Encore. 

Note: Adobe Bridge scripts using the BridgeTalk protocol enable communication between Adobe Contribute and the 

Adobe Creative Suite applications. The BridgeTalk message object is used to send message packets between the 

applications.

Integrate Adobe Bridge with Adobe Contribute

The Adobe Bridge software is the new navigational control center built for Adobe Creative Suite applications and their 

components. Adobe Bridge provides centralized access to your Creative Suite project files, applications, and settings.

Adobe Contribute has been integrated with the Adobe Bridge application in the Adobe Creative Suite release. This 

integration lets you perform the following tasks:

• Organize assets

• Insert files

• Communicate across applications using the BridgeTalk protocol

• Access Adobe stock photos.
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Insert files from Adobe Bridge into Adobe Contribute

Using Adobe Bridge, you can insert files or folders into web pages or blog entry drafts in Adobe Contribute. If the 

Contribute draft supports the selected file type, then the selected file is placed in the draft, or a link to the selected file 

is displayed in the draft. File types which are not supported, are not inserted in the draft.

1 Start Adobe Contribute.

2 Open a draft of a web page or blog entry.

Note: While placing a file in Contribute, if Adobe Contribute is not running, or if a web page or blog entry draft is not 

open, a message is displayed indicating that there is no open draft to place the file.

3 Select File > Browse or click the Bridge toolbar icon . 

Note: You can select multiple files or folders to place in a Contribute draft.

Adobe Bridge is opened in a new window.

4 In Adobe Bridge, select the file you want to insert.

5 Select File > Place > In Contribute.

The file, or a link to the file is inserted in the Contribute draft. If you select a file type which is not supported, such 

a file is not inserted in the draft.

Note: You can also insert a file into a Contribute web page or blog entry draft by dragging the file from Windows 

Explorer or Mac OS Finder, and dropping it into the Contribute web page or blog entry draft.

See also 

“Publish files from Adobe Bridge to Adobe Contribute (Windows only)” on page 13

Open files from Adobe Bridge in Adobe Contribute (Windows Only)

You can select a file in Adobe Bridge, and open the file in Adobe Contribute.

1 Start Adobe Bridge.

2 Select the file you want to open in Contribute.

Note: You can open only Microsoft Word documents with .doc or .docx extension, and Microsoft Excel documents 

with .xls, .xlsm, or .xlsx extension.

3 Select Tools > Contribute > Open In Contribute.

Note: The Tools > Contribute > Open In Contribute menu is available for the Windows platform only.

Contribute is started and the contents of the Word or Excel document are inserted in the web page draft based on 

the insertion option you selected.

See also 

“Open documents in Contribute from Microsoft Office applications (Windows only)” on page 96
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Publish files from Adobe Bridge to Adobe Contribute (Windows only)

You can select the following file types in Adobe Bridge, and publish them in Adobe Contribute: .doc, .xls, .docx, .xlsm, 

and .xlsx. When you publish a Microsoft Office document that contains other files, the additional files are copied to 

your web page draft automatically. 

1 Start Adobe Bridge.

2 Select the file you want to publish to Adobe Contribute.

3 Select Tools > Contribute > Publish To Website.

Note: The Tools > Contribute > Publish To Website menu is available for the Windows platform only.

The Publish To Website dialog box appears.

4 To select the settings for publishing the document, do the following: 

a Select the website where you want to publish the file. 

Note: If you do not have a connection to your website before you publish a document, you can create one by 

selecting Create New Connection in the Select pop-up menu in the Publish To Website dialog box. For more 

information on creating a website connection, see “Create a website connection” on page 231.

b Select a location for storing the file. 

Note: You can select multiple files or folders from Adobe Bridge to publish in Contribute.

c Enter a filename. The filename must not have any spaces, tabs, or alphanumeric characters.

d Select a format. 

e (Optional) Clear the Publish Current Selection Only check box to publish the whole document instead of the 

selection. 

You can also set these preferences in the Microsoft Documents tab from the Edit menu in Contribute. To do 

this, select Edit > Preferences > Microsoft Documents and make a selection. For more information on setting 

these preferences, see “Set Contribute preferences” on page 30.

5 Click Publish. 

Contribute publishes the document to your web page, and a confirmation dialog box appears.

Note: If Contribute is not running when you publish a file from Adobe Bridge to Contribute, Adobe Contribute is 

started first, and then the Publish To Website dialog box is opened.

6 Click OK.

See also 

“Integrate Adobe Bridge with Adobe Contribute” on page 11

“Insert files from Adobe Bridge into Adobe Contribute” on page 12

“Publish a document from Microsoft Office (Windows only)” on page 212

Reference

This section provides information about the dialog boxes introduced in this chapter.
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Completing the Import Connection Key dialog box

Use the Import Connection Key dialog box to import a connection key that establishes a connection to your website. 

Connection keys are available only for websites; they are not available for blogs.

1 Enter your name and your e-mail address.

2 Enter the password for the connection key.

Note: If you don’t have a password, contact the Contribute administrator who sent you the connection key.

3 Click OK.

When the connection is complete, the home page of the website appears in the Contribute browser. 

Entering an FTP password

The Contribute administrator might send you a connection key that does not include the FTP login and password 

information. An FTP password and user name are required to access password-controlled files on the server. 

When you import a connection key that doesn’t include the required FTP information, Contribute displays the FTP 

password dialog box after you enter your name, e-mail address, and password for the connection key.

Note: Connection keys are available only for websites; they are not available for blogs.

If you are connecting to a local network computer, the login information you enter in this dialog box is typically the 

same as your network login information.

1 In the Username text box, type your FTP user name.

2 In the Password text box, type your password. 

3 Click OK. 

The Connection Failure dialog box

1 If Contribute can’t detect a network connection for one or more of your websites or blogs, the Connection Failure 

dialog box gives you two choices:

• Select Work Offline if you know that you’re not connected to the network and you want to work offline. For 

more information, see “Work offline” on page 65.

• Select Try To Connect Anyway if you aren’t sure what the problem is and you want Contribute to try to connect 

again. If Contribute still cannot connect, you can disable one or more of your website or blog connections. 

2 Click OK.
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Chapter 3: Workspace

You can use Adobe® Contribute® as a web browser and as a web page editor. You can easily switch between browsing 

web pages and editing web pages. The Contribute workspace makes it easy for you to access pages, whether you’re 

browsing or editing. 

You can navigate the Contribute dialog boxes and workspace without using your mouse. You can also set preferences 

to customize Contribute.

OWL

Workspace overview

You create and manipulate your documents and files using various elements, such as panels, bars, and windows. Any 

arrangement of these elements is called a workspace. The workspaces of the different applications in Adobe® Creative 

Suite® 4 share the same appearance so that you can move between the applications easily. You can also adapt each 

application to the way you work by selecting from several preset workspaces or by creating one of your own.

Although the default workspace layout varies in different products, you manipulate the elements much the same way 

in all of them.
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Default Illustrator workspace
A. Tabbed Document windows  B. Application bar  C. Workplace switcher  D. Panel title bar  E. Control panel  F. Tools panel  G. Collapse To 
Icons button  H. Four panel groups in vertical dock  

• The Application bar across the top contains a workspace switcher, menus (Windows only), and other application 

controls. On the Mac for certain products, you can show or hide it using the Window menu.

• The Tools panel contains tools for creating and editing images, artwork, page elements, and so on. Related tools are 

grouped.

• The Control panel displays options for the currently selected tool. The Control panel is also known as the options 

bar in Photoshop. (Adobe Flash®, Adobe Dreamweaver®, and Adobe Fireworks® have no Control panel.) 

• Flash, Dreamweaver, and Fireworks have a Property inspector that displays options for the currently selected 

element or tool. 

• The Document window displays the file you’re working on. Document windows can be tabbed and, in certain cases, 

grouped and docked.

• Panels help you monitor and modify your work. Examples include the Timeline in Flash, the Layers panel in Adobe 

Photoshop®, and the CSS Styles panel in Dreamweaver. Panels can be grouped, stacked, or docked.

G

F
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• On the Mac, the Application frame groups all the workspace elements in a single, integrated window that lets you 

treat the application as a single unit. When you move or resize the Application frame or any of its elements, all the 

elements within it respond to each other so none overlap. Panels don’t disappear when you switch applications or 

when you accidentally click out of the application. If you work with two or more applications, you can position each 

application side by side on the screen or on multiple monitors. If you prefer the traditional, free-form user interface 

of the Mac, you can turn off the Application frame. In Adobe Illustrator®, for example, select Window > Application 

Frame to toggle it on or off. (In Flash, the Application frame is on permanently. Dreamweaver does not use an 

Application frame.)

Hide or show all panels

• (Illustrator, Adobe InCopy®, Adobe InDesign®, Photoshop, Fireworks)To hide or show all panels, including the 

Tools panel and Control panel, press Tab.

• (Illustrator, InCopy, InDesign, Photoshop) To hide or show all panels except the Tools panel and Control panel, 

press Shift+Tab.

You can temporarily display hidden panels if Auto-Show Hidden Panels is selected in Interface preferences. It’s 

always on in Illustrator. Move the pointer to the edge of the application window (Windows®) or to the edge of the 

monitor (Mac OS®) and hover over the strip that appears. 

• (Flash, Dreamweaver, Fireworks) To hide or show all panels, press F4.

Display panel options 

❖ Click the panel menu icon  in the upper-right corner of the panel.

You can open a panel menu even when the panel is minimized. 

(Illustrator) Adjust panel brightness

❖  In User Interface preferences, move the Brightness slider. This control affects all panels, including the Control 

panel.

Reconfigure the Tools panel

You can display the tools in the Tools panel in a single column, or side by side in two columns. (This feature is not 

available in the Tools panel in Fireworks and Flash.)

In InDesign and InCopy, you also can switch from single-column to double-column (or single-row) display by setting 

an option in Interface preferences.

❖  Click the double arrow at the top of the Tools panel.

Manage windows and panels

You can create a custom workspace by moving and manipulating Document windows and panels. You can also save 

workspaces and switch among them.

Note: The following examples use Photoshop for demonstration purposes. The workspace behaves the same in all the 

products.
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Narrow blue drop zone indicates Color panel will be docked on its own above the Layers panel group.
A. Title bar  B. Tab  C. Drop zone  

In Photoshop, you can change the font size of the text in the Control panel, in the panels, and in tool tips. Choose a 

size from the UI Font Size menu in Interface preferences.

Manage Document windows

When you open more than one file, the Document windows are tabbed. 

• To rearrange the order of tabbed Document windows, drag a window’s tab to a new location in the group.

• To undock a Document window from a group of windows, drag the window’s tab out of the group.

• To dock a Document window to a separate group of Document windows, drag the window into the group.

Note:  Dreamweaver does not support docking and undocking Document windows. Use the Document window’s 

Minimize button to create floating windows.

• To create groups of stacked or tiled documents, drag the window to one of the drop zones along the top, bottom, or 

sides of another window. You can also select a layout for the group by using the Layout button on the Application bar.

Note:  Some products do not support this functionality. However, your product may have Cascade and Tile commands 

in the Window menu to help you lay out your documents.

• To switch to another document in a tabbed group when dragging a selection, drag the selection over the document’s 

tab for a moment.

Note:  Some products do not support this functionality.

Dock and undock panels

A dock is a collection of panels or panel groups displayed together, generally in a vertical orientation. You dock and 

undock panels by moving them into and out of a dock.

Note: Docking is not the same as stacking. A stack is a collection of floating panels or panel groups, joined top to bottom.

• To dock a panel, drag it by its tab into the dock, at the top, bottom, or in between other panels. 

• To dock a panel group, drag it by its title bar (the solid empty bar above the tabs) into the dock.

• To remove a panel or panel group, drag it out of the dock by its tab or title bar. You can drag it into another dock 

or make it free-floating.

A

B

C
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Navigator panel being dragged out to new dock, indicated by blue vertical highlight

Navigator panel now in its own dock

You can prevent panels from filling all the space in a dock. Drag the bottom edge of the dock up so it no longer meets 

the edge of the workspace.

Move panels

As you move panels, you see blue highlighted drop zones, areas where you can move the panel. For example, you can 

move a panel up or down in a dock by dragging it to the narrow blue drop zone above or below another panel. If you 

drag to an area that is not a drop zone, the panel floats freely in the workspace.

• To move a panel, drag it by its tab. 

• To move a panel group or a stack of floating panels, drag the title bar.

Press Ctrl (Windows) or Command (Mac OS) while moving a panel to prevent it from docking. Press Esc while 

moving the panel to cancel the operation.

Note: The dock is stationary and can’t be moved. However, you can create panel groups or stacks and move them 

anywhere.

Add and remove panels

If you remove all panels from a dock, the dock disappears. You can create a dock by moving panels to the right edge 

of the workspace until a drop zone appears. 

• To remove a panel, right-click (Windows) or Control-click (Mac) its tab and then select Close, or deselect it from 

the Window menu.

• To add a panel, select it from the Window menu and dock it wherever you want.
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Manipulate panel groups

• To move a panel into a group, drag the panel’s tab to the highlighted drop zone in the group. 

Adding a panel to a panel group

• To rearrange panels in a group, drag a panel’s tab to a new location in the group.

• To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.

• To move a group, drag the title bar (the area above the tabs).

Stack floating panels

When you drag a panel out of its dock but not into a drop zone, the panel floats freely. The floating panel allows you 

to position it anywhere in the workspace. You can stack floating panels or panel groups so that they move as a unit 

when you drag the topmost title bar. (Panels that are part of a dock cannot be stacked or moved as a unit in this way.)

Free-floating stacked panels

• To stack floating panels, drag a panel by its tab to the drop zone at the bottom of another panel.

• To change the stacking order, drag a panel up or down by its tab.

Note: Be sure to release the tab over the narrow drop zone between panels, rather than the broad drop zone in a title bar.

• To remove a panel or panel group from the stack, so that it floats by itself, drag it out by its tab or title bar.

Resize panels

• To minimize or maximize a panel, panel group, or stack of panels, double-click a tab. You can also single-click the 

tab area (the empty space next to the tabs).

• To resize a panel, drag any side of the panel. Some panels, such as the Color panel in Photoshop, cannot be resized 

by dragging.

Manipulate panels collapsed to icons

You can collapse panels to icons to reduce clutter on the workspace. In some cases, panels are collapsed to icons in the 

default workspace. 
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Panels collapsed to icons

Panels expanded from icons

• To collapse or expand all panel icons in a dock, click the double arrow at the top of the dock. 

• To expand a single panel icon, click it. 

• To resize panel icons so that you see only the icons (and not the labels), adjust the width of the dock until the text 

disappears. To display the icon text again, make the dock wider.

• To collapse an expanded panel back to its icon, click its tab, its icon, or the double arrow in the panel’s title bar.

In some products, if you select Auto-Collapse Icon Panels from the Interface or User Interface Options preferences, 

an expanded panel icon collapses automatically when you click away from it.

• To add a floating panel or panel group to an icon dock, drag it in by its tab or title bar. (Panels are automatically 

collapsed to icons when added to an icon dock.)

• To move a panel icon (or panel icon group), drag the icon. You can drag panel icons up and down in the dock, into 

other docks (where they appear in the panel style of that dock), or outside the dock (where they appear as floating, 

expanded panels).

Restore the default workspace

• Select the default workspace from the workspace switcher in the Application bar.

• (Photoshop) Select Window > Workspace > Default Workspace.

• (InDesign, InCopy) Select Window > Workspace > Reset [Workspace Name].

Save and switch workspaces

By saving the current size and position of panels as a named workspace, you can restore that workspace even if you 

move or close a panel. The names of saved workspaces appear in the workspace switcher in the Application bar.

In Photoshop, the saved workspace can include a specific keyboard shortcut set and menu set.
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Save a custom workspace

1 With the workspace in the configuration you want to save, do one of the following: 

• (Photoshop, Illustrator) Choose Window > Workspace > Save Workspace.

• (InDesign, InCopy) Choose Window > Workspace > New Workspace.

• (Dreamweaver) Choose Window > Workspace Layout > New Workspace.

• (Flash) Choose New Workspace from the workspace switcher in the Application bar.

• (Fireworks) Choose Save Current from the workspace switcher in the Application bar.

2 Type a name for the workspace.

3 (Photoshop, InDesign) Under Capture, select one or more options:

Panel Locations Saves the current panel locations.

Keyboard shortcuts Saves the current set of keyboard shortcuts (Photoshop only).

Menus Saves the current set of menus.

4 Click OK or Save. 

Display or switch workspaces

❖ Select a workspace from the workspace switcher in the Application bar.

In Photoshop, you can assign keyboard shortcuts to each workspace to navigate among them quickly.  

Delete a custom workspace

• Select Manage Workspaces from the workspace switcher in the Application bar, select the workspace, and then 

click Delete. (The option is not available in Fireworks.)

• (Photoshop, InDesign, InCopy) Select Delete Workspace from the workspace switcher. 

• (Illustrator) Choose Window > Workspace > Manage Workspaces, select the workspace, and then click the Delete icon.

• (InDesign) Choose Window > Workspace > Delete Workspace, select the workspace, and then click Delete.

(Photoshop) Start with the last or default panel locations

When you start Photoshop, panels can either appear in their original default locations, or appear as you last used them.

In Interface preferences:

• To display panels in their last locations on startup, select Remember Panel Locations.

• To display panels in their default locations on startup, deselect Remember Panel Locations.

The Contribute workspace

The Contribute workspace has three main areas: the Contribute browser and editor, the toolbar, and the sidebar. 
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A. Sidebar  B. Toolbar  C. Start page in the browser and editor  

The Contribute browser and editor

The main window in Contribute is used for browsing and editing. If you are not sure whether you are browsing or 

editing in Contribute, look at the toolbar. The toolbars are different when you are browsing and when you are editing 

a draft.

When you use the Contribute browser, you can browse to any web page—not just to pages on your website. The 

Contribute browser functions as a true web browser: Click links in web pages to browse to the page you want to edit. 

You can also create bookmarks to pages that you visit frequently.

When you use the Contribute editor, you can edit pages in websites you have connected to (see “Connect to a blog” on 

page 6). You can edit text, images, tables, links, and pages with frames. 

It’s easy to browse and edit in Contribute, and to switch between browsing and editing. For more information, see 

“Switch between browsing and editing” on page 25.

The Contribute toolbars

The Contribute toolbar changes according to whether you are browsing or editing a web page or a blog entry. When 

you are editing a web page, the editor toolbar lets you edit text or images, depending on the content you’ve selected. 

And when you are editing a draft for your blog, the blog metadata and secondary metadata toolbars help you tag your 

blog pages.

When you receive or open a web page, the toolbar displays buttons for only those actions that you can perform at that 

stage of the workflow, and to which you have permissions. 

The Browser toolbar Contains buttons for navigating your website or creating a page or blog entry. The browser 

toolbar contains the same options for websites and blogs.

B
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The Editing toolbar Contains buttons for common operations from the File, Insert, Format, and Table menus. The 

toolbar options vary depending on whether you are working on a draft for a website or a blog.

A. Action buttons  B. Insert content  C. Add row or column  D. Page properties  E. Check Spelling  

The Blog Metadata toolbar Contains information about the draft, including the blog title, the blog post title, and the 

associated tags. This toolbar is available for blog drafts only.

The Secondary Metadata toolbar Contains more options for associating metadata with a blog post. This toolbar is 

available for blog drafts only.

The Text Formatting toolbar Contains buttons for formatting text. The text formatting toolbar options also vary 

depending on whether you are working on a draft for a website or a blog.

A. Style menu  B. Font menu  C. Font size menu  D. Bold  E. Italic  F. Alignment buttons  G. List buttons  H. Outdent/Indent buttons  I. Text 
color  J. Highlight color  

Note: If your Contribute administrator has restricted editing to text only, some formatting options are not available. Also, 

options might be disabled if a cascading style sheet has been applied to a text selection.

The Image Editing Toolbar Contains buttons for editing images.

A. Resize  B. Rotate buttons  C. Crop  D. Sharpen  E. Brightness/Contrast  F. Style  G. Resize  H. Alignment  I. Image Properties  

The Contribute sidebar

The Contribute sidebar makes it easy to switch between editing and browsing, and gives you quick access to your 

drafts. You can also use the sidebar to get quick instructions for performing tasks in Contribute.

The sidebar has two parts:

The Pages panel Gives you access to the web browser and all drafts you’re currently editing. There is also a link to the 

Draft Console, which shows the status of your drafts.

Note: The Draft Console is not available if your website doesn’t have an administrator assigned.

The How Do I panel Provides quick step-by-step instructions to help you complete some common Contribute tasks. 

The panel shows a list of browsing tasks while you are browsing, and a list of editing tasks while you are editing. 

Click any link in the How Do I panel in the sidebar to get more information on that task. If the desired task is not in 

the list, see Contribute Help (Help > Adobe Contribute Help) to get detailed information.

You can expand, collapse, or resize the panels and the sidebar.

B C D EA
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Expand or collapse the sidebar

❖ Do one of the following:

• Select View > Sidebar.

• In Windows, click the arrow on the splitter bar between the sidebar and the Contribute browser and editor. 

• In Mac OS, double-click the grabber on the splitter bar between the sidebar and the Contribute browser and 

editor. 

Resize the sidebar

❖ Drag the splitter bar between the sidebar and the Contribute browser and editor.

Expand or collapse a panel in the sidebar

❖ Double-click the panel title bar. 

Resize panels vertically in the sidebar

❖ Drag the title bar in the How Do I panel.

Switch between browsing and editing

You can use Contribute to browse or edit web pages and blog entries. You can switch between browsing and editing 

at any time. When you leave a draft you’re editing, Contribute saves your changes so that you can return to the draft 

later and continue editing where you left off.

When you switch to browsing, Contribute does not publish your draft. While you are browsing the page or blog entry, 

the message area advises you that you have an unpublished draft of the page or blog entry. 

If you are not sure if you are browsing or editing in Contribute, look at the toolbar. When you are browsing, you’ll see 

the browser toolbar with the Edit Page (or Create Connection) button, and when you are editing, the editor toolbar 

appears (see “The Contribute toolbars” on page 23).

Switch from browsing to editing

❖ Do one of the following:

• Click the Edit Page button in the toolbar to edit a web page, or click the Edit Entry button to edit a blog entry.

Note: Edit Page and Edit Entry are enabled only for pages on a website or entries in a blog that you are connected 

to and that you have permission to edit.

• Click a draft title in the Pages panel in the sidebar.

Switch from editing to browsing

❖ Do one of the following:

• Click Browser in the Pages panel in the sidebar.

• Click the Save For Later button in the toolbar.

• Select View > Browser.
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See also 

“Browse to web pages and blog entries” on page 26

Browse to web pages and blog entries

The easiest way to find a web page or blog entry you want to edit is to browse to the page or entry in Contribute like 

you would browse in any web browser. 

To learn other ways to find your web pages or blog entries, see “Open web pages and blog entries without browsing” 

on page 26. 

Note: (Windows only) If you use Microsoft Internet Explorer as your primary web browser, the Contribute browser 

inherits preferences from Internet Explorer. To change basic settings, such as fonts, cookies, or plug-ins, change your 

preferences in Internet Explorer; then start Contribute again.

You can browse to any website or blog entry with Contribute, but you can edit only web pages and blog entries that 

are in your websites and blogs; that is, websites or blogs that you’ve created connections to (for more information, see 

“Connect to a blog” on page 6). When you browse to a page that is in your website or a blog entry that is in your blog 

and that you have permission to edit, the Edit Page button is enabled in the toolbar.

❖ Do one of the following:

• Click links in web pages or blog entries to navigate to other pages.

• Type the web address (URL) of the page in the Address text box, and click Go. You can also press Enter or 

Return.

• Select View > Go To Web Address, enter the web address (URL), and click OK.

See also 

“Open web pages and blog entries without browsing” on page 26

“Edit existing web pages and blog entries” on page 50

Open web pages and blog entries without browsing

You can use Contribute to open web pages and blog entries without browsing to find them. 
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A. Current drafts  B. Bookmarks  C. Home pages  D. Pages that aren’t linked  

View drafts and new pages or blog entries

The Pages panel displays the titles of drafts you are currently editing. You can also access drafts from the File menu.

❖ Do one of the following:

• Click the title of the draft in the Pages panel in the sidebar.

• Select File > Drafts, and then select a draft from the pop-up menu.

See also 

“View home pages for your websites and blogs” on page 27

“View recently published web pages and blog entries” on page 28

“View blog entries” on page 28

“View pages and files that you can’t browse” on page 28

View home pages for your websites and blogs

You can use the toolbar to view the home pages for all your websites and blogs to which you are connected. The View 

menu also gives you access to these pages and blog entries.

❖ Do one of the following:

• Click the Home Pages button in the toolbar, and then select a home page.

• Select View > Home Pages, and then select a home page from the pop-up menu.

A B C D
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See also 

“View drafts and new pages or blog entries” on page 27

“View recently published web pages and blog entries” on page 28

“View blog entries” on page 28

“View pages and files that you can’t browse” on page 28

View recently published web pages and blog entries

The File menu gives you quick access to web pages and blog entries you’ve recently published.

❖ Select File > Recent Pages and Blog Entries, and then select a page from the pop-up menu.

See also 

“View drafts and new pages or blog entries” on page 27

“View home pages for your websites and blogs” on page 27

“View pages and files that you can’t browse” on page 28

View blog entries

The Entries pop-up menu provides quick access to a blog entry from your blog home page.

1 Browse to your blog home page.

2 From the Entries pop-menu, select the blog entry you want to manage. You can also select a blog entry by using 

View > Select Blog Entry > Blog entry title.

The selected blog entry appears in the embedded browser, and the title of the selected blog entry is displayed in the 

Entries pop-up menu.

Note: If a blog entry does not have a title, the title of the blog entry appears as <Untitled Blog Entry> in the Entries pop-

up menu.

See also 

“View drafts and new pages or blog entries” on page 27

“View home pages for your websites and blogs” on page 27

“View pages and files that you can’t browse” on page 28

“View recently published web pages and blog entries” on page 28

View pages and files that you can’t browse

Contribute gives you access to pages and files that are associated with your website or blog but that you can’t browse 

to. Use the Choose button in the toolbar to view pages and files that are saved on a website folder but aren’t linked from 

any page on your website or blog.

1 In the Contribute browser or editor, select View > Choose File or Blog Entry or click the Choose button in the 

browser toolbar.

The Choose File or Blog Entry dialog box appears.
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2 Select a file or blog entry by doing one of the following:

• If the file is in a folder on the website or blog you are currently browsing, select a file.

• If the file is not in a folder on the current website or blog, use the Look In pop-up menu to navigate to the correct 

website or blog folder, and then select a file.

Depending on the type of the file you select, a preview may appear so that you can confirm that you’re selecting the 

correct file.

3 Do one of the following:

• Select Entries Only to display pages with blog entries.

• Select Pages to display a special kind of blog entry. Contents of Pages are stored in a database, and are retrieved 

using protocols like MetaWeblog and Atom.

4 Click OK.

The web page or file appears in the Contribute web browser.

Note: If you select a file type that the Contribute browser can’t display, you’ll see the File Placeholder page.

See also 

“View drafts and new pages or blog entries” on page 27

“View home pages for your websites and blogs” on page 27

“View recently published web pages and blog entries” on page 28

“View blog entries” on page 28

Set up access to commonly used pages

Contribute lets you keep a list of bookmarks for pages that you visit frequently. You can add a bookmark for any page—

not just pages in websites or entries in blogs that you’re connected to. 

View pages in your bookmarks list

You can select pages in your list of bookmarks to quickly view those pages. 

In Windows, Contribute also includes your Internet Explorer bookmarks (up to 2000 bookmarks) in the Other 

Bookmarks list under your Contribute bookmarks.

❖ Do one of the following:

• To view a Contribute bookmark, select the Bookmarks menu, and then select a bookmark from the list.

• (Windows only) To view an Internet Explorer bookmark, select Bookmarks > Other Bookmarks, and then select 

a bookmark from the list.

See also 

“Add bookmarks” on page 30

“Delete bookmarks” on page 30
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Add bookmarks

You can add any web page—not just pages in websites or entries in blogs that you’re connected to—to your bookmarks 

list. You can have as many as 1000 bookmarks. 

1 Browse to the page you want to add to your bookmarks list.

2 Select Bookmarks > Add Bookmark.

The Add Bookmark dialog box appears.

3 To change the title of the bookmark, enter a new title in the Name text box.

This is the name that appears in your bookmarks list.

4 To add the page to a folder, click an existing folder name or click New Folder to add a folder.

5 Click OK.

Contribute adds the page to your bookmarks list in the Bookmarks menu.

See also 

“View pages in your bookmarks list” on page 29

“Delete bookmarks” on page 30

Delete bookmarks

You can delete any page from your bookmarks list, or you can delete a bookmarks folder.

1 Select Bookmarks > Delete Bookmark.

The Delete Bookmark dialog box appears.

2 Select the name of the bookmark or the folder you want to delete.

3 Click Delete.

Contribute removes the page from your bookmarks list in the Bookmarks menu.

4 To delete another bookmark or folder, select it, and then click Delete again.

5 Click Close when you finish deleting bookmarks.

See also 

“View pages in your bookmarks list” on page 29

“Add bookmarks” on page 30

Set Contribute preferences

You use the Preferences dialog box to set your user preferences for Contribute. You can set preferences for blog 

defaults, general editing, file editors, proxy settings, invisible elements, inserting Microsoft Office documents, Adobe® 

PDF® documents, the servers to ping when a blog entry is posted, password security, and blog entry tags. 

You can also set the time intervals at which Contribute automatically saves the draft. This minimizes the possibility of 

losing unsaved changes under unforeseen circumstances.
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Edit user preferences

1 Select Edit > Preferences (Windows) or Contribute > Preferences (Mac OS).

The Preferences dialog box appears.

2 Select an option from the list on the left:

• Select Blog Defaults to set options for the following:

• Default blog in which a blog entry is created

•  Whether to create a blog entry when you click the New button

• Whether comments and trackbacks are allowed by default for blog entries

For more information, see “Setting blog default preferences” on page 39.

• Select Editing to set general editing options, such as how Contribute handles table editing, or to select a spelling 

dictionary (see “Setting editing preferences” on page 40). You can also set your preference for saving the draft 

at regular time intervals.

• Select File Editors to select primary application editors by file type (see “Setting file editor preferences” on 

page 40).

• Select FTP Proxy to add or change settings for your FTP proxy server (see “Setting FTP proxy preferences” on 

page 41).

• Select Invisible Elements to hide or show invisible elements (see “Setting invisible element preferences” on 

page 41).

• (Windows only) Select Microsoft Documents to determine how Contribute handles Office documents (see 

“Setting Microsoft Office document preferences (Windows only)” on page 41).
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• Select PDF Documents to configure the way Contribute handles insertion of PDF documents in draft web pages 

or blog entries. (See “Setting PDF document user preferences” on page 42.)

• Select Ping Servers to add or remove the ping server URLs you want Contribute to notify when you post a new 

blog entry using Contribute. You can also view a list of the most recent failed ping server log entries, up to a 

specified number of entries. (See “Setting ping server preferences” on page 42.)

• Select Security to set up a Contribute startup password (see “Setting security preferences” on page 43).

• Select Tagging to add and remove tagging servers, determine where Contribute adds tags to blog entries, and to 

specify details about the tag repository (see “Setting tagging preferences” on page 44).

Change or disable startup password 

You can change your Contribute startup password as often as you like. Before you can change the startup password, 

you must first successfully enter the current Contribute startup password and start Contribute.

If the Require Password At Startup option is selected in the Contribute Preference dialog box, you must enter the 

correct password to start Contribute and edit website pages. If you forget or don’t know the Contribute startup 

password, you can’t use Contribute to edit pages unless you disable the Contribute startup password requirement. 

Before you can change the startup password requirement, you must remove all your existing website connections.

Change the Contribute startup password

1 Select Edit > Preferences (Windows) or Contribute > Preferences (Mac OS).

The Preferences dialog box appears.

2 Select Security from the option list on the left.

3 Type the new password, and then type the new password again.

4 Click OK. 

Disable a Contribute startup password

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

2 Under Website Name, select a website connection, and then click Remove.

Note: You might have to discard any unpublished drafts before removing the website connections.

3 Repeat step 2 until you remove all website connections.

4 Click Close.

5 Select Edit > Preferences (Windows) or Contribute > Preferences (Mac OS).

6 In the Preferences dialog box, select Security.

7 Deselect the Require Password At Startup option.

8 Click OK.
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Set browser encoding

To specify how a page should appear in the Contribute browser, you can set the browser encoding for that page. You 

might need to set encoding if characters aren’t displayed properly in the Contribute browser.

1 In the Contribute browser, right-click (Windows) or Control-click (Mac OS) on the page.

2 Select Encoding, and then select an option from the pop-up menu.

Contribute accessibility features

Accessibility refers to making websites and web products usable by people with visual, auditory, motor, and other 

disabilities. Contribute provides features that make it accessible to users with disabilities.

It’s important to make your web pages accessible to all your website visitors. 

The U.S. government and other organizations have established accessibility legislation and guidelines. For more 

information about two significant initiatives, see the World Wide Web Consortium Web Accessibility Initiative 

(www.w3.org/wai) and Section 508 of the Federal Rehabilitation Act (www.section508.gov).

Also, as you edit your pages, remember that some visitors use screen readers. Contribute helps you make your images 

and tables more accessible in the following ways:

• You can add text that screen readers recite to describe images on your pages. Your Contribute administrator can 

have Contribute prompt you for descriptive text whenever you insert an image. For more information, talk to your 

Contribute administrator or see “Set page-editing and paragraph settings” on page 288.

• You can include table headings to be recited by screen readers. To insert tables with headings, see “Insert tables” on 

page 158.

Note: Screen readers do not read boldface headings centered in a row or column.

Use screen readers with Contribute

A screen reader recites text that appears on the computer screen. It also reads nontextual information, such as button 

labels or image descriptions.

You can use a screen reader when you edit your web pages. The screen reader starts reading at the upper left corner of 

the application.

Contribute supports the following screen readers:

• JAWS® for Windows®, from Freedom Scientific® (www.freedomscientific.com)

• Window-Eyes screen readers, from GW Micro® (www.gwmicro.com)

See also 

“Use operating system accessibility features” on page 33

“Use the keyboard to navigate Contribute” on page 34

Use operating system accessibility features

Contribute supports the Windows operating system high-contrast setting. You activate this setting through the 

Windows Control Panel. 

http://www.w3.org/wai
http://www.section508.gov
http://www.freedomscientific.com
http://www.gwmicro.com


34USING CONTRIBUTE CS4

Workspace

When high contrast is on, Contribute responds as follows:

• Dialog boxes and panels use system color settings.

For example, if you set the color to White On Black, all Contribute dialog boxes and panels appear with a white 

foreground color and black background.

• The Contribute editor uses the background and text colors you set in Format > Page Properties so that your pages 

render colors as a website visitor’s browser renders them.

See also 

“Use screen readers with Contribute” on page 33

Use the keyboard to navigate Contribute

While you are editing, you can use the keyboard to navigate the Contribute workspace, dialog boxes, and tables 

without a mouse.

You can also use keyboard shortcuts to open some dialog boxes and perform some commands. For a list of shortcuts, 

see “Windows keyboard shortcuts” on page 307.

You can use keyboard shortcuts to navigate the Contribute workspace—that is, to select commands from the menus 

and to switch between the Contribute browser and editor. For a complete list of Contribute keyboard shortcuts, see 

“Windows keyboard shortcuts” on page 307.

All the items in the Pages panel and toolbar are accessible through the menus. To view task information in the How 

Do I panel, use Contribute Help (Help > Adobe Contribute Help).

Keyboard shortcut to switch from the Contribute browser to the editor

❖ Do one of the following:

• Press Control+Shift+E (Windows) or Command+Shift+E (Mac OS), to edit the current page.

Note: This has the same effect as clicking the Edit Page button in the toolbar.

• (Windows only) Press Alt+F, press Alt+F again, and then use the arrow keys to select a current draft or new page 

from the pop-up menu.

The drafts and new pages listed in the Pages panel appear in this list.

Keyboard shortcut to switch from the Contribute editor to the browser

❖ Press Control+Shift+B (Windows) or Command+Shift+B (Mac OS).

Note: This has the same effect as clicking Browser in the Pages panel.

See also 

“Keyboard shortcuts to navigate dialog boxes” on page 34

“Keyboard shortcuts for navigating in tables” on page 35

Keyboard shortcuts to navigate dialog boxes

You can use the keyboard to navigate dialog boxes.

• To move through dialog box options, press Tab.

In Mac OS, pressing Tab moves the insertion point from one text field to the next.
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• To accept a choice and exit the dialog box, press Enter or Return.

• To close the dialog box without making any changes, press Escape or Alt+F4 (Windows).

• (Windows only) To move through choices for an option, use the arrow keys.

For example, if an option has a pop-up menu, move focus to that option, use the Down Arrow key to move through 

the choices.

• (Windows only) To move through an option list, press Control+Tab to shift focus to the option list, and then use 

the arrow keys to move up or down the list.

To see an example of an option list, select Edit > Preferences. 

• (Windows only) To shift to the options for an option in an option list, press Control+Tab.

See also 

“Keyboard shortcuts for navigating in tables” on page 35

Keyboard shortcuts for navigating in tables

After you select a table, you can use the keyboard to navigate through it.

1 In the Contribute editor, do one of the following to select the table:

• If the insertion point is to the left of the cell, press Shift+Right Arrow.

• If the insertion point is to the right of the cell, press Shift+Left Arrow.

2 Press the Down Arrow key to position the insertion point in the first cell.

3 Use the arrow keys or press Tab to move to other cells as necessary. 

Pressing Tab in the rightmost cell of a row adds another row to the table.  

4 To select a cell, press Control+A (Windows) or Command+A (Mac OS) while the insertion point is in the cell.

5 To exit the table, use the Select Table Cell command (Control+A) or Command+A (Mac OS); then press the Up, 

Left, or Right Arrow key.

Reference

This section provides information about the dialog boxes introduced in this chapter.

Completing the Go To Web Address dialog box 

Use the Go To Web Address dialog box to find a specific web page, if you know the page’s web address.

1 Enter an address in the Web Address (URL) text box.

2 Click OK.

Using the Choose <Image/Library Item/SWF Content> dialog box

Use the Choose Image, Choose Library Item, or Choose SWF Content dialog box to select one or all images, library 

items, or SWF content in a folder, to include as Shared Assets.
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Select an image in the Choose Image dialog box

1 Select an image from the required folder.

2 (Optional) Click the Select All Files In Folder button, and click OK.

If you select a single file, a preview appears so that you can confirm that you’re selecting the correct entry.

3 Click OK in the message box that appears.

The Shared Asset Properties dialog box appears with the Web address of the image file.

4 The title of the image file appears in the Name field. You can modify the title.

5 Specify a relevant value in the ALT Text field. ALT text describes the image for people with disabilities or for people 

whose browsers are set to only display text. 

6 Click OK. The selected image file appears in the Shared Assets list.

Note: You can select one or more shared assets in the list and click Edit or Remove.

To select a SWF file in the Choose SWF Content dialog box:

1 Select a SWF movie from the required folder.

2 (Optional) Click the Select All Files In Folder button, and click OK.

If you select a single file, the SWF icon appears in the Preview area.

3 Click OK in the message box that appears.

The Shared Asset Properties dialog box appears.

4 The title of the SWF movie file appears in the Name field. You can modify the title.

The Web address of the SWF movie appears below the Name field.

5 Click OK. The selected SWF movie file appears in the Shared assets list.

Select a Library Item in the Choose Library Item dialog box

1 Select a Dreamweaver library item (.lbi file) from the required folder.

2 (Optional) Click the Select All Files In Folder button, and click OK.

If you select a single file, the Dreamweaver icon appears in the Preview area.

3 Click OK in the message box that appears.

The Shared Asset Properties dialog box appears.

4 The title of the Library file appears in the Name field. You can modify the title.

5 Determine the Editing behavior by selecting the Lock Item On Page Check box.

The Web address of the Library file appears below the Name field.

6 Click OK. The selected Library file appears in the Shared Assets list.

Note: If you select multiple files in a folder, the files names are listed in the Shared Asset Properties dialog box. You can 

select a file, and click the Name column or the ALT Text column to modify the title or the ALT Text value of the file.
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Using the Choose File or Blog Entry dialog box

This dialog box is displayed when, from the View menu, you select the Choose File or Blog Entry option. You can view, 

edit, or delete specific entries in your blog using the Choose File or Blog Entry dialog box.

1 Select an entry by doing one of the following:

• If the entry is in a folder on the blog you are currently browsing, select an entry.

• If the entry is not in a folder on the current blog, use the Look In pop-up menu to navigate to the correct blog 

folder, and then select an entry.

Click the Up One Level icon if necessary. 

A preview might appear so that you can confirm that you’re selecting the correct entry.

2 Do one of the following:

• Select Entries Only to display pages with blog entries.

• Select Pages to display a special kind of blog entry. Contents of Pages are stored in a database, and are retrieved 

using protocols like MetaWeblog and Atom.

3 Choose from the following options:

• Click the View button to see the selected entry in the Contribute browser.

• Click the Edit button to open the selected entry as a draft in the Contribute editor.

• Click the Delete button to remove the selected entry from your blog.

4 If you clicked Delete, click Yes in the confirmation dialog box, and then click Close to close the Choose File or Blog 

Entry dialog box.

Completing the Choose File or Blog Entry dialog box

While editing a web page or blog entry, you can use the Choose File or Blog Entry dialog box to find web pages, blog 

entries, PDFs, and other files in the websites and blogs you’re connected to.

1 Select an item by doing one of the following:

• If the item is in a folder on the website or blog you are currently browsing, make a selection.

• If the item is not in a folder on the current website or blog, use the Look In pop-up menu to navigate to the 

correct folder, and then make a selection.

Depending on what you select, a preview might appear so that you can confirm that you’re making the correct 

selection.

2 Do one of the following:

• Select Entries Only to display pages with blog entries.

• Select Pages to display a special kind of blog entry. Contents of Pages are stored in a database, and are retrieved 

using protocols like MetaWeblog and Atom.

3 Click the folder icons as necessary:

• Up One Level moves the selection up one level in the folder structure.

• New Folder lets you add a folder.

• Delete Folder removes the selected folder.

Note: You can delete folders only if they are empty. 
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4 Click OK.

The file is opened in the right pane.

Completing the New Folder dialog box

The purpose of the New Folder dialog box is to add a new folder to your website or to your list of bookmarks.

1 Enter a name for the folder.

2 Click OK.

Completing the Add Bookmark dialog box

The purpose of the Add Bookmark dialog box is to add a page to your list of bookmarks.

1 To change the name of the bookmark, enter a new name in the Name text box.

This is the name that appears in your bookmarks list.

2 To add the page to a folder, click an existing folder name or click New Folder to add a folder.

3 Click OK.

Contribute adds the page to your bookmarks list in the Bookmarks menu.

See also 

“Add bookmarks” on page 30

Completing the Delete Bookmark dialog box

The purpose of the Delete Bookmark dialog box is to remove a page or folder from your list of bookmarks.

1 Select the name of the bookmark or the folder you want to delete.

2 Click Delete.

Contribute removes the page from your bookmarks list in the Bookmarks menu.

3 To delete another bookmark or folder, select it, and then click Delete again.

4 Click Close when you finish deleting bookmarks.

See also 

“Delete bookmarks” on page 30
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Setting blog default preferences

Use the Blog Defaults option of the Preferences dialog box to set blog default options. You can select the default blog 

server in which Contribute creates a blog entry, whether clicking the New button creates a new blog entry, and whether 

comments and trackbacks are allowed by default for blog entries.

1 Select the options you want to set:

• Select the blog in which you want Contribute to create a blog entry from the Default Blog pop-up menu.

Contribute creates a blog entry in the blog you select when you click the New Entry button as well as when you 

post to the blog from a Microsoft Office document or from a browser such as Internet Explorer (Windows) or 

Firefox. Contribute also creates a blog entry in this blog if you select the Create a new blog entry when the “New” 

button is clicked preference option, which is described in this section. Finally, Contribute creates a blog entry in 

this blog when you quote information from a website or blog entry you are currently viewing.

For more information on creating a blog entry from a quoted selection, see “Create a blog entry based on a 

quoted selection” on page 83.

All blogs to which you have a Contribute connection are listed. When a user doesn’t specify a blog in which to 

create a blog, the first blog is listed in the pop-up menu by default.

• Select or clear Create A New Blog Entry when the “New” button is clicked.

When this option is enabled, the name of the New button changes to New Entry. Contribute creates a new blog 

entry in the blog you selected from the Default Blog pop-up menu, which is described in this section.

If you don’t enable this option, clicking the New button opens the New Web Page Or Blog Entry dialog box.

• Select or deselect Allow Comments.

When this option is enabled, Contribute allows the blog server to accept comments for blog entries.

This option is enabled by default when you create a blog entry. You can disable it before posting the blog entry.

Some blogs do not support comments. For more information, see your blog documentation.

In the Contribute browser, you can select Format > Blog Metadata > Allow Comment or click the Allow 

Comments button in the toolbar to allow comments. For more information about allowing comments, see 

“Allow comments for blog entries” on page 91. The Allow Comments button is highlighted when selected and 

dimmed when it is not selected.

• Select or deselect Allow Trackbacks.

When this option is enabled, Contribute notifies the blog server to allow other users to link to a blog entry using 

its trackback URL. A trackback URL is associated with the posted blog entry, which can be used to track other 

posts that refer to the entry. Other blog authors use the trackback URL when they add a reference to the blog 

entry. The blog server maintains a list of links to blogs that reference a blog entry’s trackback URL. Users can 

click the links to go to these blogs.

In the Contribute browser, you can select Format > Blog Metadata > Allow Trackback or click the Allow 

Trackback button in the toolbar to enable trackbacks. The Allow Trackback button is highlighted when selected 

and dimmed when it is not selected.

To insert a trackback URL, select Insert > Trackback URL or click the Insert Trackback button on the Contribute 

toolbar, and then paste the trackback URL of the original post to be tracked.

Some blogs do not support the trackback feature or require you to set a preference to allow it. For more 

information, see your blog documentation.

2 Click OK. 
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See also 

“Set Contribute preferences” on page 30

Setting editing preferences

Use the Editing option of the Preferences dialog box to set editing options. 

1 Select the options you want to set:

• Select or deselect Enable screen reader support.

When this option is enabled, Contribute disables offscreen rendering of pages so that a screen reader can be used.

• Select a dictionary from the Spelling dictionary pop-up menu.

• To automatically save files at regular intervals, select Save Contents In The Background, and enter a value for 

the time interval.

2 Click OK. 

See also 

“Set Contribute preferences” on page 30

Setting file editor preferences

Use the File Editors option of the Preferences dialog box to select or change your primary editing applications for each 

type of file you edit. When you need to edit web page content, such as an image, in an external application, Contribute 

starts that application. 

Note: Before you set file editor preferences, make sure to close the application you want to set as a file editor.

Change the editor for a file type

1 Select a file type in the left pane.

Associated editors appear in the right pane. If the application you want to select is in the pane, skip to step 5.

2 Click the Plus (+) button above the right pane.

The Select External Editor dialog box appears.

3 Navigate to the application you want to add, and click Open.

The application name appears in the right pane.

Note: You can associate an editor with the Web Page Source type, but if the Contribute administrator has not enabled 

source editing for your website, you cannot start an external application to edit the source.

4 Select the application you want Contribute to start for the selected file type, and then click the Make Primary 

button.

The word Primary appears beside the application name.

5 Click OK. 

Add a file type and associate an editor

1 Click the Plus (+) button above the left pane, and then type the file type.

2 Click the Plus (+) button above the right pane.

The Select External Editor dialog box appears.
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3 Navigate to the application you want to associate with the new file type, and click Open.

The application name appears in the right pane.

4 Click OK. 

Delete a file type or associated editor

1 Select a file type in the left pane or an application in the right pane.

2 Click the Minus (-) button above the pane.

The file type or application name disappears from the pane.

Note: You cannot delete the Web Page Source type.

3 Click OK. 

See also 

“Set Contribute preferences” on page 30

Setting FTP proxy preferences

Use the FTP Proxy option of the Preferences dialog box to enter or change your FTP proxy host and port.

1 In the FTP proxy host text box, enter the name of the firewall host.

2 In the FTP proxy port text box, enter the network port number through which FTP access is enabled.

3 Click OK. 

See also 

“Set Contribute preferences” on page 30

Setting invisible element preferences

Use the Invisible Element option of the Preferences dialog box to turn invisible elements, such as section anchors, on 

or off.

Note: For more information about section anchors, see “Link to a specific place in a page” on page 186.

1 Select or deselect the Show section anchors when editing a page check box.

2 Click OK.

See also 

“Set Contribute preferences” on page 30

Setting Microsoft Office document preferences (Windows only)

Use the Microsoft Documents option in the Preferences dialog box to select a preference for inserting Microsoft 

documents.

1 Select an option to specify the default action that Contribute performs when you insert a Microsoft document in a 

draft:

Insert The Contents Of The Document Into The Current Draft Copies the content of the selected document into the 

draft.
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Create A Link To The Document Inserts a link to the selected document.

Convert To PDF And Create A Link To The PDF Converts the selected document into a PDF and inserts a link to the 

PDF document.

Convert To PDF And Embed The PDF As Object Converts the selected document into a PDF and embeds the PDF 

document as an object.

Ask Whenever I Insert A Microsoft Office Document Into Contribute Lets you select how you want to insert the 

Office document.

2 Click OK.

See also 

“Set Contribute preferences” on page 30

Setting PDF document user preferences

As a Contribute user, you can use the PDF Documents option in the Preferences dialog box to select a preference for 

inserting PDF documents in draft web pages or blog entries.

1 Select an option to specify the default action that Contribute performs when you insert a PDF document in a draft: 

Create A Link To PDF Document Inserts a link to the selected document.

Insert PDF As An Embedded Object Inserts the PDF file into the draft as an object.

Ask Whenever I Insert A PDF Document Into Contribute Lets you select how you want to insert the PDF document.

2 Click OK.

Note: You can insert the PDF as an embedded object only if the Administrator has granted the Allow PDF Embedding 

permission for the relevant website or blog connection.

See also 

“Set Contribute preferences” on page 30

Setting ping server preferences

Use the Ping Server option of the Preferences dialog box to add and remove ping server URLs to notify when a blog 

entry is posted, to view a list of pings to the ping servers, and to enter the maximum number of failed pings to store for 

the listed ping servers.

Add the URL of a ping server to notify when a blog entry is posted

1 Click the Plus (+) button above the Ping Servers pane.

2 In the Ping Servers pane, enter the URL for the server (for example, http://rpc.technorati.com/rpc/ping, or 

http://ping.blo.gs), and press Tab.

If the URL is invalid, an error message appears. You can click OK to add the invalid URL and correct it later.

3 (Optional) Repeat step 2 to add additional ping server URLs.

4 Click OK.

Delete a ping server

1 In the Ping Servers pane, select the desired ping server URL.
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2 Click the Minus (-) button above the Ping Servers pane.

3 Click OK.

View a log of failed ping server entries

1 Click the View Log button.

The Failed Ping Servers Log dialog box opens, listing the ping server URLs to which a ping update request failed. 

As many as 100 entries are listed, depending on the maximum number of entries you specify in the Maximum 

Number Of Log Entries field in the Ping Server pane. If there are more than 100 entries, the oldest entry is deleted.

2 (Optional) Click the Clear Log button to clear the log.

3 Click OK.

Determine the maximum number of log entries to list in the Failed Ping Servers log

1 In the Maximum Number Of Log Entries field, enter the maximum number of entries to display when you click the 

View Log button that opens the Failed Ping Servers Log dialog box.

If the number of entries in the Failed Ping Servers Log dialog box exceeds the number you specify, the oldest entries 

are deleted so that the most recent number of entries are displayed. You can specify as many as 100 log entries (the 

default setting).

2 Click OK.

See also 

“Set Contribute preferences” on page 30

Setting security preferences

Use the Security option of the Preferences dialog box to use a stronger encryption method when storing website 

connection information on your computer.

If you require this password at startup, you can prevent other people with access to your computer from making 

changes to your Contribute websites. 

1 Select Encrypt Connection Information For All Websites and blog sites to let Contribute encrypt connection 

information, such as user name and password.

2 Type a password in the Password text box.

Contribute uses this password to encrypt information. It restricts access at startup if an incorrect password is 

entered.

3 In the Confirm Password text box, type the password again.

Note: If the passwords do not match, you see an error message asking you to retype and confirm the password.

4 (Optional) Select Require Password At Startup to enter the password each time you start Contribute.

When you require a startup password, anyone using Contribute on your computer must provide the correct 

password in order to edit, add, or delete pages in your websites. 

Note: Be sure to keep your password information secure and do not lose it. If you lose your password, you must remove 

all of your Contribute website connections before you can use Contribute to make changes in your websites.

5 Click OK.
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See also 

“Set Contribute preferences” on page 30

“Change or disable startup password” on page 32

Setting tagging preferences

Use the Tagging option of the Preferences dialog box to specify how Contribute will use tags with blog entries you 

create or edit. You can specify where tags appear in your blog entries, enter a tag prefix to use with tags, add and remove 

tag repositories, and specify a default tag repository. 

When you specify a tag repository to use for your blog entries, users can search this repository for blog entries that use 

one or more tags. The user can view any blog entry you created that uses a tag that they entered in their search.

For more information about tagging, see “Add tags to a blog entry” on page 89. 

Determine where tags appear and enter a tag prefix

1 Select whether tags appear at the top or bottom of blog entries from the Default Tag Placement pop-up menu.

2 If you would like to use a specific tag prefix, enter a tag prefix in the Tag Prefix field.

3 Click OK.

Enter a new tag repository

1 Click the Plus (+) button above the Tag Repositories pane. 

2 In the Tag Repositories pane, enter the URL for the repository you want to add, and press Tab.

If the URL is invalid, an error message appears. You can click OK to add the invalid URL and correct it later.

3 (Optional) Repeat step 2 to add other tag repository URLs.

4 Click OK.

Specify a default tag repository

1 In the Tag Repositories pane, select the repository you want to set as the default.

The first repository listed is specified as the default, but you can select a different repository.

2 Click the Make Default button.

3 Click OK.

Delete a tag repository

1 In the Tag Repositories pane, select the tag repository you want to delete.

2 Click the Minus (-) button above the Tag Repositories pane.

3 Click OK.

See also 

“Set Contribute preferences” on page 30



45USING CONTRIBUTE CS4

Workspace

Using the Failed Ping Servers Log dialog box

The Failed Ping Servers Log dialog box lists the ping server URLs to which a ping update request failed. As many as 

100 entries are listed, depending on the maximum number of entries you specify in the Maximum Number Of Log 

Entries field in the Ping Server pane of the Preferences dialog box. If there are more than 100 entries, the oldest entry 

is deleted.

1 (Optional) Click the Clear Log button to clear the log.

2 Click OK.

See also 

“Setting ping server preferences” on page 42
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Chapter 4: Working with existing web 
pages and blog entries

Adobe® Contribute® lets you edit existing web pages and content on your website and to edit existing blog entries and 

content on your blogs. You can cancel your edits or cancel a new web page or blog entry. You can delete blog entries 

and, with permission, you can delete web pages and other files on your website. You can also export a page to an HTML 

file. For information about creating pages, see “Create or copy a page on your website” on page 76.

Web pages with a workflow other than Author > Publish must be approved/reviewed before you can publish it. When 

you publish the web page draft, Contribute updates the existing web page with your edits. You publish drafts of blog 

entries in the same way, with the exception of sending a draft of a blog entry to other users.

You can now experience the benefits of Contribute in browsers such as Microsoft Internet Explorer and Mozilla 

Firefox. Using the Contribute toolbar in these browsers, you can add and edit web pages, publish web pages to your 

website, or publish to a blog directly from the browsers.

Overview of working with blogs and web pages

You can use Contribute to edit existing blog entries on your blog and existing pages on your website, including web 

pages based on templates. 

Note: You cannot edit web pages created with in-context editor (ICE) in Contribute.

The draft review process

The review process for a draft web page depends on the workflow assigned to its template. Administrators enforce 

workflows to web pages by assigning predefined workflows in Contribute templates. When you create a web page using 

a template, it is assigned the workflow associated with that template. Contribute assigns a default workflow to the 

following:

• Templates that are not assigned a workflow

• Starter web pages

• Web pages created without using a template

If your web page is created in an application other than Dreamweaver®, it is assigned the workflow of its linked page 

in Contribute.

The strict enforcement of workflows in Contribute help maintain a disciplined author-centric approach to the 

authoring and publishing process. In previous versions of Contribute, a reviewer could send the page to another 

reviewer without the web page coming back to the author.

The four workflows available in Contribute are:

Author > Publish Authors can directly publish a web page after creating it if they have publish permissions.

Author > Review > Publish The author must get the web page reviewed before publishing it.

Author > Approve > Publish The author must get the web page approved before publishing it.

Author > Review > Approve > Publish The author must get the web page reviewed and approved before publishing it.
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For all workflows other than Author > Publish, the web page must be reviewed/approved before it is published. 

When users receive a web page, the toolbar displays buttons for actions that the users can perform and to which they 

have permissions. Actions are similarly enabled or disabled in the menu bar (File > Actions.)

For example, a webpage test.htm is associated to a template that has the Author > Review > Publish workflow assigned 

to it. When authors complete adding content to the page, they can only send it for review. The Publish button does not 

appear in the toolbar until the web page comes back from the reviewer. Similarly, the toolbar of the reviewer has 

buttons for only those actions available to the reviewer. When the reviewer completes reviewing the web page, it can 

only be sent back to the author for further action. 

Workflows are defined in XML files, and decide the course of the web page from its authoring stage to the time it gets 

published. It is possible to create your own workflow by customizing an existing XML file. However, Contribute checks 

only for syntax errors in such XML files. 

The XML files for workflows are protected on the server, and users cannot download and edit these files.

Note: Workflows cannot be assigned to blog pages.

You can send a draft for edit, review, or approval to anyone who has connected to the website. Contribute stores user 

names when users connect to the website. You can send the draft to multiple reviewers at the same time. However, 

only one reviewer can review the draft at a given time. When you send a draft for review or approval, you transfer 

“ownership” of that draft. You cannot proceed to the next stage in the workflow until the draft comes back from all the 

people to which it has been sent.

All the users, to whom the web page draft has been sent, must approve the draft. If even one user rejects the draft, it is 

removed from the Pages panel of all the users to which it has been sent. The draft is then returned to the author.

When you receive a draft for review or approval, it appears in your Pages panel in Contribute. You might also receive 

an e-mail message from the sender to alert you that you have a draft to review or approve. When you complete editing, 

reviewing, or approving the draft, the draft is returned to the author.

The following table lists the actions that are available in Contribute during the life cycle of the web page. Only those 

actions are available to users for which they have permissions, and which can be performed at that stage of the web 

page life cycle.

Action Description

Publish Publishes the web page. All intermediate drafts are deleted and all inbox messages are 

removed.

Send Uploads the files to a temporary location in the site and sends messages to the 

recipients. The task for a draft sent to multiple recipients is closed only when all the 

recipients perform one of the actions assigned to them, or when one of the actions like 

publish, or delete terminates the workflow. The options available for this action are 

listed in the subsequent rows.

Send for Edit Sends the page for editing.

Send for Approval Sends the page for approval. The approver cannot edit or review the draft.

Send for Review Sends the page for review. The reviewer cannot edit the web page; only comment on it.

Send for Publish Sends the page for publishing if the author does not have permissions to publish.

Edit Draft Opens the draft for editing.

Edit Done Closes the edit session. The web page moves to the next step in the workflow.

Delete Draft Deletes the draft in the WIP (work in progress) state and closes the workflow.
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Web pages continue to use the initial workflow of a template till they are published. Any changes made to the workflow 

during the draft cycle are reflected only when the web page re-enters the cycle.

You can select the option to publish a web page along with its dependent files and linked files if they are in the same 

workflow. The location of linked/dependent files that have a different workflow is finalized on the site, but they are not 

published.

All dependent files of the published file are published along with the published page. Shared dependent files are also 

published. However, dependent files exclusive to the linked file are published with the linked file. 

For example, consider the following case:

• Page1.htm is based on the template template1.dwt with the workflow Author > Publish.

• Page2.htm is based on the template tempate2.dwt with the workflow Author > Review > Publish.

• Page1.htm is associated with the dependent files (assets) wav1.mp3 and video1.mpeg.

• Page2.htm is associated with the wav1.mp3, and video2.mpeg files as its dependent files (assets). 

When Page1.htm is published, the dependent files wav1.mp3, and video1.mpeg are also published. The location of 

Page2.htm is finalized on the site, but it is not published until the workflow of Page2 is complete. The dependent file 

video2.mpeg is published only when Page2.htm gets published.

The status and information of a page at any stage of the lifecycle is available on the status bar, the draft history, and the 

Draft Console.

Users connecting to a website administered using a previous version of Contribute cannot use the workflow feature 

until the site is upgraded. Users with previous versions of Contribute cannot assign a workflow to their templates. 

When they send their pages for review to users of Contribute CS4, the reviewers can use only those features that were 

available in the previous release.

Users of previous versions of Contribute can receive pages created in Contribute CS4 only after they upgrade. For 

Contribute CS4 pages that have been sent to users with previous versions, the author can undo the send, and retrieve 

the file.

The e-mail review process

The Contribute e-mail review process uses your default e-mail application to create a message containing a web 

address where reviewers can see a temporary copy of your draft. Contribute automatically creates the temporary copy 

on the same server where you publish your website. The recipient clicks the web address (URL) link in the e-mail 

message to view your draft.

Delete Page Deletes the page from the website.

Discard Draft Clears any changes made to the draft.

Undo Send Returns the draft to the person who sent it and deletes it from the inbox of the 

recipients.

Return Returns the draft to the sender if the web page has been unaltered. 

Review Opens the web page for review.

Review Done Closes the review session.

Reject Rejects the draft. Even if one of the reviewers rejects the draft, the draft is deleted from 

the inbox of all the other reviewers. The draft is returned to the author.

Action Description



49USING CONTRIBUTE CS4

Working with existing web pages and blog entries

When you send an e-mail review request, Contribute displays a message under the toolbar to alert you that you sent 

the draft for review; the message includes the date you sent the review request. You can then save the draft for later, 

until you get feedback from your reviewer, or you can continue editing the draft.

After reviewing your draft, the reviewer can send you feedback by e-mail. The reviewer cannot edit the review draft. 

You can make changes to your draft based on the reviewer’s feedback, and then publish the draft or request another 

review. When the draft is canceled or published, Contribute removes the temporary copy of the draft that it placed on 

the server for the reviewer.

E-mail review process

About templates

A Dreamweaver template contains a preset page layout and includes elements such as text and images. A template 

gives you a starting point for new web pages and blogs. Using a template can ensure that the pages on your website or 

blog have a consistent look. 

Templates are also associated to workflows. Web pages created using a template will follow the workflow assigned to 

it. For more information about workflows, see “The draft review process” on page 46.

For example, on a company’s internal website, the company employee template might contain basic elements and 

provide sections for employee information. Suppose the template has the company logo and address, and blank 

sections for the employee’s name, department, phone number, and picture. Any new employee page based on the 

company employee template inherits the same page layout.

In a template, the designer creates regions to control which elements of a template-based page you can edit. There are 

editable regions in a template, which you can edit, and locked regions, which you can’t edit. In the employee template 

example, the company logo and address might be in a locked region. The employee information sections would be 

editable regions.

You request an
e-mail review.

Reviewer clicks
link in e-mail to
view the draft.

Reviewer sends
you e-mail

with feedback.

You make edits
to draft

as necessary.

You are ready
to publish!

Finished?
YesNo

1 2 3 4

5
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A. Locked region  B. Template tab  C. Editable region  

See also 

“Edit a template-based web page” on page 62

Edit existing web pages and blog entries

You can edit web pages on websites and blog entries on blogs that you’re connected to and have permission to edit (see 

“Connect to a blog” on page 6). You cannot edit a web page or blog entry if it is locked—that is, if someone else is 

currently editing it. When you browse to a web page or blog entry, the message area under the toolbar indicates 

whether you can edit it.

Contribute supports editing content in dynamic sites that use the Atom and MetaWeblog blog protocols.

While you edit a web page or blog entry, Contribute saves it as a draft, and the draft title appears in the Pages panel in 

the sidebar. 

The Pages panel

A

B

C
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For more information, see “Edit a web page” on page 51. For information about working with drafts, see “Save drafts” 

on page 55. 

Note: To edit a Microsoft document that you’ve linked to on your website, see “Edit web pages in an external application” 

on page 67.

There might be restrictions on which parts of a web page draft you can edit. Your template designer can create a 

template with locked regions, or your Contribute administrator can set up editing constraints that restrict editing to 

text only. 

Note: If you do not have permission to edit a page or part of a page that you need to edit, talk to your Contribute 

administrator or see “Managing users and roles” on page 280.

You can also use Contribute plug-ins to edit web pages and blog entries from your browser, such as Internet Explorer 

and Mozilla Firefox. For more information, see “Edit a web page or blog from your browser” on page 52.

Edit a web page 

After you’ve connected to a website, you can easily browse to and edit pages on that website. 

1 Browse to the page to edit (see “Browse to web pages and blog entries” on page 26).

2 Do one of the following:

• Click the Edit Page button in the toolbar.

• Select File > Actions > Edit Page.

The page appears in the Contribute editor as a draft, and the draft title appears in the Pages panel.

See also 

“Edit existing web pages and blog entries” on page 50

“Save drafts” on page 55

Edit a blog

You can make changes to a blog entry in two ways. You can edit an entry directly in Contribute. Alternatively, if you 

have an entry in a browser window, you can click the Edit In Contribute button to start Contribute, where you can edit 

the entry. For more information, see “Edit a web page or blog from your browser” on page 52.

Note: If the Edit Page or Edit Entry button is not visible in the toolbar in the Contribute application, you aren't connected 

to the blog server hosting the blog. Click the Create Connection button in the toolbar to create a connection to the blog 

server.

1 Browse to your blog home page.

2 From the Entries pop-up menu, select the blog entry you want to manage, or select View > Select Blog Entry > blog 

entry title and choose the relevant blog entry to edit. Alternatively, select View > Choose File or Blog Entry, and in 

the Choose File or Blog Entry dialog box, click the Edit button.

The selected blog entry appears in the embedded browser, and the title of the selected blog entry is displayed in the 

Entries pop-up menu.

3 Click the Edit Entry button or select File > Actions > Edit Entry.

The blog entry opens as a draft in Contribute. You can make your changes to the content as needed, and publish 

the entry.
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Note: You can link this blog entry to a blank blog entry and publish the entries. For more information, see “Link to a 

new blank blog entry” on page 179.

See also 

“Edit existing web pages and blog entries” on page 50

“Save drafts” on page 55

“Manage blog entries” on page 84

Edit a web page stored on your computer

You can use Contribute to edit pages that aren’t on a website you’ve connected to; you can open an HTML page saved 

on your computer and make your edits. The experience is similar to using Notepad or TextEdit, but it has the ease of 

use and functionality of Contribute.

For example, suppose you receive an HTML page in e-mail that you need to edit for a coworker. Even if the page isn’t 

associated with a website you’ve connected to, you can save the page to your computer, open and edit the page in 

Contribute, and return it to your coworker.

Note: Do not create a connection to your local drive. If you do, Contribute treats files saved on your computer as files on 

a website, and the Direct Edit feature does not work properly.

1 In the Contribute browser or editor, select File > Open.

The Open dialog box appears.

Note: You cannot use this feature to open and edit TXT files saved on your computer.

2 Navigate to and select the file you want to edit, and then click Open.

The page opens as a draft in the Contribute editor; the toolbar contains Save and Close buttons instead of Publish 

and Discard Draft buttons. 

Note: Administrator preferences are not applied because this page is not part of a website. To enforce preferences for 

pages that are edited this way, see the Contribute Support Center at http://www.adobe.com/support/contribute/.

See also 

“Save drafts” on page 55

Edit a web page or blog from your browser 

You can use Contribute plug-ins to open your web pages and blog entries for editing in Contribute directly from your 

web browser. You can also directly edit a web page or blog entry within the web browser without opening Contribute. 

The web page will follow the workflow assigned to its template after the editing is complete.

Unlike the Contribute application, the in-browser editor opens in the edit mode only. Tasks like administering the 

website, creating a connection, and setting preferences cannot be performed in the in-browser editor. The in-browser 

editor honors site connection settings, permissions, and workflow settings in Contribute. The web pages follow the 

workflow assigned to their templates in Contribute.

You cannot connect to a web site using the Internet browser. Connect to your website or blog in Contribute before you 

edit a web page or blog entry in your browser. See “Create a website connection” on page 231 and “Create a blog server 

connection” on page 233. You are prompted to connect to the page if you haven’t done so already. 

http://www.adobe.com/support/contribute/


53USING CONTRIBUTE CS4

Working with existing web pages and blog entries

When you choose to edit the web page or blog entry in the web browser, Contribute launches the in-browser editor 

(IBE). The in-browser editor is the editor in Contribute that runs within the web browser. You can only edit published 

pages in the in-browser editor. You cannot create new web pages or blogs using the IBE.

The in-browser editor has three areas: toolbar area, edit area, and status area. The edit area and status area look the 

same as in the Contribute application.

The toolbar in the in-browser editor is different from the one in Contribute in the following ways. 

The IBE toolbar: 

• Displays only those actions that can be performed in the in-browser editor and are available to the user. 

• Does not have a menu bar. Some of the actions available only in the menu bar in Contribute have been moved as 

new icons to the toolbar.

• Does not have buttons for some of the tasks in Contribute that are not commonly used. 

You can use the same keyboard shortcuts that you use in Contribute while working in the in-browser editor. You can 

drag and drop images into the in-browser editor during editing, like in Contribute.

When you open a page for editing in the browser, the URL changes to the one set by the in-browser editor. The original 

URL is displayed after you perform an action on the page. 

Note: If you close the in-browser editor or the tab containing it, the web page draft is available in the pages panel of 

Contribute.

Web pages must be sent for review, edit, or approval before they are published. When you complete editing a page, 

and choose the appropriate send action, you are prompted to select the reviewers, or approvers. The draft sent to the 

reviewers appears in the pages panel of their application. This step onwards, the draft follows the same pattern as it 

would if it had been edited in Contribute. Collaborative authoring is possible only if the draft has been set for editing 

in Contribute.

You can edit only one instance of a web page in the in-browser editor at a time. An error message is displayed if you 

try to open the same page in another instance for editing. Similarly, a web page open for editing is locked and 

unavailable to other users for editing. 

Close all linked files open in Contribute or the in-browser editor before you publish a web page. Close a web page if it 

has a dependent file that is shared with the file being published.

Any of the following actions performed on the web browser closes the in-browser editor after asking you for 

confirmation. Contribute saves the web page before closing it.

• Closing the tab containing the in-browser editor

• Closing the browser 

• Using the Back and Forward buttons to move to another web page in the in-browser editor window

Note: Clicking the Stop or Refresh button does not impact the in-browser editor.

This feature is available on the following browser versions and operating systems:

• Internet Explorer versions 6.0 and later on Windows Vista (SP 1) and Windows XP (SP 2)

• Mozilla Firefox versions 1.5 and later on Windows Vista (SP 1) and Windows XP (SP 2)

• Mozilla Firefox versions 1.5 and later on Mac OS X® (10.3.9) and Mac OS X (10.4.x).

Install the browser plug-ins in Windows

The Internet Explorer browser plug-in is automatically installed when you install Contribute on your computer.
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When you launch Contribute for the first time on a Windows computer, you will be prompted to install the Firefox 

Extension plug-in. If you click Cancel, you can install this component from the following path:

[Contribute install path]/SupportFiles/FirefoxExtension/FirefoxExtensionSetup

After Contribute is successfully installed on your computer, the Edit and Post To Blog plug-ins appear as buttons in a 

separate toolbar in the browser window. The Edit menu has two options:

Edit Opens the web page for editing within the browser.

Edit in Contribute Opens the web page for editing in Contribute.

Note: If you cannot see the toolbars, select View > Toolbars > Contribute Toolbar in your web browser.

The browser plug-in for editing a page

Install the browser plug-ins on Mac OS

When you launch Contribute for the first time in Mac OS, you will be prompted to install the Firefox Extension plug-in.

When you launch Contribute for the first time on a Windows computer, you will be prompted to install the Firefox 

Extension plug-in. If you click Cancel, you can install this component from the following path:

[Contribute install path]/FFExtnForContributeCS4.app

After Contribute is successfully installed on your computer, the Edit and Post To Blog plug-ins appear as buttons in a 

separate toolbar in the browser window.

Note: 

• You can remove the Contribute browser plug-ins for Mozilla Firefox in Mac OS only by using the Firefox Extension 

Manager.

• You cannot repair the Contribute application in Mac OS; reinstall the application.

You must have a connection to your website or blog before you edit a web page or blog entry in the internet browser. 

See “Create a website connection” on page 231 and “Create a blog server connection” on page 233.

If you see the Create Connection button when the page or entry opens, then you do not have a connection to the 

website or blog you were browsing and you cannot edit the page. See “Create a website connection” on page 231 for 

information on connecting to a web page.

Edit a web page or blog entry in Contribute from your browser

1 Open or navigate to the web page, blog, or individual blog entry in your browser.

2 Select Edit > Edit In Contribute. 

3 If you browsed to a blog home page, then select a blog entry to edit in the Entries pop-up menu. The web page or 

blog entry opens as a draft in the Contribute editor. You can now edit this page or blog entry.

4 For web pages with a workflow other than Author > Publish, you are prompted to send the page for review or 

approval. Select the reviewers from the dialog box, and click OK.

When the reviewers connect to the site in Contribute, the web page is displayed in their Contribute panel.
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Edit a web page or blog entry in your favorite browser

1 Open or navigate to the web page, blog, or individual blog entry in your browser.

Note: You must have a connection to your website or blog before you edit a web page or blog entry in your browser. 

See “Create a website connection” on page 231, and “Create a blog server connection” on page 233.

2 Click Edit in the browser’s toolbar.

3 If you browsed to a blog home page, then select a blog entry to edit in the Entries pop-up menu. The web page or 

blog entry opens as a draft in the web browser. You can now edit this page or entry.

4 For web pages with a workflow other than Author > Publish, you are prompted to send the page for review or 

approval. Select the reviewers from the dialog box and click OK.

When the reviewers connect to the site in Contribute, the web page is displayed in the Pages panel.

After the required action is performed on the page, the in-browser editor closes, and the web page is refreshed in the 

browser.

If the web page is not editable, an error message is displayed within the in-browser editor, and the page is restored to 

its original URL. However, if an error message is displayed after the in-browser editor is loaded, click the Close button 

to return to the original page.

Undo mistakes

In Contribute, as in most applications, you can undo individual mistakes as you make them. You can also redo an edit 

if you decide that you don’t want to undo it. 

Note: In Contribute, you can also discard changes, after you publish your draft, by reverting to a previously published 

version of a page. For more information, see “Roll back to a previous version of a page” on page 211.

Undo an edit

❖ Select Edit > Undo.

Redo an edit

❖ Select Edit > Redo.

Save drafts

Save a draft while you work

Contribute automatically saves a copy of your draft when you switch to the browser, switch to another draft, publish 

the draft, or exit Contribute. You can use the Preferences dialog box to set time intervals for automatically saving the 

draft. This will minimize the possibility of losing unsaved changes under adverse circumstances.

When you edit a page or blog entry (see “Edit existing web pages and blog entries” on page 50), Contribute 

automatically saves the page or blog entry as a draft, and the draft title appears in the Pages panel in the sidebar. 
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Note: This option is only available for drafts saved on your computer, not for drafts that are associated with a website or blog.

Save a draft and continue working

1 Select File > Save.

2 Click Save in the toolbar.

Note: When you save a new page draft for the first time, you do not give it a filename until you publish it. For more 

information, see “Publish a new page to your website” on page 205.

Automatically save a draft at regular time intervals

1 Select Edit > Preferences

2 Select Editing from the options in the left panel.

3 In the Save Contents In the Background Field, set a value in minutes at which you want to automatically save the 

drafts.

Save a draft for later use

Contribute saves your draft whenever you leave it and keeps the draft in the Pages panel until you publish (see 

“Publishing web pages and blog entries” on page 203), cancel (see “Discard a draft, new page, or new blog entry” on 

page 70), or send for review (see “The draft review process” on page 46).

1 Do one of the following to close your draft:

• Click Browser in the Pages panel to switch to the browser.

• Select View > Browser to switch to the browser.

• Click the Save For Later button in the toolbar to close the draft and switch to the browser.

• Click another draft title in the Pages panel to edit that page.

• Close Contribute.

2 If you closed Contribute, restart the application.

3 Click the draft title in the Pages panel to return to the draft you were previously editing.

The draft appears in the Contribute editor for you to continue editing.

Send web page drafts and files for review

For workflows other than Author > Publish, send the document for review or approval before you can publish the web 

page. The Publish button is enabled only after the workflow is honored. If your role doesn’t allow you to publish 

directly to the website, you can send the draft to someone who can publish it. For more information on workflows, see 

“The draft review process” on page 46.

You can use the e-mail review process to post web page drafts for review. For more information on using the e-mail 

review process, see “The e-mail review process” on page 48.

The review process lets you get feedback and collaborate with others on a web page draft or file. Reviewers can add 

comments to the draft or return the draft without reviewing it. The administrator assigns the workflow defining the 

review process for a template. For web pages without templates, and for templates without a workflow, Contribute 

assigns a default workflow.
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Note: The draft review process only applies to web page drafts. It does not apply to any kind of blog entry.

Send a web page draft for review

1 Select Send > Send For Review in the toolbar, or select File > Actions > Send > Send for Review.

The Send dialog box appears.

2 Select the Send The Draft To Another Contribute User option, and then complete the dialog box. You can send the 

draft to any user who has connected to this website.

For more information, see “Completing the Send For Review dialog box” on page 73.

For information about options in the dialog box, click the Help button.

3 Click Send.

4 If the Send New Page dialog box appears, you can change the draft’s filename, or click Choose Folder to select the 

folder from where you want to publish the file. You can also change the expiry date for the new page than the one 

specified by the administrator. Then click Send.

Note: The current folder location appears in the web address under the filename.

5 If the Send Linked New Files dialog box appears, you can click the names of the unpublished linked pages, and then 

change the filenames and folder location. Then click Send All.

Send a web page draft for review by e-mail

You can make the web page draft available for others to review—even if they don’t have Contribute. 

Note: If the page to be reviewed is in a frameset, the web address is for the single page that you edited, not the entire 

frameset.

For more information about the e-mail review process, see “The e-mail review process” on page 48. If you are assigned 

a role that cannot publish, you cannot use the e-mail review process. In that case, use the draft review process (see “The 

draft review process” on page 46).
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Note: The draft review process only applies to web page drafts. It is not applicable to blog entry drafts.

1 In your draft, select Send > Send for Review, or select File > Actions > Send> Send For Review.

The Send dialog box appears.

2 Select the Send e-mail With A Link To A Preview Of The Draft option, and then click Send.

3 If the Send New Page dialog box appears, you can change the draft’s filename or click Choose Folder to save this 

draft in another location. You can also change the expiry date for the new page than the one specified by the 

administrator. Then click Send or Next.

Note: The current folder location appears in the web address (URL) under the filename.

4 If the Send Linked New Files dialog box appears, select each unpublished linked page to change the filename and 

folder location as necessary. Then click Send All.

Contribute creates a new e-mail message in your default e-mail application.

In Mac OS, Contribute works with the following default e-mail applications: Apple Mail®, Eudora®, and Entourage®. 

Note: If Contribute does not find a default e-mail application or cannot start your e-mail application, you can create 

the e-mail message by clicking the Click Here link in the message area under the toolbar. Copy the web address (URL) 

for the draft that appears in the browser window and paste the address in an e-mail message to send to reviewers.

5 Enter the reviewer’s name and a message, and then send the e-mail message.

In Contribute, you can work on another draft or switch to the Contribute browser until you receive feedback from 

the reviewer. When you receive feedback from the reviewer, click the draft title in the Pages panel to return to the 

draft and update it. 

Note: When you delete or publish the draft, Contribute removes the temporary copy of the draft that it placed on the 

server for the reviewer.

Send a file for review 

You can send a file that is on your computer to another person to review or publish for you. You cannot select HTML 

files or dynamic file types, such as JSP. If you select an invalid file type, Contribute warns that you cannot select this 

file and provides a complete list of invalid file types.

You can also publish a file directly from your computer, depending on the role the Contribute administrator assigned 

you. For more information, see “Publish a file from your computer to your website” on page 208.

1 Select File > Send File From My Computer. The Select File dialog box appears.

2 Select the file you want to add to the website, and then click Select. If you have connections to more than one 

website, the Select Website dialog box appears.

3 If the Select Website dialog box appears, select the website where you want to add the draft for the file for review, 

and then click OK.

The website list includes any website you are connected to. The reviewer you want to send the file to must also be 

connected to the website you select.

The Send For Review dialog box appears.

4 Select the name of the person you want to review the file you are sending from your computer, enter comments for 

the reviewer, and then click Send.

The Send New Page dialog box appears.

5 Do the following: 
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Note: The current folder location appears in the web address under the filename.

a Change the filename, or click the Choose Folder button to save this draft in another location

b (Optional) Change the expiry date.

See also 

“Publish a file from your computer to your website” on page 208

Track web page drafts

After you send a web page draft for review, you can track it to see what the reviewer does with the draft. 

Note: The draft edit/review process only applies to web page drafts. It is not applicable to blog entry drafts.

1 Click the Draft Console link in the Pages panel.

Note: The Draft Console is not available if you don’t have a website connection that has an administrator assigned.

The Draft Console displays links to all the drafts you have sent and all the drafts you’re editing or reviewing. Each 

sent draft also has status information. 

Contribute removes published and deleted drafts from the Draft Console every 30 days. If you would like to 

manually remove outdated drafts, press Control+Shift while selecting View > Refresh Drafts.

2 If you would like to view a draft, select the draft title.

The draft appears in Contribute; you can click the Draft Console link to return to the Draft Console.

3 To update your view at any time, do one of the following:

• Click the Refresh Drafts icon  at the bottom of the Pages panel.

• Click the Refresh button in the Draft Console.

• Select View > Refresh Drafts.

4 When you finish viewing the Draft Console or the draft you selected, select the browser or another draft in the Pages 

panel.

Retrieve sent drafts

1 Click the Draft Console link in the Pages panel. The draft console appears. 

If you have just sent the draft and are still viewing it in the Contribute window, you can click the Undo Send button 

and skip the rest of this procedure.

2 Select a draft in the Sent Drafts section. Contribute displays the draft.

3 Click Undo Send in the toolbar.

The draft disappears from the reviewer’s Pages panel and appears in your Pages panel.
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Access new review drafts

Adobe Contribute is configured to check for new review drafts and to synchronize them with the available drafts for 

connected websites and blogs in the background. The next time you edit an existing review draft, Contribute 

automatically checks for new review drafts, downloads them, and displays them in the Pages panel along with a 

notification in the status bar indicating that there are new review drafts for review. Alternatively, you can manually 

check for new drafts by clicking the Refresh icon. The new draft sent for review is listed in the Drafts To Review area 

in the Draft Console page. As a result, the process of starting Contribute is not delayed.

1 Click the Draft Console link in the Pages panel. 

Note: The Draft Console will not be available if you do not have a website connection that has an administrator 

assigned to it.

The Draft Console displays links to all the drafts you have sent, and all the drafts you are editing or approving. Every 

dispatched draft has status information. 

Note: Contribute removes published and deleted drafts from the Draft Console every 30 days. If you want to manually 

remove outdated drafts, press Control+Shift while selecting View > Refresh Drafts.

2 If you want to view a draft, select the draft title. 

The draft appears in Contribute; you can click the Draft Console link to return to the Draft Console.

3 To update your view at any time, do one of the following: 

• Click the Refresh Drafts icon in the Draft console panel. 

• Select View > Refresh Drafts. 

If there are new review drafts, Contribute downloads them, and displays them in the Pages panel, along with a 

notification in the status bar indicating that there are new review drafts for review.

While you are editing a draft, if Contribute delivers an updated version of an earlier review, you can delete the 

earlier draft. This delete operation does not force Contribute to check for new review drafts, and therefore, 

improves the performance of Contribute.

Edit web page drafts

When someone sends you a web page draft for editing, the draft appears in your Pages panel in Contribute. You can 

manually refresh the Pages panel to check for drafts to edit. 

Note: The draft edit process only applies to web page drafts. It is not applicable to blog entry drafts.

1 Select a draft in the Pages panel to edit.

The draft appears in the Contribute window for you to edit; the draft status pane at the bottom of the window 

contains information about the draft.

Note: If the draft status pane is not expanded, click the expander arrow at the bottom right of the Contribute window 

to display the pane.

2 Do one of the following:

• Click the Edit Draft button in the toolbar to change the draft.

The draft appears in the Contribute editor. After you finish editing, you can do one of the following:
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• Click Save For Later to save the changes you made to the draft. 

• Click Actions > Edit Done. In the Edit Done dialog box, enter any comments for the author. When you click 

OK, the draft is sent back to the author with the comments.

• Click Delete Draft if you want to discard your changes to the draft. Deleting a draft does not remove the draft 

from the review process.

Note: You can delete drafts only if the administrator has provided you with the required permissions. 

Review web page drafts

When someone sends you a web page draft for your review, the draft appears in your Pages panel in Contribute. You 

can review the document by selecting the content you want to comment on, and adding your comments. However, 

you cannot edit the document, as it is in a read-only state. 

Only one reviewer can edit the draft at a given time. Other reviewers can review the draft only after the reviewer 

completes reviewing the draft.

You can do the following when reviewing a web page:

• Make your comments public or private: Only the author and the reviewer providing the comment can view 

comments marked as private. All the reviewers in the review cycle can view comments marked as Public.

• Use the various options in the Review menu to filter comments.

• Select the color for the highlighted text to which you are adding a comment.

• Select a color for the comment dialog that pops up when you select text on the web page.

• Manually refresh the Pages panel to check for drafts pending review.

• View all the public comments that reviewers have added to the draft.

Note: The draft review process only applies to web page drafts. It does not apply to any blog entry drafts.

1 Select a draft in the Pages panel to review.

The draft appears in the Contribute window for you to review; the draft status pane at the bottom of the window 

contains information about the draft.

Note: If the draft status pane is not expanded, click the expander arrow at the lower right of the Contribute window 

to display the pane.

2 Click the Review button in the toolbar.

3 Select the text to which you want to add a comment. The comment pop-up menu appears. 

4 After you add a comment, do the following:

• Click Add Comment to add the comment.

• Click Public or Private to mark the comment as Public or Private.

• If you do not want to add the comment, click Delete Comment to remove the added comment from the draft.

5 Click Review Done to send the draft with the comments to the author.



62USING CONTRIBUTE CS4

Working with existing web pages and blog entries

View and filter comments for a web page draft you are reviewing

1 Select Review > Show, and use one of the following options to filter the comments on the page:

Show Comments List  Displays all the comments as a list at the bottom of the page.

Hide All Comments  Hides all the comments in the document.

Show All Comments  Displays all the comments on the page.

Show By Reviewers Sorts the comments by reviewers. If you have not selected a reviewer using this option, 

comments from all reviewers are displayed.

Show By Type  Select an option to display public comments, private comments, or both. The option to display 

private comments is available only to the author of the document.

Open All Comment Pop-Ups  Opens all the comment pop-up menus.

Minimize All Comment Pop-Ups Minimizes all comment pop-up menus. The content in the comment is displayed 

when the user moves the mouse over the minimized dialog.

2 To move through the comments list, use the Previous Comment and Next Comment options in the Review menu.

Note: Some comments might not appear at their intended position in the page. Navigate to the end of the page to locate them.

Work with template-based web pages 

A Dreamweaver template is a special type of web page that contains a preset page layout and includes elements such 

as text and images. In Contribute, you can create a web page or a blog entry based on a template. You can also edit a 

template-based page for a website or a blog, edit the template properties of the page for a website, and customize 

templates for blogs. 

Note: If you have a lot of templates on your website, Contribute can take longer to start. For faster startup, consider not 

connecting to specific websites and blog connections or disabling your websites and blog connections when you start 

Contribute. For more information, see “Enable a website or blog server connection” on page 261.

See also 

“About templates” on page 49

“Create a web page based on a template” on page 80

Edit a template-based web page

A page based on a Dreamweaver template (a template-based page) has editable regions, where you can add or edit 

content, and locked regions, where you cannot add or edit content.

Note: If you try to edit a locked region in a document based on a template, the pointer changes to indicate that you can’t 

click in that region. 

When you view a template-based page, you see outlines around the editable regions. The editable regions each have a 

tab at the upper left giving the name of that content area. The tabs show you where you can add or update content on 

the page.

For example, a product template-based page might have a Title region, for the product title, and a Description region, 

for a product description. You add content to the appropriate sections.
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You can edit the editable regions of a template-based page as you would edit any other web page.

1 Browse to the template-based page you want to edit.

2 Do one of the following:

• Click the Edit Page button in the toolbar.

• Select File > Actions > Edit Page.

The web page opens as a draft in the Contribute editor. You can make edits in the editable regions.

See also 

“About templates” on page 49

“Customize template files for blogs” on page 64

“Refresh templates” on page 65

Set template properties for a web page

You can change template properties and customize templates when you work in web pages or blogs in Contribute. You 

can change template properties such as background color on a web page. You can customize blog templates by adding 

extra fields in the Dreamweaver template file, which is created automatically after you start working in a blog in 

Contribute.

The Dreamweaver template designer might make it possible for you to show or hide parts of the page. You control this 

content in the Template Properties dialog box. Pages based on a template might have editable attributes, such as 

background color, that you can edit in Template Properties.

1 Browse to a template-based page; then click the Edit Page button in the toolbar.

2 Select Format > Template Properties.

The Template Properties dialog box opens.

3 In the Name list, select a property.

Contribute updates the bottom of the dialog box to show the label of the selected property and its assigned value.
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4 In the field to the right of the property label, edit the value to modify the property.

5 Click Apply to apply changes without closing the dialog box, or click OK to apply changes and close the dialog box.

See also 

“About templates” on page 49

Customize template files for blogs

Whenever you create a connection to a blog in Contribute, a Dreamweaver template (DWT) file is automatically 

generated. You can customize DWT files to include additional fields in your blog if your blog publishing service 

supports extra fields. You can use these additional fields to add extra information to your blogs. 

Note: Not all blog publishing services support extra fields.

You can enter any additional fields in the form of XML tags in the Dreamweaver template file. After you add these tags, 

the additional fields appear the next time you create a blog entry. For more information on creating blog entries, see 

“Create a blog entry for your blog” on page 81.

Note: This process is helpful to customize your Dreamweaver template file. Familiarity with XML tags is helpful to 

publish your blog entries to a blog publishing service such as Movable Type.

You can also publish this customized blog entry to another blog if the other blog server supports extra fields; otherwise 

the additional fields are invisible in the blog. After you change the blog entry back to the original blog, all the additional 

fields become visible. For more information on specifying target blogs, see “Select the blog for the blog entry” on 

page 88.

1 Open the DefaultTemplate.dwt file in any text editor:

• In Windows, the DefaultTemplate.dwt file is located at: C:\Documents and Settings\[user name]\Local 

Settings\Application Data\Adobe\Contribute CS4\Sites\Sitex\Templates.

Note: If you cannot see the Local Settings folder, open Windows Explorer and select Tools > Folder Options > View. 

In Hidden Files And Folders, select Show Hidden Files And Folders. 

• In Mac OS, the DefaultTemplate.dwt is located at: /[Mac OS HD]/Application Support/Adobe/Contribute 

CS4/Sites/Sitex/Templates

2 Enter the XML tags for the fields you want. Following is an example for adding the Extended Content, Excerpt, and 

Keyword tags:

 <<begintranslate>> <!-- TemplateBeginEditable name="mt_text_more" --> <<endtranslate>><!-- 
TemplateEndEditable -->  
 <<begintranslate>> <!-- TemplateBeginEditable name="mt_excerpt" --> <<endtranslate>><!-- 
TemplateEndEditable -->  
 <<begintranslate>> <!-- TemplateBeginEditable name="mt_keywords" --> <<endtranslate>><!-- 
TemplateEndEditable -->

Always add the tags after the following lines:

 <div class="entry-content">  
 <<begintranslate>> <!-- TemplateBeginEditable name="adobe_main_content" --> 
<<endtranslate>><!-- TemplateEndEditable --></div>

3 Save and close the file.

The additional fields appear the next time you create a blog. For more information, see “Create a blog entry for your 

blog” on page 81.
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See also 

“About templates” on page 49

Refresh templates

If you have several templates on your website, Contribute can take longer to start. For faster startup, you can configure 

Adobe Contribute to start up without downloading templates from the server to your client computer. You can 

download updated templates whenever it is required, or when Contribute displays a message indicating that a selected 

template is not synchronized with the template available on the server.

1 In the Contribute browser, click New in the toolbar, or select File > New. 

The New Web Page Or Blog Entry dialog box opens.

2 In the Create New Web Page or Blog Entry For pane, select and expand the website or blog connection in which 

you want to create the new page or blog entry, if it is not already expanded.

3 Below the Preview pane, view information about the template associated with the selected website. If Contribute 

indicates that the template is out of date, click Refresh Templates, and select one of the following options from the 

pop-up menu:

For All Websites Updates templates for all websites and blogs globally.

For Selected Website/Blog Updates templates for the selected website or blog only.

For Selected Template Updates the selected template only.

The template is refreshed.

4 Click OK.

While creating a new page, if you select a template that does not match the template on the server, Contribute 

prompts you to confirm whether you want to create the page based on the old template. If you click Yes, the new 

page is created based on the old template. However, if you click No, the selected template is updated, and then the 

page is created.

Note: If a template is not available, the For Selected Template option is disabled.

See also 

“About templates” on page 49

Work offline

Contribute gives you the freedom to edit web pages and blog entries without a network connection. Using the Work 

Offline feature of Contribute, you can work on an airplane, at home, or anywhere. 

While you are working offline, you can edit drafts, but you cannot use the Contribute browser. Contribute remains 

offline—even if you establish a network connection—until you switch to working online. 

❖ Do one of the following:

• If Contribute is running and has a network connection, select File > Work Offline (Windows) or Contribute > 

Work Offline (Mac OS).
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• If Contribute is not running, start Contribute without a network connection; select Work Offline in the 

Connection Failure dialog box, and then click OK.

The Contribute browser displays the Working Offline page. Click a draft title in the Pages panel to start editing.

Switch between working online and working offline

If you start Contribute offline without a server connection, or switch to working offline during an online Contribute 

session, you can switch to working online whenever you establish a server connection.

Note: Contribute does not reestablish the connection to your web server. You must connect to the server before you switch 

to working online in Contribute.

Switch from working online to working offline

❖ Select File > Work Offline (Windows) or Contribute > Work Offline (Mac OS).

Switching to working offline does not disconnect your network connection. 

Switch from working offline to working online

1 Restore your network connection, if necessary.

2 Do one of the following:

• Select File > Work Offline (Windows) or Contribute > Work Offline (Mac OS). 

The check mark next to this menu option disappears.

• Click the Work Online button in the toolbar.

Work offline in the Contribute editor

When you’re working offline, the Contribute editor displays information about what you can do offline. You cannot 

browse to other web pages, websites, blog entries, or blogs when you are offline. 

You can edit current drafts in the Pages panel or create web pages and blog entries while you’re offline. Some 

Contribute editor functions are not available when you’re offline. For example, you can’t publish web pages or blog 

entries until you are online again.

Before you work offline, be sure to click Edit Page to create drafts for any web pages or blog entries you want to edit 

offline. You cannot access home pages or recently published web pages or blog entries while you are offline. 

Edit a draft while working offline

❖ Click a draft title in the Pages panel of the sidebar. 

The draft opens in the Contribute editor.

Create a web page or blog entry while working offline

❖ Select File > New. The New Web Page Or Blog Entry dialog box opens. You can create a blank web page or blog 

entry.

The new web page or blog entry opens as a draft in the Contribute editor, and its title appears in the Pages panel.

Delete a new web page or blog entry while working offline

1 Open any new web page or blog entry that you created while working offline.
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Note: You can delete only those web pages and blog entries that you created while working offline. You cannot cancel 

changes to a draft while working offline.

2 Click the Discard Draft button in the toolbar or select File > Actions > Discard Draft.

Contribute discards the new web page or blog entry from the Pages panel and opens the Contribute Working 

Offline page.

See also 

“Switch between working online and working offline” on page 66

Edit web pages in an external application

To edit images, Microsoft Word documents, Adobe Fireworks™ content, or files of other types on your website, edit 

the content in the application in which it was created. You can open the appropriate application from Contribute to 

edit the file. 

Note: Use Contribute to edit the file in an external application; changes you make to the local, original source file do not 

appear on your website.

Before you can use Contribute to start an external application editor, you may need to associate an editor with the type 

of the file you intend to edit (see “Setting file editor preferences” on page 40). Contribute has preassigned editors for 

common file types.

Before you can use Contribute to start an external application editor, you may need to associate an editor with the type 

of the file you intend to edit. Contribute has preassigned editors for common file types.

1 To find the content you want to edit, do one of the following:

• Browse to the page or file that contains the content you want to edit, and then click Edit Page.

• Click the Choose button in the toolbar, navigate to the file you want to edit, and then click OK.

Note: If the Contribute browser cannot display the page or file you’ve selected, you’ll see the File Placeholder page.

• If you browsed to a page and opened it as a draft, right-click (Windows) or Control-click (Mac OS) the element 

you want to edit, and then select Edit In External Application.

Contribute displays the External Application Editing page and starts an external editing application. 

Note: To change your default editor, see “Setting file editor preferences” on page 40.

2 If you are editing an image in Fireworks, click No in the Find Source dialog box to indicate that you do not want to 

edit the source file for this image; you want to edit the image for your website only.

3 In the external application, make changes as necessary; then save your changes and close the application.

Note: If you are editing in Fireworks, click the Done button in the editing window.

4 In Contribute, click one of the action buttons in the toolbar.

Click the Launch link on the External Application Editing page to open the content in the external editor again, to 

make additional changes.
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Edit web page source in an external application

You can edit web page source in an external application to make quick modifications or to do testing, such as link 

checking or accessibility testing. Contribute opens the source in an external editing application. 

Note: If your Contribute administrator has not enabled source editing, you cannot edit the source in an external 

application. For information, talk to your Contribute administrator.

Important: Editing web page source in an external application is very different than the editing experience in Contribute. 

If you are unsure about editing the source directly, talk to your Contribute administrator.

1 In the Contribute browser or editor, view the page you want to edit the source for.

2 Select File > Actions > Edit Page Source In External Application.

Contribute displays the External Application Editing page and starts an external editing application. 

Note: To change your default editor associated with Web Page Source, see “Setting file editor preferences” on page 40.

3 In the external application, make changes as necessary, and then save your changes and close the file or application.

Important: Be careful when you edit web page source—you can easily alter style and formatting and get unexpected 

results. If you are unsure about editing the source directly, talk to your Contribute administrator.

4 In Contribute, do one of the following:

• Click the Edit In Contribute link on the External Application Editing page to reload the draft in Contribute.

This option lets you see your changes and resume editing.

Note: If Contribute warns you that you must save and close the file in the external application, click OK.

• Click the Launch link on the External Application Editing page to reopen the content in the external editor.

This option lets you make additional changes, and provides a convenient way to switch back and forth between 

Contribute and the external editing application.

• Click the Publish button in the toolbar to publish your changes to the website.

• Click the Send For Review button to send the draft to another user to review your changes.

• Click the Discard Draft button if you want to discard the changes after editing in an external application.

This options discards all changes you’ve made in Contribute or in the external application since you started 

editing this draft.

See also 

“Edit web pages in an external application” on page 67

Configure blog server settings

Blogging systems support a variety of features that enhance blogging experience. Client applications, like Contribute, 

can access only those features to which the blog system provides access. Because not all blog systems support all the 

features, Contribute provides you a common set of features, which it can access from different blog systems. The 

following features are currently supported in Contribute.

• Inserting images

• Inserting audio 
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• Inserting video 

• Commenting features

• Categories

• Trackback features

• Pages

• Parent pages

• Page order

When you access a blog page, only those features supported by the blog server are enabled on the interface. However, 

you can choose to enable a feature that the blog server doesn’t support. This override works only if the server starts to 

support the feature before the blog is published. From the list of features supported by Contribute, you can personalize 

only three features — Images, Audio, and Video.

For example, if the server does not support embedding images, you can enable the option using the blog interface. The 

embedded image is published on the server only if the server starts providing this support before the page is published. 

You can also choose to disable features supported by the server. These settings are applied only on your computer, and 

do not affect settings on the server.

The configured settings for different blog systems are stored in the registry.

Note: The applied settings work only on your local computer, and you must reconfigure them when you edit blogs from 

a different computer. 

1 Select Edit > My Connections.

2 In the My Connections dialog box, select the blog server that you want to configure. Click Configure. The 

Configure Blog Server dialog box appears. 

The features supported by the server appear selected next to the corresponding options. The features supported by 

the server that cannot be customized appear in the field below the options.

3 To enable a feature that is not supported, check the option. The corresponding button and menu item for that 

feature are enabled in the interface.

4 To revert to the default server options, and to check the current status of the features supported by the blog server, 

click Update Support.

Configure blog settings

1 Select Edit > Configure Blogs, and select the blog that you want to configure. Alternatively, in the My Connections 

dialog box, select the blog site and click Configure.

2 In the Configure Blog dialog box, select Styles And Fonts in the left panel.

a Select the method by which Contribute users can (or cannot) apply styles to text from the Style support pop-up 

menu. The style options are as follows:

Don’t Allow Users To Create Styles Prohibits users from creating styles. Users cannot modify any text and style 

formatting options.

HTML Tags Lets you determine whether users can create HTML styles, and to what degree they can modify and 

apply styles on the website. 

Document-level CSS Lets you determine whether users can create CSS styles in the document, and to what 

degree they can apply CSS styles from existing CSS style sheets.
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b Change the Styles options as necessary. If the Allow Users To Apply Styles option is selected, users can apply 

heading and paragraph styles using the Contribute editor toolbar or menu commands. If this option is 

deselected, the user cannot apply new paragraph styles.

Include HTML heading styles (<h1>, ...) in the Style menu Specifies that the standard HTML Paragraph, 

Heading1, Heading2, Heading 3, Heading 4, Heading 5, and Heading 6 tags are available in the Style menu. 

Include CSS styles in the Style menu Specifies that CSS styles appear in the Style menu. 

Allow users to apply fonts and sizes (displays the Font and Size menu) Activates the Font and Style menus in 

the Contribute editor toolbar. This lets users select the fonts and font sizes to use on the page. If this option is 

not selected, Contribute uses the font styles and sizes defined in the page’s HTML source code.

Allow users to apply bold, italic, underline, strikethrough, and fixed width styles Activates the bold, italic, 

underline, strikethrough, and fixed width style options in the Formatting menu and lets the user apply these 

options to text. 

Allow users to apply font color and background color Activates the Text Color and Highlight Color options in 

the Formatting menu and lets the user apply these options to text.

3 Select New Images in the left panel. Use the options in the New Images panel to customize your settings.

 For each blog site, the blog-specific settings are stored in a separate BlogHub.CSI file.

Discard a draft, new page, or new blog entry

When you are editing a draft of an existing web page or blog entry, you can decide to discard all changes and retain the 

currently published version of the web page or blog entry. When you are editing a new web page or blog entry that you 

created, you can discard it.

Also, depending on your role, you might be able to delete pages that are published on your website. For more 

information, see “Delete a web page or file” on page 71.

Discard changes to a draft of a published web page or blog entry

❖ In your draft, click the Discard Draft button in the toolbar.

The published version of the web page or blog entry appears in the Contribute browser, without any edits.

Discard a new web page or blog entry

❖ In the new page draft, click the Discard Draft button in the toolbar.

Contribute discards the new web page or blog entry.

Delete a web page or blog entry

You can permanently delete pages and entries from your website or blog. 

If you want to delete a draft, and not remove the existing page or entry from your website or blog, see “Discard a draft, 

new page, or new blog entry” on page 70.
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Delete a web page or file

Depending on your role, you might be able to delete pages from your website. If you can delete pages, you can delete 

files of any type on your website, including image files.

Note: If you do not have permission to delete a page that you need to delete, talk to your Contribute administrator or see 

“Set folder and file access settings” on page 286.

You do not need special permission to delete a new page that you created and haven’t published yet. For more 

information, see “Discard a draft, new page, or new blog entry” on page 70.

1 Do one of the following to find the page or file:

• Browse to the page or file you want to delete.

• Click the Choose button in the toolbar; then select a file and click OK.

Note: If Contribute cannot display the page or file you browse to, you’ll see the File Placeholder page. You can still 

delete the page or file, even though you can’t view it.

2 Select File > Actions > Delete Page.

Note: This menu item is disabled if you do not have permission to delete pages on your website.

3 Click Yes to confirm that you want to delete the file.

Contribute deletes the page and displays the last page you viewed in the browser.

See also 

“Discard a draft, new page, or new blog entry” on page 70

Delete a blog entry

You can delete existing entries from your blog. 

If you want to delete a draft, see “Discard a draft, new page, or new blog entry” on page 70.

1 In the Contribute browser, browse to the blog home page that contains the entry you want to delete.

2 From the Entries pop-up menu, select the blog entry you want to delete, or select View > Select Blog Entry and 

choose the relevant blog entry.

3 When the blog entry is displayed in the embedded browser, click the Delete Entry button, or select File > Actions 

> Delete Entry.

Note: You can also delete a blog entry by selecting the Choose File or Blog Entry option from the View menu. In the 

dialog box that appears, select the required blog entry, and click the Delete button.

4 In the confirmation dialog box, click Yes to confirm that you want to delete the entry.

Contribute deletes the entry from your blog, and displays your blog home page.

Note: The list of blog entries in the Entries pop-up menu is updated after a blog entry is deleted.

Refresh the Entries list

You can update the list of blog entries in your home page by refreshing the list, manually.

❖ Click the Refresh Blog Entry List  button to refresh the list of blog entries displayed in the Entries pop-up menu, 

or select View > Refresh Blog Entry List.

The blog entries listed in the Entries pop-up menu are updated.
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Export a web page or blog entry (Windows only) 

Contribute lets you export a web page or blog entry from Contribute to an external HTML file. You can save the file 

anywhere on your computer or network.

If you export a new web page with images—that is, a page you haven’t published yet—you’ll see the images in your 

exported web page. If you edit an existing web page—a previously published page—you might not see all the images 

on your exported page. This is because the new web page references local versions of the images, and the existing page 

references images that are saved on your website.

1 Browse to the web page or blog entry to export.

2 Do one of the following:

• If you are exporting a web page, click the Edit Page button in the toolbar.

• If you are exporting a blog entry, click the Edit Entry button in the toolbar.

3 Select File > Export.

The Export dialog box appears.

4 Select a location to save the exported file.

5 Enter a filename.

6 Click Save. 

The exported file appears in the folder you selected.

Print a web page or blog entry

You can browse to a web page or blog entry and print it, or you can print a web page or blog entry you are editing to 

check your changes. 

Preview a page

1 Do one of the following:

• Select File > Print Preview (Windows).

• Select File > Print, and then click the Preview button (Mac OS).

The web page or blog entry appears in a browser window. 

2 To print the page or blog entry, click Print or OK.

3 Click Close to close the preview when you finish viewing it.

To preview a web page or blog entry in a browser, see “Preview a page in your default browser” on page 207. 

Print a page

1 Select File > Print.

Note: (Windows only) In the Contribute browser, you can also right-click, and then select Print.

2 Click Print or OK.
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Your default printer prints the page.

See also 

“Edit web page source in an external application” on page 68

Add Google search 

You can add a Google™ search field to your web page, so that your website visitors can search the entire web or just 

your website.

Insert a Google search field

1 In your draft, place the insertion point where you’d like the search field to appear.

2 Select Insert > Google Search Field.

The Insert Google Search Field dialog box appears.

3 Set the options on each screen, and then click Next (Windows), or click Continue (Mac).

For information about any of the options in a screen, click the Help button.

4 Review the summary, and then click Done, or click Finish (Mac).

The Google search field appears on your draft.

Change Google search field properties

1 In your draft, select the Google search field.

2 Select Format > Google Search Field Properties.

The Google Search Field Properties dialog box appears.

3 Click any tab at the top of the dialog box, and then change options as necessary.

For information about any of the options in the tab, click the Help button.

4 When you finish, click OK.

Reference

This section provides information about the dialog boxes introduced in this chapter.

Completing the Send For Review dialog box

Use the Send For Review dialog box to send a draft you’re editing, or a file from your computer, to someone for review.

1 Select one of the following options:

Note: These options are available if you are sending a draft for review. If you are sending a file for review, skip this step.

Send E-mail with a link to a preview of the draft Uses the email review process. This option opens a message in 

your default email application. Contribute automatically adds a link to the preview of the draft, and you can select 

reviewers, and add a message.
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This review method is useful if you want to keep working on the draft while someone reviews it. Working on the 

draft does not affect the temporary draft posted for review. This review method is also useful for reviewers who do 

not have Contribute. For more information, see “The draft review process” on page 46.

Send The Draft To Another Contribute User Uses the e-mail review process. This option opens a message in your 

default e-mail application. Contribute automatically adds a link to a preview of the draft, and you select the 

reviewers and add a message. 

This option sends the draft you are working on to the users you select.

This review method is useful if you need another user to review, edit, or publish a draft for you. You cannot 

continue working on the draft after you send it for review. For more information, see “The e-mail review process” 

on page 48.

2 Select the options for the review as follows:

• If you selected the Send Draft To Another Contribute User option, select the name of the person you want to 

review the draft, and then enter comments for the reviewer.

The Users list shows all users who have connected to this website. You can Control-click (Windows) or 

Command-click (Mac OS) to select multiple users.

In the Comments section, you might want to tell the reviewer what has changed in the draft or maybe give the 

reviewer instructions about what to do with the draft after the review.

• If you selected the Send Draft To Another Contribute User option, select Notify Recipients Through e-mail if 

you want to send an e-mail message to the reviewer.

This option automatically launches your default e-mail application so that you can send an e-mail message to 

reviewers alerting them to check Contribute for a draft to review.

3 Click Send.

For workflows other than Author > Publish, you have to send the document for review or approval before you can 

publish the web page. The Publish button is enabled only after the workflow is honored. If your role doesn’t allow you 

to publish directly to the website, you can send the draft to someone who can publish it. For more information on 

workflows, see “The draft review process” on page 46.

Using the Draft History dialog box

Use the Draft History dialog box to view the history associated with the draft you received for review. 

Note: The Draft History dialog box enables you to only view the description of changes. You can add a description of 

changes when you send the draft for review (see “The draft review process” on page 46).

Select a Sender’s Name The comments entered by the sender are displayed in the Description Of Changes section.

The action performed and Date columns Describe the action performed by the user, and the date of the action.

Recipients The names of users to which the document was sent.

See also 

“Edit web page drafts” on page 60
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Completing the Template Properties dialog box

Use the Template Properties dialog box to show or hide content in a template-based page.

1 In the Name list, select a property.

Contribute updates the bottom of the dialog box to show the label of the selected property and its assigned value.

2 In the field to the right of the property label, edit the value to modify the property.

3 Click Apply to apply changes without closing the dialog box, or click OK to apply changes and close the dialog box.

See also 

“Set template properties for a web page” on page 63

Completing the Select Website Folder dialog box

Use the Select Website Folder dialog box to select the local folder that contains the website for the page you’re opening. 

This enables Contribute to locate any dependent files used by the page.

❖ Select the folder that contains the website for the page you’re opening, and then click OK.

Completing the Send New Page dialog box

Use the Send New Page dialog box to change the filename of the draft you are sending for review, before you send it. 

1 In the Filename field, change the filename of the draft you are sending for review.

2 Click Choose Folder to select the folder from where you want to publish the file.

3 Select an expiry date for the page from the Page Expires On pop-up menu.

4 The selected folder location appears in the web address under the filename.

5 Click Send.
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Chapter 5: Adding pages, blog entries, and 
documents

With Adobe® Contribute® , you can add pages to your website. You can create a blank web page, a copy of a web page, a 

copy of a sample web page, or a web page based on a template. In addition to creating web pages, you can add existing 

content from Microsoft Office documents, such as Word or Excel files, to your website, and add video files to a web page.

You can also use Contribute to create a stand-alone page that is not associated with one of your websites by saving the 

new page to your computer.

With Contribute, you can create and post blog entries to your blog. You can also create a blank blog entry, create a blog 

entry by quoting a selection from a web page you are viewing, or create a blog entry from existing information you 

select in your browser or in Microsoft Office documents, such as Word or Excel files. Contribute also supports a special 

kind of blog entry called Pages, which are supported by some blog sites. 

Create or copy a page on your website

You can create or copy any of the following types of pages on your website:

• Copy of current page 

• Blank web page 

• Starter web page 

• Template

Note: If your Contribute administrator has restricted the types of new pages you can create, you won’t see all of these 

options when you create or copy a page. For more information, talk to your Contribute administrator or see “Specify 

settings for new web pages” on page 291.

See also 

“Create a stand-alone web page” on page 81

Copy a page on your website

You can create a copy of the page you are currently viewing on your website. You must be viewing the page in the 

Contribute browser. 

You cannot create a copy of a page that is a draft in the Contribute workspace. Also, you cannot copy a page from one 

website to another website. You cannot create a copy of a page that contains frames.

Remember to add a link to the page before you publish; otherwise, website visitors cannot navigate to the page. 
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For web pages, the copied page has the same workflow that is assigned to the page from which it has been created.

1 Navigate to the page you want to copy, and click the New button in the toolbar or select File > New.

The New Web Page Or Blog Entry dialog box appears. 

2 In the Create New Web Page Or Blog Entry For pane, select Copy Of Current Page. 

Note: If you cannot select this option, you are viewing a page in your browser that you cannot copy. If you do not see 

this option, your Contribute administrator has restricted the types of new pages that you can create. For more 

information, talk to your Contribute administrator or see “Specify settings for new web pages” on page 291.

A preview of the page appears in the Preview pane on the right side of the dialog box.

3 Enter a page title in the Page Title text box. 

This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

4 Click OK. 

The new page opens as a draft in Contribute. Be sure to add a link to your new page before you publish it (see 

“Create text and image links” on page 177).

Note: Contribute creates the new page in the same folder as the page you copied. You can change the folder location 

when you publish the new page. 

Create a blank web page

You can create a blank web page to add to your website. Remember to add a link to the page before you publish; 

otherwise, website visitors cannot navigate to the page. 

Blank web pages are assigned the default workflow Author > Publish.
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Note: It’s a good idea to create the new page and a link to that page at the same time. To do that, see “Link to a new page” 

on page 178.

1 In the Contribute browser, click the New button in the toolbar, or select File > New. 

The New Web Page Or Blog Entry dialog box opens.

2 In the Create New Web Page Or Blog Entry for pane, expand the website in which you want to create the new page, 

if it is not already expanded, and select Blank Web Page.

Note: If you don’t see this option, your Contribute administrator has restricted the types of new pages that you can 

create. For more information, talk to your Contribute administrator or see “Specify settings for new web pages” on 

page 291.

3 Enter a page title in the Page title text box. 

This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

4 Select a template that you want to assign to the web page. The page workflow assigned to the template is displayed 

below the Preview panel.

5 Click OK. 

The new page opens as a draft in Contribute. Be sure to add a link to your new page before you publish it (see 

“Create text and image links” on page 177).

Contribute creates the new page in the same folder as the page you were viewing when you created the page (unless 

you selected another website in step 2). You can change the folder location when you publish the new page. 

See also 

“Set page properties for a web page” on page 85

“Add keywords and a description for a web page” on page 87

Copy a starter web page

Contribute comes with built-in starter web pages that you can copy and use on your website. Use any of these pages as 

a starting point for your web page. 

Starter web pages are assigned the default workflow Author > Publish.

Remember to add a link to the page before you publish it; otherwise, website visitors cannot navigate to the page. 

Note: It’s a good idea to create the new page and a link to that page at the same time. To do that, see “Link to a new page” 

on page 178.

1 In the Contribute browser, click the New button in the toolbar, or select File > New. 

The New Web Page or Blog Entry dialog box opens.

2 In the Create new web page or blog entry for pane, do the following:

a Expand the website in which you want to create the new page, if it is not already expanded. 

b Expand the Starter Web Pages folder, and then select a starter web page. 

Note: If you don’t see the Starter Web Pages folder, your Contribute administrator has restricted the types of new 

pages that you can create. For more information, talk to your Contribute administrator or see “Specify settings for 

new web pages” on page 291.

A preview of the page you select appears in the Preview pane on the right side of the dialog box.
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3 Enter a page title in the Page title text box. 

This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

4 Click OK. 

The new page opens as a draft in Contribute. For information about editing the starter web page, see “Edit a starter 

web page” on page 79. Also, be sure to add a link to your new page before you publish it (see “Create text and image 

links” on page 177).

Note: Contribute creates the new page in the same folder as the page you were viewing when you created the page 

(unless you selected another website in step 2). You can change the folder location when you publish the new page. 

Edit a starter web page 

The Contribute starter web pages were created by a professional design firm. You can copy any of the sample pages 

and use them in your website. You can use any of the pages as a starting point to create your own page, or replace the 

existing content with your information.

After you create a page based on a starter web page, you can modify the page. This page is not a template, in which 

some parts can be modified but other parts are restricted. The page is a starting point for your web page; you can 

change it as needed.

Note: The hypertext links on the page do not work automatically; you must edit each link on the page so that it refers to 

a page in your website. 

The following are guidelines for working with text, images, and links on the starter pages. These are tips to help you 

get started; there are many ways to modify the starter web pages to make them your own. 

Modify text in a draft based on a starter page

1 To replace existing text, select any text on the draft and type over it.

When you replace existing text, Contribute retains the formatting established by the design of the starter web page. 

You can apply formatting to any text to override the design. 

2 To add text to draft, copy text from the draft or from another source (such as Microsoft Word), place the insertion 

point on the page or select text you want to replace, and then select Edit > Paste Text Only.

Note: To delete the date object from your page, you must deselect Protect Scripts And Forms in the administration 

settings. For more information, talk to your Contribute administrator or see “Set page-editing and paragraph settings” 

on page 288.

For more information about working with text, see “Working with text” on page 113.

Replace an image or graphic element in a draft based on a starter page

❖ Select the image, press Delete, and then drag a new image to the draft.

Most images and graphics on the starter web pages have dimensions on them. When you replace an image, try to 

use an image that’s close in size to the one you’re replacing, so that you retain the page design.

Note: If you see a yellow shield icon, it’s probably a placeholder for the current date. When you publish the page, the 

current date appears.

For more information about working with images, see “Working with images and graphic elements” on page 131.
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Enable links in a draft based on a starter page

❖ Do one or more of the following:

• To replace existing link text, select a link, and then type your link text. 

Note: Not all links on the starter web pages look like typical links, with blue, underlined text. Links might not be 

underlined and might have a different design treatment applied to them. When you click an intended link on a 

draft based on a starter page, the status bar at the bottom of the Contribute editor indicates that it is a link. 

• To make a link work, select a link, click the Link button in the toolbar, and then select Browse To Web Page. 

Click the Browse or Choose button in the Insert Link dialog box to find and select a page, and then click OK to 

close the Insert Link dialog box.

You must make the links work, or delete the ones you don’t want.

You can also link to a new web page, such as another starter web page, and modify the new starter web page 

later. For more information, see “Link to a new page” on page 178.

• To add a link to a vertical navigation bar, select the row that contains the last link in the series, and then select 

Edit > Copy. With the row still selected, click the Insert Row Below button in the toolbar. Select the new row, 

and then select Edit > Paste.

For more information about working with links, see “Working with links” on page 177.

See also 

“Copy a starter web page” on page 78

Create a web page based on a template

You can create a web page based on a template, which can help you maintain a consistent look across your website. In 

Contribute, there are two types of templates:

• A template created in Dreamweaver® (see Dreamweaver Help > Using Dreamweaver). A Dreamweaver template is 

a template that a designer creates for you with editable and locked regions.

• A page that your Contribute administrator designated as a template. Your Contribute administrator can designate 

any page on your website as a template.

You can create a copy of either type of template to use as a starting point for your new page. Dreamweaver templates 

have editable and locked regions (see “Work with template-based web pages” on page 62). Such regions could be 

absent from templates created by the administrator. In addition, templates created by the administrator are assigned 

a workflow. Contribute assigns a default workflow to templates without a workflow. For more information, see “The 

draft review process” on page 46.

You can create a blog entry based on a template if your blog publishing service generates Dreamweaver templates for 

your blog. To know more about creating blog entries, see “Create a blog entry for your blog” on page 81.

Remember to add a link to the new page before you publish it; otherwise, website visitors cannot navigate to the page. 

Note: It’s a good idea to create the new page and a link to that page at the same time for websites and blog entries. For 

more information, see “Link to a new page” on page 178 and “Link to a new blank blog entry” on page 179.

1 In the Contribute browser, click the New button in the toolbar, or select File > New. 

The New Web Page Or Blog Entry dialog box opens.

2 In the Create New Web Page Or Blog Entry For pane, do the following:

a Expand the website in which you want to create the new page. 
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b Expand the Templates folder, and then select a template.

Note: If you don’t see the Templates folder, your Contribute administrator has restricted the types of new pages 

that you can create. For more information, talk to your Contribute administrator or see “Specify settings for new 

web pages” on page 291.

A preview of the page you select appears in the Preview pane on the right side of the dialog box.

3 Enter a page title in the Page Title text box. 

This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

4 Click OK. 

The new page opens as a draft in Contribute. Be sure to add a link to your new page before you publish it (see 

“Create text and image links” on page 177).

Note: Contribute creates the new page in the same folder as the page you were viewing when you created the page 

(unless you selected another website in step 2). You can change the folder location when you publish the new page. 

Create a stand-alone web page

You can use Contribute to create pages that aren’t on a website you’ve connected to. You can save the page on your 

computer or network.

1 In the Contribute browser, click the New button in the toolbar, or select File > New. 

The New Web Page or Blog Entry dialog box appears. 

2 In the Create New Web Page Or Blog Entry For pane, expand My Computer (Windows) or This Mac (Mac OS), 

and then select Blank Web Page.

Note: Please select the option under My Computer (Windows) or This Mac (Mac OS) and not under a website that 

you are connected to.

3 Enter a title for the new page.

4 Click OK, and then click OK again at the prompt.

The Save As dialog box appears.

5 Browse to the location where you want to save the file, and click Save.

The new page opens as a draft in the Contribute editor.

See also 

“Create or copy a page on your website” on page 76

Create a blog entry for your blog

You can create the following types of blog entries:

• Blank blog entry

• Blank page 

• Blog entry based on a auoted selection from a web page
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Create a blank blog entry

You can create a blank blog entry to add to your blog. A blank blog entry is a blank page that might have the template 

(page layout and elements such as text and images) of your blog template, depending on whether your blog publishing 

service generates Dreamweaver templates for your blog. For example, if you create a blank blog entry for your blog 

hosted by TypePad, the blank blog entry has the page layout and elements of the blog template.

When you connect to a blog server, Contribute checks if the server supports the following properties:

• Categories

• Comments

• Trackbacks

• Media objects

• Images

If any property is not supported by the server, the corresponding option is disabled in Contribute.

You can add new information in a blank blog entry.

1 In the Contribute browser, click the New button in the toolbar, or select File > New. 

The New Web Page Or Blog Entry dialog box opens. 

2 Select the desired blog, and choose the Blank Blog Entry option.

3 Enter a title for the blog entry in the Blog Entry Title text box.

4 Click OK. 

The new blog entry opens as a draft in Contribute.

5 (Optional) Add a tag using the Tags field.

6 In the Date area, click the Set Date Time icon and set the date and time when you want your blog entry draft to be 

published.

7 (Optional) Select one or more categories from the Categories list.

8 Click the Allow Trackbacks icon  to maintain a list of other blogs that are linked to your blog entry.

9 Click the Allow Comments icon  to allow users to enter comments about your blog entry.

Note: Before publishing the blog entry, select File > Preview In Browser to view the blog entry in a web browser and 

test all the links in the entry.

10 Enter content for the blog entry and publish it.

Note: You can link a blank blog entry to another blank blog entry and publish the entries. For more information, see 

“Link to a new blank blog entry” on page 179.

Create a blank Page

Contribute supports a special blog entry called Pages supported by some blog sites. Contents of Pages are stored in a 

database, and are retrieved using protocols like MetaWeblog and Atom.

Pages, spelled with a capital P, contain information that does not change drastically over a period of time. Information 

contained in the Pages is displayed permanently on the blog. Pages can be organized in a hierarchical fashion into 

pages and subpages with a parent-child relationship between them. 

Note: You cannot use this feature when working with blog sites that do not support Pages. 
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For example, Pages could contain information about the author, copyright information, legal matter, or description of 

the blog. Sub pages for the author could contain information related to the author, like hobbies, professional interests, 

and personal likes and dislikes. 

Note: If the word Pages appears after a period, the reference could be either to Pages or normal web pages depending on 

the context.

Pages can use templates and each Page can use a different template. However, Contribute CS4 supports only the default 

template of the blog site and assigns it to all the Pages.

Note: You cannot assign categories or tags to Pages.

1 Connect to the blog in which you want to create the new blank blog Page. 

2 In the Contribute browser, click the New button in the toolbar, or select File > New. 

The New Web Page Or Blog Entry dialog box opens. 

3 Select the desired blog, and choose the Blank Page option.

Note: This option is not available for blog sites that do not support Pages. 

4 Enter a title for the blog Page in the Blog Page Title box.

5 Click OK. 

The new blog Page opens as a draft in Contribute.

6 In the Date area, click the Set Date Time icon and set the date and time when you want to publish your blog entry 

draft.

7 Select an option from the Parent Page pop-up menu to set a parent page for the Page.

8 Enter a number to set a page order for the Page. This order can change based on the relative page order of child 

pages.

9 Click the Allow Trackbacks icon to maintain a list of other blogs that are linked to your blog entry.

Note: Before publishing the blog entry, select File> Preview In Browser to view the blog entry in a web browser. Test 

all the links in the entry.

10 Enter the content for the blog entry and publish it.

Note: You can link a blank blog entry to another blank blog entry and publish the entries. For more information, see 

“Link to a new blank blog entry” on page 179.

See also 

“Create a blog entry based on a quoted selection” on page 83

“Set date and time for a blog entry” on page 84

Create a blog entry based on a quoted selection

You can create a new blog entry from information you select in a web page in the Contribute browser. Such a selection 

is called a quote.
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You can also create a blog entry from a quoted selection in an external browser, such as Microsoft Internet Explorer 

(see “Post content to a blog from a browser” on page 215) or from Microsoft Office applications such as Word, Excel, 

and Outlook (see “Post content to a blog from Microsoft Office applications (Windows only)” on page 215). You can 

then publish the entry to your blog. 

1 In the Contribute browser, browse to the web page you want to quote a selection from.

2 Make a selection in the web page.

3 Do one of the following:

• If you have a connection to the website you are viewing, click the New button in the toolbar.

• If you don’t have a connection to the website you are viewing, select File > New.

The New Web Page Or Blog Entry dialog box appears.

4 Expand the folder for the blog where you want to publish the new entry.

5 Select Quote From Current Page.

Note: This option is not available if you are using a browser other than the Contribute browser.

6 Enter the title for the blog entry in the Blog Entry Title field.

7 Click OK.

See also 

“Create a blank blog entry” on page 82

Manage blog entries

Adobe Contribute has simplified the task of managing blog entries. You can quickly access a blog entry from your 

blog's home page by selecting the entry title from the Entries pop-up menu. This list displays all blog entries in the blog 

to which you are connected in reverse chronological order. When you select a blog entry from the Entries pop-up 

menu, the selected blog entry is loaded in the embedded browser.

You can make changes to a blog entry in the following ways:

• You can edit a blog entry directly in Contribute. For more information, see “Edit a blog” on page 51. 

• If you have a blog home page or an individual entry in a browser window, you can click the Edit In Contribute 

button to start Contribute and edit. For more information, see “Edit a web page or blog from your browser” on 

page 52.

Note: You must have a connection to the website or blog before you can edit a web page or blog entry in your browser.

See also 

“Undo mistakes” on page 55

“Save a draft for later use” on page 56

“Set date and time for a blog entry” on page 84

Set date and time for a blog entry

You can set the date and time when you want to schedule the publishing of your blog entry draft.
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If you select an earlier date, and publish the blog entry, it is published immediately with the date you specified. If you 

select a future date and publish the blog entry, the blog entry will be published on the specified date at the specified 

time only if your blog server supports the date control API. Alternatively, the blog entry is published immediately with 

the future date you specified.

Note: The publishing date and time settings are honored by compatible blog servers only.

Set parent Page and page order for a blog Page 

You can edit a blank blog Page to set its parent page and page order in blog sites that support this feature. Any page 

other than the page itself and its child pages are listed in the menu. For new blank blog Pages, all the pages are listed.

For Pages in the same hierarchal level, you can set the order in which they appear in the list. For example, let us 

consider two parent pages: My Hobbies with an order of 1 and About Me with an order of 2 that are listed under a Page 

called Personal Info. If you want About Me to be displayed before My Hobbies, change the Page Order for About Me 

to 1 and that for My Hobbies to 2. The final ordering, however, is determined based on the relative page order among 

Pages under the same Parent.

View and delete blog Pages

You can view blog Pages using the Choose File Or Blog Entry dialog box (View > Choose File or Blog Entry.) Click the 

Pages button to view the Pages in the blog. To delete a Page, browse to it using Contribute, and click Delete Blog Entry.

See also 

“Create a blank blog entry” on page 82

“Manage blog entries” on page 84

Set page properties for a web page

For each web page, you can specify layout and formatting properties, including the default font family and font size, 

background color, margins, link styles, and many other aspects of page design.

Note: You can set page properties for web pages only. You can’t set them for blog entries.

The page properties you select apply only to the current web page. If a page uses an external CSS style sheet, Contribute 

does not make changes to the external style sheet, because those changes affect all other pages that use that style sheet.
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Note: If you are editing a draft based on a template, or if you are restricted to text-only editing by your Contribute 

administrator, you might be able to change the page title only. For more information, contact your Contribute 

administrator or see “Set page-editing and paragraph settings” on page 288.

1 In your draft, click the Page Properties button in the toolbar, or select Format > Page Properties.

The Page Properties dialog box appears.

2 Select categories from the list on the left and make changes as necessary.

By default, Contribute uses CSS to assign page properties. If your Contribute administrator set the preference to 

use HTML tags instead of CSS, you see only the Title/Encoding and Appearance categories on the left side of the 

dialog box. For more information about this setting, contact your Contribute administrator or see “Set style and 

font settings” on page 289.

Note: If you cannot select the Links or Headings categories, your Contribute administrator has set options to prevent 

you from changing those page properties. Likewise, if you can only change page margins in the Appearance category, 

the administrator has restricted access to the other properties in that category. For more information, talk to your 

Contribute administrator or see “Set style and font settings” on page 289.

For information about options in any of the categories, see the following sections:

• “Setting the HTML Appearance Page Properties options” on page 108 or “Setting the CSS Appearance Page 

Properties options” on page 108

• “Setting the CSS Links Page Properties options” on page 109

• “Setting the CSS Headings Page Properties options” on page 109

• “Setting the Title/Encoding Page Properties options” on page 107

For information about options in any of the categories, click the Help button.

3 Click Apply to see changes without closing the dialog box or click OK to apply changes and close the dialog box.

See also 

“Add keywords and a description for a web page” on page 87
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Add keywords and a description for a web page

You can associate keywords and a description with your web page. Visitors who type one of your keywords in a search 

engine can find your page.

Note: You can add keywords and descriptions for web pages only. You can’t add them for blog entries.

1 Browse to the page you want to add keywords and a description for, and then click the Edit Page button in the 

toolbar.

A draft opens in the Contribute editor.

2 Select Format > Keywords And Description.

The Page Keywords And Description dialog box appears.

3 Enter or change keywords in the Keywords pane.

Separate each keyword with a single space (for example, meeting minutes planning committee holiday party).

4 Enter or change the page description in the Description pane.

5 Click OK. 

See also 

“Set page properties for a web page” on page 85

Set preferences for blog entries

You can set other preferences for blog entries. In the Preferences dialog box, you can perform the following tasks:

• Set options for the default blog to connect to, whether to create a blog entry when you click the New Page button, 

whether comments are allowed for blog entries, and whether to allow other users to link to a blog entry using its 

trackback URLs (see “Set Contribute preferences” on page 30).

Note: Some blog hosts do not support comments, or require you to set a preference to allow comments. Review your 

blog host’s documentation for more information.

For more information about adding trackback URLs to blog entries, see “Add trackback URLs to a blog entry” on 

page 91. For more information about adding tags to blog entries, see “Add tags to a blog entry” on page 89.

• Specify the ping server URLs you want Contribute to notify when you post a blog entry.
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• View a list of failed pings to the ping servers.

See also 

“Set Contribute preferences” on page 30

Enter metadata for a blog entry

When you’re creating or editing a blog entry, you can enter additional information about the entry using the blog 

metadata features. You can do the following tasks for blog entries:

• Select the blog to post the blog entry to

• Enter or change the title

• Add tags

• Assign categories

• Add trackback URLs

• Specify whether to allow comments

The primary blog metadata features—the blog to post the entry to, the blog entry title, and the tags to add to the 

blog entry—are available from the main blog entry toolbar in the Contribute browser. Secondary blog metadata 

features—categories, whether to allow trackback URLs, and whether to allow comments—are available when you 

click the Show/Hide Secondary Metadata button  on the blog entry toolbar, next to the Tags field or select More 

Options from the View menu.

In addition to the blog entry toolbars, you can also enter metadata features for a blog entry from the Format > Blog 

Metadata menu.

Select the blog for the blog entry

You can select the blog where you want to post a blog entry you’re creating or editing. You can post a blog entry to any 

blog to which you’ve created a Contribute connection. 

1 Create or edit the blog entry you want to post.

Note: For information about creating a blog entry, see “Create a blog entry for your blog” on page 81. For information 

about editing a blog entry, see “Manage blog entries” on page 84.

2 Do one of the following:

• Select the blog where you want to post from the Blog pop-up menu in the toolbar. 

• Select Format > Blog Metadata > Blogs, and then select the blog you want to post to from the pop-up menu.

Note: A warning appears if you’re posting an existing blog entry that you’re editing to a target blog other than the 

original blog. If you post the edited blog entry to a different blog, some blog metadata associated with the blog entry 

may be removed, and links to other blog entry drafts in the original blog are removed.

3 (Optional) Click OK to close the warning dialog box.

The blog entry is posted to the target blog. 

When you post an existing edited blog entry to a new blog, any links from the blog entry to blog entry drafts in the 

original blog are broken. You must resolve the broken links in the blog entry you moved and in the drafts to which 

it linked. 



89USING CONTRIBUTE CS4

Adding pages, blog entries, and documents

Note: For more information on linking to a blog entry, see “Link to a new page” on page 178. For more information 

on publishing a blog entry, see “Post content to a blog” on page 214.

Enter or change a blog entry’s title

You can enter or change the title for a blog entry. You can enter a title for a blog entry when you create it, or change it 

after you save the blog entry as a draft or post it to your blog.

Enter the title for a new blog entry

❖ Enter the title in the Blog entry title field in the New Web Page Or Blog Entry dialog box when you create the entry.

Enter or change the title for an existing blog entry or blog entry draft

❖ Do one of the following:

• Enter the title in the Title field in the toolbar.

• Select Format > Blog Metadata > Title, and enter the title in the Title field in the toolbar.

Add tags to a blog entry

You can use tags to enter one or more brief descriptions for your blog entries. Other users can search for blog entries 

that use those tags. For example, for a blog entry about the most strikeouts in a major league baseball game, you could 

enter tags such as “baseball,” “strikeouts,” “strikeout records,” and so on. The following tag repositories are provided 

for you:

• www.technorati.com/tag 

• http://blogs.icerocket.com/search?q=

When the user enters a tag in the tag field for a blog entry, Contribute creates a tag link. After the user publishes the 

entry and clicks the tag link, a list appears in the embedded browser showing all the blog entries indexed by the tag 

repository using the same tag.

When you create or edit a blog entry in the Pages panel, you can enter as many tags as you want for the entry, separated 

by commas.

Note: You can set preferences to determine where tags appear with your blog entries, the tag prefix to appear before tags 

in a blog entry, and more. For more information on entering tags, see “Set Contribute preferences” on page 30.

1 In the Pages panel, select the desired blog entry.

2 Do one of the following:

• Click the Tags field in the toolbar to place the pointer in it.

• Select Format > Blog Metadata > Tags to place the pointer in the Tags field in the toolbar.

3 In the Tags field, enter one or more tags for the blog entry. 

You can enter as many tags as you want for an entry. Use commas to separate tags.

Depending on the preferences you set for the Tagging option in the Preferences dialog box, Contribute adds the tags 

to the top or bottom of the blog entry, preceded by the specified tag prefix.

After you add the tags for the blog entry, you can edit it, publish it, or save it as a draft.

Note: You can clear tags from a blog entry by deleting them from the Tags field, or, if you are editing the blog entry, by 

deleting the tag in the entry. After you publish the updated blog entry, the tag no longer appears with the blog entry on 

the blog.
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See also 

“Set Contribute preferences” on page 30

Assign categories to a blog entry

You can assign categories to blog entries to group similar blog entries together. For example, you can categorize blog 

entries related to current affairs or sports. 

You can assign more than one category to a blog entry. You can change or remove a selected category at any time.

Support for categories varies among blog hosts. Some blog hosts provide predefined categories, others let you create 

your own categories, and some don’t support categories. For more information, review your blog host’s 

documentation.

1 In the Pages panel, select the desired blog entry.

2 Do one of the following: 

• Select the desired category from the Categories pop-up menu in the toolbar. 

A check mark appears next to the selected category. 

• Select Format > Blog Metadata > Categories, and then select the desired category from the pop-up menu.

A check mark appears next to the selected category. 

Note: You can assign multiple categories to a blog entry.

Assign a different category to a blog entry

1 If necessary, select the desired blog entry in the Pages panel.

2 Do one of the following:

• Select the new category from the Categories pop-up menu in the toolbar.

A check mark appears next to the specified category.

• Select Format > Blog Metadata > Categories, and then select the new category from the pop-up menu.

A check mark appears next to the specified category.

Remove a category from a blog entry

1 If necessary, in the Pages panel, select the desired blog entry in the Pages panel.

2 Do one of the following:

• Deselect the categories from the Categories pop-up menu in the toolbar.

• Select Format > Blog Metadata > Categories, and then deselect all selected Categories from the pop-up menu.

Refresh the list of available categories

Some blog hosts let you add, edit, or delete the categories you can assign to blog entries. After you make changes to the 

available categories at your blog host, you can refresh the list of available categories in Contribute to reflect the changes.

Note: You can make changes only to the available categories at your blog host. You can’t make changes to the categories 

in Contribute.

1 Select the desired blog in the Pages panel.

2 Click the Refresh button  on the blog metadata toolbar.
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The revised categories appear in the Categories pop-up menu in the toolbar. They also appear when you select 

Format > Blog Metadata > Categories. Blog entries using a newly created, edited, or deleted category are updated.

See also 

“Create a blog entry for your blog” on page 81

Add trackback URLs to a blog entry

When you create a blog entry, you can add one or more trackback URLs to it. You use trackback URLs to maintain a 

list of other blogs that are linked to your blog entry. To link to one of your blog entries, other blog authors add that 

blog entry’s trackback URLs to their blog entry. Your blog maintains a record of these linked blog entries for each of 

your blog entries. You can click these links to view the linked entries. You can also prevent other users from adding 

your blog’s trackback URL to their blog entries by disabling the Allow Trackback option.

Note: You set a preference to determine whether trackback is enabled for blog entries. Some blogs don’t support the 

trackback feature or require you to set a preference to allow it. For more information, see your blog documentation. For 

more information on enabling trackback URLs for blog entries, see “Set Contribute preferences” on page 30.

1 Select the desired blog entry in the Pages panel.

Note: Contribute does not validate the URLs you enter in the Trackbacks dialog box or the Trackback URL(s) field. If 

you enter an invalid URL, or want to change the trackback URL later, you can edit the blog entry and add a new 

trackback URL. However, you cannot edit or delete the trackback URLs you originally entered.

2 Do one of the following: 

• Click the Trackbacks button  in the toolbar. 

• Select Format > Blog Metadata > Allow Trackbacks. 

3 Enter the trackback URL for the blog entry in the Trackback URL(s) field, and then click OK.

Contribute adds the URLs to the blog entry, and the Trackbacks field appears at the bottom of the Contribute 

workspace. You can add, edit, or delete trackback URLs in this field. These modifications are also reflected in the 

Trackbacks dialog box.

Note: Some blogs do not support the trackback feature or require you to set a preference to allow it. For more 

information, see your blog documentation.

After you add a trackback URL to the blog entry, you can edit, publish, or save it as a draft.

Note: You can add only one trackback URL per line in the Trackbacks dialog box and the Trackback URL(s) field in 

the Contribute workspace.

See also 

“Set Contribute preferences” on page 30

Allow comments for blog entries

You can use the Blog Defaults option of the Preferences dialog box to specify whether Contribute allows the blog server 

to accept comments for your blog entries. If you enable comments, users can enter comments about your blog entries. 

You can also allow or disallow comments for individual blog entries.
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Note: You set a preference to determine whether comments are enabled for blog entries. For more information about 

allowing comments for blog entries, see “Set Contribute preferences” on page 30. Some blogs don’t support comments or 

require you to set a preference to allow it. For more information, see your blog documentation. 

1 Browse to a blog entry.

2 Click the Edit Entry button in the toolbar, or select File > Actions > Edit Entry.

3 Do one of the following:

• Select or deselect Format > Blog Metadata > Allow Comments to allow or disallow comments for the blog entry.

• Click the Allow Comments button in the toolbar to allow or disallow comments. 

4 After you allow or disallow comments for the blog entry, you can edit, post, or save it as a draft.

When you post the blog entry to your blog, a Comments link lets anyone reading the entry post a comment.

About converting documents to PDFs (Windows only)

You can use Contribute to convert Microsoft Office documents, such as Word documents, PowerPoint presentations, 

and Excel spreadsheets, to PDF documents, and insert these documents in Adobe Contribute web pages or blog entry 

drafts. The process of inserting a Microsoft Office document as a PDF involves conversion of the document to an 

Adobe PDF file before it is inserted. 

The PDF files are uploaded to a folder based on relevant Administrator settings.

See also 

“Set Contribute preferences” on page 30

Insert Office documents as PDFs in Contribute pages (Windows only)

You can use Contribute to convert Microsoft Office documents, such as Word documents, PowerPoint presentations, 

and Excel spreadsheets, to PDF documents, and insert these documents in Adobe Contribute web pages or blog entry 

drafts. The process of inserting a Microsoft Office document as a PDF involves conversion of the document to a PDF 

before it is inserted.

Note: If you are inserting a Microsoft Word document or Microsoft PowerPoint presentation, and want to specify the area 

of the document to convert, convert the document while working in Word or PowerPoint, and then insert it in your page 

in Contribute.

1 In the draft, place the insertion point where you want the PDF document to appear.

2 Select Insert > Document As PDF.

The Open dialog box appears with a list of PDF Convertible Documents.

3 Select an Office document, and then click Open.
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The Insert Office Document As PDF dialog box appears.

4 Select one of the following options:

Create A Link To The PDF Document  Converts the document to a PDF, and inserts a link to the selected document.

Insert The PDF As Embedded Object Converts the document to a PDF, and embeds the PDF document as an object.

Note: The Insert the PDF as Embedded Object option is disabled if your website administrator has prevented 

embedding of PDFs.

5 Select the Remember This Setting And Don't Ask Again check box, if desired. 

For more information about settings defined in the Preferences dialog box, see “Setting Microsoft Office document 

preferences (Windows only)” on page 41.

6 Click OK.

Contribute converts the document to a PDF document and inserts it as a link or an embedded object into your draft.

Create and insert a PDF document by dragging

1 In the draft, place the insertion point where you want the PDF document to appear.

Reduce the size of the Contribute window so that you can also see the application that contains the file you plan 

to drag.

2 Open Windows Explorer.

3 Drag the document to convert, to the insertion point.

The Insert Microsoft Office Document dialog box appears.

4 Select Convert To PDF and create a link to the PDF or Convert To PDF and embed the PDF as Object, and then 

click OK.

Contribute converts the document to a PDF document and inserts it into your draft.

Delete a PDF document from a draft 

1 In the draft, highlight the PDF document to select it. 

2 Press the Delete key.
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Add Microsoft Word and Excel documents to a website

With Contribute you can easily add Word and Excel documents or content from those documents to your website or 

blog entry. 

For example, suppose you have a Word table that contains contact information for all of your sales representatives in 

North America. You don’t have to recreate the table on your web page—you can use Contribute to add it to your 

website.

There are four ways to add Word or Excel content to a web page or blog entry: 

• Add the contents of a Word or Excel document to a new or existing web page or blog entry (Windows only).

• Insert a link to a Word or Excel document on an existing web page or blog entry.

• Convert the document to a PDF, and insert a link to the documenting an existing web page or blog entry.

• Convert the document to a PDF, and insert the document as an embedded object in an existing web page or blog 

entry.

In Windows, you can set a user preference so that when you add a Word or Excel document, Contribute always 

adds the contents of the document as an embedded object or inserts a link to the document. For more information, 

see “Setting editing preferences” on page 40.

You can add the contents of a Word and Excel document to the Contribute editor directly from Microsoft Office 

applications. For more information, see “Open documents in Contribute from Microsoft Office applications 

(Windows only)” on page 96.

Add Microsoft Word or Excel content to a page (Windows only)

You can add the contents of a Word or Excel document to a new or existing web page or blog entry.

When you add content to a page, Contribute converts it to HTML and copies it to your web page or blog entry. You 

can then edit the content in Contribute; changes you make to the original file on your computer do not appear on your 

website or blog entry.

If the document you are converting to HTML is larger than 300KB, Contribute notifies you that the file is too large to 

convert and gives you other options for inserting the document, such as converting the document to a PDF document 

or inserting a link to the document. For information about these options, see “Insert Office documents as PDFs in 

Contribute pages (Windows only)” on page 92 and “Insert a link to a Microsoft Word or Excel document” on page 95.

Note: If you use Microsoft Office 97, you cannot add the contents of a Word or Excel document; you must insert a link to 

the document or convert the document to a PDF document. 

1 In your draft, place the insertion point where you want the content to appear.

2 Do one of the following to select the file with the content you want to insert:

• In Contribute:

1 Select Insert > Microsoft Office Document. 

The Open dialog box appears.

2 Select the required Microsoft Office document, and click Open.

• (Windows only) From Windows Explorer, drag the file from its current location to the Contribute draft where 

you want the content to appear. 
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3 In the Insert Microsoft Office Document dialog box, click Insert The Contents Of The Document Into This Page, 

and then click OK.

4 (Optional) Select the Remember This Setting And Don't Ask Again check box if you do not want to be asked about 

the insert option in the future. 

You can also set these preferences from the Edit menu in Contribute. To do this, select Edit > Preferences > 

Microsoft Documents and set the desired preferences. For more information on setting these preferences, see “Set 

Contribute preferences” on page 30.

5 Click OK.

The contents of the Word or Excel document appear in your draft.

See also 

“Insert a link to a Microsoft Word or Excel document” on page 95

“Insert Office documents as PDFs in Contribute pages (Windows only)” on page 92

Insert a link to a Microsoft Word or Excel document

You can insert a link to a Microsoft Word or Excel document in an existing page or blog entry. 

When you publish the page or blog entry with the link, Contribute copies the document to your website and then links 

to that copy (not to the original file on your computer). 

Note: To edit content in the linked page or blog entry after you publish, see “Edit web page source in an external 

application” on page 68. Changes you make to the original file do not appear on your website or blog entry.

1 In your draft, place the insertion point where you want the content to appear.

2 Do one of the following to select the file with the content you want to insert:

• Place the insertion point in your draft where you want the link to appear, or select text or an image on the draft, 

then click the Link button  in the toolbar and select File On My Computer. 

In the Insert Link dialog box, enter link text, browse to the file you want to link to, and then click OK.

• (Windows only) Drag the file from its current location to the Contribute draft where you want the link to 

appear. 

In the Insert Microsoft Office Document dialog box, click Create A Link To The Document, and then click OK.

Note: The link text is the name of the file you link to. To change link text after you create the link, see “Change link 

text and destination” on page 189.

A link to the document appears in your draft.

See also 

“Add Microsoft Word or Excel content to a page (Windows only)” on page 94

“Insert Office documents as PDFs in Contribute pages (Windows only)” on page 92

Convert documents to PDF and inserting them in drafts (Windows only)

You can convert a Microsoft Word or Excel document to a PDF document, and insert a link to the PDF in an existing 

web page or blog entry, or insert the PDF as an embedded object in the draft.

1 In the draft, place the insertion point where you want the PDF document to appear.
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2 Select Insert > MS Office Document. In the dialog box that appears, browse to the file, and then click Open. 

The Insert Microsoft Office Document dialog box appears.

3 Select from the following options to insert the PDF document in your Contribute draft:

Note: These options are available for Microsoft Word and Excel documents only.

• Select Convert To PDF And Create A Link To The PDF to convert the selected document into a PDF, and insert 

a link to the PDF document.

• Select Convert To PDF and embed the PDF as Object to convert the selected document into a PDF, and embed 

the PDF document as an object.

4 (Optional) Select the Remember This Setting And Don't Ask Again check box if you do not want to be asked about 

the insert option in the future.

5 Click OK.

The document is converted to a PDF document and inserted as a link, or embedded as an object in your draft.

See also 

“Add Microsoft Word or Excel content to a page (Windows only)” on page 94

“Insert a link to a Microsoft Word or Excel document” on page 95

Open documents in Contribute from Microsoft Office 
applications (Windows only)

You can open documents such as spreadsheets, Word documents, and e-mail messages in Contribute using the 

Contribute toolbar in Microsoft Word, Excel, and the Outlook e-mail reader. You can open the documents inside these 

applications, use the Office toolbar for Contribute to insert the contents into the Contribute editor, and publish the 

content to your website without having to open Contribute.

The Microsoft Office toolbar is automatically installed when you install Contribute on your computer. 

Note: The Contribute toolbar is installed only on computers with Microsoft Office 2003, Microsoft Office XP, and 

Microsoft Office 2007 versions.

You can see the following changes in the MS Office toolbar:

• A new menu item Contribute appears in the application menu.

• A toolbar for Contribute appears in a separate row in the applications.

Open documents from Microsoft Word, Excel, and the Outlook e-mail reader

Whenever you open a document in Contribute from a Microsoft Office application, you can either insert a section or 

the entire contents of the document in the Contribute editor, create a link to the document from the active page in the 

Contribute editor, or insert the contents as a PDF.
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Note: When you open Outlook e-mail messages in Contribute, you can insert only the contents of the message in the 

editor.

There are three ways to add content from Microsoft Office applications to your new web page:

• Add Word, Excel, or Outlook contents to the page

• Insert a link from a Word or an Excel document

• Inserting a Word or Excel document as a PDF

Add Microsoft Word, Excel, or Outlook contents into a page from Microsoft Office (Windows 
only)

You can add the contents of a document (Word document, Excel spreadsheet, or an Outlook message) to a new web 

page. You can also associate templates with these documents before opening them.

When you add content to a page, Contribute copies the contents of your document into the Contribute editor. You 

can the edit the content in Contribute, and publish it to your website.

1 Open a document in Microsoft Word or Excel.

2 To open the document in Contribute, do one of the following from the Contribute toolbar in the application:

Note: If you made changes to the document, save the document before you open it in Contribute.

• Select Contribute > Open In Contribute.

• Click the Open In Contribute button in the toolbar.

Note: Contribute provides an alert if you do not have a website connection. For more information on creating a 

website connection, see “Create a website connection” on page 231.

The Open As New Page dialog box appears in Contribute.

3 Select the website where you want to place your document.

4 Click the Choose Template button to set an updated template for an Office document opened in Contribute. For 

more information about setting a template, see “Set templates when opening Office documents (Windows only)” 

on page 101.

If you do not click the Choose Template button in the Open as New Page dialog box, the template that was last used 

to open a Microsoft Office document or the _blank template is associated with the document you are currently 

opening. In addition, if this template does not match the template on the server, Contribute displays the Download 

Template dialog box. You can choose to do one of the following:

• Click the Open Using The Old Template button to open the document using the old template.



98USING CONTRIBUTE CS4

Adding pages, blog entries, and documents

• Click the Download And Open button to download the updated template from the server, and then open the 

document.

Note: If the target website does not have templates, when you click the Choose Template button, a message indicating 

that there are no templates is displayed.

5 (Optional) If you selected content in the document, and want to open the entire document instead of the selection, 

clear the Open Current Selection Only check box.

Note: This option is available only if you selected content in the document.

For information about options in the dialog box, click the Help button.

6 Click Open.

The Insert Microsoft Office Document dialog box appears in Contribute.

Note: The Insert Microsoft Office Document dialog box does not appear if you are inserting contents from an Outlook 

e-mail message. The contents of the e-mail message are automatically inserted into the Contribute editor after you 

click Open.

7 Select Insert The Contents Of The Document Into This Page.

8 (Optional) Select The Remember This Setting And Don’t Ask Again check box if you do not want to be asked about 

the insert option in the future.

For more information about options in the dialog box, click Help.

9 Click OK.

The selected template is applied to the web page, and Contribute opens the document in a draft. Before you publish 

this document, you must create a link to this new page from an existing page. For more information, see “Create 

text and image links” on page 177.

Note: You cannot use the Open In Contribute option for .rtf files.

See also 

“Insert a Microsoft Word or Excel document as a PDF from Microsoft Office (Windows only)” on page 100

“Set templates when opening Office documents (Windows only)” on page 101
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Insert a link to a Microsoft Word or Excel document from Microsoft Office (Windows only)

You can insert a link to a Microsoft Word or Excel document in a new page. When you publish the page with the link, 

Contribute copies the document to your website and then links to the copy (not to the original file on the computer).

1 Open a document in Microsoft Word or Excel.

2 (Optional) To open only a specific section of the document in Contribute, select the section.

3 To open the document in Contribute, do one of the following from the Contribute toolbar in the application:

Note: If you have made current changes to the document, save the document before you open it in Contribute.

• Select Contribute > Open In Contribute.

• Click the Open In Contribute button in the toolbar.

Note: Contribute provides an alert if you do not have a website connection. For more information on creating a 

website connection, see “Create a website connection” on page 231.

The Open As New Page dialog box appears in Contribute.

4 Select the website where you want to place your document.

5 Click the Choose Template button to set a template for an Office document opened in Contribute. For more 

information about setting a template, see “Set templates when opening Office documents (Windows only)” on 

page 101.

If you do not click the Choose Template button in the Open As New Page dialog box, the template that was last 

used to open a Microsoft Office document is associated with the document you are currently opening. In addition, 

if the template does not match the template on the server, Contribute displays the Download Template dialog box. 

You can do one of the following:

• Click the Open Using The Old Template button to open the document using the old template.

• Click the Download and Open button to update the template with changes from the server, and then open the 

document.

Note: If the target website does not have templates, when you click the Choose Template button a message indicating 

that there are no templates is displayed.

6 (Optional) Clear the Open Current Selection only check box to open the entire document instead of the selection.

Note: This checkbox is enabled when you select text in your document.

For information about options in the dialog box, click the Help button.

7 Click Open.

The Insert Microsoft Office Document dialog box appears.
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8 Select Create A Link To The Office document.

9 (Optional) Select the Remember This Setting And Don’t Ask Again check box if you do not want to be asked about 

the Insert option in the future.

For more information about options in the dialog box, click the Help button.

10 Click OK.

The selected template is applied to the web page, and Contribute inserts a link to the document in a draft. Before 

you publish this document, you must create a link to this new page from an existing page. For more information, 

see “Create text and image links” on page 177.

See also 

“Add Microsoft Word, Excel, or Outlook contents into a page from Microsoft Office (Windows only)” on page 97

“Insert a Microsoft Word or Excel document as a PDF from Microsoft Office (Windows only)” on page 100

“Set templates when opening Office documents (Windows only)” on page 101

Insert a Microsoft Word or Excel document as a PDF from Microsoft Office (Windows only)

With Contribute, you can insert a Microsoft Word or an Excel document as a PDF document from Microsoft Word 

or Excel into a web page.

1 Open a document in Microsoft Word or Excel.

2 (Optional) To open only a specific section of the document in Contribute, select the section.

3 To open the document in Contribute, do one of the following from the Contribute toolbar in the application:

Note: If you made changes to the document, save the document before you open it in Contribute.

• Select Contribute > Open In Contribute.

• Click the Open in Contribute button in the toolbar.

Note: Contribute provides an alert if you do not have a website connection. For more information on creating a 

website connection, see “Create a website connection” on page 231.

The Open As New Page dialog box appears.

4 Select the website where you want to place your document.

5 Click the Choose Template button to set a template for an Office document opened in Contribute. For more 

information about setting a template, see “Set templates when opening Office documents (Windows only)” on 

page 101.

If you do not click the Choose Template button in the Open as New Page dialog box, the template that was last used 

to open a Microsoft Office document is associated with the document you are currently opening. In addition, if this 

template does not match the template on the server, Contribute displays the Download Template dialog box. You 

can do one of the following:

• Click the Open Using The Old Template button to open the document using the old template.

• Click the Download and Open button to update the template with changes from the server, and then open the 

document.

Note: If the target website does not have templates, when you click the Choose Template button, a message indicating 

that there are no templates is displayed.

6 (Optional) Clear the Open current selection only check box to open the entire document instead of the selection.
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For information about options in the dialog box, click the Help button.

7 Click Open.

The Insert Microsoft Office Document dialog box appears.

8 Select Convert To PDF and create a link to the PDF or Convert To PDF and embed the PDF as Object.

9 (Optional) Select the Remember This Setting And Don’t Ask Again check box if you do not want to be asked about 

the insert option in the future.

For information about options in the dialog box, click the Help button.

10 Click OK.

Contribute converts the document to a PDF file and inserts it as a link or as an embedded object into your draft. 

Also, Contribute applies the selected template to the web page. 

See also 

“Add Microsoft Word, Excel, or Outlook contents into a page from Microsoft Office (Windows only)” on page 97

“Insert a link to a Microsoft Word or Excel document from Microsoft Office (Windows only)” on page 99

“Set templates when opening Office documents (Windows only)” on page 101

Set templates when opening Office documents (Windows only)

Adobe Contribute lets you place content from Office documents (Microsoft Word and Microsoft Excel) or entire 

documents in document templates, while opening the documents in Contribute. 

When you choose a template, the workflow associated with that template is assigned to the created page.

1 Open a Microsoft Office application file. 

2 Edit the content and save the document.

3 Click the Open In Contribute button in the toolbar.

The Open As New Page dialog box appears.

Note: You cannot use the Open in Contribute option for .rtf files.

4 Select the required website.

The Root URL of the selected website appears automatically.

5 Click the Choose Template button. The Choose Template dialog box appears.

If you do not click the Choose Template button in the Open as New Page dialog box, the template that was last used 

to open a Microsoft Office document is associated with the document you are currently opening. In addition, if this 

template does not match the template on the server, Contribute displays the Download Template dialog box. You 

can do one of the following:

• Click the Open Using The Old Template button to open the document using the old template.

• Click the Download and Open button to update the template with changes from the server, and then open the 

document.

Note: If the target website does not have templates, when you click the Choose Template button, a message indicating 

that there are no templates is displayed. If the document you are opening is in the native format, the Choose Template 

button is disabled. 

6 Select a template from the list of available templates.
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The preview of the selected template appears in the Preview pane.

Note: While creating a new page, if you select a template that does not match the template on the server, Contribute 

prompts you to confirm whether you want to create the page based on the old template. If you click Yes, the new page 

is created based on the old template. If you click No, the selected template is updated, and then the page is created.

7 Select a template region from the list of editable regions available in the selected template.

Note: If the selected template does not have editable regions, the Select The Template Region list is empty.

This list is disabled if you select the _blank template.

Note: After selecting a template to use, you must select a template region. If you select a template to use and click OK, 

then the first editable region in the Select The Template Region list is selected.

8 Click the Refresh Templates button, and select one of the following options to update templates and editable 

regions in a selected template:

For This Website To view an updated list of templates for the selected website.

For Selected Template To view an updated list of editable regions in the selected template.

9 By default, the Make This As The Default Template check box is selected. Clear this check box, if desired.

10 Click OK.

The selected template is applied to the web page containing the Office document, and the document is opened in 

the HTML format.

11 (Optional) If you selected content in the document, and want to open the entire document instead of the selection, 

clear the Open Current Selection Only check box.

12 Click Open.

The Insert Microsoft Office Document dialog box appears.

13 Select one of the following options:

• Insert the contents of the document into this page to copy the content of the selected document into the draft.

• Create a link to the office document to insert a link to the selected document.

• Convert to PDF and create a link to the PDF to convert the selected document into a PDF, and insert a link to 

the PDF document.

• Convert to PDF and embed the PDF as Object to convert the selected document into a PDF, and embed the PDF 

document as an object.

14 (Optional) Select the Remember This Setting And Don’t Ask Again check box if you do not want to be asked about 

the insert option in the future.

15 Click OK.

The selected template is applied to the new web page in which the document is inserted. The selected content 

appears in the Contribute draft, or a link to the selected content is inserted in the draft. If you converted the 

document to a PDF file, Contribute inserts a link to the PDF file, or embeds the PDF file as an object.

Note: If you open or publish a document in Contribute without clicking the Choose Template button in the Publish 

To Website Or Open As New Page dialog box, the last template stored in the registry is applied to the web page 

containing the Office document. If you are performing the Publish to Website or Open in Contribute operation for the 

first time, then a blank template is selected.
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Insert PDFs in Contribute pages

Adobe Contribute lets you embed PDFs as objects, or insert links to PDFs in Contribute web pages and blog entry 

drafts. You can add rich PDF content ranging from high resolution images to three-dimensional models on your 

website or blog page. The PDFs may be available on your computer, or on a website. 

When you publish a web page or blog entry containing an embedded PDF object, Contribute makes the content 

EOLAS-compliant.

Note: It is recommended that you install Adobe Acrobat 8 on your computer before working with PDFs in Contribute.

Insert a PDF from your computer

1 In the draft, place the insertion point where you want the PDF document to appear.

2 Select Insert > PDF Document > From My Computer.

The Open dialog box appears.

3 Navigate to the required PDF document, and then click Open.

The Insert PDF Document dialog box appears.

4 Select one of the following options:

• Create A Link To The PDF Document 

• Insert The PDF As Embedded Object.

Note: The Insert The PDF As Embedded Object option is disabled if the Administrator has selected the Do not 

allow PDF Embedding option for the relevant website or blog connection.

5 (Optional) Select the Remember this option and don't ask again check box, if it is required.

6 Click OK.

Note: If you inserted the PDF as an embedded object, a message box appears indicating that some content of the PDF is 

not accessible, and that some browsers may not render the PDF content. Select the Don't Warn Me Again check box, if 

desired, and then click OK.

The link to the PDF or the content of the embedded PDF appears at the insertion point in the draft. If you inserted the 

PDF as a link, the name of the PDF file appears as the linked text.

Insert a PDF from your website

1 In the draft, place the insertion point where you want the PDF document to appear.

2 Select Insert > PDF Document > From Website.

Note: You can use the Insert > PDF Document > From Website option only if you have an active website.

The Choose PDF Document on Website dialog box appears.

3 Double-click the web address and navigate to the folder containing the PDF you want to insert. Select the required 

PDF and click OK.

4 Depending on the user preference you have defined, the PDF is inserted as a link or as an embedded object. 

Alternatively, the Insert PDF Document dialog box appears, and you can select one of the following options:

• Create A Link To The PDF Document

• Insert The PDF As Embedded Object.
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5 (Optional) Select the Remember this option and don't ask again check box, if desired.

Note: The Insert the PDF as embedded Object option is disabled if the administrator has selected the Do not allow 

PDF Embedding option for the relevant website.

6 Click OK.

Note: If you inserted the PDF as an embedded object, a message box appears indicating that some content of the PDF is 

not accessible, and that some browsers may not render the PDF content. Select the Don't Warn Me Again check box, if 

desired, and then click OK.

The link to the PDF or the content of the embedded PDF appears at the insertion point in the draft. If you inserted the 

PDF as a link, the name of the PDF file appears as the linked text. 

Note: You can also drag and drop a PDF file from Windows Explorer to your website or blog entry draft.

Resize embedded PDF files inserted in web pages or blog entries

You can change the size of the embedded PDF object in a web page or blog entry draft by selecting the object and dragging 

its boundaries. Alternatively, you can resize the object by entering specific values in the PDF Properties dialog box.

Resize an embedded PDF file manually

1 In your draft, select the content of the embedded PDF you want to resize.

2 Drag one of the selection handles to the desired size.

Hold the Shift key as you drag if you do not want to change the height and width of the PDF object by the same 

percentage. 

Resize an embedded PDF file with specific values

1 In your draft, select the embedded PDF you want to resize.

2 Double-click the embedded PDF object, right-click the object and select the PDF Properties option, or select the 

PDF object and choose Format > PDF Properties.

The PDF Properties dialog box appears.

3 Enter Width and Height values, and choose whether or not to constrain proportions.

4 Click OK.

Contribute changes the height and width of the embedded PDF object.

Note: You can also format an embedded PDF object by right-clicking the object and selecting an option from the pop-

up menu.

See also 

“Add Microsoft Word or Excel content to a page (Windows only)” on page 94

“Insert a link to a Microsoft Word or Excel document from Microsoft Office (Windows only)” on page 99

“Insert a Microsoft Word or Excel document as a PDF from Microsoft Office (Windows only)” on page 100
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Insert HTML code snippets 

Advanced Adobe Contribute users can use Adobe Contribute to add custom HTML code snippets to Contribute 

pages. For example, you can insert code snippets that run video or audio files in your web or blog pages. However, you 

can add code snippets only if the website administrator has granted the relevant permission to your user role.

You can create and insert your own HTML code snippets. Although Contribute validates the syntax of the code 

snippet, it does not validate the code for logical correctness. 

Important: The HTML code you add to a Contribute page may override some Administrator settings, thus altering 

product behavior. Therefore, it is recommended that you use this feature with discretion.

1 Browse to a web page or your blog home page.

2 If you browsed to a blog home page, select a blog entry to edit from the Entries pop-up menu.

3 Click Edit Page or Edit Entry.

4 Place the insertion point in your draft where you want to insert the HTML code snippet.

5 Select Insert > HTML Snippet.

The Insert HTML Snippet dialog box appears.

Note: If your website Administrator has not enabled the Allow HTML Snippet Insertion option for your user role, the 

HTML Snippet option in the Insert menu will be disabled. However, this option is enabled by default, for blog entries.

6 Type the code snippet, or insert the HTML code snippet you have copied from another source.

7 Click OK.

The HTML code snippet is executed in the relevant draft.

See also 

“Set the option for inserting HTML Code Snippets” on page 289

Reference

This section provides information about the dialog boxes introduced in this chapter.

Completing the Insert Microsoft Office Document dialog box (Windows only)

The Insert Microsoft Office Document dialog box appears when you perform the following tasks:

• From a Microsoft Office application (Word or Excel), you choose to open a document in Contribute.

• Insert a Microsoft Office document (Word or Excel) in Contribute.

• Drag a Microsoft Office document (Word or Excel) to your draft in the Contribute editor. 

You can insert the content into your draft, or you can create a link to the document. You can also convert the document 

to a PDF and insert a link to the PDF, or insert the PDF as an object in your draft.

1 Select from the following options:

• Select Insert The Contents Of The Document Into This Page to insert the contents of the document.

• Select Create A Link To The Office Document to create a link to this document.
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• Select Convert To PDF And Create A Link To The PDF to convert the selected document into a PDF, and insert 

a link to the PDF document.

• Select Convert To PDF And Embed The PDF As Object to convert the selected document into a PDF, and 

embed the PDF document as an object.

If the document you want to insert is larger than 300KB, Contribute displays an alert that the document is too large 

to insert and gives other options for adding it to your website.

Note: When you insert a link, the link text is the name of the file you link to. To change link text after you create the 

link, see “Change link text and destination” on page 189. Also, when you publish the draft, Contribute copies the 

document to your draft and then links to that copy, not to the original file.

2 Select Remember This Setting And Don’t Ask Again to have Contribute remember your preference.

3 Click OK.

The content or a link to the content appears in your draft.

See also 

“Add Microsoft Word and Excel documents to a website” on page 94

“Post content to a blog from Microsoft Office applications (Windows only)” on page 215

Completing the New Web Page Or Blog Entry dialog box

Use the New Web Page or Blog Entry dialog box to create a page on your website or blog entry on your blog.

1 Select the website or blog in which you want to create a web page or blog entry in the Create New Web Page Or Blog 

Entry For pane.

Note: If you cannot edit any folders on the website, you cannot create a page for that website.

2 Do one of the following to indicate the type of page or entry you want to create:

• If you are creating a new web page, select one of the following options:

Note: If your Contribute administrator has restricted the types of new pages that you can create or you do not have 

permission to edit this website, you won’t see all these options.

Blank Web Page Creates a blank page.

Copy Of Current Page Creates a copy of the website page that you are currently viewing.

Note: You cannot create a copy of the current page if the page contains frames or if the page is a draft in the 

Contribute workspace. You cannot copy a page from one website to another website.

Select A Page In The Starter Web Pages Folder Creates a copy of a built-in sample page provided with 

Contribute.

Select A Page In The Templates Folder Creates a page based on a Dreamweaver template or on a website page 

that your Contribute administrator designated as a template.

• If you are creating a new blog entry, select one of the following options:

Select Blank Blog Entry Creates a blank blog entry.

Select Blank Page Creates a blank blog Page entry.

Select Quote From Current Page Creates a blog entry using content you selected from a blog entry or web page 

you are viewing.
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Note: This option is available only if you selected text in the page you are currently viewing.

When you select a page type, a preview and a description appear. 

3 Click the Refresh Templates button, and then select one of the following options:

For All Websites To update templates of all websites or blogs globally.

For Selected Website/Blog To update templates of the selected website or blog only.

For Selected Template In the case of websites, to update the selected template only.

Note: For blogs, be sure to select a blog before you click the button.

4 Enter a title in the Page Title or Blog Entry Title text box.

5 For web pages, the title appears in the browser title bar when a website visitor views the page; for blog entries, the 

title appears on the blog home page as a link to the entry.

6 Click OK.

The new page or blog entry opens as a draft in Contribute, so you can add content. For new pages, be sure to add a 

link to your new page before you publish it (see “Create text and image links” on page 177).

Note: Contribute creates the new page in the same folder as the page you were viewing when you created the page 

(unless you selected another website). You can change the folder location when you publish the new page. 

Using the Trackbacks dialog box

The Trackbacks dialog box allows you to define one or more trackback URLs for a selected blog entry.

1 In the Enter Trackback URLs field, specify the required URLs. Ensure that each URL is defined on a separate line.

2 Click OK.

If you defined the trackback URLs for the first time, the Trackbacks field appears along with the new URLs in the 

Contribute workspace.

Note: You can use the Trackbacks field in the Contribute workspace to add new URLs, edit, or delete them.

Setting the Title/Encoding Page Properties options

The Title/Encoding Page Properties options let you specify a page title for your web page and select a document 

encoding type.

1 Make changes to any of the following options:

Title Specifies the page title that appears in the title bar of the website visitor’s browser; the title does not appear on 

the page itself. 

Giving a page a title is not the same as giving it a filename. For information about filenames, see “Publishing a page 

to your website” on page 203.

Encoding Specifies the encoding used for characters on the page.

Select Western for English and Western European languages. Additional options include Central European, 

Cyrillic, Greek, Icelandic, Japanese, Traditional Chinese, Simplified Chinese, and Korean. 

Note: Click the Reload button only if Contribute opened the page for editing with the wrong encoding. Select the 

correct encoding for the page; then click Reload to reload the last saved version of the page with the correct encoding.

2 Click Apply to see changes without closing the dialog box or click OK to apply changes and close the dialog box.
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See also 

“Set page properties for a web page” on page 85

Setting the HTML Appearance Page Properties options

The HTML Appearance Page Properties options let you specify several basic page layout options for your web pages.

1 Make changes to any of the following options:

Text Color Defines a color for text on the page.

Background color Sets the background color of the page. If you also select a background image for the page, website 

visitors do not see the background color (unless the image is transparent).

Background image Lets you browse to select a background image for the page.

Click the Browse button, and then select Images On My Computer or Images On Website to select an image.

Left margin, Top margin, Right margin, and Bottom margin determine the size of page margins. If you do not want 

margins on the page, enter 0 for each margin or leave it blank. 

Margins are measured in pixels; there are approximately 72 pixels per inch.  

2 Click Apply to see changes without closing the dialog box or click OK to apply changes and close the dialog box.

See also 

“Set page properties for a web page” on page 85

Setting the CSS Appearance Page Properties options

The CSS Appearance Page Properties option lets you specify several basic page layout options for your web pages.

1 Make changes to any of the following options:

Page Font Specifies the default font family to use in your web pages. Contribute uses the font family you specify 

unless another font is specifically set for a text element.

Size Specifies the default font size to use in your web pages. Contribute uses the font size you specify unless another 

font size is specifically set for a text element.

Text Color Defines a color for text on the page.

Background Color Sets the background color of the page. If you also select a background image for the page, 

website visitors do not see the background color (unless the image is transparent).

Background Image Lets you browse to select a background image for the page.

Click the Browse button, and then select Images On My Computer or Images On Website to select an image.

Left Margin, Top Margin, Right Margin, and Bottom Margin Determine the size of page margins. If you do not want 

margins on the page, enter 0 for each margin.

2 Click Apply to see changes without closing the dialog box, or click OK to apply changes and close the dialog box.

See also 

“Set page properties for a web page” on page 85
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Setting the CSS Links Page Properties options

The CSS Links Page Properties option lets you define the default font, font size, and colors for links, visited links, and 

active links.

1 Make changes to any of the following options:

Link Font Specifies the default font family to use for link text. By default, Contribute uses the font family specified 

for the entire page unless you specify another font.

Size Specifies the default font size to use for link text.

Link Color Specifies the color to apply to link text.

Visited Links Specifies the color to apply to links a website visitor has clicked.

Rollover Links Specifies the color to apply when a mouse (or pointer) hovers over a link.

Active Links Specifies the color to apply when a mouse (or pointer) clicks on a link

Underline Style Specifies the underline style to apply to links. 

2 Click Apply to see changes without closing the dialog box or click OK to apply changes and close the dialog box.

See also 

“Set page properties for a web page” on page 85

Setting the CSS Headings Page Properties options

The CSS Headings Page Properties options let you specify the font family and font size for headings in CSS pages.

1 Make changes to any of the following options:

Heading Font Specifies the default font family to use in your web pages. Contribute uses the font family you specify 

unless another font is specifically set for a text element.

Heading 1 Size Specifies the font size and color to use for up to six levels of heading tags. 

2 Click Apply to see changes without closing the dialog box, or click OK to apply changes and close the dialog box.

See also 

“Set page properties for a web page” on page 85

Completing the Page Keywords and Description dialog box

Use the Page Keywords and Description dialog box to associate keywords and a description with a web page.

1 Enter or change keywords in the Keywords pane.

Separate each keyword with a single space (for example, meeting minutes planning committee holiday party).

2 Enter or change the page description in the Description pane.

3 Click OK. 
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Completing the Open As New Page dialog box (Windows only)

You use the Open As New Page dialog box to specify a website when inserting the contents of your Word document, 

Excel spreadsheet, or an Outlook e-mail message in the Contribute workspace.

1 Select the website where you want to place your document.

The site root URL path for the selected website appears in the Root URL field.

2 Click the Choose Template button to set a template for an Office document opened in Contribute. For more 

information about setting a template, see “Set templates when opening Office documents (Windows only)” on 

page 101.

If you do not click the Choose Template button in the Open as New Page dialog box, the template that was last used 

to open a Microsoft Office document is associated with the document you are currently opening. In addition, if this 

template does not match the template on the server, Contribute displays the Download Template dialog box. You 

can do one of the following:

• Click the Open Using The Old Template button to open the document using the old template.

• Click the Download And Open button to update the template with changes from the server, and then open the 

document.

If the target website does not have templates, when you click the Choose Template button, a message indicating 

that there are no templates is displayed.

3 If you have made a selection in the document and want to continue to insert only the selected section, select Open 

Current Selection Only.

Note: The Open Current Selection Only field appears disabled if you have not selected any content in your document.

4 Click Open.

Selecting the blog entry to edit

You use the Select a Blog Entry to Edit dialog box to select which of the blog’s entries you want to edit.

1 In the Select The Entry You Want To Edit pane, select the blog entry.

A preview of the page you select appears in the Preview pane.

2 Click Edit.

Contribute opens the selected blog entry for editing.

Using the Insert Office Document as PDF dialog box (Windows only)

You use the Insert Office Document as PDF dialog box to convert Microsoft Office documents, such as Word files, 

PowerPoint presentations, or Excel spreadsheets, into PDF documents, and insert these documents in Adobe 

Contribute web pages or blog entry drafts.

1 Select one of the following options:

Create A Link To The PDF Document Converts the document to a PDF, and inserts a link to the PDF document.

Insert The PDF As Embedded Object  Converts the document to a PDF, and embeds the PDF document as an 

object.

Note: The Insert the PDF As Embedded Object option is disabled if your website administrator has prevented 

embedding of PDFs.
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2 Select the Remember This Setting And Don't Ask Again check box, if desired. For more information about settings 

defined in the Preferences dialog box, see “Setting Microsoft Office document preferences (Windows only)” on 

page 41.

3 Click OK.

Contribute converts the document to a PDF document and inserts it as a link or an embedded object into your draft.

Using the Insert PDF Document dialog box

You use the Insert PDF Document dialog box to embed PDFs as objects, or insert links to PDFs in Contribute web 

pages or blog entry drafts.

1 Select Insert > PDF Document > From My Computer. 

Note: The Insert the PDF as embedded Object option in the Insert menu is disabled if the Administrator has selected 

the Do not allow PDF Embedding option for the relevant website or blog connection.

2 Select a PDF file. The Insert PDF Document dialog box appears. Select one of the following options

Create A Link To The PDF Document Converts the document to a PDF, and inserts a link to the PDF document.

Insert The PDF As Embedded Object Converts the document to a PDF, and embeds the PDF document as an object.

3 (Optional) Select the Remember This Option And Don't Ask Again check box, if desired.

4 Click OK.

Note: If you inserted the PDF as an embedded object, a message box appears indicating that some content of the PDF 

is not accessible, and that some browsers may not render the PDF content. Select the Don't Warn Me Again check box, 

if desired, and then click OK.

The link to the PDF or the content of the embedded PDF appears at the insertion point in the draft. If you inserted 

the PDF as a link, the name of the PDF file appears as the linked text.

Using the PDF Properties dialog box to resize an embedded PDF

You use the PDF Properties dialog box to specify custom width and height values to resize an embedded PDF object 

in a web page or blog entry draft.

1 Enter Width and Height values.

2 (Optional) Select the Constrain Proportions option to preserve the current proportions of the PDF object. By 

default, this option is selected.

3 Click OK.

Using the Insert HTML Snippet dialog box

Use the Insert HTML Snippet dialog box to write or copy code snippets that run video or audio files in web page or 

blog entry. The code snippet is then inserted into the Contribute page.

1 In the Enter The HTML Code Snippet You Want To Insert pane, type the code snippet, or paste the HTML code 

snippet you have copied from another source.

2 Click OK.

The HTML code snippet is executed in the draft Contribute page.
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Using the Choose Template dialog box (Windows only)

Use the Choose Template dialog box to set an updated template for a Microsoft Office document opened or published 

in Contribute.

1 Select a template from the list of available templates.

The preview of the selected template appears in the Preview pane.

2 Select a template region from the list of editable regions available in the selected template.

Note: If the selected template does not have editable regions, the Select The Template Region list is empty.

This list is disabled if you select the _blank template.

Note: You must select an editable region. If you select a template and click OK, then the first editable region in the 

Select Editable Region list is selected.

3 Click the Refresh Templates button, and select one of the following options to update your list of templates and 

editable regions in a selected template:

• For this website To view an updated list of templates for the selected website.

• For selected template To view an updated list of editable regions in the selected template.

4 By default, the Make this as the default template check box is selected. Clear this check box, if desired.

5 Click OK.

The selected template is applied to the web page containing the Office document, and the document is opened in 

the HTML format.

6 (Optional) If you selected content in the document, and want to open the entire document instead of the selection, 

clear the Open Current Selection Only check box.

7 Click Open.

Using the Download Template dialog box (Windows only)

Use the Download Template dialog box to open or publish a Microsoft Office document, using the old template or the 

latest template available on the server.

Use the Download Template dialog box while opening a Microsoft Office document in Contribute

• Click the Open Using The Old Template button to open the document using the old template.

• Click the Download And Open button to update the template with changes from the server, and then open the 

document.

Use the Download Template dialog box while publishing a Microsoft Office document in Contribute

• Click the Publish Using The Old Template button to publish the document using the old template.

• Click the Download And Publish button to download the updated template from the server, and then publish the 

document.
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Chapter 6: Working with text

You can use Adobe® Contribute® to add and format text, much as you do with a basic word processor. You’ll find a few 

differences in working with text in Contribute and a word-processing program, such as Microsoft Word, because 

Contribute formats your text using HTML behind the scenes.

For information about working with text in tables, see “Working with tables” on page 158. For information about 

aligning text around images, see “Align an image” on page 137. For information about editing link text, see “Working 

with links” on page 177.

About HTML and CSS styles in the Contribute Style 
menu

The Style pop-up menu in Contribute lists HTML heading and paragraph styles, plus user-defined cascading style 

sheet (CSS) styles that you can apply to format your content. All styles in the list appear as they appear when you apply 

them to text.

Note: If the Style menu is not enabled, your Contribute administrator has restricted the website so you cannot apply styles. 

You might also be able to create CSS styles as you format text; Contribute automatically adds these styles to your style 

list. This makes applying the same formatting to a block of text much simpler as well as letting you create a more 

consistent look for your pages. 

Note: You do not see HTML heading or CSS styles if your Contribute administrator has disabled one or both of them. To 

enable or disable CSS styles in Contribute, talk to your Contribute administrator or see “Set style and font settings” on 

page 289.

You cannot attach a cascading style sheet to a page in Contribute to add more styles; use Dreamweaver to attach a style 

sheet. 

See also 

“Apply styles to text” on page 118

“Create and manage styles” on page 119

Add text to a web page

You can add text to a web page by typing text, copying and pasting text, or dragging text from another application or 

web page to your Contribute draft. 

If you are using the Windows version of Contribute, you can add the entire contents of a Microsoft Word or Excel 

document to a web page. For more information, see “Add Microsoft Word and Excel documents to a website” on 

page 94. 
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Your Contribute administrator can specify the amount of space that Contribute adds between paragraphs when you 

press Enter or Return. For more information, talk to your Contribute administrator or see “Set page-editing and 

paragraph settings” on page 288.

❖ Do one of the following:

• Place the insertion point in the draft; then type text directly into your draft.

• Select text in another application; then select Edit > Copy. Place the insertion point in your Contribute draft; 

then select Edit > Paste. 

Leave Microsoft Excel running when you copy and paste Excel content to Contribute so that the pasted content 

retains its formatting.

• Drag selected text from another application to your Contribute draft.

Note: Contribute might preserve text formatting applied in the other application.

Add the current date to a page

You can add the current date to a page. The date can also include the day of the week and the time.

1 Place the insertion point in your draft where you want the date to appear.

2 Select Insert > Date.

The Insert Date dialog box appears.

The insert Date pane

3 Select the format for the day, date, and time.

For more information about the options, see “Completing the Insert Date dialog box” on page 127.

4 Click OK.

Contribute adds the current date to your draft.

See also 

“Add special characters to a page” on page 115
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Add special characters to a page

You can add special characters, such as a copyright symbol (©) or a pound sign (#), to your page. 

Note: You can add special characters only to pages that use Western (Latin 1) encoding. For more information about 

setting page encoding, see “Set page properties for a web page” on page 85.

1 Place the insertion point in your draft where you want the character to appear.

2 Do one of the following:

• Select Insert > Special Characters, and then select a character from the pop-up menu.

• Select Insert > Special Characters, and then select Other. In the Insert Other Character dialog box, click the 

character you want to insert, and then click OK.

The Insert Other Character pane

The character appears in your draft.

Format text

Contribute lets you format text—characters and entire paragraphs—quickly and easily. You can use menu options or 

use the text formatting toolbar to change text with one click.

For a detailed illustration of the text formatting toolbar, see “The Contribute toolbars” on page 23.

Note: For information about moving text, see “Position text on the page” on page 120.

Change text font and size

You can change the appearance of text by changing its font or size. Select a font or size from the available options; you 

cannot enter a custom size.

Most browsers can render the fonts in the Contribute font list. It’s good web-design practice to use fonts that are 

generally available to your website visitors. 
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Each font in the list actually represents a font combination list. To edit your list of available fonts, see “Edit the font 

list” on page 117.

Change text size

1 In your draft, select the text you want to change.

2 Do one of the following:

• Select a size from the Font Size pop-up menu in the text formatting toolbar.

• Right-click (Windows) or Control-click (Mac OS), select Size, and then select a size from the pop-up menu.

Note: This option is not available if you are working in a table.

• Select Format > Size, then select a size from the pop-up menu.

Change text font

1 In your draft, select the text you want to change.

2 Do one of the following:

• Select a font from the Font pop-up menu in the text formatting toolbar.

• Right-click (Windows) or Control-click (Mac OS), select Font, and then select a font from the pop-up menu.

Note: This option is not available if you are working in a table.

• Select Format > Font, then select a font from the pop-up menu.

Make text bold, italic, or underlined

1 In your draft, select the text you want to change.

2 Do one of the following:

• Click the Bold or Italic button in the text formatting toolbar.

• Right-click (Windows) or Control-click (Mac OS), then select Bold, Italic, or Underline.

Note: This option is not available if you are working in a table.

• Select Format > Bold, Format > Italic, or Format > Underline.

Note: It is not good practice to use the underline style in web pages because website visitors might mistake 

underlined text for link text. Use a style other than underline to emphasize text.

Make text strikethrough, emphasis, strong, or fixed width

1 In your draft, select the text you want to change.

2 Do one of the following:

• Right-click (Windows) or Control-click (Mac OS), select Other, and then select one of the options from the pop-

up menu.

Note: This option is not available if you are working in a table.

• Select Format > Other, and then select one of the options from the pop-up menu.

Note: Emphasis and Strong apply the same styles as Italic and Bold, respectively, but use different HTML tags. Your 

Contribute administrator determines which tag Contribute actually inserts.
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See also 

“Apply styles to text” on page 118

“Create and manage styles” on page 119

Change text color

1 In your draft, select the text you want to change.

2 Do one of the following:

• Click the Text Color button in the text formatting toolbar.

• Right-click (Windows) or Control-click (Mac OS), and then select Color.

Note: This option is not available if you are working in a table.

• Select Format > Text Color.

The color selector appears.

3 Select a color from the color selector.

The color selector closes and the text color changes in your draft.

Highlight text

1 In your draft, select the text you want to highlight.

2 Click the Highlight Color button in the text formatting toolbar, or select Format > Highlight Color.

The color selector appears.

3 Select a color from the color selector.

The color selector closes and the text is highlighted in your draft.

See also 

“Apply styles to text” on page 118

“Create and manage styles” on page 119

“Change text color” on page 117

Edit the font list 

Font combinations in the Contribute font list determine how a browser displays text in your web page. Each font you 

see in the Font menu represents the first font in that font combination. You can edit the font combinations in 

Contribute.
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A browser uses the first font in a font combination that is installed on the website visitor’s computer. If none of the 

fonts in the combination are installed, the browser displays the text as the visitor’s browser preferences specify.

1 In your draft, select Format > Font > Edit Font List.

The Edit Font List dialog box appears.

2 Select a font combination in the Font List section.

The fonts in the selected combination appear in the Chosen Fonts section. The Available Fonts section lists fonts 

that are installed on your computer.

3 Make changes as necessary.

You can add or remove a font combination, move a font combination up or down in the list, add or remove fonts 

from a font combination, or add a font that is not installed on your system.

For more information, see “Completing the Edit Font List dialog box” on page 128.

4 Click OK when you finish editing the font list.

See also 

“Change text font and size” on page 115

Apply styles to text

You can easily apply styles, such as a heading style, to format your text. The Style pop-up menu in Contribute lists 

HTML heading and paragraph styles, plus user-defined CSS styles.

Note: If the Style menu is not enabled, your Contribute administrator has restricted the website so that you cannot apply 

styles. 

For more information about the HTML and CSS styles in the Style menu, see “About HTML and CSS styles in the 

Contribute Style menu” on page 113. 

Apply styles to text

1 In your draft, select the text you want to change or place the insertion point in the paragraph you want to change.

2 Do one of the following:

• Select a style from the Style pop-up menu in the text formatting toolbar.



119USING CONTRIBUTE CS4

Working with text

• Select Format > Style, and then select a style from the pop-up menu.

The text you selected, or the entire paragraph where the insertion point is, changes to the new style.

Note: If you select a built-in heading style, the entire paragraph changes to that style, even if you selected specific 

text in the paragraph.

When you press Enter (Windows) or Return (Mac) after text that has a style applied, Contribute applies the 

same style to the next line, unless the previous text was a heading. When you press Enter or Return after a 

heading, the next line of text is in paragraph style. 

Clear the current text style

1 In your draft, select the text you want to change, or place the insertion point in the text.

2 Select Normal from the Styles pop-up menu in the text formatting toolbar.

Note: You can also select Format > Style > Remove Paragraph Breaks. This option clears the style and removes any 

paragraph tags around the selection.

See also 

“Change text font and size” on page 115

“Change text color” on page 117

Create and manage styles

As you format text in a page, Contribute keeps track of the styles and builds a library of styles that you can reuse in that 

page. 

Note: If your Contribute administrator has restricted style creation for your website, you can apply formatting properties 

to text, but Contribute does not save the style for you to reuse. For more information, talk to your Contribute 

administrator or see “Set style and font settings” on page 289.

You can manage your list of user-defined CSS styles by renaming them or deleting them as necessary. You cannot 

rename or delete HTML styles in the list.

For more information about HTML and CSS styles, see “About HTML and CSS styles in the Contribute Style menu” 

on page 113.

Create a text style

1 In your draft, place the insertion point in the paragraph, or select some of the text in the paragraph.

2 Apply the font, size, or color as desired.

Contribute keeps track of the formatting properties you assign and assigns a label to the new style, using the naming 

convention: Style1, Style2, Style3, Stylen. The label appears in the Style pop-up menu in the text formatting toolbar.

If you assign the same formatting attributes to two or more text elements, Contribute labels those elements with the 

same title, eliminating redundant style names. 

Rename a style

1 In your draft, select Format > Style > Rename Style or select Rename Style from the Style pop-up menu in the text 

formatting toolbar.

The Rename Style dialog box appears.
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2 Select the style you want to rename from the Style pop-up menu.

3 Enter a new name in the New Style Name text field.

4 Click OK.

Contribute renames the style and the new name appears in the Style pop-up menu in the text formatting toolbar.

Delete a style

1 In your draft, select Format > Style > Delete Style or select Delete Style from the Style pop-up menu in the text 

formatting toolbar.

The Delete Style dialog box appears.

2 Select the style you want to delete.

3 Click Delete.

Contribute deletes the style from the Style pop-up menu in the text formatting toolbar.

See also 

“Change text font and size” on page 115

“Apply styles to text” on page 118

“Change text color” on page 117

Position text on the page

To position text on your page, you can add paragraph spacing, align text, or change indentation. 

Note: For information about formatting text to change its appearance, see “Format text” on page 115.

Add paragraph spacing

Contribute works similarly to many word processing applications: you press Enter (Windows) or Return (Mac OS) to 

create a paragraph. Web browsers automatically insert a blank line of space between paragraphs. You can add a single 

line of space between paragraphs by inserting a line break.

Add a paragraph return

1 In your draft, place the insertion point at the end of a paragraph.

2 Press Enter (Windows) or Return (Mac OS). 

Add a line break

1 In your draft, place the insertion point where you want the line break to appear.

2 Do one of the following:

• Select Insert > Line Break.

• Press Shift+Enter (Windows) or Shift+Return (Mac OS).

See also 

“Indent text” on page 121
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Align text 

You can select one of four text alignment options: Left, Center, Right, and Justify.

1 In your draft, select text, or place the insertion point in the text.

Note: Contribute applies alignment to the entire paragraph, even if you select specific text in the paragraph.

2 Do one of the following:

• Click one of the alignment buttons in the text formatting toolbar.

• Select Format > Align, and then select an alignment from the pop-up menu.

The text alignment changes in your draft.

See also 

“Add paragraph spacing” on page 120

Indent text 

In Contribute, you can indent or outdent a paragraph. You can indent or outdent the same paragraph multiple times, 

further increasing or decreasing the space at the beginning of the text. Indenting and outdenting affects the right 

margin as well as the left. 

1 In your draft, select the text you want to change or place the insertion point in the text.

2 Do one of the following:

• Click the Indent or Outdent button in the text formatting toolbar.

• Select Format > Indent or Format > Outdent.

The text indention changes in your draft.

See also 

“Add paragraph spacing” on page 120

Create lists

You can create numbered lists, bulleted lists, and definition lists in Contribute. You can also create sublists in your lists.

Create numbered lists

You can use numbered lists for information organized as a sequence or progression. You can apply numbering as you 

create the list, or you can add numbering to an existing list.

1 Place the insertion point in your draft where you want to add the list.

2 Do one of the following:

• Click the Numbered List button in the text formatting toolbar.

• Select Format > List > Numbered List.

3 Type the first list item.

4 Press Enter (Windows) or Return (Mac OS) to type another item, and repeat for each item.
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5 When you finish typing the list, do one of the following to turn off numbering:

• Press Enter (Windows) or Return(Mac) twice.

• Press Enter (Windows) or Return (Mac), and then click the Numbered List button in the text formatting toolbar.

Create a numbered list from existing text

1 In your draft, select multiple lines of existing text.

2 Do one of the following:

• Click the Numbered List button in the text formatting toolbar.

• Select Format > List > Numbered List.

Contribute adds numbers to your list.

See also 

“Create definition lists” on page 123

“Create sublists” on page 123

“Set list properties” on page 125

Create bulleted lists

Use bulleted lists to organize information that is related but in no particular sequence. You can apply bullets as you 

create the list, or you can add bullets to an existing list.

1 Place the insertion point in your draft where you want to add the list.

2 Do one of the following:

• Click the Bulleted List button  in the text formatting toolbar.

• Select Format > List > Bulleted List.

3 Type the first list item.

4 Press Enter (Windows) or Return (Mac OS) to type another item, and then repeat for each item.

5 When you finish typing the list, do one of the following to turn off the bullets:

• Press Enter or Return twice.

• Press Enter or Return, and then click the Bulleted List button in the text formatting toolbar.

Create a bulleted list from existing text

1 In your draft, select multiple lines of existing text.

2 Do one of the following:

• Click the Bulleted List button in the text formatting toolbar.

• Select Format > List > Bulleted List.

Contribute adds bullets to your list.

See also 

“Create sublists” on page 123

“Set list properties” on page 125
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Create definition lists

A definition list is a series of items, each with an indented sub-item. 

1 Place the insertion point in your draft where you want to create the list.

2 Select Format > List > Definition List.

3 Type the first list item, and then press Enter (Windows) or Return (Mac OS).

4 Type the indented definition, and then press Enter or Return, and then repeat the previous step as necessary.

5 When you finish typing the list, do one of the following to turn off the indenting:

• Press Enter or Return twice. 

• Press Enter or Return, and then select Format > List > Definition List.

Create a definition list from existing text

1 In your draft, select multiple lines of existing text.

2 Select Format > List > Definition List.

See also 

“Create numbered lists” on page 121

“Set list properties” on page 125

Create sublists

You can change the level of a numbered or bulleted list item to create a nested list. For example, you might have a 

bulleted list where one of the bullets has a sublist of bullets.

The nested list does not have to be of the same type as the parent list. For instance, you can nest a bulleted list in a 

numbered list. You can have multiple nested lists in your list.



124USING CONTRIBUTE CS4

Working with text

A page demonstrating the use of sublists in a Contribute page

1 In your draft, place the insertion point at the end of the line in an existing list where you want to create the sublist.

2 Press Enter (Windows) or Return (Mac OS).

3 Do one of the following:

• Click the Indent button in the text formatting toolbar.

• Press Tab.

Note: This option is not available for template-based pages or in tables.

• Select Format > Indent.

Contribute indents the number or bullet of the new line. 

4 To have the sublist and parent list be different types, click the Numbered List or Bulleted List button in the text 

formatting toolbar, as appropriate.

5 Type the list item, and then press Enter or Return to add more items to the sublist.

6 When you finish typing the list, do one of the following to leave the sublist:

• Press Enter or Return twice.

• Press Enter or Return, then click the Outdent button in the text formatting toolbar.

Note: If you changed the sublist to be a different type than the parent list, click the Numbered List or Bulleted List 

button to switch back to the type of the parent list.

See also 

“Create numbered lists” on page 121

“Create bulleted lists” on page 122
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Set list properties

You can change the appearance of an entire list, or change the look of an individual list item in a bulleted or numbered list.

Set list properties for an entire list

1 In your draft, select an entire bulleted or numbered list. 

2 Do one of the following:

• Select Format > List > Properties.

• Right-click (Windows) or Control-click (Mac OS), and then select List > Properties.

Note: This option is not available for template-based pages or in tables.

The List Properties dialog box appears.

3 Make changes as necessary.

For more information, see “Completing the List Properties dialog box” on page 129.

4 Click OK.

Contribute applies your changes to the list. It also applies the new style automatically to any items you add to the list.

Set list properties for a list item

1 In your draft, place the insertion point in the bulleted or numbered list item you want to change.

Note: If you select multiple items, list properties are applied to the entire list.

2 Do one of the following:

• Select Format > List > Properties.

• Right-click (Windows) or Control-click (Mac OS), and then select List > Properties.

Note: This option is not available for template-based pages or in tables.

The List Properties dialog box appears.

3 In the Selected Item section, change options for the list as necessary.

For more information, see “Completing the List Properties dialog box” on page 129.

4 Click OK.
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Contribute applies your changes to the list item.

See also 

“Create numbered lists” on page 121

“Create bulleted lists” on page 122

“Create definition lists” on page 123

Check spelling

It’s a good idea to use the Check Spelling command to check the spelling in your draft after you add or edit text. 

Contribute checks for the spelling and corrects any error if the auto spell check is on. 

Check and correct spelling

1 In your draft, select Format > Check Spelling.

If Contribute encounters an unrecognized word, the Check Spelling dialog box appears.

2 Select the appropriate option based on how you want Contribute to handle the discrepancy.

For more information about the options, see “Completing the Check Spelling dialog box” on page 129.

3 After you finish checking spelling, click the Close button in the Check Spelling dialog box or click OK in the 

Spelling Check Completed message box.

Enable auto spell check

 Minimize spelling errors when typing using the inline spell checker in Contribute. Any spelling errors are flagged with 

a red squiggle below the incorrect word when you are in the Edit mode. Right-click the flagged word to display options 

suggested by the dictionary. After you choose the correct option, the flagged word is replaced with the selected word.

 When you change the dictionary, the background spell checker scans the entire document using the selected 

dictionary. Any errors flagged with the previous dictionary are removed. 

Note: Incorrect words are flagged only when the page is in the edit mode.

1 In your draft, select Edit > Preferences.

2 Select Editing from the panel on the left.

3 Select Enable Spell Checking In The Background.

Find and replace text 

You can search the draft you’re editing for specific text. You can also search for and replace text in drafts.

Search text

1 In your draft, select Edit > Find.

The Find And Replace dialog box appears.
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2 Type the text you want to find, and then click Find Next until you finish searching the draft.

For more information, see “Completing the Find and Replace dialog box” on page 130.

3 When you finish, click Close.

Search and replace text

1 In your draft, select Edit > Find.

The Find And Replace dialog box appears.

2 Type the text you want to find, and then type the replacement text.

3 Click Find Next.

4 For each instance, decide whether to replace the text, replace all instances of the text, or find the next instance 

without replacing the text.

For more information, see “Completing the Find and Replace dialog box” on page 130.

5 When you finish, click Close.

Reference

This section provides information about the dialog boxes introduced in this chapter.

Completing the Insert Date dialog box

Use the Insert Date dialog box to add the current date to your web page.

1 In the Day Format pop-up menu, select the format in which you want the day of the week to appear.

Select No Day if you do not want to include the day in the date.

2 In the Date Format pop-up menu, select the format in which you want the date to appear.

3 In the Time Format pop-up menu, select standard or military time.

Select No Time if you do not want to include the time with the date.

4 Select Update Automatically On Save to have Contribute update the date with the current date each time the draft 

is saved.

5 Click OK.

Contribute adds the current date to your draft.

Completing the Insert Other Character dialog box

Use the Insert Other Character dialog box to add special characters to your web page.

❖ Select the character you want to insert, and then click OK.
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Completing the Edit Font List dialog box

Use the Edit Font List dialog box to add or remove a font combination, move a font combination up or down in the 

list, add or remove fonts from a font combination, or add a font that is not installed on your system.

1 Select a font combination in the Font List section.

The fonts in the selected combination appear in the Chosen Fonts section. The Available Fonts section lists fonts 

that are installed on your computer.

2 Choose from the following options:

• To add or remove a font combination, click the Plus (+) and Minus (–) buttons above the Font List.

• To move a font combination up or down in the list, click the arrow buttons above the Font List.

• To add or remove fonts from a font combination, click the arrows button (<< or >>) between the Chosen Fonts 

and the Available Fonts.

• To add a font that is not installed on your system, type the font name in the text box below Available Fonts, then 

click the Add arrows button (<<) to add it to the combination.

Adding a font that is not installed on your computer is useful, for example, for specifying a Windows-only font 

when you are developing pages in Mac OS.

3 Click OK when you finish editing the font list.

See also 

“Edit the font list” on page 117

Completing the Rename Style dialog box

Use the Rename Styles dialog box to rename a user-defined CSS style that appears in the list in your Style menu.

1 Select the style you want to rename from the Style pop-up menu.

You only see user-defined CSS styles in the list; you cannot rename HTML style or CSS styles that your Contribute 

administrator provides.

2 Enter a new name in the New Style Name text field.

The name must start with an alphanumeric character and cannot contain any spaces or special characters. 

3 Click OK.

Contribute renames the style, and the new name appears in the Style pop-up menu in the text formatting toolbar.

See also 

“Create and manage styles” on page 119

Completing the Delete Style dialog box

Use the Delete Styles dialog box to remove a user-defined CSS style from the list in your Style menu.

1 Select the style you want to delete from the Style pop-up menu.

You see only user-defined CSS styles in the list; you cannot delete HTML styles or CSS styles that your Contribute 

administrator provides. 

2 Click Delete.
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Contribute deletes the style from the Style pop-up menu in the text formatting toolbar.

See also 

“Create and manage styles” on page 119

Completing the List Properties dialog box

Use the List Properties dialog box to change the appearance of an entire list, or to change the look of an individual list 

item in a bulleted or numbered list.

1 In the List properties section, change options for the entire list: 

• List type specifies whether the list is a bulleted, numbered, directory, or menu list. 

Depending on the list type you select, different options are enabled or disabled in the dialog box.

• Style determines the style of numbers or bullets used for a numbered or bulleted list.

Contribute applies this style to all items unless you specify a new style for individual items in the list.

• Start at number sets the value for the first item in a numbered list.

2 In the Selected item section, change options for the selected item: 

• Style specifies a style for the selected list item. Options in the pop-up menu are specific to the list type, either 

bulleted or numbered.

• Reset to number sets a specific number from which to number list item entries.

3 Click OK.

Contribute applies your changes to the list. It also applies the new style automatically to any items you add to the list.

See also 

“Set list properties” on page 125

Completing the Check Spelling dialog box

Use the Check Spelling dialog box to select the appropriate action for reconciling a discrepancy when Contribute 

encounters an unrecognized word in a spelling check.

1 Select the appropriate option based on how you want Contribute to handle the discrepancy:

• Click Add to add the unrecognized word to your personal dictionary. You can add any word and Contribute 

ignores it in the future.

• Click Ignore to ignore this instance of the unrecognized word.

• Click Change to replace this instance of the unrecognized word with text that you type in the Change to text box 

or with the selection in the Suggestions list.

• Click Ignore All to ignore all instances of the unrecognized word.

• Click Change All to replace all instances of the unrecognized word in the same manner.

2 When you finish checking spelling, click the Close button in the Check Spelling dialog box, or click OK in the 

Spelling Check Completed message box.

See also 

“Check spelling” on page 126
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Completing the Find and Replace dialog box

Use the Find and Replace dialog box to search your draft for specific text and to search for and replace text in drafts.

Search for text

1 In the Search for text box, type the text you want to find.

2 Select Match case to limit the search to text that exactly matches the case of the text you type in the Search for text box.

For example, if you type the brown derby in the text box, you will not find The Brown Derby.

3 Click Find Next, then repeat until you finish searching the draft.

Search and replace text

1 In the Search for text box, type the text you want to find.

2 In the Replace with text box, type the replacement text.

3 Select Match case to limit the search to text that exactly matches the case of the text you type in the Search for text box.

For example, if you type the brown derby in the text box, you will not find The Brown Derby.

4 Click Find Next.

5 For each occurrence, select one of the following:

• Replace replaces the current instance with the replacement text.

• Replace All replaces all instances with the replacement text.

• Find Next finds the next instance without changing the current instance.

See also 

“Find and replace text” on page 126
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Chapter 7: Working with images and 
graphic elements

Adobe® Contribute® makes it easy for you to edit, add, or delete images on your web pages. 

You can add the following to your page using Adobe Contribute:

• Movies

• Enclosures (audio and video files) to your blog

• PayPal buttons for completing e-commerce transactions through your web page

• Insert rich media images, SWF files, and videos directly from the Internet into Contribute pages

Contribute supports the following file formats: 

Image files .gif, .jfif, .jpe, .jpeg, .jpg, and .png

SWF files .swf

Video files .avi, .flv, .mp4, .mpeg, .mpg, .mov, .qt, and .wmv

For information about making an image a hypertext link (also known as a link), see “Create text and image links” 

on page 177.

About inserting images and buttons

There are special considerations when you insert images and PayPal buttons on a web page.

About images

You can add images from several sources, including your computer, local network, website, e-mail, Microsoft Internet 

Explorer web browser, or another application, such as Microsoft Word or Excel.

Note: Images that you add to your page should be in one of the following web-ready formats: .gif, .jfif, .jpe, .jpeg, .jpg, or 

.png (16). If the image you want to add is in another format, you can use an image-editing tool, such as Adobe Fireworks, 

to convert the image to a web-ready format.

When you add an image to a page, it’s a good idea to add descriptive text about the image so that the image is accessible 

to users with disabilities. Your Contribute administrator can enforce the image-accessibility option so that a dialog box 

prompts you for a description whenever you add an image. 

Note: For more information, talk to your Contribute administrator or see “Set page-editing and paragraph settings” on 

page 288.

See also 

“Add an image to a page” on page 132
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About PayPal buttons 

PayPal buttons, created by WebAssist.com, make it easy for you to add e-commerce functionality to a Contribute page. 

After you create a payment button, you can instantly accept credit card payments from your customers. PayPal 

provides a secure, hosted check-out service to process and record all your transactions. If you don’t have a PayPal 

account, you can open one for free in a few minutes. There are no setup or monthly fees and PayPal charges you only 

when a customer payment occurs. 

Note: Your Contribute administrator must enable the PayPal feature for your role before you can use it. For more 

information, talk to your Contribute administrator or see “Set page-editing and paragraph settings” on page 288.

You can add five kinds of PayPal buttons to a web page:

Buy Now button Defines an item offered for immediate purchase and includes a product name, price, item number, 

and other shipping and handling costs.

Add to Cart button Defines an item that a customer can use to add the item to a shopping cart for purchase.

View Cart button Is used with the Add to Cart button and lets customers view the items in their shopping cart and 

check out whenever they want to complete their purchases.

Subscription button Defines a service that the customer can pay for on a recurring basis and also provides an option 

to setup a free trial period. You can define the amount, the subscription period, and how many times to repeat billing.

Donation button Lets you collect donations from a button on your website, or even using a link in an e-mail.

All payment button wizards let you price items in multiple currencies, such as Canadian dollars, British pounds 

sterling, euros, or Japanese yen. They also provide options that let you display your business name and logo on the 

checkout page. Finally, you can specify a web address (URL) for a web page you want shown when a customer 

completes a purchase, such as a “Thank you for your order” page.

You insert the PayPal button and its associated functionality in a page by completing the screens of the PayPal wizard. 

Through the wizard, you select button images to insert in the page and define multiple options (such as an item 

number, price, and so on) for each item you are selling. If you need help completing the screens in the PayPal wizard, 

click the Help button to view additional online help.

You can insert multiple PayPal buttons in the same page. Just be sure not to insert more than one button in the same 

paragraph or table cell. 

If your page contains other HTML forms, make sure you do not insert a PayPal button in an existing HTML form. If 

you use JavaScript code to reference a form in your page, verify that the JavaScript functionality is still working after 

you add the PayPal button(s) to your page.

See also 

“Insert PayPal e-commerce buttons” on page 149

Add an image to a page 

You can use three ways to add an image to your web page:

• Use the Insert menu or the Image button to add an image from your computer or website.

• Drag an image from another source to your Contribute draft.

• Copy and paste an image from another source on your Contribute draft.
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Note: If your Contribute administrator has restricted the types of images your user role can insert, you might be able to 

insert images only from shared assets.

See also 

“About inserting images and buttons” on page 131

“Insert shared assets into a web page” on page 135

“Change image properties” on page 136

“Edit an image in Contribute” on page 138

Use the Insert menu or Image button to add images to a page

You can use the Insert menu or Image button in the toolbar to add an image from your computer or website to a page. 

You can add images from other sources by dragging them to the page (see “Drag images to a page” on page 134) or by 

copying and pasting them on the page (see “Copy and paste images” on page 134).

1 Place the insertion point in your draft where you want the image to appear.

2 Do one of the following:

• Click the Image button in the toolbar. 

• Select Insert > Image.

3 Select one of the following options from the pop-up menu: 

• From My Computer 

• From Website 

• From Internet

• From Shared Assets

Note: If your Contribute administrator has restricted the types of images your user role can insert, you might be able 

to insert images only from shared assets.

The Select Image, Choose Image on Website, Browse for Image, or Insert Shared Asset dialog box appears.

If you have already inserted an image in a page in a Contribute website and you want to reuse the image, select 

From Website.

4 Browse to and select the image, and then click the Select button.

Note: You must select a specific file. You cannot select a folder to insert in a Contribute page.

5 If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users 

whose browsers are set to display text only, and then click OK.

The image appears in your draft. To make the image web-ready, Contribute reduces large images to the size pre-set 

by the Contribute administrator, if the administrator has enabled image processing for your role.

Note: If the image you are inserting is from your computer, you can edit the image inline (if your user role has 

permission to edit inline), but you can’t edit the image in an external application until you publish the draft. For more 

information about editing, see “Edit an image in Contribute” on page 138.

After you insert the image, double-click the image to change the image properties. For more information, see 

“Change image properties” on page 136. 
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Drag images to a page

You can drag an image from another source to your Contribute page.

Note: If your Contribute administrator has restricted the types of images your user role can insert, you might be able to 

insert images only from shared assets.

You can also add images by using the Insert menu or Image button (see “Use the Insert menu or Image button to add 

images to a page” on page 133) or by copying and pasting them on the page (see “Copy and paste images” on page 134).

1 Reduce the size of the Contribute application window so you can also see the application that contains the image 

you plan to drag.

2 In the other application, select the image.

3 Drag the image to your Contribute draft where you want the image to appear.

You can’t drag an image from a web browser if the image has a link attached to it. Save the image to your computer 

first, and then drag the image to your Contribute draft, or copy and paste the image.

4 If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users 

whose their browsers set to display text only, and then click OK.

The image appears in your draft. To make the image web-ready, Contribute reduces large images to the size pre-set 

by the Contribute administrator, if the administrator has enabled image processing for your role.

Note: If the image you are inserting is from your computer, you can edit the image inline, but you can’t edit the image 

in an external application until you publish the draft. For more information about editing, see “Edit an image in 

Contribute” on page 138.

After you insert the image, double-click the image to change the image properties. For more information, see 

“Change image properties” on page 136. 

Copy and paste images

You can copy an image from another source, and paste it on your Contribute page.

Note: If your Contribute administrator has restricted the types of images your user role can insert, you might be able to 

insert images only from shared assets.

You can also add images by using the Insert menu or Image button (see “Use the Insert menu or Image button to add 

images to a page” on page 133) or by dragging them to the page (see “Drag images to a page” on page 134).

1 In the application that contains the image you want to copy, select the image.

2 Select Edit > Copy.

3 Place the insertion point in your Contribute draft where you want the image to appear.

4 Select Edit > Paste.

5 If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users 

whose browsers are set to display text only, and then click OK.

The image appears in your draft. To make the image web-ready, Contribute reduces large images to the size pre-set 

by the Contribute administrator, if the administrator has enabled image processing for your role.

Note: If the image you are inserting is from your computer, you can edit the image inline, but you can’t edit the image 

in an external application until you publish the draft. For more information about editing, see “Edit an image in 

Contribute” on page 138.
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After you insert the image, double-click the image to change the image properties. For more information, see 

“Change image properties” on page 136. 

Insert shared assets into a web page

Contribute lets you insert images, SWF content, or Dreamweaver library items from a list of shared assets for your 

website. 

Your Contribute administrator adds assets to the list so that they are available to most or all users. Then you can insert 

assets from the list as you need them. 

For example, suppose you need to add the official company logo to your draft. As long as your Contribute 

administrator has added the logo to the list of shared assets for your role, you can easily find the approved logo and 

add it to your page. For more information, see “Set options for shared assets” on page 294.

1 Place the insertion point in your draft where you want the shared asset to appear.

2 Do one of the following, depending on the type of shared asset you are inserting:

• For all shared assets, including Dreamweaver library items, select Insert > Shared Asset.

• For images only, select Insert > Image > From Shared Assets or click the Image button in the toolbar, and then 

select From Shared Assets.

• For SWF content only, select Insert > SWF > From Shared Assets.

Note: If library items and SWF content are not available, your Contribute administrator might have indicated that 

users in your role can insert images only from shared assets. 

The Insert Shared Asset dialog box appears.

3 Select a shared asset in the left pane.

A preview appears in the right pane. 
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4 Click OK. 

5 If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users 

whose browsers are set to display text only, and then click OK.

The shared asset appears on your draft.

See also 

“Add an image to a page” on page 132

“Insert SWF content into your web page” on page 142

Change image properties

After you add an image to a page (see “Add an image to a page” on page 132), you can change its viewable properties. 

Image properties include location of image source, display area size, padding, alignment, border, and alternate text. 

Modifying image properties only affects the way the image appears on the page. To edit the image, see “Edit an image 

in Contribute” on page 138.

1 In your draft, do one of the following:

• Double-click the image.

• Select the image, and then click the Image Properties button  in the image editing toolbar.

• Select the image, and then select Format > Image Properties.

• Right-click (Windows) or Control-click (Mac OS) the image, and then select Image Properties.

The Image Properties dialog box appears.

2 Make changes as desired.

For information about specific image properties, see “Completing the Image Properties dialog box” on page 151.

3 Click OK.

Contribute applies your changes to the image.
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See also 

“Add an image to a page” on page 132

“Resize an image” on page 140

Change an image’s position or orientation

You can move an image on a page, you can change its alignment in relation to surrounding elements, and you can 

rotate an image to change its orientation on the page.

Move an image

You can easily move an image to a new location on a web page. 

❖ Do one of the following:

• Drag the image to a new location.

• Select the image, and then copy (or cut) and paste the image in a new location.

See also 

“Change image properties” on page 136

“Edit an image in Contribute” on page 138

“Rotate an image” on page 141

Align an image

You can change image alignment two ways: you can change the alignment of an image on the page (for example, where 

an image is in a table cell) or you can change how the image aligns with surrounding elements.

1 In your draft, select the image you want to realign. 

2 Click an alignment option in the image editing toolbar.

Contribute aligns the image in the draft.

Align image in relation to surrounding elements

1 In your draft, select the image you want to realign.

2 Do one of the following:

• Double-click the image, and then select an option from the Alignment pop-up menu in the Image Properties 

dialog box.

• Right-click (Windows) or Control-click (Mac OS) the image, and then select an option from the Align pop-up menu.

Contribute aligns the image in relation to surrounding elements, such as text.

See also 

“Change image properties” on page 136

“Align an image” on page 137

“Rotate an image” on page 141
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Edit an image in Contribute

In Contribute, you can edit an image’s brightness and contrast, sharpening, cropping, and dimensions. 

To make more advanced edits, you can edit images in an external image-editing application. For more information, 

see “Edit an image in an external application” on page 141.

Note: When you edit an image in Contribute, Contribute creates a copy of the image you are editing, so edits affect only 

this instance of the image. When you use Contribute to edit an image in an external application, you edit the original 

image source file, so these edits affect all instances of that image on your website.

Adjust the brightness and contrast of an image

You can adjust the contrast or brightness of an image. This affects the highlights, shadows, and midtones of an image. 

You typically adjust brightness and contrast to correct images that are too dark or too light.

Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.

1 In your draft, select the image you want to adjust. 

2 Do one of the following:

• Click the Brightness/Contrast button  in the image editing toolbar.

• Select Format > Edit Image > Adjust Brightness and Contrast.

• Right-click (Windows) or Control-click (Mac OS) the image, and then select Edit Image > Adjust Brightness 

and Contrast.

Note: These options are not available if you belong to a user role that the Contribute administrator has restricted from 

inline image editing. For more information, talk to your Contribute administrator or see “Set page-editing and 

paragraph settings” on page 288.

The Brightness/Contrast dialog box appears.

3 Drag the Brightness and Contrast sliders to adjust the settings.

Values range from -100 to 100. 

4 Click OK.

See also 

“Add an image to a page” on page 132

“Sharpen an image” on page 138

“Crop an image” on page 139

“Resize an image” on page 140

“Rotate an image” on page 141

Sharpen an image

Sharpening increases the contrast around the edges of objects to increase the image’s definition. 

Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.

1 In your draft, select the image you want to adjust. 
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2 Do one of the following:

• Click the Sharpen button  in the image editing toolbar.

• Select Format > Edit Image > Sharpen.

• Right-click (Windows) or Control-click (Mac OS) the image, and then select Edit Image > Sharpen.

Note: These options are not available if you belong to a user role that the Contribute administrator has restricted from 

inline image editing. For more information, talk to your Contribute administrator or see “Set page-editing and 

paragraph settings” on page 288.

The Sharpen dialog box appears.

3 Specify the degree of sharpening by dragging the slider control, or entering a value between 0 and 10 in the text box.

As you adjust the sharpness of the image, you can preview the change to the image.

4 Click OK.

Undo sharpening and revert to the original image

• Select Edit > Undo Sharpen More (Windows).

• Select Edit > Undo (Mac).

You can only undo the effect of the Sharpen command (and revert to the original image file) before publishing the 

page containing the image. 

See also 

“Add an image to a page” on page 132

“Adjust the brightness and contrast of an image” on page 138

“Crop an image” on page 139

“Resize an image” on page 140

“Rotate an image” on page 141

Crop an image

You can crop (or trim) images. 

Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.

1 In your draft, select the image you want to crop. 

2 Do one of the following:

• Click the Crop Tool icon  in the image editing toolbar.

• Select Format > Edit Image > Crop.

• Right-click (Windows) or Control-click (Mac OS) the image, and then select Edit Image > Crop.

Note: These options are not available if you belong to a user role that the Contribute administrator has restricted from 

inline image editing. For more information, talk to your Contribute administrator or see “Set page-editing and 

paragraph settings” on page 288.

Crop handles appear.

3 Adjust the crop handles to surround the part of the image you want to keep.
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4 Do one of the following to finish the crop:

• Double-click inside the bounding box.

• Press Enter or Return.

• Right-click (Windows) or Control-click (Mac OS) the image, and then select Edit Image > Finish Crop.

The shaded part of the image disappears from the image. 

Undo the effects of the Crop command 

1 Select Edit > Undo Crop(Windows.)

2 Select Edit > Undo (Mac.)

You can undo the effect of the Crop command (and revert to the original image file) until you quit Contribute.

See also 

“Add an image to a page” on page 132

“Adjust the brightness and contrast of an image” on page 138

“Sharpen an image” on page 138

“Rotate an image” on page 141

Resize an image

You can change the size of an image visually or by entering specific values. 

Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.

Resize an image with specific values

1 In your draft, select the image you want to resize. 

2 Enter Width and Height values in the image editing toolbar.

Contribute changes the height and width of the image.

Note: Resizing this way affects the image size and its display area on the page. To change only the display area, see 

“Change image properties” on page 136.

Revert an image to its original size

In your draft, select Format > Edit Image > Revert to Original Size. 

See also 

“Add an image to a page” on page 132

“Adjust the brightness and contrast of an image” on page 138

“Sharpen an image” on page 138

“Crop an image” on page 139
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Rotate an image

You can rotate an image to change its orientation on the page.

1 In your draft, select the image you want to rotate. 

2 Do one of the following:

• Click one of the rotate buttons  in the image editing toolbar.

You can click the rotate button multiple times to further rotate the image.  

• Select Format > Edit Image > Rotate Clockwise or Edit Image > Rotate Counter-Clockwise.

• Right-click (Windows) or Control-click (Mac OS) the image, and then select Edit Image > Rotate Clockwise or 

Edit Image > Rotate Counter-Clockwise.

See also 

“Edit an image in Contribute” on page 138

“Change an image’s position or orientation” on page 137

Edit an image in an external application

You can use Contribute to start an external image-editing application. You can make simple edits directly in 

Contribute, using the image editing toolbar (see “Edit an image in Contribute” on page 138).

Note: When you edit an image in Contribute, Contribute creates a copy of the image you are editing, so edits affect only 

this instance of the image. When you use Contribute to edit an image in an external application, you edit the original 

image source file, so these edits affect all instances of that image on your website.

1 Do one of the following:

• In the Contribute browser, click Choose in the toolbar, select the image you want to edit, and then click OK. 

When the image opens, click Edit in the toolbar.

• In the Contribute editor, select an image, and then select Format > Edit Image in External Application or right-

click (Windows) or Control-click (Mac OS) the image, and then select Edit Image in External Application.

Note: The image you select should be on a published page on your website or in one of your website folders. If you add 

a new image to a draft, you cannot edit that image in an external editor until it has been published to the website.

Contribute starts an application for you to edit the image. 

To change your default external image editor, see “Setting file editor preferences” on page 40. 

2 If you are editing an image in Fireworks, click No in the Find Source dialog box to indicate that you do not want to 

edit the source file for this image. 

By clicking No, you edit the image for the website only.

3 In the external application, make changes as necessary, and then save your changes and close the application.

Important: Editing an image in an external application permanently changes the original image saved on the server 

and affects other occurrences of this image throughout your website.

4 If you are editing in Fireworks, click Done in the editing window, and then close the application.
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To make additional changes to the image before you publish, click Launch in Contribute to open the content in the 

external editor again.

5 In Contribute, click Publish to publish your changes to the website.

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.

The updated image appears in Contribute.

See also 

“Add an image to a page” on page 132

“Change image properties” on page 136

“Edit an image in Contribute” on page 138

Insert SWF content into your web page

Many websites contain SWF assets such as navigation buttons or a banner. You can insert SWF content from your 

computer, from your website, from the Internet, or from your Shared Assets list. 

When you publish a page that contains SWF content, Contribute automatically copies the file (.swf) to your website. 

Note: For information about inserting movie types other than SWF, see “Insert a video in your web page” on page 143.

1 Place the insertion point in your draft where you want the SWF content to appear.

2 Select one of the following options: 

• Insert > SWF > From My Computer

• Insert > SWF > From Website

• Insert > SWF > From Internet

• Insert > SWF > From Shared Assets

The Open, Choose SWF File From Website, Browse For SWF, or Insert Shared Asset dialog box appears.

3 Navigate to and select the SWF file you want to insert, and then click Open or OK. 

Note: You cannot select a folder to insert in a Contribute page.

The SWF movie object appears in your draft.

Reuse a SWF movie (SWF file)

Select Insert > SWF > From Website.

Set SWF movie properties

You can set properties for SWF movies (SWF files) that you insert into your web pages. 

1 In your draft, select the SWF movie object. 

2 Select Format > FLV Properties.

The SWF Movie Properties dialog box appears.

3 Make changes as necessary.
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For more information, see “Completing the SWF Movie Properties dialog box” on page 152.

4 Click OK.

See also 

“Insert SWF content into your web page” on page 142

Insert a video in your web page

You can insert videos onto a web page and control them in Contribute.

Note: If you are inserting a SWF file, the process is slightly different; for more information, see “Insert SWF content into 

your web page” on page 142.

You can insert videos that are saved on your computer, videos available on the Internet, or videos on your website. You 

can also insert a video of certain file types from a still camera, video camera, or a video editor such as Movie Maker or 

iMovie into your web page. Some file types that you can use include QuickTime (MOV and QT), video files (MP4, 

MPG, or MPEG), AVI, and Windows Media (WMV). 

When you edit and save videos for your website, save the videos for the web, so that they are compressed.  

1 Place the insertion point where you want the video to appear in your draft.

2 Select one of the following options: 

• Insert > Video > From My Computer

• Insert > Video > From Website

• Insert > Video > From Internet

The Select Video, Browse For Video, or Choose Video On Website dialog box appears.

Note: You can also drag the video from another application. To do this, reduce the size of the Contribute application 

window so that you can also see the application that contains the video you plan to drag. In the other application, 

select the video and drag the video to your Contribute draft where you want the video to appear.

3 Navigate to and select the video file to insert, and then click Open, or OK.

Note: If you insert MOV file types in Contribute, your website visitors must have the QuickTime player installed to 

view the video on a Windows computer. If you insert WMV file types, your website visitors must have the Windows 

Media Player installed to view the video in Mac OS.

A video placeholder appears in your draft. 

Note: You may not be able to insert a video that exceeds the size restrictions that your Contribute administrator 

specifies for your user role. For more information, talk to your Contribute administrator or see “Specify setting options 

for file placement” on page 293.

The video does not play in the draft; you must publish your draft to play the video.

The default video display in Contribute for all video files (except for an FLV file) is 320 x 240. For an FLV file, 

Contribute detects the display size of the FLV file and displays it in the same size as the FLV file. If Contribute 

cannot detect the size of your FLV file, the video display is 320 x 240.
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Set video properties

You can set properties for videos you insert into your web pages.

Note: To edit properties for a SWF file, see “Set SWF movie properties” on page 142.

1 Select the video placeholder in your draft.

2 Double-click the video placeholder, or select Format > Video Properties.

Right-click (Windows) or Control-click (Mac OS) the video placeholder and select Video Properties.  

Depending on the file you insert, a Video Properties dialog box appears.

The following Video Properties dialog box appears if you are inserting any video file. The dialog box for FLV files 

has more options.

3 Make changes as necessary.

If you inserted a file other than FLV, for more information, see “Completing the Video Properties dialog box” on 

page 153.

If you inserted an FLV file, for more information, see “Completing the Video Properties dialog box (For FLV files)” 

on page 153.

4 Click OK.

Check your video file properties for the size of your movie. Then, double-click the video placeholder in Contribute 

to set the display size to the size of your video, so that your web page displays the video properly.

See also 

“Insert a video in your web page” on page 143

Change a video’s position or orientation

You can move a video on a page and you can change its alignment in relation to surrounding elements.

Move a video

You can easily move a video to a new location on a web page. 

• Drag the video to a new location.
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• Select the video, and then copy (or cut) and paste the video in a new location.

See also 

“Insert a video in your web page” on page 143

Align a video

You can change video alignment in relation to surrounding elements.

Change alignment of a video in relation to surrounding elements

1 In your draft, select the video to realign.

2 Do one of the following:

• Select Format > Align and then select an alignment option.

• Right-click (Windows) or Control-click (Mac OS) the video, and then select an option from the Align pop-up menu.

See also 

“Move a video” on page 144

“Insert a video in your web page” on page 143

Add audio and video files to your blog

Audio and video files that you add to your blog entry are called enclosures. For example, you can add a podcast to a 

blog entry, and then publish it to your blog. After you publish a blog that has an enclosure, the enclosure appears as a 

link in the page.

Note: You can add only one enclosure to a new or existing blog entry draft. You can still add one enclosure when you edit 

an existing blog entry that has multiple enclosures.

When you add an enclosure to a draft, the bottom of the Contribute status bar changes to show the enclosure details. 

You can click the arrow in the status bar to minimize or expand this status bar, or delete the enclosure. 

You can add audio and video files from the following locations to your blog entry draft:

• Your computer

• Your websites (to which you are connected)

• The Internet

Add audio or video files from your computer

You can add audio and video files located on your hard disk on your computer.

1 Do one of the following:

• Select Insert > Enclosure > From My Computer.

• Click on the Enclosures button in the toolbar and select From My Computer from the pop-up menu.

The Select Enclosure dialog box appears.

2 Navigate to and select the audio or video file to insert, and then click Open.
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The audio or video file now appears in the Enclosure workspace in the draft. The file does not play in the draft; you 

must publish your draft to play the file.

Add audio or video files from your website

You can add audio and video files from websites (to which you are connected) in Contribute.

1 Do one of the following:

• Select Insert > Enclosure > From Website.

• Click on the Enclosures button in the toolbar and select From Website from the pop-up menu.

The Choose Enclosure On Website dialog box appears.

2 Navigate to and select the audio or video file to insert.

For information about the options in this dialog box, see “Completing the Choose Enclosure on Website dialog 

box” on page 154.

3 Click Open.

The audio or video file now appears in the Enclosure workspace in the draft. The file does not play in the draft; you 

must publish your draft to play the file.

Add audio or video files from the Internet 

You can add audio and video files as enclosures from the Internet. 

Before adding enclosures, you can set the default media player to Windows Media Player (Windows only) or 

QuickTime (Windows or Mac OS).

When your default media player is Windows Media Player, you must play the audio and video files in Windows Media 

Player, and then add the files as enclosures in your blog entry draft.

Note: You cannot insert audio or video files as enclosures without playing them first in Windows Media Player.

Add audio or video files from the Internet (Windows Media Player in Windows)

1 In your draft, do one of the following:

• Select Insert > Enclosure > From the Internet.

• Click on the Enclosures button in the toolbar and select From the Internet from the pop-up menu.

The Browse for Enclosure dialog box appears.

2 Navigate to the web page that contains the link to the desired audio or video file.

3 Right-click on the hyperlink of the audio or video file and select Copy Shortcut. 

This copies the path of the audio or video file to the clipboard.

4 Paste this path in the address bar in the Browse for Enclosure dialog box and click Go.

The audio or video file opens in Windows Media Player in a separate window and begins to play. 

5 Close the Windows Media Player application window.

Note: You do not have to play the file completely to close the player window.

6 Go back to the Browse for Enclosure dialog box, which is currently open in Contribute, and click OK.
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The audio or video file is inserted as an enclosure and now appears in the Enclosure workspace in the draft. The file 

does not play in the draft; you must publish your draft to play the file.

Add audio or video files from the Internet (QuickTime)

You can add enclosures from the Internet if your default media player is set to QuickTime in Windows, or in Mac OS. 

The default media player for Mac OS is QuickTime. In Windows, you might have to set QuickTime as the default 

media player to use it to add enclosures.

1 In your draft, do one of the following:

• Select Insert > Enclosure > From the Internet.

• Click on the Enclosures button in the toolbar and select From the Internet from the pop-up menu.

The Browse for Enclosure dialog box appears.

2 Browse to the web page and then to the hyperlink of the audio or video file to insert.

3 Click the hyperlink of the audio or video file. 

The audio or video file opens and plays in QuickTime player in the Browse for Enclosure dialog box.

4 Click OK.

The audio or video file is inserted as an enclosure and now appears in the Enclosure workspace in the draft. The file 

does not play in the draft; you must publish your draft to play the file.

Delete audio and video files

You can delete an enclosure that is present in the draft you are currently editing.

Delete inserted audio and video files

❖ Click the Delete icon  in the Enclosure workspace.

Note: Deleting an enclosure from a blog entry does not delete the enclosure file; it only removes the link to the enclosure 

file from the blog entry. To delete files permanently from the blog, verify how you can delete files with your blog 

publishing service. 
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Add or delete a horizontal rule

You can add horizontal rules to your pages to help organize content. For example, you can use rules to group text and 

other elements into topic areas.

Insert a horizontal rule

1 Place the insertion point in your draft where you want the horizontal rule to appear.

2 Select Insert > Horizontal Rule.

Contribute inserts the horizontal rule. Content before the insertion point appears above the line, and content after 

the insertion point appears below the line.

Delete a horizontal rule

1 In your draft, click the horizontal rule to select it.

2 Press Delete.

Change the properties of a horizontal rule

You can customize the height, width, and shading applied to a horizontal rule on a page. By default, a horizontal rule 

in Contribute is 3 pixels high, expands to the width of the page or table cell in which it is inserted, and has a small drop 

shadow (or shading) applied. 

For information about adding or deleting horizontal rules, see “Add or delete a horizontal rule” on page 148.

1 In your draft, click the horizontal rule to select it, and do one of the following:

• Select Format > Horizontal Rule Properties.
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• Right-click (Windows) or Control-click (Mac OS) the horizontal rule, and then select Properties.

The Horizontal Rule Properties dialog box appears.

2 Change options as necessary.

For information about the options, see “Completing the Horizontal Rule Properties dialog box” on page 155.

3 Click OK.

Contribute changes the horizontal rule properties.

See also 

“Add or delete a horizontal rule” on page 148

Insert PayPal e-commerce buttons 

PayPal is a payment processing service that lets you sell your products and services online and accept credit card 

payments from your customers. You can add instant e-commerce functionality by creating payment buttons on your 

web pages.

Note: Your Contribute administrator must enable the PayPal feature for your role before you can use it. For more 

information, talk to your Contribute administrator or see “Set page-editing and paragraph settings” on page 288.

See also 

“About PayPal buttons” on page 132

Insert a single PayPal button

You can easily insert a PayPal button into your page. 

1 Place the insertion point in your draft where you want the button to appear.

Note: Make sure the insertion point does not overlap another PayPal button. 

2 Select Insert > PayPal, and then select the type of button you want to insert.

Note: If you cannot select a button, your Contribute administrator hasn’t enabled the PayPal feature for your role. 

For more information, talk to your Contribute administrator or see “Set page-editing and paragraph settings” on 

page 288.

The PayPal object wizard opens.

3 In the wizard, complete the screens to set the options you want to apply.
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Click Next to move through the screens in the wizard. 

4 On the Summary page, click Finish.

The PayPal button appears in your draft.

See also 

“About PayPal buttons” on page 132

“Edit a PayPal button” on page 150

Insert multiple PayPal buttons

You can insert multiple PayPal buttons in the same page. For example, you might insert an Add to Cart button and a 

View Cart button in the same page. However, you cannot insert more than one PayPal button in a paragraph or table 

cell. If you attempt to do so, an error message appears.

Note: Your Contribute administrator must enable the PayPal feature for your role before you can use it. For more 

information, talk to your Contribute administrator or see “Set page-editing and paragraph settings” on page 288.

Add a button in a paragraph that already contains a button

1 In your draft, place the insertion point in the paragraph, and then press Enter (Windows) or Return (Mac OS).

2 Insert a PayPal button.

Add a button to a table cell that already contains a button

1 In your draft, place the insertion point in the cell, and then select Table > Split Cell.

2 Insert a PayPal button.

See also 

“About PayPal buttons” on page 132

“Insert a single PayPal button” on page 149

Edit a PayPal button

You can edit the setting you originally set for a PayPal button. For example, you might want to raise or reduce the price 

of an item, update the item name or description, select a different button image, and so on. 

1 In the draft, click to select the PayPal button you want to edit.

2 Select Format > PayPal Button Properties.

The highlighted button type for the selected button is the only item enabled in the pop-up menu.

3 Click a tab in the Advanced options screen to select the type of information you want to update, and then make 

your changes. 

4 Click OK to save your changes.
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See also 

“About PayPal buttons” on page 132

“Insert a single PayPal button” on page 149

“Insert multiple PayPal buttons” on page 150

Reference

This section provides information about the dialog boxes introduced in this chapter.

Completing the Image Description dialog box

Use the Image Description dialog box to describe the image for users with disabilities or for users whose browsers are 

set to display only text.

1 Enter text to describe the image.

2 Click OK.

Completing the Insert Shared Asset dialog box

Use the Insert Shared Asset dialog box to insert shared assets in a draft.

1 Select a shared asset in the left pane.

A preview appears in the right pane.

2 Click OK. 

The shared asset appears in your draft.

See also 

“Insert shared assets into a web page” on page 135

Completing the Image Properties dialog box

Use the Image Properties dialog box to change image properties.

❖ Make changes as necessary to the following options, and then click OK:

Image file The location of the image source file. Click the Choose button, and then select Images on My Computer 

or Images on Website, to change the image source.

Display width The width of the display area for the image. This option compresses or stretches the appearance of 

the image on this page. You can enter display size in pixels or as a percentage of the original image size.

Note: This option does not affect the original image source file; it affects only the display of the image on this page.

Display height The height of the display area for the image. This option compresses or stretches the appearance of 

the image on this page. You can enter display size in pixels or as a percentage of the original image size.

Note: This option does not affect the original image source file; it affects only the display of the image on this page.

Reset Display Size Returns the image to its original height and width.

Constrain proportions Keeps the proportions of height and width constant so that the image is not distorted.
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Horizontal padding The amount of empty space, in pixels, on the right and left of the image.

Vertical padding The amount of empty space, in pixels, on the top and bottom of the image.

Alignment The location of the image on the page in relation to any text that appears around the image

Border The width, in pixels, of the border around the image.

Description (ALT text) Describes the image for users with disabilities or for users whose browsers are set to display 

only text.

See also 

“Change image properties” on page 136

Setting the Brightness and Contrast dialog box options

Use the Brightness and Contrast dialog box to change the contrast or brightness of pixels in an image.

1 Drag the Brightness and Contrast sliders to adjust the settings.

Values range from -100 to 100.

2 Click OK.

See also 

“Adjust the brightness and contrast of an image” on page 138

Setting the Sharpen Image dialog box options

Use the Sharpen Image dialog box to change sharpening in an image. Sharpening increases the contrast of pixels 

around the edges of objects to increase the image’s definition or sharpness.

1 Specify the degree of sharpening to apply to the image by dragging the slider control, or entering a value between 

0 and 10 in the text box.

As you adjust the sharpness of the image, you can preview the change to the image.

2 Click OK.

See also 

“Sharpen an image” on page 138

Completing the SWF Movie Properties dialog box

Use the SWF Movie Properties dialog box to change SWF movie (SWF file) properties.

1 In the Options section, select any of the following:

• Select the Start playing the movie when the page loads option to automatically begin playing when the page 

appears on a website visitor’s browser.

• Select the Loop the movie continuously option to have the SWF movie (SWF file) automatically start playing 

again each time it ends.

2 In the Size section, select a unit of measure, and then enter a width and height.

Note: If the Constrain proportions checkbox is selected, Contribute keeps the proportions of height and width constant 

so that the image is not distorted.
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3 To reset the movie to its original size, click the Reset Size button.

4 Click OK.

See also 

“Set SWF movie properties” on page 142

Completing the Video Properties dialog box

Use the Video Properties dialog box to change video properties for movie file types other than SWF. 

Note: The Video Properties dialog box options differ if you are inserting a SWF Video (SWF) file. For more information 

see “Completing the Video Properties dialog box (For FLV files)” on page 153.

1 Enter new Width and Height values, if necessary.

Note: Check your movie file properties for the exact size of your movie so you can set the width and height of the display 

in Contribute accordingly. 

2 Select from the following options:

• Select Show video controls to include controls for playing and stopping the video on the web page.

• Select Start playing the video when the page loads to have the video automatically start playing when the page 

appears on a website visitor’s browser.

3 Click OK.

See also 

“Set video properties” on page 144

Completing the Video Properties dialog box (For FLV files)

Use the Video Properties dialog box to change video properties for FLV Video files.

1 Enter new Width and Height values, if necessary.

Note: Check your movie file properties for the exact size of your movie so you can set the width and height of the display 

in Contribute accordingly. 

2 Select from the following options:

• Select Automatically rewind after the video finishes playing to have the video rewind after it finishes playing.

• Select Start playing the video when the page loads to have the video automatically start playing when the page 

appears on a website visitor’s browser.

• Select a SWF Video skin to change the appearance of the video player in the browser. You can also see a preview 

of the skin after you select a skin in the SWF Video Skin pop-up menu.

3 Click OK.

See also 

“Set video properties” on page 144
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Completing the Choose Enclosure on Website dialog box

Use the Choose Enclosure on Website dialog box to add an enclosure, such as a podcast, from your website to your 

blog entry.

1 Select an enclosure by doing one of the following:

• If the enclosure is in a folder on the website you are currently browsing, select the enclosure.

• If the enclosure is not in a folder on the current website, use the Look In pop-up menu to navigate to the correct 

website folder, and then select the enclosure.

Depending on the type of enclosure you select, a preview may appear so that you can confirm that you’re selecting 

the correct one.

2 Click the folder icons as necessary:

• Up One Level moves the selection up one level in the folder structure.

• New Folder lets you add a folder to your website.

• Delete Folder removes the selected folder from your website.

Note: You can delete folders only if they are empty. For information about removing pages from your website, see 

“Delete a web page or file” on page 71.

3 Click OK.

The enclosure appears as a link in the status bar.

Click the Delete button if you want to delete the enclosure.  

Using the Browse For Enclosure dialog box

Use the Browse For Enclosure dialog box to find the enclosure you want to add to your blog entry. The procedures 

vary depending on whether your default media player is Windows Media Player or QuickTime.

To use the Browse For Enclosure dialog box to find an enclosure (Windows Media Player):

1 Browse to the page that contains the link to the desired audio or video file by doing either of the following:

• Click links in the current page.

• Type a web address (URL) in the Address text box, and then click Go. 

2 (Optional) Click the navigation buttons in the toolbar in the dialog box as necessary:

Note: In Mac OS, the navigation icons do not have labels. If you need help identifying an icon, position the pointer 

over the icon to see a tooltip.

Back Returns to the previous page.

Forward Advances a page.

Stop Cancels the page download.

Refresh Updates your view of the page.

3 When you are viewing the page with the link, right-click the hyperlink of the audio or video file, and then select 

Copy Shortcut. 

4 Paste this path in the address bar in the Browse For Enclosure dialog box, and then click Go.

The audio or video file opens in Windows Media Player in a separate window and begins to play. 
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5 Close the Windows Media Player application window.

Note: You do not have to play the file completely to close the player window.

6 Go back to the Browse For Enclosure dialog box, which is currently open in Contribute, and click OK.

The audio or video file is inserted as an enclosure and now appears in the Enclosure workspace in the draft. The file 

does not play in the draft; you must publish your draft to play the file.

To use the Browse for Enclosure dialog box to find an enclosure (QuickTime):

1 Browse to the page that contains the link to the desired audio or video file by doing either of the following:

• Click links in the current page.

• Type a web address (URL) in the Address text box, and then click Go. 

2 (Optional) Click the navigation buttons in the toolbar in the dialog box as necessary:

Note: In Mac OS, the navigation icons do not have labels. If you need help identifying an icon, position the pointer 

over the icon to see a tooltip.

Back Returns to the previous page.

Forward Advances a page.

Stop Cancels the page download.

Refresh Updates your view of the page.

3 When you are viewing the page with the link, click the hyperlink of the audio or video file. 

The audio or video file opens and plays in the QuickTime player in the Browse For Enclosure dialog box.

4 Click OK.

The audio or video file is inserted as an enclosure and now appears in the Enclosure workspace in the draft. The file 

does not play in the draft; you must publish your draft to play the file.

Completing the Horizontal Rule Properties dialog box

Use the Horizontal Rule Properties dialog box to change horizontal rules in your draft.

❖ Change any of the following options, and click OK:

• Width indicates the length of the line.

To set a specific line width for a horizontal rule, enter a number in the Width text box, and then select Pixels. 

To set a line width that expands or contracts depending on the width of a viewer’s browser window, enter a 

number between 1 and 100 in the Width text box, and then select Percent.

• Height indicates the height of the line.

• Use Outline Shading indicates that the line appears as an outline, not a solid line.

See also 

“Change the properties of a horizontal rule” on page 148

Using the Browse For Image dialog box

Use the Browse For Image dialog box to find an image on the Internet, and add it to your website or blog entry.

1 Browse to the URL that contains the image file. 
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Note: You cannot select a folder to insert as an image in a Contribute page.

2 Click the navigation buttons in the toolbar in the dialog box as necessary: 

Note: In Mac OS, the navigation icons do not have labels. If you need help identifying an icon, position the pointer 

over the icon to see a tooltip.

Back Returns to the previous page.

Forward  Advances a page.

Stop Cancels the page download.

Refresh updates your view of the page.

3 Click OK to select the image file from the Internet.

The image file from the Internet is inserted in the draft.

Note: When you insert the image in a page, the selected image is not downloaded to your local computer.

See also 

“Using the Choose <Image/SWF File/Video> On Website dialog box” on page 157

Using the Browse For SWF dialog box

Use the Browse For SWF dialog box to find a SWF file on the Internet and add it to your website or blog entry.

1 Browse to the URL that contains the SWF file.

Note: You cannot select a folder to insert as a SWF file in a Contribute page.

2 Click the navigation buttons in the toolbar in the dialog box as necessary: 

Note: In Mac OS, the navigation icons do not have labels. If you need help identifying an icon, position the pointer 

over the icon to see a tooltip.

Back Returns to the previous page.

Forward  Advances a page.

Stop Cancels the page download.

Refresh updates your view of the page.

3 Click OK to select the SWF file from the Internet.

The SWF file from the Internet is inserted in the draft.

Note: When you insert a SWF file in a page, the selected file is not downloaded to your local computer. The SWF file 

is inserted as a place-holder, which you can resize.

See also 

“Using the Choose <Image/SWF File/Video> On Website dialog box” on page 157

Using the Browse For Video dialog box

Use the Browse For Video dialog box to find a video file on the Internet and add it to your website or blog entry.

1 Browse to the URL that contains the video file. 

Note: You cannot select a folder to insert as a video file in a Contribute page.
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2 Click the navigation buttons in the toolbar in the dialog box as necessary: 

Note: In Mac OS, the navigation icons do not have labels. If you need help identifying an icon, position the pointer 

over the icon to see a tooltip.

Back Returns to the previous page.

Forward  Advances a page.

Stop Cancels the page download.

Refresh updates your view of the page.

3 Click OK to select the video file from the Internet.

The video file from the Internet is inserted in the draft. Publish the page to play the video.

Note: When you insert a SWF file in a page, the selected file is not downloaded to your local computer. The behavior 

of video file insertion is the same as the behavior of inserting an enclosure in blog entries. For more information, see 

“Using the Browse For Enclosure dialog box” on page 154.

See also 

“Using the Choose <Image/SWF File/Video> On Website dialog box” on page 157

Using the Choose <Image/SWF File/Video> On Website dialog box

Use the Choose <Image/SWF File/Video> on Website dialog box to select an image, a SWF file, or a video from a 

website, and add it to your website or blog entry draft.

1 Browse to the URL that contains the image, SWF file, or video.

Note: You cannot select a folder to insert as an image, a SWF file, or a video, in a Contribute page.

2 Click OK to select the file from the website.

The image, SWF file, or video is inserted in the draft.

Note: When you insert an image, SWF file, or video in a page, the selected file is not downloaded to your local 

computer.

See also 

“Using the Browse For Image dialog box” on page 155

“Using the Browse For Video dialog box” on page 156

“Using the Browse For SWF dialog box” on page 156
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A table is a powerful tool for presenting tabular data. For example, you might add a table to a web page that lists all 

your sales reps in one column, with their contact information in another column. 

In Adobe® Contribute®, you can add text and images to table cells the same way that you add text and images to a page 

(see “Working with text” on page 113 and “Working with images and graphic elements” on page 131). After you create 

a table you can easily modify both its appearance and structure. 

About conflicts in table formatting 

When formatting tables, you can set properties for the entire table or for selected cells, rows, or columns in the table. 

When a table property, such as background color or alignment, is set to one value for the entire table and another value 

for individual cells, cell formatting takes precedence over row formatting, which in turn takes precedence over table 

formatting. 

The order of precedence for table formatting is as follows:

1 Cells

2 Rows

3 Table

For example, if you set the background color for a single cell to blue, and then set the background color of the entire 

table to yellow, the blue cell does not change to yellow because cell formatting takes precedence over table 

formatting.

Note: When you set properties for a column, Contribute changes the attributes of the td tag corresponding to each cell 

in the column.

See also 

“Modify table appearance” on page 168

Insert tables

You can insert a table anywhere on a page, including in another table. You can quickly add a standard table with three 

rows and three columns, or you can modify options to add a custom table.

For information about a table-rendering option that might improve performance when you’re editing large tables, see 

“Setting editing preferences” on page 40.

When you start adding content to your table, use Preview in Browser to see exactly how the table will appear in the 

browsers of your website visitors (see “Preview a page in your default browser” on page 207).

1 Place the insertion point in your draft where you want the table to appear.

2 Do one of the following to open the Insert Table dialog box:

• Click the Table button  in the toolbar.
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• Select Insert > Table.

• Select Table > Insert > Table.

The Insert Table dialog box appears.

3 Complete the dialog box.

For more information, see “Completing the Insert Table dialog box” on page 172.

4 Click OK.

The table appears in your draft.

After you insert the table, select it, and then click the Table button again to change the table properties. For 

information about changing header properties, see “Modify row or column properties” on page 168.

Insert a table in a table

1 In your draft, place the insertion point in the table cell where you want the table to appear.

2 Do one of the following to open the Insert Table dialog box:

• Click the Table button  in the toolbar.

• Select Insert > Table.

• Select Table > Insert > Table.

The Insert Table dialog box appears.

3 Change options as necessary.

4 Click OK.

The table appears in the table cell where you placed the insertion point.
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See also 

“Resize tables, rows, and columns” on page 161

“Add, delete, or merge table rows and columns” on page 165

“Modify table appearance” on page 168

Select table elements

You can select an entire table, row, or column, or you can select a single cell or a contiguous block of cells in a table.

See also 

“Modify table appearance” on page 168

“Cut and copy table cells” on page 164

Select table, row, or column

You might select an entire table, row, or column because you want to paste it onto another page (see “Cut and copy 

table cells” on page 164) or because you want to change the background of all the cells in the selection at once (see 

“Modify table appearance” on page 168).

Select an entire table

❖ Do one of the following:

• Click the upper-left corner of the table or click anywhere on the right or bottom edge. 

• Click in a table cell, and then select Table > Select Table. 

Selection handles appear on the selected table’s lower and right edges. 

Select rows or columns

1 Position the pointer to point at the left edge of a row or the top edge of a column.

2 When the pointer changes to a selection arrow, click to select the row or column, or drag to select multiple rows or 

columns.
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Select a cell, a block of cells, or nonadjacent cells

You might want to select a cell or group of cells because you want to paste it onto another page (see “Cut and copy 

table cells” on page 164) or because you want to change the background of all the cells in the selection at once (see 

“Modify table appearance” on page 168).

When you select a block of cells, the block must form a rectangle. When you select multiple nonadjacent cells in a table, 

you can only modify the properties of those cells. You cannot copy or paste sets of nonadjacent cells.

Select a single cell

❖ Do one of the following:

• Click in the cell, and then drag to select the cell.

• Click in the cell, and then select Edit > Select All.

Select a line or a rectangular block of cells

❖ Do one of the following:

• Drag from one cell to another cell.

• Click in one cell, and then Shift-click another cell.

All the cells within the linear or rectangular region defined by the two cells are selected. 

Select nonadjacent cells

❖ Control-click (Windows) or Command-click (Mac OS) the cells, rows, or columns you want to select.

Note: If a cell, row, or column you Control-click or Command-click isn’t already selected, it’s added to the selection. 

If it is already selected, it’s removed from the selection.

Resize tables, rows, and columns

You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the table 

are resized proportionately.

Resize tables

1 In your draft, select the table you want to resize (see “Select table elements” on page 160).

2 Do one of the following:

• To resize the table horizontally, drag the selection handle on the right.

• To resize the table vertically, drag the selection handle on the bottom.

• To resize in both dimensions, drag the selection handle at the lower-right corner.
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Resize a column’s width

❖ Do one of the following in your draft:

• Select the column, and then drag the right border of the column.

• Select the column, and then click the Table button in the toolbar. 

In the Table Column Properties dialog box, change the number in the Column width text box, and then select 

Pixels or Percent for the width. Alternatively, select Fit to contents to clear the set width and resize the columns 

to accommodate the content you add.

Note: If you select any column but the rightmost one, the width of the adjacent column also changes, and Contribute 

retains the original table width. If you select the rightmost column, the width of the entire table changes, and all the 

columns grow wider or narrower proportionately.

Resize a row’s height

❖ Do one of the following in your draft:

• Select the row, and then drag the lower border of the row. 

• Select the row, and then click the Table button  in the toolbar.

In the Table Row Properties dialog box, change the number in the Row height text box. Alternatively, select Fit 

to contents to clear the set height and resize the rows to accommodate the content you add.

Align tables

You can indicate how a table aligns on the web page in relation to elements, such as text or images around it on the page.

You cannot select an alignment option when you create a table. You must insert the table (see “Insert tables” on 

page 158), and then change the alignment option in table properties.

Change alignment for a table

1 In your draft, select the table you want to realign (see “Select table elements” on page 160).

2 Do one of the following to open the Table Properties dialog box:

• Click the Table button in the toolbar. 

• Right-click (Windows) or Control-click (Mac OS), and then select Table Properties from the pop-up menu. 

• Select Table > Table Properties. 
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The Table Properties dialog box appears. 

3 Select an alignment option from the Table alignment pop-up menu:

Default aligns the table to the left of the page. Text or images do not flow around the table.

Left aligns the table to the left side of the page. Text or images flow to the right of the table.

Center aligns the table in the center of the page.

Right aligns the table to the right side of the page. Text or images flow to the left of the table.

4 Click Apply to see changes without closing the dialog box, or click OK to apply changes and close the dialog box.

The table alignment changes in your draft.

Cut, copy, and paste cells

You can cut, copy, or paste a single table cell or multiple cells at once, preserving the cell formatting. You can paste 

cells at the insertion point or paste over a selection in an existing table. 

The selected cells must be contiguous and in the shape of a rectangle. For example, the selection in this illustration is 

a rectangle of cells, so the cells can be cut or copied. 

The selection in this illustration is not a rectangle, so the cells can’t be cut or copied. 
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Cut and copy table cells

You can copy a single cell or multiple cells, and cut the cells, or the cells’ content, from the table. You can copy a single 

cell or multiple cells, and paste the cells in the same or another table (see “Paste table cells” on page 164).

Copy table cells, rows, or columns

1 In your draft, select one or more cells, rows, or columns in the table (see “Select table elements” on page 160). 

2 Do one of the following:

• Select Edit > Copy.

• Right-click (Windows) or Control-click (Mac OS), and then select Copy.

Contribute copies the selection to the Clipboard.

Cut table cells, rows, or columns

1 In your draft, select one or more cells, rows, or columns in the table (see “Select table elements” on page 160). 

2 Do one of the following:

• Select Edit > Cut.

• Right-click (Windows) or Control-click (Mac OS), and then select Cut.

Contribute cuts the selection from the table and copies it to the Clipboard.

Remove cell content but leave the cells intact

1 In your draft, select one or more cells. 

Note: Do not select an entire row or column. If you do, when you select Edit > Clear or press Delete, Contribute 

removes the entire row or column—not just its contents—from the table.

2 Select Edit > Clear or press Delete. 

Contribute removes the contents of the cells you selected, but leaves the empty cells in the table.

See also 

“Paste table cells” on page 164

“Delete rows and columns” on page 166

Paste table cells

You can copy cells (see “Cut and copy table cells” on page 164) and then paste them at the insertion point in a table or 

paste over a selection in an existing table. 

When you paste multiple table cells, the contents of the Clipboard must be compatible with the structure of the table 

or the selected block where they will go. For example, if you copy a block that is two cells by two cells, you must paste 

it in a two-by-two block.

1 Copy some table cells (see “Cut and copy table cells” on page 164).
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2 In your draft, do one of the following to indicate where you want to paste the cells:

• To replace existing cells with the cells you are pasting, select a set of existing cells with the same layout as the 

cells you copied. 

For example, if you’ve cut or copied a three-by-two block of cells, select another three-by-two block in which to 

paste the cut or copied content.

• To paste a full row of cells above a particular cell, click in that cell.

• To paste a full column of cells to the left of a particular cell, click in that cell.

• To create a table with the pasted cells, place the insertion point outside the table.

Note: If you have less than a full row or column of cells in the Clipboard, and you click in a cell and then paste the cells 

from the Clipboard, the cell you clicked in and its neighbors (depending on its location in the table) might be replaced 

with the cells you are pasting.

3 Do one of the following:

• Select Edit > Paste.

• Right-click (Windows) or Control-click (Mac OS), and then select Paste. 

Contribute pastes the cells from the Clipboard.

See also 

“Cut and copy table cells” on page 164

Add, delete, or merge table rows and columns

You can modify an existing table by adding or deleting rows or columns. You can also merge cells to accommodate data.

Add rows and columns

You can add a single row or column, or you can add multiple rows or columns at the same time.

Add a single row to a table

1 In your draft, place the insertion point in a table cell, or select an entire row.

2 Do one of the following: 

• Click the Insert Row Below button  in the toolbar.

A new row appears below the insertion point or selection.

• Select Table > Insert > Row Above or Table > Insert > Row Below.

• Right-click (Windows) or Control-click (Mac OS), and then select Insert Row Above or Insert Row Below.

Add a single column to a table

1 In your draft, place the insertion point in a table cell, or select an entire column.

2 Do one of the following: 

• Click the Insert Column to the Right button  in the toolbar.

A new column appears to the right of the insertion point or selection.
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• Select Table > Insert > Column to the Left or Table > Insert > Column to the Right.

• Right-click (Windows) or Control-click (Mac OS), and then select Insert Column to the Left or Insert Column 

to the Right.

Add multiple rows or columns to a table

1 In your draft, place the insertion point in a table cell.

2 Do one of the following:

• Select Table > Insert > Multiple Rows or Columns.

• Right-click (Windows) or Control-click (Mac OS), and then select Insert Multiple Rows or Columns.

The Insert Rows or Columns dialog box appears.

3 Complete the dialog box.

For more information, see “Completing the Insert Rows or Columns dialog box” on page 173.

4 Click OK.

Contribute adds the rows or columns to your table.

See also 

“Merge or Split cells” on page 167

Delete rows and columns

You can delete a single row or column, or you can delete multiple rows or columns at the same time.

Do one of the following:

• Select entire rows or columns, and then press Delete or Backspace. 

• Select entire rows or columns or place the insertion point in a single row or column, right-click (Windows) or 

Control-click (Mac OS), and then select Delete Row or Delete Column.

• Select entire rows or columns, and then select Table > Delete > Row or Table > Delete > Column. 

See also 

“Select table elements” on page 160

“Add rows and columns” on page 165



167USING CONTRIBUTE CS4

Working with tables

Merge or Split cells

You can merge any number of adjacent cells—as long as the entire selection is a line or a rectangle of cells—to produce 

a single cell that spans several columns or rows. You can split a cell into any number of rows or columns, regardless of 

whether it was previously merged. 

Merge table cells

1 In your draft, select the cells you want to merge. 

Note: You must select at least two cells.

2 Do one of the following:

• Select Table > Merge Cells.

• Right-click (Windows) or Control-click (Mac OS), and then select Merge Cells.

Contribute merges the content into a single cell. 

Split table cells

1 In your draft, place the insertion point in the cell you want to split. 

Note: Contribute only splits one cell at a time, even if you select multiple cells.

2 Do one of the following:

• Select Table > Split Cell.

• Right-click (Windows) or Control-click (Mac OS), and then select Split Cell.

The Split Cell dialog box appears.

3 Select a radio button to indicate whether to split the cell into rows or columns, and then enter the number of new 

rows or columns in which to divide the cell.

4 Click OK.

Contribute splits the cell into multiple rows or columns.

See also 

“Select table elements” on page 160

“Add rows and columns” on page 165

“Delete rows and columns” on page 166
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Modify table appearance

Modify table properties

You can modify the alignment, width, border width and color, and background color of a selected table. 

1 In your draft, select the table you want to modify (see “Select table elements” on page 160).

2 Do one of the following to open the Table Properties dialog box:

• Click the Table button  in the toolbar. 

• Right-click (Windows) or Control-click (Mac OS), and then select Table Properties from the pop-up menu. 

• Select Table > Table Properties. 

The Table Properties dialog box appears.

3 Change table properties as necessary.

For more information, see “Completing the Table Properties dialog box” on page 173.

4 Click Apply to apply changes without closing the dialog box, or click OK to apply changes and close the dialog box.

Your table property changes appear in your draft.

See also 

“Modify cell properties” on page 169

Modify row or column properties

You can modify horizontal and vertical alignment, background color, height or width, and text wrap for a selected row 

or column.

Note: To understand how Contribute resolves formatting conflicts for cells, rows, and tables, see “About conflicts in table 

formatting” on page 158.



169USING CONTRIBUTE CS4

Working with tables

Modify table row or column properties

1 In your draft, select the row or column you want to modify (see “Select table, row, or column” on page 160).

2 Do one of the following to open the Table Properties dialog box:

• Click the Table button in the toolbar. 

• Right-click (Windows) or Control-click (Mac OS), and then select Table Cell Properties from the pop-up menu. 

• Select Table > Table Cell Properties. 

The Table Properties dialog box appears with the appropriate tab (row or column) selected.

3 Change the row or column properties as desired.

For more information, see “Completing the Table Properties dialog box for a row or column” on page 174.

4 Click Apply to preview your changes, or click OK to apply changes and close the dialog box.

See also 

“Modify table properties” on page 168

Modify cell properties

You can modify horizontal and vertical alignment, background color, and text wrap for a selected cell.

Note: To understand how Contribute resolves formatting conflicts for cells, rows, and tables, see “About conflicts in table 

formatting” on page 158.

1 In your draft, select the cell or cells you want to modify (see “Select table, row, or column” on page 160).

2 Do one of the following to open the Table Properties dialog box:

• Right-click (Windows) or Control-click (Mac OS), and then select Table Cell Properties from the pop-up menu. 

• Select Table > Table Cell Properties. 

• Click the Table button  in the toolbar.

Note: If you placed the insertion point in the cell instead of selecting the cell, this option opens the Insert Table dialog 

box instead of the Table Properties dialog box for cells.
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The Table Properties dialog box appears with the appropriate tab selected.

3 Change the cell properties as desired.

For more information, see “Completing the Table Properties dialog box for a table cell” on page 175.

4 Click Apply to preview your changes, or click OK to apply changes and close the Table Properties dialog box.

See also 

“Modify table properties” on page 168

“Modify row or column properties” on page 168

Use a preset table format

You can apply a preset design to a table and select options to further customize the design.

Note: You can apply preset table designs to a simple rectangular grid of cells only. You can’t use these designs to format 

tables that contain merged cells or other unusual formatting.

1 In your draft, select a table to modify or place the insertion point in any cell in the table.

2 Select Table > Format Table. 
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The Format Table dialog box appears with the Basic tab selected.

3 Complete the dialog box.

For more information, see “Completing the Format Table dialog box” on page 175.

4 Click OK.

Contribute formats your table with the design you selected.

Sort tabular data

You can sort the rows of a table based on the contents of a single column. For example, if you have a Names column 

in a table, you can sort items in that column alphabetically.

You can also perform a more complicated table sort based on the contents of two columns. 

Note: You cannot sort on a column that contains merged cells.

1 In your draft, select the table to sort or place the insertion point in any cell in the table.

2 Select Table > Sort Table.
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The Sort Table dialog box appears.

3 Complete the dialog box.

For more information, see “Completing the Sort Table dialog box” on page 176.

4 Click OK. 

Contribute reorders the table.

Reference

This section provides information about the dialog boxes introduced in this chapter.

Completing the Insert Table dialog box

Use the Insert Table dialog box to add a table to your web page.

1 Enter the number of rows and columns you want, or accept the defaults for a table with three rows and three 

columns.

2 Change any of the following table properties:

Table width indicates how wide the table is.

Select Default width to have the width of the table columns change as you add content. Select Specific width to have 

a fixed table width. Enter a number, and use the pop-up menu to indicate whether the number represents a number 

of pixels or the percentage of the page the table will occupy.

Border thickness is the thickness of the border around the table.

Enter 0 if you do not want a table border.  

Cell padding indicates the amount of space, in pixels, between the edge of the table cell and the content of the cell.

Note: If you do not enter a value, Contribute sets cell padding to the default value, which is 1 pixel.

Cell spacing indicates the amount of space, in pixels, between each table cell.
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Note: If you do not enter a value, Contribute sets cell spacing to the default value, which is 2 pixels.

3 Click a button in the Header section to indicate whether you want a header; select from the following options:

None indicates no header.

Left indicates a header column.

Top indicates a header row.

Both indicates a header column and a header row.

Screen readers read headings of rows or columns that have one of these header types applied; they do not read 

headings that you create by entering bold and centered text.

4 Click OK.

The table appears in your draft.

After you insert the table, select it, and then click the Table button again to change the table properties. For 

information about changing header properties, see “Modify row or column properties” on page 168.

See also 

“Insert tables” on page 158

Completing the Insert Rows or Columns dialog box

Use the Insert Rows or Columns dialog box to add multiple rows or columns at the same time to a table.

1 Select a radio button to indicate whether to insert rows or columns.

2 Enter the number of rows or columns to insert.

3 Specify where the new rows or columns will go: above or below the insertion point (rows), or to the left or right of 

the insertion point (columns).

4 Click OK.

Completing the Split Cell dialog box

Use the Split Cell dialog box to divide a single table cell into multiple rows or columns.

1 Select a radio button to indicate whether to split the cell into rows or columns.

2 Enter the number of new rows or columns in which to divide the cell.

3 Click OK.

Completing the Table Properties dialog box

Use the Table Properties dialog box to change properties for the selected table.

1 Make changes to any of the following options:

Table alignment refers to the location of the table in relation to any elements (such as text or images) that appear 

around the table. Select from the following options:

• Default aligns the table to the left side of the page. Text or images do not flow around the table.

• Left aligns the table to the left side of the page. Text or images flow to the right of the table.

• Center aligns the table in the center of the page.
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• Right aligns the table to the right side of the page. Text or images flow to the left of the table.

• Table width specifies how wide the table is.

From the pop-up menu, select Percent to specify the table width as a percentage of the total browser window, or 

Pixel to specify the width in pixels (a number between 1 and 800).

Note: You can enter percentages greater than 100. For example, if you enter 150, the table is one and a half times 

the size of the browser window. When the percentage is greater than 100, a scrollbar appears for the web page. You 

can enter a value up to 1000.

Border thickness specifies the thickness of the border around the table.

Enter 0 if you do not want a table border. 

Cell padding indicates the amount of space, in pixels, between the edge of the table cell and the contents of the cell. 

Note: If you do not enter a value, Contribute sets cell padding to the default value, which is 1 pixel.

Cell spacing indicates the amount of space, in pixels, between each table cell.

Note: If you do not enter a value, Contribute sets cell spacing to the default value, which is 2 pixels.

Border color indicates the color of the border around the table and between cells.

Note: The border color does not show if the border thickness is set to 0 for no border. 

Background color indicates the background color of all the cells in the table. 

If you do not select a color, the default background is transparent. In other words, the table background is white on 

a white page, green on a green page, and so on. 

2 Click Apply to apply changes without closing the dialog box, or click OK to apply changes and close the dialog box.

See also 

“Modify table properties” on page 168

Completing the Table Properties dialog box for a row or column

Use the Row or Column tab in the Table Properties dialog box to change properties for the selected table row or 

column.

1 Make changes to any of the following options:

Horizontal alignment specifies how content in the row or column is aligned horizontally. Options are Left, Center, 

and Right.

Vertical alignment specifies how content in the row or column is aligned vertically. Options are Top, Middle, and 

Bottom.

Background color indicates the background color of the selected row or column.

Note: You can also click Highlight Color in the toolbar to change the color of the selected row or column.

Row height specifies how tall the row is.

Column width specifies how wide the column is.

For a selected row or column, you can change the number in the Row height or Column width text box, and then 

select pixels or a percentage for the width. Alternatively, select Fit to contents to clear the set height or width and 

resize the rows or columns to accommodate the content you add.
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Wrap text , When selected, indicates that text wraps to a new line when it reaches the end of the cell. When not 

selected, text does not wrap and the cell expands to accommodate the text. 

Header Row indicates that the selection is a header.

2 Click Apply to preview your changes, or click OK to apply changes and close the dialog box.

See also 

“Modify row or column properties” on page 168

Completing the Table Properties dialog box for a table cell

Use the Cell tab in the Table Properties dialog box to change properties for the selected table cell.

1 Make changes to any of the following options:

Horizontal alignment specifies how cell content is aligned horizontally. Options are Left, Center, and Right.

Vertical alignment specifies how cell content is aligned vertically. Options are Top, Middle, and Bottom.

Background color indicates the background color of the cell.

Note: You can also click Highlight Color in the toolbar to change the color of the selected cell.

Wrap text , when selected, indicates that text wraps to a new line when it reaches the end of the cell. When not 

selected, text does not wrap and the cell expands to accommodate the text. 

2 Click Apply to preview your changes, or click OK to apply changes and close the Table Properties dialog box.

See also 

“Modify cell properties” on page 169

Completing the Format Table dialog box

Use the Format Table dialog box to apply a preset design to a table, and then select options to further customize the 

design.

1 Select a design scheme from the list on the left. 

Contribute shows an example of the selected table design.

2 Click the Advanced tab.

3 In the Table properties section, enter a border width for the table.

Note: If you do not want a table border, enter 0 for the border. 

4 In the Left column section, select a text alignment and a text style for the left column of the table, which might 

contain row headings.

5 In the Header row section, select a background color and a text color, and then select a text alignment and a text 

style for the top row of the table, which might contain column headings.

6 In the Other rows section, select a color to apply to rows, and then indicate how frequently you want the colors to 

alternate. Click Color to select a second row color, if you select to alternate row color.

7 Click OK.

Contribute formats your table with the selected design.
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See also 

“Use a preset table format” on page 170

Completing the Sort Table dialog box

Use the Sort Table dialog box to sort the rows of a table based on the contents of a single column or based on the 

contents of two columns.

Note: You cannot sort on a column that contains merged cells.

1 From the Sort by pop-up menu, select the column whose values you want to sort. 

2 From the Order pop-up menu, specify whether to sort the column alphabetically or numerically, and then specify 

whether to sort it in ascending order (A to Z, lower numbers to higher numbers) or descending order.

When a column contains numbers, select Numerically. An alphabetic sort applied to 1, 2, 3, 10, 20, 30 yields the 

sequence 1, 10, 2, 20, 3, 30.

3 From the Then by pop-up menu, select a secondary column to sort. 

4 From the Order pop-up menu, specify whether to sort the secondary sort column alphabetically or numerically, 

and whether to sort it in ascending order or descending order.

5 In the Options section, select any of the following additional options:

Sort includes the first row specifies that the first row of the table is included in the sort. If the table has a header row, 

the header is the first row of the table.

Sort header rows specifies to sort header rows using the same criteria as the body rows. 

Sort footer rows specifies to sort table footer rows using the same criteria as the body rows.

Keep row colors with content specifies that table row colors should remain associated with the same content after 

the sort.

For example, do not select this option if your table has rows of alternating colors and you want to preserve the 

alternating pattern in the sorted table. If the color denotes a type of content, select this option to ensure that the 

color remains associated with the content after the sort.

See also 

“Sort tabular data” on page 171
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A hypertext link, often called a link, creates a connection from one page to another page. On a web page, links are 

typically underlined and differentiated by color from the surrounding text. When a visitor to your website clicks a link 

in one page, another page opens.

Visitors use links to navigate your website. When you add a new page to a website, you have to add a link to the new 

page on an existing page. Then, users can click the link in the existing page to view the new page.

Create text and image links

With Adobe® Contribute®, you can make text or images in your web page or blog act as links. When a visitor to your 

website clicks a link on a specified text or an image, the browser takes the visitor to another web page or file, or starts 

their e-mail application; if the link is in a blog, Contribute takes the visitor to another blog entry.

When you add a link to a web page or blog entry draft, the link is not live until you publish the page (see “Publishing 

web pages and blog entries” on page 203). Before you publish a web page or blog entry with a link, use the Preview in 

Browser feature to test the link and make sure it works.

Your text or image can link to any of the following:

• A current draft or a recently published page on your website

• A new web page, which Contribute creates at the same time as the link

• A new blog entry, which Contribute creates at the same time as the link

• An existing web page on your website or on another website 

• An e-mail address 

• An existing file on your computer, such as a Microsoft Word or PDF file

Note: To link to items in your Adobe® Acrobat® Connect account, see “Link to Adobe Acrobat Connect content, training, 

and meetings” on page 182.

See also 

“Set the advanced linking options” on page 184

“Edit links” on page 189

“Test links” on page 190

Link to a draft or a recently published page on your website

You can create a link on your page to a draft that you are currently editing or to a recently published page on your 

website. Contribute has a complete list of current drafts for you to link to, and stores a list of the last ten pages you 

published on your website. 

For information on how linked pages and files are handled in a workflow, see “The draft review process” on page 46.

For information on specifying the type of path for links in a website, see “Specify the type of path for links in a website” 

on page 250.
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For information about linking to a page that is not a current draft or was not recently published, see “Link to a page 

on your website or on another website” on page 180.

1 In your draft, do one of the following to indicate where the link will appear:

• Place the insertion point in the draft.

• Select text in the draft.

• Select an image in the draft.

2 Do one of the following to open the Insert Link dialog box:

• Click the Link button  in the toolbar, and then select Drafts and Recent Pages.

• Select Insert > Link > Drafts and Recent Pages.

• Right-click (Windows) or Control-click (Mac OS), and then select Insert Link.

3 Click Drafts and Recent Pages (Windows) or Drafts (Mac OS) at the top of the dialog box, if it’s not already selected.

4 Complete the dialog box.

For more information, see “Completing the Drafts and Recent Pages section of the Insert Link dialog box” on 

page 191.

5 Click OK.

The link appears in your draft.

See also 

“Link to a page on your website or on another website” on page 180

“Link to an e-mail address” on page 181

“Link to a file on your computer” on page 181

Link to a new page

You can create a link to a new web page on your website—that is, you can create a link to a new page that Contribute 

creates at the same time that it creates the link. 

Note: The new page appears on your website when you publish the draft with the link.

For information on how linked pages and files are handled in a workflow, see “The draft review process” on page 46.

For information on specifying the type of path for links in a website, see “Specify the type of path for links in a website” 

on page 250.

For example, suppose you are working on a page listing your products and need to create a link to a product page that 

doesn’t exist yet. Contribute lets you create the new page and link to it before you add content to the page. 

The preferred way to add a new page to your website is to create a link and the new page at the same time, and then 

add content later. (The other way to add a new page to your website is to create the page first, and then link it later. For 

more information, see “Create or copy a page on your website” on page 76.)

It’s a good idea to create a link to a new page at the same time you create the new page. This way, you don’t have to 

remember to link to the page later, and you ensure that users can navigate to the page on your website.

1 In your draft, do one of the following to indicate where the link will appear:

• Place the insertion point in the draft.
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• Select text in the draft.

• Select an image in the draft.

2 Do one of the following to open the Insert Link dialog box:

• Click the Link button  in the toolbar, and then select Create New Page.

• Select Insert > Link > Create New Page.

• Right-click (Windows) or Control-click (Mac OS), and then select Insert Link.

3 Click the Create New Page button (Windows) or New Page button (Mac OS) at the top of the dialog box, if it is not 

already selected.

The bottom half of the dialog box changes.

4 Complete the dialog box.

For more information, see “Completing the Create New Page section of the Insert Link dialog box” on page 192.

5 Click OK.

Contribute adds the link to the draft, and then opens the new page in the Contribute editor. To return to the draft 

where you added the link, click the draft title in the Pages panel.

Note: Contribute automatically saves the new page in the same folder as the draft that links to it (unless you selected 

another website). When you publish your draft, Contribute also publishes the new page. You can change the folder 

location for the new page then, if you need to.

See also 

“Link to a draft or a recently published page on your website” on page 177

“Link to a page on your website or on another website” on page 180

“Link to an e-mail address” on page 181

“Link to a file on your computer” on page 181

Link to a new blank blog entry

You can create a link to a new blank blog entry on your blog—that is, you can create a link to a new blog entry that 

Contribute creates at the same time that it creates the link. 

Note: The new blank blog entry appears on your blog when you publish the blog entry draft (the blog entry where you 

want to insert the link) with the link.

1 In your blog entry draft, do one of the following to indicate the link location:

• Place the insertion point in the draft.

• Select text in the draft.

• Select an image in the draft.

Note: Some blogs do not allow images, enclosures, media files, or links to local files in the content. Verify whether your 

blog makes this exception.

2 Do one of the following to open the Insert Link dialog box:

• Click the Link button  in the toolbar, and select Create New Entry.

• Select Insert > Link > Create New Entry.
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• Right-click (Windows) or Control-click (Mac OS), and select Insert Link.

3 Click the Create New Entry button (Windows) or New Entry button (Mac OS) at the top of the dialog box, if it is 

not already selected.

The bottom half of the dialog box changes.

4 Complete the dialog box.

For more information, see “Completing the Create New Entry section of the Insert Link dialog box” on page 193.

5 Click OK.

Note: Contribute automatically saves the new blog entry in the same folder as the draft that links to it. When you 

publish your draft (the blog entry where you inserted the link), Contribute also publishes the new blog entry. For more 

information on publishing blog entries, see “Publish a blog entry to your blog” on page 219.

See also 

“Link to a draft or a recently published page on your website” on page 177

“Link to a new page” on page 178

“Link to a file on your computer” on page 181

Link to a page on your website or on another website

You can create a link to another page on your website or on another website. If the page you’re linking to is not linked 

to any other pages—so you can’t browse to it—Contribute lets you use the file system to find the page.

Note: If the page you want to link to was recently published or is a draft, see “Link to a draft or a recently published page 

on your website” on page 177.

1 In your draft, do one of the following to indicate where the link will appear:

• Place the insertion point in the draft.

• Select text in the draft.

• Select an image in the draft.

2 Do one of the following to open the Insert Link dialog box:

• Click the Link button  in the toolbar, and then select Browse to Web Page.

• Select Insert > Link > Browse to Web Page.

• Right-click (Windows) or Control-click (Mac OS), and then select Insert Link.

3 Click the Browse to Web Page button (Windows) or Browse button (Mac OS) at the top of the dialog box, if it is 

not already selected.

4 Complete the dialog box.

For more information about options in the dialog box, see “Completing the Browse to Web Page section of the 

Insert Link dialog box” on page 193.

5 Click OK.

Contribute adds the link to your draft.
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See also 

“Link to a draft or a recently published page on your website” on page 177

“Link to a new page” on page 178

“Link to a file on your computer” on page 181

Link to an e-mail address

You can create a link to an e-mail address. When a website visitor clicks the link, Contribute creates a new message, 

with the e-mail address you specified, in the visitor’s default e-mail application.

For example, you might create the text link “Contact us about our new products!” When a visitor clicks the link, 

Contribute starts the visitor’s e-mail application and creates an e-mail message to the Sales department.

1 In your draft, do one of the following to indicate where the link will appear:

• Place the insertion point in the draft.

• Select text in the draft.

• Select an image in the draft.

2 Do one of the following to open the Link dialog box:

• Click the Link button  in the toolbar, and then select E-mail Address.

• Select Insert > Link > E-mail Address.

• Right-click (Windows) or Control-click (Mac OS), and then select Insert Link.

3 Click the E-mail Address button (Windows) or E-mail button (Mac OS) at the top of the dialog box, if it is not 

already selected.

4 Complete the dialog box.

For more information, see “Completing the E-mail section of the Insert Link dialog box” on page 195.

5 Click OK.

Contribute adds the link to the page.

See also 

“Link to a draft or a recently published page on your website” on page 177

“Link to a new page” on page 178

“Link to a page on your website or on another website” on page 180

Link to a file on your computer

To add content to your website that you saved on your computer, create a link on a page on your website to a file saved 

on your computer or network. 

For example, you might link to a Word document saved on your hard drive or an HTML page saved on your desktop. 

This essentially adds a new page to your website, with the content contained in the file. 

When you publish the page with the link, Contribute copies the file into your website and then links to that copy—not 

to the actual file on your computer—to create the new page on your website. 
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If you want to replace an existing page on your website with the contents of a file saved on you computer, see “Replace 

a file on your website” on page 209. 

You can use the Insert Link dialog box to insert a link to a file on your computer, or you can drag the file to your page 

(see “Insert a link to a Microsoft Word or Excel document from Microsoft Office (Windows only)” on page 99).

Note: If the file you want to link to is already saved on your web server—and not your computer—see “Link to a page on 

your website or on another website” on page 180.

1 In your draft, do one of the following to indicate where you want the link to appear:

• Place the insertion point in the draft.

• Select text in the draft.

• Select an image in the draft.

2 Do one of the following to open the Insert Link dialog box:

• Click the Link button in the toolbar, and then select File on My Computer.

• Select Insert > Link > File on My Computer.

• Right-click (Windows) or Control-click (Mac OS), and then select Insert Link.

3 Click the File on My Computer button (Windows) or File button (Mac OS) at the top of the dialog box, if it is not 

already selected.

4 Complete the dialog box.

For more information, see “Completing the File on My Computer section of the Insert Link dialog box” on 

page 195.

5 Click OK.

Contribute copies the file to create a page on your website. A link to the new page appears in your draft.

Note: To edit content to the linked page after you publish, see “Edit web pages in an external application” on page 67. 

Changes you make to the original file do not appear on your website.

See also 

“Link to a draft or a recently published page on your website” on page 177

“Link to a new page” on page 178

“Link to a page on your website or on another website” on page 180

“Link to an e-mail address” on page 181

Link to Adobe Acrobat Connect content, training, and meetings

If you are a Acrobat® Connect™ customer, you can link to Acrobat Connect content, training, and meetings on a web 

page.

Acrobat Connect is a communication program with the following components: Acrobat Connect Live, Acrobat 

Connect Presentation, Acrobat Connect Training, and Acrobat Connect Manager—a web application that is your 

access and control point for the other three components.

In Acrobat Connect Manager, content (which includes any files used in training, meetings, and so on), training, and 

meetings are organized in folders called libraries. Contribute provides an easy way for you to access and link to items 

in your Acrobat Connect Manager libraries.
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Note: The content, training, and meetings that you can access depend on your Acrobat Connect configuration and your 

permissions.

1 In your draft, place the insertion point where you want the link to appear.

The link text Contribute inserts is the title of the content you link to. For example, if you link to a meeting named 

My Meeting, the link text in your draft is My Meeting. You can change the link text after you insert the link.

Note: If you select text in your draft instead of placing the insertion point, Contribute changes that text to match the 

name of the content you link to. If you select an image in your draft, Contribute places the link text next to the image.

2 Select Insert > Acrobat Connect Link.

The Adobe Acrobat Connect Login dialog box appears if this is the first time you’re inserting an Acrobat Connect 

link after you start Contribute.

3 If the Acrobat Connect Login dialog box appears, enter your Acrobat Connect server URL and user information, 

and then click OK.

The Select Acrobat Connect Account dialog box appears if you have multiple Acrobat Connect accounts.

4 If the Select Acrobat Connect Account dialog box appears, select an Acrobat Connect account, and then click OK.
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The Insert Acrobat Connect Link dialog box appears. This dialog box displays folders that contain the Acrobat 

Connect library items for the Acrobat Connect account you’re connected to.

5 (Optional) To access another Acrobat Connect account, click the Settings button; enter information in the Acrobat 

Connect Login dialog box, and then click OK.

6 Find and select the item you want to link to, and then click OK.

Contribute inserts a link to the item you selected.

Change link text to Acrobat Connect content

❖ In your draft, select the link text, and then type over it.

Set the advanced linking options

The Insert Link dialog box has three advanced linking options: editing the link’s URL, setting a target, and linking to 

a specific place on a page.

See also 

“Create text and image links” on page 177

“Edit links” on page 189

Edit the URL for a link

If you are familiar with creating links in HTML, you can use Contribute to edit a link’s URL. 

When you link to a web page on a website, the link’s URL appears in the Web Address (URL) text box and in the HREF 

text box in the Advanced section of the Insert Link dialog box. Use this HREF text box to alter the URL that Contribute 

places in the page’s HTML.

Note: If the page is new, you’ll see (new) appended to the end of the URL. Contribute removes (new) when you publish 

the new page.
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The Web Address (URL) text box always shows the full URL, and the HREF text box shows the URL that’s written in 

the page’s HTML. The HREF might be a different, usually shorter, version of the URL.

1 In your draft, select an existing link.

Note: To insert a link, see “Create text and image links” on page 177.

2 Do one of the following to open the Insert Link dialog box:

• Select Format > Link Properties.

• Right-click (Windows) or Control-click (Mac OS), and then select Link Properties.

3 Click the Advanced button (Windows) or the expander arrow (Mac OS) to expand the dialog box, if it is not already 

expanded.

4 Change the web address (URL) in the HREF text box.

Note: You might notice that text in the Link text box changes as you enter text in this text box. It is the text in the 

HREF text box that Contribute places in the page’s HTML for the URL.

5 Click OK.

Set a target for your page

You can specify where a linked page opens by creating a target for the link. For example, you can have your linked 

document open in a new window instead of the current window.

If you create a link in a document with frames, you can indicate which frame, or target, displays the new content. For 

more information about creating targets for frames, see “Target frame content” on page 201.

Note: You cannot control where an e-mail link opens. When an e-mail link is clicked, the default e-mail application 

automatically starts.

You can specify the target when you create the link , or you can edit an existing link to change or add the target.

Set a target for a new link

You can specify the target for a link when you create the link.

1 In your draft, create a link (see “Create text and image links” on page 177).

2 In the Insert Link dialog box, click the Advanced button (Windows) or the expander arrow (Mac OS) to expand 

the dialog box, if it is not already expanded.

3 Select a target from the pop-up menu:

Default opens the linked document in the current window. If the page contains frames, the linked page opens in 

the frame that contains the link.

Frame

Page with link
Frame

Frame

New page
Frame
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Entire window opens the linked document in the current window. If the page contains frames, the linked page fills 

the entire window, not just the frame that contains the link.

New window opens the linked document in a new browser window, instead of the current window.

4 Click OK.

Contribute adds the link to your draft.

Set a target for an existing link

1 In your draft, select an existing link.

2 Do one of the following to open the Insert Link dialog box:

• Select Format > Link Properties.

• Right-click (Windows) or Control-click (Mac OS), and then select Link Properties.

3 Click the Advanced button (Windows) or the expander arrow (Mac OS) to expand the dialog box, if it is not already 

expanded.

4 Select a target from the pop-up menu:

Default opens the linked document in the current window. If the page contains frames, the linked page opens in 

the frame that contains the link.

Entire window opens the linked document in the current window. If the page contains frames, the linked page fills 

the entire window, not just the frame that contains the link.

New window opens the linked document in a new browser window, instead of the current window.

Note: If the page you’re linking from was in a frame, a list of frame names appears here. If you choose a frame or type 

a frame name, the linked page appears in that frame when the website visitor clicks the link. 

5 Click OK.

Contribute modifies the existing link with the target information.

Link to a specific place in a page

You can place an invisible marker, called a section anchor, on your page to mark a specific topic or place. You can then 

create links to the anchor, which take website visitors to the specified position on the page with the anchor.

For example, you might add an anchor to the company address and phone number on the Company Information page. 

Then you might add a link with the text “Contact Us!” to your home page. When a website visitor clicks this link, the 

Company Information page opens to the address and phone number section. This way, the user does not need to 

search the Company Information page to find the contact information.

Page with link

Frame

Frame New page
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Add a section anchor

You can add a section anchor to a page, and then link to that anchor from the same page or from another page. For 

more information about section anchors, see “Link to a specific place in a page” on page 186.

1 In your draft, place the insertion point at the beginning of the section where you want the page to open when a 

website visitor clicks the link.

2 Select Insert > Section Anchor.

The Section Anchor dialog box appears.

3 Enter a name for your anchor.

The name cannot begin with a number and cannot contain any spaces. You cannot have two anchors with the same 

name on a web page.

4 Click OK.

Contribute inserts an anchor marker in your draft. 

Note: If you have invisible elements turned off, Contribute turns invisible elements on so that you can see the anchor 

marker. To turn invisible elements off again, select Edit > Preferences and then select Invisible Elements.

See also 

“Edit section anchors” on page 188

Link to a section anchor

You can link to a section anchor when you create the link, or you can edit an existing link to indicate or change a 

section anchor. For more information on section anchors, see “Link to a specific place in a page” on page 186.

1 In your draft, create a link (see “Create text and image links” on page 177).

2 In the Insert Link dialog box, click the Advanced button (Windows) or the expander arrow (Mac OS) to expand 

the dialog box, if it is not already expanded.

3 Select a named anchor from the Section anchor pop-up menu.

Note: All anchors in the page you are linking to appear in the list.

4 Click OK.

Contribute adds the link to your draft.

Indicate an anchor for an existing link

1 In your draft, select an existing link.

2 Do one of the following to open the Insert Link dialog box:

• Select Format > Link Properties.

• Right-click (Windows) or Control-click (Mac OS), and then select Link Properties.
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3 Click the Advanced button (Windows) or the expander arrow (Mac OS) to expand the dialog box, if it is not already 

expanded.

4 Select a named anchor from the Section anchor pop-up menu, or type an anchor name.

All anchors in the page you are linking to appear in the list.

5 Click OK.

Contribute modifies the existing link.

See also 

“Add a section anchor” on page 187

Edit section anchors

After you create a section anchor, you can change its name or delete it.

Note: If you edit a section anchor, links to that anchor will be broken until you fix the link on the page that links to the 

section anchor.

1 In your draft, select the anchor, and then do one of the following:

• Double-click the section anchor.

• Right-click (Windows) or Control-click (Mac OS), and then select Anchor Properties from the pop-up menu.

• Select Format > Anchor Properties.

The Edit Section Anchor dialog box appears.
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2 Change the anchor name.

The name cannot begin with a number and cannot contain any spaces. You cannot have two anchors with the same 

name on a web page.

3 Click OK.

Delete a section anchor

❖ In your draft, select the section anchor, and then press Delete.

See also 

“Add a section anchor” on page 187

“Link to a section anchor” on page 187

Edit links

You can change the text or destination of a link, remove it, or change its properties.

Change link text and destination

After you insert a link, you can later change link text or change the page that the link opens.

Change link text

1 In your draft, select the link text you want to change.

2 Type new text.

Change link destination

1 In your draft, select an existing link.

2 Do one of the following to open the Insert Link dialog box:

• Select Format > Link Properties.

• Right-click (Windows) or Control-click (Mac OS), and then select Link Properties.

3 If you want to change the type of page you link to, click a button at the top of the dialog box; otherwise, skip this step.

4 Select or browse to a new page.

5 Click OK.

See also 

“Change link properties” on page 190

Remove a link

After you insert a link, you can easily remove the link from your text or image.

1 In your draft, select the link you want to remove.
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2 Do one of the following:

• Select Format > Remove Link.

• Right-click (Windows) or Control-click (Mac OS), and then select Remove Link from the pop-up menu. 

The link text or image in the draft is no longer a link.

See also 

“Change link text and destination” on page 189

Change link properties

You can change link properties, including link text and destination and advanced link settings.

1 In your draft, select an existing link.

2 Do one of the following to open the Insert Link dialog box:

• Select Format > Link Properties.

• Right-click (Windows) or Control-click (Mac OS), and then select Link Properties.

3 Change any of the following link properties:

• Link text

You can also change link text by selecting the text in your draft and typing over it.  

• Linked file, web page, or e-mail

• Web address

For more information about the web address, see “Edit the URL for a link” on page 184.

• Anchor

For more information about anchors, see “Link to a specific place in a page” on page 186.

• Target

For more information about setting a target, see “Set a target for your page” on page 185.

4 Click OK.

See also 

“Change link text and destination” on page 189

“Remove a link” on page 189

Test links

Contribute lets you preview a temporary copy of a web page on a web browser or a blog entry draft on a blog server so 

that you can test links.
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Note: If you belong to a user role that cannot publish, you cannot use the Preview in Browser feature to test links.

1 In your draft, select File > Preview in Browser.

Your page appears in your default web browser.

2 Click the links to make sure they open the correct pages (or start your e-mail application).

3 Close the browser preview to return to the draft you’re editing.

Reference

This section provides information about the dialog boxes introduced in this chapter.

Completing the Drafts and Recent Pages section of the Insert Link dialog box

Use the Drafts and Recent Pages section (Windows) or the Drafts section (Mac OS) to insert a link to a draft or a 

recently published page.

1 Enter link text in the Link text text box, if you did not select text or an image in your draft.

This is the text a website visitor clicks to go to another page.

Note: This text box is not available if you selected text or an image in the draft.

2 In the Select a page to link to section, select a web page from the list of drafts and recent pages.

A preview of the page you select appears in the dialog box so that you can confirm that this is the page to which you 

want to link.

3 To set advanced options, click the Advanced button (Windows) or click the expander arrow in front of Advanced 

options (Mac OS), and then make any of the following changes:

• Change the web address (URL) in the HREF text box.

The Web Address (URL) text box always shows the full URL, and the HREF text box shows the URL that’s 

written in the page’s HTML. The HREF might be a different, usually shorter, version of the URL.

• Select a target frame:

Default opens the linked document in the current window. If the page contains frames, the linked page opens 

in the frame that contains the link.

Entire window opens the linked document in the current window. If the page contains frames, the linked page 

fills the entire window, not just the frame that contains the link.

New window opens the linked document in a new browser window, instead of the current window.

• Select a section anchor.

For more information about section anchors, see “Link to a specific place in a page” on page 186.

4 Click OK.
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Completing the Create New Page section of the Insert Link dialog box

Use the Create New Page section to insert a link from an existing or a new web page to a new web page.

1 Enter link text in the Link text box, if you did not select text or an image in your draft.

This is the text a website visitor clicks to go to another page.

Note: This text box is not available if you selected text or an image in the draft.

2 If you have multiple websites, and want to create the new page on a website other than the current one, expand 

another website in the Create new page from pane.

Note: If you don’t have permission to edit files in the folder you select, Contribute saves the new page in the first folder 

that you can edit for that website. If you cannot edit any folders on the website, you cannot create a page for that 

website.

3 Under the expanded website in the Create new page from pane, do one of the following to select a page type:

• Select Blank Web Page to create a blank page.

• Select a page in the Starter Web Pages folder to create a copy of a preexisting sample page. You can use this page 

as a starting point for your web page.

• Select a page in the Templates folder to create a page based on a Dreamweaver template (see Help > Using 

Dreamweaver in Dreamweaver MX), or based on a page on your website that the Contribute administrator 

designated as a template. A template provides a starting point for your page and can provide a consistent look 

across your website.

When you select a page type, a page preview and a description appear. 

Note: If your Contribute administrator has restricted the types of new pages that you can create, you might not see all 

these options when you create a page. For more information, see your Contribute administrator or see “Specify settings 

for new web pages” on page 291.

4 Enter a title for the new page in the New page title text box.

This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

5 To set advanced options, click the Advanced button (Windows) or click the expander arrow in front of Advanced 

options (Mac OS), and then make any of the following changes:

• Change the web address (URL) in the HREF text box.

The Web Address (URL) text box always shows the full URL, and the HREF text box shows the URL that’s 

written in the page’s HTML. The HREF might be a different, usually shorter, version of the URL.

• Select a target frame:

Default opens the linked document in the current window. If the page contains frames, the linked page opens 

in the frame that contains the link.

Entire window opens the linked document in the current window. If the page contains frames, the linked page 

fills the entire window, not just the frame that contains the link.

New window opens the linked document in a new browser window, instead of the current window.

• Select a section anchor.

For more information about section anchors, see “Link to a specific place in a page” on page 186.

6 Click OK.

Contribute adds the link to your draft and then opens the new page in the Contribute editor. 
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Note: Contribute automatically saves the new page in the same folder as the draft that links to it (unless you selected 

another website). When you publish your draft, Contribute also publishes the new page. You can change the folder 

location for the new page then, if you need to.

To return to the draft where you inserted the link, click its title in the Pages panel. 

Completing the Create New Entry section of the Insert Link dialog box

Use the Create New Entry section to insert a link from an existing or a new blog entry to a new blank blog entry. You 

cannot create a link to a new blog entry that belongs to a different blog.

1 Enter link text in the Link text text box, if you did not select text or an image in your draft.

This is the text a blog visitor clicks to go to another page.

Note: Some blogs do not allow images, enclosures, media files, or links to local files in the content. Verify whether your 

blog makes this exception.

2 In the Create new entry from pane, under the expanded blog folder, select Blank Blog Entry to create a blank entry 

in that blog.

Note: You can only create a new entry in the blog that you are currently viewing.

3 Enter a title for the new blog entry in the New entry title text box.

This title appears in the new blog entry.

4 To set advanced options, click the Advanced button (Windows) or click the expander arrow in front of Advanced 

options (Mac OS), and then make the following change:

5 Select a target frame:

Default opens the linked document in the current window. If the page contains frames, the linked page opens in 

the frame that contains the link.

Entire window opens the linked document in the current window. If the page contains frames, the linked page fills 

the entire window, not just the frame that contains the link.

New window opens the linked document in a new browser window, instead of the current window.

6 Click OK.

Contribute adds the link to your draft and then opens the new entry in the Contribute editor. 

Note: Contribute automatically saves the new blog entry in the same folder as the draft that links to it (unless you 

selected another blog). When you publish your draft, Contribute also publishes the new blog entry. 

To return to the draft where you inserted the link, click its title in the Pages panel.  

Completing the Browse to Web Page section of the Insert Link dialog box

Use the Browse to Web Page section to insert a link to a web page on your website or on another website.

1 Enter link text in the Link text text box, if you did not select text or an image in your draft.

This is the text a website visitor clicks to go to the new page.

Note: This text box is not available if you selected text or an image in the draft.



194USING CONTRIBUTE CS4

Working with links

2 Click the Browse button to browse to the file, or click the Choose button to use the file system to find the page you 

want to link.

If you clicked the Browse button, you can copy and paste the web address instead of browsing to the page.  

3 To set advanced options, click the Advanced button (Windows) or click the expander arrow in front of Advanced 

options (Mac OS), and then make any of the following changes:

• Change the web address (URL) in the HREF text box.

The Web Address (URL) text box always shows the full URL, and the HREF text box shows the URL that’s 

written in the page’s HTML. The HREF might be a different, usually shorter, version of the URL.

• Select a target frame:

Default opens the linked document in the current window. If the page contains frames, the linked page opens 

in the frame that contains the link.

Entire window opens the linked document in the current window. If the page contains frames, the linked page 

fills the entire window, not just the frame that contains the link.

New window opens the linked document in a new browser window, instead of the current window.

4 To set advanced options, click the Advanced button (Windows) or click the expander arrow in front of Advanced 

options (Mac OS), and then make any of the following changes:

• Change the web address (URL) in the HREF text box.

The Web Address (URL) text box always shows the full URL, and the HREF text box shows the URL that’s 

written in the page’s HTML. The HREF might be a different, usually shorter, version of the URL.

• Select a section anchor.

For more information about section anchors, see “Link to a specific place in a page” on page 186.

5 Click OK.

Contribute adds the link to your draft.

Using the Browse to Link dialog box

Use the Browse to Link dialog box to find a page. The browser in this dialog box functions just as the Contribute 

browser does.

1 Click links in the current page, or type a web address (URL) in the Address text box, and then click Go to find a 

page.

2 Click the Choose button in the toolbar if you prefer to view your website directory structure to find the page.

When you click the Choose button, you can view only those pages that are on websites you’re connected to.

3 Click the navigation buttons in the toolbar in the dialog box as necessary:

Note: In Mac OS, the navigation icons do not have labels. If you need help identifying an icon, position the pointer 

over the icon to see a tooltip.

Back returns to the previous page.

Forward advances a page.

Stop cancels the page download.

Refresh updates your view of the page.
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Home Pages lets you select the home page of a website you’re connected to.

4 Click OK to select the page you are viewing.

Completing the E-mail section of the Insert Link dialog box

Use the E-mail section to insert a link to an e-mail address.

1 Enter link text in the Link text text box, if you did not select text or an image in your draft.

This is the text that a website visitor clicks to send an e-mail message.

Note: This text box is not available if you selected text or an image in the draft.

2 Enter the e-mail address in the E-mail address text box.

3 To set the advanced option, click the Advanced button (Windows) or click the expander arrow in front of 

Advanced options (Mac OS), and then change the web address (URL) in the HREF text box.

The Web Address (URL) text box always shows the full URL, and the HREF text box shows the URL that’s written 

in the page’s HTML. The HREF might be a different, usually shorter, version of the URL.

4 Click OK.

Contribute adds the link to the page.

Completing the File on My Computer section of the Insert Link dialog box

Use the File on My Computer section to insert a link to a file saved on your computer.

1 Enter link text in the Link text text box, if you did not select text or an image in your draft.

This is the text a website visitor clicks to go to another page.

Note: This text box is not available if you selected text or an image in the draft.

2 Beside the File to link to text box, click the Browse button to find the file you want to link to, and then click Select 

(Windows) or Choose (Mac OS) to close the dialog box.

3 To set advanced options, click the Advanced button (Windows) or click the expander arrow in front of Advanced 

options (Mac OS), and then make any of the following changes:

• Change the web address (URL) in the HREF text box.

The Web Address (URL) text box always shows the full URL, and the HREF text box shows the URL that’s 

written in the page’s HTML. The HREF might be a different, usually shorter, version of the URL.

• Select a target frame:

Default opens the linked document in the current window. If the page contains frames, the linked page opens 

in the frame that contains the link.

Entire window opens the linked document in the current window. If the page contains frames, the linked page 

fills the entire window, not just the frame that contains the link.

New window opens the linked document in a new browser window, instead of the current window.

• Select a section anchor.

For more information about section anchors, see “Link to a specific place in a page” on page 186.

4 Click OK.

Contribute copies the file to create a page on your website. A link to the new page appears in your draft.
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Setting the Acrobat Connect Login dialog box options

Use the Acrobat Connect Login dialog box to log in to your Acrobat Connect account so that you can link to items in 

your Acrobat Connect libraries.

To log in to your account:

1 Enter the URL for your Acrobat Connect server.

This is the same URL you use to access the Acrobat Connect Manager in a browser.

For example, http://somename.acrobatconnectcentral.com or http://acrobatconnect.somename.com.

2 Enter your Acrobat Connect login and password.

The Acrobat Connect login is usually your e-mail address. The Acrobat Connect password is the password the 

Acrobat Connect administrator assigned to you.

3 Click OK.

Contribute connects to your Acrobat Connect account and lets you access items in your Acrobat Connect libraries.

See also 

“Link to Adobe Acrobat Connect content, training, and meetings” on page 182

Setting the Select Acrobat Connect Account dialog box options 

The Select Acrobat Connect Account dialog box appears if you have multiple Acrobat Connect accounts. Use this 

dialog box to select the Acrobat Connect account that contains the item you want to link to.

1 Select an Acrobat Connect account from the pop-up menu.

2 Click OK.

Contribute connects to the Acrobat Connect account you selected and lets you access items in your Acrobat 

Connect libraries.

See also 

“Link to Adobe Acrobat Connect content, training, and meetings” on page 182

Setting the Insert Acrobat Connect Link dialog box options

Use the Insert Acrobat Connect Link dialog box to select the Acrobat Connect content, course, or meeting you want 

to link to.

1 Navigate to and select the item you want to link to.

Note: If at any point you need to move to a higher folder level, use the Look in pop-up menu to select a folder, or click 

the Up One Level icon beside the Look In pop-up menu.

2 (Optional) To log in to another Acrobat Connect account, click the Settings button to enter new account 

information in the Acrobat Connect Login dialog box.

When you change accounts, the Insert Acrobat Connect Link dialog box displays items in the Acrobat Connect 

libraries for the new account.

3 After you select an item, click Open.

Contribute inserts a link to the selected item on your draft.
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See also 

“Link to Adobe Acrobat Connect content, training, and meetings” on page 182

Completing the Section Anchor dialog box

Use the Section Anchor dialog box to name a section anchor.

1 Enter a name for your anchor.

The name cannot begin with a number and cannot contain any spaces. You cannot have two anchors with the same 

name on a web page.

2 Click OK.

Contribute inserts an anchor marker in your draft. 

Note: If you have invisible elements turned off, Contribute turns invisible elements on so that you can see the anchor 

marker. To turn invisible elements off again, select Edit > Preferences and then select Invisible Elements.

Completing the Edit Section Anchor dialog box

Use the Edit Section Anchor dialog box to change the name of a section anchor.

1 Change the name of the anchor.

The name cannot begin with a number and cannot contain any spaces. You cannot have two anchors with the same 

name on a web page.

2 Click OK.
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Framesets divide a browser window into multiple frames or regions, each of which can display different content. You 

design pages with frames in an HTML design application, such as Adobe Dreamweaver. You can edit pages with 

frames in Adobe® Contribute®.

Note: For more information about creating pages with frames in Dreamweaver, see Dreamweaver Help (Help > Using 

Dreamweaver).

About frames

A web page designed with frames displays different content in different regions of a web browser. This design is 

typically used to display content that doesn’t change, such as a navigation bar, in one area and content that changes in 

the main content area.

For example, a web page might have one narrow frame on the left side that contains navigation links, one frame along 

the top that contains the logo and title of the website, and one large frame that takes up the rest of the page and displays 

the main content.

A. Navigation frame  B. Title and logo frame  C. Main content frame.  

A

B

C
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See also 

“Edit frame content” on page 199

“Save and publish a page with frames” on page 200

“Target frame content” on page 201

Understanding frames and framesets

A page that contains frames is called a frameset. A frameset is an individual file that defines the layout and properties 

of all the frames on a page, including the number of frames, the size and placement of the frames, and the web address 

(URL) of the page that initially appears in each frame. 

A frame is an organizational element of a frameset page. It’s easy to think of the page that’s currently displayed in a 

frame as an integral part of the frame, but each frame is just a container for a page. Pages that initially load in the frames 

are referenced by the frameset, but any page can be loaded in a frame.

The content that appears in each frame is saved in separate files. A page with three frames—navigation, logo, and main 

content—actually has four files: the frameset and three web pages, one for each frame. When a website visitor clicks a 

link in one frame, a new page can be loaded in another frame. There can be a different page for each link in a frame.

A frame can load pages from the same or different websites. So you might be able to edit content in some, but not all, 

frames.

See also 

“Edit frame content” on page 199

About targeting a frame

To use a link in one frame to open a new page in another frame, you must set a target for the link. Selecting a frame in 

which to open a page is called targeting a frame.

Each link in a frameset should have a target—a frame in which to open the page when the user clicks the link. For 

example, the main frame might be the target for multiple links, so that the content of the main frame changes each 

time the user clicks a link in the navigation frame. 

Note: If you don’t specify a target for a link, Contribute uses the Default option and opens the new page in the frame that 

contains the link.

When you add a link to a page in a frameset, you can indicate a target frame for the page you’re linking to. The frameset 

designer should have given each frame a name so that you can select specific frames as targets. You can also change 

the target after you’ve inserted the link by editing the link properties (see “Edit links” on page 189).

See also 

“Target frame content” on page 201

Edit frame content

When you browse to a page with frames, you can use Contribute to change content in any of the frames, as long as you 

have permission. 
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For more information about frames and framesets, see “About frames” on page 198.

1 Browse to the page with frames to edit, and then click the Edit Page button.

The Select a Frame to Edit dialog box appears, with a list of page titles and web addresses (URLs) for the pages in 

frames.

2 Select the frame you want to edit.

When you select a frame, a border appears around that frame in the Contribute editor.

A.  Selected frame in the dialog box  B. Selection indicator in the editor.  

Note: A lock icon appears beside the page name if you can’t edit it. The lock means that you do not have permission 

to edit that frame’s content or that another user is currently editing the page.

3 Click Edit.

A draft for the frame you selected appears in the Contribute editor without the other frames.

4 Edit the content as you normally would.

5 When you are ready to publish, see “Save and publish a page with frames” on page 200.

Save and publish a page with frames

A frameset is made up of individual web pages. When you edit a page that appears in a frame, you alter only the page 

you edit—not the frameset. Publishing a page that appears in a frameset is the same as publishing a page that isn’t in 

a frameset. Because you do not actually alter the frameset page, you do not need to publish it.

A

B



201USING CONTRIBUTE CS4

Working with pages with frames

After you finish editing a page in a frame (see “Edit frame content” on page 199), you have the following options before 

you publish the page:

• Click Cancel in the toolbar (see “Discard a draft, new page, or new blog entry” on page 70).

The individual frame in the frameset appears in Contribute without your changes. Click Back in the toolbar to 

return to the frameset page.

• Select File > Preview in Browser (see “Preview a page in your default browser” on page 207). 

The individual frame showing your changes appears in a browser.

• Click Send for Review in the toolbar (see “Send web page drafts and files for review” on page 56). 

Contribute sends the draft to another user for review.

Publish a page that appears in a frame

❖ In your draft, click Publish (see “Publishing a page to your website” on page 203).

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.

Contribute displays the frameset with the updated page loaded in the correct frame.

Note: If you publish changes to a frameset that is nested (a frameset in a frameset), the child nested frameset that you 

changed appears in Contribute. If there are multiple nested framesets, only the first frameset containing the edited 

page appears.

Target frame content

You can change the content that appears in a frame by creating links in one frame that open pages in another frame.

For more information, see “About targeting a frame” on page 199.

Insert a link and select a target frame for the linked page

1 Browse to the page with frames to edit, and then click the Edit Page button.

The Select a Frame to Edit dialog box appears.

2 Select the frame in which you want to add a link that opens a new page in another frame, and then click Edit.

A draft for the frame you selected appears in the Contribute editor.

3 Place the insertion point in your draft where you want the link to appear or select text or an image.

4 Do one of the following:

• Select Insert > Link, and then select a type of page from the pop-up menu.

• Click Link  in the toolbar, and then select a type of page from the pop-up menu.

The Insert Link dialog box appears.

5 Complete the dialog box.

The options in the dialog box vary according to the type of page you are linking to. 

For more information on completing the dialog box, see “Create text and image links” on page 177.

For information about options in the dialog box, click the Help button.
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6 In the Insert Link dialog box, click the Advanced button to expand the dialog box, if it is not already expanded.

7 In the Target frame pop-up menu, select the frame where you want the linked page to open. You can either enter a 

custom-named frame in the Target frame text box (which opens the page in that frame) or select one of the 

following frame targets:

Default opens the page in the same frame as the current page.

Entire Window replaces the frameset with the page.

New Window opens the page in a new browser window.

8 Click OK.

The link appears in your draft.

Note: If you created a link to a new page, the new page draft appears. Return to the draft where you added the link.

9 Click Publish.

The page in a frame appears, with updated content in the frame you edited.

See also 

“About targeting a frame” on page 199

Reference

This section provides information about the dialog box introduced in this chapter.

Completing the Select a Frame to Edit dialog box

Use the Select a Frame to Edit dialog box to select the frame content you want to edit.

To complete the Select a Frame to Edit dialog box:

1 Select the frame you want to edit.

Note: A lock icon appears beside the page name if you can’t edit it. The lock means that you do not have permission 

to edit that frame’s content or that another user is currently editing the page.

When you select a frame, a border appears around that frame in the Contribute editor.

2 Click Edit.

A draft for the frame you selected appears in the Contribute editor without the other frames.

See also 

“Edit frame content” on page 199

“About frames” on page 198
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Publishing a draft makes it live on your website or blog, so your visitors can view the page. If the page was previously 

published, Contribute replaces the existing page with the updated page.

For information on how workflows affect the publishing process, see “The draft review process” on page 46.

Publishing a page to your website

Before you publish your draft, you can preview it in your browser. You can also make the draft available to others for 

approval or feedback before you publish the draft (see “Send web page drafts and files for review” on page 56). If you 

decide not to publish your draft, you can cancel it, leaving the published version of the page as is. 

If the draft you’re publishing was already on your website, Adobe® Contribute® replaces the existing page with your 

updated version. You can also make updates to an existing page, and then publish it as a new page without altering the 

original page. 

If the draft you’re publishing is a new page that was not on your website or blog, Contribute adds it to your website or 

blog. For new pages, Contribute asks you to name the file for the page before you publish. 

You can revert to a previous version of the page after publishing if the administrator has enabled the Page Rollback 

feature.

When you publish a web page, Contribute rewrites all dependent links in the current page. It also rewrites links to the 

current page in all its parents. Contribute rewrites all the "file:///" links as relative links. The options specified in the 

Administer Website dialog box decide the type of relative link that is chosen. For more information on link settings, 

see “Specify the type of path for links in a website” on page 250.

Close all linked files open in Contribute or the in-browser editor before you publish a web page. Close a web page if it 

has a dependent file that is shared with the file being published.

When a web page is published, its dependent files and linked pages with the same workflow as the web page are also 

published. Enable this option when publishing the page. 

If the linked page has a different workflow than the page being published, the location for the page that is published 

later is finalized on the site but the file is not published. All dependent files of the published file are published along 

with the published page. Shared dependent files are also published. However, dependent files exclusive to the linked 

page are published with the linked page.

For example, consider the following case:

• Page1.htm is based on the template template1.dwt with the workflow Author > Publish.

• Page2.htm is based on the template tempate2.dwt with the workflow Author > Review > Publish

• Page1.htm is associated with the dependent files (assets) wav1.mp3, and video1.mpeg.

• Page2.htm is associated with the wav1.mp3 and video2.mpeg files as its dependent files (assets). 
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When Page1.htm is published, the dependent files wav1.mpeg and video1.mpeg are also published. The location of 

Page2.htm is finalized on the site but it is not published until the workflow is complete. The dependent file 

video2.mpeg is published only when Page2.htm gets published.

Note: You can publish a file only if you have the permissions to publish it.

You can publish any of the following types of pages to your website:

• Updates to an existing page 

• New page, not previously published 

• Existing page as a new page

Publish updates to an existing page

When you publish updates to an existing page, Contribute replaces the currently published version of the page on your 

website with the new version.

For information on how linked pages are handled during publishing, see “The draft review process” on page 46.

Note: To replace an existing page on your website with a page that has the same filename, delete the existing page on your 

website (see “Delete a web page or blog entry” on page 70) and then publish the replacement page. If you do not have 

permission to delete pages, contact your Contribute administrator.

1 In your draft page, click the Publish button in the toolbar.

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.

If the draft contains links to any new pages, the Publish New Linked Pages dialog box appears.

2 If the Publish New Linked Pages dialog box appears, for each unpublished linked page, select the page name, file 

name, and folder location.

3 To publish all linked pages with the same workflow as the page being published, select Publish All Dependent Pages 

Whose Workflow Is The Same As The Main Page.

Note: For linked pages with a different workflow, the location on the site is finalized, but the pages are not published 

until their workflow is complete. 

4 To set a different expiry date than the one set by the administrator for the web page, select the date in the Page 

Expires On option. (Optional.)
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5 Click Publish.

For more information, see “Completing the Publish New Linked Pages dialog box options” on page 222. 

For information about options in the dialog box, click the Help button.

Contribute publishes the draft (and any new pages it links to) to your website, and then displays it in the Contribute 

browser.

Publish a new page to your website

When you publish a new page to your website, Contribute asks you to name the file for the page and any other new 

pages the page links to. Contribute publishes the new page and all pages it links to on your website. Publishing all pages 

that are linked from the new page helps ensure that you do not have broken links on your website.

If you haven’t added a link on an existing page to your new page, website visitors won’t be able to view the page. 

Remember to go to an existing web page before (or just after) you publish a new page, and add a link to the new page 

(see “Link to a draft or a recently published page on your website” on page 177).

You can create a link to the page at the same time that you create the page. For more information, see “Link to a new 

page” on page 178. 

1 In the new page draft you’re editing, click the Publish button in the toolbar.

Note: You must have publish permissions assigned to your role to publish a page assigned to you. Contact your site 

administrator for details. Depending on the role the Contribute administrator assigned you, you might not be able to 

publish.

The Publish New Page dialog box appears.

2 Change the filename. Click the Choose Folder button to save this draft in another location on your website.

For more information, see “Completing the Publish New Page dialog box options” on page 222. 

For information about options in the dialog box, click the Help button.

Note: Contribute automatically saves the file with the same name as the page title. 

3 Click Publish or Next.

Note: You will be prompted to link a new page to an existing page. After you publish the new page, be sure to create a 

link to it (see “Link to a draft or a recently published page on your website” on page 177).
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If your new page draft links to any other new pages, the Publish New Linked Pages dialog box appears.

4 If the Publish New Linked Pages dialog box appears, for each unpublished linked page, select the page name, file 

name, and folder location.

5 To publish all linked pages with the same workflow as the page being published, select Publish All Dependent Pages 

Whose Workflow Is The Same As The Main Page.

Note: For linked pages with a different workflow, the location on the site is finalized, but the pages are not published 

until their workflow is complete. 

6 To set a different expiry date than the one set by the administrator for the web page, select the date in the Page 

Expires On option. (Optional.)

7 Click Publish.

For more information, see “Completing the Publish New Linked Pages dialog box options” on page 222. 

For information about options in the dialog box, click the Help button.

Contribute publishes the new page to your website and displays it in the Contribute browser.

Publish an existing page as a new page

Contribute lets you update an existing page and then publish it as a new page without overwriting the original page. 

This feature is similar to the Save as feature in other applications.

For example, suppose you open the product page for men’s cargo pants and start updating the page with information 

about women’s cargo pants for your company website. Then you realize that you forgot to make a copy of the existing 

page before you made edits. As long as you don’t click Publish, the original page is unchanged. Use the Publish as New 

Page feature to publish the modified page as a new page on your website.

This is possible because when you click Edit Page for an existing page, Contribute creates a copy of the page (known 

as a draft) for you to edit. Saving changes to the draft does not alter the page on your website. 

1 Browse to an existing page, and then click the Edit Page button.

2 Make changes to the draft.

3 Select File > Actions > Publish as New Page.

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.

Contribute warns you if have not linked the new page from an existing page. After you publish the new page, be 

sure to create a link to it (see “Link to a draft or a recently published page on your website” on page 177).

The Publish as New Page dialog box appears. 

4 You can change the page title and filename for the draft, and then click the Choose Folder button beside the 

filename to save this draft in another location on your website.

Note: Contribute automatically saves the file with the same name as the page title. 

For more information, see “Completing the Publish As New Page dialog box options” on page 223. 

For information about options in the dialog box, click the Help button.

5 To set a different expiry date, select the date in the Page Expires On option. (Optional.)

6 Click Publish or Next.
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If your new page draft links to any other new pages, the Publish New Linked Pages dialog box appears.

7 If the Publish New Linked Pages dialog box appears, for each unpublished linked page, select the page name, file 

name, and folder location.

8 To publish all linked pages with the same workflow as the page being published, select Publish All Dependent Pages 

Whose Workflow Is The Same As The Main Page.

Note: For linked pages with a different workflow, the location on the site is finalized, but the pages are not published 

until their workflow is complete. 

9 To set a different expiry date than the one set by the administrator for the linked web page, select the date in the 

Page Expires On option. (Optional.)

10 Click Publish.

For more information, see “Completing the Publish New Linked Pages dialog box options” on page 222. 

For information about options in the dialog box, click the Help button.

Contribute publishes the draft to your website and then displays it in the Contribute browser. 

Preview a page in your default browser

When you edit a draft in Contribute you can easily view your changes in a browser at any time, to ensure that your 

changes appear as you intend in the browser. Previewing your page also gives you an opportunity to test your links 

before you publish the page.

You can view the source code for a page when you preview it in the browser.  

Note: If the Contribute administrator assigned you to a role that cannot publish, you cannot use the Preview in Browser 

feature.

❖ Do one of the following:

• Select File > Preview in Browser.

• Press the F12 key.
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Publish a file from your computer to your website

You can add a document or file (except HTML pages) directly to your website from your computer. 

You can also add documents or files, including HTML pages, to your website by linking to the them from a draft. For 

more information, see “Link to a file on your computer” on page 181.

Note: You must have the required permissions to add files to your website.

To replace an existing page on your website with the contents of a file that’s saved on your computer, see “Replace a 

file on your website” on page 209. 

1 Select File > Publish File from My Computer.

To have the file reviewed before you publish it, or if you can’t publish to the website, select File > Send File from 

My Computer to send the file for review. For more information, see “Send a file for review” on page 58.

The Select File dialog box appears.

2 Select the file you want to add to the website, and then click Select.

Note: You cannot select HTML, executable, or template files. If you select an invalid file type, Contribute warns that 

you cannot select this file and provides a complete list of invalid file types.

If you have connections to more than one website, the Select Website dialog box appears.

3 If the Select Website dialog box appears, select the website where you want to add the file from your computer.

The website list includes any website you are connected to and have permission to publish to. 

The Publish New Page dialog box appears.

4 You can change the filename, and then click the Choose Folder button to save this draft in another location on your 

website.

To replace an existing file on your website with the file you are publishing, change the name of the file to match the 

name of the existing file and make sure you choose the folder that contains the file you want to replace. 

5 Click Publish.
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If the draft has the same name as an existing file on your website, the Replace File dialog box appears.

6 If the Replace File dialog box appears, select to either replace the existing file with the one you are trying to publish 

or leave the existing file on the website and publish the new file with a similar filename, and then click OK.

The file is added to your website. Remember the web address (URL) for the page or go ahead and link the new page 

from another page, so that you can easily get back to it.

Use Contribute to edit this file after you publish. Changes you make to the original file on your computer after 

publishing do not appear on your website.

See also 

“Add Microsoft Word and Excel documents to a website” on page 94

Replace a file on your website

You can replace a file on your website with a file on your computer. 

For example, suppose you post the quarterly earnings spreadsheet on your website each quarter. You can easily replace 

the current live version with the new spreadsheet saved on your computer.

There are two ways to replace a file:

• Publish the file directly from your computer.

• Link to the file from a draft.

Replace an existing file by publishing directly from your computer

1 Select File > Publish File from My Computer.

The Select File dialog box appears.

2 Select the file you want to add to the website, and then click Select File.

Note: You cannot select HTML, executable, or template files. If you select an invalid file type, Contribute warns that 

you cannot select this file and provides a complete list of invalid file types.

If you have connections to more than one website, the Select Website dialog box appears.

3 If the Select Website dialog box appears, select the website that contains the current version of the file you are 

replacing, and then click OK.
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The Publish New Page dialog box appears.

4 Change the filename, if necessary, to make sure it matches the name of the file you’re replacing; also, make sure you 

choose the folder that contains the file you want to replace.

5 To set a different expiry date than the one set by the administrator for the web page, select the date in the Page 

Expires On option. (Optional.)

6 Click Publish.

The Replace File dialog box appears.

7 Select the Replace file name with your version option, and then click OK.

Contribute replaces the existing file on your website with the file from your computer. 

Use Contribute to edit this file after you publish. Changes you make to the original file on your computer after 

publishing do not appear on your website.

Replace a file by linking to a file on your computer

1 Browse to the page that contains the link to the file you want to replace, and then click the Edit Page button.

2 In the draft, select the link to the file you’re replacing, and then click the Link button in the toolbar and select File 

on My Computer.

The Insert Link dialog box appears. The File on My Computer button should be selected at the top of the dialog box.

3 Click the Browse button, and then navigate to and select the file on your computer you want to link to.

Note: You cannot select HTML, executable, or template files. If you select an invalid file type, Contribute warns that 

you cannot select this file and provides a complete list of invalid file types.
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The filename for the new file must exactly match the filename for the file you are replacing. If the names do not 

match, Contribute does not replace the file.

4 Click OK to close the Insert Link dialog box.

5 In your draft, click the Publish button. 

The Replace File dialog box appears.

6 Select the Replace the file option, and then click OK.

Contribute publishes the file from your computer and updates the link in the draft to replace the old file with the 

new file from your computer.

Use Contribute to edit this file after you publish. Changes you make to the original file on your computer after 

publishing do not appear on your website.

Roll back to a previous version of a page

You can use the Rollback feature to revert to a previous version of any published page. You do not have to roll back to 

the last published version; you can select any version that Contribute has saved as a rollback file.

When you roll back to a previous version of a page, Contribute reverts to the previous text contained in the version of 

the page you select. However, any assets imported into the page may or may not be recovered. For example, suppose 

you update an image file outside of Contribute and then replace the original image with another image using the same 

filename. In this case, Contribute cannot roll back to the previous version of the image because Contribute does not 

manage assets outside the web pages it creates.

Contribute does, however, maintain the older version of an image if you use Contribute to edit the image in an external 

application. Contribute considers images, Microsoft Word documents, and other content that you edit in an external 

application as assets. You can roll back assets that you’ve edited through Contribute the same way that you roll back 

pages.

For example, suppose you roll back from version C of a page to version A, and you used Contribute to edit an image 

in version B. When you roll back to version A, you do not see the current version of the image. You need to also roll 

back the image, independently of the page rollback.

To provide an extra degree of safety in publishing, Contribute lets you undo any web page you publish and roll back 

to a previously published version of that web page.

Note: The Rollback feature is only available if your Contribute administrator enabled it. For more information, see your 

Contribute administrator or see “Enable or disable rollbacks” on page 243.

1 Browse to the page to roll back.

2 Select File > Actions > Roll Back to Previous Version.
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The Roll Back Page dialog box appears. 

3 Select a previous version of the published page from the list of available pages. 

Note: The list of previously published pages shows a number of previous versions of the page, depending on your 

Contribute administrator’s setting. 

Contribute displays the page in the Preview section.

4 If the page you selected is the one you want to publish, click the Roll Back button. If the page is not the one you 

want to publish, select another page from the list, and then click Roll Back.

Contribute replaces the currently published version of the page with the previously published version that you 

selected. The version you selected becomes the current version on the website.

Note: The page you replace with the selected rollback page appears in the Roll Back Page dialog box the next time you 

open the dialog box so you can roll back to that version if you need to.

Publish a document from Microsoft Office (Windows 
only)

You can publish documents from Microsoft Word, Excel, and Outlook e-mail reader to your website without opening 

the Contribute application. You can also associate templates with these documents before publishing them. For 

example, you can create standard templates using Adobe Dreamweaver, and attach the templates to an Office 

document while opening the document in Contribute, or publishing it to your corporate website using Contribute.

For information on how templates with workflows are handled in Contribute, see “The draft review process” on 

page 46.

Next time you want to change the look and feel of your Office documents on the corporate website, you only need to 

update the document's associated template. The Contribute plug-ins in these applications make the publishing process 

fast and efficient.
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Templates and editable regions of templates listed in your desktop client are periodically updated with the latest 

templates and template content available on the server, automatically. In Adobe Contribute you can also manually 

synchronize these components using the Refresh option.

1 Open a Microsoft Office application file.

2 (Optional) To publish only a specific section of the document, select the section.

Note: You cannot publish a selection in an e-mail message in Microsoft Outlook if the message format is Plain Text.

3 To publish the file, do one of the following:

Note: Before you publish, you must save the document if you made any changes.

• Select Contribute > Publish To Website.

• Click the Publish To Website button in the toolbar.

Note: You cannot use the Publish to Website option for .rtf files.

The Publish To Website dialog box appears.

4 To select the settings for publishing the document, do the following:

a Select a website where you want to publish the file.

Note: If you do not have a connection to your website before you publish a document, you can always create one 

by selecting Create New Connection in the Select pop-up menu in the Publish To Website dialog box. For more 

information on creating a website connection, see “Create a website connection” on page 231.

b Select a location for storing the file.

c Enter a filename.

Note: The filename must not have any spaces, tabs, or alphanumeric characters.

d Select a format.

e Click the Choose Template button. The Choose Template dialog box appears.

If you do not click the Choose Template button in the Publish to Website dialog box, the template that was last 

used to publish a Microsoft Office document is associated with the document you are currently publishing. In 

addition, if the template does not match the template on the server, Contribute displays the Download Template 

dialog box. You can choose to do one of the following:

• Click the Publish using the old template button to publish the document using the old template.
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• Click the Download and Publish button to download the updated template from the server, and then publish 

the document.

Note: The Choose Template button is disabled when the native format is selected. 

f Select a template from the list of available templates.

The Preview of the selected template appears in the Preview box.

g If the template you select for publishing an Office document to a website has been updated on the server, the 

Open as New Page dialog box appears. You can choose to publish using the old template, or download the 

updated template available on the server, and then publish the document.

h Select a template region from the list of editable regions available in the selected template.

This list is disabled if you select _blank template.

i Click the Refresh Templates button, and select one of the following options to update your list of templates and 

editable regions in a selected template:

For this website to view an updated list of templates for the selected website

For selected template to view an updated list of editable regions in the selected templates

j By default, the Make this as the default template check box is selected.

Clear this check box, if desired.

k Click OK.

l (Optional) In the Page Expires On field, select an expiry date for the page.

m (Optional) Clear the Publish current selection only check box to publish the whole document instead of the 

selection.

5 Click Publish.

Contribute publishes the document to your website, and a confirmation dialog box appears.

6 Click OK.

The selected template is applied to the web page containing the Office document, and the document is published 

in the HTML format.

Note: If you open or publish a document in Contribute without clicking the Choose Template button in the Publish to 

Website or Open as New Page dialog box, the last template stored in the registry is applied to the web page containing 

the Office document. If you are performing the Publish to Website or Open in Contribute operation for the first time, 

then a blank template is selected.

Post content to a blog

With Contribute, you can now post content directly to your blog without opening the blog site. You can use the Post 

To Blog plug-ins to post content to your blog from a browser or from Microsoft Office applications such as Word, 

Excel, and Outlook e-mail reader. With the Post To Blog plug-in from a web page in your browser or a document in a 

Microsoft Office application, you can transfer the page contents to the Contribute editor, make changes to the content, 

and then post the content to your blog.
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Post content to a blog from a browser

You can use the Contribute plug-ins in your browser to post web pages from a browser such as Internet Explorer and 

Mozilla Firefox to your blog. You can use the Post To Blog plug-in from a web page in your browser, transfer the page 

contents to the Contribute editor, make changes to the content, and then post the content to your blog.

Note: You must install the browser plug-ins to use this feature. This feature is available only on selected browser versions 

and operating systems. For a complete list of supported browsers and operating systems, see “Edit a web page or blog from 

your browser” on page 52.

1 Open or navigate to the page in the browser that has the content you want to publish to your blog.

You must have a connection to your blog before you post a page. For more information, see “Create a blog server 

connection” on page 233. 

2 Select the content in the web page to post.

3 Click Post To Blog in the toolbar.

The selected content in the web page appears in the Contribute editor.

4 Make any necessary changes.

Note: Some blogs do not allow images, enclosures, media files, or links to local files in the content. Verify if your blog 

makes this exception.

5 To post this content to a different blog, select a blog from the Blog pop-up menu in the Contribute editor.

You can also set these preferences in the Blog Defaults tab from the Edit menu in Contribute. Select Edit > 

Preferences > Blog Defaults (if it is not already selected), and select a blog from the Default Blog pop-up menu. For 

more information on setting these preferences, see “Set Contribute preferences” on page 30.

6 Click Publish.

See also 

“Post content to a blog from RSS aggregators” on page 217

“Edit a web page or blog from your browser” on page 52

Post content to a blog from Microsoft Office applications (Windows only)

You can post documents from Microsoft Office applications such as Word, Excel, and Outlook e-mail reader to your 

blog. You can use the Post To Blog plug-in in a document in Word, Excel, or Outlook e-mail reader, transfer the page 

contents to the Contribute editor, make changes to the content, and then post the content to your blog.

Note: You can post an e-mail message in Microsoft Outlook to your blog only if the message format is HTML.

You can publish a document to a web page in the document’s default format (as a .doc/.docx file in Word or a 

.xls/.xlsx/.xlsm file in Excel) in the .htm format, or as a PDF. Microsoft Outlook documents can be published only as 

.htm files.

1 Open a file in a Microsoft Word or Excel.

You must have a connection to your blog before you post a page. For more information, see “Create a blog server 

connection” on page 233. 

2 Select the content you want to post to a blog entry in Contribute.
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3 To post the selection, do one of the following:

Before you post to your blog, save the document if you made any changes.  

• Select Contribute > Post To Blog.

• Click Post To Blog in the toolbar.

The Insert Microsoft Office Document dialog box appears.

4 Select from the following options:

Note: These options are available for Microsoft Word and Excel only.

Insert the contents of the document into this page to copy the content of the selected document into the draft.

Create a link to the office document to insert a link to the selected document.

Convert to PDF and create a link to the PDF to convert the selected document into a PDF, and insert a link to the 

PDF document.

Convert to PDF and embed the PDF as Object to convert the selected document into a PDF, and embed the PDF 

document as an object.

5 (Optional) Select the Remember this setting and don’t ask again check box if you do not want to be asked about the 

insert option in the future.

You can also set these preferences in the Microsoft Documents tab from the Edit menu in Contribute. To do this, 

select Edit > Preferences > Microsoft Documents and make a selection. For more information on setting these 

preferences, see “Set Contribute preferences” on page 30.

For information about options in the dialog box, click the Help button.

6 Click OK.

The selected content appears in the Contribute draft of your blog entry, or a link to the selected content is inserted 

in the blog entry draft. If you converted the document to a PDF, Contribute inserts a link to the PDF or embeds the 

PDF as an object.

7 In the Date area, set the date and time when you want to schedule the publishing of your document. The blog entry 

will be published only on the specified date and at the specified time and not when you click the Publish button.

Note: The publishing date and time settings are honored by compatible blog servers only.
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A.  Quoted from  B. Page title  C. Inserted content.  

8 Make any desired changes.

Note: Some blogs do not allow images, enclosures, media files, or links to local files in the content. Verify whether your 

blog makes this exception.

9 Click Publish.

Post content to a blog from RSS aggregators

With Contribute, you can easily post content such as news items to your blog from RSS aggregators. You can set 

Contribute as your blog publishing tool in RSS aggregators such as FeedDemon (Windows) and NetNewsWire (Mac 

OS). You can now post your favorite news clips to your blog and also add your own comments before you post it.

You can use Contribute in RSS aggregators such as FeedDemon (in Windows) and NetNewsWire (in Mac OS). You 

can configure Contribute in these RSS aggregators and post your favorite news items with your comments to your blog.

Configure Contribute in FeedDemon (Windows)

FeedDemon is a desktop RSS aggregator for Windows. You can configure Contribute in FeedDemon and post news 

entries to your blog. You can transfer the contents of the news entry to Contribute, add your own comments, and post 

to your blog. For more information on installing FeedDemon, go to 

http://www.newsgator.com/NGOLProduct.aspx?ProdID=FeedDemon

Configuring Contribute in FeedDemon may vary with different versions of FeedDemon. The following configuration 

process applies to FeedDemon version 2.6.

1 Open the FeedDemon application.

2 Select any news item in the list.

3 Click the Send To (arrow) icon, and select Blog This News Item > Configure Blog Publishing Tools.

A

B

C

http://www.newsgator.com/NGOLProduct.aspx?ProdID=FeedDemon


218USING CONTRIBUTE CS4

Publishing web pages and blog entries

The Blog Publishing Tools dialog box appears.

4 Click Add.

The Program dialog box appears.

5 Enter the following details:

• Enter Contribute in the Name text box.

• Enter the command in the Command-line or URL text box. To enter the command, browse to the location 

where the contribute.exe file is located on your hard disk. After you select the file and the path appears in the 

Command Line text box, click the cursor at the end of the path, enter one space and type -mmPostToBlog.

6 (Optional) Select Set As Default to have Contribute be your default blog publishing tool.

7 Click OK.

Contribute now appears in the Blog Publishing Tool dialog box.

8 Click OK.

To verify whether Contribute is successfully configured in FeedDemon, do the following:

• Select any news item in FeedDemon. 

• Right-click the news item. 

• Select Send Item > Blog this News Item and check whether Contribute appears in the list.

Post to a blog from FeedDemon

After you successfully configure Contribute in FeedDemon, you can post news entries to your blog.

1 Open the news item in FeedDemon.
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2 Click the Send To (arrow) icon, and select Blog This News Item > Contribute.

The contents of the news item appear in the Contribute editor.

3 Make any changes as necessary.

4 Click Publish.

Contribute publishes the news entry to your blog and then displays it in the Contribute browser.

Configure Contribute in NetNewsWire (Mac OS)

NetNewsWire is a desktop RSS aggregator for Mac OS. You can configure Contribute in NetNewsWire and post news 

entries to your blog. You can transfer the contents of the news entry to Contribute, add your own comments, and post 

to your blog. For more information on installing NetNewsWire, go to 

http://www.newsgator.com/Individuals/NetNewsWire/Default.aspx.

1 Open the NetNewsWire application.

2 Select Preferences.

3 Select Posting > Post to Web log using > Other...

4 Click Weblog Editor.

5 In the Weblog editor application pop-up menu, browse to the location of the contribute.app file.

Post to a blog from NetNewsWire

After you successfully configure Contribute in NetNewsWire, you can post news entries to your blog.

1 Select the news item in the News Items list in NetNewsWire.

2 Click Post to Weblog.

The contents of the news item appears in the Contribute editor.

3 Make changes as necessary.

4 Click Publish.

Contribute publishes the news entry to your blog and then displays it in the Contribute browser.

Preview the blog entry in your browser

❖ Do one of the following:

• Select File > Preview in Browser.

• Press the F12 key.

Publish a blog entry to your blog

After you finish editing and reviewing your blog entry, you are ready to publish it to your blog. When you publish a 

blog entry, you can publish all the blog entries or web pages that are linked to the blog entry. When you publish a blog 

entry, Contribute makes it live on your blog. 

You can publish any of the following types of blog entries to your blog:

• Updates to an existing blog entry

http://www.newsgator.com/Individuals/NetNewsWire/Default.aspx
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• Existing blog entry as a new entry

• New blank blog entry

Publish updates to an existing blog entry

When you publish updates to an existing blog entry, Contribute replaces the currently published version of the blog 

entry with the new version.

You can create a link to the blog entry at the same time that you create a blog entry. For more information, see “Link 

to a new blank blog entry” on page 179. 

1 In the blog entry draft, click the Publish button in the toolbar.

Note: Some blogs do not allow images, enclosures, media files, or links to local files in the content. You might not be 

able to publish such content if the blog you are publishing to does not accept these files. Verify whether your blog makes 

this exception.

If the blog entry draft links to any new blog entries, the Publish New Linked Blog Entries dialog box appears.

If the blog entry draft links to any web pages, the Publish New Linked Pages dialog box appears.

2 If the Publish New Linked Blog Entries dialog box or Publish New Linked Pages dialog box appears, do the 

following:

a Click the blog entry or the web page to select it.

b If you selected a web page, change the file and folder location if necessary.

c Click Publish All.

For more information about options in the dialog box, click the Help button.

Contribute publishes the blog entry and any new blog entries or web pages that are linked to it and then displays it 

in the Contribute browser.

Preview the blog entry in your browser

❖ Do one of the following:

• Select File > Preview in Browser.

• Press the F12 key.

Publish an existing blog entry as a new entry

You can publish an existing blog entry in your blog, make changes, and republish it as a new entry.

You can use the Publish as New Entry feature to publish an existing blog entry as a new entry. For example, suppose 

you have an existing blog entry with the list of your favorite radio stations, and now you want to add a list of your 

friend’s favorite radio stations. You can open the blog entry that has your favorites list, make your changes, and then 

publish the entry as a different blog entry to your same blog.

1 Browse to the blog entry in your blog, and then click the Edit Entry button.

2 Make changes to the blog entry.

3 Select File > Actions > Publish as New Entry.

If your blog entry links to any other new blog entries, the Publish New Linked Blog Entries dialog box appears.
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4 If the Publish New Linked Blog Entries dialog box appears, do the following:

a Click the blog entry to select it.

b Click Publish All.

For more information, see “Completing the Publish New Linked Blog Entries dialog box options” on page 222.

For more information about options in the dialog box, click the Help button.

Contribute publishes the blog entry to your blog and then displays it in the Contribute browser.

Preview the blog entry in your browser

❖ Do one of the following:

• Select File > Preview in Browser.

• Press the F12 key.

Publish a new blank blog entry

You can publish a new blank blog entry to your blog. You can also publish a blank blog entry with links to other new 

blank blog entries or web pages. When you publish a new blog entry that has a link to another new blog entry or web 

page, Contribute publishes the new blog entry, and all blog entries that are linked to the blog entry.

You can create a link to the blog entry at the same time that you create a blog entry. For more information, see “Link 

to a new blank blog entry” on page 179. 

1 In your draft, click the Publish button in the toolbar.

Note: Some blogs do not allow images, enclosures, media files, or links to local files in the content. You might not be 

able to publish such content if the blog you are publishing to does not accept these files. Verify whether your blog makes 

this exception.

If the blog entry draft links to any new blog entries, the Publish New Linked Blog Entries dialog box appears.

If the blog entry draft links to any web pages, the Publish New Linked Pages dialog box appears.

2 For each unpublished linked blog entry or web page, do the following:

• Click the blog entry or the web page to select it.

• If you selected a web page to link to your blog entry, change the file and folder location if necessary.

• Click Publish All.

For more information about options in the dialog box, click the Help button.

Contribute publishes the blog entry draft and any new blog entries or web pages that are linked to it and then 

displays it in the Contribute browser.

Preview the blog entry in your browser

❖ Do one of the following:

• Select File > Preview in Browser.

• Press the F12 key.
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See also 

“Publish updates to an existing blog entry” on page 220

“Publish a new blank blog entry” on page 221

Reference

This section provides information about the dialog boxes introduced in this chapter.

Completing the Publish New Linked Pages dialog box options

The Publish New Linked Pages dialog box appears when you try to publish an existing web page that contains links to 

pages that are not published. Use this dialog box to save the new linked pages before you publish your draft.

1 For each unpublished linked page, you can click the page name to select it, and then change the filename and folder 

location.

The filename appears at the end of the web address for the web page. The web address is the location where 

Contribute saves the page on your website.

Contribute publishes the draft for the existing web page, along with any new pages it links to.

2 To publish all linked pages with the same workflow as the page being published, select Publish All Dependent Pages 

Whose Workflow Is Same As The Main Page. For linked pages with a different workflow, the location on the site 

is finalized, but the pages are not published until their workflow is complete. To set a different expiry date than the 

one set by the administrator for the linked web page, select the date in the Page Expires on Option. (Optional.)

3 Click Publish.

See also 

“Publish updates to an existing page” on page 204

Completing the Publish New Linked Blog Entries dialog box options

The Publish New Linked Blog Entries dialog box appears when you publish a blog entry that contains links to blog 

entries that are not published. Use this dialog box to save the new linked blog entries before you publish your draft.

❖ For each unpublished linked blog entry, click the blog entry title to select it, and then click Publish All.

Contribute publishes the draft for the existing blog entry, along with any new blog entries it links to.

See also 

“Publish updates to an existing blog entry” on page 220

“Publish an existing blog entry as a new entry” on page 220

Completing the Publish New Page dialog box options

Use the Publish New Page dialog box to name a new page and save it to a folder before you publish it.

1 (Optional) Change the filename.

The filename appears at the end of the web address for the page.
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2 Click the Choose Folder button next to the filename to save this draft in another location on your website.

The current folder location appears in the web address under the filename.

3 To set a different expiry date, select the date in the Page Expires On option. (Optional.)

4 Click Publish or Next.

If your new page draft does not link to any new pages, Contribute publishes the new page to your website, and then 

displays it in the Contribute browser. If your new page draft links to any other new pages, the Publish Linked New 

Files dialog box appears.

Note: Contribute warns you if you have not linked the new page draft from an existing page. After you publish the new 

page, be sure to create a link to it (see “Link to a new blank blog entry” on page 179).

See also 

“Publish a new page to your website” on page 205

Completing the Publish As New Page dialog box options

Use the Publish As New Page dialog box to save an existing web page with a new page title, filename, and location.

1 Change the page title for the draft.

The page title appears in the title bar of the browser when a visitor views the page; it does not appear in the page. 

2 Change the filename for the draft.

The filename appears at the end of the web address for the web page.

Note: Contribute automatically saves the file with the same name as the page title. If you change the filename to one 

that already exists on your website, Contribute alerts you when you click Publish. 

3 Click the Choose Folder button next to the filename to save this draft in another location on your website.

Note: The current folder location appears in the web address under the filename.

4 To set a different expiry date, select the date in the Page Expires On option. (Optional.)

5 Click Publish or Next.

If your new page draft does not link to any other new pages, Contribute publishes the draft to your website and then 

displays it in the Contribute browser. If your new page draft links to any other new pages, the Publish Linked New 

Files dialog box appears.

See also 

“Publish an existing page as a new page” on page 206

Closing the unlinked page warning

Contribute displays this warning message when you try to publish a draft that is not linked on your website. Visitors 

can’t browse to a new page on your website if you do not insert a link in an existing page to the new page.

1 Select Don’t warn me again if you do not want Contribute to warn you when you are publishing a draft that is not 

linked from another page.
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2 Do one of the following:

• Click Yes to publish the draft without linking to it.

If you click Yes, be sure to add a link to the new page after you publish it (see “Link to a draft or a recently 

published page on your website” on page 177). Website visitors can’t navigate to a new page on your website if 

you do not add a link.

• Click No if you do not want to publish the draft without linking to it.

If you click No, browse to an existing page to insert a link to the new page (see “Link to a draft or a recently 

published page on your website” on page 177), and then publish the page with the link (which also publishes the 

new page at the same time).

Closing the Page Modified warning

This warning appears when you try to publish a page that has changed on your website since you started editing. The 

page could have been modified by another user.

1 Select one of the following options:

• Publish your draft as a new page.

When you select this option, Contribute publishes the draft on your website but leaves the current published 

version of the page unchanged. This means that there are two versions of this page on your website. For more 

information, see “Publish an existing page as a new page” on page 206.

• Publish your draft, overwriting the changes the other user made.

When you select this option, Contribute replaces the current published version of this page on your website with 

your draft of the page. This means that any changes made by another user while you were editing this page will 

be lost.

2 Click OK to publish the draft, or click Cancel if you do not want to publish the draft.

Completing the Select Website dialog box options

Use the Select Website dialog box to select the website where you want to save the file you are adding to a website or 

sending for review from your computer. 

❖ Select a website from the Website pop-up menu, and then click OK. 

The website list includes any website you are connected to. If you are sending the file for review, the reviewer you 

want to send the file to must also be connected to the website you select.

See also 

“Publish a file from your computer to your website” on page 208

“Send a file for review” on page 58
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Completing the Replace File dialog box options

Use the Replace File dialog box to indicate how you want to handle two files with the same name. This dialog box 

appears when you try to publish a file from your computer that has the same name as an existing file on your website.

1 Select one of the following:

• Select Replace the file to have Contribute replace the existing file on your website with the file you are publishing 

or linking to on your computer.

• Select Have Contribute create a similarly named file if you don’t want Contribute to replace the existing file but 

want to change the filename for the file on your computer.

Contribute appends a number to the filename for the new file so that its name is not the same as the existing file on 

your website.

2 Click OK.

See also 

“Replace a file on your website” on page 209

Completing the Roll Back Page dialog box options

Use the Roll Back Page dialog box to undo a published page, and roll back to a previously published version of that web page.

1 Select a previous version of the published page from the list of available pages. 

Note: The list of previously published pages displays a number of previous versions of the page, depending on your 

Contribute administrator’s setting. 

Contribute displays the page in the Preview section.

2 If the page you selected is the one you want to publish, click the Roll Back button. If the page is not the one you 

want to publish, select another page from the list, and then click Roll Back.

Contribute replaces the currently published version of the page with the previously published version that you 

selected. The version you selected becomes the current version on the website.

Note: The page you replace with the selected rollback page appears in the Roll Back Page dialog box the next time you 

open the dialog box so you can roll back to that version.

See also 

“Roll back to a previous version of a page” on page 211

Completing the Publish To Website dialog box options (Windows only)

Use the Publish To Website dialog box to publish the contents of the document in Microsoft Word, Excel, or Outlook 

to your web site.

1 To select the settings for publishing the document, do the following:

a Select a web site where you want to publish the file.

Note: If you do not have a connection to your website before you publish a document, you can always create one 

by selecting Create New Connection in the Select pop-up menu in the Publish To Website dialog box. For more 

information on creating a website connection, see “Create a website connection” on page 231.

b Select a location for storing the file.
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c Enter a filename.

Note: The filename must not have any spaces, tabs, or alphanumeric characters.

d Select a format.

e Click the Choose Template button. The Choose Template dialog box appears.

If you do not click the Choose Template button in the Publish To Website dialog box, the template that was last 

used to publish a Microsoft Office document is associated with the document you are currently publishing. In 

addition, if the template does not match the template on the server, Contribute displays the Download Template 

dialog box. You can choose to do one of the following:

• Click the Publish Using The Old Template button to publish the document using the old template.

• Click the Download And Publish button to download the updated template from the server, and then publish 

the document.

Note: The Choose Template button is disabled when the .doc format is selected.

f Select a template from the list of available templates.

A preview of the selected template appears in the Preview box.

g If the template you select for publishing a Microsoft Office document to a website has been updated on the 

server, the Open As New Page dialog box appears. You can choose to publish using the old template, or 

download the updated template available on the server, and then publish the document.

h Select a template region from the list of editable regions available in the selected template.

This list is disabled if you select _blank template.

i Click the Refresh Templates button, and select one of the following options to update your list of templates and 

editable regions in a selected template:

For this website to view an updated list of templates for the selected website

For selected template to view an updated list of editable regions in the selected templates

j (Optional) Clear the Make This As The Default Template check box.

k Click OK.

l (Optional) Clear the Publish Current Selection Only check box to publish the whole document instead of the 

selection.

2 Click Publish.

Contribute publishes the document to your website, and a confirmation dialog box appears.

3 Click OK.

See also 

“Publish a document from Microsoft Office (Windows only)” on page 212

Using the Contribute plug-in in Microsoft Office 

The Contribute plug-in appears in the toolbar in Microsoft Word, Excel, and Outlook e-mail reader. The plug-in 

automatically installs when you install Contribute.
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This plug-in enables you to publish documents to your website or blog without opening the Contribute application. 

Or, if you prefer, you can open the document in Contribute to edit it before you publish it.

❖ In Office, click one of the following options:

Open In Contribute Use this option to open a document in Contribute for editing before you publish it. For more 

information, see “Open documents in Contribute from Microsoft Office applications (Windows only)” on page 96.

Post To Blog Use this option to publish a document to your blog. For more information, see “Post content to a blog 

from Microsoft Office applications (Windows only)” on page 215.

Publish To Website Use this option to publish a document to your website. For more information, see “Publish a 

document from Microsoft Office (Windows only)” on page 212.
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Chapter 12: Creating and managing 
website and blog server connections

After you install Adobe® Contribute®, you must create a connection to a website or blog before you can begin to edit 

its pages or create pages or blog entries.

This chapter explains how to use the Contribute Connection Wizard (Windows) or Connection Assistant (Mac OS) 

to create a connection. It also explains how to set administrative settings for a website and how to rename and remove 

website and blog server connections. It also explains how to specify the types of audio, video, and image files you can 

publish to your blogs.

After you create a website connection, you can create roles (see “Managing users and roles” on page 280) and then 

export site connection information to your users.

About creating and sending website connections

When you connect to a website, depending on your web server configuration and the complexity of your website, 

Contribute might not automatically detect all possible web server configurations. The Web Server settings of the 

Administer Website dialog box let you specify alternative configurations for your website’s index files and alternative 

web addresses.

After you set up a connection to a website, you can send that connection information in a connection key file to users. 

Or, if the website is the one that Contribute Publishing Server (CPS) manages, you can use the URL.

Note: Connection keys are not available for blogs.

Web server index pages

The index page for a website is the default web page that appears when a visitor enters a website (such as 

www.mysite.com) but doesn’t specify a page on the website. A web server can be configured to look for a page with a 

particular filename if no page is specified; the most common default index page filenames are index.htm, index.html, 

default.htm, and default.html. If you are unsure of the index page filenames that your web server uses, see your web 

server’s documentation.

In addition to the primary index page filename, most web servers are configured with alternative index page filenames, 

specifying pages to be displayed if there is no page with the filename requested as the primary index page.

Note: Index pages are available only for websites. Blogs do not use index pages.

For example, a web server might look for the following index page names (in this order):

1 index.htm

2 index2.htm

3 404error.htm

If a page is named index.htm, the server sends that page to the browser to be displayed; if such a page isn’t present, the 

server sends index2.htm to the browser. If neither of those index pages is available, the server sends the 404error.htm 

page to the browser. Secondary pages such as these often provide an alternative entrance to the website or inform the 

visitor that the website is unavailable.
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Contribute includes a list of popular index page filenames, using most of the popular document type extensions (.htm, 

.html, .cfm, .asp, .jsp, .php, and so on). If the index page filename that you use for your website is listed in the Index 

files section of the Index and URL Mapping dialog box (index.cfm, for example), you can most likely ignore this 

configuration option. If, however, your index page filenames are not included among those listed in the dialog box, 

you must add your index page filenames to the list, and arrange the names in the order in which your web server is 

configured to look for them.

For example, if your website uses an Adobe ColdFusion application server that uses the document type extension .cfm, 

and the index page for your website uses the filename main.cfm, add the filename main.cfm to the list of index pages 

in the Index and URL Mapping dialog box, and list that filename as the first page that Contribute should find on the 

website. “Add index page filenames” on page 244 explains how to add an index page filename to your Contribute 

settings. 

See also 

“Add index page filenames” on page 244

“Remove index page filenames” on page 245

Alternative website addresses

Web servers can be configured in a variety of ways to respond to varying user needs. One common part of web server 

configuration is the mapping of web addresses to either different IP addresses (often for either load balancing or 

localization issues), or multiple web addresses pointing to a single IP address. The following common web server 

configurations involve URL mapping:

Multiple DNS Aliasing Occurs when two or more domain name server (DNS) aliases point to a single server (for our 

purposes, a single server consists of a single IP address). When connecting to a server configured with multiple DNS 

aliases, Contribute views the defined website and the aliases as separate websites, even though they are the same from 

the users’ perspective.

For example, if your server hosts the website www.carsonline.com, and you set up two additional web addresses that 

refer to that same website (for example, www.cars.com and www.mycars.com), you must configure Contribute to 

recognize these separate web addresses as the same website. 

Virtual Server Configurations Have two or more DNS aliases pointing to the same server, but users view them as 

different websites. When a server configured in this way receives a request to retrieve a web page, it serves different 

pages depending on the address used in the request. There are two types of virtual server configurations:

• DNS-based virtual servers use a single IP address that has two or more DNS aliases pointing to that address. In this 

configuration, the web server differentiates the page request based on the web address, serving different pages to 

the different addresses.

• IP-based virtual servers use multiple IP addresses to differentiate web servers. 

A common use of virtual server configurations is to provide localized content to different geographic locations. For 

example, a news website might provide different local information to users viewing the website based on their location. 

Port numbers are often used to further divide a domain name into multiple websites. Often this is to allow the website 

to provide different software functionality based on a port that may be listening for incoming requests.

A web address that uses a different port number is considered to be a different website. However, this is not always the 

case. As with web server configurations using multiple DNS aliases, it’s important that you map host names using 

different port numbers to the correct website.
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For example, if your organization’s website can be accessed through two different web addresses differentiated by port 

numbers, you must add these web addresses to the Alternate addresses field. In this example, assume that your 

organization maintains the following web addresses:

www.cars.com 

www.cars.com:8080

Both these web addresses point to the same website, with the exception that those sites using port number 8080 read 

the browser’s cookie file to check whether the visitor is a new or returning user. If the user is already registered, the 

website appears without prompting for registration. If a user is new, a dialog box appears requesting the user to register 

to gain access to the website.

See also 

“Specify alternative website addresses” on page 246

Connection keys

Using the Connection Wizard (Windows) or Connection Assistant (Mac OS), you can easily set up connections to 

websites for other users. The wizard enables Contribute users to collaborate by sharing website connections.

Contribute lets you share website connection information by embedding website information in a connection key file. 

Because the connection key is encrypted with a password, any network or File Transfer Protocol (FTP) login 

information you send in the file remains secure and can be accessed only through Contribute. The connection key file 

uses the filename extension.stc. You can either e-mail the file to users, or save it to your computer for users to 

download and import. If you double-click the file, either on the desktop or as an e-mail attachment, Contribute starts 

and imports the connection.

FTP and Secure FTP (SFTP) connection keys can be used across platforms; LAN connection keys are platform specific.

The procedure for sending a connection key varies depending on the type of user model you’ve chosen to manage your 

website. If you’re letting users connect to a site by manually entering connection information or by using a connection 

key file, see “Send connection keys for websites” on page 251. If you’re managing users with a connection server, see 

“Send connections for CPS managed sites” on page 253.

Note: Connection keys are not available for blogs.

Collect the following information before you begin:

• Your user name and e-mail address

The user name and e-mail address identify users and the web pages or blog entries they are working on. Contribute 

prevents multiple users from simultaneously editing the same web page. (Contribute uses a system much like the 

Dreamweaver check in and check out system to avoid editing conflicts.) 

If you have multiple copies of Contribute, use a different user name for each copy. For example, Chris(laptop), and 

Chris(Mac). Using the same user name can cause problems because you can override checkouts you make on the 

other computer.

• Web address of the website or blog server

A website’s Uniform Resource Locator (URL) is its address either on the Internet or on an organization’s intranet. 

Website URLs usually have the following form:

http://www.mysite.com/
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A blog server’s access point Uniform Resource Locator (URL) is its address either on the Internet or on your 

organization’s intranet. Blog server URLs usually have the following form:

http://blogname.blogsite.com

• Network path to the website (for connecting to local networks)

The network path is the location of the website in your organization’s local network. The network path includes the 

name of the server on which the website is stored and the directory path of the website’s files on that server. For 

example, your network path might be \\mycomputer\wwwroot\ (Windows) or afp://server:volume: (Mac OS).

Note: If you are a Mac OS X user, to create a LAN connection, make sure to mount the network volume of the server 

you are creating a connection to on your computer desktop before you create your connection. In the Finder, select Go 

> Connect to Server to mount the network to which you want to connect. 

• FTP or SFTP connection information

FTP provides a secure way to transfer files to your local or remote web server. If you will connect to your website 

from a remote location (for example, telecommuting from home or another office) you may need to connect to the 

website using FTP, to transfer files from a remote location across the Internet to your website (for example, if you 

don’t have a local network connection to the website). 

If you or your users will connect to your website by using FTP or SFTP, you must know the address of the FTP 

server as well as the user name and password to connect to the FTP server. For example, your FTP server’s address 

might be ftp.mysite.com. 

Note: Websites that CPS manages require users to use their own FTP or SFTP account information to connect to the 

website. 

• Verification that Contribute directly supports your blog

Blogs hosted on Blogger, TypePad, Roller, or WordPress are directly supported in Contribute.

If your blog is hosted by another service, the host must support the MetaWeblog API. The MetaWeblog API allows 

Contribute and other external programs to make changes to the text and attributes of blog entries. If your blog host 

supports the MetaWeblog API, you must enter the blog’s access point URL, such as http://blogname.blogsite.com, 

as well as your user name and password for the blog hosted by that service.

Note: You must have a blog account already set up with the blog host before you can connect to it using Contribute.

See also 

“Create a connection to a .Mac account” on page 236

“Enable or disable CPS for a website” on page 236

“Manage website and blog server connections” on page 256

Create a website connection

The Connection Wizard (Windows) or Connection Assistant (Mac OS) guides you through the steps of creating a 

connection to a website, prompting you for the information needed to establish a website connection. 

The process is different to create a connection to a blog; for more information, see “Create a blog server connection” 

on page 233.
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Note: If you use a Macintosh computer and have a .Mac account, you can easily create a connection to your .Mac 

account. In the Connection Assistant, select the .Mac check box. For information about selecting a folder to connect to in 

your .Mac website, see “Create a connection to a .Mac account” on page 236.

1 Start Contribute.

2 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears. The options in this dialog box let you create and manage your Contribute 

connections. 

You can also use the My Connections dialog box to create a connection to blogs. For more information on creating 

connections to blogs, see “Create a blog server connection” on page 233. 

3 Click Create.

Note: The Connection Wizard (Windows) or Connection Assistant (Mac OS) appears. This wizard or assistant guides 

you through setting up a new website connection. 

Click Back or Go Back to return to a previous screen, if necessary. If you need more information about how to 

complete a screen, click the Help button.

4 Click Next.

5 From the What do you want to connect to pop-up menu, select Website.

6 In the What is the web address (URL) of your website field, enter the website you want to connect to. If necessary, 

click the Browse button and browse to the website.

7 Click Next.

8 From the How do you connect to your web server pop-up menu, select your connection service and do one of the 

following:

• If you selected FTP, enter the FTP server name, user name, and password.

• If you selected Secure FTP (SFTP), enter the SFTP server name, user name, and password.

• If you selected Local/Network, enter the network path to your website.

• If you selected WebDAV, enter the WebDAV URL, user name, and password.
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9 (Optional) Click Advanced, and select the appropriate advanced connection options for the connection service you 

specified in step 7.

10 Click Next.

11 On the Summary screen, review the connection settings to verify that they’re correct and click Done (Windows) or 

Finish (Mac OS) to complete the connection.

Contribute creates a connection to the website.

After Contribute has successfully created a connection to the website, the Connection Wizard or Connection Assistant 

closes, and the main page of the website appears in the Contribute browser.

See also 

“Create a connection to a .Mac account” on page 236

“Enable or disable CPS for a website” on page 236

“Manage website and blog server connections” on page 256

Create a blog server connection

The Connection Wizard (Windows) or Connection Assistant (Mac OS) guides you through the steps of creating a 

connection to a blog, prompting you for the information needed to establish a blog server connection.

The process is different to create a connection to a website; for more information, see “Create a website connection” 

on page 231.

You can create a connection to a blog server in two ways:

• Specifying the blog server user name and blog server password details.

• Specifying the blog URL, and blog server user name and blog server password details.

You can connect to a blog that is hosted on one of the following servers:

• The Blogger, TypePad, or WordPress blog publishing services. Users with blogs on one of these hosts can connect 

to their blogs directly by selecting the host in the Connection Wizard or Connection Assistant. 

• Other internal servers, such as Movable Type, that support the MetaWeblog API. 

Note: The MetaWeblog API lets Contribute users make changes to the text and attributes of blog entries.

1 Start Contribute.

2 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS). 
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The My Connections dialog box appears. The options in this dialog box let you create and manage your Contribute 

connections. 

3 Click Create.

The Connection Wizard (Windows) or Connection Assistant (Mac OS) appears. This wizard or assistant guides 

you through setting up a new website connection. 

4 Click Next.

5 Select Blogs from the What do you want to connect to pop-up menu.

6 Select your blog’s host from the Who hosts your blog pop-up menu.

7 Click Next.

8 If you selected Blogger, TypePad, or WordPress, enter the blog’s user name and password. 

9 Click Done (Windows) or Finish (Mac OS) to complete the connection.

Contribute creates a connection to the blog server.

Note: If you want to connect to the Roller blog server, select Other Blog Servers from the Who hosts your blog pop-up 

menu, and provide the required information.

After Contribute successfully creates a connection to the blog, the Connection Wizard or Connection Assistant closes. 

The My Connections dialog box appears, listing your connected blog(s). The blogs are also listed on the Contribute 

Start page. 

Note: After you are connected to a blog server and you create another blog on the same blog server, you can add the new 

blog and its details by reconnecting to the blog server. For more information, see “Reconnect to a blog server” on page 235.

Create a blog server connection using the blog URL

1 Start Contribute.

2 In the Create New area, click the Blog Connection link. 

The Choosing a Connection screen of the Create Connection wizard appears.

3 By default, the Blogs option is selected in the What do you want to connect to pop-up menu.



235USING CONTRIBUTE CS4

Creating and managing website and blog server connections

4 Select Other Blog Servers from the Who hosts your blog pop-up menu if your blog is hosted on an internal server 

that supports the MetaWeblog protocol.

The What is the URL of your blog text box and Browse button appear. 

5 (Optional) In the What is the URL of your blog text box, type or browse to the URL of the home page of your blog.

6 Click Next.

The Blog Site Connection Information screen of the Create Connection wizard appears.

If you selected Blogger, or if Contribute is able to find the access point of the blog server whose URL you specified, 

only the Enter your blog server user name and Enter your blog server password text boxes appear. However, if you 

selected Other Blog Servers, or if Contribute is unable to find the access point of the blog server you specified, the 

Blog Protocol pop-up menu (which is disabled) and the Access Point text box also appear.

7 Enter your user name in the Enter your blog server user name text box.

8 Enter the password to connect to your blog in the Enter your blog server password text box. 

9 If the Access Point text box appears, specify the Access Point.

The Access Point is a URL used to connect to your Blog server. 

The Access Point is a URL used to connect to your Blog server. You can view a list of common access points in the 

Help documentation. Press F1 to view online help.

Note: Click the Back or Go Back button to return to a previous screen if necessary.

10 Click Done. 

Contribute creates a connection to the blog server and the blog’s home page appears in the Contribute browser.

See also 

“Create a connection to a .Mac account” on page 236

“Create a website connection” on page 231

“Enable or disable CPS for a website” on page 236

“Manage website and blog server connections” on page 256

Reconnect to a blog server

Close and reopen Contribute after creating a blog using the blog publishing service. When you open Contribute, it 

reconnects to the blog server. Details of the new blog are automatically updated.

• If Contribute is not running, open the application. Contribute reconnects to the blog server and automatically 

updates the connection with the details of the new blogs.

• If Contribute is running, do one of the following:

• Close Contribute and reopen the application.

• Edit the blog server connection without changing the user information. For more information on editing blog 

server connections, see “Edit website and blog server connections” on page 257.

• Disable and enable the blog server connection. For more information, see “Disable individual website and blog 

connections” on page 260 and “Enable a website or blog server connection” on page 261.
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Create a connection to a .Mac account

You can use Contribute with your .Mac account and seamlessly set up a connection to your website. This integration 

of Contribute and .Mac is available on Mac OS X 10.2 and later. 

Note: On Mac OSX 10.1, you need to mount your iDisk so that Contribute can detect your .Mac account. To mount your 

iDisk, in the Finder, select Go > iDisk.

If Contribute detects that you have an active .Mac account, you will be prompted to create a connection to your 

account when you start Contribute. If you dismiss the prompt, and later want to create a connection, use the 

Connection Assistant to create the connection to your account. 

1 Select Contribute > My Connections (Mac OS).

The My Connections dialog box appears. 

2 Click Create.

The Connection Assistant appears.

3 Select .Mac website from the What do you want to connect to pop-up menu.

Using the .Mac information stored in your computer’s system preferences, Contribute mounts your iDisk and 

creates the connection to the root folder of your website. For information about selecting a different folder to 

connect to see “Select a .Mac website folder to connect to” on page 236.

Note: If Contribute does not detect your .Mac account, you will be asked if you want to set up a .Mac account. 

Select a .Mac website folder to connect to

When you select Get connection information from my .Mac account, Contribute automatically detects the path to 

your .Mac website’s root folder. To create a connection to a subfolder of your .Mac website, let Contribute complete 

the path information, and then edit the path to the desired folder.

1 Select Contribute > My Connections (Mac OS).

The My Connections dialog box appears. 

2 Click Create.

The Connection Assistant appears.

3 Select .Mac website from the What do you want to connect to pop-up menu.

4 In the Connection Assistant, click Continue to add the .Mac connection information.

5 In the Connection Assistant, click Go Back and deselect the Get connection information from my .Mac account 

check box so you can select the path you want to connect to. 

The .Mac website connection information will not be deleted; you can make the changes you want in the 

Connection Assistant screens.

6 Click Continue to update the settings as desired. On the Summary screen, click Finish to close the Connection 

Assistant. 

Enable or disable CPS for a website

After you install and configure CPS, you can enable CPS for your website. At any point, you can disable CPS or the 

User Directory service.
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Note: To disable other services, you must use the CPS Console. For more information, see the CPS Console Help.

Enable CPS to work with your website

Before you can start using CPS with your website, you must install and configure CPS (see CPS Console Help for 

information about configuring). You must also create a Contribute connection to your website (see “Create a website 

connection” on page 231).

After you’ve completed those tasks, you can enable CPS for your website.

Before you enable CPS to use the User Directory with your website, make sure that any users who previously connected 

to the site using a connection key publish all outstanding drafts. After you enable CPS for your website, those users 

cannot connect to the website until you add them to the website from your LDAP, Active Directory, or file-based user 

database. 

1 Start Contribute.

2 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and then select the 

website you want to administer from the submenu.

The Administer Website dialog box appears.

3 Select the Users and Roles category on the left side of the dialog box.

4 Select Publishing Server from the list of administrative categories on the left.

5 Click the Enable Publishing Server button.

The Enable Publishing Server dialog box appears.

6 Enter the Publishing Server web address in the address field, and then click OK.

For more information about options in this dialog box, see “Setting the Enable Publishing Server dialog box 

options” on page 263.

For more information about options in this dialog box, click the Help button in the dialog box. 

Contribute establishes a connection to CPS, and you can launch the CPS Console.

Note: When you enable the User Directory, any users who previously connected to the site are removed, and any 

connection keys you may have previously sent no longer work. You must add users from your LDAP, Active Directory, 

or file-based user database. To learn how to add users to sites that CPS manages, see “Add users to websites that CPS 

manages” on page 254.
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7 (Optional) In the Administer Website dialog box, click the Publishing Server Console link to launch the CPS 

Console. 

See also 

“Add users to websites that CPS manages” on page 254

“Disable CPS for a website” on page 238

Disable CPS for a website

You can disable CPS for a website that CPS manages. This can be useful when you need to temporarily prevent users 

from connecting to the server; for example, when you move the server or perform server maintenance.

When you disable CPS, users who were connected to the website cannot connect until you re-enable CPS. Contribute 

does not remove the administrative settings file for the website when you disable CPS, so roles and permissions are 

unaffected.

1 Publish any open drafts for the website.

You might not be able to access outstanding drafts after you disable the service.

Make sure that users connected to the website also publish any outstanding drafts. 

2 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and then select the 

website you want to administer from the submenu.

The Administer Website dialog box appears.

3 Select Publishing Server from the category list on the left.

4 Click the Disable Publishing Server button.

A confirmation dialog box appears.

5 Click Yes to continue.

Contribute disables CPS for this website. Contribute does not remove the administrative settings file for the 

website, so roles and permissions are unaffected. You still have a connection to the website as a non-managed site.
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Note: Users who were connected to this website cannot connect until you re-enable CPS or send them connection keys 

with new connection information.

6 Click Close to close the Administer Website dialog box.

See also 

“Disable individual website and blog connections” on page 260

“Remove website and blog server connections” on page 259

“Disable the User Directory service for a website” on page 239

Disable the User Directory service for a website

You can disable the User Directory service for any website that CPS manages.

Note: To disable other services, you must use the CPS Console. For more information, see the CPS Console Help.

When you disable the User Directory service, users who were connected to the website cannot connect until you send 

them connection keys with new connection information.

1 Publish any open drafts for the website.

You might not be able to access outstanding drafts after you disable the service.

Note: Make sure that users connected to the website also publish any outstanding drafts. 

2 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and then select the 

website you want to administer from the submenu.

The Administer Website dialog box appears.

3 Select Publishing Server from the category list on the left.

4 Click the Disable User Directory button.

Contribute disables the User Directory service for this website.

Note: Users who were connected to this website cannot connect until you send them connection keys with new 

connection information.

5 Click Close to close the Administer Website dialog box.

See also 

“Enable CPS to work with your website” on page 237

“Disable CPS for a website” on page 238

Become an administrator of an existing Contribute 
website

When you create a Contribute website connection, you have the option of becoming the administrator of that website. 

If you do not become the website administrator when you create the connection, you or another user can become the 

administrator later.
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You can become the website administrator of any website that does not have an administrator associated with it. The 

website administrator is responsible for setting website permissions and for being a point of contact for users who need 

assistance.

Note: If someone inadvertently becomes the administrator for a website, or you forget the administrator password, you 

can reset the password and create a administrative login. 

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS) to display the My 

Connections dialog box, which lists all the websites that you have a connection to, as well as the administrator (if 

any) assigned to each website.

If a website does not have an administrator associated with it, the text No administrator appears in the 

Administrator column of the dialog box.

If a website does not have an administrator, you can become the administrator by completing this procedure.

2 Select the website you want to administer, and click Administer.

3 A dialog box asks whether you want to become the administrator of the website. Click Yes to become the website 

administrator.

After this selection, Contribute sets you as the administrator for the site, and the Administer Website dialog box 

appears. You can optionally set an administrative password for the site. 

4 (Optional) Select the Administration category in the Administer Website dialog box.

5 Click Set Administrator Password.

The Change Administrator Password dialog box appears.

6 Enter and confirm an administrative password for the website, and click OK.



241USING CONTRIBUTE CS4

Creating and managing website and blog server connections

After you assign an administrative password to the website, the Administer Website dialog box appears, allowing you 

to configure the website’s settings and permission groups.

See also 

“Change the website administrator” on page 242

“Change the administrator’s password” on page 242

Configure Contribute administration settings

The Administer Website dialog box lets you configure a variety of settings that specify how Contribute interacts with 

your website as well as letting you manage users.

You can set settings that affect the whole website, such as the administrator’s contact or password information, the 

number of rollback versions of pages to save, and filename conventions for website default home pages. 

See the following topics for information about using the options in this dialog box:

Open the Administer Website dialog box

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to set options for.

2 If prompted, enter the Administrator password, and then click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more 

information, see “Become an administrator of an existing Contribute website” on page 239.

The Administer Website dialog box appears.

3 Select the administrative settings category you want to modify from the list on the left side of the dialog box.

4 Choose from the options in the right-hand side of the dialog box to modify the settings from each category.
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Change the website administrator

You can change the administrator of a Contribute website by changing the e-mail address associated with the website. 

Users send e-mail to this address when they need to contact the website administrator for assistance. 

Note: Changing the e-mail address of the website administrator does not change the administrator password. To change 

the administrator password, see “Change the administrator’s password” on page 242.

Change the administrator e-mail address

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.

2 Do one of the following:

• If the Administrator Password dialog box appears, enter the administrator password and click OK.

• If the website has no administrator, click Yes when a dialog box asks whether you want to become the website 

administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

3 Select the Administration category on the left side of the dialog box.

4 Enter a new e-mail address in the Administrator contact e-mail address text box.

5 Select another category to modify, or click Close to exit the Administer Website dialog box.

Change the administrator’s password

You can change the password used by the administrator.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.

2 If prompted, enter the Administrator password, and then click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more 

information, see “Become an administrator of an existing Contribute website” on page 239.

The Administer Website dialog box appears.

3 Select the Administration category on the left side of the dialog box.

4 Click Change Password in the Administrator Information section of the dialog box.

The Change Administrator Password dialog box appears.

5 Enter your current password and the new password you want to use in the text boxes. You must enter the new 

password twice to confirm that you are entering it correctly.

6 Click OK.

7 Select another category to modify, or click Close to exit the Administer Website dialog box.

See also 

“Change the website administrator” on page 242
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Enable or disable rollbacks

Rollback pages are backup versions of each web page published with Contribute. Enable Rollback is on by default. You 

can disable rollback or change the number of rollback versions. Each rollback page is a copy of the last published 

version of that page before the currently published version. 

For example, if you browse to a page for editing in Contribute, modify the content, and publish your changes without 

having previously updated and published that page, there is only one rollback version of the page (in this case, the 

rollback version is the original page).

Contribute can maintain as many as 99 rollback versions of each published page. When you specify the number of 

rollback pages, carefully consider the amount of disk space that will be consumed by storing the rollback pages. The 

pages are stored on the web server. The default number of rollback pages is three.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS) and select the 

website you want to administer from the submenu.

2 If prompted, enter the Administrator password, and then click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more 

information, see “Become an administrator of an existing Contribute website” on page 239.

The Administer Website dialog box appears.

3 Select the Rollbacks category on the left side of the dialog box.

4 Select Enable rollbacks to activate rollbacks, or deselect it to turn rollbacks off.

5 Enter the number of rollback versions to maintain in the Keep previous versions of each page text box, or use the 

arrow buttons to change the number. Contribute can maintain as many as 99 rollback versions of each web page.

6 Select another category to modify, or click Close to exit the Administer Website dialog box.

Specify new page preferences

The New Pages category lets you determine the document encoding that should be used for your web pages as well as 

the file extension to use when creating pages from a blank page or templates in a site.

Document encoding specifies the encoding used for characters on a web page. For English and Western European 

languages, select Western. Additional options include Central European, Cyrillic, Greek, Icelandic, Japanese, 

Traditional Chinese, Simplified Chinese, and Korean. If an option for the encoding you want is not available, select 

UTF-8 to create a page using the encoding that your operating system is using.

Specify document encoding for new pages

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.

2 If prompted, enter the Administrator password and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more 

information, see “Become an administrator of an existing Contribute website” on page 239.

The Administer Website dialog box appears.

3 Select the New Pages category on the left side of the dialog box.

The New Pages panel appears.

4 Select the document encoding format you want to use from the Default encoding pop-up menu.
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5 Select another category to modify, or click Close to exit the Administer Website dialog box.

Specify the default file extension for new pages

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.

2 Do one of the following:

• If the Administrator Password dialog box appears, enter the administrator password, and click OK.

• If the website has no administrator, click Yes when a dialog box asks whether you want to become the website 

administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

3 Select the New Pages category on the left side of the dialog box.

The New Pages panel appears.

4 Enter the default file extension you want to use for both new blank pages, and new pages created from templates.

The default file extension is .htm, but you can specify any file extension appropriate to your website. For example, 

if your website exclusively uses Adobe ColdFusion pages, you will want to create pages with the file extension .cfm.

5 Select another category to modify, or click Close to exit the Administer Website dialog box and save your changes.

Add index page filenames

You can add new index filenames to your website settings that correspond to your website’s index files.

Note: For more information about index page filenames, see “Web server index pages” on page 228.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.

2 If prompted, enter the Administrator password, and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more 

information, see “Become an administrator of an existing Contribute website” on page 239.

The Administer Website dialog box appears.

3 Select the Web Server category on the left side of the dialog box and click the Index Files tab.
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The Index Files panel appears.

1 Click the Add button.

The Add or Edit Index Filename dialog box appears.

2 Enter an index filename and click OK.

The new index filename appears at the bottom of the list of possible index filenames.

3 Using the arrow buttons, arrange the index pages in the order that your web server’s configuration specifies. For 

example, if your web server is configured to use three index pages—index.htm, index2.htm, and 404error.htm—

and the primary page is index.htm, the designated order is:

• index.htm 

• index2.htm 

• 404error.htm

This is the order in which the web server retrieves and displays the index pages if one or more of the pages are 

unavailable.

4 When you have added and ordered the filenames in the Index file list, click Close to exit the Administer Website 

dialog box and save your changes, or select another category to modify.

See also 

“Web server index pages” on page 228

Remove index page filenames

You can remove index page names from the default list in Contribute. When deleting index page filenames, ensure 

that your Contribute sites don’t rely on the page names you are removing from the Index files list.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.
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2 If prompted, enter the Administrator password, and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more 

information, see “Become an administrator of an existing Contribute website” on page 239.

The Administer Website dialog box appears.

3 Select the Web Server category on the left side of the dialog box, and click the Index Files tab.

The Index Files panel appears.

4 Select the filename you want to remove from the Index files list.

Note: You cannot select multiple index files from the list; you must select each file individually and click Remove.

5 Click Remove.

6 When you have removed the filename from the Index file list, click Close to exit the Administer Website dialog box 

and save your changes, or select another category to modify.

See also 

“Web server index pages” on page 228

“Add index page filenames” on page 244

Specify alternative website addresses

If Contribute users visit a website using a different host name, directory path, or port number, you must configure 

Contribute to recognize these alternative web addresses and associate them with the appropriate website connection.

Note: For more information about alternative web addresses, see “Alternative website addresses” on page 229.

If you don’t configure Contribute to recognize alternative web addresses, users might have problems editing or 

publishing web pages if they connect to a website that isn’t defined in Contribute.

You need to configure Contribute to recognize the alternative web addresses that users need to access, not all possible 

alternative web addresses.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.

2 If prompted, enter the Administrator password, and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more 

information, see “Become an administrator of an existing Contribute website” on page 239.

The Administer Website dialog box appears.

3 Select the Web Server category on the left side of the dialog box, and click the Web Address tab.
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The Web Addresses panel appears.

4 Click the Add button.

The Add or Edit Alternate Address dialog box appears.

5 Enter an alternative URL, and click OK.

The new URL appears in the Alternate addresses list.

6 When you have entered all the alternative web addresses, click Close to exit the Administer Website dialog box and 

save your changes, or select another category to modify.

See also 

“Alternative website addresses” on page 229

Specify a guard page

Guard pages are web pages that Contribute places in folders containing administrative files and temporary copies of 

pages that have been sent for review. The guard page prevents users from browsing to a Contribute folder containing 

files that you don’t want them to access. 

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.

2 If prompted, enter the Administrator password, and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more 

information, see “Become an administrator of an existing Contribute website” on page 239.

The Administer Website dialog box appears.

3 Select the Web Server category on the left side of the dialog box, and click the Guard Page tab.

The Guard Page Panel dialog box appears.

4 Click Find Guard Page.
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The web page you specified as an index page for the site is set as the guard page. By placing a copy of the website’s 

index page in a folder, Contribute can redirect users to the home page of the website.

5 When you have specified a guard page, click Close to exit the Administer Website dialog box and save your changes, 

or select another category to modify.

See also 

“Web server index pages” on page 228

“Add index page filenames” on page 244

Enable compatibility with older versions of Contribute

Contribute offers administrators two compatibility options—one that allows users with earlier versions to work on the 

website, and one that does not:

• Transition mode 

In this mode, users of earlier versions of Contribute can continue working on the website, along with Contribute 

4.0 and later users. This lets you evaluate the new version and set up new roles and permissions without disrupting 

users with earlier versions of Contribute. 

• Compatibility mode 

In this mode, all users must use Contribute 4.0 or later. Users with earlier versions cannot work on the website. 

Contribute 4.0 or later starts in Transition mode by default when you migrate from an earlier version of Contribute. 

Use this mode temporarily; when you’re ready, transition all users to Contribute 4.0 or later and enable Compatibility 

Mode. 

1 In Contribute 4.0 or later, select Edit > Administer Websites, and then select a website.

The Administer Website dialog box appears.

2 Select Compatibility from the category list on the left.

The Compatibility options appear in the Administer Website dialog box.

3 Select Compatibility, and then click Close.

After you enable Compatibility Mode, all users connected to the website must use Contribute 4.0 or later. 

Set the expiry date for pages on the website

Administrators can set an expiry date for pages on the website. This way, older pages that are not relevant after a period 

of time can be deleted, or replaced with other pages. Authors can change the expiry date for individual web pages when 

publishing the files. 

Pages expired using the Administer Website dialog box must be deleted manually from the website using the Manage 

Page Expiry dialog box. 

The expiry date setting is applied to only those pages that are created after the administrator has configured this option. 

It is not applied to pages created or published previous to these settings being configured. Pages that are in a workflow 

cannot be deleted until they have completed the workflow.



249USING CONTRIBUTE CS4

Creating and managing website and blog server connections

Note: Information on expired pages is displayed under the website name on the first page of Contribute, and in the 

information bar of the browsed web page.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu. 

2 If prompted, enter the Administrator password and click OK. The Administer Website dialog box appears.

3 Select Page Expiry on the left panel.

4 In the right panel, select Enable Page Expiry to set an expiry date for the page. Do one of the following:

• Select Expire pages on, and set a specific date for page expiry. 

• Select Expire pages, and type the number of days for which the page can be live on the server. 

5 In the Page Expiry Action section, do one of the following:

• Select Replace the page with, and choose a page that replaces the expired page on expiry. For example, you can 

replace the expired page with a page saying, “Sorry, this page is no longer available on the website.”

• To delete the page, select Delete the page in the website.

Note: Specifying the delete option does not delete the pages from the website automatically after the expiry date. Delete 

expired pages manually using the Manage Page Expiry dialog box. 

Configure expiry settings for individual web pages

The Administrators of a website can use the Manage Page Expiry dialog box to do the following:

• Delete the expired page from the website

• Change the expiry settings for individual web pages on the website

• Expire individual pages ahead of their time

• Notify authors whose web pages are nearing the expiry date

• Sort the web pages by their expiry date. Administrators can view all the web pages on the site; authors can view only 

those pages assigned to them. 

It is possible to perform the same action on multiple files by selecting them in the list.

Note: Ensure that you are connected to the website before you open the Manage Page Expiry dialog box. 

1 Select Edit > Administer Websites > Manage Page Expiry. The Manage Page Expiry dialog appears. The list of web 

pages in the site along with their details are displayed in the panel.

2 Ensure that you are connected to the correct website by checking the Website field. To display pages for another 

website to which you are connected, choose the corresponding option from the Website pop-up menu.

3 You can filter the pages by their expiry date using the Show pop-up menu.

4 To inform the author that the web page is nearing its expiry date, select a page from the list, and click Notify. A 

compose mail dialog box of your favorite email editor appears containing information about the expired page. Edit 

and send the mail to the author. For multiple authors, compose a separate email for each author containing 

information on files authored by them.

5 To edit the expiry date for a page, click Edit. In the Edit Page Expiry dialog box, configure the expiry settings. For 

more information on configuring expiry settings, see “Set the expiry date for pages on the website” on page 248.

6 To delete a page from the website permanently, select a page from the list, and click Expire. The page is removed 

from the website or replaced with another page as specified by the settings in the Administer Website dialog box.

7 Click Close.
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Specify the type of path for links in a website

Certain pieces of code called paths are used to link Internet files. Software applications, such as a browser, use paths to 

locate a file. A browser can use a path to find, for example, an image file to display in an HTML page.

Administrators link web pages or files by specifying a path for them. The path to a file can be specified in any one of 

the following ways:

Document relative path  provides the location of a file in relation to another file on the same storage device. The 

starting point is the location of the document under consideration. 

Site-root-relative Websites are stored inside a main folder on a computer configured to work with browsers to display 

Web pages. This main folder is often referred to as the site root folder or just the root folder. A site root-relative path 

describes the location of a file relative to the root folder of the site. In other words, the starting point is the root folder 

of the site rather than the location of the document within the path. For example, the path can appear as: 

/html/images/image1.gif

The "/" indicates to the computer to search for a file within the site root folder. 

Site root-relative links are most often used with sites that have many directories with files that get moved around often. 

Absolute  provides the exact location of a file on the Internet. It doesn't specify the path in relation to something. The 

starting point is the location of the website on the Internet. 

For example, "http://my.site.com/html/images/image1.gif". 

When a file is inserted from your computer, Contribute writes the link in "file:///" URL format before publishing in 

Edit mode. The link settings are applied after the page is published to the site. The path is rewritten as document 

relative or site-root-relative depending upon link settings specified in Contribute.

When you insert files from websites, Contribute writes the link in a relative format if the files are from the same site 

(or domain). If the files are from different domains, Contribute uses the absolute format. The new Link setting affects 

the way the relative format is created. If the setting is for "Site root-relative," the links are created as root relative links.

For files inserted from the Internet, Contribute writes the links in an absolute format irrespective of the option 

specified in the Link setting.

For shared assets, and URLs in the same domain, Contribute writes the links in a "relative" format. In this case, the new 

Link setting decides the type of "relative" format. For all other cases, Contribute rewrites the link to the format chosen 

by the administrator.

When you publish a web page, Contribute updates all dependent links in the page. It also updates links to the current 

page in all its parents. In this process, Contribute rewrites all "file:///" links as relative links. The Link setting decides 

the type of relative link that is chosen.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu. 

2 If prompted, enter the Administrator password and click OK. The Administer Website dialog box appears.

3 Select Links on the left panel.

4 In the right panel, do one of the following

• Select Write links relative to the current page (document relative) to link files in the website using a document 

relative path.

• Select Write links relative to the root of the website (site root relative) to link files in the website using a site-

root-relative path.

5 Click Close.
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The Link setting is applied to all pages in a website. You can change the document relative setting to site-root relative 

for individual files when specifying the link for file types in the File Placement Rule dialog box. If you have selected the 

site-root-relative link, the option to insert a link as site-root-relative in the File Placement Rule dialog box is disabled.

Note: This setting overrides any role-specific setting for file placement.

Enable or Disable PDF Embedding

Contribute enables an Administrator to restrict users from embedding PDF documents as objects in a web page. If 

users are allowed to insert embedded PDF objects, they can choose to insert the document either as a link or as an 

embedded PDF. However, if users are not allowed to embed PDF objects, they only have the option to insert the PDF 

document as a link.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu. 

2 If prompted, enter the Administrator password and click OK.

The Administer Website dialog box appears.

3 Select the PDF Embedding category on the left side of the dialog box.

4 Select the Allow PDF Embedding or Do not allow PDF Embedding option.

Assign a workflow to a template

Administrators can assign a workflow to a template. Every template must be associated with a workflow. A default 

workflow for a template is applied if the Administrator does not assign a workflow to it.

Assign a workflow to a template

1 Select Administer > Website, and choose the website that you want to administer. The Administer Website dialog 

box appears. 

2 Select Workflow Association in the left panel.

In the template list on the right, select the template to which you want to assign a workflow.

3 In the workflow list, select the workflow that you want to assign to the selected template.

4 Click Associate. The workflow is linked to the selected template.

Any new page created using this template follows the associated workflow. 

Send connection keys for websites

Using the Export Connection Wizard (Windows) or Export Connection Assistant (Mac OS), you can easily set up 

connections to websites for other users by sending them a connection key. For more information about connection 

keys, see “Connection keys” on page 230.

Note: To send a website connection key to other users, you must create one or more Contribute website connections to 

share. For information about creating a Contribute website connection, see “Create a website connection” on page 231.

For information about sending connection keys for websites that CPS manages, see “Send connections for CPS 

managed sites” on page 253.
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Create a website connection key to share with users

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.

2 Do one of the following:

If the website has no administrator, click Yes when a dialog box asks whether you want to become the website 

administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

3 Select the Users and Roles category on the left side of the dialog box.

The Users and Roles Panel dialog box appears.

4 You can send a connection key file to a new user, or you can send a connection key to a user who has already 

connected to the site, and assign them a new role.

• To send a connection key to a new user, click Send Connection Key.

• To send a connection key to an existing user, assigning them a new role, select the user’s name from the list of 

connected users, and click Send Connection Key.
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The Send Connection Key Wizard (Windows) or Export Connection Key Assistant (Mac OS) appears. 

5 Follow the instructions in the wizard or assistant, and click Next (Windows) or Continue (Mac OS) to proceed to 

the next screen.

6 After completing the wizard or assistant, a new connection key file is created for the user, assigning them to a new 

role. 

You can e-mail the connection key file to the user or save the file to your computer.

7 Select another category to modify, or click Close to exit the Administer Website dialog box and save your changes.

See also 

“Connection keys” on page 230

“Create a website connection” on page 231

Send connections for CPS managed sites

If you use CPS to manage your website, you send users a connection key that connects them to the server. For more 

information about connection keys, see “Connection keys” on page 230.

Note: Before users can use a connection key to connect to a CPS managed website, you must add users to the website. If 

you haven’t already done so, see “Add users to websites that CPS manages” on page 254.

If you’re not using CPS to manage your website, see “Send connection keys for websites” on page 251 for information 

about sending connection keys.

Send a CPS connection key

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu.

If the website has no administrator, click Yes when a dialog box asks whether you want to become the website 

administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

2 Click the Users and Roles category on the left panel.
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3 Click Send Connection Key.

The Send Connection Key dialog box appears.

4 You can select to e-mail the connection link to the user, or to save the file to your local computer.

5 Select another category to modify, or click Close to exit the Administer Website dialog box and save your changes.

See also 

“Enable or disable CPS for a website” on page 236

Add users to websites that CPS manages

The User Directory service of CPS lets you add users from your organization’s LDAP or Active Directory service. 

Note: To add users to sites that CPS manages, you must have enabled CPS to work with your website. For more 

information, see “Enable or disable CPS for a website” on page 236.

For websites that CPS manages, you must manually add users to a website’s user list before those users can connect—

unlike non-managed websites where anyone with a connection key or connection information can connect to the site.

After you add a user to a website, you can send them a connection key or connection information to connect to the 

website.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and then select the 

website you want to administer from the submenu.

If the website has no administrator, click Yes when a dialog box asks whether you want to become the website 

administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

2 Select the Users and Roles category from the list on the left.

The Users and Roles panel of the Administer Website dialog box appears.

3 Click Add Users.

The Add Users dialog box appears.
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4 Select a role for the users you want to add from the Role for the new users pop-up menu.

The role you assign determines the editing permissions the new users have for modifying the site’s pages.

5 Use Search to find users, and then add them to the role you selected. 

6 (Optional) Select Send connection key e-mail to users to send an e-mail to the users you’ve added to the role. 

You can also have users type connect:server domain name (where server domain name is the name of the server 

where CPS is installed) in the Contribute browser address bar to connect to the website.

For more information about options in this dialog box, see “Setting the Add Users dialog box options” on page 277.

7 Click OK.

Contribute adds the specified users to the website and sends them e-mail that contains the connection key.

See also 

“Enable or disable CPS for a website” on page 236

Remove users from sites that CPS manages

CPS lets you add users to a website from your organization’s LDAP or Active Directory service (see “Add users to 

websites that CPS manages” on page 254). You can remove any users that you’ve added so that they cannot connect to 

the website.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and then select the 

website you want to administer from the submenu.

If the website has no administrator, click Yes when a dialog box asks whether you want to become the website 

administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

2 Select the Users and Roles category.

The Users and Roles panel of the Administer Website dialog box appears.

3 Select the name of the user who you want to remove and click Remove.

4 When you are finished removing users, click Close.

See also 

“Enable or disable CPS for a website” on page 236

“Add users to websites that CPS manages” on page 254

Configure dependent files for blogs

When you create a Contribute blog server connection, you can specify the types of files (audio, video, and image) that 

you can publish in blog entries to blogs hosted by the blog service.

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS) to display the My 

Connections dialog box, which lists all your connected blogs.
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2 Select the desired blog host, and click Configure.

The Configure Blog Server dialog box opens.

3 Select the publishing options for the blog host:

Allow images GIF, JPG, PNG, and so on

Allow audio MP3, WMA, WAV, and so on

Allow video MPG, MPEG, WMV, and so on

4 Click Close.

You can publish blog entries with the specified file types.

Manage website and blog server connections

You can use the My Connections dialog box to manage your website and blog server connections. The connection 

management options differ for non-CPS-managed websites, CPS-managed websites, and blog connections.

You can also use the My Connections dialog box to specify the types of audio, video, and image files that you can 

publish in blog entries.

For websites managed with CPS, you can either disable connections of individual sites, or you can remove the CPS 

connection. You cannot rename or remove an individual connection if it is managed using CPS.

For blogs, you can disable only the blog server. Disabling a blog server disables all blogs hosted on that server. You 

cannot disable individual blogs hosted by a server. Similarly, you can rename only the blog server listed in the My 

Connections dialog box, not individual blogs hosted by a blog server.

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

2 Select a website or blog server from the list of connections.
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3 Manage connections by doing any of the following:

• “Edit website and blog server connections” on page 257

If you use the Connection Wizard or Connection Assistant to create a connection, you can update the 

connection information when server or network configurations are altered (for example, changing network 

paths or a website’s URL).

Note: If you import a connection key, the only pieces of connection information you can edit are your name and 

your e-mail address.

• “Rename a website or blog server connection” on page 258

You can rename a website or blog server connection in Contribute.

You can rename only the blog server listed in the My Connections dialog box, not individual blogs hosted by a 

blog server.

• “Remove website and blog server connections” on page 259

You can delete an obsolete website or blog server connection from Contribute. When you delete the blog server 

listed in the My Connections dialog box, all individual blogs hosted by the blog server are deleted. You cannot 

delete individual blogs.

• “Disable individual website and blog connections” on page 260

You can disable website and blog server connections to improve the performance of Contribute by reducing the 

number of active connections.

• “Enable a website or blog server connection” on page 261

You can enable a website or blog server connection that you previously disabled.

• “Connect to websites and blog servers at startup” on page 261

You can configure Contribute not to connect to website or blog connections at startup, to improve the 

Contribute startup time.

4 Click Close.

Edit website and blog server connections

You can edit the connection information for any Contribute website or blog. You can modify a connection if any of 

its parameters change (for example, if you move a website to a different network location or change a blog’s URL).

Note: If you import a connection key for a website, the only connection information you can edit is your name and your 

e-mail address.

If you have open drafts, you can’t change your name or e-mail address for the website belonging to those drafts, nor 

can you change your user name or password for the blog belonging to those drafts. You must close the drafts before 

you can change that information.

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

2 Select a website or blog server from the list of connections.

3 Click the Edit button.

The Connection Wizard or Connection Assistant appears.
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4 Navigate through the Connection Wizard or Connection Assistant using the Next or Continue button, and modify 

the necessary website or blog server connections settings. 

For more information on the Connection Wizard or Connection Assistant website and blog server settings, see 

“Create a website connection” on page 231 and “Create a blog server connection” on page 233.

5 When you have modified the necessary connection settings for a website and verified that they are correct, you must 

send a connection file to users containing the new connection setting information.

Edit a website connection for a website that CPS manages

1 Close any open drafts of the website to which you want to modify the connection.

Contribute does not modify the connection information for a website in which you’re editing pages.

2 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

3 Select a website from the list of connections.

4 Click the Edit button.

The Edit Connection wizard appears.

5 Make changes as necessary, and then click Done when you are finished.

6 Click Close to close the My Connections dialog box.

See also 

“Remove website and blog server connections” on page 259

“Disable individual website and blog connections” on page 260

“Enable a website or blog server connection” on page 261

“Connect to websites and blog servers at startup” on page 261

Rename a website or blog server connection

You can rename a website or blog server connection as it appears in Contribute. The new name appears in the Home 

Pages menu, the My Connections dialog box, and, if you rename a website, the Administer Websites submenu. 

Renaming the website or blog server connection doesn’t change the actual name of the website or blog server; it 

changes how the website or blog server is referred to in Contribute.

Note: You cannot rename a website connection for a site managed with CPS. Website names come from the title of the 

site’s home page. To ensure that sites are easily identifiable, give the home page a meaningful name. Additionally, you 

can rename only blog server connections, not individual blogs hosted on that blog server.

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

2 Select the desired website or blog server connection from the list of connections.

3 Click the Rename button.

The website or blog server connection name is highlighted by an editing box.

4 Click inside the editing box, and enter a new name for the website or blog server connection.

5 Press Enter or Return to apply your changes.
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6 Click Close to save your changes and close the My Connections dialog box.

See also 

“Disable individual website and blog connections” on page 260

“Enable a website or blog server connection” on page 261

“Connect to websites and blog servers at startup” on page 261

Remove website and blog server connections

You can remove Contribute website and blog server connections when they are not needed. Removing a Contribute 

connection does not remove the website or blog server; it removes only the website or blog server connection 

information.

The process for removing a website can differ slightly, depending on whether the website uses CPS.

For information about removing unpublished drafts from a disabled website or blog, see “Remove unpublished drafts 

in a disabled website or blog” on page 261. 

1 Close any open drafts for the website or blog entries hosted by the blog server you are removing.

Contribute does not remove a connection to a website or blog in which you’re editing pages.

2 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

3 Select a website or blog server from the list of connections.

4 Click Remove.

Contribute removes the website or blog server connection from the My Connections dialog box. All blogs hosted by 

the deleted blog server are also deleted.

Remove a CPS-managed website connection

1 Close any open drafts for the website you are removing.

Contribute does not remove a connection to a website in which you’re editing pages.

2 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

3 Select a website from the list of connections.

4 Click Administer.

The Administer Website dialog box appears.

5 Select Administration from the category list on the left.

6 Click Remove Administration button.

A confirmation dialog box appears.

Note: Contribute removes the website connection from the Websites list in the CPS Console. The next time you log in 

to the console, the website will not be on your list. If the website still appears in the list, click the Delete button in the 

console to remove the website.

7 Click Yes to continue.



260USING CONTRIBUTE CS4

Creating and managing website and blog server connections

Contribute removes the connection information and administrative settings file (including user roles and website 

permissions) associated with this website. Users who were connected to this website cannot connect to it.

If users need to connect to this website, you need to create a connection and recreate roles and reset permissions. 

Then, send connection keys with new connection information to users. 

8 Click through Close twice.

See also 

“Edit website and blog server connections” on page 257

“Rename a website or blog server connection” on page 258

“Enable a website or blog server connection” on page 261

“Connect to websites and blog servers at startup” on page 261

Disable individual website and blog connections

When Contribute starts, it verifies all the connections defined in the My Connections dialog box and opens a 

connection to each defined website and blog. Sometimes, a website or blog may not be available. For example, the 

network connection may be weak or inconsistent, the network may time out, or the server may have exceeded the 

maximum number of connections. If one or more of the websites or blogs are unavailable for any reason, Contribute 

cannot open those connections.

Note: If Contribute can’t connect to a website or blog, it may automatically disable that connection. An alert that 

Contribute is not connected to the website or blog appears in the Contribute browser.

To improve Contribute performance, you can disable connections to websites and blog servers that you don’t need to 

update frequently. Defining many websites and blog servers requires multiple network connections over an extended 

period, which impacts performance. When you need to edit the website or blog, you can enable the connections.

Disabling a connection for CPS-managed websites works the same as it does for non-CPS-managed websites. In 

addition, disabling a blog server connection works like disabling websites managed by CPS.

If you do not want your website to be managed by the publishing server (CPS), you may disable the publishing server 

from the Administer Website dialog box. For more information, see “Disable CPS for a website” on page 238.

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

2 Select the desired website or blog server connection from the list of connections. (Disabled connections are marked 

with a red slash.)

3 Click the Disable button.

4 A dialog box appears, informing you that the connection has been disabled. Click OK to verify that this is the 

connection you want to disable. If you have inadvertently disabled the wrong connection, you can re-enable the 

connection; for more information, see “Enable a website or blog server connection” on page 261.

5 Click Close to save your changes and close the My Connections dialog box.
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See also 

“Edit website and blog server connections” on page 257

“Rename a website or blog server connection” on page 258

“Connect to websites and blog servers at startup” on page 261

Remove unpublished drafts in a disabled website or blog

When you use the My Connections dialog box to remove a connection to a website or blog that contains unpublished 

drafts, Contribute warns you that you must either cancel or publish the unpublished drafts before you can remove the 

connection.

Enable a website or blog server connection

If you disable a website or blog server connection, or if Contribute automatically disables it because it can’t connect to 

the website or blog server, you can enable it later.

❖ Click Connect in the toolbar.

Enable any website or blog server connection

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

2 Select the desired website or blog server connection from the list of connections. (Disabled connections are marked 

with a red slash.)

3 Click the Enable button.

4 Click Close to save your changes and close the My Connections dialog box.

See also 

“Edit website and blog server connections” on page 257

“Rename a website or blog server connection” on page 258

“Remove website and blog server connections” on page 259

Connect to websites and blog servers at startup

During startup, Contribute will not connect to any website or blog server. However, you can select the desired website 

or blog server and configure Contribute to connect to it during startup. You can also configure Contribute to connect 

to all websites and blog servers at startup.

Define connection settings for individual sites and blogs

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

2 Select a website or blog server.

Note: By default, Contribute is configured not to connect to any website or blog server. To modify this behavior, see 

“Define connection settings for all sites and blogs” on page 262.

3 Clear the selection of the Don’t connect to website or blog server name at startup check box to configure Contribute 

to connect to the selected website or blog server at startup. 
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Note: You cannot set this option for a specific blog entry. 

Next time you start Contribute, a connection is established to the selected website or blog server only. In the case of 

blog connections, all blog entries in the selected blog server will be enabled. 

For more information on accessing websites that CPS manages, see “Understanding server access for connecting to 

CPS-managed websites” in Deploying Contribute and Contribute Publishing Server. 

You can configure Contribute to connect to all websites and blog servers at startup.

Define connection settings for all sites and blogs

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Mac OS).

The My Connections dialog box appears.

2 Select each website and blog connection, and do the following:

• Enable the connection.

• Clear the selection of the Don’t connect to website or blog server name at startup check box.

3 Clear the selection of the Don't connect to any site at startup (improves Contribute startup time) check box.

4 Click Close.

When you restart Contribute, all connections enabled before closing Contribute, remain enabled. 

See also 

“Edit website and blog server connections” on page 257

“Rename a website or blog server connection” on page 258

“Remove website and blog server connections” on page 259

“Disable individual website and blog connections” on page 260

Reference

This section provides information about the dialog boxes introduced in this chapter.

Setting options for the Publishing Server

Use this dialog box to open the Enable Publishing Server dialog box. You can enable the Contribute publishing server 

using this dialog box.

See also 

“Setting the Enable Publishing Server dialog box options” on page 263
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Setting the Enable Publishing Server dialog box options

Use the Enable Publishing Server dialog box to enable CPS for your website.

1 Enter the Publishing Server web address (URL) for the server running CPS.

The format for the web address is http://server:port/contribute/ 

It contains the following components:

• Server: This is the DNS name or IP address of the server on which CPS is installed.

• Port: This is the network port number used by the server on which CPS is installed. 

Note: If you used the CPS Simple installation, the port number is 8900. If you used the CPS WAR file installation 

in an existing Java Application Server, the port number varies with your server’s configuration.

• Contribute: This is the name of the server. You must append contribute to the path.

For example, if you installed the CPS on a server named cpsserver, the web address would be 

https://cpsserver:8900/contribute.

2 By default, the Enable User Directory check box is selected. If you will not use the User Directory service to manage 

users, deselect this option.

Note: When you enable the User Directory, any users who previously connected to the site are removed, and any 

connection keys you may have previously sent no longer work. You must add users from your LDAP/Active Directory, 

or file-based user database. To learn how to add users to sites that CPS manages, see “Add users to websites that CPS 

manages” on page 254.

3 Click OK.

Contribute establishes a connection to the server.

See also 

“Enable or disable CPS for a website” on page 236

Entering information in the Log in to Publishing Server dialog box 

The Log in to Publishing Server dialog box appears each time you access a website that CPS manages. Use this dialog 

box to enter user information so that Contribute can establish a connection with the server running CPS.

1 Enter your username and password.

This is your CPS login information.

Your CPS login information is the same as your network login information if the CPS administrator used an LDAP 

directory to add users to the website.

2 Select the Remember password check box to have Contribute remember your password in the future.

3 If you see the Trust this server check box, select this option to allow Contribute to trust the server you are 

connecting to.

This option appears the first time you connect to this server or when server information changes (for example, 

when the security certificate expires). To verify that you can trust this server before you select the check box, do the 

following:

• Click the Certificate link and note the Public key fingerprint.

• Ask your CPS administrator to verify that the public key fingerprint is valid.
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Creating a connection with the Connection Wizard or Connection Assistant

Each Connection Wizard or Connection Assistant screen asks for information about you or the website or blog you 

want to connect to. After you finish entering the information in the Connection Wizard or Connection Assistant, 

Contribute creates a connection so that you can update or modify your website or blog.

❖ Click Next or Continue to proceed to the Connection Information screen.

See also 

“Create a website connection” on page 231

“Create a blog server connection” on page 233

“Providing your name and e-mail address” on page 265

“Create or edit a website or blog server connection” on page 264

Create or edit a website or blog server connection

The purpose of the Create Connection and Edit Connection wizards is to specify whether you’re connecting to a 

website or a blog server while creating or editing a connection in the Connection Wizard.

Create or edit a website connection

1 Select Website from the What do you want to connect to pop-up menu to create a connection to a website.

2 Do one of the following:

• If you’re connecting to a website, enter the URL for the website in the What is the web address (URL) of your 

website text box.

Note: If necessary, click the Browse button to find the website you want to connect to.

3 From the How do you connect to your web server pop-up menu, select your connection service and do one of the 

following:

• If you selected FTP, enter the FTP server name, user name, and password.

Note: If the FTP server is running on a port other than the default port (21), you must specify the port number 

along with the FTP server name in the format FTP server name:port number.

• If you selected Secure FTP (SFTP), enter the SFTP server name, user name, and password.

• If you selected Local/Network, enter the network path to your website.

• If you selected WebDAV, enter the WebDAV URL, user name, and password.

4 (Optional) Click Advanced, and select the appropriate advanced connection options for the connection service you 

specified in step 3.

5 Click Next.

6 On the Summary screen, review the connection settings to verify that they’re correct and click Done (Windows) or 

Finish (Mac OS) to complete the connection to the website.

Create or edit a blog server connection:

1 Select Blogs from the What do you want to connect to pop-up menu to create a connection to a blog server.

2 Select the blog server hosting your blog from the Who hosts your blog pop-up menu. For more information on 

creating connections to blogs, see “Create a blog server connection” on page 233.
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3 Click Next or Continue to proceed to the next screen.

4 If you are connecting to a blog server using the blog URL do the following: 

a Select Other Blog Servers from the Who hosts your blog pop-up menu if your blog is hosted on an internal server 

that supports the MetaWeblog protocol. The What is the URL of your blog text box and Browse button appear.

b (Optional) In the What is the URL of your blog text box, type or browse to the URL of the home page of your 

blog.

c Click Next. The Blog Site Connection Information screen of the Create Connection wizard appears.

If you selected Blogger, or if Contribute is able to find the access point of the blog server whose URL you 

specified, only the Enter your blog server user name and Enter your blog server password text boxes appear. 

However, if you selected Other Blog Servers, or if Contribute is unable to find the access point of the blog server 

you specified, the Blog Protocol pop-up menu (which is disabled) and the Access Point text box also appear.

d Enter your user name in the Enter your blog server user name text box.

e Enter the password to connect to your blog in the Enter your blog server password text box. 

f If the Access Point text box appears, specify the access point.

Note: The access point is a URL used to connect to your Blog server. You can view a list of common access points 

in the Help documentation. Press F1 to view online help.

5 Click the Back or Go Back button to return to a previous screen if necessary.

6 Click Done.

Contribute creates a connection to the blog server, and the blog’s home page appears in the Contribute browser.

See also 

“Create a website connection” on page 231

“Create a blog server connection” on page 233

Providing your name and e-mail address

The purpose of this dialog box is to enter your user name and e-mail address to identify you and the web pages you are 

working on. This information appears to other users of your website when you’re working on pages on the website. 

If you become the first administrator of the website, the name you enter here is shown to users as the name of the 

website administrator.

Note: Your name and e-mail address are seen only by other users who use Contribute or Dreamweaver to connect to your 

website. This information is not sent to Adobe or anywhere else, nor is it displayed on your website. External visitors to 

your website do not see the e-mail address you enter.

❖ Enter your name and e-mail address.

If you have multiple copies of Contribute, use a different user name for each machine that has a copy. For example, 

Chris(laptop) and Chris(Mac). Using the same user name can cause problems because you can override checkouts 

you make on the other computer.

Providing your website’s URL

The purpose of this dialog box is to provide information about the web address (URL) of your website or the server 

running CPS. 
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The web address you specify should be the root of the website, that is the highest point in the directory structure that 

a user is allowed to edit. In some cases, this may be the entire website (for example, www.mysite.com). However, in 

certain cases, if you are administering a website, you may want to restrict a permission group to editing only a 

subsection of the website. For example, if a group cannot edit web pages only in the marketing section of the website, 

the highest point you might give them access to may be www.mysite.com/marketing.

To provide your website’s web address:

❖ Enter the web address (URL) of the website.

If you aren’t sure of the exact web address of the website, click the Browse button and browse to the main page of 

your website.

Note: If the web address you enter cannot be verified, a dialog box prompts you to confirm that you are entering the 

correct address. You can use this dialog box to confirm a web address that does not yet exist but that you intend to 

create later (for example, you may not yet have created a subfolder under the site’s root).

If your organization uses CPS, you can enter the URL of your server to set up a connection. If you don’t know the 

URL, contact your system administrator for information on connecting to CPS.

Contribute expands the server name you enter to the full URL for the server running CPS. For example, if you enter 

connect:cpsserver, Contribute expands the full URL to https://cpsserver:8900/contribute/.

To provide your server web address for CPS:

❖ Enter the URL of the server you want to connect to.

See also 

“Selecting a connection method” on page 266

“Enable or disable CPS for a website” on page 236

Selecting a connection method

The purpose of this dialog box is to select a connection method for you or your users and to provide required 

information about your connection.

The connection method indicates how you or your users connect to the website and transfer new and updated files 

between Contribute and the website. In general, users working in your organization’s offices use a local or network 

connection; users working remotely may need to use FTP or SFTP to transfer files to the web server.

1 Select one of the following options from the pop-up menu:

• Local/Network 

• FTP (File Transfer Protocol) 

• Secure FTP (Secure File Transfer Protocol)

• WebDAV

2 Complete the dialog box:

• If you select Local/Network, enter the network path of the web server and the folder (directory) that contain the 

website’s files. 

The network path is not a path to the location where files will be stored locally; it’s a path to the location of the 

files on the web server. If you haven’t created a website root folder, you can use the default website root folder 

on the server. (The default varies between servers.)
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You can type the path directly in the text box, but using the Browse button to browse the web server ensures 

that the path is accurate. The network path for a Windows network always starts with two back-slashes (\\) 

rather than with a drive letter.

• If you select FTP or Secure FTP, you must provide the name of the server. 

Note: It is recommended that you require users to use their own FTP or SFTP account information. Make sure 

users understand how to enter their own login information—many users don’t understand that FTP or SFTP login 

information is different from their network login information. It’s a good idea to have your FTP, SFTP, or 

WedDAV accounts tied to your user directory service so that users do not have to know or remember another 

password.

Entering user information for your blog host

The purpose of this dialog box is to provide the user name and password for the blog to which you want to connect.

The blog host you selected in the previous screen determines the information you need to enter. If you selected 

Blogger, TypePad, or WordPress as your blog host in this screen, you must enter the user name and password for the 

blog. If you selected Other Blog Servers, you must enter the URL for the blog as the access point as well as the user 

name and password.

Note: The desired blog host must support the MetaWeblog API.

1 If you selected Other Blog Servers as your blog host in the previous screen, enter the URL for the blog to which you 

want to connect.

For a list of blog server access points, see “Blog server access points” on page 267.

If you selected Blogger, TypePad, or WordPress as your blog host, it is automatically specified as the access point.

2 Click Next.

3 In the Enter your blog server username field, enter your user name for the blog.

Note: If your blog host is WordPress, your username must not contain any reserved characters, such as $.

4 In the Enter your blog server password field, enter your password for the blog.

The blog protocol appears.

5 Click Next to proceed to the next screen.

See also 

“Selecting a connection method” on page 266

“Create a blog server connection” on page 233

“Create or edit a website or blog server connection” on page 264

Blog server access points

An access point is a URL used to connect to your blog server, and can usually be found in your blog server 

documentation. The following tables include access points for commonly used blog servers.

Access points for servers supported by Contribute:
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Access points for customized servers

Note: These servers may or may not be supported depending on the extent of customization.

Providing FTP or SFTP information

The purpose of this dialog box is to enter information about the FTP or SFTP server.

To let users connect by using FTP or SFTP, be sure you know the server name, user name, and password required to 

connect to the server. If you’re not sending users your FTP or SFTP login information, make sure they understand how 

to enter their own login information. Many less experienced computer users don’t understand that FTP or SFTP login 

information is different from the user name and password they might use to log in to their local computer network.

1 Enter the FTP address of your server.

2 Enter the FTP user name.

Your FTP user name and password may be different from your network user name and password.

Blogger (Atom) https://www.blogger.com/atom/

TypePad (TypePad) http://www.typepad.com/t/api

WordPress.com (MovableType or 

metaWeblog)

http://USERNAME.wordpress.com/xmlrpc.php

MovableType (MovableType) http://YOURSITE/PATH/TO/mt-xmlrpc.cgi

WordPress own server 

(MovableType or metaWeblog)

http://YOURSITE/PATH/TO/xmlrpc.php

BlogHarbor (MovableType) http://api.blogharbor.com/xmlrpc.cgi

Blogware (MovableType or 

metaWeblog)

http://www.blogware.com/xmlrpc.cgi

Conversant (MovableType or 

metaWeblog)

http://YOURSITE/RPC2

Drupal version 4.4 and up 

(MovableType or metaWeblog)

http://YOURSITE/PATH/TO/xmlrpc.php

IlohaBlog (MovableType) http://blog.iloha.net/rpc.php

Manila (metaWeblog) http://YOURSITE/RPC2

Nucleus < 2.5 (metaWeblog) http://YOURSITE/PATH/TO/nucleus/xmlrpc/server.php

Nucleus 2.5 and up (MovableType 

or metaWeblog)

http://YOURSITE/PATH/TO/nucleus/xmlrpc/server.php

PLog (metaWeblog) http://YOURSITE/xmlrpc.php

pyblosxom (metaWeblog) http://YOURSITE/PATH/TO/cgi-bin/pyblosxom.cgi/RPC

Radio (metaWeblog) http://127.0.0.1:5335/RPC2

Serendipity (MovableType) http://YOURSITE/serendipity/serendipity_xmlrpc.php

SquareSpace (metaWeblog) http://www.squarespace.com/do/process/external/PostInterceptor

TextPattern (metaWeblog) http://YOURSITE/PATH/TO/textpattern/xmlrpcs.php

Xaraya (MovableType or 

metaWeblog)

http://YOURSITE/PATH/TO/ws.php?type=xmlrpc
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3 Enter the FTP password

4 (Optional) To configure FTP to work with a firewall, click the Advanced button. For more information, see “Setting 

advanced connection settings” on page 269.

Some organizations use a firewall, a system that prevents unauthorized access to an intranet from outside. If your 

organization has a firewall, you may need to configure Contribute to work with it. You would also need to know 

whether your firewall supports passive FTP and whether you must provide a firewall host name and port number. If 

you are not sure how the firewall supports FTP access, consult your organization’s network administrator. 

Providing WebDAV information

The purpose of this dialog box is to enter the web address (URL) of the WebDAV server, your WebDAV user name, 

and your WebDAV password. 

1 Enter the web address (URL) for the WebDAV server.

The web address used by the WebDAV server is typically different from that used to serve the site. The WebDAV 

address may have a port number appended to it, or other WebDAV designation.

2 Enter the WebDAV user name.

Note: Your FTP user name and password may be different from your network user name and password.

3 Enter the WebDAV password.

4 (Optional) To encrypt connection information for all websites, click the Advanced button. For more information, 

see “Setting advanced connection settings” on page 269.

This option prevents unauthorized users from modifying your website when using the locally installed copy of 

Contribute.

See also 

“Create a website connection” on page 231

“Create or edit a website or blog server connection” on page 264

Setting advanced connection settings

The purpose of this dialog box is to set options for your organization’s FTP connection and firewall, and to apply 

additional security for accessing your website. 

❖ To set advanced connection settings, select the options you want to apply:

Let Contribute Automatically Detect FTP Server Settings Lets Contribute automatically detect the FTP settings of 

the server to which you are connecting. If you select this option, the manual FTP settings are disabled.

Choose FTP Server Settings Manually Lets you specify the FTP settings to use with your server.

Use Passive FTP To Connect To The Server Lets Contribute initiate the FTP connection, rather than relying on the 

remote server to set it up. To use passive FTP, the firewall must be configured to allow the FTP client to set up the 

FTP connection. 

Use FTP Performance Optimization Lets Contribute optimize the connection for better performance. 

Use Alternative Publish Method Lets you use rollback files with FTP connections. If rollbacks are enabled and you 

receive errors when you publish pages, select this option to change the way Contribute writes rollback files to the 

FTP server.
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Use FTP Proxy Settings When Connecting Lets you specify a firewall host and the port number through which FTP 

access is allowed. If you select this option, or if you click the FTP Proxy Settings button, the FTP Proxy category of 

the Preferences dialog box appears; enter the name and port number of the FTP Proxy host through which FTP 

access is enabled.

Note: The FTP Proxy category is part of the Contribute Preferences dialog box. The FTP Proxy host and port number 

are global settings for the entire application, not just for the website connection you are creating. You cannot create 

multiple Contribute website connections using different FTP Proxy settings.

Encrypt Connection Information For All Websites And Blog Sites Prevents unauthorized users from modifying 

your website when using the locally installed copy of Contribute. 

Require Contribute Startup Password On User’s Computer (For Connection Export Only) Lets you protect access to 

websites from unauthorized users by requiring anyone using your computer to log in to Contribute. If you select 

this option, Contribute opens the Security Preference dialog box; type the login password you want users to enter 

and then confirm the password.

Note: The Security category is part of the Contribute Preferences dialog box. The Contribute startup password is a 

global setting for the entire application, not just for the website connection you are creating. 

FTP remote directory path

This dialog box appears if the Connection Wizard can’t automatically discover the proper path. The FTP path you 

enter must match the URL path. If this dialog box appears, ensure that the FTP path you entered matches the URL 

path containing your website’s files.

If you have correctly entered the FTP path, the folder you are attempting to connect to may not have appropriate 

read/write permissions.

Setting the Publishing Server options in the Administer Website dialog box 

The purpose of this dialog box is to enable or disable CPS for your website. 

CPS is a suite of publishing and user management services that enables you, among other things, to integrate 

Contribute with your organization’s user directory service so that you can easily manage large numbers of Contribute 

users. 

Enable CPS

❖ Click the Enable Publishing Server button to enable your website to use CPS.

Note: Before you can start using CPS with your website, you must install and configure CPS (see CPS Console Help for 

information about configuring).

Disable CPS or modify your settings

❖ Do any of the following:

• Click the Disable Publishing Server button to disable CPS for this website.

A dialog box that asks you to confirm disabling CPS appears.

When you disable CPS, users who were connected to the website cannot connect until you re-enable CPS. 

Contribute does not remove the administrative settings file for the website when you disable CPS, so roles and 

permissions are unaffected.

• Click the Disable User Directory button if you do not want to use the User Directory service to manage users for 

this website.
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When you disable the User Directory service, users who were connected to the website cannot connect until you 

send them connection keys with new connection information. 

Setting the Users and Roles options in the Administer Website dialog box for 

CPS-managed sites

The purpose of this dialog box is to create roles, assign users to roles, remove user access to the site, and send 

connection links to users of websites using CPS.

Add users to a role

1 Click Add Users.

2 Complete the Add Users dialog box. 

For more information, see “Add users to websites that CPS manages” on page 254.

Assign a user to a different role

1 Select the user you want to reassign from the list of users.

To select multiple users, click the first user, and hold down the Control key and click additional users. 

2 Click Reassign.

The Reassign Role dialog box appears.

3 Select a role to reassign the user, and click OK.

The user now appears beneath their reassigned role in the Users and Roles category of the Administer Website 

dialog box.

4 To reassign additional users, repeat steps 1 through 3.

Remove a user from the site

1 Select the user from the list of users.

2 Click Remove.

3 To remove additional users, repeat steps 1 and 2.

See also 

“Create Contribute roles” on page 281

Setting the Users & Roles options in the Administer Website dialog box

The purpose of this dialog box is to manage users who have previously connected to a website. You can change a user’s 

role and send them a new connection key, or remove users from the list, disabling their ability to connect to the site.

Change a user’s role

1 Select the user from the list of users who have previously connected to the site.

2 Click the Send Connection Key button.

The Export Key File Wizard (Windows) or Export Key File Assistant (Mac OS) appears.

3 Follow the instructions in the wizard or assistant, and click Next (Windows) or Continue (Mac OS) to proceed.
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After you complete the tasks in the wizard or assistant, Contribute creates a new connection key file for the user that 

assigns them to a new role. You can e-mail the connection key file to the user or save the file to your computer.

Remove a user from the site

1 Select the user from the list of users who have previously connected to the site.

2 Click the Remove button.

Note: Removing a user from the list does not prevent that user from reconnecting with a previously issued connection key 

or re-entering site connection information.

See also 

“About creating and sending website connections” on page 228

“Create a website connection” on page 231

“Send connection keys for websites” on page 251

“Selecting an export method for the connection key” on page 276

Assigning a role

The purpose of this dialog box is to assign users a role. 

❖ Select the role you want to assign the user, and then click OK.

Reviewing the connection summary

The purpose of this dialog box is to review a summary of the connection information you entered.

1 Review the information.

2 Click the Back button to return to a previous screen to change a setting, and then return to the Summary screen.

3 Click Done (Windows) or Finish (Mac OS) if you are satisfied with the settings, or click Cancel if you do not want 

Contribute to create the connection.

Setting the Administration options in the Administer Website dialog box

The purpose of Administration options is to set the administrator’s contact information, establish an administrator’s 

password, and, if necessary, remove administration for a website.

1 Enter an e-mail address in the Contact e-mail address field to set or change the contact information for the website’s 

administrator. 

This e-mail address appears in the Contribute information bar when the user might need to contact the 

administrator. More than one person can belong to the Administrator role in Contribute, but only one person can 

be the administrator contact.

2 To remove the shared settings file for the website, click Remove Administration.

Important: This option removes the connection information and administrative settings file (which includes all user 

roles and website permissions) associated with this website. Users who were connected to this website cannot connect.
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See also 

“Change the website administrator” on page 242

“Change the administrator’s password” on page 242

Entering information in the Administrator’s Password dialog box

The purpose of this dialog box is to create an administrator’s password so that you can become the administrator for 

the website you selected.

1 Enter an administrative password for the website.

2 Enter the password again to confirm it.

See also 

“Become an administrator of an existing Contribute website” on page 239

Setting the Administer Website dialog box options

The purpose of this dialog box is to set settings that affect the whole website, such as the administrator’s contact or 

password information, the number of rollback versions of pages to save, and filename conventions for website default 

home pages. 

You can perform the following tasks with this dialog box:

“Change the website administrator” on page 242

“Change the administrator’s password” on page 242

“Enable or disable rollbacks” on page 243

“Specify alternative website addresses” on page 246

“Add index page filenames” on page 244

“Specify new page preferences” on page 243

“Remove index page filenames” on page 245

“Specify a guard page” on page 247

“Enable compatibility with older versions of Contribute” on page 248

“Set the expiry date for pages on the website” on page 248

“Specify the type of path for links in a website” on page 250

“Enable or Disable PDF Embedding” on page 251

“Assign a workflow to a template” on page 251

Entering information in the Change Administrator’s Password dialog box

The purpose of this dialog box is to change the administrator’s password.

1 Enter your current password and the new password you want to use. 

2 Enter the new password again to confirm it.

3 Click OK.
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See also 

“Change the administrator’s password” on page 242

Setting the Index and URL Mapping dialog box options

Depending on your web server configuration and the complexity of your website, Contribute may not be able to 

automatically detect all possible web server configurations. The purpose of this dialog box is to specify alternative 

configurations for your website’s index files and alternative web addresses.

Note: As with the general site-wide settings, the advanced site-wide settings apply to all users who connect to the website 

using Contribute.

• Index files

An index page is the web page that appears by default when a visitor visits a website. For example, if you enter the 

address www.mysite.com/ into a web browser, the page that appears may actually have the URL 

www.mysite.com/index.html.

Contribute includes a comprehensive list of possible index page names arranged in the order that they most often 

occur; however, you may need to specify exact page filenames and display order. For more information, see “Web 

server index pages” on page 228.

• Alternative website addresses

Some websites have multiple web addresses (URLs) that point to the same web pages. These sites use Domain Name 

Service (DNS) aliases, which allow several web addresses to refer to a single website. For example, www.mysite.com 

and www.mysite.org are technically different website addresses, but could point to the same website. If your website 

uses more than one web address, you must configure Contribute to recognize all the possible web addresses. For 

more information, see “Alternative website addresses” on page 229.

You can perform the following tasks with this dialog box:

• “Entering an index filename” on page 274

• “Entering an alternative website address” on page 275

Entering an index filename

The purpose of this dialog box is to add or edit a filename for an index page.

❖ Do one of the following:

• Enter a filename for an index page that your website and web server use.

• Change the filename in the Index filename text box.

See also 

“Web server index pages” on page 228

“Add index page filenames” on page 244

“Remove index page filenames” on page 245

“Specify alternative website addresses” on page 246
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Entering an alternative website address

The purpose of this dialog box is to enter an alternative URL for your website.

❖ Do one of the following:

• Enter a new alternative URL for your website.

• Change the alternative URL in the Alternate website address (URL) text box.

See also 

“Alternative website addresses” on page 229

“Specify alternative website addresses” on page 246

Selecting the connection key settings

The Export Connection Wizard (Windows) or Export Connection Assistant (Mac OS) lets you send your current 

connection information or customize your existing settings as needed for use by other permission groups. 

❖ Select one of the following:

• Click Yes if want to send your current connection settings, unaltered.

• If you are using FTP or SFTP to connect to the website, you can select the Include my FTP username and 

password option so that users are not prompted to enter their individual FTP user name and password.

If you select this option, the next screen that appears lets you select the permission group to send the connection to.

• Click No to modify your connection settings before you send the connection.

If you select this option, the next panel of the Export Connection Wizard lets you select the method users will 

use to connect to the website.

See also 

“Selecting a connection method” on page 266

Selecting a role for sites by using Contribute Publishing Server

The purpose of this dialog box is to select a role to assign to users. 

❖ Select the role you want to assign the user, and click Next.

See also 

“Add users to websites that CPS manages” on page 254

Selecting a role

The purpose of this dialog box is to select the role to which you want to belong, if you did not choose to be the website’s 

administrator.

The default role options are Administrator, Publisher, and Writer.

Note: (To administrators) Roles are not password protected. To require a user to use a specific role, send a connection key 

that assigns that role to the user.

❖ Select the role that you want, and click OK.
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See also 

“Reviewing the connection summary” on page 272

Selecting an export method for the connection key

The purpose of this dialog box is to send the connection key to users by e-mail or save it to your local computer or a 

file server on the network.

1 Select whether you want to send the connection key to users by e-mail, or save it as a file to your local computer.

The method you select depends on whether you send it using web-based e-mail or another e-mail application:

• If you use a web-based e-mail account (such as Hotmail or Yahoo!) to send the connection key, save the 

connection key as a file on your local disk and attach it manually to the e-mail message.

• If you select to save the key to disk, you can decide whether to save the connection key to your computer’s local 

disk or to a network location.

• If you send the file to users through a non-web-based e-mail application, your e-mail application starts up when 

the Export Connection Wizard (Windows) or Export Connection Assistant (Mac OS) finishes running. The e-

mail application then creates an explanatory e-mail message with the connection key attached.

Note: In Mac OS, Contribute works with the following default e-mail applications: Mail, Eudora, and Entourage. 

2 Enter a password or pass phrase to encrypt the connection key, and then enter it again.

To protect your website and ensure the safety of your network, connection keys are encrypted using a password or 

pass phrase that you select. (A pass phrase is like a password but can be longer than one word.) Be sure you send 

the connection key encryption password to the users who will import the website connection. Without knowing 

the correct password, users cannot import the website.

Note: Do not include the password you use to encrypt the connection key in the e-mail message with the connection 

key. Send the password in a separate message, or communicate it to users verbally.

See also 

“Reviewing the connection summary” on page 272

Setting the Send Connection Key dialog box options for sites by using CPS

The purpose of this dialog box is to send the connection key to users of managed websites by e-mail or save it to your 

local computer or a file server on the network.

❖ Select whether you want to send the connection key to users by e-mail, or save it as a file to your local computer, 

and click OK.

The method you select depends on whether you send it using web-based e-mail or another e-mail application:

• If you use a web-based e-mail account (such as Hotmail or Yahoo!) to send the connection key, save the 

connection key as a file on your local disk and attach it manually to the e-mail message.

• If you select to save the key to disk, you can decide whether to save the connection key to your computer’s local 

disk or to a network location.

• If you send the file to users through a non-web-based e-mail application, your e-mail application starts up when 

the Export Connection Wizard (Windows) or Export Connection Assistant (Mac OS) finishes running. The e-

mail application then creates an explanatory e-mail message with the connection key attached.

Note: In Mac OS, Contribute works with the following default e-mail applications: Mail, Eudora, and Entourage. 
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Setting the Add Users dialog box options

The purpose of the Add Users dialog box is to add users to websites that use the User Directory service to manage users.

1 Select a role for the users you want to add from the Role for the new users pop-up menu.

The role you assign determines the editing permissions the new users have for modifying the site’s pages.

2 Add users to the role you selected. 

The Search Results panel lets you locate users in your organization’s user directory and add them to the list of users 

for the role you’ve selected. Do the following to find and add user names to a role: 

a Enter a name in the Search text box, and click Search. Contribute displays the closest matches it finds in the 

Search Results list. 

b Select the name of the user you want to add to the role, and click Add to move that user to the list of Users to add.

If you inadvertently add a user to a role, you can remove that user by selecting their name in the Users to add list, 

and clicking Remove.

3 (Optional) Select Send connection key e-mail to users to send an e-mail to the users you’ve added to the role. 

Contribute creates a single e-mail message with a connection key attached that you can send to the users.

You can also have users type connect:server domain name (where server domain name is the name of the server 

where CPS is installed) in the Contribute browser address bar to connect to the website.

4 Click OK.

Contribute adds the specified users to the website and sends them an e-mail that contains the connection key.

See also 

“Add users to websites that CPS manages” on page 254

Setting the Blog Server Publish Options dialog box 

The purpose of the Blog Server Publish Options dialog box is to specify the types of audio, video, and image files that 

you can publish in blog entries to blogs hosted by the blog service. 

1 Select the publishing options for the blog host:

Allow images GIF, JPG, PNG, and so on

Allow audio MP3, WMA, WAV, and so on

Allow video MPG, MPEG, WMV, and so on

2 Click Close.

See also 

“Configure dependent files for blogs” on page 255

Using the My Connections dialog box

The purpose of this dialog box is to create and manage your website and blog server connections. 

You can perform the following tasks with this dialog box:

“Creating a connection with the Connection Wizard or Connection Assistant” on page 264
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“Edit website and blog server connections” on page 257

“Rename a website or blog server connection” on page 258

“Remove website and blog server connections” on page 259

“Disable individual website and blog connections” on page 260

“Enable a website or blog server connection” on page 261

“Configure dependent files for blogs” on page 255

“Connect to websites and blog servers at startup” on page 261

Set the expiry date for pages on the website using the Administer Website 

dialog box

1 Select Page Expiry on the left panel.

2 In the right panel, select Enable Page Expiry to set an expiry date for the page. Do one of the following

• Select Expire pages on, and set a specific date for page expiry. 

• Select Expire pages, and type the number of days for which the page can be live on the server. 

3 In the Page Expiry Action section, do one of the following:

• Select Replace the page with, and choose a page that replaces the expired page on expiry. For example, you could 

replace it with a page saying, “Sorry, this page is no longer available on the website.”

• To delete the page, select Delete the page in the website.

Note: Specifying the delete option does not delete the pages from the website automatically after the expiry date. Delete 

expired pages manually using the Manage Page Expiry dialog box.

See also 

“Configure expiry settings for individual web pages” on page 249

Configure expiry settings for individual web pages

Note: Ensure that you are connected to the website before you open the Manage Page Expiry dialog box. 

1 Select Edit > Administer Websites > Manage Page Expiry. The Manage Page Expiry dialog appears. The list of web 

pages in the site along with their details is displayed in the panel.

2 Ensure that you are connected to the correct website by checking the Website field. To display pages for another 

website to which you are connected, choose the corresponding option from the Website pop-up menu.

3 You can filter the pages by their expiry date using the Show pop-up menu.

4 To inform the author that the web page is nearing its expiry date, select a page from the list, and click Notify. A 

compose mail dialog box of your favorite email editor appears containing information about the expired page. Edit 

and send the mail to the author. For multiple authors, compose a separate email for each author containing 

information on files authored by them.

5 To edit the expiry date for a page, click Edit. In the Edit Page Expiry dialog box, configure the expiry settings. For 

more information on configuring expiry settings, see “Set the expiry date for pages on the website” on page 248.

6 To delete a page from the website permanently, select a page from the list, and click Expire. The page is removed 

from the website or replaced with another page as specified by the settings in the Administer Website dialog box.
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7 Click Close.

Specify the type of path for links in a website

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and select the 

website you want to administer from the submenu. 

2 If prompted, enter the Administrator password and click OK. The Administer Website dialog box appears.

3 Select Links on the left panel.

4 In the right panel, do one of the following

• Select Write links relative to the current page (document relative) to link files in the website using a document 

relative path.

• Select Write links relative to the root of the website (site root relative) to link files in the website using a site-

root-relative path.

5 Click Close.

Note: This setting overrides any role-specific setting for file placement.

Assign a workflow to a template

1 Select Administer > Website, and choose the website that you want to administer. The Administer Website dialog 

box appears. 

2 Select Workflow Association in the left panel.

In the template list on the right-hand side, select the template to which you want to assign a workflow.

3 In the workflow list, select the workflow that you want to assign to the selected template.

4 Click Associate. The workflow is linked to the selected template.

Any new page created using this template follows the associated workflow. 
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Chapter 13: Managing users and roles

Adobe® Contribute® lets you control the extent to which users can alter a website. To do so, you create roles for each 

website and define permissions for each role. After a website’s permissions are defined, Contribute creates a folder 

labeled _mm at the root of the website and places a shared settings file in this folder. The shared settings file contains 

all the website settings and permissions for Contribute website connections that you create. All Contribute users who 

connect to the website automatically inherit the settings defined for their assigned role.

About roles

Contribute lets you define a set of user permissions, ranging from file access to the level of typographic control, as a 

role. You assign the roles you create to Contribute users, which determines the degree to which a specific user can 

modify a site’s content.

Contribute has three default roles that you can assign to users “as-is,” or modify further to meet the content editing 

needs of your website. The default Contribute roles are:

Administrator Users with this role are administrators of this website.

Publisher Users with this role can create and edit pages as well as publish pages to the website.

Writer Users with this role can create and edit pages but cannot publish pages to the website. To publish new pages or 

page modifications to a site, users in this role must send their updates to a user in the publisher role for review. The 

publisher can then choose to publish the page to the site or send it back to the writer for additional editing.

In most cases you can use the default settings specified for these roles. However, if your website has certain design 

features that need to be preserved, you can configure Contribute to work with those design considerations.

If you are not familiar with such web page design elements as font and paragraph usage, Cascading Style Sheets (CSS) 

styles, and image file formats and size limitations, consult a web page designer or other web professional who is 

knowledgeable about your organization’s website. 

For information about Contribute categories of permissions and website settings, see “About role settings” on 

page 280.

About role settings

Contribute lets you define the following categories of permissions and website settings in the Edit Role Settings dialog box:

General Lets you select a starting (home) page that users in the selected role see when they enter the website. For more 

information, see “Setting general role settings” on page 285.

Folder/File Access Limits a role’s access to the selected folder (or folders) and any subfolders they contain. For more 

information, see “Set folder and file access settings” on page 286.

Editing Lets you specify what content users can modify and determine how Contribute processes paragraphs, line 

spacing, and accessibility options. For more information, see “Set page-editing and paragraph settings” on page 288. 

You can also allow users to insert HTML code snippets in Contribute pages. For more information, see “Set the option 

for inserting HTML Code Snippets” on page 289.

Styles and Fonts Specifies which font sets users have access to, and which users can apply style and formatting to text. 

For more information, see “Set style and font settings” on page 289.
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New Pages Specifies whether Contribute users can create blank pages, and which (if any) of Adobe’s Dreamweaver 

MX templates they can use to create pages. You can also specify which pages, if any, the user can copy. The options in 

this category determine what options users see in the New Page dialog box. For more information, see “Specify settings 

for new web pages” on page 291.

New Images Lets you specify a maximum file size, width, and height for images. You can also restrict users so that they 

can use images only from a shared asset library that you create, or you can allow them to add any image to a web page. 

For more information, see “Specify setting options for new images” on page 292.

File Placement Lets you specify folder locations for files based on the file extension used to identify the file type. You 

can also specify that Contribute not allow files of a certain size to be uploaded to the web server. For more information, 

see “Specify setting options for file placement” on page 293.

Shared Assets Lets you create a library of assets (such as images, video content, or Dreamweaver library items) that 

users can add to web pages. You can restrict access to shared assets to specific users or let any Contribute user accessing 

the website add the assets to their pages. For more information, see “Set options for shared assets” on page 294.

See also 

“Edit a role’s settings” on page 283

Create Contribute roles

When Contribute users connect to a website, they are prompted to indicate which role they belong to. For example, a 

Contribute user might choose or be assigned to the Writer role. Thereafter, while connected to that website, that user 

has whatever permissions you have configured for the Writer role.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and then select the 

website you want to administer from the submenu.

If the website has no administrator, click Yes when a dialog box asks whether you want to become the website 

administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears. 

2 Select Users and Roles.
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By default, Contribute creates three roles: Administrator, Publisher, and Writer.

3 Click Create New Role. 

The Create New Role dialog box appears.

4 Select an existing role from the Create new role from copy of list box.

Selecting an existing role as a base for a new role lets you reuse the selected role’s settings. You can modify the new 

role’s settings as needed.

5 Enter a name for the role you want to create, and then click OK. 

The new role appears in the list of role names in the User and Roles panel of the Administer Website dialog box.

6 Select the role name, and then click Edit Role Settings.

The Edit Role Settings dialog box appears. The Edit Role dialog box lets you modify the user settings associated with 

each role. 

7 Modify the settings for the role. 
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When you are finished defining the role, click OK to save your changes. The Edit Role Settings dialog box closes, 

returning you to the Administer Website dialog box. 

8 To create additional roles, repeat steps 4 through 7 for each role you want to add.

9 Select another administrative category to modify, or click Close to apply your changes and exit the Administer 

Website dialog box.

Note: You can modify a role’s settings at any time, even after you have distributed a connection key. Connection 

information and website permissions are maintained separately.

• To modify the roles you have created, select the role whose settings you want to modify and click Edit Role 

Settings. The Edit Role Settings dialog box appears. To learn more about the settings you can modify, see “Edit 

a role’s settings” on page 283.

• To send the connection to the users that make up the role, click Send Connection Key. The Export Connection 

Wizard appears. To learn how to export a connection key, see “Send connection keys for websites” on page 251.

To edit the role now, skip to step 4 of the following procedure. Otherwise, click Cancel to close the Edit Role 

Settings dialog box, and then click Close to close the Administer Website dialog box.

Edit a role’s settings

The Role Settings dialog box lets you define different home pages for users based on the role they belong to, limit roles 

to working in specific folders, and determine the modifications a role can make to a website.

Note: For information about creating roles, see “Create Contribute roles” on page 281.

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and then select the 

website you want to administer from the submenu.

If the Administrator Password dialog box appears, enter the administrator password and click OK.

The Administer Website dialog box appears.

2 Select Users and Roles.



284USING CONTRIBUTE CS4

Managing users and roles

The User and Roles category of the Administer Website dialog box lets you see what roles already exist, add users 

to roles, edit and remove roles, and send connection key files to users assigning them a role.

3 Select the role whose settings you want to modify, and then click Edit Role Settings.

The Edit Role Name Settings dialog box appears. The Edit Role Name Settings dialog box lets you modify the 

settings associated with each role. 

4 Select a settings category to modify.

5 Modify the settings for the role.

When you finish defining the role, click OK to save your changes. The Edit Role Settings dialog box closes, 

returning you to the Administer Website dialog box.

6 Select another administrative category to modify, or click Close to apply your changes and exit the Administer 

Website dialog box.
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Setting general role settings 

The General category lets you specify a starting (home) page that users in the selected role see when they enter the 

website. For example, if users in a given role are assigned to a section of the site that excludes the site’s home (or main) 

page, you might consider specifying a page elsewhere in the site as the starting page for that role.

1 Open the Edit Role Name Setting dialog box, if it’s not already open. (See “Edit a role’s settings” on page 283.)

2 Click the General category on the left side of the dialog box.

3 (Optional) Select Allow users to publish files.

If you select this option, users assigned to this role can publish pages they create. They can also publish or delete 

drafts sent to them for review. 

Providing publish and delete restrictions for draft reviews lets users delete or publish drafts sent to them by other 

Contribute users. Before allowing a user to publish or delete drafts, carefully consider if their assigned role should 

be given this level of control in the publishing of documents. You might need to create a specific role with this 

permission enabled.

Users without draft publishing and deleting permissions can only send drafts for review or edit drafts in the review 

process. For more information about the draft review process, see “Send web page drafts and files for review” on 

page 56.

4 In the Role description text box, enter a brief description of the role and its responsibilities.

This description appears when a user selects a role to join.

5 When you initially defined the website, you specified the website’s home page. To let users in the selected role have 

a more specific home page on the website, enter the URL in the Home page for users in this role text box, or click 

the Choose button to locate the home page.
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You can choose to specify any page on the website as the home page for the specified role. 

6 Select another role settings category to modify, or click OK to apply your changes.

Set folder and file access settings

The Folder/File Access settings category lets you limit a role’s access to selected folders (or directories) and to any 

subfolders they contain as well as determine whether users can delete web pages and related files.

Set folder access settings

You can choose to limit user access to specific folders on the website or to allow users to access all the folders in the 

defined website.

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Edit a role’s settings” on page 283.)

2 Click the Folder/File Access category on the left side of the dialog box.

3 Select Allow users to edit files in any folder to let users access all folders and files on the website’s root, or select 

Only allow editing within these folders to limit access to a specific subfolder or group of subfolders.

4 If you’ve selected Only allow editing within these folders, specify folders by clicking Add Folder. 
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The Choose Folder dialog box appears.

5 The Choose Folder dialog box displays all folders and files under the website’s root. 

You can preview pages on the website by selecting them. This lets you see which pages you are restricting access to.

6 Navigate to the folder you want to provide access to, and click Select Folder.

For example, if the website’s root is http://www.mysite.com and you want to specify that users can edit only those 

pages that are in the folder labeled marketing, click the marketing folder. The access path appears as: 

http://www.mysite.com/marketing. 

The Choose Folder dialog box closes, and the selected folder appears in the Folder access list. You can add folders 

to the Folder access list to give users access to multiple directories on the website.

7 Click OK. 

When the next Contribute user connects to this website, they can edit only those pages and files that are inside the 

listed folders. 

Change access to a folder in the list

❖ Do one of the following:

• To remove a folder from access, select the folder in the folder list, and then click Remove.

• To change a folder the user can access, select the folder in the folder list, and then click Edit.

Set file-deletion settings

You can allow users to delete pages from the web server. When determining whether users should be able to remove 

a page from the website, carefully consider whether you want to maintain a backup copy of deleted pages. 

If you do want to maintain backup copies, you must make sure that the Contribute rollback feature is enabled. To learn 

more about web page rollbacks, see “Enable or disable rollbacks” on page 243.

Permit users to delete files from the web server

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Edit a role’s settings” on page 283.)

2 Click the Folder/File Access category on the left side of the dialog box.
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3 Select Allow users to delete files they have permission to edit. 

4 You can also choose to remove any rollback files associated with a page by selecting Remove rollback versions on 

delete. Carefully consider whether you want to maintain backup copies of web pages before allowing users to delete 

both an active web page and any rollbacks versions of that page. 

5 Select another settings category to modify, or click OK to apply your changes.

If a user deletes a file, but not the rollback copies of the file, the file can be recovered from the rollback copy. For 

more information, see “Roll back to a previous version of a page” on page 211.

Set page-editing and paragraph settings

The Editing category lets you specify what kinds of changes users can make to the website’s web pages and how 

Contribute treats paragraphs and typographic elements.

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Edit a role’s settings” on page 283.)

2 Click the Editing category on the left side of the dialog box.

The Editing category provides options that let you specify which page-editing attributes Contribute applies. When 

you set these options, carefully consider who the content contributors are and what page-editing capabilities they 

require.

3 Change options in the following sections as necessary:

• General editing restrictions: This section lets you specify what kinds of changes users can make to pages.

• Paragraph spacing: This section lets you specify how Contribute applies HTML paragraph tags, which 

determines whether blank lines appear between paragraphs as a user types.

• Other editing options: This section gives you more editing options.
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Note: In Contribute, Users can insert HTML code snippets in web pages if you select the Allow HTML Snippet 

Insertion option. For more information, see “Set the option for inserting HTML Code Snippets” on page 289.

For more information about any of the options, see “Setting the Editing options in the Role Settings dialog box” 

on page 298.

4 Select another role settings category to modify, or click OK to apply your changes.

Set the option for inserting HTML Code Snippets

Based on permissions granted by the Administrator to user roles, users can perform relevant operations in Adobe 

Contribute.

1 Open Contribute.

2 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Mac OS), and choose a site 

to administer.

If the Administrator Password dialog box appears, enter the administrator password and click OK.

The Administer Website dialog box appears.

3 Select Users and Roles. Select Administrator, and then click Edit Role Settings.

The Edit “Administrator” Settings dialog box appears.

4 Select Editing from the list on the left.

The settings appear on the right.

5 Select Allow HTML Snippet Insertion.

By default, the Allow HTML Snippet Insertion option is enabled only for a blog site. You must manually edit the 

bloghub.csi file to disable this feature for blog sites.

Note: If your website Administrator has not enabled the Allow HTML Snippet Insertion option for your user role, the 

HTML Snippet option in the Insert menu will be disabled. By default, this option is not enabled for websites.

6 Click OK to apply your changes.

Note: This feature is applicable also on Mac OS.

See also 

“Insert HTML code snippets” on page 105

Set style and font settings

The Styles and Fonts category in the Role dialog box lets you control whether typographic styles and fonts appear in 

the Contribute toolbar and which kinds of typographical styles users can apply to text.

1 Open the Edit Role Name Settings dialog box, if it’s not already open. 
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2 Click the Styles and Fonts category on the left side of the dialog box.

3 Select a style setting from the Style support pop-up menu. The style and font options vary based on what option 

you select from the pop-up menu.

The Style Support options are:

Don’t allow users to create styles prevents users from creating styles. Users cannot modify any text or style 

formatting options.

Document-level CSS lets you determine whether users can create CSS styles in the document and to what degree 

they can apply CSS styles from existing CSS style sheets.

HTML tags lets you determine whether users can create HTML styles and to what degree they can modify and apply 

styles on the website. 

4 Modify the style settings for your chosen style support option as necessary.

For more information on the style setting options, see “Setting the Style and Fonts options in the Role Settings 

dialog box” on page 300.

For more information about options in this dialog box, click the Help button in the dialog box. 

5 Select another role settings category to modify, or click OK to apply your changes.

Limit available CSS styles 

Although CSS style sheets often include many style definitions, you may want to limit the number of styles available 

to a given Contribute user role. Limiting available styles to those necessary for updating information in the body of a 

web page can help to eliminate potential stylistic editing mistakes by content editors with limited knowledge of web 

pages and CSS styles.
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Contribute lets you limit the number of CSS styles available in the Style menu by selecting a CSS style sheet from which 

to filter styles for a given role. The filter file you select can include only those styles you want the members of that role 

to have access to, or you can create individual CSS style sheets for each role, and select them as the CSS styles to use 

for that role.

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Edit a role’s settings” on page 283.)

2 Click the Styles and Fonts category on the left side of the dialog box.

3 From the Style support pop-up menu, select Document-level CSS.

4 Select the following options:

• Allow users to apply styles

• Include CSS styles in the Style menu

• Show only CSS styles included in the CSS file

5 Click Choose.

The Choose File or Blog Entry dialog box shows all folders and files under the website’s root. 

6 Navigate to the CSS style sheet whose styles you want to let users access from the Styles menu.

7 Select the CSS style sheet, and then click OK.

8 Select another role settings category to modify, or click OK to apply your changes.

Specify settings for new web pages

The New Pages category in the Edit Role Name Settings dialog box lets you specify whether users can create blank pages 

or create duplicate pages by copying the current page. You can also define which Dreamweaver templates users are 

able to see and use. 

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Edit a role’s settings” on page 283.)
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2 Click the New Pages category on the left side of the dialog box.

3 Change options as necessary.

Contribute lets you control the types of new pages that users can create, and it lets you specify templates for creating 

pages. 

When specifying the new page types that users are able to create, carefully consider the look and feel of the website. 

In many cases, it may be best to constrain users either to use copies of existing pages or to use only Dreamweaver 

templates, if they are available.

For more information about any of the options, see “Setting the New Pages options in the Role Settings dialog box” 

on page 301.

For more information about options in this dialog box, click the Help button in the dialog box. 

4 Select another role settings category to modify, or click OK to apply your changes.

Specify setting options for new images

You can use the New Images category of the Role dialog box to specify whether users can import images, specify 

whether users can edit images, limit the maximum file size of an image a user can add to a page, and reduce images 

larger than a size you specify. 

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Edit a role’s settings” on page 283.)
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2 Click the New Images category on the left side of the dialog box.

3 Specify the options Contribute uses to restrict the adding of images to a page.

For information about any of the options, see “Setting the New Images options in the Role Settings dialog box” on 

page 302.

For more information about options in this dialog box, click the Help button in the dialog box. 

4 Select another role settings category to modify, or click OK to apply your changes.

Specify setting options for file placement 

Contribute lets you specify the folders into which you can copy different file types. The file types include images, linked 

documents (such as Microsoft Office documents and Acrobat PDF files), and movie content. By default, Contribute 

places these files relative to the web page that they are linked to. 

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Edit a role’s settings” on page 283.)



294USING CONTRIBUTE CS4

Managing users and roles

2 Click the File Placement category on the left side of the dialog box.

3 Specify the rules Contribute uses to place files as necessary.

For information about any of the options, see “Setting the File Placement options in the Role Settings dialog box” 

on page 302.

For more information about options in this dialog box, click the Help button in the dialog box. 

4 Select another role settings category to modify, or click OK to apply your changes.

Set options for shared assets

Contribute lets users add images, movies, or Adobe’s Dreamweaver library items to your website from a list of shared 

assets. The website administrator can make shared assets available to users by adding assets to the list so that they are 

available to most or all users. Then users can insert assets from the list as they need them. 
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For more information, see “Insert shared assets into a web page” on page 135.

You can modify your Shared Assets list as follows:

• Add image files, movies, and Dreamweaver library items to your list of shared assets.

The assets you add to your Shared Assets list must already be on the server; Contribute does not upload the files for 

you. You can use Contribute to browse to files and then add them to a central list for users.

• Remove shared assets from your list.

You can remove shared assets from individual lists for specific roles or from one list that applies to the entire 

website.

• Change shared asset properties.

Properties include the name used to refer to the asset, alternate text for images, and the editing attribute for 

Dreamweaver Library items.

You create one Shared Assets list for all roles in your website, or you customize these lists for each role.

If different roles are restricted to different shared assets, it’s a good idea to add all shared assets for the website at 

once and then modify the list for each role. It’s more efficient to add the shared assets once and delete as necessary 

than to add the same assets several times.

Add shared assets, delete shared assets, or modify shared asset properties for an entire 
website or for a specific role

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Edit a role’s settings” on page 283.)

Note: If you’re making changes that apply to all roles associated with the website, it doesn’t matter which role you 

select.
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2 Select Shared Assets from the list on the left.

The Shared Assets settings appear.

If you already have shared assets in your list, they are sorted by type alphabetically. To view the list alphabetically, 

click the Name heading at the top of that column.

3 Do one of the following:

• To add a shared asset, click the Add button, and then select Image, Library Item, or SWF.

You can Shift-click to select multiple assets.  

• To delete a shared asset, select an asset in the pane, and then click the Remove button.

• To view or change shared asset properties, select an asset in the pane; then click the Edit button.

4 Do one of the following:

• To let your changes apply to all roles associated with the website, make sure Use this list for all roles is selected.

• To let your changes apply to the role you selected in the Define Roles dialog box only, deselect Use this list for 

all roles.

Note: This option applies to the entire list of shared assets showing in the pane. It is not specific to any shared assets 

that might be selected in the pane.

For more information about any of the options in this dialog box, see “Setting the Shared Assets options in the 

Role Settings dialog box” on page 304.

For more information about options in this dialog box, click the Help button in the dialog box. 

5 Click OK.

Manage drafts sent for review 

As an administrator, you can view and change the status of drafts that are currently in the draft review process for your 

website. You can change owners for a draft that has been sent for review, and you can also remove any draft from the 

draft review process.

Note: For more information about the draft review process, see “The draft review process” on page 46.

View drafts in the drafts review process

1 Select Edit > Administer Websites > Manage Sent Drafts.

2 Do any of the following:

• To view a draft, select the draft, and then click View Draft.

• To transfer ownership of a draft to another person, select the draft, and then click Change Owner.

• To remove a draft from the draft review process, select the draft, and then click Undo Checkout.

For more information about the Manage Sent Drafts dialog box, see “Using the Manage Sent Drafts dialog box” 

on page 305.

For more information about options in this dialog box, click the Help button in the dialog box. 

3 Click Close.
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Reference

This section provides information about the dialog boxes introduced in this chapter.

Setting the Create New Role dialog box options

Use the Create New Role dialog box to provide a name for a new role.

1 Select an existing role from the Create new role from copy of list box.

Selecting an existing role as a base for a new role lets you reuse the selected role’s settings. You can then modify the 

role’s settings as needed.

2 Enter a name for the role you want to create, and then click OK. 

See also 

“Create Contribute roles” on page 281

Setting the General options in the Role Settings dialog box

Use the General permissions category to specify a starting (home) page that users in the selected role see on entering 

the website. 

1 Select Allow users to publish files to let users assigned to this role publish pages they create. In addition, they can 

publish or delete drafts sent to them for review. 

Allowing users to publish or delete files lets them delete or publish drafts sent by other Contribute users. Before 

letting a user publish or delete files, carefully consider if their assigned role should be given this level of control in 

the publishing of documents. You might need to create a specific role with this permission enabled.

Users without draft publishing and deleting permissions can only send drafts for review or edit drafts in the review 

process. For more information about the draft review process, see “Send web page drafts and files for review” on 

page 56.

2 In the Role description text box, enter a brief description of the website.

This description appears when a user selects a role to join.

3 To let users in the selected role have a more specific home page on the website, enter the URL in the Home page for 

users in this role text box, or click the Browse button to locate the home page.

You can specify any page on the website as the home page for the specified role. For example, the home page of a 

website is typically www.mysite.com/index.htm. However, you might want to have members of a role directed to a 

page on the website, such as www.mysite.com/marketing/marcom.htm.

4 Select another permissions category to modify or click OK to apply your changes.

See also 

“Setting general role settings” on page 285

Setting the Folder/File Access options in the Role Settings dialog box

Use the Folder/File Access permissions category to limit a role’s access to selected folders (or directories) and to any 

subfolders they contain as well as determine whether users can delete web pages and related files.
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See also 

“Set folder access settings” on page 286

“Set file-deletion settings” on page 287

Setting the Editing options in the Role Settings dialog box

Use the Editing category to specify what kinds of changes users can make to the website’s web pages, and how 

Contribute treats paragraphs and typographic elements.

The Editing category provides options that let you specify which page-editing attributes Contribute applies. When you 

set these permissions, carefully consider who the content contributors are and what page-editing capabilities they 

require.

1 Change the General editing restrictions options as necessary:

Allow Unrestricted Editing Lets users modify any page elements that Contribute supports. This includes editing 

text, editing tables, and adding images.

Protect Scripts And Forms prevents users from deleting script tags, server-side includes, code tags (such as 

ColdFusion, ASP, JSP, and PHP tags), form tags, and form elements. 

This option is activated by default. Carefully consider whether the users editing your website’s content are 

experienced enough to modify code embedded in web pages. In general, tasks involving the modification of code 

and code tags are best left to web developers using Dreamweaver.

Prevent Users From Inserting Images Stops users from inserting images into a page and from editing inline images. 

To let users have access to a select group of images for use in a page, but restrict them from inserting any image they 

can access, select this option, and create a shared assets library. 

To learn more about shared assets, see “Set options for shared assets” on page 294.

Only Allow Text Editing And Formatting Specifies that users can only edit text, modify styles, and apply bullets or 

numbered lists. Users cannot add or edit tables, images, or links, or delete server directives or plug-in content. 

Those tags are not editable. 

2 Change the Paragraph spacing options as necessary:

One line, as in standard word processors applies inline CSS styles to each new p tag. The CSS styles defined for a 

website usually cause paragraphs to be rendered closer together. This style is often more familiar to users who have 

worked with desktop publishing applications, which provide greater typographic control. Users can include more 

space between paragraphs by pressing Enter twice to add a standard HTML paragraph (p) tag.

A trade-off to consider is that the use of inline CSS styles causes more complex mark-up tags to be added to the 

page. This can make the HTML structure of the page less clear to web designers who view the HTML tags.

Two lines, as in web page editors adds standard HTML paragraphs using p tags. When a user presses the Enter key, 

Contribute adds the HTML p tag; browsers display a blank line between paragraphs that use the p tag.
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The following example illustrates how these two spacing schemes are rendered in a browser. 

For additional information on specifying paragraph types, see “Set page-editing and paragraph settings” on 

page 288.

3 Change the Other editing options as necessary:

Allow users to edit web page source in external application lets users edit a page’s source code using an external 

editor. Individual users can select which external application to use for editing web page source code by using the 

Application Preferences dialog box. On computers that have Dreamweaver installed, Contribute uses 

Dreamweaver as the default external editor. If Dreamweaver is not installed, Contribute uses the default system text 

editor (Notepad in Windows, or TextEdit in Mac OS). 

For information on specifying an external editor, see “Set Contribute preferences” on page 30.

Important: Allowing users to edit source code using an external editor ignores all editing restrictions enforced by 

Contribute. When selecting this option, make sure that it is assigned only to roles whose users understand how to 

modify web page source code.

Allow users to insert third-party objects (Google and PayPal) lets users insert Google and PayPal extensions into 

web pages. 

Allow multiple consecutive spaces (uses &nbsp;) lets the user add multiple consecutive spaces between words. 

When this option is selected and a user adds multiple spaces, Contribute adds multiple nbsp entities 

(&nbsp;&nbsp;&nbsp;...), which causes browsers to display all the spaces instead of only one space.

Require ALT text for images (improves website accessibility) specifies that Contribute should always prompt users 

for accessibility information so that the HTML generated by Contribute is more accessible to people with 

disabilities. For example, when adding an image, Contribute prompts the user to enter alternative text to appear if 

a web page cannot display images or if the viewer of the page has visual disabilities. 

Contribute cannot validate whether SWF content is accessible, and cautions users when SWF content is added.

Use <strong> and <em> in place of <b> and <i> specifies that, when users format text as bold or italic, Contribute 

should use the strong and em tags instead of the b and i tags. The b and i tags are considered deprecated in the 

latest HTML specification.
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Allow HTML Snippet Insertion specifies that users can insert HTML code snippets in web pages and blog entries. 

This option is enabled by default only for blog sites. You must manually edit the bloghub.csi file to disable this 

feature for blog sites. If this option is not selected for a user role, the HTML Snippet option in the Insert menu will 

be disabled. By default, this option is not enabled for websites.

Line break type pop-up menu lets you specify which character combination Contribute uses to denote line endings 

in the saved file. 

The default is Windows, which uses a carriage return and then a line feed to denote a line break. This value should 

be set based on the host computer for the website, not the computer being used to edit the page.

4 Select another permissions category to modify or click OK to apply your changes.

See also 

“Set Contribute preferences” on page 30

“Set page-editing and paragraph settings” on page 288

“Set style and font settings” on page 289

Setting the Style and Fonts options in the Role Settings dialog box

Use the Styles and Fonts category to control whether typographic styles and fonts appear in the Contribute toolbar and 

which kinds of typographical styles users can apply to text.

1 Select the method by which Contribute users can (or cannot) apply styles to text from the Style support pop-up 

menu. The style options are as follows:

Don’t Allow Users To Create Styles Prohibits users from creating styles. Users cannot modify any text or style 

formatting options.

HTML Tags Lets you determine whether users can create HTML styles, and to what degree they can modify and 

apply styles on the website. 

Document-level CSS Lets you determine whether users can create CSS styles in the document, and to what degree 

they can apply CSS styles from existing CSS style sheets.

2 Change the Styles options as necessary:

If the Allow users to apply styles option is selected, users can apply heading and paragraph styles using the 

Contribute editor toolbar or menu commands. If this option is deselected, the user cannot apply new paragraph 

styles.

Include HTML heading styles (<h1>, ...) in the Style menu specifies that the standard HTML Paragraph, Heading1, 

Heading2, Heading 3, Heading 4, Heading 5, and Heading 6 tags are available in the Style menu. 

Include CSS styles in the Style menu specifies that CSS styles appear in the Style menu. 

Show all CSS styles specifies that all CSS styles, whether they are in the document or are referenced in styles, appear 

in the Style menu.

Show only CSS styles included in this CSS file lets you limit the CSS styles visible to users in the Style menu by 

specifying a specific CSS file that you create. To let all roles have access to the same CSS styles, use a single CSS file; 

to make only certain CSS styles available to users in a role, create an individual CSS file for each role.
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Note: To prevent a CSS style from being available to Contribute users, the page designer can change the name of the 

style so that the name starts with “mmhide” (without quotation marks). For example, if you use a style named 

RightJustified on a page but you don’t want Contribute users to use that style, rename the style to 

mmhideRightJustified. For more information, see “Setting Up a Site for Use with Contribute” in Dreamweaver MX 

2004 Help.

Allow users to apply fonts and sizes (displays the Font and Size menu) activates the font and style menu in the 

Contribute editor toolbar. This lets users select the fonts and font sizes to use on the page. If this option is not 

selected, Contribute uses the font styles and sizes defined in the page’s HTML source code.

Apply sizes using lets you select the unit of measure to display in the Contribute editor toolbar: points, pixels, or 

ems. This option is available only if you selected Document-level CSS from the Style support pop-up menu. 

Allow users to apply bold, italic, underline, strikethrough, and fixed width styles activates the bold, italic, 

underline, strikethrough, and fixed width style options in the Formatting menu and lets the user apply these options 

to text. 

Allow users to apply font color and background color activates the Text Color and Highlight Color options in the 

Formatting menu and lets the user apply these options to text.

3 Select another role settings category to modify or click OK to apply your changes.

See also 

“Set style and font settings” on page 289

“Limit available CSS styles” on page 290

Setting the New Pages options in the Role Settings dialog box 

Use the New Pages category to specify whether users can create blank pages or create duplicate pages by copying the 

current page. You can also define which Dreamweaver templates users are able to see and use.

1 Change the types of new pages that users can create as necessary:

Create a blank page lets users create blank pages. 

Use built-in starter pages lets users create and modify copies of preexisting sample pages that are provided with 

Contribute.

Create a new page by copying any page on the website lets users create and modify a copy of an existing page on 

the website. 

Create a new page by copying a page from this list lets users create pages based on a set of pages that you specify.

Use Dreamweaver templates lets users create pages based on templates created in Dreamweaver, usually by a web 

page designer or other web professional, that have defined editable and non-editable regions. Such pages ensure a 

consistent look and feel throughout a website and let users update only specific areas of text and specific images. 

Dreamweaver templates are stored as files with a .dwt filename extension, in a folder called Templates in the root 

folder of a website. For more information about Dreamweaver templates, see Dreamweaver Help. 

2 If you select Use Dreamweaver templates, select one of the following:

Show users all templates allows users to see all the available templates.

Only show users these templates displays only certain templates to users. If you select this option, you can select 

templates and use the Hide and Show buttons to move the templates between the Hidden templates list and the 

Only show users these templates list. 
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3 Repeat until all the templates you want to display to users of the role are visible in the Only show users these 

templates list.

4 Select another permissions category to modify, or click OK to apply your changes.

See also 

“Specify settings for new web pages” on page 291

Setting the New Images options in the Role Settings dialog box

Use the New Images category to limit the file size of images a user can add to a page. 

1 Select Enable Contribute image processing when inserting images to let users modify images using the Contribute 

image editing tools. This option is selected by default. Deselecting it prevents users from modifying images inserted 

into web pages using Contribute.

2 Automatically reduce image dimensions if they exceed these limits lets you specify the dimensions and file size of 

images that users can add to a page. This option is selected by default when you enable Contribute image 

processing. If users are allowed to add images other than those available in a Shared Assets library, you must specify 

what restrictions you want to apply to the dimensions and file size of images that users add to a page. Select from 

the following options to specify how new images should be added to a page:

Max width and Max height  reduces the dimensions of the image to the size you specify. The default settings reduce 

images to 700 x 700 pixels. 

JPEG quality lets you specify the degree to which Contribute compresses JPEG image files. Image compression is a 

trade-off between file size and image quality; the greater the amount of compression, the lower the quality of the 

image.

Reject images that exceed max file size sets the maximum file size (in kilobytes) of an image that a user can insert 

into a page. Contribute does not allow users to add an image greater than the specified size.

3 Select another role settings category to modify, or click OK to apply your changes.

See also 

“Specify setting options for new images” on page 292

“Edit an image in Contribute” on page 138

Setting the File Placement options in the Role Settings dialog box 

Use the File Placement category to specify folders in which to place files linked to web pages based on the type of file 

(such as images, Microsoft Office documents, or SWF content). By default, all images and document types are placed 

in a folder relative to the document in which they are being placed. You can specify that certain file types be placed in 

a folder that you create anywhere in a site. For example, you might decide to have all image files with a .jpg, .jpeg, or 

.gif, extension placed in a folder named Image at the site’s root folder.

To add a new file type to the list of dependent files:

1 Click Add to add a new document type extension.

2 Complete the options in the File Placement Rule dialog box, specifying which file extensions you want and where 

to place them. 

3 Click OK.
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The file type you added, and the folder in which such file types are placed appear in the list of file types and their 

locations.

4 To add more file types and folder locations, click Add and repeat the previous steps.

To remove a file type:

1 Select the file type you want to remove from the list of file types.

2 Click Delete. 

Note: You cannot remove the All images or All other documents file types. These are default Contribute file types.

3 Click Yes in the confirmation dialog box.

The file type is removed from the list. 

When you remove a file type from the file placement list, the folder placement for files with that extension reverts 

to a folder relative to the document in which it’s being placed.

To edit a file type:

1 Select the file type you want to edit from the list of dependent file types.

2 Click Edit.

The File Placement Rule dialog box appears.

3 Edit the options in the dialog box.

To prevent users from inserting linked files larger than a certain size:

1 Select Reject linked files (except images) that exceed max file size.

2 Enter the maximum file size (in kilobytes) in the Max file size text box.

In addition to preventing users from inserting files larger than a certain size, you can stop users from inserting files 

(except for image files) by entering a value of 0 for the maximum allowable file size. 

See also 

“Specify setting options for file placement” on page 293

“Setting the New Images options in the Role Settings dialog box” on page 302

Setting the File Placement Rule dialog box options

Use this dialog box to specify which folder file types should be stored relative to pages in your website.

1 Enter or modify the file extensions you want to specify for placement.

File extensions take the form .abc; to enter more than one file extension, use commas to delimit your entries. For 

example, to specify Microsoft Office documents, type .doc. To specify a series of image file types, type: .jpg, .jpeg, 

.gif, .png.

2 Specify where to place the dependent file:

Same Folder As Draft Places files of the specified type into the draft folder of the page to which you’re linking or 

adding the file.

Folder Next To Each Web Page Specifies a folder relative to the page that the file type is being linked to.
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For example, you might specify that any image file added to a page be placed in a folder labeled Image. A folder 

labelled Image is then created, relative to each web page into which users insert an image file. This folder stores all 

image files added to that page.

Specific Folder On Your Website Specifies a single folder in the site in which to place the file type that is being linked to.

For example, you can specify a folder labeled Documents into which all Microsoft Office and Acrobat PDF 

documents are placed when linked to a page. This folder stores all of the Microsoft Office and Acrobat PDF 

documents added to any page in the site.

You can either enter the path to the folder or click the Browse button to browse to a folder in the site.

Write Links Relative To The Root Of The Website Specifies that Contribute create site-root relative links to files. 

Site-root-relative links (or paths) provide the path from the site’s root folder to a document. You might want to use 

this type of path if you’re deploying Contribute on a large website that uses more than one server, or one server that 

hosts several websites.

If you don’t specify links relative to the root of the website, Contribute uses document-relative links. These links 

(or paths) are the most appropriate paths to use for local links in most websites.

3 Click OK.

The file type and the location in which it’s to be placed appear in the list of file types.

Setting the Shared Assets options in the Role Settings dialog box 

Use the Shared Assets category to create a library of images, SWF content, and Dreamweaver library items from a list 

of shared assets for your website. Users can copy assets from the list as they need them.

• To add a shared asset, click the Add button, and then select Image, Library Item, or SWF.

In the Choose dialog box, double-click the website root showing in the pane to view folders on the website. Browse 

to and select the file you want to add, and then click Select. Change or confirm the shared asset properties, and then 

click OK.

You can Shift-click to select multiple assets.  

The asset appears in the Shared Assets list.

• To delete a shared asset, select an asset in the pane and click the Remove button.

If a warning appears, click Yes to continue.

The asset disappears from the Shared Assets list. If the Use This List For All Roles option is selected, the asset 

disappears from the Shared Assets list for all roles on the website.

• To view or change shared asset properties, select an asset in the pane and click the Edit button.

In the Shared Asset Properties dialog box, make changes as necessary, and click OK.

Properties include the name used to refer to the asset, alternate text for images, and the editing attribute for 

Dreamweaver Library items. The editing attribute determines whether the library item is locked, so that it cannot 

be edited, or unlocked, so that it can be edited, when it is added by users.

See also 

“Insert shared assets into a web page” on page 135

“Set options for shared assets” on page 294
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Setting the Shared Assets Properties dialog box options 

Use the Shared Assets Properties dialog box to view or change properties assigned to shared assets.

There are two versions of the Shared Assets Properties dialog box: a dialog box that lets you view or change properties 

for a single asset, and a dialog box that lets you view or change properties for multiple assets. 

Specify properties for images

1 Make changes as necessary to the following options:

Name is the label of the image that appears to the user.

Use names that are easy for users to understand.

ALT text describes the image for people with disabilities or for people whose browsers are set to only display text. 

2 Click OK to apply your changes.

To specify properties for SWF or Dreamweaver library items:

1 Select and type over the Name to change it, if necessary.

2 (Library item only) Select the Lock item on page check box if you don’t want users to edit this item.

By default, library items are not locked, so that they are editable by users. Select the check box if you don’t want 

users to edit this library item. 

Note: This option appears only when you edit properties for a single library item.

3 Click OK to apply your changes.

See also 

“Insert shared assets into a web page” on page 135

“Set options for shared assets” on page 294

Using the Manage Sent Drafts dialog box 

Use the manage Sent Drafts dialog box to view and change the status of drafts that are currently in the draft review 

process for your website.

1 Click the Refresh Drafts button at any time to update your view.

2 Select a draft in the pane.

Use Control-click (Windows) or Command-click (Mac OS) to select multiple drafts.  

Each line contains the following draft information:

Title is the name of the draft.

Status indicates where the draft is in the draft review process:

Sent indicates that the draft owner has sent the draft to another person for review, but that person has not taken 

action on the draft. 

Being edited indicates that the draft is currently being edited by a reviewer.

Owner indicates who has control of the draft. For in-transit drafts, the owner is the intended recipient, and for 

drafts being edited, the owner is the person who is editing the draft. There can be multiple owners for a draft.
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Last Accessed is the date a draft was last edited or sent for review.

Connection assigns a number to each of your websites, so that drafts in the same website each have the same site 

number. The Site # column also shows the website name.

Target Web Address is the web address for the draft when it is published on your website. 

Note: This URL does not match the temporary URL you see if you click View Draft.

Description of Last Change (at the bottom of the dialog box) shows the last comment for the selected draft. 

3 Do any of the following:

• Click View Draft to view a draft.

Note: This option is not enabled if you select more than one draft.

• Click Change Owner to transfer ownership of a draft to another person.

Note: If you selected multiple drafts, they must all belong to the same website.

Contribute warns you about the action before the Change Owner dialog box appears for you to select a new 

owner.

• Click Undo Checkout to remove a draft from the draft review process.

Contribute asks if you are sure you want to remove the lock on the file, to remove the draft from the process, 

before it performs the action. 

Important: If a user is editing the draft when you Change Owner or Undo Checkout, that user’s changes are lost. 

When Contribute synchronizes with the server and cannot locate the file, it lets the user know that the draft is no 

longer available and destroys the draft.

See also 

“Manage drafts sent for review” on page 296
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Chapter 14: Windows keyboard shortcuts

The following sections contain tables listing the Windows operating system keyboard shortcuts for Adobe® 

Contribute®.

File menu 

The following table lists the keyboard shortcuts for performing File menu actions in Contribute.

Edit menu 

The following table lists the keyboard shortcuts for performing Edit menu actions in Contribute.

Action Shortcut

Create a page Control+N

Open a file on your computer Control+O

Close draft Control+W

Edit page Control+E

Publish Control+Shift+P

Edit page source in external application Control+Shift+E

Save without publishing Control+S

Save for later Control+Shift+L

Preview in browser F12

Print Control+P

Exit/Quit Control+Q

Action Shortcut

Undo Control+Z 

Redo Control+Y 

Cut Control+X 

Copy Control+C

Paste Control+V 

Paste text only Control+Shift+V

Clear Delete

Select all Control+A

Find Control+F
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View menu

The following table lists the keyboard shortcuts for performing View menu actions in Contribute.

Insert menu 

The following table lists the keyboard shortcuts for performing Insert menu actions in Contribute.

Format menu 

The following table lists the keyboard shortcuts for performing Format menu actions in Contribute.

Action Shortcut

Open or close sidebar F4

Open Draft Console Control+Shift+D

Open the browser Control+Shift+B

Back Alt+Left

Forward Alt+Right

Refresh browser F5

Select file on website Control+Shift+O

Action Shortcut

Insert a table Control+Alt+T

Insert a link to a web page Control+Alt+L

Insert a section anchor Control+Alt+A

Add a line break Shift+Enter

Add a non-breaking space Control+Shift+Space

Action Shortcut

Check spelling F7

Make selected text bold Control+B

Make selected text italic Control+I

Underline selected text Control+U

Set left alignment Control+Alt+Shift+L

Set center alignment Control+Alt+Shift+C

Set right alignment Control+Alt+Shift+R

Set justified alignment Control+Alt+Shift+J
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Table menu 

The following table lists the keyboard shortcuts for performing Table menu actions in Contribute.

Working with blog entries

The following table lists the keyboard shortcut for working with blog entries.

Working in templates 

The following table lists the keyboard shortcuts for navigating template regions.

Editing text 

The following table lists the keyboard shortcuts for editing text in Contribute.

Indent a paragraph Control+Alt+]

Outdent a paragraph Control+Alt+[ 

Add a keyword or description Control+Alt+K

Set page properties Control+J

Action Shortcut

Select a table Control+T

Insert a table Control+Alt+T

Merge selected cells Control+Alt+M

Split selected cell Control+Alt+S

Insert a row Control+M

Insert a column Control+Shift+A

Show table properties Control+Shift+T

Action Shortcut

Refresh blog entries in the Entries list Control+Shift+R

Action Shortcut

Move to the next editable region Control+Alt+E

Move to the previous editable region Control+Shift+Alt+E

Action Shortcut
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Working in tables 

The following table lists the keyboard shortcuts for performing table actions in Contribute.

Working with images

The following table lists the keyboard shortcuts for performing image actions in Contribute.

Action Shortcut

Create a paragraph Enter

Insert a line break <BR> Shift+Enter

Insert a space Spacebar

Insert a non-breaking space Control+Shift+Space

Move text or object to another place in the page Drag selected item to new location

Select a word Double-click the word

Select a paragraph Triple-click a word in the paragraph

Indent paragraph Control+Alt+]

Outdent paragraph Control+Alt+[

Align left Control+Shift+Alt+L

Align center Control+Shift+Alt+C

Align right Control+Shift+Alt+R

Action Shortcut

Select cell (with insertion point inside the cell) Control+A

Move to the next cell Tab

Move to the previous cell Shift+Tab

Insert a row (above current) Control+M

Add a row at end of table Tab in the last cell

Insert a column Control+Shift+A

Merge selected table cells Control+Alt+M

Split table cell Control+Alt+S

Action Shortcut

Change image properties Double-click image
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Getting help

The following table lists the keyboard shortcuts for accessing the online help system in Contribute.

Action Shortcut

Open online help F1

Open the Start Page Alt+Home
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Chapter 15: Macintosh keyboard shortcuts

The following sections contain tables listing the Macintosh operating system keyboard shortcuts for Adobe® 

Contribute®.

File menu 

The following table lists the keyboard shortcuts for performing File menu actions in Contribute.

Edit menu 

The following table lists the keyboard shortcuts for performing Edit menu actions in Contribute.

Action Shortcut

Create a page Command+N

Open a file on your computer Command+O

Close draft Command+W

Edit page Command+Shift+E

Publish Command+Shift+P

Edit page source in external application Command+Shift+E

Save without publishing Command+S

Save for later Command+Shift+L

Print Command+P

Exit/Quit Command+Q

Action Shortcut

Undo Command+Z 

Redo Command+Y 

Cut Command+X 

Copy Command+C

Paste Command+V 

Paste text only Command+Shift+V

Clear Delete

Select all Command+A

Find Command+F
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View menu

The following table lists the keyboard shortcuts for performing View menu actions in Contribute.

Insert menu

The following table lists the keyboard shortcuts for performing Insert menu actions in Contribute.

Format menu 

The following table lists the keyboard shortcuts for performing Format menu actions in Contribute. 

Action Shortcut

Open the browser Command+Shift+B

Open Draft Console Command+Shift+D

Refresh browser Command+R

Choose file or blog entry Command+Shift+O

Action Shortcut

Insert a table Command+Option+T

Insert a link Command+Option+L

Insert a section anchor Command+Option+A

Add a line break Shift+Return

Add a non-breaking space Command+Shift+Space

Insert HTML code snippet Command+Option+H

Action Shortcut

Make selected text bold Command+B

Make selected text italic Command+I

Underline selected text Command+U

Set left alignment Command+Option+Shift+L

Set center alignment Command+Option+Shift+C

Set right alignment Command+Option+Shift+R

Set justified alignment Command+Option+Shift+J

Indent a paragraph Command+Option+]
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Table menu 

The following table lists the keyboard shortcuts for performing Table menu actions in Contribute.

Help menu

The following table lists the keyboard shortcut for accessing the Contribute Start page.

Working in templates 

The following table lists the keyboard shortcuts for navigating template regions.

Editing text 

The following table lists the keyboard shortcuts for editing text in Contribute.

Outdent a paragraph Command+Option+[

Add a keyword or description (Not available in the IBE) Command+Option+K

Set page properties Command+J

Action Shortcut

Select table Command+T

Insert a table Command+Option+T

Merge selected cells (Not available in the IBE) Command+Option+M

Split selected cell (Not available in the IBE) Command+Option+S

Insert a row Command+M

Insert a column Command+Shift+A

Show table properties Command+Shift+T. This shortcuty key does not work in the 

in-browser editor.

Action Shortcut

Open the Start Page Option+Home

Action Shortcut

Move to the next editable region Command+Option+E

Move to the previous editable region Command+Shift+Option+E

Action Shortcut
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Working in tables 

The following table lists the keyboard shortcuts for performing table actions in Contribute.

Working with images

The following table lists the keyboard shortcuts for performing image actions in Contribute.

Action Shortcut

Create a paragraph Enter

Insert a line break <BR> Shift+Enter

Insert a space Spacebar

Insert a non-breaking space Command+Shift+Space

Move text or object to another place in the page Drag selected item to new location

Select a word Double-click the word

Select a paragraph Triple-click a word in the paragraph

Indent paragraph Command+Option+]

Outdent paragraph Command+Option+[

Align left Command+Shift+Option+L

Align center Command+Shift+Option+C

Align right Command+Shift+Option+R

Action Shortcut

Select cell (with insertion point inside the cell) Command+A

Move to the next cell Tab

Move to the previous cell Shift+Tab

Insert a row (before current) Command+M

Add a row at end of table Tab in the last cell

Insert a column Command+Shift+A

Merge selected table cells Command+Option+M

Split table cell Command+Option+S

Action Shortcut

Change image properties Double-click image
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Symbols

.Mac accounts

creating connection 236

A

about 92

converting documents to PDF 92

absolute path 250

access points for blog servers 267

accessibility

about 35

alternative text, requiring 299

high contrast 33

images 131

keyboard shortcuts, Macintosh 312

keyboard shortcuts, Windows 307

keyboard-only navigation 34

screen readers 33

shared assets 305

accessing 60

new review draft 60

activation of software 1

Add Bookmark dialog box 30, 38

add to cart

adding PayPal button 132

adding

add to cart PayPal button 132

buy now PayPal button 132

donation PayPal button 132

keywords and descriptions to web 
pages 87

subscription PayPal button 132

view cart PayPal button 132

Administer Website dialog box

options 241

administrators

assigning role 240

changing 242

defined 5

draft review process, managing 296

password, changing 242

roles 280

settings 241

website connections, setting up 7

Adobe Acrobat Connect content, linking 
to 182

Adobe applications

running startup scripts to integrate Adobe 
Contribute 11

Adobe Bridge

inserting files in Adobe Contribute 12

integrating with Adobe Contribute 11

opening files in Adobe Contribute 12

publishing files to Adobe Contribute 13

Adobe Contribute

inserting files from Adobe Bridge 12

integrating with Adobe Bridge 11

opening files from Adobe Bridge 12

publishing files from Adobe Bridge 13

Adobe Contribute Publishing Server. See 
CPS.

Adobe Exchange 3

Adobe Product Improvement Program 1

alignment

images 137

keyboard shortcuts 314

keyboard shortcuts for Macintosh 313

keyboard shortcuts, Macintosh 314

keyboard shortcuts, Windows 308, 309

tables 162, 173

text 121

videos 145

Allow Comments 39, 91

Allow Trackback 39

alternative text

accessibility requirements 33

images, adding to 131

requiring 299

shared assets, adding to 305

alternative web addresses

types of 229

applications

images, editing 141

source code editing 298

web page content, editing in 68

ASP pages 298

assign

workflow to template 251

audio, blog files 145, 255

autoplaying movies 152

AVI files 143

B

background color

high setting 33

options 108

table 174

web page properties 85

background images 108

blog entries 51

browsing 26

categories, assigning 90

comments, allowing 39, 91

creating based on selection 83

creating based on templates 80

creating blank 82

customizing templates 64

deleting 71

discarding changes 70

editing offline 66

editing, methods for 84

enclosures 145

existing, publishing as new 220

exporting 72

features 46, 76

linking to new blank 179

metadata, entering 88

New Web Page or Blog Entry dialog 
box 106

opening for editing 51

preferences 39, 87

printing 72

publishing new 221

recently published, viewing 28

saving drafts for later 56

saving drafts while working 55

selecting blogs for posting 88

setting date and time 84

tagging 44, 89

templates 49, 62, 80

titles 89

trackback URLs 91

updating 220

viewing 28

blog entries list

keyboard shortcuts, Windows 309

blog metadata toolbar 24
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blog Page entries

creating blank 82

blog server connections

about 228

administrators 6

editing information 257

enabling 9, 261

managing 256

removing 259

renaming 258

selecting for startup 261

setting up 233

supported 231

working offline 8, 65

blog servers

access points 267

blog URL

defining to connect to a blog server 234

using to create connection to blog 
server 234

blogs

dependent files, configuring 255

home pages, viewing 27

posting content from a browser 214

posting content from Microsoft 
Office 215

posting content from RSS aggregators 217

preferences 39

publishing existing entries as new 220

publishing new entries 221

selecting for posting 88

unlinked files, viewing 28

updating entries 220

workflow overview 5

bold text

alternative tags 299

keyboard shortcuts, Macintosh 313

keyboard shortcuts, Windows 308

bookmarks

Add Bookmark dialog box 38

adding 30

Delete Bookmark dialog box 38

deleting 30

viewing 29

borders, table

color 174

thickness 172, 174

Bridge 11

brightness

adjusting in Illustrator 17

brightness and contrast

high, accessibility settings 33

images, adjusting 138

broken links 204

Browse for Flash dialog box

using 156

Browse for Image dialog box

using 155

Browse for Video dialog box

using 156

Browse to Web Page dialog box 180

browser toolbar 23

browsers

blog content, posting 215

encoding 33, 107, 243

links, previewing 190

targeting links 185

browsing

blog entries 26

Pages panel 24

previewing pages 207

switching to editing 25

toolbars 23

unlinked web page 28

web pages 26

workflow overview 5

workspace 23

bulleted lists, creating 122

buttons, PayPal

about 132

editing 150

inserting multiple 150

inserting single 149

permissions 299

buy now

adding PayPal button 132

C

Cascading Style Sheets. See CSS.

categorizing blog entries 90

cells, table

copying or cutting 163

formatting conflicts 158

keyboard shortcuts, Macintosh 314, 315

keyboard shortcuts, Windows 309, 310

merging 167

padding 174

pasting 164

properties 169

selecting 161

spacing 174

splitting 167

centering text 121

Change Administrator Password dialog 
box 242

character encoding 33, 107, 243

Check Spelling command

keyboard shortcuts, Macintosh 313

keyboard shortcuts, Windows 308

using 126

Choose File or Blog Entry dialog box 37

Choose Flash content dialog box 35

Choose Image dialog box 35

Choose Library Item dialog box 35

choose template dialog box

using 112

choosing

template 97, 99, 100, 101, 110, 213, 226

code

protecting 298, 299

viewing 207

code snippets

inserting in Adobe Contribute pages 105

user permissions 289

ColdFusion 298

color

default text 108

high-contrast setting 33

page background 108

tables 174

text 108

web page properties 85

columns, table

adding 165

deleting 166

formatting conflicts 158

keyboard shortcuts, Windows 309, 310

properties 168, 174

resizing 161

selecting 160

sorting data 171

width 172

comments

allowing for blog entries 39, 91

viewing 62

Community help 2

Community search engine 2

completing

send new page dialog box 75

conflicts, user 230
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Connect

to website 6

connect

manually 7

using connection key 7

connecting to a blog

access points 267

connecting to a blog server

using blog URL 234

Connection Assistant

blog server setup 233

website setup 231

connection keys

security 230

sending for CPS sites 253

sending for websites 251

Connection Wizard

blog server setup 233

website setup 231

connections

administrators 7

disabling CPS 238

editing information 257

enabling 9, 261

enabling CPS 236

information, collecting 230

managing 256

removing 259

renaming 258

setting up blog server 233

setting up website 231

User Directory service, disabling 239

working offline 65

connections at startup

selecting websites and blog servers 261

consecutive spaces 299

contrast

high 33

images, adjusting 138

Contribute

integrating with Bridge 11

Contribute editor

working offline 66

converting 92

MS Office documents to PDFs 92

Office documents to PDF and 
inserting 110

copying

images 134

keyboard shortcuts, Macintosh 312

keyboard shortcuts, Windows 307

starter pages 78

table cells 163

web pages 76

CPS

adding users 254

connection keys, sending 253

disabling for websites 238

editing connection information 257

enabling 236

managing connections 256

removing connections 259

removing users 255

User Directory service, disabling 239

Create New Entry dialog box 179

Create New Page dialog box 178

Create New Role dialog box 282

creating connections

.Mac accounts 236

creating web pages

refreshing templates 65

cropping images 139

CSS

available styles 113

creating styles 119

limiting available styles 290, 300

page properties 85

paragraph spacing 298

text, applying to 118

user permissions 289

CSS Headings Page Properties options 109

CSS Links Page Properties options 109

customizing templates 64

D

date

adding to web page 114

for publishing blog entry 82

for publishing blog Page entry 82

date and time

setting for blog entries 84

default settings. See  preferences\

default workspace

restoring 21

definition lists 123

delete

pages permanently 249

Delete Bookmark dialog box 30, 38

Delete Workspace command 22

deleting

blog entries 71

bookmarks 30

enclosures 147

links 189

permissions for deletion 287

table cells 164

table rows and columns 166

users 272

web page 71

web page or blog entry 70

website connections 259

dependent files

blogs 255

placement options 293

descriptions

images 131

keyboard shortcuts, Macintosh 313

keyboard shortcuts, Windows 308

requiring 299

shared assets 305

developers, defined 5

dialog boxes, keyboard-only navigation 34

dictionary, spell check 126

disabling

CPS 238

individual blog server connection 260

individual website connection 260

reenabling website connections 9

rollbacks 243

User Directory service 239

discarding

changes to a web page, blog entry, or 
draft 70

DNS, multiple aliases 229

document relative path 250

domain name server, multiple aliasing 229

donation

adding PayPal button 132

download template dialog box 112

downloading

template 98, 99, 100, 101, 110, 213, 226

downloads

updates, plug-ins, and tryouts 3

Draft Console 24, 59

Draft History 62

draft review process

e-mailing web pages 57

keyboard shortcuts, Macintosh 312

keyboard shortcuts, Windows 307
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managing 296

reviewing drafts 60, 61

sending web pages directly to user 58

sending web pages to website 56

tracking drafts 59

viewing comments 62

drafts

comments, viewing 62

discarding changes 70

editing offline 66

linking to 177

removing unpublished 261

review process 46

reviewing 60, 61

saving for later 56

saving while working 55

spelling, checking 126

tracking 59

viewing 27

Drafts and Recent Pages dialog box 177

Dreamweaver library items

inserting from shared assets 135

permissions 294

Dreamweaver templates

about 49

blog entries 80

creating web pages 80

customizing 64

editing pages based on 62

keyboard shortcuts, Macintosh 314

keyboard shortcuts, Windows 309

permissions 291

properties 63

dynamic pages

scripts and forms, protecting 298

E

edit

pages in web browser 52

web page in browser 55

Edit menu, keyboard shortcuts

Macintosh 312

Windows 307

Edit Section Anchor dialog box 188

editing 51

blog entries 51

conflicts 230

connection information 257

discarding changes 70

external application files 68

features 46

finding and replacing text 126

frames 199

images 138, 141

keyboard-only navigation 34

link URLs 184

offline 66

Pages panel 24

PayPal buttons 150

permissions 280, 288

preferences 40

redoing 55

section anchors 188

source code 298

spelling, checking 126

starter web pages 79

switching from browsing 25

template regions 49

template-based page 62

text with keyboard shortcuts, 
Macintosh 314

text with keyboard shortcuts, 
Windows 309

toolbars for 23

undoing 55

web page content in external 
application 67

web pages from a website 51

workflow overview 5

workspace 23

editing methods

for blog entries 84

editing source code using external 
applications

permission 299

editor toolbar 24

E-mail Address dialog box 181

e-mail links 181

e-mail review

keyboard shortcuts, Macintosh 312

keyboard shortcuts, Windows 307

managing 296

process 48

reviewing web pages 60, 61

sending web page links 57

sending web pages directly to user 58

sending web pages to website 56

tracking 59

viewing comments 62

e-mailing connection keys

for CPS sites 253

for websites 251

security 230

embedded PDF object 111

embedded PDFs

resizing 104

Enable Publishing Server dialog box 237

enabling

blog server connections 261

CPS 236

rollbacks 243

website connections 9, 261

enclosures

adding 145

deleting 147

encoding, character 33, 107, 243

Entries list 28

refreshing 71

Excel

folder placement options 293, 302

linking documents to web pages 95, 99

Open As New Page dialog box 110

opening documents in Adobe 
Contribute 96

posting blog content 214, 215

publishing documents 212

Exchange 3

expire individual web pages 249

expire pages 248

Explorer

bookmarks 29

posting blog content 215

settings 26

exporting connection keys

for CPS sites 253

for websites 251

security 230

exporting web pages or blog entries 72

external applications

images, editing 141

source code editing 298

web page content, editing in 68

Extras 3

F

FeedDemon, posting blog content from 217

file editor preferences 40
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File menu, keyboard shortcuts

Macintosh 312

Windows 307

File on My Computer dialog box 181

files

deletion permissions 287

folder access permissions 286

linking to 181

placement options 293

publishing 208

replacing on website 208, 209

viewing unlinked 28

Find and Replace command 126

finding. See searching

Firefox

posting blog content 215

Flash (SWF) files

accessibility 299

autoplaying or looping 152

folder placement options 293

inserting 135, 142

properties 142

shared asset permissions 294

Folder/File Access options 286

folders

.Mac accounts 236

file placement options 293

New Folder dialog box 38

permissions 286

shared settings file 280

font installation 2

fonts

adding 117

bold 299

creating styles 119

encoding 33, 107, 243

italic 299

keyboard shortcuts, Macintosh 313

keyboard shortcuts, Windows 308

limiting available CSS styles 290, 300

size, changing 115

special characters 115

style permissions 289

styles, applying 118

web page properties 85

word spacing 299

Format menu, keyboard shortcuts

Macintosh 313

Windows 308

Format Table dialog box 170

forms, protecting 298

frames

about 198, 199

editing content 199

saving and publishing 200

targeting 199, 201

framesets

about 198, 199

publishing pages 200

FTP

connection information 231

connection keys, sending 230

proxy preferences 41

G

Go to Web Address dialog box 35

Google search functionality

adding 73

permissions for 299

graphics. See images

H

headers, table

adding 173

preset formats 175

properties 175

sorting options 176

headings, applying styles 118

help system

How Do I panel 24

keyboard shortcuts, Macintosh 314

keyboard shortcuts, Windows 311

high-contrast setting 33

history, draft 62

home pages

user settings 285, 297

viewing 27

Horizontal Rule Properties dialog box 148

horizontal rules 148

How Do I panel 24

HTML Appearance Page Properties 108

HTML code snippets

editing permissions 289

inserting in Adobe Contribute pages 105

user permissions 289

HTML snippets

permission to allow insertion 300

HTML tags

paragraph spacing 298

user permissions 290

I

icons

panels as 20

Image button 133

image editing toolbar 24

Image Properties dialog box 136

images

 See also shared assets

adding to web pages 131, 132

alignment 137

alternative text, adding 131

alternative text, requiring 299

blog files 255

brightness, adjusting 138

contrast, adjusting 138

copying and pasting 134

cropping 139

descriptions, adding 131

descriptions, requiring 299

dragging onto a page 134

editing in Adobe Contribute 138

editing in external applications 141

folder placement options 293

horizontal rules 148

Insert menu 133

keyboard shortcuts, Macintosh 315

keyboard shortcuts, Windows 310

moving on a page 137

permissions 292

properties 136

resizing 140

rotating 141

sharpening 138

size 302

starter pages, editing 79

iMovie 143

in-browser editor

about 52

indenting

lists 123

paragraphs 121

index pages

about 228

deleting filenames 245

individual blog server connection

disabling 260

individual website connection

disabling at startup 260

Insert HTML Snippet dialog box

using 111
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Insert Link dialog box

Browse to Web Page 180

Create New Entry 179

Create New Page 178

Drafts and Recent Pages 177

E-mail Address 181

File on My Computer 181

Insert menu, keyboard shortcuts

Macintosh 313

Windows 308

Insert Microsoft Office Document dialog 
box 105, 216

Insert Office Document as PDF dialog 
box 110

Insert PDF Document dialog box 111

Insert Table dialog box 158

inserting

HTML code snippets in Adobe 
Contribute pages 105

MS Office documents as PDFs in Adobe 
Contribute 92, 95

Office documents as PDFs 110

PayPal buttons 149

PDF document as a link 111

PDF document as an embedded 
object 111

PDFs in Adobe Contribute pages 103

inserting files

from Adobe Bridge to Adobe 
Contribute 12

inserting HTML snippets

permission 300

integrating

Adobe Bridge with Adobe Contribute 11

integrating with Contribute 11

Internet Explorer

bookmarks 29

posting blog content 215

settings 26

invisible elements, viewing 41

italic text

alternative tags 299

keyboard shortcuts, Macintosh 313

keyboard shortcuts, Windows 308

J

JAWS for Windows screen reader

images 131

settings 35

supported 33

JSP pages 298

justifying text 121

K

keyboard shortcuts for tables

Macintosh 315

keyboard shortcuts, Macintosh

Edit menu 312

File menu 312

Format menu 313

Help menu 314

images 315

Insert menu 313

templates 314

View menu 313

keyboard shortcuts, Windows

blog entries list 309

Edit menu 307

editing text 309

File menu 307

Format menu 308

help system 311

images 310

Insert menu 308

Table menu 309

tables 310

templates 309

View menu 308

keyboard-only navigation 34

keywords and descriptions

adding 109

adding for web pages 87

web page 109

L

languages, encoding 33, 107, 243

library items

Adobe Acrobat Connect, linking to 182

inserting from shared assets 135

permissions 294

line breaks

adding 300

keyboard shortcuts, Macintosh 313

keyboard shortcuts, Windows 308

lines, horizontal 148

link path

configure 250

linking to

Adobe Acrobat Connect content 182

drafts or recently published pages 177

e-mail addresses 181

files on your computer 181

new blank blog entries 179

new pages 178

section anchors 187

website pages 180

links

broken 204

CSS Page Properties 109

deleting 189

destinations, changing 189

enclosures, blogs 145

file placement options 293

Microsoft Word or Excel documents to 
web pages 95, 99

previewing in a browser 190

properties, changing 190

publishing web pages 177, 204

section anchors, adding 187

section anchors, editing 188

starter pages, editing 80

targeting frames 199, 201

targeting where a page opens 185

testing 190, 207

text, changing 189

trackback URLs 91

URLs, editing 184

web page properties 85

lists

bulleted 122

definition 123

numbered 121

properties 125

sublists 123

locked template regions 49

looping Flash movies 152

M

Macintosh

keyboard shortcuts 313

keyboard shortcuts for table rows 314

keyboard shortcuts for tables 315

Macintosh keyboard shortcuts

Edit menu 312

File menu 312

Format menu 313

Help menu 314

images 315

Insert menu 313
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templates 314

View menu 313

managing

connections 256

draft review process 296

margins, setting web page 85, 108

meetings, linking to Adobe Acrobat 
Connect meetings 182

merging table cells 167

metadata, blog entries 88

MetaWeblog API 231

Microsoft Excel

adding content to web pages 94, 97

folder placement options 293, 302

inserting documents as PDF 100

linking documents to web pages 95, 99

Open As New Page dialog box 110

opening documents in Adobe 
Contribute 96

posting blog content 214, 215

publishing documents 212

Microsoft Internet Explorer

bookmarks 29

posting blog content 215

settings 26

Microsoft Office

folder placement options 293

opening documents in Adobe 
Contribute 96

posting blog content 214, 215

publishing documents 212

Microsoft Outlook

Open As New Page dialog box 110

opening documents in Adobe 
Contribute 96

posting blog content 214, 215

publishing documents 212

Microsoft Word

adding content to web pages 94, 97

folder placement options 293, 302

inserting documents as PDF 100

linking documents to web pages 95, 99

Open As New Page dialog box 110

opening documents in Adobe 
Contribute 96

posting blog content 214, 215

publishing documents 212

Movie Maker 143

movies

alignment 145

blog files 145, 255

Flash, inserting 135, 142

Flash, properties 142

inserting 143

moving 144

properties 144

moving

images 137

videos 144

Mozilla Firefox

posting blog content 215

MS Office documents

converting to PDFs 92

converting to PDFs and inserting 110

inserting as PDFs in drafts 105

inserting in Adobe Contribute 95

My Connections

using 256

N

navigating

keyboard-only 34

nested lists 123

NetNewsWire, posting blog content 
from 217, 219

network path 231

networks

working offline 8, 65

New Folder dialog box 38

new review drafts 60

New Style option 129

New Web Page or Blog Entry dialog box 106

numbered lists, creating 121

O

Office

folder placement options 293

opening documents in Adobe 
Contribute 96

posting blog content 214, 215

publishing documents 212

offline, working 65

online help system

How Do I panel 24

keyboard shortcuts, Macintosh 314

keyboard shortcuts, Windows 311

online resources 3

Open As New Page dialog box 110

opening

blog entries for editing 51

Microsoft Office documents in Adobe 
Contribute 96

page in a new window 185

web pages and blog entries without 
browsing 26

web pages for editing 51

opening Adobe Contribute

changing startup password 32

entering startup password 7

working offline 8, 65, 66

opening files

from Adobe Bridge in Adobe 
Contribute 12

opening MS Office documents in Adobe 
Contribute

setting templates 101

opening without browsing 26

other blog servers

selecting for creating blog servers 234

selecting to connect to a blog server 234

Outlook

Open As New Page dialog box 110

opening documents in Adobe 
Contribute 96

posting blog content 214, 215

publishing documents 212

P

padding

table cells 174

page expiry

individual pages 249

set 248

Page Keywords and Description dialog 
box 109

Page Properties 85, 107, 108, 109

page separators 148

Pages (wordpress) 82

Pages panel 24

pages. See web pages

palettes

See also panels

about 15

panel menu, displaying 17

panels

See also palettes

about 15

collapsing to icons 20

docking 18

grouping 20

moving 19

showing and hiding 17

stacking 20
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paragraphs

alignment 121

bulleted lists 122

definition lists 123

indenting 121

keyboard shortcuts 314

keyboard shortcuts for Macintosh 313

keyboard shortcuts, Macintosh 314

keyboard shortcuts, Windows 308, 309

line breaks 300

list properties 125

numbered lists 121

spacing 298

passwords

preferences 43

passwords, administrator

changing 242

passwords, startup

changing 32

entering 7

requiring 269

pasting

images 134

keyboard shortcuts, Macintosh 312

keyboard shortcuts, Windows 307

table cells 164

PayPal buttons

about 132

add to cart 132

adding 149

buy now 132

donation 132

editing 150

inserting multiple 150

inserting single 149

permissions 299

subscription 132

view cart 132

PDF 92

converting MS Office documents 92

Microsoft Word or Excel documents, 
inserting 100

preferences 42

PDF document

preferences 42

PDF documents

inserting MS Office documents in Adobe 
Contribute 95

PDF files

folder placement options 293

PDF Properties dialog box

using 111

PDFs

inserting as embedded objects 95

inserting as links 95

inserting in Adobe Contribute pages 103

permission

allowing insertion of HTMLsnippets 300

permissions

editing HTML code 289

editing web pages 288

file deletion 287

file placement 293

folder access 286

Google search fields 299

home page settings 285, 297

images 292

PayPal buttons 299

publishing 285, 297

role settings 280, 283, 285, 297

shared assets 294

shared settings file 280

source code 298

style settings 289, 290, 300

template regions 49

web page creation 291

PHP pages 298

placing files

from Adobe Bridge to Adobe 
Contribute 12

plug-ins

in Adobe Store 3

podcasts 145

port numbers 229

posting blog content from

browsers 214

Microsoft Office 215

RSS aggregators 217

preferences

blog entries 39, 87

editing 40

file editor 40

FTP proxy 41

invisible elements 41

PDF document 42

role settings 280, 283, 285

security 43

setting for Contribute 30

tagging 44

user 297

previewing

links 190

web pages 207

printing

keyboard shortcuts, Macintosh 312

keyboard shortcuts, Windows 307

web pages or blog entries 72

properties

CSS Links 109

Flash content (SWF files) 142

horizontal rules 148

HTML Appearance options 108

images 136

lists 125

movies 144

table cells 169

table rows and columns 168, 174

tables 168

templates 63

Title/Encoding options 107

web page 85

Publish File dialog box 209

Publish New Linked Blog Entries dialog 
box 220

Publish New Linked Pages dialog box 206, 
207

Publish New Page dialog box 205

Publish to Website dialog box 213

publisher role 280

publishing

about 203

blog content from a browser 214

blog content from Microsoft Office 215

blog content from RSS aggregators 217

blog entries, new 221

existing blog entries as new 220

existing page as new page 206

files 208

frame pages 200

keyboard shortcuts, Macintosh 312

keyboard shortcuts, Windows 307

linked documents 204

linking to recent pages 177

Microsoft Office documents 212

new web pages 205

permissions 280, 285, 297

previewing links 190

previewing pages 207

replacing files 208, 209

Rollback feature 211
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updates to an existing page 204

updating blog entries 220

updating web pages 204

viewing recent web pages and blogs 28

workflow overview 5

publishing blog entry

specifying date and time 82

publishing blog Page entry

specifying date and time 82

publishing files

from Adobe Bridge to Adobe 
Contribute 13

Q

Quick Time files 143

R

read me file 2

redoing an edit 55

Refresh Drafts 60, 61

refreshing

drafts 60, 61

Entries list 71

refreshing templates

creating web pages 65

registration of software 1

removing. See deleting

renaming

website connections 258

website or blog server connections 258

replacing

files on website 208, 209

text 126

Require Adobe Contribute startup 
password 7

Reset Count To option 129

resizing 111

an embedded PDF object 111

embedded PDFs 104

images 140

tables 161

reverting to previous version

about 211

enabling and disabling Rollback 
feature 243

using Rollback feature 211

review drafts

accessing new drafts 60

reviewing drafts

e-mailing web pages 57

keyboard shortcuts, Macintosh 312

keyboard shortcuts, Windows 307

managing 296

reviewing web pages 60, 61

sending web pages directly to user 58

sending web pages to website 56

tracking 59

viewing comments 62

reviewing process

drafts 46

roles

about 280

administrator, assigning 240

administrator, changing 242

creating new 281

draft review management 296

home page settings 285, 297

publishing permissions 297

settings 283

settings, general 280, 285, 297

shared settings files 280

types of 280

web developers, Contribute users, 
administrators 5

Roll Back Page dialog box 212

Rollback feature

about 211

using 211

rotating images 141

rows, table

adding 165

deleting 166

formatting conflicts 158

keyboard shortcuts, Windows 309, 310

properties 168, 174

resizing 161

selecting 160

RSS aggregators, posting blog content 
from 217

running startup scripts in Adobe 
applications

integrating Adobe Contribute 11

S

Save As 206

Save Current command 22

Save for Later command 56

Save Workspace command 22

saving drafts

automatically 55

exporting web pages or blog entries 72

for later 56

keyboard shortcuts, Macintosh 312

keyboard shortcuts, Windows 307

Publish as New Page 206

while working 55

screen readers

accessibility settings 35

images 131
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