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Image Processor

The basic functions of the Image Processor enable you to save a 
batch of selected files in the JPEG, PSD or TIFF formats or con-
vert a set of files simultaneously to all three formats. You can re-
size the images to fit within a certain pixel dimension, as well as 
include an ICC color profile, and copyright metadata. The dialog 
also features the ability to run an Action on the files before they 
are saved in the specified format. This extends the Image Proces-
sor’s functionality to include a variety of processes that can be 
recorded as Actions, making it a very customizable feature. 

Image Processor can be accessed from the main menu in Pho-
toshop by choosing File > Scripts > Image Processor, but the 
easiest way to use it is to access it through Adobe Bridge. Simply 
select the thumbnails of the images you want to process and 
choose Tools > Photoshop > Image Processor (Figure 1).

If you access the Image Processor from within Photoshop, the 
top section lets you choose between processing the currently 
open files or selecting images from your hard drive. If you access 
it from Bridge using specifically selected files, it will show that 
the selected files from Bridge will be processed and it will list the 
number of files in parentheses. If you have selected no thumb-
nails it will process all of the images in the folder that is currently 
being browsed in Bridge.

Note: The Image Processor works with Photoshop (PSD), JPEG, 
and camera raw files.
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Figure 1. Accessing the Image Processor 
from Adobe Bridge CS3.

Learning how to take advantage of automation in Photoshop is key to helping you speed up certain tasks. 
While computers are not that good at making subjective creative decisions for individual images, they excel 
at repetition and automation so it makes sense to leverage this power to streamline your workflow whenever 
you can. Photoshop and Bridge offer a number of ways that you can automate common procedures. To start 
this module off, let’s take a look at the Image Processor, one of the most useful automated features for con-
verting files into another format.
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The Image Processor Deconstructed

Using the Image Processor is pretty simple since the interface practically walks you through the process.  
I’ll just clarify some of the options below.

Section 1, Select the Images to Process:

If you are targeting raw files, the Open First Image to Apply Settings option will open the first file in the 
group and allow you to apply Camera Raw settings that will then be applied to all the other files in the batch. 
This is useful if all the files were shot in the same lighting and can benefit from the same set of adjustments or 
white balance correction. For PSD and JPEG file you can use it to convert to a profile for the first image and 
all the subsequent images.

Section 3, File Type: 

Save as JPEG allows you to choose a quality level. The higher the number, the better the quality, with 12 as 
the maximum quality setting. 

Save as PSD allows you to choose the Maximize Compatibility option. This is recommended if you want 
your layered files to properly preview in other applications.

Save as TIFF allows you to choose the lossless LZW compression scheme to yield a smaller file size.

Figure 2. The Image Processor dialog.
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The Resize to Fit controls let you specify the maximum height and width of the image in pixels. For example, 
if you enter 800x800 pixels, the longest dimension of the image, be it height or width, will be 800 pixels. This 
is the same functionality offered by the Fit Image command that was discussed in the previous Working with 
Actions in Photoshop CS3 article, and it allows you to resize verticals and horizontals using the same set-
tings. 

Section 4, Preferences:

Run Action lets you choose an Action set and specify the particular Action within that set. With this option 
you can customize the functionality of the Image Processor so that it does more than just resize and save files 
in a different format.

Copyright Info: I feel that the layout of this feature in the dialog needs to be re-designed since it’s not imme-
diately clear how it works (especially since there is no check box). If you have previously used the File Info 
dialog (or similar dialogs in another program) to add any copyright information to the IPTC copyright meta-
data fields, it will be automatically included in the converted files. Any text that you enter in the text field in 
the Image Processor dialog will overwrite existing IPTC copyright information.

Include ICC Profile: If an ICC profile is already present in the file, this option embeds the color profile into 
the converted files. Since the presence of profiles ensures that your images are displayed correctly (as long as 
they are being displayed by programs that are ICC-savvy, that is), this option is always recommended.

Batch Processing with Actions
Batch processing with actions is an ex-
cellent way to save time when you need 
to apply the same tasks and commands 
to a group of files. You can run an ac-
tion on a group of images that are con-
tained in a folder on your hard drive, or 
from selected files in Adobe Bridge.

In Adobe Bridge, select several images 
you want to batch process by com-
mand clicking (Mac) or control click-
ing (PC) on their thumbnails. If you 
have a group of thumbnails that are 
contiguous to each other (i.e., like a 
row of images), you can click on one 
and then shift-click on the thumbnail 
at the end of the row to select them 
all. Then choose Tools > Photoshop 
> Batch. If you want to start from 
within Photoshop and select a spe-
cific folder on your hard drive, choose 
File>Automate>Batch. Figure 3. The Batch dialog.
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The Batch dialog is divided into four parts:  
Play, Source, Destination, and Errors. 

Play: In the top section (Play), you tell Photoshop which 
Action you want to use. If you had the action highlighted 
in the Actions palette before you brought up this dialog, 
then it should already be selected for you. If it is not, 
choose the correct set and the correct action.

Source: In the Source section, you specify which images 
you want to process with the action. You can choose from 
a folder, opened images, imported images, or the selected 
files Bridge. This section also contains four options that 
control how the actions behave regarding open com-
mands in the action itself, images in subfolders, file open dialogs, and color profile warnings.

	 Override Action “Open” Commands – If there are any specific steps in the action that open specific files, 
choosing this will ignore those steps and use the selected images instead. Do not use this unless the ac-
tion does contain a step to open a previously saved file or it will ignore the files that you have selected.

	 Include All Subfolders – If you are targeting a folder of images, any files contained within subfolders will 
also be processed.

	 Suppress File Open Options Dialog – This is useful when batching actions on camera raw image files 
where you do not want teh Camera RAw dialog to open for each image. If checked, then the default or 
previously specified Camera Raw settings will be used.

	 Suppress Color Profile Warnings – This will turn off any profile mismatch or missing profile messages.

I generally choose to suppress both file open options dialogs and color profile warnings if I am running a 
batch on a large group of images. If these are left unchecked, then you have to sit at the computer and deal 
with a dialog every time a file opens up (not exactly a hands-free, time-saving experience). I should note that 
before I run actions on large groups of images, I have usually already resolved any conflicting color profile 
issues, which is why I turn off the color profile warnings at this point. 

Destination: In the Destination section, you tell Photo-
shop where to place the files once the action is completed. 

	 None – this will leave the files open in Photoshop 
without saving them  (unless you want to immediate-
ly check the files and will be saving them as a dupli-
cate files yourself, this is generally not a good idea, especially if you’re dealing with lots of files). 

	 Save and Close – this is also not one of my favorites, because it overwrites the original file in the current 
location. The reason I do not care for this is that it could cause problems if  the action does not run as 
expected. I never want to overwrite my original files when I run an action.

	 Folder – I use this last option 99% of time because lets me save the processed files to another location 
and it preserves my original images in case there was a problem with the way the action affected the files.

Figure 4. The Play and Source sections of the Batch 
dialog.

Figure 5. The Destination section of the Batch dialog.
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Override Action “Save As” Commands: This option and the various permutations it can assume, can vary, 
depending on other settings in the Batch dialog, as well as on specific steps in the action itself.

	 Scenario #1: If this is turned on (checked) the processed files are saved to the destination folder speci-
fied in the Destination section of the Batch dialog. If you have selected Save and Close in the Destina-
tion menu then the files are saved back to their original folder. In both cases the files are saved with their 
original names or the names you specify in the File Naming section of the Batch dialog box.

	 Scenario #2: If this option is not selected (unchecked) and the action includes a Save As command, the 
files will be saved into the folder specified by the Save As command in the action, and any folder speci-
fied in the Destination section of the Batch command will not be used. 

	 Scenario #3 (“Danger, Will Robinson!”): Additionally, if you do not select this option and the Save As 
command in the action uses a specific filename, the Batch command overwrites the any file with the 
same name (the file name specified in the action) each time it processes an image. This can cause big 
problems since the action will overwrite each previously processed file, leaving you with only a single file 
at the end of the batch process.

	 Scenario #4:  If you want to batch process files using the original file names in the folder you specified 
in the Destination section, create a step in the action that saves the file. Then, when you create the batch, 
select the Override Action “Save As” Command (checked) and specify a destination folder. 

	 Scenario #5:  If you specify new file names in the Batch dialog and do not choose Override Action “Save 
As” Command, then Photoshop will save your processed images twice: once with the new name in the 
specified folder, and once with the original name in the folder specified by the Save As command in the 
action.

	 Note: To use this option, the action must contain a Save As command. If no Save As commnad exists, the 
Batch command will not save the processed files. 

File Naming:  This contains some fairly conven-
tional file naming options that apply if writing files 
to a new folder. Select different name elements from 
the menus or enter custom text into the fields to be 
added into the default names for all files. 

Important: You must include at least one field that 
is unique for every file (for example, file name, se-
rial number, or serial letter) to prevent files from 
overwriting each other. 

Starting Serial Number specifies the starting num-
ber for any serial number fields. Serial letter fields 
always start with the letter “A” for the first file.

Compatibility: Makes file names compatible with Windows, Mac OS, and Unix operating systems (do not 
use slashes in file names as this conflicts with characters reserved by the Unix system).

Figure 6. The File Naming and Errors sections of the 
Batch dialog.
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Errors: Finally, in the very last section, Errors, you can control how the program behaves if it runs into any 
errors while the batch operation is in progress.

	 Stop For Errors – as the name suggests, this halts the action until you confirm the error message.

	 Log Errors to File – Records each error in a file without halting the action. If errors are logged to a file, 
a message will appear after the action has run. To review the error file, open with a text editor after the 
Batch command has run.

Batch processing is great when you have a lot of images to deal with and they all need the same treatment. I 
once had to convert to CMYK, resize and sharpen over 500 product shots for a client’s catalogue. Having a 
good action and batch processing meant that I could start the action on the folder of files and go to lunch. 
When I returned from my break, the batch had finished and the images were ready for delivery. Now that’s 
what I call better living through technology!

A Word of Advice on Batch Processing

Before you get excited and start batch processing bulging folders of images, take the time to make sure that 
you’ve thought of everything and that the action is “bullet-proof ” and up to the task at hand. 

Will it affect all images the same way? Do the images need to be in a cetain state (i.e., no layers) in order for 
the action to run properly? Was it designed for a horizontal image only? Will it create the wrong result if it’s 
run on a vertical image? These are the type of questions you want to ask and answer before you start a big 
batch process job. Thorough testing of the action is recommended before you unleash it on a folder of im-
portant images. Investing the time up front to make sure the action works perfectly will ensure a successful 
batch with no unpleasant surprises. And, just to insulate yourself against unexpected disasters, remember to 
always save your processed files to a separate folder so that the original files are preserved in case there is a 
problem.

Droplets
A Droplet is another way to run a commonly-used action on a single image or group of images without actu-
ally having to deal with the Batch dialog settings. You can create a droplet from an existing action by choos-
ing File > Automate > Create Droplet. 

The Batch dialog will open 
with a slight change at the 
very top: you need to choose 
a location where the droplet 
will be saved (Figure 7). Next, 
select the action you want to 
use in the droplet, specify any 
file handling options, such 
as ignore color profiles, and 
choose a destination for the 
processed files and click OK.

Figure 7. Creating a Droplet from a specific Action.
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To use a Droplet to process images, just drag folder or 
image icon onto the droplet icon and the batch will start 
automatically, even launching Photoshop if it is not 
currently running. The nice thing about droplets is that 
they save you from having to enter Batch dialog settings 
every time you want to run that action on a folder of im-
ages. For high-volume production environments, Drop-
lets can save a lot of time.

Droplets & Cross-Platform Compatibility

If you create a droplet on a Windows system and want to 
use it on a Mac computer, you have to update it for use 
on the Mac platform before you can use it. To do this, 
after you have copied the file to the Mac, simply drag the 
droplet icon onto the Photoshop application icon and 
Photoshop will open and update the droplet. Droplets 
created on a Mac can be used on Windows computers 
with no updating as long as you add the “.exe” suffix 
after their name.

Figure 8. A droplet icon.

Figure 9. Dragging the target folder of images 
onto a droplet icon will launch the batch pro-
cess and apply the droplet’s action to all of the 
files in the folder.
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