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Adobe Photoshop 7.0

Selecting and masking, two of Photoshop’s most important features, lay the foundation for many if not most of the 
adjustments you make to images.  The uses for masks are endless, and although Photoshop offers many different 
types of masks and ways to create them, their purpose and behavior are the same: masks control which areas of an 
image or layer are edited or unaffected, or what areas are hidden or revealed. For example, a Quick Mask could be 
used to make a selection to lighten or darken a specifi c area of an image, while a Layer Mask might be used to hide 
or display information on a layer, such as another image, a pattern, a color, an adjustment, type, a set of images, or 
a combination of all of them.  And because no two images are alike, Photoshop provides several distinct types of 
masks and over a dozen selection tools to create masks, providing tremendous fl exibility and precise control.

Masks have two very powerful advantages: 

• Most masks are non-destructive—none of your original artwork is edited or deleted, it’s simply hidden. (There 
are a few exceptions, such as Quick Masks and a few masking tools, which we’ll discuss later.) 

• Masks are tremendously fl exible—they can be changed at any time, in any way, to reveal or hide areas of 
layers.

From a creative perspective, the fl exibility and non destructive nature of masks means that everything you do 
today can be changed tomorrow if you (or your client) change your mind, - you’ll never have to go back to square 
one to recover information. So, unless you make perfect adjustments or have perfect clients, you should be editing 
with masks! 

Note:  Although selecting and masking are similar, selecting is an art of its own and this discussion is limited to 
explaining and working with the various types of masks in Photoshop. 

Lets begin by discussing the several types of masks in Photoshop to discover which one will help you achieve the 
distinctive effect that you will need for your artwork. 

Quick Masks

The name Quick Mask can be a bit misleading. As Photoshop’s earliest masking feature, a Quick Mask is actually 
a selection viewed in a different mode. Rather than displaying the selection as a dotted-line marquee, it is repre-
sented in varying shades of red, where each shade represents the areas of the image that are affected, and by how 
much. If you fi nd this concept confusing, think of the varying shades of red as a percentage of opacity, for example, 
where dark red indicates that an area is completely opaque (hidden) and a lighter red or pink tone indicates that 
the area is somewhat transparent (revealed). The important thing to remember about Quick Masks is that they are 
not permanent. Unlike Photoshop’s other masks, such as layer and vector masks, after a Quick Mask is converted 
to a selection, the adjustments you make can edit the original image. Because of this, I often use Quick Masks to 
create an initial selection, and then use other permanent types of masks to continue manipulating an image without 
affecting my original artwork. 

Creating Quick Masks

• Start with an existing selection or simply click the Quick Mask icon near the bottom of the tool bar to toggle 
from Standard mode to Quick Mask mode. If you start with a selection, clicking the Quick Mask icon displays a 
temporary mask (red) over the selected area. 

Then, using a painting tool such as the paintbrush or gradient tool, you can edit the mask (selection) rather than 
the underlying image. 
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• With a painting tool selected, set the foreground color to black and paint to add to the mask (protect additional 
areas of the image). Initially, it may seem odd that painting with black displays red (instead of black) over the 
image, but the use of red emulates the traditional method of masking using a rubylith overlay. 

• Next, set the foreground color to white and paint to erase parts of the mask (selection). Painting with white lets 
you easily make corrections or refi ne edges of the mask. 

• After the mask is completed, click the Standard Mode icon on the toolbox to turn the mask into a selection you 
can now use to manipulate your image. 

Note that because Quick Masks are temporary, if you deselect and then make another selection, you’ll have to rec-
reate your Quick Mask (selection). (Although you can save selections and load them later, I fi nd that I get the same 
results and more fl exibility using Layer Masks, which we’ll talk about later.) 

Options: The red mask color, the opacity of the mask, and the option to have the mask color represent either the 
masked areas or the selected areas of an image can be changed by double-clicking the Quick Mask icon in the 
toolbox. For example, you may want to change the default mask color from red to another color if your image 
contains a lot of red tones. 

Clipping Groups

Clipping groups let you create masks by grouping multiple layers, an extremely effective way to mask multiple 
images (providing that all the layers in the group are masked by a single shape). If a shape needs to change later in 
the creative process, editing one mask is much easier than trying to make the exact change to multiple layers.

Before you group layers, it is important to know that the information on the base (bottom) layer in the clipping 

group will be used to hide and reveal the information on the other layers in the group. For example, if the base layer 

contains type, information on other layers appears only in the type areas. If the base layer contains a small image 

or shape, information on other layers appears only within the image or shape. In addition, editing the base layer’s 

opacity or Blend mode affects how the information on the other layers is displayed. 

Creating Clipping Groups

• To group multiple layers, fi rst identify the base layer (the layer you want to act as the mask). Next, in the Layers 
palette, move the other layers above the base layer in the order in which you want them to appear. 

Note: The base layer can not be the Background layer in the Layers palette; however, any other layer can be defi ned 
as a base layer as long as it is below the layers you want to include in the clipping group. 

• In the Layers palette, target the layer directly above the base (mask) layer and choose Layer > Group with 
Previous. 

Notice that the layer above the base layer is masked, so that its contents is displayed only where there is informa-
tion on the base layer.  However, if there is no overlap with the base layer and the layer above, the “grouped” layer 
will not be visible.

• To mask multiple layers in a clipping group, continue selecting adjacent layers above the base layer and choose 
Layer > Group with Previous for each layer you want included in the group. (Layers included in the group must 
be adjacent to each other.) 

You can also use a keyboard shortcut for grouping layers.  

• With the top layer targeted in the Layers palette, hold down Option (Mac) or Alt (Win) and press G. 

• Or,  in the Layers palette, hold down Option (Mac) or Alt (Win) and position the pointer on the line between two 
layers you want to group—when you see a small icon of a triangle with two overlapping circles, click to group 
the two layers. 

Continue grouping layers using either of the methods described until you’ve added all the layers you want included 

with the base layer. In the Layers palette, Clipping Groups are represented differently than other layers: the base layer 
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is underlined, grouped layers are indented, and a small downward arrow appears to the left of grouped layers. 

Note: Layer styles applied to the base layer of a clipping group are applied to all the clipped layers in the group. 

In addition to creating clipping groups using images, using type as the base layer of a clipping group can produce 
interesting results when you display a photograph through the type mask. Similarly, grouping an Adjustment layer 
with an image layer can restrict the effect of the adjustment to that layer without affecting any of the other layers 
below it in the layer stack. To do this, simply select the Adjustment layer and group it with the layer you want it to 
affect.

Options: When applying layer effects such as drop shadows or glows to layers that are part of a clipping group, 
you can use the Advanced Blending option in the Layer Style dialog box to affect the way the effects are applied 
and displayed to individual layers or the entire group. Apply the desired layer styles, then click Blending Options: 
Custom in the Layer Style dialog box, and then Blend Clipped Layers as Group. This allows you to either apply the 
effect separately to each layer, or have the effect applied only to the resulting combination of the layers.

Layer Masks

Layer Masks can be added to any layer except the Background. However, if you want to add a layer mask to the 
Background, convert the Background to a layer by choosing Layer > New > Layer from Background or double-click-
ing the Background layer in the Layers palette. 

Creating Layer Masks 

• Target the desired layer in the Layer palette and choose Layer > Add Layer Mask > Reveal All, or click the Mask 
icon at the bottom of the Layers palette. In the Layers palette, a white thumbnail is added to the right of the 
layer, indicating the presence of a layer mask. Where the mask is white, the information on the layer is displayed, 
and where it is black, the information on the layer is hidden, revealing the layers below. 

Note: If you add a layer mask to a layer containing an active selection, Photoshop automatically creates a mask 
based on the selection, where the selected area is white and the unselected area is black.

After you add a layer mask to a layer, you can edit either the layer or the layer mask. 

• To select which part of the layer you want to edit, click directly on either the thumbnail representing the image 
or the thumbnail representing the mask. In the layers palette, to the left of the thumbnails, an icon is displayed 
to indicate what you’re editing: the icon is a paintbrush if you’re editing the image, and a mask icon if you’re 
editing the layer mask. 

When the mask is selected in the Layers palette, painting with black hides information (parts of the image) on 
the layer. If you mask too much of the image, simply change the foreground color to white and paint to reveal the 
hidden information. The beauty of layer masks is their tremendous fl exibility; you can always change your mind to 
hide and reveal the information on the layer! 

In addition to painting on the mask  to hide and reveal areas of an image, there may be times when you want to 
display the entire mask in the image window, for example, when you want to edit small areas. 

• To display the mask in the image window, Option (Mac)/Alt (Win) click the layer mask icon in the Layers 
palette.

• After editing the mask, click the screened back eye icon to the left of the layer mask icon in the Layers palette 
to return to the image view. 

You can also temporarily hide a layer mask, for example, when you want to see the entire image on the layer. 

• To hide a layer mask, choose Layer > Disable Layer Mask or Shift-click the layer mask icon in the Layers palette to 
display a red X over the thumbnail. To display the layer mask, choose Layer > Enable Layer Mask or simply click 
on the layer mask icon in the Layers palette.

To achieve more subtle transitions between layers, try painting in a Layer Mask with shades of gray to partially hide 
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or reveal the image on the layer or, use the gradient tool to create a gradient in the Layer Mask from black to white. 
The longer the gradient, the more gradual the transition. 

Painting with black (or white if the mask is already black) with the brush set to a lower opacity will also partially 
hide or reveal the image. 

Note: By default, a layer mask and the layer are linked–if you move or transform the layer, both the mask and the 
layer are affected. However, to affect the layer and the layer mask individually, you can unlink them by clicking the 
link icon between the thumbnail of the image and the thumbnail of the layer mask in the Layers palette. 

Layer masks can also be applied to content layers such as Adjustment layers or Fill layers (as opposed to layers with 
images on them). Technically, these are the same as other layer masks, but I wanted to discuss them separately for 
two reasons: 

First, most people don’t realize you can apply a mask to an adjustment layer. While in fact, masks are automatically 
added to content layers when they’re created (including Adjustment Layers and Fill Layers). If an active selection is 
present when the mask is created, the selected area shows the adjustment (represented by white in the mask) and 
the unselected area is hidden (represented by black in the mask). If no selection is active when the mask is created, 
the mask is added with the default setting of white (showing the adjustment throughout the image).  

Second, I have found when using a mask with an adjustment layer, the process of masking (hiding and revealing) 
the adjustment can be confusing, especially when the adjustment is used to control the tonal values of the image. 
Painting with black and white can appear to change the brightness of the image when they are really only hiding 
or revealing the adjustment. In fact, depending on the adjustment, painting with white can actually darken the 
image and painting with black can lighten it. The important thing to remember is that painting with black hides 
the adjustment, painting with white reveals it: regardless of what the adjustment is.

Applying Layer Masks to Layer Sets

You can apply layer masks to layer sets, enabling multiple layers to be hidden or revealed by the same mask. In addi-
tion, because individual layers within the layer set can have their own masks, the ability to create multiple masks 
increases their fl exibility tremendously.

When using layer sets, the opacity and blend mode of the set can be manipulated. By default, the layer set’s blend 
mode is set to Pass Through, allowing the layers in the set to interact with the layers outside of and below the layer 
set. However, there may be times when this is not the desired behavior, for example, when you want an adjust-
ment layer to affect multiple layers within a set, but not the layers below. To isolate the Adjustment layer, that is, 
to affect only the layers in the set (without clipping them to individual layers), set the layer set’s blend mode from 
Pass Through to Normal. 

Vector Masks 

Vector masks, originally introduced in Photoshop 6 with the name Clipping Path masks, are resolution-independent 
paths analogous to type or shape layers in Photoshop or objects or shapes created in illustration or page layout 
programs like Adobe Illustrator or Adobe InDesign. Vector masks print at the resolution of the Postscript image 
setter, regardless of the Photoshop fi le resolution, and are essential for printing logos, type, or crisp shapes from 
Photoshop. When you create a shape layer, a vector mask is created automatically. You can add Vector masks to any 
other type of layer, with the exception of the Background. 

•  To create a shape layer, select any of the pen or shape tools; then click the shape layers icon in the Options bar   To create a shape layer, select any of the pen or shape tools; then click the shape layers icon in the Options bar   
(under the menu bar) and draw the desired path or shape. In the Layers palette, a Shape layer appears with two 
thumbnail icons. The icon on the left represents the fi ll color (limited to the shape of the vector in the image 
window), and the icon on the right is the vector mask (masking the fi ll color outside of the vector). 

• To change the fi ll color of the vector, double-click the fi ll color thumbnail in the Layers palette. 

Note: To change a Shape layer to another content layer, select Layer > Change Layer Content and choose the 
desired layer type.
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Adding Vector Masks to Layers 

• To add a vector mask, select Layer > Add Vector Mask > Reveal All or Cmd (Mac)/Ctrl (Win)-click the Mask icon 
at the bottom of the Layers palette.

In the Layers palette, a second thumbnail appears. (If a layer mask is already applied to the layer, a third thumbnail 
appears.) 

• To draw the vector mask, select any of the Pen or Shape tools, click the Paths icon (the second icon) on the 
Options bar and then draw the desired path shape. 

Note:  If a path is active and a vector mask is added by selecting Layer > Add Vector Mask, Photoshop automatically 
adds the path as an option to the menu. If a path is selected and a vector mask is added via Cmd (Mac)/Ctrl (Win)-
click the Mask icon, the path is used by default as the mask.

Although vector masks are fairly obvious to identify, the Layers palette displays two visual cues to help you distin-
guish between, layer masks and vector masks. First, a vertical line appears to the left of the Vector Masks thumbnail 
to distinguish it from the layer and layer mask thumbnails. Second, as soon as a path is added to the vector mask, 
the hidden areas are represented as gray in the mask and the visible areas remain white outlined with a black line 
representing the vector shape. 

After a vector mask is added to a layer, either the mask or the layer can be edited.  

• To change the target from the mask to the image, simply click on the desired thumbnail in the Layers palette. 

• If you are working on a Layer that has both a layer mask and a vector mask applied, target the desired mask and, 
use a painting tool to affect the layer mask, or a pen or shape tool to affect the vector mask. 

• To invert a Vector Mask, simply select it with the Path Selection Tool and, in the options bar, click the subtract 
from shape icon.

By default, the vector mask and layer are linked so that if you move or transform a layer, both of them are altered, 
but like layer masks, you can click the link between them to unlink them and transform and reposition them indi-
vidually. This feature can be useful if the mask is positioned correctly but the layer isn’t or if you want to transform 
a layer to fi t within a mask.

Because shapes and paths are object oriented, they can be moved, changed, or transformed endlessly with no loss 
of quality. They can also be manipulated using the Path Component Selection tool, the Direct Selection Tool, or the 
Add, Delete, and Convert Anchor Point tools. When you create a path that you may want to use again, you can add 
it to your shape library by selecting the path and defi ning as a custom shape (Edit > Defi ne Custom Shape).

If the path defi ning the shape obstructs your view of an image, you can hide the path without removing or discard-
ing it. 

• To hide a path, click once on the vector mask thumbnail in the Layers palette. Click on it again to turn it on or 
hold the curser over the icon to turn it back on temporarily until you move the cursor away from the icon. 

• To temporarily hide the effects of a Vector Mask, select Layer > Disable Vector Mask or, on the Layers palette, 
Shift-click the vector mask thumbnail. Like layer masks, the mask is hidden and displays a red X. Select Layer > 
Enable Vector Mask to view the mask again or, simply click the thumbnail in the Layers palette.

Vector Masks can also be used with page layout applications such as InDesign to control which areas of an image 
are printed. Traditionally, this is accomplished using a clipping path. A clipping path works like a cookie cutter: what’s 
inside the cutter prints, and what’s outside of the cutter is hidden. Today, with the improvements in page layout 
technology, any path in a Photoshop fi le or even transparency defi ned by a layer mask can be used to defi ne an 
area to print in InDesign. 

The Background Eraser

In addition to non-destructive masking techniques, Photoshop offers extracting or masking tools that permanently 
manipulate or remove parts of your original image. The Background Eraser, like the Eraser and the Magic Eraser, 
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deletes unwanted information rather than hiding it. Keep in mind however, that it’s a necessary trade off: as the 
Background Erase erases information, it incorporates "color decontamination" into the selection by looking at the 
colors around the edges of the selection and removing unwanted casts to prevent the halo effect common around 
composited images. Unfortunately, changes are permanent with these tools because color decontamination can’t 
be accomplished in a composite image, but must be done on an individual channel level. 

Tip:  Create a duplicate layer before using the Background Eraser so you’ll have another copy to work with if you 
delete too much information on the fi rst try. You can also create a snapshot of the image so that you can paint back 
in areas that may be deleted with the History Brush.

The Background Eraser’s brush has a sample point in the center and an affected area that is the size of the brush. 
Position the center “hot spot” over the color you want to remove - the brush size displays the affected area. The 
Background Eraser also provides several options to help you erase the desired area with added precision. The Limits 
feature can be changed to select and delete contiguous or discontiguous pixels, or to stop when it fi nds an edge. 
In areas where there is a great deal of contrast between the background and the subject, the Find Edges option 
works well. In areas of softer transition, for example, where the background is revealed behind strands of hair, the 
Discontiguous option works well. 

The Sampling options in the Background Eraser options bar determine how often or what color the Background 
eraser deletes. The Continuous, Once, or Background Swatch options control the erased color as you move the 
brush’s sample point over the image. If the background contains varied tones, the Continuous option works well; 
if the background contains similar tones, the Once option is most useful. Finally, the Tolerance option works the 
same as in other tools: the higher the setting, the more dissimilar the pixels can be. (You may fi nd that you need to 
change these settings as you work on different areas of the image.) 

The Extract Command

The Extract command provides a sophisticated way to isolate a foreground object from its background, which 
was previously best achieved using complex channel operations or tool combinations. Similar to the Background 
Eraser, the Extract command deletes information based on color and tonal values and also incorporates advanced 
color decontamination technology. Now, even objects with wispy, intricate, or undefi ned edges can be removed 
from their surroundings with  minimum effort or technical know-how. While objects that differ in color from their 
surroundings are the easiest to extract, even the most challenging extractions can be refi ned with help of the His-
tory Brush and the Eraser.

Using Extract

• Before using the Extract command, create a snapshot of your image using the History palette. Later, you can 
fi ne-tune areas with small imperfections using the History Brush. 

• Choose Filter >Extract. 

• In the Extract dialog box, select the Edge Highlighter tool at the top left corner; then drag to defi ne the transitional 
areas by painting over the areas that contain both foreground and background information. (To have Photoshop 
help defi ne the smallest transitional area, select the Smart Highlighting option.) For best results, use a smaller 
brush where edges are sharp and a larger brush for less defi ned areas. Set the brush size in the Tool Options 
area at the right side of the Extract dialog box.  

• After outlining the transitional areas, chose the Fill tool (the paint bucket) and click in the area you want to retain. 
If you accidentally fi ll the wrong area, click the Fill tool again to undo the fi ll. If the paint fi lls the whole image, 
there is probably a gap in your outline. 

• Click the Preview button to preview the extraction. 

• If the extraction isn’t perfect, modify the outline using the Eraser and Edge Highlighter tools, then preview again 
to view the improvements. 

Note:  In the lower right area of the Extract dialog box, you can choose from a variety of preview options to simulate 
your image on a variety of backgrounds. 
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Depending on the color similarity between your subject and surroundings, it may be necessary to use the History Brush or the Eraser 
to refi ne small imperfections. 

• From the Tool palette, click the History Brush. In the History palette,  set the brush to sample from the snapshot, then paint in the 
missing areas. To delete stray pixels from the image, use the Eraser tool.

The Blend If Sliders

Another interesting way to create a mask is to use the composite or individual channel’s tonal values with the Blend If sliders. This 
technique produces unique results that can make the image appear to break apart or dissolve in specifi c tonal ranges. 

Using the Blend If Sliders

• Choose Layer > Layer Style > Blending Options. In the Blend If area of the dialog box, choose the gray values to affect the composite 
or, select individual color channels with the pop up menu. 

• In the Blend If area of the dialog box, adjustment sliders are displayed: This Layer and Underlying Layer. To hide the darkest values 
in the image, drag the left most triangle to the right; to affect the lighter areas, drag the white triangle to the left. 

For a softer mask, you can divide each slider into two sliders.

 • To divide a slider, hold down Option (Mac)/Alt (Win) and drag the slider apart into two smaller triangles. The distance between 
the triangles represents the tonal range where the mask is being applied at decreasing opacity. 

In addition, you can affect the appearance of the underlying layers in the image by dragging the Underlying Layer sliders; these slid-
ers work in the same way as the This Layer sliders. 


