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Photoshop CS3: Basics 
Learning Guide 
 

 

 Getting Started with Photoshop 
Launching Photoshop 

 From the Start menu, select Programs. 

 From Programs submenu, select Adobe Design Premium 

CS3. 

 From Adobe Design Premium CS3 submenu, select Adobe 

Photoshop CS3. 

 



 2  

Navigating in Photoshop CS 
Opening Images 

Because Photoshop’s interface is different from the Microsoft 

Office products, navigating within the Photoshop environment can 

take some practice.  Viewing existing images in the Photoshop 

environment is a great way to become acquainted with the 

Photoshop interface.  To view an existing image: 

 

 From the File menu, select Open. 
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 The Open window will appear. 

 Navigate to the folder that contains your images. 

 Select the file you want to open. 

 Click on the button labeled Open. 

 

 
 

 The image you opened will appear in a new window. 

 

 



 4  

Getting to Know Your Image 

Every image in Photoshop also includes two additional 

components, a window and a canvas.  The canvas is the virtual 

paper on which the image is drawn.  The window is the area on the 

screen in which the image appears.  When you open an image in 

Photoshop, the image will appear within its window.  The window 

functions just like a window containing a Word document or an 

Excel spreadsheet.   

 To enlarge the image window, click on the maximize button 

(labeled with a box symbol) in the window’s upper right 

corner. 

 To minimize the image window, click on the minimize button 

(labeled with a minus symbol) in the window’s upper right 

corner. 

 To close an image, click on the close button (labeled with an x) 

in the window’s upper right corner. 

 

 

 

 

 
 

Minimize 
 

Maximize 
 

     Close 
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Changing the Size of the Image Window 

 To change the size of the image window, place your mouse on 

any edge or corner of the window. 

 The cursor will become a double-sided arrow. 

 To enlarge the window, click and drag your mouse away from 

the center of the image. 

 To reduce the size of the window, click and drag your mouse 

toward the center of the image. 

 Although the size of the window changes, the image will 

remain the same size. 
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Changing the Magnification of your Image 

 On the left side of the Photoshop window, locate the Photoshop 

toolbox. 

  From the toolbox, click on the icon that looks like a 

magnifying glass.  This is the Zoom Tool. 

 

 
 

Tip:  When you position the cursor over any tool, Photoshop 

displays a pop-up box containing the tool's name and its keyboard 

shortcut. 

 

 After you select the Zoom Tool, your cursor will appear as a 

magnifying glass whenever you place it on your image. 

 

 

Zoom Tool 
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 To zoom in on your image: 

o Click on the image with the magnifying glass cursor. 

 

 
 

o The magnification of your image will increase each 

time you click on it with the magnifying glass cursor: 

o The image window’s title bar displays the level of 

magnification, shown as a percentage of the image’s 

original size.   

o Each time you click on the image, this percentage 

increases. 

  

 
 

 To zoom out:  

o Press the ALT key on your keyboard. 

o The symbol within the magnifying glass cursor will 

change from a plus sign to a minus sign.  

o As you press the ALT key simultaneously click on the 

image with the magnifying class cursor.   

o Each time you click on the image, it will reduce in size 

and the percentage of its magnification will decrease. 
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 The following table displays additional ways you can change 

the magnification of your image. 

 
To zoom in… To zoom out… 

From the View menu select Zoom In. From the View menu select 
Zoom Out. 

Right-click on your image and select 
Zoom In from the drop-down menu 
that appears. 

Right-click on your image and 
select Zoom Out from the 
drop-down menu that appears.. 

 

Tips: Some magnification shortcuts  

Located at the top the Photoshop window, the zoom tool option bar 

offers some shortcuts for making specific changes to the 

magnification of your image. 

 

 
 

 To return your image to its original magnification, click on the 

Actual Pixels button.   

 To automatically change the size of the image window so that it 

displays all of an image whose magnification has changed: 

o On the left side of the zoom tool options bar locate the 

box labeled Resize Windows to Fit. 

o Confirm that a checkmark appears within this box.   

o If the box is not checked, click on it once to place a 

checkmark in the box. 

o Now, as you zoom in or zoom out, the image window 

will adjust itself so that it displays your entire image. 
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Making Basic Changes to your Image 
Rotating your Image 

After you open an existing image in Photoshop, sometimes you’ll 

want to change its orientation so that the image will fit better in 

your document or PowerPoint presentation.  For example, the 

image of the cannon below initially appears with a vertical 

orientation.   

 

  
 

 

However, Photoshop’s rotation tool makes it easy to reorient the 

image so that it displays properly. To rotate your image: 

 From the Image menu, select the Rotate Canvas submenu. 

 

 

Original Image Rotated 90o Clockwise 
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 From the submenu that appears, select the rotation you wish to 

apply to your image.  

 

 

 

Resizing your Image 

In many situations, you may also want to change the actual size of 

your image so that it coexists better with the rest of the content in 

your document or PowerPoint presentation.  You’ll usually want to 

resize your image proportionally so that your image does not 

become distorted.  To change the size of your image: 

 

 From the Image menu, choose Image Size. 

 

 

To rotate your image…. Choose…. 

Upside-down 180°  

A quarter-turn to the right (clockwise) 90o CW 

A quarter-turn to the left 
(counterclockwise) 

90o CCW 

To an angle that you choose Arbitrary 

By inverting it from right to left Flip Canvas Horizontal 

By inverting it from top to bottom Flip Canvas Vertical 
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 The Image Size window will appear. 

 

 
 

 

To resize your image proportionately: 

 At the bottom left of the Image Size window, confirm that the 

Constrain Proportions box is checked.   

 If this box is not checked, click on it once to place a checkmark 

in the box. 

 At the top of the Image Size window locate the Pixel 

Dimensions area. 

 In the Width box enter the new width of your image.  

 Click within the Height box. 

 Photoshop will automatically adjust the height of your image 

so that it will retain its proportions. 

 Click OK to change the size of your image. 

 

To resize your image without maintaining its proportions: 

 At the bottom left of the Image Size window, confirm that the 

Constrain Proportions box is unchecked.   

 If this box is checked, click on it once to remove the 

checkmark from the box. 

 At the top of the Image Size window locate the Pixel 

Dimensions area. 

 In the Width and Height boxes, enter the new dimensions of 

your image.  

 Click OK to change the size of your image. 
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Tip:  

When you constrain the proportions of an image in Photoshop, it is 

as if you are dragging on the corner of an image box in 

PowerPoint; both the height and width are changed 

proportionally.  Conversely, changing the dimensions of an image 

without checking the Constrain Proportions box is similar to 

stretching the image in PowerPoint by dragging on the side or 

bottom of its image box.   

 

In some cases, distorting your image can be useful.  For example, 

you may want to make an image appear larger, but you may only 

have room to increase its proportions in one direction.  

Furthermore, in some cases, you may want your image to appear 

stretched or warped so that you can strongly emphasize one aspect 

of the image.   

 

 

 
Saving your Work in Progress 
As you work on an image, it is important to consistently save your 

work so you do not lose your changes.  In most cases, you’ll want 

to save your image in Photoshop’s native format so that you can 

continue to work on it.  To save your image: 

 From the File menu, select Save As. 
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 The Save As window will appear. 

 

 
 

 At the top of the Save As window locate the Save in box. 

 Click on the down-facing arrow to the right of the Save in box. 

 From the drop-down menu that appears navigate to the folder 

where you wish to save your image. 

 In the box labeled File name, located at the center of the Save 

As window, type the name of your image.  

 Beneath the File name box, click on the down-facing arrow 

next to the box labeled Format. 

 From the drop-down menu that appears select 

Photoshop (*.PSD, *.PDD). 

 After you save your image for the first time, you can continue 

to save it throughout your Photoshop session by clicking on the 

File menu and selecting Save. 

 

Tip:  It is important to save continually as you alter your image so 

that you do not lose any of your work.  You can never save too 

often! 
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Working With the Crop Tool 
As you continue to modify your image, you may want to crop it in 

order to get rid of some background area.  This allows your 

viewers to focus their attention on the important parts of the image.  

To crop your image: 

 

 Select the Crop Tool from the toolbox. 

 

 
 

 After you select the Crop Tool, your cursor will appear as a 

cropping symbol whenever you place it on your image. 

 With the cropping cursor click and drag to draw a large box 

around the portion of your image that you wish to keep.  This 

part of your image within your selection is known as the 

cropping marquee. 

 Photoshop will darken the part of your image that is outside the 

cropping marquee.  This darkened portion will be removed 

from your image when the cropping is complete.   

 

 
 

Crop Tool 
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 To adjust the size of the area inside the cropping marquee:  

o Place your cursor over any of the square selection 

handles on the edge of the marquee.   

o The cursor will become a double-sided arrow. 

o Drag the cursor to resize the marquee. 

 

 
 

 To finish the cropping process, double-click anywhere within 

the cropping marquee. 

 Photoshop will delete the darkened portion of your image that 

is outside the cropping marquee. 

 

Tip: Cropping your image to an exact size 

 From the View menu select Rulers. 

 Rulers will appear on the top and to the left of your image. 

 Use the rulers as a guide to exactly adjust the size of the 

cropping marquee. 

 When you are satisfied your adjustments, double-click 

anywhere within the cropping marquee to complete the 

cropping process.  

 

  
 

 

Tips: Some cropping shortcuts  

Located at the top the Photoshop window, the crop tool option bar 

offers some shortcuts for making specific changes to the print size 

and resolution of your image. 
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The crop tool option bar is a powerful utility to consider especially 

when cropping known widths, heights, and resolutions.  It offers an 

instant way to size your image to specific print sizes and is ideal 

when working with large pictures like those imported from your 

digital camera. 

 

 
 

You can access the option bar by selecting the crop tool from the 

floating tool bar or typing C as your keyboard shortcut.  The crop 

tool option bar will change to reflect crop utilities at the top of 

your Photoshop window. 

 

Example: 

 

A digital image may have a resolution of 2600 x 1800 pixels at 

72dpi.  The print size of this picture would be enormous without 

some adjustments.  You may want to center in on a particular 

section of the photo without distorting the image.  By using a 

combination of the Image Size information and the crop tool 

option bar, you can easily and quickly size your picture to a print 

size that you desire without losing any quality to the picture. 

 

This original picture was 500 x 667 pixels at 72 dpi.  Using the 

option bar, you can center in on Jean Mayer’s head to make the 

cropped image a 2 inch by 3 inch photo at 100 dpi. 
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Adding a Border to your Image 
When preparing an image for a document, you may want to add a 

border.  To add a border in Photoshop, you must first choose a 

color for the border and then increase the size of your image’s 

canvas. 

 

Getting started 

 From the Image menu, select Canvas Size. 

 

 
 

 The Canvas Size window will appear. 
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Choosing the Size of your Image Canvas 

 For best results, you’ll want to make sure the canvas size is 

measured in pixels.  Before resizing your image: 

o From the New Size area at the center of the Canvas 

Size window, locate the Width and Height boxes. 

o If the canvas size is not measured in pixels, click on the 

down-facing arrow next to the Width box.  

o From the drop-down menus that appear, select pixels. 

 

 
 

 From the Current Size region at the top of the Canvas Size 

window, locate the actual dimensions of your image. 

 

 
 

 Determine the new size of your image by adding the desired 

width of your border to each of your image’s current 

dimensions. 

 

 In the New Size area: 

o In the Width box, enter your image’s new width. 

o In the Height box, enter the new height of your image. 

 

 

Tip: The Anchor area at the bottom of the Canvas Size window 

indicates where your existing image will be positioned on the new 

canvas.  The default option, with the central square selected, 

positions your image at the center of the new canvas and adds a 

border evenly to each side of your image. 

Example 
Current 
Dimension 

Plus Border 
Width 

New 
Dimension 

Width 330 pixels + 10 pixels = 340 pixels 

Height 397 pixels + 10 pixels  = 407 pixels 
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Choosing the Color for your Border 

 Click on the down-facing arrow next to the box labeled Canvas 

extension color. 

 From the drop-down menu that appears, click on Other…. 

 

 
 

 The Color Picker window will appear. 

 From the center of the Color Picker window locate the color 

slider, a vertical rainbow-colored strip. 

 Drag the horizontal arrows up and down the slider until you 

have chosen the color you like. 

 

 
 

 The hue of your new foreground color will appear at the top of 

the color selection rectangle to the right of the color slider.  

Your original foreground color appears at the bottom of the 

rectangle. 
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 To adjust the lightness or darkness of your color, use the color 

field at the right side of the Color Picker window.   

 
To choose a…. Click on the color field’s…. 

Lighter shade Upper left corner  

More vibrant shade Upper right corner 

Less vibrant shade Lower right corner 

Darker shade Lower left corner 

 

 A small circle will mark your luminosity choice, and the 

adjustment will be applied to your new foreground at the top of 

the color selection rectangle. 

 To finalize your color choice, click OK. 

 

 

Tip: Selecting printable colors 

Sometimes, the color you chose cannot be printed.  In this 

situation, a warning symbol ( ) will appear beside the color you 

chose.  To select the closest printable color: 

 Click on the warning symbol to the right of the color selection 

rectangle.   

 Photoshop will change your new foreground color to the 

closest printable hue, and the warning symbol will be removed. 

 

   
 

 

 Finally, to add the border to your image, click OK. 

 

 

 

New image border 
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Undoing Actions in Photoshop 
Photoshop records the last 20 actions that you have taken in the 

History Palette.  If at any time you are unsatisfied with a change 

that you have made to your image, the History Palette offers a 

convenient way to undo your unwanted changes.  For example, 

suppose you are unsatisfied with the border that you added to your 

image in the previous section.  To undo your border creation: 

 

 Locate the History Palette on the right side of the Photoshop 

window. 

 

 
 

 To remove the border from your image, click on the name of 

the state to which you want to revert.  In this case, the border 

around the image was created by increasing the image’s canvas 

size.   

 Therefore, to undo the Canvas Size state and return to the state 

of the image immediately before the border was added, click 

on Crop.  
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 In the History Palette the Crop state will be highlighted and 

the Canvas Size state will be deselected.  Meanwhile, 

Photoshop will remove the border from your image. 

 

                   
 

 

Tips:  

 You can click on any state within the History Palette to return 

your image to that state.  

 Once you select a previous image state from the History 

Palette, the image states beneath the state you picked become 

deselected. 

 If you make a change to your image after returning to a 

previous state, all the states that had been deselected will be 

removed and your most recent changes will be recorded. 

 By default, the History Palette only lists the 20 most recent 

states of your image.  Previous states are automatically deleted 

to free more memory for Photoshop. 

 In addition to using the History Palette, you can undo the most 

recent change to your image by selecting the Undo command 

from the Edit menu. 
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Selecting an Area of your Image 
In the previous sections, you learned how to make overall changes 

to your images.  However, sometimes you will want to make 

specific changes to areas of your image without affecting the 

whole thing.  To do this, you need to learn how to select areas of 

an image. 

 

Selecting a Rectangular Area 

 Select the Rectangular Marquee Tool from the toolbox. 

 

 
 

 After you select the Rectangular Marquee Tool, your cursor 

will appear as a cross-hair symbol whenever you place it on 

your image. 

 With the cross-hair cursor click and drag around the area you 

wish to select. 

 You will see a rectangle of blinking dotted lines around the 

area that you selected. 

 

 
 

Rectangular Marquee Tool 
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 To add areas to your existing selection: 

o hold down the Shift key until a small plus sign appears 

under the cross-hair cursor. 

 

 
 

o While the Shift key is pressed, draw additional 

rectangles around the areas you want to select.   

 

 
 

o When you release the mouse button, Photoshop will 

add the new area to your existing selection 

 If you select an area that you do not wish to include in your 

final selection.:  

o Hold down the Alt key until a small minus sign appears 

beneath the cross-hair cursor. 
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o While the Alt key is pressed, draw a rectangle around 

the area you want to deselect. 

 

 
 

o When you release the mouse button, the area that was 

chosen for deselection will be removed from your final 

selection. 

 

 
 

Tip: If you accidentally click away from your selected area and 

lose your selection, you can use the History Palette to restore your 

selected area.  You can also use the History Palette to correct your 

selection mistakes.   
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Tip: Undoing selected areas 

 To remove your entire selection, from the Select menu choose 

Deselect.   

 

 
 

 To reverse only your latest addition or removal from your 

selection, use the History palette. 

 

 

Selecting a round area in your image 

 To select the Elliptical Marquee Tool: 

o At the top of the toolbox right-click in the Marquee 

Tool area. 

o From the menu that appears select the Elliptical 

Marquee Tool.  

  

 
 

 After you select the Elliptical Marquee Tool, your cursor will 

appear as a cross-hair symbol whenever you place it on your 

image. 
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 With the cross-hair cursor click and drag to draw a circle 

around the area you wish to select. 

 

 
 

 To add areas to your selection: 

o Hold down the Shift key until a small plus sign appears 

under the cross-hair cursor. 

o Draw additional circles around the areas you want to 

select. 

o When you release the mouse button, these areas will be 

added to your selection. 

 To remove an area from your selection: 

o Hold down the Alt key until a small minus sign appears 

under the cross-hair cursor. 

o Draw a circle around the area you want to deselect. 

o When you release the mouse button, the area will be 

removed from your selection. 

 

 

Using the Magic Wand tool  

While the Rectangular and Elliptical Marquee tools are helpful 

for selecting large sections of your image, the Magic Wand tool 

allows you to select areas of your image that are similarly colored. 

 

 Select the Magic Wand tool from the toolbox. 

 

 

Magic Wand Tool 
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 After you select the Magic Wand Tool, your cursor will 

appear as a magic wand symbol whenever you place it on your 

image. 

 With the magic wand cursor click on the colored area of your 

image that you wish to select. 

 The entire similarly colored area will be selected. 

 

 
Tip: Selecting all the areas of your image that are the same color 

Sometimes you may want to select more than one area of you 

image that is the same color.  In the previous example, you might 

want to change all the blue areas of the “TUFTS” letters to brown.  

Instead of individually adding each blue area to your selection, the 

Magic Wand Tool allows you to select all the blue areas at once.  

To select all of the areas of your image that have the same color: 

 On the magic wand options bar locate the Contiguous 

checkbox.  

 Click on the box to remove the checkmark.  Without a 

checkmark in this box, you’ll be able to select non-adjacent 

areas of the same color. 

 

 
 

 With the magic wand cursor click on the area of your image 

that is the color you want to select.   
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 Photoshop will select all the areas of your image that are the 

color which you chose. 

 

 
 

 

Tip: Adjusting the Tolerance of the Magic Wand Tool 

When using the Magic Wand Tool, you may need to change its 

Tolerance in order to adjust the precision of your selection.  The 

Tolerance affects Photoshop’s ability to distinguish between 

different colors.   

 

The value of Photoshop’s Tolerance ranges from 0 to 255.  If you 

choose a low value, the Magic Wand Tool will only select colors 

that are very similar to the pixel you click, but if you choose a high 

value, a broader range of colors will be included in your selection.   

 

For example, suppose your image contains black areas surrounded 

by dark gray.  If you choose a low tolerance, and click on a black 

pixel, only the black area of your image will be selected.  However, 

if you had chosen a high tolerance, both the black and dark gray 

areas would have been selected.  To change the Tolerance of the 

Magic Wand Tool: 

 

 On the magic wand options bar locate the Tolerance box. 

 In the Tolerance enter the value of that corresponds to how 

broad a range of colors you wish to select.  
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Filling the area you have selected 
Sometimes, you will select an area of an image because you want 

to change the color of that area.  Once you have selected an area, 

you can fill that selected area with a color of your choice.  

Whenever you fill a selection with a color, you are adding 

Foreground Color to your image. Therefore, you need to select 

the Foreground Color box before picking your filler color. 

 

Choosing a foreground color for filler 

 From the toolbox click on the Foreground Color box.  

 

 
 

 The Color Picker window will appear. 

 From the center of the Color Picker window locate the color 

slider, a vertical rainbow-colored strip. 

 Drag the horizontal arrows up and down the slider until you 

have chosen the color you like. 

 The hue of your new foreground color will appear at the top of 

the color selection rectangle to the right of the color slider.  

Your original foreground color appears at the bottom of the 

rectangle. 

 

 
 

 To adjust the lightness or darkness of your color, use the color 

field box on the right sideof the Color Picker window.   

 Your color adjustment will be applied to your new foreground 

at the top of the color selection rectangle. 

 To finalize your color choice click OK 

 

 

Foreground Color Box 

Background Color Box 
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Filling your selected area 

 Once you have selected the color you wish to use, select the 

Paint Bucket Tool from the toolbox.  It shares the same icon 

location as the Gradient Tool and uses the keyboard shortcut 

G.  You can alternate between the two by using Shift-G. 

 

 
 

 After you select the Paint Bucket Tool, your cursor will 

appear as a paint bucket symbol whenever you place it on your 

image. 

 To fill your selected area, position the paint bucket within the 

selected area of your image and click.   

 

 
 

 The contiguous portion of the selection you clicked within will 

be filled with your new foreground color. 

 

 
 

 To fill the entire selection, continue clicking in each contiguous 

area. 

Paint Bucket Tool 
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Saving your images for print and web media 
To place your image into a Word or PowerPoint document or to 

display the image on the web, you need to save it in a format other 

than Photoshop’s default format.   

 

The two most commonly used formats are GIFs and JPEGs. 

 

GIF:  

 Best format for saving images that contain large areas of single 

color, such as screenshots or simple paint images.   

 Ideal for logos, line art, and diagrams or images that need extra 

sharpness. 

 Removes unused colors from your image to reduce the size of 

your image files. 

 Permits only 256 colors. 

 Enables transparent backgrounds. 

 Does not work well for photographs. 

 

 

JPEG:  

 Best format for photographs or images with subtle color 

changes. 

 Offers compression to reduce the size of your image files. 

 Permits 16.7 million colors. 

 Does not work well for images that have large stretches of a 

single color. 
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Saving your image with Save for Web  

The best way to save optimized images is using the Save for Web 

window.  Your optimized image will usually look as sharp as the 

original image did, and its file size will be substantially smaller.  

To optimize your images: 

 

 From the File menu, choose Save for Web & Devices... 

 The Save for Web window will appear, offering you various 

ways to preview optimized versions of your image. 

o On the right side of the Save for Web window is the 

Optimize panel.  From this panel you can: 

 Select the format (GIF or JPEG) of the image 

you wish to save. 

 Select the optimized quality of the image you 

wish to save. 

o By clicking on the 4-Up tab at the top left corner of the 

Save for Web window, you will be able to compare 

various optimized versions of your image. 

 The pane at the top left always displays your 

original image.   

 Details about each image version, including file 

size and image quality, are located at the lower 

left of each version. 
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Saving your document as a JPEG 

When you are optimizing a photograph, you will probably want to 

save the image as a JPEG.  While the following process is meant to 

guide you through the steps of saving the image, the settings we 

use are only suggestions.  The settings you use will depend upon 

your image, the quality you desire, and the file size you wish to 

achieve.  To save your image as a JPEG: 

 

 From the File menu, choose Save for Web. 

 At the top left corner of the Save for Web window click on the 

4-Up tab. 

 Four versions of your image will appear in the Save for Web 

window.  

 Click on the image version in the upper right corner of the 

Save for Web window. 

 At the top of the Optimize panel locate the Preset area. 

 At the top right corner of the Preset area, confirm that JPEG 

appears in the Format menu.  If JPEG does not appear: 

o Click on the down-facing arrow next to the Format 

menu. 

o From the drop-down menu that appears select JPEG. 

o The different menus within the Preset area will change 

to those that correspond with the JPEG format. 

 

 

Format Menu 
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 Directly beneath the Format menu locate the Quality menu.  

 Click on the down-facing arrow next to the Quality menu. 

 From the drop-down menu that appears, select Medium. 

 

       
 

 

Tip: Choosing an exact value of image quality 

You can choose a precise quality for your image by using the 

Quality box located to the right of the Quality menu.  Photoshop 

allows you to choose a quality between 0 and 100, where 0 

represents the poorest degree of quality and 100 represnts the 

highest degree of quality.  To designate an exact quality for your 

image: 

 Click within the box labeled Quality. 

 Type a number between 0 and 100.   

 

Tip: Troubleshooting JPEG images with text 

When saving an image with text as a JPEG, you may notice some 

degradation around the lettering in your image.  To get rid of these 

artifacts and make your text clearer, either: 

 Increase the quality of your JPEG image, or 

 Save the image as a GIF. 

 

Saving your image as a GIF 

When you are optimizing a flat-color image, such as a logo, you 

will probably want to save the image as an optimized GIF.  While 

the process is meant to guide you through the steps of saving the 

image, the settings we use are only suggestions.  The settings you 

use will depend upon your image, the quality you desire, and the 

file size you wish to achieve.  To save your image as a GIF: 

 

 From the File menu, choose Save for Web. 

 Confirm that four versions of your image appear in the Save 

for Web window.   

 If four versions do not appear, click on the 4-Up tab at the top 

left corner of the Save for Web window. 

Quality Menu 
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 At the top right corner of the Preset area, confirm that GIF 

appears in the Format menu.  If GIF does not appear: 

o Click on the down-facing arrow next to the Format 

menu. 

o From the drop-down menu that appears select GIF. 

o The different menus within the Preset area will change 

to those that correspond with the GIF format. 

 Directly to the right of the Format menu locate the box labeled 

Lossy.   

 Click within the Lossy box and type 15. 

 

 
 

 

 

 

Tip: The Lossy box is similar to the Quality box for JPEG format.  

The Lossy box allows you to choose the amount of data that will be 

selectively discarded to reduce the size of your image’s file.  The 

higher the Lossy value, the more data that will be discarded. 

You can often apply a Lossy value of 5-10, and sometimes up to 

50, without degrading the image. By using the Lossy menu you can 

often reduce the file size of your image by 5%-40%.  

Format 
Menu 

Lossy 
Box 
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Comparing the optimized formats  

Before you choose which optimized image you want to use, you 

will want to compare the size and quality of the optimized GIF 

image with the optimized JPEG image.  By examining them at 

their default size and also at greater magnifications, you will be 

able to see how the different optimization options have affected all 

areas of the image.  Remember that text and large solid blocks of 

color are affected differently than photographic images by different 

optimized formats. 

 

 After comparing the two image versions at their current sizes, 

select the zoom tool from the Save for Web toolbox. 

 

 
 

 Click on any of the Save for Web image versions to 

simultaneously zoom in on all of them. 

 Using the Save for Web zoom tool just like the Zoom Tool in 

the main Photoshop environment: magnify each version of 

your image in order to examine the effect of your optimization 

choices on its color and sharpness. 

 

 

Tips: Examining different areas of your image versions 

After you have zoomed in on your image versions, you may want to 

examine portions of your image that may not at first appear in the 

image window.  To view a different area of your image: 

 Select the hand tool from the Save for Web toolbox. 

 

 

Save for Web Zoom Tool 

Save for Web Hand Tool 
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 Place your cursor over one of the image versions, then drag to 

display a section of the image that was previously hidden. 

 

         
 

 

Tip: Determining the best format for your image  

 Once you have carefully viewed your whole image, you may 

want to consider the following points to help you determine 

whether to save your image as a GIF or JPEG:  

 Which format produces a larger file size?  

 Which format has a better display quality? 

 Do I need my background to be transparent? 

 

 

 

Saving your image in the optimized format 

 After you have decided on a final format, click on the image 

version that you want to use for your final image. 

 A blue border will appear around the image version you 

selected. 

 At the top of the Optimize panel click Save. 

 The Save Optimized As window will appear. 

 Navigate to the folder in which you want to store your saved 

image.   

 Type the name of your image in the File name box. 

 Click Save. 
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Extracting an image from its background 
Sometimes a photograph captures more information than you want 

to use in your presentation materials.  You can use Photoshop to 

extract an image from its background.  To do this, we use the same 

selection tools we used earlier.  This time, however, we’ll cut the 

selected area from the image instead of filling it with color. 

 

Image modes and edits 

When you delete the background of your image, you want 

Photoshop to replace the background of your image with 

transparent pixels. Not all color modes allow you to have 

transparent areas in an image.  However, RGB mode allows for 

transparency.  Therefore, before you can edit the background of 

your duplicate image, you may need to make sure that its color 

mode is RGB.  To change the image mode to RGB: 

 

 From the Image menu, select Mode. 

 From the submenu that appears select RGB. 
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Unlocking an image 

When you borrow an image from the web, it may be locked to 

protect it from changes.  If your image is locked, a small padlock 

symbol will appear on the Background layer in the Layers 

Palette at the lower right corner of the Photoshop window.   

 

 
 

 Double-click on the padlock symbol to unlock the image. 

 

 
 

 In the New Layer box that appears, enter a name for your 

unlocked background layer in the box labeled Name. 

 Click OK to finish unlocking your image. 

 

 
 

 After you have done so, the layer will look like the one below. 

 

 

Padlock Symbol 
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Selecting the background area for deletion 

Now that you have a workable image, you can begin deleting the 

background.  To select the area you want to delete you can use any 

of the previously discussed selection methods.  Remember, if the 

area you want to select is similar in color, the Magic Wand Tool 

makes selection easier. 

 

 From the toolbox pick the selection tool you wish to use. 

 Use your selection skills to select the area you want to delete 

from your image. 

 From the Edit menu, select Cut. 

 The selected portion of your image will be replaced by gray 

and white-checkered background, which represents 

transparency. 

 

            
 

 Save your work by selecting Save from the File menu. 
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Saving an optimized version of an image with transparency  

The JPEG format does not support transparency.  Therefore, all 

images with transparent backgrounds must be saved as GIFs.  To 

save an optimized version of your transparent image: 

 

 From the File menu, select Save for Web. 

 The Save for Web window will appear. 

 In the Optimized panel select GIF from the Format menu. 

 Type your desired lossy value into the Lossy box. 

 From the Matte menu select None. 

 

 
 

 Within the Color Table click on the small, gray and white-

checkered color swatch. 

 A black border will appear around the color swatch once it is 

selected.   

 

 
 

 Choose an optimized version of your image. 

 At the top of the Optimized panel click Save. 

 The Save Optimized As window will appear. 

 Navigate to the folder in which you want to store your saved 

image.   

 Type the name of your image in the File name box. 

 Click Save. 


