
   

 

Dear Candidate, 

In preparation for the Visual Communication certification exam, we’ve put together a set of practice 

materials and example exam items for you to review. What you’ll find in this packet are: 

 Topic areas and objectives for the exam.  

 Practice materials with image assets. 

 Practice exam items. 

We’ve assembled excerpted material from the Visual Design Curriculum guide to highlight a few of the 
more challenging techniques covered on the exam.  You can work through these technical guides and 
with the provided image files (provided separately). Additionally, we’ve included the certification 
objectives so that you are aware of the elements that are covered on the exam. Finally, we’ve included 
practice exam items to give you a feel for some of the items.  

These materials are meant to help you familiarize yourself with the areas of the exam so are not 
comprehensive across all the objectives. 

Thank you, 

Adobe Education 
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Adobe Visual Communication using Photoshop CS4  
EXAM AND OBJECTIVES 

After taking the exam, your score is electronically reported.  Please allow 2-4 weeks from the date you pass the exam to 
receive your ACA Welcome Kit. 

Exam Structure 
 The following lists the topic areas and percentage of questions delivered in each topic area:  

Topic area % of exam # of items 

Setting project requirements  7%  3  

Identifying design elements when preparing images  18%  7  

Understanding Adobe Photoshop CS4 26%  10  

Manipulating images  44%  17  

Evaluating digital images  5%  2  

 
Number of Questions, Time and Passing Score  

• 39 questions  
• 50 minutes  
• 60% minimum required to pass 

 
Exam Objectives 
Domain 1.0 Setting Project Requirements 

1.1 Identify the purpose, audience, and audience needs for preparing image(s). 

1.2 Demonstrate knowledge of standard copyright rules for images and image use.  

1.3 Demonstrate knowledge of project management tasks and responsibilities. 

1.4 Communicate with others (such as peers and clients) about design plans. 

 

Domain 2.0 Identifying Design Elements When Preparing Images 

2.1 Demonstrate knowledge of image resolution, image size, and image file format for web, video, and print. 

2.2 Demonstrate knowledge of design principles, elements, and image composition. 

2.3 Demonstrate knowledge of typography. 

2.4 Demonstrate knowledge of color correction using Photoshop CS4. 

2.5 Demonstrate knowledge of image-generating devices, their resulting image types, and how to access resulting 
images in Photoshop. 

 

Domain 3.0 Understanding Adobe Photoshop CS4 

3.1 Identify elements of the Photoshop CS4 user interface and demonstrate knowledge of their functions. 

3.2 Demonstrate knowledge of layers and masks. 

3.3 Demonstrate knowledge of importing, exporting, organizing, and saving. 

3.4 Demonstrate knowledge of producing and reusing images.  

3.5 Demonstrate an understanding of and select the appropriate features and options required to implement a color 
management workflow. 
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Domain 4.0 Manipulating Images using Adobe Photoshop CS4 

4.1 Demonstrate knowledge of working with selections and measurement. 

4.2 Use Photoshop guides and rulers. 

4.3 Transform images. 

4.4 Adjust the tonal range and correct the color of an image. 

4.5  Demonstrate knowledge of retouching and blending images. 

4.6 Demonstrate knowledge of drawing and painting. 

4.7 Demonstrate knowledge of type. 

4.8 Demonstrate knowledge of filters. 

 

Domain 5.0 Publishing Digital Images using Adobe Photoshop CS4 

5.1 Demonstrate knowledge of preparing images for web, print, and video. 
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How to understand color management 
In working with images, you’ll likely move color images from device to device. For example, you might scan an 
image, view the image on your monitor at home, print the image on an inkjet printer to preview it, and then have it 
printed professionally by a print vendor. 

At each stage in this process, you can end up with color variations. The reason is this: These devices all have a 
limited color gamut. Color gamut refers to the range of colors a device displays. After all, no device can reproduce 
the full range of colors the human eye can see. 

For example, monitors use RGB color. This color is created through a mix of red, green, and blue light. Because it 
depends on light, RGB tends to be better at bright colors—like those in a neon sign—and less adept with dull 
colors—blacks and some pastels. CMYK, in contrast, is used by four-color printers, and is a mix of cyan, magenta, 
yellow, and black. Because it depends on light being reflected off a page, CMYK tends to be better at pastels and 
pure black. 

Colors might vary for one of the following reasons: 

• Differences in image sources—whether the image is from a camera or scanned in. 

• The way software applications define color. 

• Your choice of print media. For example, newsprint paper reproduces a smaller gamut than magazine-quality 
paper. 

• Natural variations between devices—monitors differ based on manufacturer and monitor age. 

Each device operates within a specific color space that can produce a certain range, or gamut, of colors. Because of 
these varying color spaces, colors can shift in appearance as you transfer documents between different devices. For 
example, a shade of blue with the values R 25, G 200, B 225 might appear slightly different when you scan an image 
with this color than when you view it on a monitor or print it. 

Monitor profiles describe how the monitor is currently reproducing color. You should create this profile first, 
because you need to view colors accurately on your monitor to make design decisions. If what you see on your 
monitor does not represent the actual colors in your document, you will not be able to maintain color consistency. 
For more information on creating monitor profiles, see Monitor Profiles in Photoshop Help. 

Input device profiles describe what colors an input device is capable of capturing or scanning. If your digital camera 
offers a choice of profiles, Adobe recommends selecting Adobe RGB. Otherwise, use sRGB (this is the default for 
most cameras). 

Output device profiles describe the color space of output devices such as a desktop printer or a printing press. If 
you’re printing to your desktop printer, you can set this through the Print dialog box. When you print, the color 
management system uses output device profiles to properly map the colors in a document to the colors within the 
gamut of an output device’s color space. Ideally, the output profile should also consider specific printing conditions, 
such as the type of paper and ink. For example, glossy paper can display a different range of colors than matte paper. 
Most newer inkjet printers include profiles to handle a range of such conditions, and you can often use these profiles 
to best effect. 

Managing color when you open files 
You can solve the problem of working with different color spaces by using a color management system, such as the 
one included with Adobe Photoshop CS4 Extended. This color management system handles a lot of these choices 
automatically, but it’s useful to understand color management so you can address problems as they crop up. 
Photoshop provides options for you to manage the way color profiles are interpreted when you open files. You set 
these options through the Color Settings dialog box, available through the Edit menu. 

The settings you choose in the Color Settings dialog box determine the way colors are applied for both RGB and 
CMYK. When you choose RGB or CMYK in the Images > Mode menu, the colors displayed in these modes are 
determined by the Color Settings dialog box. 
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Pretested sets of options in the Color Settings dialog box 

Although you can customize the options in the Color Settings dialog box, Adobe provides pretested sets of options 
you can use. These are available in the Settings menu at the top of the Color Settings dialog box. 

These settings have been tested by Adobe to work with most monitors (for screen output) and printers (for print 
output) in North America. 

Here are three sets of settings you will find useful: 

• North America General Purpose 2 works well if you are exporting to both web and print formats. For 
example, this setting group uses the sRGB IEC61966-2 setting for the RGB working space. This working space 
reflects the settings on most computer monitors, low-end printers, and scanners. 

• North America Prepress 2 works well if you are exporting to a printing press. For example, this setting group 
uses the Adobe RGB (1998) setting for the RGB working space. This working space reflects an RGB range that 
corresponds more closely to CMYK (which is what printing presses use). 

• North America Web/Internet works well if you are exporting to the Internet only. All images are converted to 
the sRGB IEC61966-2 working space. 

How Photoshop handles color spaces in opened files 

When you open a file, Photoshop compares the colors in the file’s color space with the colors defined in the Color 
Settings dialog box. By selecting the Ask When Opening option, you can have Photoshop ask you how to proceed 
when it encounters a different color space. If this option is not selected, Photoshop automatically converts these 
colors to the working space settings in the Color Settings dialog box. For example, if the image you’re opening has 
been created by using an sRGB IEC61966-2 B color space, and the Color Settings dialog box has Adobe RGB 
(1998) working space for RGB, Photoshop converts the sRGB colors to Adobe RGB. 

To use the Color Settings dialog box: 

1. Start Photoshop. 

2. Choose Edit > Color Settings. 

 The Color Settings dialog box appears (Figure 1). 

 In the Settings menu, you can choose from a series of 
preset settings. For most print purposes, you can choose 
North America General Purpose 2. 

 These settings have been tested by Adobe to work with 
most monitors (for screen output) and printers (for print 
output) in North America. 

3. Move the pointer over the menus in the Color Settings 
dialog box to view more information on these options. 
Information appears in the Description box at the bottom 
of the dialog box. 

4. Change the Settings to North America Prepress 2 and 
observe the results. Remember, North American 
Prepress 2 is best for exporting to a printing press, so 
Photoshop changes RGB to Adobe RGB (1998). With 
North American Prepress 2, Ask When Opening is 
selected to preserve the integrity of colors as you import 
them. 

 
Figure 1 Color Settings dialog box 
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Using soft proofing 
You can use soft proofing to proof on-screen. Soft proofing refers to changing on-screen colors to mimic the colors 
at actual printing. 

To use soft proofing: 

1. Start Photoshop and open an image. If possible, open an 
image with a wide color range, so as to best observe the 
effects of soft proofing. 

 First, you’re going to soft proof the image as it would 
appear with CMYK printing. 

2. Choose View > Proof Setup> Working CMYK. 

 As you do, look carefully at the image’s colors. You 
should notice a slight shift. 

 Note: The amount of color shift depends on the current 
settings in the Color Settings dialog box, the image’s 
colors, and other factors. 

 Now you’re going to soft proof an inkjet printer. 

3. Choose View > Proof Setup> Custom. 

 The Customize Proof Condition dialog box appears 
(Figure 2). 

4. Select the Preview option.  

 This lets you view changes on-screen as you make them. 

5. Select Kodak 5205/7205 Printing Density (By Adobe) 
from the Device To Simulate menu. 

 Photoshop soft proofs the image as it would appear 
when printed with Kodak 5205/7205 film. 

 Observe the results in the image. 

6. Click Cancel to close the Customize Proof Condition 
dialog box without keeping changes. 

 
Figure 2 Customize Proof Condition dialog box 
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Managing colors when printing 
You can also set options for color management when you print to your printer. In the Color Management area of the 
Print dialog box, you can configure whether colors are managed by Photoshop or your printer and specify 
preferences for how colors are handled. 

Most new inkjet photo printers come with fairly accurate profiles built into the driver. You may end up with the best 
results—and save time—by letting the printer select the profile. 

To view the Color Management area of the Print dialog box: 

1. Open an image in Photoshop. 

2. Choose File > Print. (You do not need to have a printer 
currently connected to your printer for this exercise.) 

 The Print dialog box appears (Figure 3). 

 The Color Management area should be active on the 
right side of the dialog box. 

3. If Color Management is not selected, select it from the 
pop-up menu. 

4. Move the pointer over the menus in the sections labeled 
Color Handling, Printer Profile, and Rendering Intent. 

 Information on the option selected in each menu appears 
in the lower-right section of the dialog box. For 
example, in the section Color Handling, you should see 
Printer Manages Colors selected in the menu. This 
option asks your printer to determine how colors are 
printed. 

5. When you’ve reviewed these options, click Cancel to 
close the Print dialog box. 

 
Figure 3 Print dialog box 

Rendering intent 
Rendering intent refers to the way colors are converted from one system to another. When you print, you’re 
converting from one colorspace (Photoshop) to another (your printer). Rendering intents set the rules that determine 
how colors are adjusted. The product of a rendering intent depends on the colors in your image and the current 
settings in the Color Settings dialog box. Some profiles produce identical results for different rendering intents. 

Photoshop sets a default rendering intent according to the profile you’ve selected in the Color Settings dialog box. 
For example, if you chose a color setting for North America or Europe, the default rendering intent is Relative 
Colorimetric. Generally, it’s a good idea to go with these defaults, especially if you’re still learning about color 
management. 
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How to use drawing tools 
Previous guides describe how to use Adobe Photoshop CS4 Extended to modify an existing image. In this guide, 
you create new content by using Photoshop’s brush tools. 

You can use the brush tools—the Pencil, Pen, and Pattern Stamp—to draw lines or paint areas. Photoshop gives you 
a remarkably wide set of options for brush tools. You can select from a number of brush tips and then modify these 
further by using the Brushes palette. You can even create your own brush settings and save these for later use. 

This guide is a basic introduction to drawing. After learning the basics, you should experiment with brushes to find 
the settings that work for you. 

This guide covers three tools: 

• The Pencil tool paints the current foreground color of an image and creates hard-edged lines. 

• The Brush tool paints the current foreground color on an image and creates soft strokes of color. 

• The Pattern Stamp tool paints whatever you have currently selected in the Pattern picker. 

Setting brush options 

With each brush, you set one or more of the following options in the options bar (Figure 1). 

 

  

 

 

Figure 1 Brush options bar 

Tool Preset Picker: Save settings for the current tool, such as Airbrush Soft Round 50% Flow. As you change 
settings for the Brush tools, you can save your settings for later use. 

Brush Preset Picker: Select from a series of preset brushes. There are a wide range of these preset brushes, and you 
can also create your own. 

Painting Mode: Describe how painted colors will blend with the underlying image. See the Photoshop Help topic 
“List of Blending Modes” for more detail. 

Set Opacity For Stroke: Set the transparency for painted lines, from 0% (invisible) to 100% (opaque). As you paint 
over an area, the color’s transparency remains the same until you release the mouse button, no matter how many 
times you move the pointer over the area. When you release the mouse button and then paint over the same area, you 
apply additional color at the same opacity. 

Set Flow Rate For Stroke: Set the rate at which color is applied as you paint. For example, if you set the opacity to 
100% and the flow to 33%, the color moves 33% toward 100% opacity each time you move over an area. Note: This 
setting is for the Brush only. 

Airbrush: Simulate painting with an airbrush. Paint builds up as you hold down the mouse button. Brush hardness, 
opacity, and flow options control how fast and how much the paint is applied. Click the button to turn this option on 
or off. Note: This setting is for the Brush only. 

Auto Erase: Paint the background color over areas that contain the foreground color. Note: This setting is for the 
Pencil only. 

Note: The options bar presents only a subset of brush options. Many other options—brush tips, settings, and so on—
are available through the Brushes palette. See Photoshop Help for more information on these options. 

Tool Preset picker 

Brush Preset picker 

Painting mode Airbrush 

Set opacity for stroke Set flow rate for stroke 
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To draw with the Pencil: 

1. Open Photoshop and create a new document. 

2. Select the Pencil tool. 

3. Choose a foreground color in the Tools palette. 

4. Choose a relatively small brush, such as 9 px, from the 
Brush Preset picker (Figure 2). 

 Note: You can also set the diameter and hardness 
manually in the Brush Preset picker. Hardness 
determines the softness of the line’s edges. 

5. In the options bar, leave Mode set to Normal. 

6. Make sure Opacity is set to 100%. 

7. Draw by using one of the following methods: 

• To draw freehand, drag in the image (Figure 3). 

• To draw a straight line, click a starting point in the 
image. While holding down the Shift key, click an 
ending point for the line (Figure 4). 

8. Change Opacity to 50% in the options bar and draw 
another line that overlaps the first line (Figure 5). 

 Observe that the line is half as dark as the first line and 
that the first line shows through wherever you 
overlapped it. 

 
Figure 2 Basic brush options in the Brush Preset 
picker 

 

 
Figure 3 Drawing freehand with the Pencil tool 

 

 
Figure 4 Drawing a straight line with the Pencil 
tool 

 

 
Figure 5 Second line with Opacity set to 50% 
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To draw with the Brush: 

1. Open a new document in Photoshop. 

2. Select the Brush tool. 

3. Choose a foreground color in the Tools palette. 

4. Choose a relatively small brush, such as 9 px, from the 
Brush Preset picker. 

 Note: You can also set the diameter and hardness 
manually in the Brush Preset picker. Hardness 
determines the softness of the line’s edges. 

5. In the options bar, leave Mode set to Normal. 

6. Set Opacity to 100%. 

7. Set Flow to 10%. 

 When you set Flow to 10%, the darkness of the line 
moves 10% closer to full opacity each time you overlap 
lines. 

8. Draw freehand by dragging in the image. Without lifting 
the pointer, drag back over the line you just painted 
(Figure 6). 

 When you are using the Brush, observe that the line’s 
edges are softer than they were with the Pencil. Also 
observe that the line’s color is lighter because you set 
Opacity to 10% and Flow to 100%. 

 At the point where the lines overlap, the line becomes 
darker because you set Flow to 10%. In that area, the 
traced-over line has an opacity of 20% 

 Note: As you did with the Pencil, you can draw a 
straight line with the Brush by holding down the Shift 
key. 

9. To draw a new line, release the mouse button and click 
on the image again. 

 
 

Figure 6 Drawing with Brush, Opacity 100%, 
Flow 10% 

 

This area is at 20% opacity. 
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Using specialty brush tips 

A large number of brush tips are included with Photoshop. These range from artistic brushes—wet or calligraphic 
brushes—to specialty brushes such as starbursts or snowflakes. You access these in the Brushes palette. The Brushes 
palette also lets you change settings for these brushes. 

To use brush tips: 

1. Choose Window > Brushes to open the Brushes palette. 

2. Click the Brushes pop-up palette menu (upper-right 
corner of the palette) and select Assorted Brushes 
(Figure 7). 

3. When you are asked if you want to replace the current 
brushes or append, click OK to replace them. 

 This loads the Assorted Brushes set into the Brushes 
palette. 

4. Click one of the specialty brush tips in the Brushes 
palette, such as Crosshatch 2 brush (#14) (Figure 8). 

5. Drag in the image to paint with the specialty brush 
(Figure 9). 

 
Figure 7 Brushes palette pop-up menu 

 

 
Figure 8 Selecting a specialty brush tip 

 

 
Figure 9 Painting with a specialty brush tip 
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Using the Pattern Stamp tool 

With the Pattern Stamp tool, you can paint patterns onto an image, choosing from a variety of patterns. 

To use the Pattern Stamp tool: 

1. Click the Clone Stamp tool and hold down the mouse 
button to open a menu with the Pattern Stamp tool 
(Figure 10). Select the Pattern Stamp tool. 

 Observe that the options bar is slightly different than it 
is for the Brush tool (Figure 11).  

 To the right of the Flow text box is the Pattern picker.  

2. Select a pattern from the Pattern picker. 

3. Select the Aligned option to keep the pattern aligned 
with your original starting point. 

 Otherwise, the pattern starts anew each time you lift the 
pointer. 

4. Leave the Impressionist option deselected. 

 With this option on, the pattern appears in blocks of 
color. 

5. Drag on the image to draw with the Pattern Stamp tool 
(Figure 12). 

 
Figure 10 Pattern Stamp tool 

 

 
Figure 11 Pattern Stamp tool options 

 

 
Figure 12 Painting with the Pattern Stamp tool 
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How to draw shapes 
In addition to its photo-editing features, Adobe Photoshop CS4 has a full suite of drawing tools. This guide teaches 
you how to draw shapes in Photoshop. If you’ve used other drawing tools, such as Adobe Illustrator, you will see 
that Photoshop’s approach to drawing is slightly different. Everything in Photoshop is based on the idea of film 
exposure, of letting light show through rather than placing things onto a canvas. 

Photoshop uses both bitmapped and vector images. Bitmapped images are made up of individual pixels and do not 
scale well; vector images are constructed from mathematical formulas and scale very well. 

Types of shapes 
This guide addresses adding shapes as shape layers, which gives you the most flexibility in determining how your 
shapes appear. However, adding shapes as separate layers adds to your image’s file size and may eventually affect 
Photoshop’s speed. Shape layers are added as vector masks—that is, they are vector shapes through which only part 
of the background shows. 

If you’re creating very simple shapes that do not need to be scaled, you can create bitmaps by using the Fill Pixels 
option. This option creates shapes that are rasterized or created from individual pixels. Because Fill Pixels shapes 
don’t require additional layers, they can improve performance. 

You set shape options in the Shape options bar (Figure 1). 

 

 

 
 

 

 

Figure 1 Shape options bar 

Drawing shape layers 
Shape layers are essentially vector masks that hide a background. They consist of two parts: a mask and a 
background color. 

Shape layers offer the most flexibility in determining a shape’s appearance, position, and visibility. Because the 
shape masks are vector shapes, you can transform these shapes without loss of clarity. 

To draw a shape in a shape layer: 

1. Start Photoshop and create a new file. 

2. Click one of the shape tools in the Tools palette, such as 
the Polygon tool. 

 Shape tools are located between the Path selection tool 
and the 3D Rotate tool. By default, the Tools palette 
shows the Rectangle tool. To access other shapes, click 
the Rectangle tool and hold down the mouse button 
(Figure 2). 

 

 
Figure 2 Shape tools in the Tools palette 
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3. In the options bar, make sure Shape Layers and Create 
New Shape Layer are selected (Figure 1). 

4. In the color picker, choose a color for the layer 
background. 

5. From the Shape Tool Options pop-up menu (Figure 1), 
select options for the shape you chose. 

 In Figure 3, the polygon is set to Star, leaving the 
Indent Sides By setting at its default of 50%. 

5. Draw the shape by dragging the pointer across the 
canvas (Figure 4). 

6. If the Layers palette is not already visible, choose 
Window > Layers. 

 Observe that the shape is on a separate layer with the 
default name of Shape 1 (Figure 5). The link icon 
between the shape and fill indicates the two are linked. 

7. Double-click the fill thumbnail. 

 The color picker appears (Figure 6). 

8. Pick a new color for the shape’s fill. 

9. Click OK to apply the color and close the color picker. 

 
Figure 3 Polygon options pop-up menu 

 

 
Figure 4 Shape appearance as you draw it 

 

 
 

Figure 5 Shape layer in Layers palette 

 

 
Figure 6 Color picker 

Fill thumbnail Mask thumbnail 
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Adjusting a shape’s path 

A path is the edge of a vector shape. By changing the path, you change the appearance of the vector mask and thus 
the appearance of the shape. One way to change the shape’s path is by moving one of its anchor points. Anchor 
points appear at the shape’s corners. 

To adjust a shape’s path: 

1. Click the Path Selection tool, hold down the mouse 
button, and select the Direct Selection tool (Figure 7). 

2. Click the edge of the shape to select its path. 

 Anchor points—small hollow squares—appear at the 
corners of the shape (Figure 7). 

3. Move the pointer over an anchor point. 

4. Click to select the anchor point. 

 Observe that the anchor point changes from a hollow 
square to a solid square when you select it. 

5. Drag to change the shape (Figure 8). 

 In Figure 8, the left corner of the square has been 
moved up by dragging its anchor point. 

 

 
 
 

Figure 7 Moving a point with the Direct Selection 
tool 

 

 
Figure 8 Path change completed 

Adding to and subtracting from shape areas 

You can add to or subtract from a shape layer to show more or less of the background. You set add and subtract 
options in the Shape options bar. 

 
 

 

 

Figure 9 Shape options bar 

Create New Shape Area: Create a new shape layer. 

Add To Shape Area: Add to the existing shape. 

Subtract From Shape Area: Subtract from the existing shape. You will only observe the effect of subtracting if you 
draw over an existing shape. 

Intersect Shape Areas: Show only those areas where the last two shapes drawn intersect. 

Exclude Intersecting Shape Areas: Show all parts of a shape except where the last two drawn shapes intersect. 
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area 
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To add to a shape layer: 

1. Click the shape thumbnail in the Layers palette to select 
the shape. 

2. Select a shape tool, such as the Ellipse tool. 

3. Click the Add To Shape Area icon in the Shape options 
bar (Figure 9). 

4. Draw a shape that adds to the image (Figure 10). 

 Observe that the new shape appears in the shape layer 
(Figure 10).  

Figure 10 Adding to a shape layer 

To subtract from a shape layer: 

1. Click the mask thumbnail in the Layers palette to select 
the shape. 

2. Select a shape tool, such as the Ellipse tool. 

3. Click the Subtract From Shape Area icon in the Shape 
options bar (Figure 9). 

4. Draw a shape that overlaps the image (Figure 11). 

 Observe that the shape has been modified in the shape 
layer (Figure 11). 

 
Figure 11 Subtracting from a shape layer 

Controlling shape appearance with layer styles 
Because shapes are on a layer, you can change their appearance by using layer styles. You can add a drop shadow to 
the shape, make the shape appear embossed or beveled, or outline the shape with a stroke. 

To modify a shape by using layer styles: 

1. If it is not already visible, choose Window > Layers to 
open the Layers palette. 

2. Double-click the shape’s layer to open the Layer Style 
dialog box (Figure 12). 

3. One of the simplest things you can do is apply a stroke 
or outline to the shape. Select the Stroke option to apply 
a stroke. Make sure the Preview option is selected so 
you can observe the effects of applying the stroke. 

4. Now, set options for the stroke by clicking the word 
itself. You can set the size, position, blend mode, 
opacity, fill type, and color of the stroke. 

 
 

Figure 12 Layer Style dialog box 
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5. Click OK to apply the stroke (Figure 13). 

6. Apply one or more additional layer styles to the shape. 

 Figure 14 shows the shape with the Bevel style, to give 
the shape a slightly raised appearance, and the Drop 
Shadow style, to make the shape appear slightly above 
the page. 

 Note: You can apply layer styles to rasterized shapes as 
well. However, the advantage of creating shapes on 
shape layers is that you can resize them without loss of 
resolution. 

 
Figure 13 Stroke applied 

 

 
Figure 14 Bevel and Drop Shadow applied 
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How to add text to images 
In Adobe Photoshop CS4 Extended, you add text directly to an image. As with shapes, you add text in its own layer, 
which is named after the first few words of your text. Once you add text, you can modify it by using the Character 
and Paragraph palettes, by transforming the text box, and by applying layer styles to the text’s layer. 

 

 

 

  

 

Figure 1 Text options bar 

Adding text to an image 

1. Start Photoshop and open an image. 

2. Select the Text tool. 

3. In the Text options bar, set a font family, font style, size, 
alignment, and color for the text (Figure 1). 

 Note: When you’re working with a font on-screen, you 
may observe that it seems smaller or larger than its point 
size. This is because the on-screen appearance of fonts 
depends on the document size and magnification. To see 
the font sized as it will appear when printed, choose 
View > Print Size. 

4. Select an anti-aliasing option from the Anti-aliasing 
pop-up menu. 

5. Drag on the image to draw a text box (Figure 2). When 
you are satisfied with the size of the box, release the 
mouse. 

6. Click in the text box you’ve created and type to add text 
(Figure 3). 

 
Figure 2 Drawing a text box 

 

 
Figure 3 Text box with text added 
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Modifying text by using the Character and Paragraph palettes 
You can change textual characteristics through the Character and Paragraph palettes. These options are similar to 
those found in many word-processing and layout applications. 

Modifying text by using the Character palette 

To set an option in the Character palette, you first open the palette and select the text you want to change. For each 
option in the palette, choose a value from the pop-up menu (Figure 4) or type a value. When you type a value 
directly, press Enter (Windows) or Return (Mac OS) to apply it. 

 

 

 

 

 

 

 

 

Figure 4 Character palette options 

The options in the Character palette include the following: 

Font size: Depends on document size. You set this in points. 

Leading: Space between lines. You set leading in points. 

Tracking: Space between characters. You set tracking in points. You can also fine-tune the space between any two 
characters by selecting them and adjusting kerning. Usually you only need to adjust kerning for large font sizes—at 
least 16 points. 

Horizontal scale: Height of the letters. You set this as a percentage. 

Vertical scale: Width of the letters. You set this as a percentage. 

Leading 
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Font color 
Vertical scale 

Font size 

Kerning Tracking 

All caps 

Small caps 

Anti-aliasing  
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Anti-aliasing 

Anti-aliasing produces smooth-edged type by partially filling the edge pixels so the edges of the type blend into the 
background. For print jobs, you will generally want to apply anti-aliasing to your text, especially for larger text. For 
smaller text or for web images, you may want to leave anti-aliasing turned off. 

Note: When you use anti-aliasing, type may be rendered inconsistently at small sizes and low resolutions (such as 
the resolution used for web graphics). To reduce this inconsistency, deselect the Fractional Width option in the 
Character palette menu. 

• None: Applies no anti-aliasing. 

• Sharp: Type appears at its sharpest. (This option is set by default.) 

• Crisp: Type appears somewhat sharp. 

• Strong: Type appears heavier. 

• Smooth: Type appears smoother. 

To modify text by using the Character palette: 

1. Choose Window > Character.. 

 The Character palette appears (Figure 5). 

2. Apply changes to the text. 

 In Figure 5, for example, the following changes have 
been applied: 

• Font size set to 24 pt. 

• Leading set to 30 pt. 

• Font color set to dark blue. 

• Horizontal scale set to 80%. 

 
Figure 5 Character palette 

Modifying text by using the Paragraph palette 

You can make further changes to the text in the Paragraph palette. Most importantly, you can change the text’s 
alignment—whether the text lines up with the right, left, or center of the text box. You can also justify the text. 
Justification means spacing the text so it meets both margins. 

To modify text by using the Paragraph palette: 

1. Choose Window > Paragraph. 

 The Paragraph palette appears (Figure 6). 

2. Apply changes to the text. 

 In Figure 6, for example, the text has been aligned with 
the right side of the text box. 

 
Figure 6 Paragraph palette 
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Transforming a text box 
As with most objects in Photoshop, you can transform text boxes. After you apply transformations, the text remains 
editable. 

To transform a text box: 

1. Choose Edit > Free Transform. 

2. Drag a transform control to change the shape of the text 
box. 

3. Move the pointer over a corner of the text box until the 
pointer changes into a rotation tool (Figure 7). 

4. Drag the rotation tool to rotate the text box (Figure 7). 

5. Choose the Text tool in the Tools palette. 

 A message appears asking if you want to apply the 
transformation. 

6. Select Yes. 

7. Click in the text box. 

 Observe that the text remains editable even while 
rotated. If you resize the text box vertically, the font size 
changes accordingly. 

 
 

Figure 7 Transforming a text box 

Warping text 
You can also curve, or warp, text by using the Create Warped Text option. 

1. Select the text you wish to warp. 

2. Click the Create Warped Text icon in the Text options 
bar. 

 The Warp Text dialog box appears (Figure 8). 

3. Select a style, such as Arch. 

4. Choose Horizontal or Vertical to determine a direction 
for the warp. 

5. Select a degree of bend for the warp. 

6. Leave Horizontal Distortion and Vertical Distortion at 0. 

 These settings let you create asymmetrical warps in 
either a horizontal or vertical direction. You can 
experiment with these settings later, but for now, keep 
the warp straightforward. 

7. Click OK to apply the warp (Figure 9). 

 
Figure 8 Warp Text dialog box 

 

 
Figure 9 Text with Arch warp applied 

Rotation pointer 
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Modifying text by using layer styles 
Because text is added to its own layer, you can also change the appearance of text by using layer styles. You can add 
a drop shadow to the text, make the text appear embossed or beveled, or outline each letter with a stroke. 

To modify text by using layer styles: 

1. If  the Layers palette is not already visible, choose 
Window > Layers. 

2. Double-click the text layer to open the Layer Style 
dialog box (Figure 10). 

 Layer styles appear in a column on the left. To apply a 
style, check its box. You can also modify a style by 
clicking its name. 

3. Apply one or more layer styles to the text.  

 Bevel style and Drop Shadow style have been applied to 
the text in Figure 11. 

 Bevel style gives the text a slightly raised appearance, 
and Drop Shadow style makes the text appear to float 
slightly above the page. 

 
 

 

Figure 10 Layer Style dialog box 

 

 
Figure 11 Layer effects applied to text 

 

 

Check a box to 
apply style 

Click a style’s name to 
modify options for it 



Adobe Photoshop CS4 Extended Project 1 guide 

© 2008 Adobe Systems Incorporated How to retouch photos 1 

How to retouch photos 
Other than correcting color, one of the most common tasks you will perform in Adobe Photoshop is retouching 
photos to correct imperfections, edit out undesired parts of the photo, and correct problems that result from the 
photo-taking process. This guide covers several ways to retouch photos, including use of the Clone Stamp tool, the 
Spot Healing Brush tool, and the Red Eye tool. 

Using the History palette 
Because retouching can require trial and error, you should know how to use the History palette to undo steps. 

Like most computer users, you’re probably aware of the Undo command available in many applications. This 
command lets you undo the effects of whatever command you’ve just applied. 

Photoshop takes the Undo command several steps further with the History palette. The History palette keeps track of 
the last 20 commands you’ve applied to an image, allowing you to revert to any one of these. When you execute a 
command, such as transforming an image or adding text, these are added to the History palette. The commands 
appear in the list in the order in which you performed them. Each command is listed with the name of the tool or 
command you used to change the image. 

You can also take a “snapshot” of a particular set of commands, allowing you to revert to this snapshot later. 

Note: Although the History palette is great, it does consume memory (RAM). Layers also consume memory, so if 
you’re working with a complex, multilayered image, you may want to reduce the number of History commands 
saved. You can do so by choosing Edit > Preferences > Performance. 

To use the History palette:  

1. Open an image in Photoshop. 

2. Execute several commands—such as selecting a part of 
the image, applying a filter, and adding a layer. 

 The point is to add some commands to the History 
palette (Figure 1). 

3. Click one of the earlier commands, such as Paste 
(Figure 2). 

 Observe that the image reverts to its appearance at the 
time this command was executed. Any commands 
executed afterward are temporarily discarded and appear 
dimmed. In Figure 2, for example, the Paint Bucket and 
Rectangular Marquee are dimmed and the effects no 
longer appear in the image. 

 At this point, the Paint Bucket and Rectangular Marquee 
commands are still available in the palette (if you select 
either). However, if you execute another command, the 
dimmed commands will be permanently discarded. 

4. To delete a command, select it and then click the Delete 
icon (Figure 1). 

 The image permanently reverts to the command prior to 
the deleted command. 

 
 

Figure 1 The History palette 
 

 
Figure 2 Earlier command selected 

Delete icon 
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Taking a snapshot 

You can use the Snapshot feature to capture the image as it appears at any point in the list of History commands. 
Once you’re satisfied with an image, it’s a good idea to take a snapshot. 

To take a snapshot: 

1. Click the History command you want to capture. 

2. Click the Snapshot icon. 

3. Scroll to the top of the History palette to view the 
snapshot (Figure 3). 

4. To revert to the snapshot, click it as you would any other 
History command.  

 You can compare different snapshots by clicking on 
them. 

 
Figure 3 Snapshots in the History palette 

Using the Clone Stamp tool 
You can use the Clone Stamp tool to remove minor blemishes from a photo. It is most effective with small, distinct 
features. 

To use the Clone Stamp tool: 

1. Identify the object you want to remove from an image. 

 For example, you can remove the marks from the flower 
pictured in Figure 4. 

 

 
 

Figure 4 Initial image to be retouched 

Area to be retouched 
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Area to be cloned Clone Stamp tool 

2. Use the Zoom tool to magnify the object (Figure 5). 

3. Identify an area of the background that will blend with 
the problem area.  

 For example, in Figure 5, you can remove the spot from 
the flower petal. The area to be cloned should be 
consistent; the Clone Stamp tool works best with 
patterned or single-color areas. 

4. Select the Clone Stamp tool in the toolbar. 

5. Hold down Alt (Windows) or Option (Mac OS) and 
click the area to be cloned (Figure 6). 

6. Release Alt (Windows) or Option (Mac OS) and move 
the Clone Stamp tool over the object you want to 
remove (Figure 7). 

 

 
Figure 5 Object magnified 

 

 
 

Figure 6 Clone area selected 

 

 
Figure 7 Cloning the area 
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7. Continue moving the Clone Stamp tool over the object 
until it disappears (Figure 8). 

8. When you finish with the Clone Stamp tool, you can 
switch to another tool by clicking the new tool in the 
toolbar. 

 

 
Figure 8 Cloning complete 
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Using the Spot Healing Brush tool 
The Spot Healing Brush tool makes touchups even easier for small areas. The Spot Healing Brush tool automatically 
samples pixels from the surrounding area and applies these to the selected area. The Spot Healing Brush tool makes 
changes quickly to a small area. You do not need to select a sample area. 

To use the Spot Healing Brush tool: 

1. Click the Spot Healing Brush tool in the toolbar.  

 The pointer changes to a brush. Usually the brush 
appears as a circle. 

2. You can change the size or shape of the brush in the 
Options bar (Figure 9).  

 The brush should be large enough to cover the entire 
spot, with some room around the edges. 

3. Position the Spot Healing Brush tool over the area you 
want to correct (Figure 10. 

4. Click to apply the correction (Figure 11). 

 

 
Figure 9 Brush options 

 

 
 

Figure 10 Spot Healing brush positioned over a 
blemish 

 

 
Figure 11 Spot Healing brush applied 

Spot Healing Brush tool 
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Using the Red Eye tool 
When you take photos with a flash, red eye can often result. You can quickly correct red eye with the Red Eye tool. 

To use the Red Eye tool: 

1. Click the Red Eye tool in the toolbar (Figure 12). 

 The pointer changes to a cross. 

2. Position the Red Eye tool over the pupil you want to 
correct. 

3. Click to apply the correction (Figure 13). 

 

 
Figure 12 Red Eye tool  

 

 
Figure 13 Red Eye tool applied 
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How to use filters 
Adobe Photoshop CS4 filters provide a range of options for changing your image’s appearance. You can use filters 
to clean up or retouch your images, apply special art effects that give your image the appearance of a sketch or 
pastel painting, and apply distortions and lighting effects. These filters can create added interest or help you achieve 
design goals. As with many Photoshop features, though, you should take care not to overuse filters, as too many 
filters can make an image look busy or unprofessional. 

Each filter has a range of settings. You can preview these before you apply them. Experiment with different settings 
to achieve your design goals. 

Filters have the following limitations: 

• Some filters work only on RGB images. 

• All filters work with 8-bit images. If you are using 16-bit or 32-bit images, please see Photoshop Help for 
information on which filters work with each. 

• When applying filters to shape layers, Photoshop first rasterizes the shape. Rasterizing refers to converting the 
shape from vector to bitmap format. 
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Creating a custom shape 
In the following steps, you create a shape and then apply filters to it to give it an artistic appearance. 

1. Start Photoshop and create a new document. 

2. Click and hold the Rectangle tool in the Tools palette to 
select the Custom Shape tool (Figure 1). 

3. In the option bar, make sure Shape Layers is selected 
(Figure 2). 

4. Select a shape from the Custom Shape Picker, such as 
the Thumbtack (Figure 3). 

5. Drag the pointer across the image to draw the custom 
shape, just as you would if you were drawing a 
rectangle. 

 To make the shape uniform in size, hold down the Shift 
key while dragging. 

 

 
Figure 1 Custom Shape tool 

 

 
 

Figure 2 Custom Shape tool options bar 

 

 
Figure 3 Custom Shape Picker 

Shape Layers Open Custom Shape Picker 
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Applying a filter 

1. Select the layer that contains the custom shape 
(Figure 4).  

 By default, it will be labeled “Shape 1.” 

2. Choose Filter > Sketch > Halftone Pattern. 

 Halftone Pattern is just one of many filters with which 
you can achieve an artistic effect. The effect of the 
Halftone Pattern is similar to that of certain Pop Art 
techniques. 

 Photoshop warns you it needs to rasterize the image 
before proceeding. This means the image will no longer 
be a vector mask. 

3. Click OK. 

 The Halftone Pattern dialog box appears (Figure 5). 

 Note: The Artistic, Brush Strokes, Distort, Sketch, 
Stylize, and Texture filters all open in the same dialog 
box. 

 You can preview the effects of different filters by 
selecting them in the middle column. 

4. In the right column, set Size to 2, Contrast to 20, and 
Pattern Type to Dot. 

5. Click OK. 

 The filter is applied to the custom shape (Figure 6). 

 

 
Figure 4 Layers panel 

 

 
Figure 5 Halftone Pattern dialog box 

 

 
Figure 6 Halftone filter applied 
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Applying another filter 

You can apply multiple filters to one image. 

In these steps, you’re applying filters to a custom shape. You can apply filters to almost any image, such as 
photographs or other artwork. 

1. Click the layer with the custom shape. 

2. Choose Filter > Artistic > Sponge. 

 As with the Halftone Pattern filter, a dialog box lets you 
preview and change settings for the Sponge filter 
(Figure 7). 

3. Set Brush Size to 2, Definition to 12 and Smoothness 
to 5. 

4. Click OK. 

 The Sponge filter is applied to the shape (Figure 8). 

 Observe how the Sponge filter modifies the effects of 
the Halftone Pattern filter. You can create a wide range 
of effects by combining filters. 

 

 
Figure 7 The Sponge dialog box 

 

 
Figure 8 Sponge filter applied 
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Using the Liquify filter 
The Liquify filter is another interesting filter you can apply to images. It causes the image to appear melted, along 
the lines of a Salvador Dali painting. 

Using the Liquify filter, you can push, pull, rotate, reflect, pucker, or bloat any area of an image. 

To use the Liquify filter: 

1. Open an image in Photoshop. 

2. Select the layer to which you wish to apply the Liquify 
filter. 

3. Choose Filter > Liquify. 

 The Liquify dialog box appears (Figure 9). 

4. In the right column, set a brush size to use. 

 The brush size needs to be big enough to modify your 
image. 

5. On the left, choose the Forward Warp tool. 

6. Drag the pointer through a part of the image 
(Figure 10). 

 Note: The Reconstruct tool, positioned beneath the 
Forward Warp tool, will undo the effects of a liquify 
tool. To revert, choose the Revert tool a nd then drag 
through the image. 

 Experiment with other liquify tools, such as the Pucker, 
Bloat, Twirl Clockwise, and Turbulence tools. 

7. When you are satisfied, click OK to apply your changes 
to the image. 

 
 

Figure 9 Liquify dialog box 

 

 
 

Figure 10 Forward warp tool applied 
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How to create layer comps 
Designers often create multiple compositions or “comps” of a design layout to show clients. You can create comps 
out of your image’s layers by using the Layer Comps palette. Using this palette, you can create, manage, and view 
multiple versions of a layout in a single Adobe Photoshop CS4 file. 

A layer comp is a snapshot of current layer visibility, position, and appearance. Layer comps capture the document 
as it currently appears. 

• Layer visibility refers to whether a layer is showing or hidden. 

• Layer position refers to the layer’s position in the Layer palette, above or below other layers. In your 
documents, content in upper layers appears over content in lower layers. 

• Layer appearance refers to whether a layer style is applied to the layer. It also refers to the layer’s blending 
mode. For more information on layer styles and blending modes, see Photoshop Help. 

When you create a layer comp, you can choose to capture one, two, or three of these attributes. 

Layer comps are best employed with images that have many layers. You will find it much easier to create layer 
comps if you are in the habit of giving layers meaningful names, such as “image_main” or “border” or “blue 
background.” When you give layers names, you can more easily identify them later. 

To create a layer comp: 

1. Open a file with multiple layers in Photoshop. 

2. Choose Window > Layer Comps to display the Layer 
Comps palette (Figure 1). 

3. Click the Create New Layer Comp button at the bottom 
of the Layer Comps palette. 

 This creates a new comp that shows layers as they 
currently appear. 

 The New Layer Comp dialog box appears (Figure 2). 

 

 
 

Figure 1 Layer Comps palette 

 

 
Figure 2 New Layer Comp dialog box 
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4 Type a name for the comp and add descriptive 
comments. 

5. Select Visibility, Position, and Appearance (Layer 
Style). 

 Selecting all three options ensures that the layer comp 
will appear exactly as you want it to appear. 

6. Click OK. 

 The current state of the layers has been saved as a layer 
comp. This means that the image’s current appearance 
has been saved as a layer comp (Figure 3). 

7. Using the Layers palette, make changes to the image: 
hide some layers and show others. Your goal is to make 
the image appear significantly different than it appears 
now so you can save a different layer comp. 

 Note: To show or hide a layer, click the Eye icon to the 
left of it (Figure 4). 

 For example, in Figure 4, the blue text layer has been 
deselected and the red text made visible. In the 
Hue/Saturation adjustment layer, the blue background 
has been deselected, and the red background layer made 
visible. 

 Next you’re going to create a new layer comp by saving 
the changes you just made in the Layers palette. 

 
Figure 3 Blue background version layer comp 

 

 
 

Figure 4 Layers palette with layers selected for 
red background highlighted 

 

Eye icon 
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8. Repeat steps 3–6 to save your changes as another layer 
comp. In Figure 5, the new layer comp is called “Brown 
background version.” 

9. In the Layer Comps palette, click the left column next to 
the layer comp you first created (Figure 6). 

 When you do so, the Apply Layer Comp icon appears 
next to the layer comp, indicating it is selected. 

 The image changes to the first layer comp (Figure 6). 

 Observe that layer visibility has now changed in the 
Layers palette. 

 
 

Figure 5 Brown background version layer comp 

 

 
 

Figure 6 Selecting a layer comp 

Updating layer comps 
After you’ve created them, you can also update layer comps. 

To update a layer comp: 

1. Select a layer comp in the Layer Comps palette. 

2. Open the Layers palette and make changes to layer 
visibility or position. 

 Once you make changes to the Layers palette, the Apply 
Layer Comp icon disappears from the selected layer 
(Figure 7). The layer comp has not yet been updated, 
and the document’s current layer visibility is different 
from that saved in the layer comp. 

 The layer comp remains selected, however, as indicated 
by gray highlighting. 

3. Click the Update Layer Comp button to save your 
changes. 

 
 

Figure 7 Layer Comps palette 
Update Layer Comp button 

Layer comps palette 

Apply Layer Comp icon 
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Exporting layer comps 
You need to export your layer comps in a form your clients can view. Although you could generate a different file 
for each layer comp, Photoshop also lets you create a PDF presentation with multiple layer comps. A PDF 
presentation opens by default as a slideshow. (It also functions as a regular PDF after you close the slideshow.) 

To export multiple layer comps as a PDF presentation: 

1. Choose File > Scripts > Layer Comps To PDF. 

 The Layer Comps To PDF dialog box appears 
(Figure 8). 

2. Click Browse to set a location on your system for the 
PDF. 

 The Select Destination dialog box appears (Figure 9). 

3. In the File Name text box, enter a name for the file. 

 It is a good idea to give this file a PDF extension, for 
example mycomps.pdf. 

4. Click Save. 

5. In the Layer Comps To PDF dialog box, deselect 
Selected Layer Comps Only.  

 This ensures that all of the layer comps in the Layer 
Comps palette will be included in the PDF. 

6. If desired, select options for the slideshow in the 
Slideshow Options area of the Layer Comps To PDF 
dialog box. 

 You can change how fast the slideshow advances and 
choose to loop the slideshow. 

7. Click Run. 

 Photoshop creates a PDF file according to your 
specifications in the location you indicated. A success 
message appears when the file creation is complete. 

8. In your system, open the folder containing the PDF. 

9. Double-click the PDF file to open it.  

 The PDF opens as a slideshow. 

 
Figure 8 Layer Comps To PDF dialog box  

 

 
Figure 9 Select Destination dialog box 
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How to use advanced color techniques 
In Adobe Photoshop CS4, you can adjust an image’s colors in a variety of ways. Using the techniques described in 
this guide, you can take the raw material of your image and transform it into an image with different or flattened 
colors, improved warmth, or various types of grayscale. You will need practice to get these techniques right, and 
you will have to try them to see how they can help you meet your design goals. 

This guide discusses the following techniques: 

• Changing the hue and saturation of an image 

• Inverting the colors in an image 

• Brightening selective colors in an image 

• Posterizing an image 

• Applying photo filters to an image 

• Using the Channel Mixer 

• Using the Replace Color function 

• Localized color corrections 

You will implement most of these changes in adjustment layers. The first section of this guide describes adjustment 
layers. 

Using adjustment layers 
As you apply color changes to an image, you will usually want to preserve your original image. One way is to save a 
copy of your original image (this is always a good idea). Photoshop CS4 also lets you make changes in special 
layers called adjustment layers. 

An adjustment layer applies changes to your image without changing the image’s pixels permanently. For example, 
instead of changing hue and saturation in your original image, you can create a Hue & Saturation adjustment layer. 
The adjustments are stored in the adjustment layer. 

These changes apply to all layers below the adjustment layer. Using the Layers panel, you can discard your changes 
and restore the original image at any time. 

You access adjustment layers through the Layer > New Adjustment Layer menu. To make most of the color 
modifications discussed in this guide, you can also use the individual adjustment features in the Adjustments panel 
(Figure 1). This new panel provides quick access to every tool you need to adjust the color and tone of images 
without losing any of the original image data. 
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Figure 1 Adjustments panel 

Changing hue and saturation 
Hue identifies easily named colors such as red, orange, and pink and simply refers to the color’s specific place on 
the color wheel. Saturation describes relative intensity or dullness of a color from the inside to the outside of the 
wheel (Figure 2). 

 
Figure 2 Color wheel 

For hue, values reflect the number of degrees of rotation around the wheel from the pixel’s original color. A positive 
value indicates clockwise rotation; a negative value, counterclockwise rotation. Values can range from -180 to +180. 
In other words, when you change hue positively, blues become more purple, yellows become more green, and so on. 
As you decrease hue, the opposite happens. 

Saturation changes as you move out from the center of the wheel. That is, yellows become more yellow, and oranges 
become more orange. Values can range from -100 to +100. 



Adobe Photoshop CS4 Extended Project 6 guide 

© 2008 Adobe Systems Incorporated How to use advanced color techniques 3 

To change hue and saturation in an adjustment layer: 

1. Start Photoshop and open an image. 

2. Choose Layer > New Adjustment Layer > 
Hue/Saturation. 

 The New Layer dialog box appears. By default, the layer 
is named “Hue/Saturation 1.” 

 Note: You can change this name if you wish, but this 
layer will change hue and saturation, so this name is 
meaningful and therefore useful. 

3. Click OK. 

 The New Layer dialog box closes. 

 The Adjustments panel appears, with Hue/Saturation 
options (Figure 3). 

 
Figure 3 Adjustments panel, Hue/Saturation 

 

4. Move the Hue slider about halfway to the right. 

 The colors of your image shift dramatically (Figure 4), 
with yellows becoming more green and oranges 
becoming more yellow (Figure 5). 

 
Figure 4 Image original 

 

 
Figure 5 Hue increased 
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Using the Invert command 
The Invert command reverses the colors in an image. When you invert an image, the brightness value of each pixel 
in the channels is converted to its opposite value on the color wheel. For example, shades of blue convert to shades 
of orange, and shades of purple convert to shades of green. 

To use the Invert command in an adjustment layer: 

1. Choose Layer > New Adjustment Layer > Invert. 

 The New Layer dialog box appears. 

2. Click OK. 

 Your image is inverted (Figure 6). 

 

 
 

Figure 6 Invert command applied 

Using selective colors 
With the Selective Color command, you can change the intensity of selected color groups—such as blues, reds, or 
magentas—along the CMYK scale. 

Yellow in original Black in original 
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To use the Selective Color options: 

1. Choose Layer > New Adjustment Layer > 
Selective Color. 

 The New Layer dialog box appears. 

2. Click OK. 

 The Adjustments panel appears, with Selective Color 
options (Figure 7). 

3. Choose a color family from the Colors pop-up menu, 
such as Magentas. 

4. Drag the cyan, magenta, yellow, and black sliders and 
observe the effect each has on the image. 

 Note: The effect on your image may be subtle, 
depending on your image’s colors. 

 For example, if you increase cyan with Magentas 
selected, the image’s reds become more purplish or 
bluish. If you select Blacks, the image’s reds take on 
more shadows. 

5. When you are satisfied with the image’s appearance, 
minimize the panel. 

  

 
Figure 7 Adjustments panel with Selective Color 
options 

Posterizing an image 
The Posterize command lets you specify the number of colors in each channel (either RGB or CMYK) in an image 
and then maps pixels to the closest matching level. The different colors—or values—in each channel are known as 
tonal levels. 

The Posterize command immediately reduces the total number of colors in the image. For example, if you choose 
two tonal levels in an RGB image, Photoshop limits the total number of colors to six: two each for red, green, and 
blue. When you enter 255 in the Posterize dialog box, the result is a “normal–looking” image because you get 255 
colors in each channel, the same as for RGB images. 

This command is useful for creating special effects such as large, flat areas in a photograph. 

Minimize 
panel 
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To apply the Posterize image command in an adjustment layer: 

1. Open an image in Photoshop CS4. 

2. Choose Layer > New Adjustment Layer > Posterize. 

 The New Layer dialog box appears. 

3. Click OK. 

 The Adjustments panel appears, with Posterize options 
(Figure 8). 

4. In the Levels text box, enter a number between 4 and 8, 
or use the slider to select the Posterize level. 

 The image’s colors flatten (Figure 9). 

 You can preview your changes in the image window. 

 The effects of the Posterize command are most dramatic 
with a low number. 

 

 
Figure 8 Posterize command 

 

 
Figure 9 Posterize command applied 
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Using photo filters 
The photo filters in Photoshop CS4 mimic the effects of a camera’s lens filters, as though you applied a very thin 
layer of colored cellophane over your image. You can give a black-and-white photo an antiqued look by using a 
sepia filter, or you can make your image’s colors seem warmer or cooler by using orange or blue filters. 

To use a photo filter in an adjustment layer: 

1. Open an image in Photoshop CS4. 

2. Choose Layer > New Adjustment Layer > Photo Filter. 

 The New Layer dialog box appears. 

3. Click OK. 

 The Adjustments panel appears, with Photo Filter 
options (Figure 10). 

4. Choose a filter from the pop-up menu.  

 In Figure 10, one of three warming filters is selected. 

 Each filter applies a color to the image. You can also 
choose a custom color by selecting the Color option and 
clicking the color box. 

 The Density slider changes how much color is applied to 
the image. For example, with the warming filter in 
Figure 10, the warm (orange) color tint intensifies when 
you increase Density. 

 The warming filter is applied. The light parts of the 
image appear slightly more orange, giving the photo a 
warmer look (Figure 11). 

 
Figure 10 Photo Filter dialog box 

 

 
Figure 11 Photo-warming filter applied 
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Using the Channel Mixer 
You can use the Channel Mixer command to increase or decrease the color values in the red, green, or blue 
channels. Each channel contains a set of colors; the three channels combine to create the millions of colors in an 
image. 

In practice, this filter is often used to modify black-and-white images. You can also choose from a set of Channel 
Mixer presets. With these presets, you can create black-and-white photos with a variety of shading. Because the 
channels have distinct color ranges, they appear dramatically different when converted to black-and-white. 

To use the Channel Mixer: 

1. Open an image in Photoshop CS4. 

2. Choose Layer > New Adjustment Layer > 
Channel Mixer. 

 The New Layer dialog box appears. 

3. Click OK. 

 The Adjustments panel appears, with Channel Mixer 
options (Figure 12). 

4. From the Preset menu, choose Black & White With Blue 
Filter. 

 Observe the results (Figure 13). 

5. From the Preset menu, choose Black & White With 
Green Filter. 

 Observe the results (Figure 14). 

 Although both photos are black-and-white, the two 
images have depths of gray in different areas. For 
example, in the Black & White With Blue Filter, the 
side of the car—yellow in the original—appears much 
darker than in the Black & White With Green Filter. 

 
Figure 12 Adjustments panel with Channel Mixer 

 

 
Figure 13 Black & White With Blue Filter applied 

 

 
Figure 14 Black & White With Green Filter 
applied 

Using the Replace Color function 
You can use the Replace Color function to change the hue and saturation of a limited set of colors in your picture. 
For example, you can change a purple sweater to red or a green flag to blue. 
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To change hue and saturation: 

1. Open an image in Photoshop CS4. 

2. Choose Image > Adjustments > Replace Color. 

 The Replace Color dialog box appears (Figure 15). 

3. Move the pointer over the image and click an area with a 
specific color. 

 In the preview area in the center of the Replace Color 
dialog box, all of the areas of your image with the 
selected color turn white. 

 The Fuzziness slider adjusts the degree to which colors 
close to the chosen color are also selected. 

4. Move the Fuzziness slider until you have selected the 
amount of the color you want to select. 

 For example, in Figure 15, the Fuzziness slider has been 
moved to the right until the car’s bodywork is almost the 
only thing selected. 

5. When you finish selecting the area you want, move the 
Hue slider to adjust the Result color (shown in the lower 
right corner). 

 For example, in Figure 16, the car’s bodywork has 
changed from yellow to red. 

6. You can also adjust the saturation and lightness of the 
selected color. 

 For example, in Figure 17, the car’s paint job has 
become a highly saturated bright red. 

 
 

Figure 15 Replace Color dialog box 

 

 
Figure 16 Hue of selected color changed 

 

 
Figure 17 Saturation of selected color changed 

Localized color corrections 
Sometimes all you need to do to achieve a desired effect is make a minor color adjustment to a small, localized area 
of your image. Use selection tools to define a precise area to adjust localized color. 

Parts of image with chosen 
color turn white here 

Color chosen here 
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To make localized color changes: 

1. Click the Magic Wand tool in the toolbar. 

 The pointer looks like a magic wand. 

2. Click the Add To Selection option in the options bar and 
set Tolerance to 20 (Figure 18). 

3. Move the Magic Wand over a small area of your image 
and click an area with a specific color. 

 In this case, the headlight and turning signal of the car 
are selected (Figure 19). 

 You may need to use the Magnify tool to view the areas 
to be selected. 

4. Choose Layer > New Adjustment Layer > 
Color Balance. Click OK in the New Layer dialog box. 

 The Adjustments panel appears, with Color Balance 
options (Figure 20). 

5. Select the Shadows, Midtones, or Highlights you want 
to adjust. 

6. Adjust the color balance sliders to achieve the localized 
color correction you want. 

 Notice in the example how the selected areas of the 
image appear more saturated and brighter than in the 
original (Figure 21). 

 

 
 

Figure 18 Magic Wand options bar 

 

 
Figure 19 Selected areas 

 

 
Figure 20 Adjustments panel with Color Balance 
options 

 

 
Figure 21 Selected areas of enhanced localized 
color 

 
 

Add To Selection 
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How to use the Vanishing Point filter 
In many of the images you work with, you’ll need to make edits that involve perspective—the way an object appears 
in relation to the viewer and the horizon. The Vanishing Point filter in Adobe Photoshop CS4 makes it easier to edit 
images that have perspective planes—rectangular surfaces that seem to get smaller as they approach the horizon. 
When you look up a hallway, for example, the walls appear to taper toward the horizon. In Figure 1, the train track 
rails seem to get closer together towards the horizon. 

 
Figure 1 Image with perspective plane 

When you use the Vanishing Point filter, you specify the planes in an image, and then apply edits such as painting, 
cloning, copying or pasting, and transforming. 

Your edits honor the perspective of the plane you’re working in—that is, they are oriented correctly. 

To use the Vanishing Point filter: 

1. Start Adobe Photoshop CS4 and open an image that 
contains a perspective plane. 

2. Display the Layers palette  

3. Click the Create A New Layer button to add a new layer 
(Figure 2). 

 When using the Vanishing Point filter, it is best to make 
your changes in a separate layer so you do not alter your 
original image. 

4. Make sure the new layer in the Layers palette is selected 
(Figure 2). 

 
 

Figure 2 Layers palette 
 

Create A New Layer button 
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5. Choose Filter > Vanishing Point. 

 The Vanishing Point dialog box appears (Figure 3). 

6. Your first step is to select a perspective plane to modify. 
Make sure the Create Plane tool is selected (Figure 4). 

7. Click the four points of a perspective plane. 

 In Figure 5, four points on the train track rails are 
selected. 

 

 
Figure 3 Vanishing Point dialog box 

 

 
 

Figure 4 Create Plane tool 

 

 
Figure 5 Creating a plane 

 

Create Plane tool 
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 When you click the fourth point in the plane, a grid 
forms between the four points (Figure 6). 

8. Select the Brush tool in the Vanishing Point dialog box 
(not in the Tools palette). 

 So you can see better, you can magnify the image by 
using the Zoom tool. 

 The brush tip (normally a circle) becomes an oval that 
continually re-aligns with the image plane as you move 
the brush around (Figure 7). 

9. Drag the pointer to paint in the image. 

 Following the lines of the plane is easier than it would 
be without the Vanishing Point filter. 

10. Select the Clone tool in the Vanishing Point dialog box. 

11. Hold down the Alt key (Windows) or Option key 
(Mac OS) and click within the perspective plane to 
select an area for cloning (Figure 8). 

12. Drag in the image to clone the area. 

 Observe that the shape of the clone area aligns with the 
plane. 

13. When you have completed your changes, click OK to 
close the Vanishing Filter dialog box and apply the 
changes to the image. 

 Because you began by adding a new layer, all changes 
appear in the new layer. 

 
 

Figure 6 Perspective plane grid created (tools 
magnified) 

 

 
Figure 7 Painting with the Vanishing Point brush 

 

 
 

Figure 8 Cloning with Vanishing Point  
 

Brush tool Zoom tool 

Area cloned Source area for cloning 

Grid 



Adobe Photoshop CS4 Extended Project 6 guide 

© 2008 Adobe Systems Incorporated How to blend, feather, and smooth 1 

How to blend, feather, and smooth 
Quite often, you need to select part of an image to modify it. When you select uniform geometric areas—squares, 
circles, ovals, rectangles—you don’t need to worry too much about getting the selection exactly right. 
Unfortunately, most of the selections you’ll make in Adobe Photoshop CS4 are likely to be irregular shapes, such as 
people, trees, or flags. For example, the selection of the ship in Figure 1 has plenty of irregular edges, most notably 
in the sails. 

 
Figure 1 Irregular selection 

Photoshop’s smoothing, feathering, and blending features help you manage such irregular selections. 

• Smoothing: Reduce the jagged edges that often result from making selections with one of the Lasso tools. 

• Feathering: Soften a selection’s edges by making a boundary area between the selection and the pixels behind 
it. Feathering is especially useful when you copy a selection to a new background. A selection’s jaggedness 
may be emphasized because of contrast between the selection and its new background. Feathering helps reduce 
this jaggedness. 

• Blending: The way colors appear when overlaid—when one layer overlays another, for example. You can fine-
tune the way a selection appears by adjusting how the selection blends with its background. Photoshop CS4 
provides a wide range of blending options. 
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Smoothing and feathering with the Refine Edge command 
You can use the Refine Edge command to change your selection and preview these changes over a dark or light 
background. This makes it easier to edit your selection before you copy and paste it elsewhere. 

1. Start Photoshop CS4 and open an image. 

2. Select the Lasso tool in the Tools palette (Figure 2). 

 Note: Some users find the Polygonal lasso tool easer to 
use because you can make a series of short segments 
instead of one continuous line. To access the Polygonal 
lasso tool, click the Lasso tool and hold down the mouse 
button (Figure 2). 

3. Using the Lasso tool, select part of the image. 

 Preferably, select some irregular shapes like the sails in 
Figure 1. 

4. Complete the selection by closing the selection loop, 
and release the mouse. 

 For more information on making selections, see 
Photoshop CS4 Help. 

5. Choose Select > Refine Edge. 

 The Refine Edge dialog box appears (Figure 3). 

 The selection appears on a white background by default. 
You can choose a different background option at the 
bottom of the Refine Edge dialog box. White or black 
will be most useful in adjusting smoothing and 
feathering. 

6. Under Smooth, drag the slider to the right. 

 Any jagged edges become smoother. 

7. When you are satisfied with the selection’s appearance, 
release the mouse button. 

8. Under Feather, drag the slider to the right. 

 The outline of the selection becomes blurred. This is the 
effect of the feathering. 

 It is best to limit feathering to 3–5 pixels. Increasing the 
feathering beyond 5 pixels can produce interesting 
effects, but unless these effects are part of your design 
goals, you will not want to apply them. 

9. When you are satisfied with the selection’s appearance, 
release the mouse button (Figure 4). 

10. Click OK to close the Refine Edge dialog box. 

 
Figure 2 Lasso tool 

 

 
Figure 3 Refine Edge dialog box 

 

 
Figure 4 Smoothing and feathering applied 
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 The image remains essentially the same, although the 
selection shape may change slightly (Figure 5). 

11. Open the Layers palette. 

12. Click the Create A New Layer button to add a new layer 
(Figure 6). 

13. With the object’s layer (the original layer) selected, 
choose Edit > Cut. 

14. Select the new layer and choose Edit > Paste to paste the 
selection into the new layer (Figure 6). 

15. Select the original layer (the background layer) and 
choose Select > All. 

16. Press Delete to remove the original background. 

17. With the background layer still selected, select the Paint 
Bucket tool in the Tools palette. 

18. Click in the image to add a new background color. 

 Observe that the background layer now displays a 
thumbnail of a solid color (Figure 6). 

 The selection now appears on a new background 
(Figure 7). 

 

 
Figure 5 Selection changes applied to image 

 

 
 

Figure 6 Layers palette 

 

 
Figure 7 Selection with a new background 

 

Create A New Layer button 
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Layer blending options 
Blending options let you determine how colors in the upper layer—known as the blend color—and the lower 
layer—known as the base color—blend with one another. 

Photoshop offers a wide range of blending modes. A few are defined here. For more information on blending modes, 
see the topic “List of Blending Modes” in Photoshop CS4 Help. Blends only apply where the two layers overlap. 

• Lighten: Photoshop CS4 looks at the colors in each layer and selects the lighter of the base or blend color as the 
result color. Pixels darker than the blend color are replaced, and pixels lighter than the blend color do not 
change. 

• Darken: Photoshop CS4 looks at the colors in each layer and selects the darker of the base or blend color as the 
result color. Pixels lighter than the blend color are replaced, and pixels darker than the blend color do not 
change. 

• Color Dodge: Photoshop CS4 compares the colors in each layer and brightens the base color to reflect the blend 
color by decreasing the contrast. 

• Hue: Photoshop CS4 creates a new color with the luminance and saturation of the base color and the hue of the 
blend color. 

Because you can preview these changes, the best way to decide which mode works for you is to experiment with 
different blends. 
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To apply blending options to a layer: 

1. Open an image with at least two layers. 

 You can best observe blending options if the bottom 
layer is a solid color and the top layer is smaller in area 
than the bottom layer, as in Figure 7. 

2. Click the top layer to select it. 

3. Choose Layer > Layer Style > Blending Options. 

 The Layer Style dialog box appears (Figure 8). 

4. Make sure the Preview option is selected, so you can 
observe your changes as you make them. 

5. Select Lighten from the Blend Mode pop-up menu. 

 Observe the results (Figure 9). 

 

 
 

Figure 8 Layer Style dialog box 

 

 
Figure 9 Lighten blend mode 

 

Blend Mode pop-up menu 
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6. Select Darken from the Blend Mode pop-up menu. 

 Observe the results (Figure 10). 

7. Select Color Dodge from the Blend Mode pop-up menu. 

 Observe the results (Figure 11). 

8. Select Hue from the Blend Mode pop-up menu. 

 Observe the results (Figure 12). 

 

 
Figure 10 Darken blend mode 

 

 
Figure 11 Color Dodge blend mode 

 

 
Figure 12 Hue blend mode 
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